Subject: [Deb-dev] Bug#543097: [Pkg-scicomp-devel] Bug#543097: dolfin: FTBFS: Please install SWIG version 1.3.36 or recompile UFC with present SWIG.

From: Johannes Ring <[email-masked]>
Date: Mon, 24 Aug 2009 14:12:57 +0200

Hi Lucas,

Thanks for the report. The problem is that both UFC and DOLFIN has to
be built with the same version of SWIG. In this case, UFC has been
built with SWIG 1.3.36 while DOLFIN was rebuilt with SWIG 1.3.39. The
proper fix in this situation would be to rebuild UFC with the current
SWIG and then rebuild DOLFIN.

Thanks,

Johannes

On Sat, Aug 22, 2009 at 6:41 PM, Lucas Nussbaum<[email-masked]> wrote:
> Package: dolfin
> Version: 0.9.2-1
> Severity: serious
> User: [email-masked]
> Usertags: qa-ftbfs-20090822 qa-ftbfs
> Justification: FTBFS on amd64
>
> Hi,
>
> During a rebuild of all packages in sid, your package failed to build on
> amd64.
>
> Relevant part:
>> make[1]: Entering directory `/build/user-dolfin_0.9.2-1-amd64-q0hiv1/dolfin-0.9.2'
>> make[1]: Nothing to be done for `update-config'.
>> make[1]: Leaving directory `/build/user-dolfin_0.9.2-1-amd64-q0hiv1/dolfin-0.9.2'
>> scons --directory="." CC="cc" CFLAGS="-g -O2 -g -Wall -O2" CXX="g++" CXXFLAGS="-g -O2 -g -Wall -O2"  prefix=/usr -j10 enableMpi=1 enableUmfpack=1 enableGts=1 enablePetsc=1 withPetscDir=/usr/lib/petsc enableTrilinos=0 enableSlepc=1 withSlepcDir=/usr/lib/slepc enableScotch=1 enableDocs=0 enableDemos=0 enableTests=0 enablePydolfin=1
>> scons: Reading SConscript files ...
>>
>> scons: warning: The BoolOption() function is deprecated; use the BoolVariable() function instead.
>> File "/build/user-dolfin_0.9.2-1-amd64-q0hiv1/dolfin-0.9.2/SConstruct", line 65, in <module>
>>
>> scons: warning: The PathOption() function is deprecated; use the PathVariable() function instead.
>> File "/build/user-dolfin_0.9.2-1-amd64-q0hiv1/dolfin-0.9.2/SConstruct", line 97, in <module>
>> SCons.Script:133: DeprecationWarning: Option 'enablePydolfin' is deprecated and will be removed in the future. Please use the option 'enablePython' instead to enable/disable compiling of Python wrappers.
>>
>> scons: warning: The Options class is deprecated; use the Variables class instead.
>> File "/build/user-dolfin_0.9.2-1-amd64-q0hiv1/dolfin-0.9.2/scons/simula-scons/simula_scons/__init__.py", line 252, in __init__
>> Using options from /build/user-dolfin_0.9.2-1-amd64-q0hiv1/dolfin-0.9.2/scons/options.cache
>> Checking for pkg-config... yes
>> Checking for numpy-1... no (pkg-config file not found)
>>  Trying to generate pkg-config file for numpy-1... done
>>  Found NumPy and generated pkg-config file in
>>  '/build/user-dolfin_0.9.2-1-amd64-q0hiv1/dolfin-0.9.2/scons/pkgconfig'
>> Checking for scotch... no (pkg-config file not found)
>>  Trying to generate pkg-config file for scotch... done
>>  Found SCOTCH and generated pkg-config file in
>>  '/build/user-dolfin_0.9.2-1-amd64-q0hiv1/dolfin-0.9.2/scons/pkgconfig'
>> Checking for parmetis... no (pkg-config file not found)
>>  Trying to generate pkg-config file for parmetis... failed
>> Checking for ufc-1... yes
>> Checking for umfpack... no (pkg-config file not found)
>>  Trying to generate pkg-config file for umfpack... done
>>  Found UMFPACK and generated pkg-config file in
>>  '/build/user-dolfin_0.9.2-1-amd64-q0hiv1/dolfin-0.9.2/scons/pkgconfig'
>> Checking for mtl4... no (pkg-config file not found)
>>  Trying to generate pkg-config file for mtl4... failed
>> Checking for petsc... no (pkg-config file not found)
>>  Trying to generate pkg-config file for petsc... done
>>  Found PETSc and generated pkg-config file in
>>  '/build/user-dolfin_0.9.2-1-amd64-q0hiv1/dolfin-0.9.2/scons/pkgconfig'
>> Checking for gts... yes
>> Checking for boost... no (pkg-config file not found)
>>  Trying to generate pkg-config file for boost... failed
>> Checking for cholmod... no (pkg-config file not found)
>>  Trying to generate pkg-config file for cholmod... done
>>  Found CHOLMOD and generated pkg-config file in
>>  '/build/user-dolfin_0.9.2-1-amd64-q0hiv1/dolfin-0.9.2/scons/pkgconfig'
>> Checking for python-2... no (pkg-config file not found)
>>  Trying to generate pkg-config file for python-2... done
>>  Found 'Python' and generated pkg-config file in
>>  /build/user-dolfin_0.9.2-1-amd64-q0hiv1/dolfin-0.9.2/scons/pkgconfig
>> Checking for slepc... no (pkg-config file not found)
>>  Trying to generate pkg-config file for slepc... done
>>  Found SLEPc and generated pkg-config file in
>>  '/build/user-dolfin_0.9.2-1-amd64-q0hiv1/dolfin-0.9.2/scons/pkgconfig'
>> Checking for libxml-2.0... yes
>> Resolving compiler... done
>> Warning: Unknown dependency package: boost
>> *** UFC compiled with different version of SWIG.
>> Please install SWIG version 1.3.36 or recompile UFC with present SWIG.
>> make: *** [debian/stamp-scons-build] Error 1
>
> The full build log is available from:
>   http://people.debian.org/~lucas/logs/2009/08/22/dolfin_0.9.2-1_lsid64.buildlog
>
> A list of current common problems and possible solutions is available at
> http://wiki.debian.org/qa.debian.org/FTBFS . You're welcome to contribute!
>
> About the archive rebuild: The rebuild was done on about 50 AMD64 nodes
> of the Grid'5000 platform, using a clean chroot.  Internet was not
> accessible from the build systems.
>
> --
> | Lucas Nussbaum
> | [email-masked]   http://www.lucas-nussbaum.net/ |
> | jabber: [email-masked]             GPG: 1024D/023B3F4F |
>
>
>
> _______________________________________________
> Pkg-scicomp-devel mailing list
> [email-masked]
> http://lists.alioth.debian.org/mailman/listinfo/pkg-scicomp-devel
>

---

From: Johannes Ring <[email-masked]>
Date: Wed, 4 Nov 2009 10:12:42 +0100

Hi,

UFC and DOLFIN are now built with the same version of SWIG and the bug
reported here is no longer an issue. Could you please close this bug?

Thanks,

Johannes