Subject: [Deb-dev] [HG DebianPackages] Added script to build FEniCS packages nightly.

From: [email-masked] (Debian packages)
Date: Wed, 4 Mar 2009 12:12:24 +0100 (CET)

One or more new changesets pushed to the primary DebianPackages repository.
A short summary of the last three changesets is included below.

changeset:   170:5f2dd22c8974d477d52073452ee3366cf3b3ee47
tag:         tip
user:        Johannes Ring <[email-masked]>
date:        Wed Mar 04 12:12:21 2009 +0100
files:       build_all_nightly.sh
description:
Added script to build FEniCS packages nightly.

changeset:   169:5f3edc56405606b50a80c88c5e8cb6c8d097ab25
user:        Johannes Ring <[email-masked]>
date:        Tue Mar 03 09:36:53 2009 +0100
files:       conf/ufc/hardy/debian/changelog conf/ufc/hardy/debian/ufc.preinst conf/ufc/intrepid/debian/changelog conf/ufc/intrepid/debian/ufc.preinst
description:
Bug fix for ufc package (added preinst script that removes old unused ufc files).

changeset:   168:0cff257bf1e6150358f0573d740196a243aa7571
user:        Johannes Ring <[email-masked]>
date:        Thu Feb 26 14:20:26 2009 +0100
files:       build_package.sh
description:
Minor updates in build script (remove svn-control-dir and allow to run in multiple threads).

----------------------------------------------------------------------
For more details, visit http://www.fenics.org/hg/dev/deb

---

From: "Johannes Ring" <[email-masked]>
Date: Wed, 4 Mar 2009 12:34:27 +0100 (CET)

Hi,

I have set up a cron job that builds FEniCS packages each night based on
the development repositories and uploads them to the Debian/Ubuntu
repository at packages.simula.no. This could be useful for developers to
help staying up to date with different packages. Instructions can be found
here:

http://fenics.org/wiki/Download#Nightly_packages

Currently the repository only contains packages for Hardy but packages for
Intrepid and sid will be available tomorrow.

Johannes

On Wed, March 4, 2009 12:12, Debian packages wrote:
> files:       conf/ufc/hardy/debian/changelog
> conf/ufc/hardy/debian/ufc.preinst conf/ufc/intrepid/debian/changelog
> conf/ufc/intrepid/debian/ufc.preinst
> description:
> _______________________________________________
> Deb-dev mailing list
> [email-masked]
> http://fenics.org/mailman/listinfo/deb-dev
>

---

From: Johan Hake <[email-masked]>
Date: Wed, 4 Mar 2009 12:43:30 +0100

> Intrepid and sid will be available tomorrow.

This is just beautiful!

Are the packages built for what ever results of the buildbots?

Johan

---

From: "Johannes Ring" <[email-masked]>
Date: Wed, 4 Mar 2009 12:50:15 +0100 (CET)

>> Intrepid and sid will be available tomorrow.

:-)

> Are the packages built for what ever results of the buildbots?

Yes, currently, but this might change as it is possible to contact the
buildbot and ask for the state of the last build. However, packages that
fails to build will not be uploaded with the current script.

Johannes