Subject: Re: [Deb-dev] [DOLFIN-dev] Status of Dolfin Packages for Debian ( ?smund ?deg?rd )

From: Anders Logg <[email-masked]>
Date: Tue, 30 Oct 2007 13:47:03 +0100

On Tue, Oct 30, 2007 at 12:30:15PM +0100, Lorenzo Isella wrote:
> Dear All,
> Unfortunately I cannot run the demo yet.
> When I try:
> python demo.py
> 
> this is what I get:
> 
> $ python demo.py
> Creating sub domain markers for boundary condition.
> Solving linear PDE.
> --- Instant: compiling ---
> Traceback (most recent call last):
>   File "demo.py", line 47, in ?
>     u = pde.solve()
>   File "/usr/lib/python2.4/site-packages/dolfin/assemble.py", line 129, in solve
>     A = assemble(self.a, self.mesh)
>   File "/usr/lib/python2.4/site-packages/dolfin/assemble.py", line 24,
> in assemble
>     (compiled_form, module, form_data) = jit(form)
>   File "/usr/lib/python2.4/site-packages/ffc/jit/jit.py", line 54, in jit
>     create_extension(wrap_headers=[filename], module=module_name,
> additional_declarations=ufc_include, include_dirs=path)
>   File "/usr/lib/python2.4/site-packages/instant.py", line 582, in
> create_extension
>     ext.create_extension(**args)
>   File "/usr/lib/python2.4/site-packages/instant.py", line 209, in
> create_extension
>     raise RuntimeError, "The extension module did not compile, check
> %s/compile.log" % self.module
> RuntimeError: The extension module did not compile, check
> ffc_form_0_module/compile.log
> 
> 
> and the ffc_form_0_module/compile.log reads as follows:
> 
> more ffc_form_0_module/compile.log
> ffc_form_0_module.i:25: Error: Unable to find
> '/home/aasmundo/deb/build/ufc-1.0/debian/ufc/usr/include/ufc.h'

Looks strange. /home/assmundo looks like the home directory of Åsmund
on his machine. It shouldn't be there. Are you sure you have the
latest version of the packages?

Can you check which output you get when running

  pkg-config --cflags ufc-1

/Anders

> running build_ext
> building '_ffc_form_0_module' extension
> creating build
> creating build/temp.linux-i686-2.4
> gcc -pthread -fno-strict-aliasing -DNDEBUG -g -O2 -Wall
> -Wstrict-prototypes -fPIC -I-I.
> -I/home/aasmundo/deb/build/ufc-1.0/debian
> /ufc/usr/include -I/usr/include/python2.4 -c
> ffc_form_0_module_wrap.cxx -o
> build/temp.linux-i686-2.4/ffc_form_0_module_wrap.o
> gcc: ffc_form_0_module_wrap.cxx: No such file or directory
> gcc: no input files
> error: command 'gcc' failed with exit status 1
> 
> 
> I just understand that something is missing, but I do not have a real
> understanding of what is going on. I think that, after the new
> releases, these are the last glitches to iron out.
> It is strange however that this cannot run on my Debian testing box.
> Any suggestions?
> Cheers
> 
> Lorenzo
> 
> 
> 
> 
> >
> >    1. Re: Status of Dolfin Packages for Debian ( ?smund ?deg?rd )
> >
> >
> > ----------------------------------------------------------------------
> >
> > Message: 1
> > Date: Fri, 26 Oct 2007 16:41:02 +0200
> > From: " ?smund ?deg?rd " <[email-masked]>
> > Subject: Re: [DOLFIN-dev] Status of Dolfin Packages for Debian
> > To: [email-masked]
> > Cc: "[email-masked]" <[email-masked]>
> > Message-ID:
> >         <[email-masked]>
> > Content-Type: text/plain; charset="iso-8859-1"
> >
> > The debian-packages for ffc, fiat and instant are now upgraded. I have
> > tested the 'demo.py' script from fenics.org, and it works on my
> > etch-installation.
> > I guess there are still issues, user-reports are welcome on the deb-dev
> > maillist!
> >
> > On 10/23/07, Anders Logg <[email-masked]> wrote:
> > >
> > > ok, FIAT 0.3.3 and FFC 0.4.3 have been released.
> > >
> > > This should pave the way for fixing the Debian packages.
> > >
> > > /Anders
> > >
> > >
> > > On Mon, Oct 22, 2007 at 09:57:00PM +0200, Anders Logg wrote:
> > > > For various reasons, fixing the bug in the Debian packages relied on
> > > > making a new release of FFC which in turn relies on a new release of
> > > > FIAT.
> > > >
> > > > We are mostly in place but need to run some more tests before releasing
> > > the
> > > > new versions.
> > > >
> > > > /Anders
> > > >
> > > >
> > > > On Mon, Oct 22, 2007 at 11:06:02AM +0200, ?smund ?deg?rd wrote:
> > > > > There are some incompatibilities between the versions of the different
> > > > > components of the dolfin project. Right now we are waiting for a new
> > > release of
> > > > > FFC, because the demo.py example works with the version in the
> > > mercurial
> > > > > repository, but not the released versions. Obviously some unittests
> > > are
> > > > > incomplete...
> > > > >
> > > > > Anders, is it possible to speed up things on the FFC side?
> > > > >
> > > > >
> > > > > On 10/22/07, Lorenzo Isella <[email-masked]> wrote:
> > > > >
> > > > >     Dear All,
> > > > >     I am back on this topic. This is by no means a "reproach" (I also
> > > > >     understood somebody on this list was becoming a father and
> > > obviously
> > > > >     an open source project cannot have a priority here).
> > > > >     As far as I can tell, nothing has changed in the repositories over
> > > the
> > > > >     past few weeks [at least according to my package manager].
> > > > >     I would like to try my hands at Dolfin via the python interface
> > > and
> > > > >     pre-built binaries, but I cannot right now.
> > > > >     BTW, if I now try running the tutorial
> > > > >     (http://www.fenics.org/wiki /Tutorial), I get this error (I do not
> > > know
> > > > >     if it is very illuminating):
> > > > >
> > > > >     ./dolfin.py
> > > > >     from: can't read /var/mail/dolfin
> > > > >     ./dolfin.py: line 4: syntax error near unexpected token `('
> > > > >     ./dolfin.py: line 4: `mesh = UnitSquare(32, 32)'
> > > > >
> > > > >
> > > > >
> > > > >     Are there any plans for this?
> > > > >     Kind Regards
> > > > >
> > > > >     Lorenzo
> > > > >     _______________________________________________
> > > > >     DOLFIN-dev mailing list
> > > > >     [email-masked]
> > > > >     http://www.fenics.org/mailman/listinfo/dolfin-dev
> > > > >
> > > > >
> > > > >
> > > > >
> > > >
> > > > > _______________________________________________
> > > > > DOLFIN-dev mailing list
> > > > > [email-masked]
> > > > > http://www.fenics.org/mailman/listinfo/dolfin-dev
> > > >
> > > > _______________________________________________
> > > > DOLFIN-dev mailing list
> > > > [email-masked]
> > > > http://www.fenics.org/mailman/listinfo/dolfin-dev
> > > _______________________________________________
> > > DOLFIN-dev mailing list
> > > [email-masked]
> > > http://www.fenics.org/mailman/listinfo/dolfin-dev
> > >
> >
> >
> >
> >
> > ------------------------------
> >
> > _______________________________________________
> > DOLFIN-dev mailing list
> > [email-masked]
> > http://www.fenics.org/mailman/listinfo/dolfin-dev
> >
> >
> > End of DOLFIN-dev Digest, Vol 17, Issue 21
> > ******************************************
> >
> _______________________________________________
> DOLFIN-dev mailing list
> [email-masked]
> http://www.fenics.org/mailman/listinfo/dolfin-dev

---

From: "Åsmund Ødegård" <[email-masked]>
Date: Mon, 5 Nov 2007 18:24:43 +0100

[moved to deb-dev]

On 11/5/07, Lorenzo Isella <[email-masked]> wrote:
>
> Hello Asmund,
> Sorry for the late reply but I have been ill lately.
> I tried the following:
>
> n$ sudo apt-get --purge remove ufc
> [snip]
> Many thanks, I think this is finally fixed.
>
>
Good!

-- 
[simula.research laboratory]
                 Åsmund Ødegård
                 IT-Manager
                 phone: +4790069915
                 http://www.simula.no/