Subject: [Deb-dev] [Fwd: [FEniCS-dev] Problem with the Poisson solver demo]

From: Benjamin Le Reverend <[email-masked]>
Date: Thu, 11 Oct 2007 13:38:00 +0100

Subject: [FEniCS-dev] Problem with the Poisson solver demo
From: Benjamin Le Révérend <[email-masked]>
To: "[email-masked]" <[email-masked]>
Date: Thu, 11 Oct 2007 11:51:12 +0100
List-Id: <fenics-dev.fenics.org>

Hi,

I want to use Fenics to solve PDEs for Food Engineering (crystallization
of fats in foods ...)

I installed the Debian/Ubuntu packages on my Ubuntu box (Feisty) and I
can't run the example from the tutorial. Could someone help ???

This is what I get from the terminal window :

ben@vaiosz4:~/Desktop$ python dolfin_demo.py
Creating sub domain markers for boundary condition.
Solving linear PDE.
['ffc_form_0_module.i', '../ffc_form_0.h']
['ffc_form_0_module.i', '../ffc_form_0.h']
ffc_form_0_module.i:25: Error: Unable to find
'/home/aasmundo/deb/build/ufc-1.0/debian/ufc/usr/include/ufc.h'
running build_ext
building '_ffc_form_0_module' extension
creating build
creating build/temp.linux-i686-2.5
gcc -pthread -fno-strict-aliasing -DNDEBUG -g -O2 -Wall
-Wstrict-prototypes -fPIC -I-I. -I/usr/include/python2.5 -c
ffc_form_0_module_wrap.cxx -o
build/temp.linux-i686-2.5/ffc_form_0_module_wrap.o
gcc: ffc_form_0_module_wrap.cxx: No such file or directory
gcc: no input files
error: command 'gcc' failed with exit status 1
ffc_form_0_module.i:25: Error: Unable to find
'/home/aasmundo/deb/build/ufc-1.0/debian/ufc/usr/include/ufc.h'
running install
running build
running build_ext
building '_ffc_form_0_module' extension
gcc -pthread -fno-strict-aliasing -DNDEBUG -g -O2 -Wall
-Wstrict-prototypes -fPIC -I-I. -I/usr/include/python2.5 -c
ffc_form_0_module_wrap.cxx -o
build/temp.linux-i686-2.5/ffc_form_0_module_wrap.o
gcc: ffc_form_0_module_wrap.cxx: No such file or directory
gcc: no input files
error: command 'gcc' failed with exit status 1
Traceback (most recent call last):
  File "/home/ben/Desktop/dolfin_demo.py", line 47, in <module>
    u = pde.solve()
  File "/usr/lib/python2.5/site-packages/dolfin/assemble.py", line 107,
in solve
    A = assemble(self.a, self.mesh)
  File "/usr/lib/python2.5/site-packages/dolfin/assemble.py", line 24,
in assemble
    (compiled_form, module, form_data) = jit(form)
  File "/usr/lib/python2.5/site-packages/ffc/jit/jit.py", line 68, in jit
    exec("compiled_form = compiled_module.%s()" % form_name)
  File "<string>", line 1, in <module>
AttributeError: 'module' object has no attribute 'ffc_form_0BilinearForm'

If someone has an idea why it needs a file from /home/aasmundo/... it
would be great

Ben

_______________________________________________
FEniCS-dev mailing list
[email-masked]
http://www.fenics.org/mailman/listinfo/fenics-dev

---

From: Anders Logg <[email-masked]>
Date: Thu, 11 Oct 2007 15:54:59 +0200

This looks like an obvious bug in the Debian package.

Åsmund who is the package maintainer just had a baby so I expect he 
won't be able to look at it the next couple of weeks.

I'm on parental myself until the end of November so I don't have time to 
fix it.

But hang in there and it will be fixed...

/Anders

Benjamin Le Reverend wrote:
> 
> 
> ------------------------------------------------------------------------
> 
> Subject:
> [FEniCS-dev] Problem with the Poisson solver demo
> From:
> To:
> "[email-masked]" <[email-masked]>
> 
> To:
> "[email-masked]" <[email-masked]>
> 
> 
> Hi,
> 
> ------------------------------------------------------------------------
> 
> Deb-dev mailing list
> [email-masked]
> http://fenics.org/mailman/listinfo/deb-dev

---

From: LUK ShunTim <[email-masked]>
Date: Thu, 11 Oct 2007 22:41:57 +0800

Hello Ben,

It has something to do with the debian packaging. Edit 
/usr/lib/pkgconfig/ufc-1.pc and change the line starting with "Cflags:" to

Cflags: -I/usr/include

and you can move forward. However, I still got other errors.

See this thread in the ml archive:
http://fenics.org/pipermail/deb-dev/2007-October/000040.html

The c++ version works well. If you need pydolfin in a hurry, try 
compiling from the hg repository.

Hope you have better luck,
ST
--

---

From: Benjamin Le Révérend <[email-masked]>
Date: Thu, 11 Oct 2007 16:36:29 +0100

> Hope you have better luck,
Thanks very much for that, I fixed the CFlags but there are still other 
errors, as predicted by ST. Has anyone ever managed to run this case out 
of an Ubuntu system ???

Ben

---

From: "Åsmund Ødegård" <[email-masked]>
Date: Fri, 12 Oct 2007 10:47:51 +0200

> errors, as predicted by ST. Has anyone ever managed to run this case out

Unfortunately no. There are some incompatibilities between the versions of
dolfin, ffc and instant used. I am tryung to sort it out, but as Anders told
you I just had a baby....

I'm probably back on track next week.

-- 
[simula.research laboratory]
                 Åsmund Ødegård
                 IT-Manager
                 phone: +4790069915
                 http://www.simula.no/

---

From: Benjamin Le Reverend <[email-masked]>
Date: Fri, 12 Oct 2007 10:57:54 +0100

Åsmund Ødegård wrote:
>
>
> On 10/11/07, *Benjamin Le Révérend* <[email-masked] 
> <mailto:[email-masked]>> wrote:
>
>     LUK ShunTim wrote:
>     >> From:
>     >> Benjamin Le Révérend <[email-masked] <mailto:[email-masked]>>
>     >> Date:
>     >> " [email-masked] <mailto:[email-masked]>"
>     <[email-masked] <mailto:[email-masked]>>
>     >>
>     >> To:
>     >> "[email-masked] <mailto:[email-masked]>" <
>     [email-masked] <mailto:[email-masked]>>
>     >>
>     >>
>     >> Hi,
>     >>
>     >> [email-masked] <mailto:[email-masked]>
>     >> [email-masked] <mailto:[email-masked]>
> Unfortunately no. There are some incompatibilities between the 
> versions of dolfin, ffc and instant used. I am tryung to sort it out, 
> but as Anders told you I just had a baby....
>
Ok brilliant, I will wait next week then, thanks very much and 
congratulations ...

Ben