Subject: Re: [Deb-dev] [FEniCS-dev] Segfault while executing FeniCS programm

From: "Johannes Ring" <[email-masked]>
Date: Fri, 1 Aug 2008 12:10:12 +0200 (CEST)

Hi Jiping,

I think this segfault problem must have been introduced when I added
Trilinos as a dependency to the DOLFIN Ubuntu packages. This seems to only
affect the 64 bit packages. I will try to work out a solution, but I wont
be able to do it until next week. If you need to work with DOLFIN before
that, I suggest you build DOLFIN from source.

Sorry for your troubles,
Johannes

On Thu, July 31, 2008 17:33, Jiping Xin wrote:
> Hi there,
>
> I'm writing you to ask you if you could help me with a problem:
>
> I'm Using Ubuntu 8.04 x86_64 with kernel 2.6.24-19-generic and installed
> FEniCS on my computer.
> But when I want to start the demo.py, I'm getting pretty soon a fatal MPI
> error.
>
> I already googled this issue, but the only "solution" I found there:
> http://www.mail-archive.com/[email-masked]/msg02795.html
>
> But this solution (to follow the installation instruction on the FEniCS
> homepage) was exactly what I've done to install FEniCS.
>
> I hope you can give me some more information or support to solve this
> issue.
>
> If you need any additional informations, don't hesitate to ask for it.
>
> Here is the output of the demo.py (which I attach to this mail):
>
> ==========================
> jiping@iwr22:~/Documents/FEniCS$ python demo.py
> [iwr22:06710] mca: base: component_find: unable to open osc pt2pt: file
> not found (ignored)
> libibverbs: Fatal: couldn't read uverbs ABI version.
> --------------------------------------------------------------------------
> [0,0,0]: OpenIB on host iwr22 was unable to find any HCAs.
> Another transport will be used instead, although this may result in
> lower performance.
> --------------------------------------------------------------------------
> Solving linear PDE.
>   Assembling matrix over cells (finished).
>   Assembling vector over cells (finished).
>   Assembling vector over exterior facets (finished).
>   Computing Dirichlet boundary values, topological search (finished).
>   Applying boundary conditions to linear system.
>   Solving linear system of size 1089 x 1089 (PETSc LU solver, umfpack).
> Saved function u (discrete function) to file poisson.pvd in VTK format.
> *** An error occurred in MPI_Attr_get
> *** after MPI was finalized
> *** MPI_ERRORS_ARE_FATAL (goodbye)
> [iwr22:6710] Abort before MPI_INIT completed successfully; not able to
> guarantee that all other processes were killed!
> *** An error occurred in MPI_Comm_rank
> *** after MPI was finalized
> *** MPI_ERRORS_ARE_FATAL (goodbye)
> *** An error occurred in MPI_Type_free
> *** after MPI was finalized
> *** MPI_ERRORS_ARE_FATAL (goodbye)
> Segmentation fault
> ==========================
>
>
> Here is, what /var/log/messages tells me:
> ==========================
> Jul 31 17:15:55 iwr22 kernel: [  454.120388] python[6710]: segfault at 58
> rip 7f020373c666 rsp 7fff0dfae960 error 4
> ==========================
>
> I hope you can help me and thank you in advance,
> Jiping Xin
>
>
> --
> Jiping Xin
> Engineering Mathematics, Mathematics School of Chalmers University of
> Technology
> Brahegatan 9, 1207 Room,
> Gothenburg_______________________________________________
> FEniCS-dev mailing list
> [email-masked]
> http://www.fenics.org/mailman/listinfo/fenics-dev
>

---

From: "Garth N. Wells" <[email-masked]>
Date: Fri, 01 Aug 2008 11:17:45 +0100

Johannes Ring wrote:
> Trilinos as a dependency to the DOLFIN Ubuntu packages. 

Why do we have Trilinos as a dependency for the package? I don't see 
what this adds for the user at this stage.

Garth

This seems to only
> _______________________________________________
> Deb-dev mailing list
> [email-masked]
> http://fenics.org/mailman/listinfo/deb-dev

---

From: "Johannes Ring" <[email-masked]>
Date: Fri, 1 Aug 2008 12:20:49 +0200 (CEST)

> what this adds for the user at this stage.

Well, if it doesn't add anything to the user, I can simply remove it.

Johannes

---

From: Kent-Andre Mardal <[email-masked]>
Date: Fri, 01 Aug 2008 13:09:20 +0200

> Well, if it doesn't add anything to the user, I can simply remove it.

Agree that dolfin should not depend on trilinos. Does the dolfin package
depend on PETSc ? 

More general, should the dolfin package be minimalistic or
maximalistic ? 

Kent

---

From: "Johannes Ring" <[email-masked]>
Date: Fri, 1 Aug 2008 13:28:54 +0200 (CEST)

> Agree that dolfin should not depend on trilinos. Does the dolfin package

Yes, it depends on PETSc.

> More general, should the dolfin package be minimalistic or

I thought maximalistic, but I guess this is up to others to decide.

Johannes

---

From: "Garth N. Wells" <[email-masked]>
Date: Fri, 01 Aug 2008 12:53:34 +0100

> I thought maximalistic, but I guess this is up to others to decide.

I would say maximalistic in terms of available Ubuntu packages (e.g. 
OpenMPI, PETSc, umfpack, etc), and minimalistic in terms of home-made 
packages (e.g. Trilinos).

On this note, SCOTCH is package under Ubuntu 8.10.

Garth

---

From: Anders Logg <[email-masked]>
Date: Fri, 1 Aug 2008 14:02:02 +0200

> On this note, SCOTCH is package under Ubuntu 8.10.

I don't think it's a problem to depend on Trilinos and other
"home-made" packages now that they are available from the same
repository as the FEniCS packages.

The packages are in the same repository and built by the same person
so the Trilinos package can be trusted just as much as for example
the FFC package.

-- 
Anders

---

From: "Garth N. Wells" <[email-masked]>
Date: Fri, 01 Aug 2008 13:12:08 +0100

> so the Trilinos package can be trusted just as much as for example

Home-made packages increase the testing burden, while in the case of 
Trilinos not substantially affecting functionality. If at some point 
Trilinos provides substantial functionality, e.g. when parallel assembly 
and solve is supported, then it could/should be a dependency.

Also, if an aim is to eventually have fenics accepted as Debian/Ubuntu 
package isn't easier if as few new packages as possible are required?

Garth

---

From: Anders Logg <[email-masked]>
Date: Fri, 1 Aug 2008 14:22:03 +0200

> package isn't easier if as few new packages as possible are required?

Good point.

If there is need for it, we could add a second package dolfin-trilinos
which does depend on Trilinos, but I suspect most people who want to
use Trilinos will build DOLFIN from source?

-- 
Anders

---

From: "Johannes Ring" <[email-masked]>
Date: Fri, 1 Aug 2008 14:26:40 +0200 (CEST)

> package isn't easier if as few new packages as possible are required?

There are some work going on to get Trilinos into Debian. Actually, my
Trilinos packages are based on some packages that were in unstable not
long ago, but they are currently removed.

Johannes

---

From: Kent-Andre Mardal <[email-masked]>
Date: Fri, 01 Aug 2008 15:00:54 +0200

> and solve is supported, then it could/should be a dependency.

The Trilinos package adds a linear algebra library that is nice to play
with in Python. This might however not be evident from the examples and
demoes that have been added to dolfin so far. 

> package isn't easier if as few new packages as possible are required?

Might be. 

Kent

---

From: Kent-Andre Mardal <[email-masked]>
Date: Fri, 01 Aug 2008 15:02:00 +0200

> use Trilinos will build DOLFIN from source?

Fine with me. I build Dolfin from the sources and use the trilinos
package of Johannes. 

Kent

---

From: "Johannes Ring" <[email-masked]>
Date: Tue, 5 Aug 2008 12:25:09 +0200 (CEST)

> Fine with me. I build Dolfin from the sources and use the trilinos

The segmentation fault problem with the 64 bit packages is now fixed. I
decided to let the DOLFIN packages still depend on Trilinos, but I
compiled new packages for Trilinos, this time without MPI.

Johannes