Subject: Re: [Dorsal-dev] [FEniCS-users] [Fwd: Re: build issuse with dolfin on amd64 platform]

From: "Garth N. Wells" <[email-masked]>
Date: Tue, 22 Sep 2009 20:39:39 +0100

This looks like the MTL4 problem again. We're thinking of removing MTL4 
from DOLFIN.

Harish: Is it an idea to disable MTL4 in Dorsal?

Garth

Andre Massing wrote:
> Hi Kaspar,
> 
> I just forward your email to the fenics-user list so that its member can 
> also participate in this thread and you get a higher probability that 
> your questions will be quickly and thoroughly answered :)
> Hope your are subscribed, as it would be advisable for a serious fenics 
> user ;)
> 
> Greetings,
> Andre
> 
> ------------------------------------------------------------------------
> 
> Subject:
> Re: build issuse with dolfin on amd64 platform
> From:
> Kaspar Müller <[email-masked]>
> Date:
> Tue, 22 Sep 2009 11:50:51 -0700
> To:
> Andre Massing <[email-masked]>
> 
> To:
> Andre Massing <[email-masked]>
> 
> 
> Hi Andre
> 
> Thanks for your help. I did an update to Karmic and built the packages 
> with Dorsal. But first I had to replace the ginac-1.5.3 with the 
> ginac-1.5.3 because the 1.5.3 has some problems with 64 bit architecture.
> http://www.ginac.de/pipermail/ginac-devel/2009-July/001615.html
> With this all went good.
> But now when I try to run a demo I get some errors.
> When I use the example pde/poisson/python and type python demo.py a get 
> the following error:
> ------------------------------------------------------------------------------------------------------------------------------------------------------------------ 
> 
> muellerk@kitt:~/FEniCS/dolfin-0.9.2/demo/pde/poisson/python$ python demo.py
> Traceback (most recent call last):
>  File "demo.py", line 19, in <module>
>    from dolfin import *
>  File 
> "/home/muellerk/FEniCS/build/lib/python2.6/site-packages/dolfin/__init__.py", 
> line 11, in <module>
>    import cpp
>  File 
> "/home/muellerk/FEniCS/build/lib/python2.6/site-packages/dolfin/cpp.py", 
> line 22, in <module>
>    _cpp = swig_import_helper()
>  File 
> "/home/muellerk/FEniCS/build/lib/python2.6/site-packages/dolfin/cpp.py", 
> line 18, in swig_import_helper
>    _mod = imp.load_module('_cpp', fp, pathname, description)
> ImportError: /home/muellerk/FEniCS/build/lib/libdolfin.so.0: undefined 
> symbol: 
> _ZN3mtl6vector8num_rowsIdNS0_10parametersINS_3tag9col_majorENS0_9non_fixed9dimensionELb0ELb0EEEEENS0_12dense_vectorIT_T0_E9size_typeERKSB_ 
> 
> --------------------------------------------------------------------------------------------------------------------------------------------------------- 
> 
> If I try the cpp case the ffc compilation for the variational 
> formulation runs through but then the program compilation with scons 
> gives me the following error:
> --------------------------------------------------------------------------------------------------------------------------------------------------------- 
> 
> muellerk@kitt:~/FEniCS/dolfin-0.9.2/demo/pde/poisson/cpp$ scons
> scons: Reading SConscript files ...
> scons: done reading SConscript files.
> scons: Building targets ...
> mpic++ -o demo -Wl,-rpath,/home/muellerk/FEniCS/build/lib -pthread 
> -Wl,--export-dynamic main.o -L/home/muellerk/FEniCS/build/lib 
> -L/usr/lib/atlas -L/usr/lib/lib -ldolfin -lgmp -lgmpxx -lslepc -lml 
> -lifpack -lamesos -laztecoo -lteuchos -lepetra -lepetraext -lumfpack 
> -lgts -lm -lxml2 -llapack -lblas -lcholmod -lamd -lcolamd -lscotch 
> -lscotcherr -lparmetis -lmetis -lpetscts -lpetscsnes -lpetscksp 
> -lpetscdm -lpetscmat -lpetscvec -lpetsc -lgthread-2.0 -lrt -lgmodule-2.0 
> -lglib-2.0
> /home/muellerk/FEniCS/build/lib/libdolfin.so: undefined reference to 
> `mtl::vector::dense_vector<double, 
> mtl::vector::parameters<mtl::tag::col_major, 
> mtl::vector::non_fixed::dimension, false, false> >::size_type 
> mtl::vector::num_rows<double, 
> mtl::vector::parameters<mtl::tag::col_major, 
> mtl::vector::non_fixed::dimension, false, false> 
>  >(mtl::vector::dense_vector<double, 
> mtl::vector::parameters<mtl::tag::col_major, 
> mtl::vector::non_fixed::dimension, false, false> > const&)'
> collect2: ld returned 1 exit status
> scons: *** [demo] Error 1
> scons: building terminated because of errors.
> --------------------------------------------------------------------------------------------------------------------------------------------------------- 
> 
> Thanks for your help,
> Cheers Kaspar
> 
> Andre Massing wrote:
>> Hi Kaspar,
>>
>> uff, let me try to recall (good thing that you sent the link to the 
>> post :))
>>
>> AFAIR I switched from the libsuitesparse-metis-dev package to the 
>> libsuitesparse-dev package *without* libmetis support and compiled 
>> everything from scratch (to be sure) with dorsal. If you recompile, 
>> remember to remove all the related pkg-config files, which where 
>> generated by scons. They can sometimes cause a real headache :) if you 
>> switch related libraries.
>> Usually they reside in DOLFIN_REPOSITORY_DIRECTORY/scons/pkgconfig, 
>> and in the DOLFIN_INSTALLATION_PATH/lib/pkgconfig.
>>
>> I am now on karmic, and everything compiles quite smoothly.
>>
>> HTH, and let me know, if it worked for you.
>> Good luck :)
>>
>> Kaspar Müller wrote:
>>> Hi Andre
>>>
>>> I runned in the same problem as you
>>> http://article.gmane.org/gmane.comp.mathematics.fenics.dolfin/7914
>>> on my Ubuntu 8.10 Intrepid 64bit maschine.
>>> I tried to compile the fenics packages with dorsal
>>> http://www.fenics.org/pub/software/dorsal/
>>> To specifie the compilation of the different packages for fenics you 
>>> have the *.package files.
>>> In the suitesparsewithmetis.package there was the flac -fPIC already 
>>> set like Harish proposed to solve the problem.
>>> http://article.gmane.org/gmane.comp.mathematics.fenics.dolfin/7916
>>>
>>> Could you solve your problem? If yes, how you did it? If not, do you 
>>> know how to get mor help?
>>>
>>> Thanks for your help
>>> Cheers Kaspar
>>
> 
> 
> ------------------------------------------------------------------------
> 
> _______________________________________________
> FEniCS-users mailing list
> [email-masked]
> http://fenics.org/mailman/listinfo/fenics-users

---

From: Harish Narayanan <[email-masked]>
Date: Tue, 22 Sep 2009 21:46:46 +0200

> Harish: Is it an idea to disable MTL4 in Dorsal?

No, but it is not difficult to do. Just comment out mtl from the list of
packages for your platform.

Once DOLFIN removes support for it, I will remove it for all platforms.

Harish

---

From: "Garth N. Wells" <[email-masked]>
Date: Wed, 23 Sep 2009 07:35:41 +0100

> Once DOLFIN removes support for it, I will remove it for all platforms.

I'm suggesting that you disable it now in Dorsal. I won't consider 
removing it from DOLFIN until after the release.

Garth

---

From: Harish Narayanan <[email-masked]>
Date: Wed, 23 Sep 2009 08:40:32 +0200

Garth N. Wells wrote:
> 
> 
> Harish Narayanan wrote:
>> Garth N. Wells wrote:
>>> This looks like the MTL4 problem again. We're thinking of removing
>>> MTL4 from DOLFIN.
>>>

I will do that then.

Harish