Subject: Re: [Dorsal-dev] [DOLFIN-dev] MUMPS or SPOOLES

From: Anders Logg <[email-masked]>
Date: Mon, 14 Sep 2009 11:17:50 +0200

On Mon, Sep 14, 2009 at 11:15:57AM +0200, Garth N. Wells wrote:
>
>
> Anders Logg wrote:
> > Which is the preferred parallel direct solver? MUMPS or SPOOLES?
> >
>
> Probably depends on the system, but in my experiences MUMPS has been
> better. However, the Debian/Ubuntu PETSc packages are configured with
> SPOOLES, but not MUMPS.

ok, I'm trying out MUMPS now.

Harish: Perhaps --download-mumps=yes should be added to petsc.package
in Dorsal?

--
Anders

---

From: "Garth N. Wells" <[email-masked]>
Date: Mon, 14 Sep 2009 11:19:58 +0200

> Harish: Perhaps --download-mumps=yes should be added to petsc.package

It requires a few more flags than just '--download-mumps=yes' as you'll 
soon see ;).

Garth

> 
> --
> Anders
> 
> 
> ------------------------------------------------------------------------
> 
> _______________________________________________
> DOLFIN-dev mailing list
> [email-masked]
> http://www.fenics.org/mailman/listinfo/dolfin-dev

---

From: Anders Logg <[email-masked]>
Date: Mon, 14 Sep 2009 11:34:56 +0200

> It requires a few more flags than just '--download-mumps=yes' as you'll

Yes...

So far, I've added

  --with-parmetis=1 --with-parmetis-dir=/usr/include/parmetis --download-mumps=1

But PETSc is complaining about ScaLAPACK. Is it possible to use the
Debian package? I'm using OpenMPI (from Debian) but
libscalapack-mpi-dev seems to require mpich.

Which is the simplest way to get MUMPS running?

--
Anders

---

From: Matthew Knepley <[email-masked]>
Date: Mon, 14 Sep 2009 05:47:34 -0500

> Which is the simplest way to get MUMPS running?

--download-scalalpack --download-blacs --download-mumps

It is really depressing that MUMPS is built on such as crappy package.
However, it is the
best parallel direct solver, and SPOOLES is not actively supported anymore.

Also, you can only use the packages if you buy into whatever
compiler/flag/package combination
they happened to use. One reason we need the "crazy download stuff".

   Matt

> --
> Anders
>
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v1.4.9 (GNU/Linux)
>
> iEYEARECAAYFAkquDkAACgkQTuwUCDsYZdF08ACfQWBDM6UpRnH3dcLudaHiDhYe
> vS8An1Xgfn7pQeQfBJ7MG9KmXPniH8Tz
> =IDz8
> -----END PGP SIGNATURE-----
>

-- 
What most experimenters take for granted before they begin their experiments
is infinitely more interesting than any results to which their experiments
lead.
-- Norbert Wiener

---

From: Anders Logg <[email-masked]>
Date: Mon, 14 Sep 2009 13:01:43 +0200

On Mon, Sep 14, 2009 at 05:47:34AM -0500, Matthew Knepley wrote:
> It is really depressing that MUMPS is built on such as crappy package. However,
> it is the
> Also, you can only use the packages if you buy into whatever compiler/flag/
> package combination

Thanks, I'll try that.

I'm very happy PETSc handles this (and Hypre) for me. In an ideal
world, there would be decent Debian packages for all this.

--
Anders

---

From: Anders Logg <[email-masked]>
Date: Mon, 14 Sep 2009 15:11:19 +0200

> world, there would be decent Debian packages for all this.

Works fine. Here are the flags I ended up using:

 COPTFLAGS=-O3 --with-debugging=0 --with-clanguage=cxx --with-shared=1
 --download-hypre=1 --with-parmetis=1
 --with-parmetis-dir=/usr/include/parmetis --download-scalapack=1
 --download-blacs=1 --download-mumps=1

Thanks Matt.

--
Anders

---

From: Harish Narayanan <[email-masked]>
Date: Mon, 21 Sep 2009 10:28:41 +0200

>  --download-blacs=1 --download-mumps=1

I've added something very similar to the build script now. The only
thing that needs to be checked is whether --with-parmetis-dir=/usr would
suffice.

Harish