Subject: [Dorsal-dev] [HG dorsal] Small fixes and polishing toward a 0.4 release. Still needs testing on the various Ubuntus and Debian.

From: [email-masked] (Dorsal)
Date: Thu, 22 Jan 2009 21:09:28 +0100 (CET)

One or more new changesets pushed to the primary dorsal repository.
A short summary of the last three changesets is included below.

changeset:   134:f0113ec8bbe72c1b1fb61c38a8c672ee221efc25
tag:         tip
user:        Harish Narayanan <[email-masked]>
date:        Thu Jan 22 15:08:45 2009 -0500
files:       ChangeLog README TODO dorsal.cfg dorsal.sh packages/syfi-stable.package packages/vtk.package platforms/rhel4.platform
description:
Small fixes and polishing toward a 0.4 release. Still needs testing on the various Ubuntus and Debian.

changeset:   133:e4a83717c85f54cc21333eb3ffe55979159a3485
user:        Harish Narayanan <[email-masked]>
date:        Thu Jan 22 18:09:07 2009 +0100
files:       TODO dorsal.cfg dorsal.sh
description:
Created a mechanism to fetch and build only stable versions of FEniCS packages. Dorsal still defaults to fetching from development repositories but this behaviour can be easily switched in dorsal.cfg.

changeset:   132:5b9f9a056543b5bffda94d663bea44fb3ad2c768
user:        Harish Narayanan <[email-masked]>
date:        Thu Jan 22 17:37:31 2009 +0100
files:       dorsal.sh packages/dolfin-stable.package packages/ferari-stable.package packages/ffc-stable.package packages/fiat-stable.package packages/instant-stable.package packages/numpy.package packages/syfi-stable.package packages/ufc-stable.package packages/viper-stable.package
description:
Added packages containing links to stable versions of FEniCS projects

----------------------------------------------------------------------
For more details, visit http://www.fenics.org/dev/dorsal

---

From: Joachim Berdal Haga <[email-masked]>
Date: Fri, 23 Jan 2009 09:13:31 +0100

> Small fixes and polishing toward a 0.4 release. Still needs testing on the various Ubuntus and Debian.

I tested on debian lenny. It compiles fine. The demos seem to partly work,
but they all segfault on exit somewhere in the MPI library.

-j.

---

From: Harish Narayanan <[email-masked]>
Date: Fri, 23 Jan 2009 09:51:18 +0100

> but they all segfault on exit somewhere in the MPI library.

OK. I have observed this for a long time (months?) on my Mac OS machine
and haven't made the time to sort it out (and I've come to live with
it). Apart from looking ominous, it doesn't seem to do anything bad.

Is it an error of the following form? (The following is the most verbose
I could make it; it's usually much shorter, but still a segfault on exit.)

*** An error occurred in MPI_Attr_get
*** after MPI was finalized
*** MPI_ERRORS_ARE_FATAL (your MPI job will now abort)
*** An error occurred in MPI_Comm_rank
*** after MPI was finalized
*** MPI_ERRORS_ARE_FATAL (your MPI job will now abort)
[0]PETSC ERROR:
------------------------------------------------------------------------
*** An error occurred in MPI_Comm_rank
*** after MPI was finalized
*** MPI_ERRORS_ARE_FATAL (your MPI job will now abort)
[0]PETSC ERROR: Caught signal number 11 SEGV: Segmentation Violation,
probably memory access out of range
*** An error occurred in MPI_Comm_rank
*** after MPI was finalized
*** MPI_ERRORS_ARE_FATAL (your MPI job will now abort)
[0]PETSC ERROR: Try option -start_in_debugger or -on_error_attach_debugger
*** An error occurred in MPI_Comm_rank
*** after MPI was finalized
*** MPI_ERRORS_ARE_FATAL (your MPI job will now abort)
[0]PETSC ERROR: or see
http://www.mcs.anl.gov/petsc/petsc-as/documentation/troubleshooting.html#Signal***
An error occurred in MPI_Comm_rank
*** after MPI was finalized
*** MPI_ERRORS_ARE_FATAL (your MPI job will now abort)
[0]PETSC ERROR: or try http://valgrind.org on linux or man libgmalloc on
Apple to find memory corruption errors
*** An error occurred in MPI_Comm_rank
*** after MPI was finalized
*** MPI_ERRORS_ARE_FATAL (your MPI job will now abort)
[0]PETSC ERROR: configure using --with-debugging=yes, recompile, link,
and run
*** An error occurred in MPI_Comm_rank
*** after MPI was finalized
*** MPI_ERRORS_ARE_FATAL (your MPI job will now abort)
[0]PETSC ERROR: to get more information on the crash.
*** An error occurred in MPI_Comm_rank
*** after MPI was finalized
*** MPI_ERRORS_ARE_FATAL (your MPI job will now abort)
[0]PETSC ERROR: --------------------- Error Message
------------------------------------
*** An error occurred in MPI_Comm_rank
*** after MPI was finalized
*** MPI_ERRORS_ARE_FATAL (your MPI job will now abort)
[0]PETSC ERROR: Signal received!
*** An error occurred in MPI_Comm_rank
*** after MPI was finalized
*** MPI_ERRORS_ARE_FATAL (your MPI job will now abort)
[0]PETSC ERROR:
------------------------------------------------------------------------
*** An error occurred in MPI_Comm_rank
*** after MPI was finalized
*** MPI_ERRORS_ARE_FATAL (your MPI job will now abort)
[0]PETSC ERROR: Petsc Release Version 2.3.3, Patch 15, Tue Sep 23
10:02:49 CDT 2008 HG revision: 31306062cd1a6f6a2496fccb4878f485c9b91760
*** An error occurred in MPI_Comm_rank
*** after MPI was finalized
*** MPI_ERRORS_ARE_FATAL (your MPI job will now abort)
[0]PETSC ERROR: See docs/changes/index.html for recent updates.
*** An error occurred in MPI_Comm_rank
*** after MPI was finalized
*** MPI_ERRORS_ARE_FATAL (your MPI job will now abort)
[0]PETSC ERROR: See docs/faq.html for hints about trouble shooting.
*** An error occurred in MPI_Comm_rank
*** after MPI was finalized
*** MPI_ERRORS_ARE_FATAL (your MPI job will now abort)
[0]PETSC ERROR: See docs/index.html for manual pages.
*** An error occurred in MPI_Comm_rank
*** after MPI was finalized
*** MPI_ERRORS_ARE_FATAL (your MPI job will now abort)
[0]PETSC ERROR:
------------------------------------------------------------------------
*** An error occurred in MPI_Comm_rank
*** after MPI was finalized
*** MPI_ERRORS_ARE_FATAL (your MPI job will now abort)
[0]PETSC ERROR: Unknown Name on a darwin9.2 named megatr0n.local by
hnarayan Fri Jan 23 09:48:16 2009
*** An error occurred in MPI_Comm_rank
*** after MPI was finalized
*** MPI_ERRORS_ARE_FATAL (your MPI job will now abort)
[0]PETSC ERROR: Libraries linked from
/Users/hnarayan/Work/FEniCS/build/lib/darwin9.2.0-cxx-opt
*** An error occurred in MPI_Comm_rank
*** after MPI was finalized
*** MPI_ERRORS_ARE_FATAL (your MPI job will now abort)
[0]PETSC ERROR: Configure run at Wed Jan 21 20:54:53 2009
*** An error occurred in MPI_Comm_rank
*** after MPI was finalized
*** MPI_ERRORS_ARE_FATAL (your MPI job will now abort)
[0]PETSC ERROR: Configure options COPTFLAGS=-O3 --with-debugging=0
--with-clanguage=cxx --with-fc=0 --with-shared=1
--prefix=/Users/hnarayan/Work/FEniCS/build
*** An error occurred in MPI_Comm_rank
*** after MPI was finalized
*** MPI_ERRORS_ARE_FATAL (your MPI job will now abort)
[0]PETSC ERROR:
------------------------------------------------------------------------
*** An error occurred in MPI_Comm_rank
*** after MPI was finalized
*** MPI_ERRORS_ARE_FATAL (your MPI job will now abort)
[0]PETSC ERROR: User provided function() line 0 in unknown directory
unknown file
*** An error occurred in MPI_Abort
*** after MPI was finalized
*** MPI_ERRORS_ARE_FATAL (your MPI job will now abort)
--------------------------------------------------------------------------
MPI_ABORT was invoked on rank 0 in communicator MPI_COMM_WORLD
with errorcode 59.

NOTE: invoking MPI_ABORT causes Open MPI to kill all MPI processes.
You may or may not see output from other processes, depending on
exactly when Open MPI kills them.
--------------------------------------------------------------------------
Segmentation fault

Harish

---

From: Joachim Berdal Haga <[email-masked]>
Date: Fri, 23 Jan 2009 10:12:07 +0100

> *** MPI_ERRORS_ARE_FATAL (your MPI job will now abort)

I'm away from the box now, but yes: it looked very similar to your example. In 
particular I remember that the first report was in MPI_Attr_get and it said 
"after MPI was finalized".

I didn't see these errors the last time I tested, but that is at least a month ago.

-j.