Subject: [Dorsal-dev] [HG dorsal] Add scotch, gmp etc. optional packages to Debian platform.

From: [email-masked] (Dorsal)
Date: Mon, 22 Dec 2008 20:07:38 +0100 (CET)

One or more new changesets pushed to the primary dorsal repository.
A short summary of the last three changesets is included below.

changeset:   123:658288aab04b0578749d9f70607f6b58a1c15ff5
tag:         tip
user:        "Joachim B Haga <[email-masked]>"
date:        Mon Dec 22 20:07:33 2008 +0100
files:       dorsal.sh platforms/lenny.platform platforms/sid.platform
description:
Add scotch, gmp etc. optional packages to Debian platform.

Renamed sid.platform to lenny.platform, for upcoming lenny
release. Will probably re-add sid later, when it diverges
from lenny.

Also changed guess_platform, due to change in /etc/issue. It
is now hopefully more robust.

changeset:   122:4de8ce4ce1c79f8a866ab85bae573c744b83ecbe
user:        [email-masked]
date:        Mon Dec 22 18:09:05 2008 +0100
files:       TODO dorsal.sh packages/dolfin-stable.package packages/ffc-stable.package packages/matplotlib.package packages/petsc.package
description:
Added matplotlib since the CBC flow code uses it

changeset:   121:77892cd3c60906f7d89bd36bb9937e322e3bc25d
user:        "Joachim B Haga <[email-masked]>"
date:        Mon Dec 22 10:34:48 2008 +0100
files:       platforms/intrepid.platform
description:
Intrepid: set PARMETIS_DIR, GMP_DIR, SCOTCH_DIR

----------------------------------------------------------------------
For more details, visit http://www.fenics.org/dev/dorsal

---

From: Joachim Berdal Haga <[email-masked]>
Date: Mon, 22 Dec 2008 20:16:23 +0100

OK, it's tested on Debian testing (which is more-or-less lenny).

Note that I kept compilation of slepc, even though it is now packaged in
Debian. The packaged version doesn't seem to provide what pkgconfiggen needs:

slepc_makefile:7: /usr/bmake/slepc_common: No such file or directory

(JR: just FYI)

-- 
j.

Dorsal wrote:
> _______________________________________________
> Dorsal-dev mailing list
> [email-masked]
> http://fenics.org/mailman/listinfo/dorsal-dev

---

From: LUK ShunTim <[email-masked]>
Date: Sat, 27 Dec 2008 17:11:18 +0800

> OK, it's tested on Debian testing (which is more-or-less lenny).

Compiled OK on debian sid, amd64 using the lenny.platform.

> slepc_makefile:7: /usr/bmake/slepc_common: No such file or directory

Same situation here.

Regards,
ST
--

---

From: Joachim Berdal Haga <[email-masked]>
Date: Tue, 30 Dec 2008 16:07:19 +0100

> Compiled OK on debian sid, amd64 using the lenny.platform.

Good! Did you have to specify that lenny.platform should be used? If so,
what's the output if you run "lsb_release -c"?

-j.

---

From: LUK ShunTim <[email-masked]>
Date: Wed, 31 Dec 2008 14:01:11 +0800

> Good! Did you have to specify that lenny.platform should be used? If so,

I just copied it over to sid.platform and used it.

> what's the output if you run "lsb_release -c"?

$ lsb_release -c
Codename:	lenny

BTW, is there a simple way in dorsal to test all the demo examples? I'm
mainly interested in the python ones at the moment.

Regards,
ST
--

---

From: Joachim Berdal Haga <[email-masked]>
Date: Wed, 31 Dec 2008 10:53:29 +0100

> mainly interested in the python ones at the moment.

The dolfin demos? THere's a script $DOLFIN_DIR/test/system/test.py which
runs most of the demos (with plotting turned off). It would be easy enough
to call this at the end of the dolfin build, just

cd $DOLFIN_DIR/test/system
source $DOLFIN_DIR/dolfin.conf
python test.py --python-only

-j.

---

From: LUK ShunTim <[email-masked]>
Date: Wed, 31 Dec 2008 18:02:06 +0800

> python test.py --python-only

Thanks.

ST
--

---

From: Harish Narayanan <[email-masked]>
Date: Wed, 31 Dec 2008 11:46:57 +0100

>> what's the output if you run "lsb_release -c"?

There ought not be a need to copy anything for this to happen.

Joachim, could you update guess_platform() to reflect the fact that
lenny.platform works for sid?

Harish

---

From: Joachim Berdal Haga <[email-masked]>
Date: Wed, 31 Dec 2008 12:00:19 +0100

> There ought not be a need to copy anything for this to happen.

Agreed, this will work without any extra action right now since sid is the
same as, and self-identifies as, lenny. I don't know yet what happens when
they diverge, if sid will call itself "sid", "squeeze", "sid/squeeze", or
what. I'll keep an eye on it.

> lenny.platform works for sid?

No action required yet, since sid==lenny. I'll put a comment to that effect
on top of lenny.platform.

-j.

---

From: Harish Narayanan <[email-masked]>
Date: Wed, 31 Dec 2008 12:03:18 +0100

> what. I'll keep an eye on it.

All right, I did not know that. I thought sid identified itself as 'sid'
and lenny as 'lenny,' which would fool the current guess_platform()
implementation.

> on top of lenny.platform.

Cool, OK.

Harish

---

From: Joachim Berdal Haga <[email-masked]>
Date: Thu, 15 Jan 2009 17:14:51 +0100

Hi ShunTim,

 > Thanks. All ran OK except la/eigensolver/demo.py. Errors like these below

I haven't had the chance to check this error yet. Is this with the Debian petsc 
package?

Joachim

> 
> <quote>
> [0]PETSC ERROR: --------------------- Error Message
> ------------------------------------
> [0]PETSC ERROR: Invalid argument!
> [0]PETSC ERROR: Invalid object cookie 0
> This often happens if you compile with PETSC_USE_DYNAMIC_LIBRARIES, but
> link with static libraries.!
> [0]PETSC ERROR:
> ------------------------------------------------------------------------
> [0]PETSC ERROR: Petsc Release Version 2.3.3, Patch 3, Fri Jun 15
> 16:51:25 CDT 2007 HG revision: f051789beadcd36f77fb6111d20225e26ed7cc0d
> [0]PETSC ERROR: See docs/changes/index.html for recent updates.
> [0]PETSC ERROR: See docs/faq.html for hints about trouble shooting.
> [0]PETSC ERROR: See docs/index.html for manual pages.
> [0]PETSC ERROR:
> ------------------------------------------------------------------------
> [0]PETSC ERROR: Unknown Name on a linux-gnu named jdk by stluk Thu Jan
> 1 13:41:14 2009
> [0]PETSC ERROR: Libraries linked from
> /home/hazelsct/petsc-2.3.3/lib/linux-gnu-c-opt
> [0]PETSC ERROR: Configure run at Thu Aug 28 16:57:49 2008
> [0]PETSC ERROR: Configure options --with-shared --with-dynamic
> --with-debugging=0 --useThreads 0 --with-mpi-dir=/usr/lib/openmpi
> --with-mpi-shared=1 --with-blas-lib=-lblas --with-lapack-lib=-llapack
> --with-umfpack=1 --with-umfpack-include=/usr/include/suitesparse
> --with-umfpack-lib="[/usr/lib/libumfpack.so,/usr/lib/libamd.so]"
> --with-superlu=1 --with-superlu-include=/usr/include/superlu
> --with-superlu-lib=/usr/lib/libsuperlu.so --with-spooles=1
> --with-spooles-include=/usr/include/spooles
> --with-spooles-lib=/usr/lib/libspooles.so --with-hypre=1
> --with-hypre-dir=/usr --with-babel=1 --with-babel-dir=/usr
> [0]PETSC ERROR:
> ------------------------------------------------------------------------
> [0]PETSC ERROR: ClassRegLogGetClass() line 283 in
> src/sys/plog/utils/classLog.c
> [0]PETSC ERROR: PetscLogObjCreateDefault() line 311 in
> src/sys/plog/utils/classLog.c
> </quote>
> 
> repeat in demo.log. The line
> 
> [0]PETSC ERROR: Libraries linked from
> /home/hazelsct/petsc-2.3.3/lib/linux-gnu-c-opt
> 
> seems strange.
> 
> Happy new year,
> ST
> --
> 
>

---

From: Ilmar Wilbers <[email-masked]>
Date: Thu, 15 Jan 2009 17:39:25 +0100

It seems as though PETSc is installed locally, judging from the 
directory name. Compiling without --with-dynamic should solve this. I 
use the following options for configuring PETSc:
--with-shared=1 --with-fortran=0 --with-x=0 --with-x11=0

ilmar

---

From: LUK ShunTim <[email-masked]>
Date: Fri, 16 Jan 2009 13:10:05 +0800

Ilmar Wilbers wrote:
>> I haven't had the chance to check this error yet. Is this with the
>> Debian petsc package?
>>
>> Joachim

Ilmar, Joachim,

Thanks for the replies.

Yes, I have the petsc package from debian. But after I rebuilt (on Jan
10), the problem went away, miraculously. I don't know why. I've
forgotten whether petsc is updated during the period. I'll report if I
see the errors again.

Regards,
ST
--