Subject: Re: [Dorsal-dev] Dorsal-dev Digest, Vol 10, Issue 3

From: Max Novelli <[email-masked]>
Date: Wed, 29 Jul 2009 10:31:28 -0400

Hi

as suggested I downloaded the latest version of dorsal through mercurial 
repository.
I run ./dorsal.sh and I got the following error:

----------------------------------------
Unpacking swiginac-1.5.1
Building swiginac-1.5.1
running build_ext
building '_swiginac' extension
swigging swiginac.i to swiginac_wrap.cpp
swig -python -c++ -o swiginac_wrap.cpp swiginac.i
archive.i:59: Warning(503): Can't wrap 'operator <<' unless renamed to a 
valid identifier.
archive.i:60: Warning(503): Can't wrap 'operator >>' unless renamed to a 
valid identifier.
creating build
creating build/temp.linux-x86_64-2.5
gcc -pthread -fno-strict-aliasing -DNDEBUG -O2 -g -pipe -Wall 
-Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector 
--param=ssp-buffer-size=4 -m64 -mtune=generic -D_GNU_SOURCE -fPIC -fPIC 
-I/usr/include/python2.5 -c swiginac_wrap.cpp -o 
build/temp.linux-x86_64-2.5/swiginac_wrap.o
swiginac_wrap.cpp: In function ‘PyObject* 
_wrap_new_registered_class_options(PyObject*, PyObject*)’:
swiginac_wrap.cpp:24482: error: no matching function for call to 
‘GiNaC::registered_class_options::registered_class_options(const char*, 
const char*, const std::type_info&)’
/usr/include/ginac/registrar.h:52: note: candidates are: 
GiNaC::registered_class_options::registered_class_options(const char*, 
const char*, const void*, GiNaC::ex (*)(const GiNaC::archive_node&, 
GiNaC::lst&))
/usr/include/ginac/registrar.h:50: note: 
GiNaC::registered_class_options::registered_class_options(const 
GiNaC::registered_class_options&)
swiginac_wrap.cpp: In function ‘PyObject* _wrap_basic_match(PyObject*, 
PyObject*)’:
swiginac_wrap.cpp:26108: error: no matching function for call to 
‘GiNaC::basic::match(const GiNaC::ex&, std::map<GiNaC::ex, GiNaC::ex, 
GiNaC::ex_is_less, std::allocator<std::pair<const GiNaC::ex, GiNaC::ex> 
 > >&) const’
/usr/include/ginac/basic.h:166: note: candidates are: virtual bool 
GiNaC::basic::match(const GiNaC::ex&, GiNaC::lst&) const
swiginac_wrap.cpp: In function ‘PyObject* 
_wrap_basic_return_type_tinfo(PyObject*, PyObject*)’:
swiginac_wrap.cpp:27870: error: ‘return_type_t’ is not a member of ‘GiNaC’
swiginac_wrap.cpp:27870: error: expected `;' before ‘result’
swiginac_wrap.cpp:27883: error: ‘result’ was not declared in this scope
swiginac_wrap.cpp:27901: error: expected type-specifier
swiginac_wrap.cpp:27901: error: expected `)'
swiginac_wrap.cpp:27901: error: expected `)' before ‘;’ token
swiginac_wrap.cpp: In function ‘PyObject* 
_wrap_integral_return_type_tinfo(PyObject*, PyObject*)’:
swiginac_wrap.cpp:39514: error: ‘return_type_t’ is not a member of ‘GiNaC’
swiginac_wrap.cpp:39514: error: expected `;' before ‘result’
swiginac_wrap.cpp:39527: error: ‘result’ was not declared in this scope
swiginac_wrap.cpp:39545: error: expected type-specifier
swiginac_wrap.cpp:39545: error: expected `)'
swiginac_wrap.cpp:39545: error: expected `)' before ‘;’ token
swiginac_wrap.cpp: In function ‘PyObject* 
_wrap_function_options_set_return_type__SWIG_0(PyObject*, PyObject*)’:
swiginac_wrap.cpp:47660: error: ‘return_type_t’ is not a member of ‘GiNaC’
swiginac_wrap.cpp:47660: error: ‘arg3’ was not declared in this scope
swiginac_wrap.cpp:47660: error: ‘return_type_t’ is not a member of ‘GiNaC’
swiginac_wrap.cpp:47660: error: expected primary-expression before ‘)’ token
swiginac_wrap.cpp:47660: error: expected `;' before numeric constant
swiginac_wrap.cpp:47687: error: expected type-specifier
swiginac_wrap.cpp:47687: error: expected `>'
swiginac_wrap.cpp:47687: error: expected `('
swiginac_wrap.cpp:47687: error: ‘return_type_t’ is not a member of ‘GiNaC’
swiginac_wrap.cpp:47687: error: expected primary-expression before ‘>’ token
swiginac_wrap.cpp:47687: error: expected `)' before ‘;’ token
swiginac_wrap.cpp:47691: error: ‘return_type_t’ is not a member of ‘GiNaC’
swiginac_wrap.cpp:47691: error: expected `)' before ‘const’
swiginac_wrap.cpp: In function ‘PyObject* _wrap_find(PyObject*, PyObject*)’:
swiginac_wrap.cpp:49514: error: invalid initialization of reference of 
type ‘GiNaC::lst&’ from expression of type ‘std::set<GiNaC::ex, 
GiNaC::ex_is_less, std::allocator<GiNaC::ex> >’
/usr/include/ginac/ex.h:712: error: in passing argument 3 of ‘bool 
GiNaC::find(const GiNaC::ex&, const GiNaC::ex&, GiNaC::lst&)’
swiginac_wrap.cpp: In function ‘PyObject* _wrap_match(PyObject*, 
PyObject*)’:
swiginac_wrap.cpp:50859: error: invalid initialization of reference of 
type ‘GiNaC::lst&’ from expression of type ‘std::map<GiNaC::ex, 
GiNaC::ex, GiNaC::ex_is_less, std::allocator<std::pair<const GiNaC::ex, 
GiNaC::ex> > >’
/usr/include/ginac/ex.h:772: error: in passing argument 3 of ‘bool 
GiNaC::match(const GiNaC::ex&, const GiNaC::ex&, GiNaC::lst&)’
swiginac_wrap.cpp: In function ‘PyObject* 
_wrap_clifford_read_archive(PyObject*, PyObject*)’:
swiginac_wrap.cpp:79108: error: ‘class GiNaC::clifford’ has no member 
named ‘read_archive’
error: command 'gcc' failed with exit status 1
Failure with exit status: 1
Exit message: There was a problem in build setup for swiginac-1.5.1.
----------------------------------

My platform is Fedora 10 64bits.

thank you
Max

[email-masked] wrote:
> Send Dorsal-dev mailing list submissions to
> 	[email-masked]
>
> To subscribe or unsubscribe via the World Wide Web, visit
> 	http://fenics.org/mailman/listinfo/dorsal-dev
> or, via email, send a message with subject or body 'help' to
> 	[email-masked]
>
> You can reach the person managing the list at
> 	[email-masked]
>
> When replying, please edit your Subject line so it is more specific
> than "Re: Contents of Dorsal-dev digest..."
>
>
> Today's Topics:
>
>    1. Re: ufl issues (Harish Narayanan)
>
>
> ----------------------------------------------------------------------
>
> Message: 1
> Date: Wed, 29 Jul 2009 10:38:18 +0200
> From: Harish Narayanan <[email-masked]>
> Subject: Re: [Dorsal-dev] ufl issues
> To: [email-masked]
> Cc: [email-masked]
> Message-ID: <[email-masked]>
> Content-Type: text/plain; charset=ISO-8859-1
>
> Max Novelli wrote:
>   
>> Hi
>>
>> I'm using dorsal on fedora 10 and I get the following error:
>>
>> Fetching ufl
>> abort: requirement '<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 
>> Transitional//EN">' not supported!
>> Failure with exit status: 255
>> Exit message: Error fetching ufl.
>>
>> Am I doing something wrong?
>>     
>
> No, you're not. The UFL source repository was moved at some point and
> this is not reflected in the version of Dorsal you are using. Please
> fetch the latest version [1] and it will fix this problem.
>
>   
>> Thank you so much for your help
>>     
>
> If you run into other problems with getting things to build on Fedora
> 10, point them out here and I will try to fix them. I don't test it
> frequently on Fedora since no one around seems to be using it.
>
> Also, sign up for the mailing list [2], otherwise there is a chance that
> your messages to the list will be discarded as spam.
>
> Harish
>
> [1] hg clone http://www.fenics.org/dev/dorsal
> [2] http://fenics.org/mailman/listinfo/dorsal-dev
>
>
> ------------------------------
>
> _______________________________________________
> Dorsal-dev mailing list
> [email-masked]
> http://fenics.org/mailman/listinfo/dorsal-dev
>
>
> End of Dorsal-dev Digest, Vol 10, Issue 3
> *****************************************
>   

-- 
Massimiliano (Max) Novelli
System Administrator
University of Pittsburgh

Email: [email-masked]

Phone: +1.412.624-6898
LRDC
Suite 718
3939 O'Hara Street
Pittsburgh, PA 15260

Phone: +1.412.586.9251
Oxford Building
Suite 450, Room 461
3501 Forbes Avenue
Pittsburgh, PA 15213

---

From: Max Novelli <[email-masked]>
Date: Wed, 29 Jul 2009 12:19:05 -0400

Hi

I'm trying to compile fenics tools on centos 5.3 i386 and I got the 
following error:

------------------------------------------
Fetching petsc-3.0.0-p5
Unpacking petsc-3.0.0-p5
Building petsc-3.0.0-p5
=================================================================================
             Configuring PETSc to compile on your system
=================================================================================
/home/nitrosx/installs/fenics/src/petsc-3.0.0-p5/config/BuildSystem/config/compilers.py:7: 
DeprecationWarning: the sets module is deprecated
  import sets
/home/nitrosx/installs/fenics/src/petsc-3.0.0-p5/config/PETSc/package.py:7: 
DeprecationWarning: the md5 module is deprecated; use hashlib instead
  import md5
/home/nitrosx/installs/fenics/src/petsc-3.0.0-p5/config/BuildSystem/script.py:101: 
DeprecationWarning: The popen2 module is deprecated.  Use the subprocess 
module.
  import popen2
=================================================================================                                                                                                                                     
WARNING! Compiling PETSc with no debugging, this 
should                                                                                                                                                     
only be done for timing and production runs. All development 
should                                                                                                                                   
be done when configured using 
--with-debugging=1                                                                                                                                
=================================================================================                                                                                                                     
TESTING: FortranMPICheck from 
config.packages.MPI(config/BuildSystem/config/packages/MPI.py:617)                                                                                                      
*********************************************************************************
         UNABLE to CONFIGURE with GIVEN OPTIONS    (see configure.log 
for details):
---------------------------------------------------------------------------------------
Fortran error! mpif.h could not be located at: []
*********************************************************************************

Failure with exit status: 1
Exit message: There was a problem in build setup for petsc-3.0.0-p5.
--------------------------------------

I used the latest dev version of dorsal.

Thank you
Max

Email: [email-masked]

Phone: +1.412.624-6898
LRDC
Suite 718
3939 O'Hara Street
Pittsburgh, PA 15260

Phone: +1.412.586.9251
Oxford Building
Suite 450, Room 461
3501 Forbes Avenue
Pittsburgh, PA 15213

---

From: Harish Narayanan <[email-masked]>
Date: Wed, 29 Jul 2009 18:32:20 +0200

> I run ./dorsal.sh and I got the following error:

I think there is a conflict between the version of GiNaC Dorsal is
trying to install vs the GiNaC sitting in your /usr/ folder. If
possible, try uninstalling the fedora ginac package before retrying.

Also, since Swiginac is not essential to getting DOLFIN running, you can
just edit out swiginac from dorsal/platforms/fedora10.platform and
circumvent this problem for now.

Harish

---

From: Harish Narayanan <[email-masked]>
Date: Wed, 29 Jul 2009 18:39:24 +0200

> I'm trying to compile fenics tools on centos 5.3 i386 and I got the 

I think you need to install some version of fortran (gfortran) on your
machine first. I think the yum package is called gcc-gfortran.

(Please make a note of these changes/fixes for fedora/centos as you make
them, and send me a summary e-mail when it's all working.)

Harish

---

From: Max Novelli <[email-masked]>
Date: Wed, 29 Jul 2009 15:29:25 -0400

Hi

I was able to move a little bit forward.
Here is what I did:
 - removed standard rpm ginac from fedora 10.
 - changed dorsal/platform/fedora10.platform. Added ginac right before 
swiginac.

Now dorsal stos when building syfi
-------
Error in building syfi
...
Install file: "syfi/tools.h" as 
"/home/nitrosx/installs/fenics/build/include/SyFi/tools.h"
Install file: "syfi/utilities.h" as 
"/home/nitrosx/installs/fenics/build/include/SyFi/utilities.h"
Install file: "syfi/swig/_SyFi.so" as 
"/home/nitrosx/installs/fenics/build/lib64/python2.5/site-packages/_Sy
Fi.so"
scons: *** DirNodeInfo instance has no attribute 'csig'
scons: building terminated because of errors.
Failure with exit status: 2
Exit message: There was a problem building syfi.
------

I did some research but I did not quite understand the problem.

Max

Email: [email-masked]

Phone: +1.412.624-6898
LRDC
Suite 718
3939 O'Hara Street
Pittsburgh, PA 15260

Phone: +1.412.586.9251
Oxford Building
Suite 450, Room 461
3501 Forbes Avenue
Pittsburgh, PA 15213

---

From: Harish Narayanan <[email-masked]>
Date: Wed, 29 Jul 2009 21:33:12 +0200

> Exit message: There was a problem building syfi.

This is some evil scons thing that crops up from time to time. You could
try removing Fedora's scons package (yum remove scons) and replacing it
with a Dorsal scons (add scons to the fedora10.platform list).

Harish

---

From: Max Novelli <[email-masked]>
Date: Wed, 29 Jul 2009 16:18:03 -0400

Hi

Almost....
I removed fedora rpm scons and added the package to fedora10.package.
Restarted and went a little bit further...

Here is the new error:
Building dolfin-0.9.2
scons: Reading SConscript files ...

scons: warning: The BoolOption() function is deprecated; use the 
BoolVariable() function instead.
File "/home/nitrosx/installs/fenics/src/dolfin-0.9.2/SConstruct", line 
65, in <module>

scons: warning: The PathOption() function is deprecated; use the 
PathVariable() function instead.
File "/home/nitrosx/installs/fenics/src/dolfin-0.9.2/SConstruct", line 
97, in <module>

scons: warning: The Options class is deprecated; use the Variables class 
instead.
File 
"/home/nitrosx/installs/fenics/src/dolfin-0.9.2/scons/simula-scons/simula_scons/__init__.py", 
line 252, in __init__
Using options from 
/home/nitrosx/installs/fenics/src/dolfin-0.9.2/scons/options.cache
Checking for pkg-config... yes
Checking for numpy-1... yes
Checking for python-2... yes
Checking for scotch... no (pkg-config file not found)
 Trying to generate pkg-config file for scotch... failed
Checking for trilinos... no (pkg-config file not found)
 Trying to generate pkg-config file for trilinos... failed
Checking for ufc-1... yes
Checking for umfpack... no (pkg-config file not found)
 Trying to generate pkg-config file for umfpack... failed
Checking for mtl4... no (pkg-config file not found)
 Trying to generate pkg-config file for mtl4... failed
Checking for petsc... no (pkg-config file not found)
 Trying to generate pkg-config file for petsc... done
 Found PETSc and generated pkg-config file in
 '/home/nitrosx/installs/fenics/src/dolfin-0.9.2/scons/pkgconfig'
Checking for gts... yes
Checking for boost... no (pkg-config file not found)
 Trying to generate pkg-config file for boost... failed
Checking for cholmod... no (pkg-config file not found)
 Trying to generate pkg-config file for cholmod... failed
Checking for parmetis... no (pkg-config file not found)
 Trying to generate pkg-config file for parmetis... failed
Checking for gmp... no (pkg-config file not found)
 Trying to generate pkg-config file for gmp... failed
Checking for slepc... no (pkg-config file not found)
 Trying to generate pkg-config file for slepc... done
 Found SLEPc and generated pkg-config file in
 '/home/nitrosx/installs/fenics/src/dolfin-0.9.2/scons/pkgconfig'
Checking for libxml-2.0... yes
Resolving compiler... done
 Some tests failed using mpic++
 Switching to use mpicxx instead.
Warning: Unknown dependency package: boost
*** Unable to import UFC. Install latest UFC
Failure with exit status: 1
Exit message: There was a problem building dolfin-0.9.2.

Is this an issue with UFC or boost?

Thank you
Max

Email: [email-masked]

Phone: +1.412.624-6898
LRDC
Suite 718
3939 O'Hara Street
Pittsburgh, PA 15260

Phone: +1.412.586.9251
Oxford Building
Suite 450, Room 461
3501 Forbes Avenue
Pittsburgh, PA 15213

---

From: Harish Narayanan <[email-masked]>
Date: Wed, 29 Jul 2009 22:36:08 +0200

> Is this an issue with UFC or boost?

I'm not sure. Could you peek into
.../dolfin-0.9.2/scons/simula_scons.log and see if it has anything helpful?

Harish

---

From: Max Novelli <[email-masked]>
Date: Wed, 29 Jul 2009 16:48:37 -0400

Here is the tail of simula_scons.log

Error message:
sh: mpic++: command not found
resolveCompiler: No pkg-config generator for package 'ufc-1'. Assuming Ok.
resolveCompiler: Some tests failed for package 'petsc'. Discarding package.
resolveCompiler: Unable to compile a PETSc test program.
Compilation command was:
mpic++ -I/home/nitrosx/installs/fenics/build//include 
-I/home/nitrosx/installs/fenics/build/include -I/usr/include/mpich2 -c 
petsc_config_test_version.cpp
Failed test program was:

#include <stdio.h>
#include <petsc.h>

int main() {
  #ifdef PETSC_VERSION_MAJOR
    #ifdef PETSC_VERSION_MINOR
      #ifdef PETSC_VERSION_SUBMINOR
        printf("%d.%d.%d", PETSC_VERSION_MAJOR, PETSC_VERSION_MINOR, 
PETSC_VERSION_SUBMINOR);
      #else
        printf("%d.%d", PETSC_VERSION_MAJOR, PETSC_VERSION_MINOR);
      #endif
    #else
      printf("%d", PETSC_VERSION_MAJOR);
    #endif
  #endif
  return 0;
}

Error message:
sh: mpic++: command not found
resolveCompiler: No pkg-config generator for package 'ufc-1'. Assuming Ok.
resolveCompiler: No pkg-config generator for package 'gts'. Assuming Ok.

Any suggestion?
Thanks a lot
Max

Email: [email-masked]

Phone: +1.412.624-6898
LRDC
Suite 718
3939 O'Hara Street
Pittsburgh, PA 15260

Phone: +1.412.586.9251
Oxford Building
Suite 450, Room 461
3501 Forbes Avenue
Pittsburgh, PA 15213

---

From: "Johannes Ring" <[email-masked]>
Date: Thu, 30 Jul 2009 08:52:45 +0200

Hi Max,

It seems like Boost is missing. From your output below it says:

scons/simula_scons.log should tell you why it fails. Try to point
BOOST_DIR to where your Boost sources are located and then rebuild DOLFIN.
Please also include the complete simula_scons.log and not just the tail.

Johannes

---

From: Max Novelli <[email-masked]>
Date: Thu, 30 Jul 2009 17:25:45 -0400

Johannes

I installed fedora rpm for boost and I got a little further.
Now I get :

....
Checking for boost... yes
Checking for libxml-2.0... yes
Resolving compiler... done
Error: Unknown dependency package: ufc-1

dolfin/scons/simula_scons.log si the following:
=================== dolfin log ===================
2009-07-30 17:17:06.409790
Using simula_scons from: 
/home/nitrosx/installs/fenics/src/dolfin/scons/simula-scons/simula_scons/__init__.pyc
A pkg-config generator for 'ufc' couldn't be found, consider creating a 
pkg-config entry ('ufc-1.pc') manually
Unable to find the location of UMFPACK. Consider setting the UMFPACK_DIR 
variable.
Unable to find the location of AMD. Consider setting the AMD_DIR variable.
resolveCompiler: No pkg-config generator for package 'gts'. Assuming Ok.

I checked and ufc-1.pc is under build/lib64/python2.5/site-packages/.
Also, I see that soem packages have been installed under lib (32bits) 
and some under lib64.
Do you think that this could be an issue?

Do fenics tools compile under 64bits? and do they compile 63 bits or 32 
bits?

Thank you
MAx

Email: [email-masked]

Phone: +1.412.624-6898
LRDC
Suite 718
3939 O'Hara Street
Pittsburgh, PA 15260

Phone: +1.412.586.9251
Oxford Building
Suite 450, Room 461
3501 Forbes Avenue
Pittsburgh, PA 15213

---

From: "Johannes Ring" <[email-masked]>
Date: Fri, 31 Jul 2009 12:11:40 +0200

> =================== dolfin log ===================

This is not the right place for ufc-1.pc. I have no idea how it got there
but normally it should have been placed under 'build/lib/pkgconfig' or
'build/lib64/pkgconfig' if 'build' is your installation prefix. One of
these paths must be added to PKG_CONFIG_PATH in order for pkg-config to
find ufc-1.pc.

> Do you think that this could be an issue?

No, just make sure that lib64/pkg-config (if it exists) is in
PKG_CONFIG_PATH and it should be fine.

> Do fenics tools compile under 64bits? and do they compile 63 bits or 32

Yes, FEniCS compiles fine on 64 bit platforms.

Johannes

---

From: Max Novelli <[email-masked]>
Date: Fri, 31 Jul 2009 11:52:15 -0400

Johannes

I checked and ufc-1.pc is located under build/lib/pkgconfig too.

I configured PKG_CONFIG_PATH to point to the right place, but no luck!!

If you have any suggestion, I will really appreciate.

Thank you
Max

Email: [email-masked]

Phone: +1.412.624-6898
LRDC
Suite 718
3939 O'Hara Street
Pittsburgh, PA 15260

Phone: +1.412.586.9251
Oxford Building
Suite 450, Room 461
3501 Forbes Avenue
Pittsburgh, PA 15213