Subject: [Dorsal-dev] Dorsal Mac OS Tiger: Error fetching mt14

From: Aron Wahlberg <[email-masked]>
Date: Wed, 18 Feb 2009 18:11:06 +0100

While running ./dorsal I get the error message in the excerpt below.   
Why doesn't it find the command svn? What is exit status 127? Why  
does it fail? What to do?

I have followed the recommendation to run make check, and some things  
happened, but the same problem remains.

Aron

##############excerpt############################
...
...

+-------------------------------------------------------------+
| CAUTION:                                                    |
|                                                             |
| If you have not already run "make check", then we strongly  |
| recommend you do so.                                        |
|                                                             |
| GMP has been carefully tested by its authors, but compilers |
| are all too often released with serious bugs.  GMP tends to |
| explore interesting corners in compilers and has hit bugs   |
| on quite a few occasions.                                   |
|                                                             |
+-------------------------------------------------------------+

Fetching mtl4
./dorsal.sh: line 68: svn: command not found
Failure with exit status: 127
Exit message: Error fetching mtl4.
bash-3.2$ make check
make: *** No rule to make target `check'.  Stop.
bash-3.2$ pwd
/Applications/FENICS/Dorsal/dorsal-d99bc4183a94
bash-3.2$
#######################################################

---

From: Anders Logg <[email-masked]>
Date: Wed, 18 Feb 2009 18:13:25 +0100

svn is the command for Subversion which is needed to download the
source to MTL4. You need to install Subversion for this to work.

I guess it's in Fink?

-- 
Anders

On Wed, Feb 18, 2009 at 06:11:06PM +0100, Aron Wahlberg wrote:
> While running ./dorsal I get the error message in the excerpt below.  Why
> doesn't it find the command svn? What is exit status 127? Why does it fail?
> What to do?
> 
> I have followed the recommendation to run make check, and some things happened,
> but the same problem remains.
> 
> Aron
> 
> 

> _______________________________________________
> Dorsal-dev mailing list
> [email-masked]
> http://fenics.org/mailman/listinfo/dorsal-dev

---

From: Harish Narayanan <[email-masked]>
Date: Wed, 18 Feb 2009 19:28:27 +0100

Aron Wahlberg wrote:
>  Why doesn't it find the command svn? What is exit status 127? Why does
> it fail? What to do?
> 

fink install svn

(You're keeping a list of all the changes/additional instructions you've
needed for Tiger, yes?)

Harish

---

From: Aron Wahlberg <[email-masked]>
Date: Thu, 19 Feb 2009 15:15:33 +0100

Despite the installation of svn (fink install svn), I still get the  
same error. The installation seemed to go well. Do I need to update  
something before running ./dorsal again? How?

The list is being updated all along :)

Aron

18 feb 2009 kl. 19.28 skrev Harish Narayanan:

>> does

---

From: Harish Narayanan <[email-masked]>
Date: Thu, 19 Feb 2009 16:02:22 +0100

> The list is being updated all along :)

I don't see why it is failing now. Try the following:

1. Do the usual 'locate's and 'find's and such and try to find out if
fink installed svn under a slightly different name. (Again, to not
conflict with svn which exists on Leopard.)

2. Or remove mtl from packages/tiger.package as it is not essential.

Rerun dorsal.sh

Harish