Subject: [Dorsal-dev] [HG dorsal] Updated GMP since DOLFIN seems to require it.

From: [email-masked] (Dorsal)
Date: Wed, 27 May 2009 12:05:24 +0200 (CEST)

One or more new changesets pushed to the primary dorsal repository.
A short summary of the last three changesets is included below.

changeset:   199:dbe4479c9020868cd5767a4768a09edd5f16e34f
tag:         tip
user:        Harish Narayanan <[email-masked]>
date:        Wed May 27 12:05:09 2009 +0200
files:       packages/gmp.package
description:
Updated GMP since DOLFIN seems to require it.

changeset:   198:782cbd5d32d044e5c73cc8781e98b3e7a1265501
user:        Harish Narayanan <[email-masked]>
date:        Mon May 25 16:01:21 2009 +0200
files:       packages/dolfin.package platforms/leopard.platform
description:
I think I have fixed compilation on leopard with recent versions of everything, including gcc4.4. and boost_program_options

changeset:   197:078338edb7de8d15467603f5bb9a27723d11ba64
user:        Harish Narayanan <[email-masked]>
date:        Mon May 25 15:57:49 2009 +0200
files:       packages/trilinos.package
description:
Automated patching of trilinos for gcc4.4

----------------------------------------------------------------------
For more details, visit http://www.fenics.org/dev/dorsal

---

From: Harish Narayanan <[email-masked]>
Date: Wed, 27 May 2009 12:06:36 +0200

> Updated GMP since DOLFIN seems to require it.

With this changeset, both stable and unstable builds work out of the box
on Leopard. (Brave) people on other platforms could try their luck as well.

Harish

---

From: Joachim Berdal Haga <[email-masked]>
Date: Fri, 29 May 2009 12:32:25 +0200

I tried on a freshly-installed jaunty, but petsc wouldn't compile (or rather, 
configure failed).

This because (with the recommended packages) there is no liblapack.so in 
/usr/lib, only liblapack-3.so and other "specialised" ones.

There is however a liblapack.so in /usr/lib/atlas, and when passing 
--with-blas-lapack-dir=/usr/lib/atlas to $PETSC/configure, it works.

I don't know which package is responsible for creating the symlink 
/usr/lib/liblapack.so, and I don't have the time to follow up on this now. Just 
thought I'd let you know.

-j.

Harish Narayanan wrote:
> _______________________________________________
> Dorsal-dev mailing list
> [email-masked]
> http://fenics.org/mailman/listinfo/dorsal-dev

---

From: Harish Narayanan <[email-masked]>
Date: Fri, 29 May 2009 12:36:28 +0200

Joachim Berdal Haga wrote:
> I tried on a freshly-installed jaunty, but petsc wouldn't compile (or
> rather, configure failed).
> 
> /usr/lib/liblapack.so, and I don't have the time to follow up on this
> now. Just thought I'd let you know.

I'll look into this. I think Anders has it working on Jaunty, and so we
can figure out what works and what does not.

Harish

---

From: Ilmar Wilbers <[email-masked]>
Date: Fri, 29 May 2009 12:48:06 +0200

I got it working as well (with Jaunty).

ilmar

---

From: Joachim Berdal Haga <[email-masked]>
Date: Fri, 29 May 2009 12:48:45 +0200

>> rather, configure failed).

Additionally, it seems that a fortran compiler is required for petsc to compile 
hypre. Options: (a) add gfortran (or similar) to prerequisites list, or (b) drop 
hypre. I guess (a)? I know gfortran is available on at least jaunty, intrepid, 
sid and lenny.

-j.

---

From: Ilmar Wilbers <[email-masked]>
Date: Fri, 29 May 2009 12:51:27 +0200

Does it work to disable Fortran support when configureing PETSc? (
--with-fc=0).

ilmar

---

From: Joachim Berdal Haga <[email-masked]>
Date: Fri, 29 May 2009 12:52:58 +0200

> I got it working as well (with Jaunty).

Do you have /usr/lib/liblapack.so? If so, do you know how it got there? Do any 
of the following say anything useful about it maybe?

dpkg -S /usr/lib/liblapack.so
update-alternatives --display liblapack.so
ldconfig -v 2>/dev/null | grep liblapack.so

-j

---

From: Joachim Berdal Haga <[email-masked]>
Date: Fri, 29 May 2009 12:55:32 +0200

> Does it work to disable Fortran support when configureing PETSc? (

Nope, I still get: "Error: Hypre requires Fortran compiler"

-j

---

From: Harish Narayanan <[email-masked]>
Date: Fri, 29 May 2009 13:03:34 +0200

Joachim Berdal Haga wrote:
> Additionally, it seems that a fortran compiler is required for petsc to
> compile hypre. Options: (a) add gfortran (or similar) to prerequisites
> list, or (b) drop hypre. I guess (a)? I know gfortran is available on at
> least jaunty, intrepid, sid and lenny.

Add gfortran.

Harish

---

From: Ilmar Wilbers <[email-masked]>
Date: Fri, 29 May 2009 13:13:51 +0200

dpkg -S /usr/lib/liblapack.so
liblapack-dev: /usr/lib/liblapack.so

ilmar

Joachim Berdal Haga wrote:
> Do you have /usr/lib/liblapack.so? If so, do you know how it got 
> there? Do any of the following say anything useful about it maybe?
>

---

From: Joachim Berdal Haga <[email-masked]>
Date: Fri, 29 May 2009 13:29:19 +0200

> liblapack-dev: /usr/lib/liblapack.so

Ok; so it links with the generic lapack instead of the atlas one. Same for blas, 
I guess.

   You reach a fork in the road. There is a signpost here. To the east,
   the sign reads: "Simplicity, pop. 7 1/2". To the west, it reads:
   "Performanceville".

   Which way do you want to go?

So we should either add liblapack-dev to prerequisites, or add a 
--with-blas-lapack-dir=/usr/lib/atlas to the petsc builds for debian-based 
platforms.
(Or convince debian/ubuntu to put liblapack into the alternatives system, but 
that won't help for legacy platforms.)

-j.

---

From: Harish Narayanan <[email-masked]>
Date: Fri, 29 May 2009 13:31:38 +0200

Joachim Berdal Haga wrote:
> Ok; so it links with the generic lapack instead of the atlas one. Same
> for blas, I guess.
> 

Pick the simple variant that has a reasonable chance of working.

If someone knows enough to care, they will know enough to change things
themselves.

Harish

---

From: Ilmar Wilbers <[email-masked]>
Date: Fri, 29 May 2009 13:33:30 +0200

Talking about speed, why do we not build PETSc with UMFPACK? According 
to Johannes the DOLFIN demos went a lot faster with UMFPACK 
(libsuitesparse).

ilmar

Joachim Berdal Haga wrote:
> --with-blas-lapack-dir=/usr/lib/atlas to the petsc builds for 
> debian-based platforms.
> (Or convince debian/ubuntu to put liblapack into the alternatives 
> system, but that won't help for legacy platforms.)
>
> -j.
>

---

From: Joachim Berdal Haga <[email-masked]>
Date: Fri, 29 May 2009 13:46:25 +0200

> to Johannes the DOLFIN demos went a lot faster with UMFPACK 

I'll leave that to the experts ;-)

Is it just a configuration flag to petsc, or more involved?

-j.

---

From: Ilmar Wilbers <[email-masked]>
Date: Fri, 29 May 2009 13:49:04 +0200

I meant adding support for UMFPACK when configureing PETSc:
  --with-umfpack=<bool>
  --with-umfpack-dir=<dir>

ilmar

Harish Narayanan wrote:
> I don't understand your question. PETSc is not built with UMFPACK
> because UMFPACK is available in libsuitesparse (which is available as a
> package in many platforms).
>
> One can easily pick petsc or umfpack during runtime.
>
> Harish
>

---

From: Harish Narayanan <[email-masked]>
Date: Fri, 29 May 2009 13:51:53 +0200

> I meant adding support for UMFPACK when configureing PETSc:

No real reason. (Apart from the fact that it will take time to compile,
and umfpack is available on most platforms through libsuitesparse).
> 
> ilmar
> 
> Harish Narayanan wrote:
>> Ilmar Wilbers wrote:
>>  
>>> Talking about speed, why do we not build PETSc with UMFPACK?
>>> According to Johannes the DOLFIN demos went a lot faster with UMFPACK
>>> (libsuitesparse).
>>>     
>>

---

From: Anders Logg <[email-masked]>
Date: Fri, 29 May 2009 20:30:19 +0200

> > least jaunty, intrepid, sid and lenny.

Yes, Fortran is needed to build PETSc with Hypre (I've always needed
it to build at least).

-- 
Anders