Subject: [Dorsal-dev] Error in FEniCS installation: PETSC

From: Alfredo Raul Carella <[email-masked]>
Date: Tue, 16 Jun 2009 09:50:00 +0200

Hi,

I get this error when using Dorsal to install FEniCS in my Linux Debian 5 (Lenny) laptop Dell XPSM1530:

 ERROR: PETSC_DIR enviroment variable is not valid
 /home/alfredo/Work/FEniCS/slepc-3.0.0-p3/conf/slepc_common_variables:1: /usr/lib/petsc/conf/variables: No such file or directory
 /home/alfredo/Work/FEniCS/slepc-3.0.0-p3/conf/slepc_common_variables:2: /home/alfredo/Work/FEniCS/slepc-3.0.0-p3/linux-gnu-c-opt/conf/slepcvariables: No such file or directory
 /home/alfredo/Work/FEniCS/slepc-3.0.0-p3/conf/slepc_common_rules:1: /usr/lib/petsc/conf/rules: No such file or directory
 /home/alfredo/Work/FEniCS/slepc-3.0.0-p3/conf/slepc_common:15: /usr/lib/petsc/conf/test: No such file or directory
 make: *** No rule to make target `/usr/lib/petsc/conf/test'.  Stop.
 Failure with exit status: 2
 Exit message: There was a problem building slepc-3.0.0-p3.

I was told what I need to do is install petsc via dorsal, which should be a small change, but I don't know how to do it.
Does anybody know hoy to fix this? Thanks in advance for your help! :-)

Alfredo

---

From: Anders Logg <[email-masked]>
Date: Tue, 16 Jun 2009 11:33:33 +0200

> Does anybody know hoy to fix this? Thanks in advance for your help! :-)

Just add on the line before slepc in platforms/lenny.platform:

PACKAGES=(
petsc
slepc
mtl
trilinos
fiat
ferari
ufc
ufl
ffc
syfi
viper
instant
dolfin
)

Make sure to remove the installation of Trilinos before rebuilding (or
all of it) since it will otherwise break.

Harish: Should there be a "pre-install" hook of some kind for packages so that
Trilinos can be automatically removed before rebuilding?

-- 
Anders