Subject: [FEniCS-apps] [HG CBC.Solve] Moved a few things around. Details will arrive shortly.

From: [email-masked] (FEniCS Apps)
Date: Sat, 14 Nov 2009 18:18:47 +0100 (CET)

One or more new changesets pushed to the primary cbc.solve repository.
A short summary of the last three changesets is included below.

changeset:   39:344a81595e5a
tag:         tip
user:        Harish Narayanan <[email-masked]>
date:        Sat Nov 14 18:18:21 2009 +0100
files:       cbc/twist/__init__.py cbc/twist/equation_solvers.py cbc/twist/hyperelasticity_problems.py cbc/twist/problem_definitions.py cbc/twist/solution_algorithms.py demo/twist/release.py demo/twist/twist.py demo/twist/uniaxial-tension.py
description:
Moved a few things around. Details will arrive shortly.

changeset:   38:46490a0e1cb8
user:        Anders Logg <[email-masked]>
date:        Thu Nov 12 14:51:35 2009 +0100
files:       cbc/flow/problems.py cbc/flow/solvers.py
description:
Add interface for specifying a mesh velocity for ALE formulations

changeset:   37:4fbc10380f3b
user:        Anders Logg <[email-masked]>
date:        Thu Nov 12 13:51:47 2009 +0100
files:       cbc/common/CBCSolver.py cbc/flow/solvers.py
description:
Add simple printing of progress to solver base class, used in Navier Stokes solver.

----------------------------------------------------------------------
For more details, visit http://www.fenics.org/apps/cbc.solve

---

From: Harish Narayanan <[email-masked]>
Date: Sat, 14 Nov 2009 18:22:01 +0100

> Moved a few things around. Details will arrive shortly.

hyperelasticity_problems -> problem_definitions
equation_solvers -> solution_algorithms

(Static)HyperElasticityProblem -> (Static)HyperElasticity

The twist tree now looks like:

twist/
problem_definitions.py (HyperElasticity, (ViscoElasticity), ...)
solution_algorithms.py (HyperElasticitySolver, ...)
material_models.py (neoHookean, MooneyRivlin, Biderman, ...)
kinematics.py (Strain measures, Transformations between configurations, ...)

I am happy with this.

Harish

---

From: Anders Logg <[email-masked]>
Date: Sat, 14 Nov 2009 18:29:28 +0100

> equation_solvers -> solution_algorithms

Sounds good.

> (Static)HyperElasticityProblem -> (Static)HyperElasticity

Sounds good.

> kinematics.py (Strain measures, Transformations between configurations, ...)

We can do the corresponding modifications in CBC.Flow. It would at
least make sense to have problem_definitions.py and
solution_algorithms.py. At some point we might also consider adding
material_models.py.

Feel free to make the corresponding changes in CBC.Flow. Or I can do
it next time I edit the code.

--
Anders