Subject: [FEniCS-apps] new-app.tar

From: Kristian Oelgaard <[email-masked]>
Date: Fri, 10 Jul 2009 13:28:16 +0200

Hi,

I've created a tarball of useful files when setting up a new application for
FEniCS Apps.

I put a link on http://www.fenics.org/wiki/FEniCS_Apps in the Management
section.
http://www.fenics.org/pub/software/fenics-apps/new-app/ where new-app.tar is
located.

Have a look and feel free to make comments/adjustments.

Kristian

---

From: "Garth N. Wells" <[email-masked]>
Date: Sat, 11 Jul 2009 12:01:56 +0100

> Have a look and feel free to make comments/adjustments.

Eventually it would be nice to add a framework for a solver developer to 
create a Python module from their C++ code via SWIG.

Garth

> Kristian
> _______________________________________________
> FEniCS-Apps mailing list
> [email-masked]
> http://fenics.org/mailman/listinfo/fenics-apps

---

From: Kristian Oelgaard <[email-masked]>
Date: Sat, 11 Jul 2009 15:09:31 +0200

> create a Python module from their C++ code via SWIG.

OK, we could do that. There is also an item called:

User solvers
* Code and build system template for users to create solvers that use the DOLFIN
library

under 'Other planned features' on the DOLFIN road map. Could this collection of
files be considered to cover that?

Kristian

---

From: Johan Hake <[email-masked]>
Date: Sat, 11 Jul 2009 23:50:18 +0200

On Saturday 11 July 2009 15:09:31 Kristian Oelgaard wrote:
> > > I've created a tarball of useful files when setting up a new
> > > application
> >
> > for
> >
> > > FEniCS Apps.
> > >
> > > I put a link on http://www.fenics.org/wiki/FEniCS_Apps in the
> > > Management section.
> > > http://www.fenics.org/pub/software/fenics-apps/new-app/ where
> > > new-app.tar
> >
> > is
> >
> > > located.
> > >

This should be fairly straight forward. A small wrapper of instant should do 
the trick.

I can look at it after my vacation that starts .... well it has already 
started!

:)

johan

> * Code and build system template for users to create solvers that use the
> DOLFIN library
>
> under 'Other planned features' on the DOLFIN road map. Could this
> collection of files be considered to cover that?
>
> Kristian
>
> > Garth
> >
> > > Kristian