Subject: [FEniCS-apps] [HG CBC.Solve] Remove static NavierStokes problem and solver (not implemented anyway).

From: [email-masked] (FEniCS Apps)
Date: Thu, 12 Nov 2009 13:27:33 +0100 (CET)

One or more new changesets pushed to the primary cbc.solve repository.
A short summary of the last three changesets is included below.

changeset:   36:0475542fe96b
tag:         tip
user:        Anders Logg <[email-masked]>
date:        Thu Nov 12 13:25:24 2009 +0100
files:       cbc/flow/problems.py cbc/flow/solvers.py demo/flow/channel.py demo/flow/drivencavity.py
description:
Remove static NavierStokes problem and solver (not implemented anyway).
Also renamed NavierStokesProblem --> NavierStokes.

Perhaps the same can be done for hyperelasticity?

Looks a bit nicer:

  class DrivenCavity(NavierStokes):

      ...

changeset:   35:732a3ef051d1
user:        Harish Narayanan <[email-masked]>
date:        Thu Nov 12 02:56:08 2009 +0100
files:       cbc/flow/problems.py sandbox/fsi/fsi.py
description:
The finite deformation FSI problem is getting closer

changeset:   34:9e85b39331ef
user:        Harish Narayanan <[email-masked]>
date:        Thu Nov 12 01:52:14 2009 +0100
files:       cbc/twist/kinematics.py sandbox/fsi/fsi.py
description:
Added the Piola transform (and its inverse) to map back and forth between the fluid and solid stresses living on different configurations

----------------------------------------------------------------------
For more details, visit http://www.fenics.org/apps/cbc.solve

---

From: Harish Narayanan <[email-masked]>
Date: Thu, 12 Nov 2009 14:13:54 +0100

>   class DrivenCavity(NavierStokes):

Yea, and will do.

Harish