Subject: [FEniCS-apps] [HG Unicorn-unstable] Attempt at fixing the stabilization functions in parallel

From: [email-masked] (FEniCS Apps)
Date: Mon, 17 Aug 2009 16:44:42 +0200 (CEST)

One or more new changesets pushed to the primary unicorn-unstable repository.
A short summary of the last three changesets is included below.

changeset:   245:33bc748691d9869793a613ff02257c4dca268c35
tag:         tip
user:        Peter Brune <[email-masked]>
date:        Mon Aug 17 09:44:16 2009 -0500
files:       SConstruct src/function/StabilizationFunctions.cpp src/function/StabilizationFunctions.h ucsolver/icns/FormFactory.cpp ucsolver/icns/NSESolver.cpp ucsolver/icns/cylinder/.sconsign.dblite ucsolver/icns/unicorn/FormFactory.h ucsolver/icns/unicorn/NSEContinuity2D.h ucsolver/icns/unicorn/NSEContinuity2D.ufl ucsolver/icns/unicorn/NSEDualContinuity2D.h ucsolver/icns/unicorn/NSEDualContinuity2D.ufl ucsolver/icns/unicorn/NSEDualMomentum2D.h ucsolver/icns/unicorn/NSEDualMomentum2D.ufl ucsolver/icns/unicorn/NSEMomentum2D.h ucsolver/icns/unicorn/NSEMomentum2D.ufl
description:
Attempt at fixing the stabilization functions in parallel

changeset:   244:4e77e3b580840ae11f6799db806caaefe3f9ff9c
user:        "Johan Jansson <[email-masked]>"
date:        Mon Aug 17 13:15:31 2009 +0200
files:       ucsolver/icns/FormFactory.cpp ucsolver/icns/NSESolver.cpp ucsolver/icns/unicorn/FormFactory.h ucsolver/icns/unicorn/NSEDualContinuity2D.h ucsolver/icns/unicorn/NSEDualContinuity2D.ufl ucsolver/icns/unicorn/NSEDualMomentum2D.h ucsolver/icns/unicorn/NSEDualMomentum2D.ufl
description:
Try to minimize manual initialization of coefficients with
e.g. function space, DOLFIN already knows this from the form. Manual
initialization still kept for special functions.

Verified as working in serial, not in parallel yet.

changeset:   243:4286737b27e34c8004685d86c3cedc336243755e
user:        Niclas Jansson <[email-masked]>
date:        Sun Aug 16 22:21:03 2009 +0200
files:       SConstruct src/fem/TimeDependentPDE.cpp src/fem/TimeDependentPDE.h ucsolver/cns/bench/SConstruct ucsolver/cns/shock-tube/SConstruct ucsolver/fsi/bench2D/SConstruct ucsolver/fsi/example3D/SConstruct ucsolver/fsi/flag3D/SConstruct ucsolver/fsi/test3D/SConstruct ucsolver/icns-newton/cube/SConstruct ucsolver/icns-newton/cylinder/SConstruct ucsolver/icns/bench2D3D/SConstruct ucsolver/icns/cube/SConstruct ucsolver/icns/cylinder/SConstruct ucsolver/icns/quicktest/SConstruct ucsolver/icns/wing/SConstruct ucsolver/le/example/SConstruct
description:
Cleanup build system, add dolfin.pc as dep, in unicorn.pc

----------------------------------------------------------------------
For more details, visit http://www.fenics.org/apps/unicorn-unstable

---

From: Peter Brune <[email-masked]>
Date: Mon, 17 Aug 2009 10:08:19 -0500

I'm doing the right thing right now... don't worry.

On Mon, Aug 17, 2009 at 9:44 AM, FEniCS Apps <[email-masked]> wrote:

> files:       SConstruct src/function/StabilizationFunctions.cpp
> src/function/StabilizationFunctions.h ucsolver/icns/FormFactory.cpp
> ucsolver/icns/NSESolver.cpp ucsolver/icns/cylinder/.sconsign.dblite
> ucsolver/icns/unicorn/FormFactory.h ucsolver/icns/unicorn/NSEContinuity2D.h
> ucsolver/icns/unicorn/NSEContinuity2D.ufl
> ucsolver/icns/unicorn/NSEDualContinuity2D.h
> ucsolver/icns/unicorn/NSEDualContinuity2D.ufl
> ucsolver/icns/unicorn/NSEDualMomentum2D.h
> ucsolver/icns/unicorn/NSEDualMomentum2D.ufl
> ucsolver/icns/unicorn/NSEMomentum2D.h
> ucsolver/icns/unicorn/NSEMomentum2D.ufl
> description:
> files:       ucsolver/icns/FormFactory.cpp ucsolver/icns/NSESolver.cpp
> ucsolver/icns/unicorn/FormFactory.h
> ucsolver/icns/unicorn/NSEDualContinuity2D.h
> ucsolver/icns/unicorn/NSEDualContinuity2D.ufl
> ucsolver/icns/unicorn/NSEDualMomentum2D.h
> ucsolver/icns/unicorn/NSEDualMomentum2D.ufl
> description:
> files:       SConstruct src/fem/TimeDependentPDE.cpp
> src/fem/TimeDependentPDE.h ucsolver/cns/bench/SConstruct
> ucsolver/cns/shock-tube/SConstruct ucsolver/fsi/bench2D/SConstruct
> ucsolver/fsi/example3D/SConstruct ucsolver/fsi/flag3D/SConstruct
> ucsolver/fsi/test3D/SConstruct ucsolver/icns-newton/cube/SConstruct
> ucsolver/icns-newton/cylinder/SConstruct ucsolver/icns/bench2D3D/SConstruct
> ucsolver/icns/cube/SConstruct ucsolver/icns/cylinder/SConstruct
> ucsolver/icns/quicktest/SConstruct ucsolver/icns/wing/SConstruct
> ucsolver/le/example/SConstruct
> description:

---

From: Peter Brune <[email-masked]>
Date: Mon, 17 Aug 2009 10:09:05 -0500

The Error Estimate code needs this too (there's a HUGE fixme).  I'll do the
same thing twice.

On Mon, Aug 17, 2009 at 10:08 AM, Peter Brune <[email-masked]> wrote:

> On Mon, Aug 17, 2009 at 9:44 AM, FEniCS Apps <[email-masked]>wrote:
>