Subject: Re: [FEniCS-dev] [DOLFIN-dev] ImportError: No module named cpp

From: "Garth N. Wells" <[email-masked]>
Date: Mon, 16 Feb 2009 12:12:15 +0000

Aron Wahlberg wrote:
> I have downloaded all modules from FEniCS this week and installed
> everything. When trying to run some of the python demo-scripts, I get
> an error message "ImportError: No module named cpp".
> Any ideas of what is wrong?
> 
> Regards,
> Aron
> 
> 
> These are the version of the modules I have:
> 
> cln-1.2.2
> dolfin-0.9.0
> FErari-0.0.2
> ffc-0.6.0
> FIAT-0.3.4
> ginac-1.4.4
> instant-0.9.5
> puffin-0.1.6
> syfi-0.5.1
> ufc-1.1
> viper-0.4.2
> 
> Example of a run of a demo-script:
> 
>  > python fem/simple/python/demo.py
> /usr/local/lib/python2.6/site-packages/ffc/compiler/language/index.py:9:
> DeprecationWarning: the sets module is deprecated
>  from sets import Set
> Traceback (most recent call last):
>  File "fem/simple/python/demo.py", line 12, in <module>
>    from dolfin import *
>  File "/usr/local/lib/python2.6/site-packages/dolfin/__init__.py",
> line 16, in <module>
>    from assemble import *
>  File "/usr/local/lib/python2.6/site-packages/dolfin/assemble.py",
> line 25, in <module>
>    import cpp
> ImportError: No module named cpp
>

It may be unrelated, but I don't know if any of the FEniCS components 
have been tested with Python 2.6.

Garth

> 
> ------------------------------------------------------------------------
> 
> _______________________________________________
> DOLFIN-dev mailing list
> [email-masked]
> http://www.fenics.org/mailman/listinfo/dolfin-dev

---

From: Harish Narayanan <[email-masked]>
Date: Mon, 16 Feb 2009 15:10:36 +0100

> have been tested with Python 2.6.

I've used them on a machine with with Python 2.6, and as of a few weeks
ago (when I last tried things) they work. A few deprecated function
warnings pop up, but things work.

Harish