Subject: [fenics-dev] Sieve

From: "tomtzigt" <[email-masked]>
Date: Thu, 8 Jun 2006 14:13:39 -0400

Any word on the Sieve and its integration into FEniCS yet?

Theo

---

From: Anders Logg <[email-masked]>
Date: Wed, 7 Jun 2006 22:33:19 +0200

> Any word on the Sieve and its integration into FEniCS yet?

Not that I have heard, but I'm working on a much improved rewrite of
the DOLFIN mesh library that will most likely be merged into the DOLFIN
main tree within a week or two.

/Anders

---

From: Anders Logg <[email-masked]>
Date: Fri, 9 Jun 2006 20:36:00 +0200

On Fri, Jun 09, 2006 at 11:24:00AM -0500, Matthew Knepley wrote:
> On 6/7/06, Anders Logg <[email-masked]> wrote:
> 
> Cool, you have to tell me what's in it. So for the Sieve stuff, it now appears
> to be working in a visco-elastic-plastic post-rupture easrthquake code
> called PyLith (formerly Tecton). Dmitry is cleaning up the Field
> representation,
> but basically the alpha now has everything working.

It's not as fancy as Sieve. It's a light-weight minimal and very
simple implementation of a dimension-independent storage for mesh
entities and connectivity. Our current mesh library is used here at
Simula and they need something simple and fast. I haven't benchmarked
the new mesh yet but I suspect orders of magnitude speedup (for
computation of connectivity and iteration over entities).

> Petsc just switched to Mercurial, and you can pull the latest version from
> 
>     hg clone old-http://www-unix.mcs.anl.gov/~petsc/BuildSystem
>     hg clone old-http://www-unix.mcs.anl.gov/~petsc/petsc-dev
>
> and look at the examples in src/dm/mesh/examples/tutorials first, and then
> there are some preliminary KSP examples. Peter Brune (student of Rob Kirby)
> will be here this summer helping make unstructured multigrid work in this
> framework.
> 
>    Matt

Cool. How's Mercurial working out so far? Have you had any problems
with it?

/Anders

---

From: Anders Logg <[email-masked]>
Date: Fri, 9 Jun 2006 21:01:56 +0200

On Fri, Jun 09, 2006 at 01:43:27PM -0500, Matthew Knepley wrote:
> On 6/9/06, Anders Logg <[email-masked]> wrote:
> 
> I like it. Its not as nice as BK, but workable. The problems are almost all
> related to lack of bundling of operations. For instance, I always have to
> do:
> 
>   hg pull
>   hg update -m
>   hg commit
> 
> instead of the BK model where it all happens correctly in sequence.
> 
>    Matt

I often end up with

    hg commit
    hg push default
    Aargh, someone beat me to it so I need to pull
    hg undo
    hg pull
    hg update
    Aargh, forgot -m
    hg update -m
    hg commit
    hg push default

:-)

/Anders

---

From: "tomtzigt" <[email-masked]>
Date: Fri, 9 Jun 2006 15:22:20 -0400

And from left field..... I love Perforce!

Perforce branch and merge is like a walk in the park.... Interactive
resolves on demand too. Worth it even if you have to pay for it. Free for
open source.

I have PETSc and FEniCS as code drops in the Perforce tree and a build
script from the tar ball so that all can pull from Perforce and get all the
software they need. Both PETSc and FEniCS are solid so we don't need to do
any mods in our own sccs.

Theo

P.S. I do not work for Perforce Software and do not have an affiliation or
stock position. I do like them though...

-----Original Message-----
From: Anders Logg [mailto:[email-masked]] 
Sent: Friday, June 09, 2006 3:02 PM
To: Matthew Knepley
Cc: Anders Logg; tomtzigt; Discussion of FEniCS development
Subject: Re: [fenics-dev] Sieve

I often end up with

    hg commit
    hg push default

:-)

/Anders

---

From: Anders Logg <[email-masked]>
Date: Fri, 9 Jun 2006 21:35:18 +0200

I haven't seen it, but "free for open source" sounds dangerous...

/Anders