Subject: [FEniCS-dev] Release names

From: Anders Logg <[email-masked]>
Date: Tue, 7 Apr 2009 20:20:11 +0200

Yes, good idea! How about using first names?

Starting with A, should this one be Albert? Or are there other
options?

We also need adjectives (just like Ubuntu). What should it be?

How about we make the first release

  Awesome Albert (FEniCS 9.04)

?

We also need to prepare a list of names for future releases.
Here are two I want to include:

  Bouncing Boris (Galerkin)
  Gleaming Gottfried (Wilhelm Leibniz)

Other suggestions?

-- 
Anders

On Tue, Apr 07, 2009 at 08:05:12PM +0200, Martin Sandve Alnæs wrote:
> I think so. Maybe 0.x for features and 0.x.y for bugfixes only?
> 
> I like the FEniCS 9.04 idea. Maybe we can have release
> names as well, from famous scientists or something :)
> 
> Martin
> 
> 
> 
> On Tue, Apr 7, 2009 at 7:51 PM, Anders Logg <[email-masked]> wrote:
> > Nice! :-)
> >
> > Will there be 0.3, 0.4, 0.5, 0.6, etc on the way to 1.0?
> >
> >
> >
> > On Tue, Apr 07, 2009 at 07:34:30PM +0200, Martin Sandve Alnæs wrote:
> >> 0.2.0 [2009-04-07]
> >>  - Initial release of UFL.
> >> 0.1.0 [...]
> >>  - Unreleased development versions of UFL.
> >>
> >> Martin
> >> _______________________________________________
> >> UFL-dev mailing list
> >> [email-masked]
> >> http://fenics.org/mailman/listinfo/ufl-dev
> >
> > -----BEGIN PGP SIGNATURE-----
> > Version: GnuPG v1.4.9 (GNU/Linux)
> >
> > iEYEARECAAYFAknbkosACgkQTuwUCDsYZdFMCwCdGm7XGHWtUGi5hJLMolcU9nZy
> > I08An3v頓䋀륄쮛ೡ锦㨹
> > =fdIg
> > -----END PGP SIGNATURE-----
> >
> >

---

From: Robert Kirby <[email-masked]>
Date: Tue, 7 Apr 2009 13:50:00 -0500

"Albert" is already taken in the finite element world, at least in the
feminine form:
http://www.alberta-fem.de/

Is naming a release after the competition a bad form?  I'm sure that the Nth
Ubuntu release will not be "surly sid"

Rob

On Tue, Apr 7, 2009 at 1:20 PM, Anders Logg <[email-masked]> wrote:

> iEYEARECAAYFAknbmVoACgkQTuwUCDsYZdGjtQCbBUqs0SR1HZU5Az5LH57pt2f/
> R/UAnRleAiND+zTZRQseAeAp8tdX/Qdg
> =8Zlj
> FEniCS-dev mailing list
> [email-masked]
> http://www.fenics.org/mailman/listinfo/fenics-dev
>
>

---

From: Anders Logg <[email-masked]>
Date: Tue, 7 Apr 2009 20:56:05 +0200

Yes, perhaps. Other options?

-- 
Anders

On Tue, Apr 07, 2009 at 01:50:00PM -0500, Robert Kirby wrote:
> "Albert" is already taken in the finite element world, at least in the feminine
> form:
>

---

From: Ridgway Scott <[email-masked]>
Date: Tue, 7 Apr 2009 12:53:28 -0700

Albert was not very good at math and not computationally oriented.
von Neumann would make a better analogy.

Ridg

---

From: Anders Logg <[email-masked]>
Date: Tue, 7 Apr 2009 21:55:45 +0200

But that would be a 'J', right?

Or does he have a middle name starting with 'A'?

-- 
Anders

On Tue, Apr 07, 2009 at 12:53:28PM -0700, Ridgway Scott wrote:
>> -- Anders

---

From: Robert Kirby <[email-masked]>
Date: Tue, 7 Apr 2009 15:55:29 -0500

Augustin Cauchy (or Alonzo Church if we want to be more computational)Blaise
Pascal
Carl Friedrich Gauss
David Hilbert
Evariste Galois/Emile Picard (depending on whether we care about "duelity"
or fixed-points ;)

Rob

On Tue, Apr 7, 2009 at 2:55 PM, Anders Logg <[email-masked]> wrote:

> iEYEARECAAYFAknbr8AACgkQTuwUCDsYZdEZCQCfTAVUEHkiZE07a0lo87MVObmm
> GdAAn0VBS4PCcozFiM1vYuNgDFNA2XJQ
> =cVqE

---

From: Ridgway Scott <[email-masked]>
Date: Tue, 7 Apr 2009 16:18:49 -0700

Rob,

are you planning to develop this idea of "duelity theory" further?

Ridg

On Apr 7, 2009, at 1:55 PM, Robert Kirby wrote:

> Augustin Cauchy (or Alonzo Church if we want to be more computational)
> Blaise Pascal
> Carl Friedrich Gauss
> David Hilbert
> Evariste Galois/Emile Picard (depending on whether we care about  
> "duelity" or fixed-points ;)
>
>
>
> Rob
>
>
>

---

From: Robert Kirby <[email-masked]>
Date: Tue, 7 Apr 2009 20:25:36 -0500

Young Evariste's interest in duelity theory took him to a particular fixed
point I would prefer to avoid for the time being,so no thanks.

---

From: Anders Logg <[email-masked]>
Date: Wed, 8 Apr 2009 08:57:59 +0200

Augustin sounds like a good choice then.

Any good adjective to go with that? I like "awesome" so I'll assume
that if no one complains. It is, after all, the most commonly used
adjective in American movies. :-)

I've put up a page for future release names. Please help out to fill
in the blanks. Links can be found here:

  http://www.fenics.org/wiki/Projects

-- 
Anders

On Tue, Apr 07, 2009 at 03:55:29PM -0500, Robert Kirby wrote:
> Evariste Galois/Emile Picard (depending on whether we care about "duelity" or
> fixed-points ;)
> 
> 
> 
> Rob
> 
> 
>

---

From: Robert Kirby <[email-masked]>
Date: Wed, 8 Apr 2009 09:54:55 -0500

In line with the goals of the FEniCS project, I might suggest
"Automatic Augustin"

as a possible alternative.

On Wed, Apr 8, 2009 at 1:57 AM, Anders Logg <[email-masked]> wrote:

> iEYEARECAAYFAkncSvcACgkQTuwUCDsYZdHv1wCeOPoayUlAKTOQFyf2upMTaot5
> n5wAmwZY/RojEtEyddsU5C5iqRkTv9Vx
> =MC9v

---

From: Anders Logg <[email-masked]>
Date: Wed, 8 Apr 2009 22:29:57 +0200

Nice. I've updated the name.

http://www.fenics.org/wiki/FEniCS_2009-04_(Automatic_Augustin)

-- 
Anders

On Wed, Apr 08, 2009 at 09:54:55AM -0500, Robert Kirby wrote:
>     >     > Albert was not very good at math and not computationally oriented.
>     >     > von Neumann would make a better analogy.
>     >     >
>     >     > Ridg
>     >     >
>     >     > On Apr 7, 2009, at 11:20 AM, Anders Logg wrote:
>     >     >
>     >     >> Yes, good idea! How about using first names?
>     >     >>
>     >     >> Starting with A, should this one be Albert? Or are there other
>     >     >> options?
>     >     >>
>     >     >> We also need adjectives (just like Ubuntu). What should it be?
>     >     >>
>     >     >> How about we make the first release
>     >     >>
>     >     >>  Awesome Albert (FEniCS 9.04)
>     >     >>
>     >     >> ?
>     >     >>
>     >     >> We also need to prepare a list of names for future releases.
>     >     >> Here are two I want to include:
>     >     >>
>     >     >>  Bouncing Boris (Galerkin)
>     >     >>  Gleaming Gottfried (Wilhelm Leibniz)
>     >     >>
>     >     >> Other suggestions?
>     >     >>
>     >     >> -- Anders
>     >     >>
>     >     >>
>     >     >> On Tue, Apr 07, 2009 at 08:05:12PM +0200, Martin Sandve Alnæs
>     wrote:
>     >     >>> I think so. Maybe 0.x for features and 0.x.y for bugfixes only?
>     >     >>>
>     >     >>> I like the FEniCS 9.04 idea. Maybe we can have release
>     >     >>> names as well, from famous scientists or something :)
>     >     >>>
>     >     >>> Martin
>     >     >>>
>     >     >>>
>     >     >>>
>     >     >>> On Tue, Apr 7, 2009 at 7:51 PM, Anders Logg <[email-masked]>
>     wrote:
>     >     >>>> Nice! :-)
>     >     >>>>
>     >     >>>> Will there be 0.3, 0.4, 0.5, 0.6, etc on the way to 1.0?
>     >     >>>>
>     >     >>>>
>     >     >>>>
>     >     >>>> On Tue, Apr 07, 2009 at 07:34:30PM +0200, Martin Sandve Alnæs
>     >     >>>> wrote:
>     >     >>>>> 0.2.0 [2009-04-07]
>     >     >>>>>  - Initial release of UFL.
>     >     >>>>> 0.1.0 [...]
>     >     >>>>>  - Unreleased development versions of UFL.
>     >     >>>>>
>     >     >>>>> Martin
>     >     >>>>> _______________________________________________
>     >     >>>>> UFL-dev mailing list
>     >     >>>>> [email-masked]
>     >     >>>>> http://fenics.org/mailman/listinfo/ufl-dev
>     >     >>>>
>     >     >>>> -----BEGIN PGP SIGNATURE-----
>     >     >>>> Version: GnuPG v1.4.9 (GNU/Linux)
>     >     >>>>
>     >     >>>> iEYEARECAAYFAknbkosACgkQTuwUCDsYZdFMCwCdGm7XGHWtUGi5hJLMolcU9nZy
>     >     >>>> I08An3v頓䋀륄쮛ೡ锦㨹
>     >     >>>> =fdIg
>     >     >>>> -----END PGP SIGNATURE-----
>     >     >>>>
>     >     >>>>
>     >     >> _______________________________________________
>     >     >> FEniCS-dev mailing list
>     >     >> [email-masked]
>     >     >> http://www.fenics.org/mailman/listinfo/fenics-dev
>     >     >
>     >