Subject: Re: [FEniCS-dev] [DOLFIN-dev] Bug tracking and feature requests

From: Anders Logg <[email-masked]>
Date: Wed, 2 Sep 2009 20:45:29 +0200

On Wed, Sep 02, 2009 at 03:10:36PM +0100, Garth N. Wells wrote:
> As some of you have already noticed, we have moved to using Launchpad
> for bug tracking and feature planning for DOLFIN and FFC. You can find
> the Launchpad pages at
>
>      https://launchpad.net/dolfin
>      https://launchpad.net/ffc
>
> Launchpad is significantly easier to use and comprehend than Bugzilla,
> and everyone is encouraged to make use of it. The 'DOLFIN Roadmap'
> (http://www.fenics.org/wiki/DOLFIN_road_map) will gradually be moved to
> Blueprints (https://blueprints.launchpad.net/dolfin).
>
> It is likely that other FEniCS components will also make use of
> Launchpad in the future.

I suggest we move all bugs to launchpad and discontinue Bugzilla on
fenics.org. Are there any objections? Is Bugzilla used by any of the
projects?

We only have 21 bugs registered (indicating that Bugzilla has not been
used that much, not that we have only 21 bugs), and most of them are
for DOLFIN. I'll scan the bug list and move the ones I think important
to Launchpad. Feel free to help out. Then we can shut down Bugzilla.

Another issue is if we should direct messages from Launchpad to the
mailing list (dolfin-dev etc). I think we should.

--
Anders

---

From: Ola Skavhaug <[email-masked]>
Date: Thu, 3 Sep 2009 09:58:54 +0200

> mailing list (dolfin-dev etc). I think we should.

I have another question. Should we redirect build/test errors from the
buildbots to Launchpad?

Ola

> --
> Anders
>
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v1.4.9 (GNU/Linux)
>
> iEYEARECAAYFAkqevUgACgkQTuwUCDsYZdEjLQCePPMVeCwGkgzDoTrlndIqX01A
> kBgAn2Iuv5k4x3QdTcFyV2Y6epGRmOYm
> =D/yF
> -----END PGP SIGNATURE-----
>
> _______________________________________________
> DOLFIN-dev mailing list
> [email-masked]
> http://www.fenics.org/mailman/listinfo/dolfin-dev
>
>

-- 
Ola Skavhaug

---

From: Anders Logg <[email-masked]>
Date: Thu, 3 Sep 2009 22:34:54 +0200

> I have another question. Should we redirect build/test errors from the

I don't know, but we could try and see how it works out.

I'm working on notification from launchpad to the mailing lists but
it's a bit tricky since only members may post etc.

--
Anders