Subject: [FEniCS-users] turn off logging

From: Patrick Riesen <[email-masked]>
Date: Thu, 5 Nov 2009 11:22:25 +0100

hello

i would like to suppress any output from dolfin for a moment, so i told 
my newtonsolver

newtonsolver.parameters["report"] = false;

and used

logging(false);

and

set_log_level(0);

but there remains still some output:

Starting Newton solve.
Newton solver finished in 2 iterations and 2 linear solver iterations.

can i get rid of this too, or is there another way of suppressing output 
messages?

thanks in advance :-)

patrick

---

From: Patrick Riesen <[email-masked]>
Date: Thu, 5 Nov 2009 16:37:51 +0100

ok i figured out that

set_log_level(-1)

(should) supresse all, but when "report" is set to true, it still outputs

     Iteration [.....]

but not all the rest. it needs both "report" = false and 
set_log_level(-1) that nothing is output.

patrick

Patrick Riesen wrote:
> _______________________________________________
> FEniCS-users mailing list
> [email-masked]
> http://fenics.org/mailman/listinfo/fenics-users

---

From: Andy Ray Terrel <[email-masked]>
Date: Thu, 5 Nov 2009 10:49:38 -0600

Another way is to do:

logging(false);

-- Andy