Subject: [FEniCS-users] Weird error with dolfin::Function.vector().get()

From: phil marinier <[email-masked]>
Date: Wed, 19 Aug 2009 14:19:12 -0400

This code where I'm having the error is inside a function, so I assumed it would be automaticly cleaned up when it went out of scope. Just to be sure, I explicitly called delete at the end of the function. I still get the same error.

I don't clean up my dolfin::Functions anywhere inside my program because I never use the new command when creating one. Until now I haven't had a problem with doing this. Should I in fact be cleaning up my dolfin::Functions as well? and if so, do I use the delete?

Again, I'm not looking for you to debug my code for me, but the error seems to be inside a Function, and any help is appreciated

Phil

---

From: "Garth N. Wells" <[email-masked]>
Date: Wed, 19 Aug 2009 19:33:22 +0100

Not much we can comment on without a snippet of code.

Garth

phil marinier wrote:
> This code where I'm having the error is inside a function, so I assumed 
> it would be automaticly cleaned up when it went out of scope. Just to be 
> sure, I explicitly called delete at the end of the function. I still get 
> the same error.
> 
> I don't clean up my dolfin::Functions anywhere inside my program because 
> I never use the new command when creating one. Until now I haven't had a 
> problem with doing this. Should I in fact be cleaning up my 
> dolfin::Functions as well? and if so, do I use the delete?
> 
> Again, I'm not looking for you to debug my code for me, but the error 
> seems to be inside a Function, and any help is appreciated
> 
> Phil
> 
> 
> ------------------------------------------------------------------------
> 
> _______________________________________________
> FEniCS-users mailing list
> [email-masked]
> http://fenics.org/mailman/listinfo/fenics-users