Subject: [FEniCS-users] parameters output

From: Patrick Riesen <[email-masked]>
Date: Fri, 9 Oct 2009 10:15:47 +0200

hello,

writing an parameter set to an xml file throws the following error:

terminate called after throwing an instance of 'std::runtime_error'
   what():  *** Error: Unable to write parameter 
"displacement_scale_(m)" to XML file, unknown type: "real".

there is no output function for parameters of type 'real' in 
XMLParameters::write() but there is one for 'double', so shouldn't 
parameters with type 'real' be directed to the output parsing for 'doubles'?

greetings,
patrick

---

From: Anders Logg <[email-masked]>
Date: Fri, 9 Oct 2009 13:40:11 +0200

> parameters with type 'real' be directed to the output parsing for 'doubles'?

Thanks for the bug report. This should be fixed now.

--
Anders

---

From: Patrick Riesen <[email-masked]>
Date: Fri, 9 Oct 2009 13:46:49 +0200

> Thanks for the bug report. This should be fixed now.

cool, likewise thank you :-)

if i find more such things, would it be better for you if i register to 
launchpad at post them there?

patrick

> 
> 
> ------------------------------------------------------------------------
> 
> _______________________________________________
> FEniCS-users mailing list
> [email-masked]
> http://fenics.org/mailman/listinfo/fenics-users

---

From: Anders Logg <[email-masked]>
Date: Fri, 9 Oct 2009 13:49:31 +0200

> launchpad at post them there?

Yes, that would be good.

--
Anders