Subject: [FEniCS-users] TimeDependent?

From: Chong Luo <[email-masked]>
Date: Tue, 6 Oct 2009 15:07:35 -0700 (PDT)

I noticed that after upgrading from dolfin-0.9.2 to dolfin-0.9.3, the class "TimeDependent" is no longer there. Suppose we want to define a function (for example, a pulling force on the boundary) which depends on an incremental parameter "time". What shall we do?

Thank you!

---

From: Kristian Oelgaard <[email-masked]>
Date: Wed, 07 Oct 2009 09:57:25 +0200

Quoting Chong Luo <[email-masked]>:

> I noticed that after upgrading from dolfin-0.9.2 to dolfin-0.9.3, the class
> "TimeDependent" is no longer there. Suppose we want to define a function (for
> example, a pulling force on the boundary) which depends on an incremental
> parameter "time". What shall we do?

We shall look at the demos e.g., demo/pde/elastodynamics/cpp/main.cpp.

Kristian

---

From: Anders Logg <[email-masked]>
Date: Wed, 7 Oct 2009 22:31:34 +0200

> parameter "time". What shall we do?

Is it needed? You can easily add a member variable

  double t

to your own classes.

--
Anders

---

From: Chong Luo <[email-masked]>
Date: Fri, 9 Oct 2009 13:13:43 -0700 (PDT)

I see. Adding a member variable  "t" solves the problem.

Thank you!

Best,
Chong

________________________________
From: Anders Logg <[email-masked]>
To: [email-masked]
Sent: Wed, October 7, 2009 3:31:34 PM
Subject: Re: [FEniCS-users] TimeDependent?

  double t

to your own classes.

--
Anders