Subject: [FEniCS-users] Parameters in Dolfin

From: Jehanzeb Hameed <[email-masked]>
Date: Sun, 4 Oct 2009 13:51:39 -0500

Hello,

I have just shifted to the latest version of Dolfin. Previously the
way to load parameters from a xml file was

File file("parameters.xml");
file >> ParameterSystem::parameters;

I cant figure out the equivalent in the new version. Can someone please help?

Thanks,
-Jehanzeb

---

From: Johan Hake <[email-masked]>
Date: Sun, 4 Oct 2009 21:02:23 +0200

Hello!

Take a look in 

  demo/parameters/cpp/main.cpp 

and see if that helps!

Johan

On Sunday 04 October 2009 20:51:39 Jehanzeb Hameed wrote:
> _______________________________________________
> FEniCS-users mailing list
> [email-masked]
> http://fenics.org/mailman/listinfo/fenics-users
>

---

From: Jehanzeb Hameed <[email-masked]>
Date: Sun, 4 Oct 2009 14:06:58 -0500

That directory (patameters) is not in my demo directory ( I installed
by adding the sudo apt-get install fenics).

---

From: Johan Hake <[email-masked]>
Date: Sun, 4 Oct 2009 21:18:39 +0200

> by adding the sudo apt-get install fenics).

Do you have a demo directory at all?

With the ubuntu pakages the demos should be installed under:

  /usr/share/doc/dolfin-doc/demo

Johan

---

From: Anders Logg <[email-masked]>
Date: Sun, 4 Oct 2009 21:24:33 +0200

>   /usr/share/doc/dolfin-doc/demo

You can browse the code here:

  http://www.fenics.org/hg/dolfin

Click "browse" on the left.

Reading parameters is almost as before:

  file >> parameters;

--
Anders

---

From: Jehanzeb Hameed <[email-masked]>
Date: Sun, 4 Oct 2009 15:11:45 -0500

>  http://www.fenics.org/hg/dolfin

Thanks. That helped.

>>   /usr/share/doc/dolfin-doc/demo

No, no such directory. But since now I can browse the code, I am not
sweating on it :)

-Jehanzeb
On Sun, Oct 4, 2009 at 2:24 PM, Anders Logg <[email-masked]> wrote:
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v1.4.9 (GNU/Linux)
>
> iEYEARECAAYFAkrI9nEACgkQTuwUCDsYZdHBEQCfZm409RomKqJ0wuJGM/FZYG9Z
> bFgAn3AKUl26jmgto+UALoNi9F8dHrjC
> =8J//
> -----END PGP SIGNATURE-----
>