Subject: Re: [FEniCS-users] configure petsc-3.0.0-p8 on OS X 10.6.1 - Unknown Fortran name mangling

From: Faisal Moledina <[email-masked]>
Date: Fri, 23 Oct 2009 16:29:07 -0400

Hello all,

Seems like my last message was too large (I didn't know about the 40 K
limit). I wanted to add that petsc was available in MacPorts and
installed fine through that. I commented out the petsc package in the
snowleopard.platform file and proceeded to run dorsal.sh again.
Everything compiled without error (did not check for warnings). I'm
not sure of any runtime issues with this method since I'm not at all
familiar with these packages. Just thought I would share with the
group.

Faisal

On Thu, Oct 22, 2009 at 5:30 PM, Faisal Moledina
<[email-masked]> wrote:
> Hello everyone,
>
> I am trying to install dorsal-d46919da0713 and when I run ./dorsal.sh,
> the first package, petsc-3.0.0-p8 fails to configure. The error I get
> is below:
> =================================================================================
>             Configuring PETSc to compile on your system
> =================================================================================
> /Users/fideli/Work/FEniCS/petsc-3.0.0-p8/config/BuildSystem/config/compilers.py:7:
> DeprecationWarning: the sets module is deprecated
>  import sets
> /Users/fideli/Work/FEniCS/petsc-3.0.0-p8/config/PETSc/package.py:7:
> DeprecationWarning: the md5 module is deprecated; use hashlib instead
>  import md5
> /Users/fideli/Work/FEniCS/petsc-3.0.0-p8/config/BuildSystem/script.py:101:
> DeprecationWarning: The popen2 module is deprecated.  Use the
> subprocess module.
>  import popen2
> TESTING: checkFortranNameMangling from
> config.compilers(config/BuildSystem/config/compilers.py:530)
>
> *********************************************************************************
>         UNABLE to CONFIGURE with GIVEN OPTIONS    (see configure.log
> for details):
> ---------------------------------------------------------------------------------------
> Unknown Fortran name mangling
> *********************************************************************************
>
> I have also attached the configure.log. I searched the text archives
> of the mailing list and this doesn't appear to have been reported.
> Thank you in advance.
>
> Faisal
>

---

From: Harish Narayanan <[email-masked]>
Date: Sat, 24 Oct 2009 00:15:54 +0200

> familiar with these packages. Just thought I would share with the

Thanks for the report. I have not run into this problem when compiling
petsc, but the reason Dorsal builds it instead of just using the version
in MacPorts is to compile petsc with some custom flags that I find useful.

If, after trying a few things, you still see that using the petsc from
MacPorts works for you, please let me know.

Harsh

---

From: Faisal Moledina <[email-masked]>
Date: Sat, 24 Oct 2009 01:07:44 -0400

> MacPorts works for you, please let me know.

Harish,

I may have spoke too soon. Now, no matter what python demo I run in
the dolfin folder in Work, I get the following error.
$ python demo.py
Traceback (most recent call last):
  File "demo.py", line 10, in <module>
    from dolfin import *
  File "/Users/fideli/Work/FEniCS/build/lib/python2.6/site-packages/dolfin/__init__.py",
line 11, in <module>
    import cpp
  File "/Users/fideli/Work/FEniCS/build/lib/python2.6/site-packages/dolfin/cpp.py",
line 28, in <module>
    _cpp = swig_import_helper()
  File "/Users/fideli/Work/FEniCS/build/lib/python2.6/site-packages/dolfin/cpp.py",
line 24, in swig_import_helper
    _mod = imp.load_module('_cpp', fp, pathname, description)
ImportError: dlopen(/Users/fideli/Work/FEniCS/build/lib/python2.6/site-packages/dolfin/_cpp.so,
2): Symbol not found: __ZN3MPI3Win14Set_errhandlerERKNS_10ErrhandlerE
  Referenced from: /Users/fideli/Work/FEniCS/build/lib/libdolfin.dylib
  Expected in: flat namespace
 in /Users/fideli/Work/FEniCS/build/lib/libdolfin.dylib