Subject: [FFC-dev] user function qudrature points evaluation

From: [email-masked]
Date: Fri, 11 Jul 2008 11:38:36 +0200

Is there a way to evaluate a given user function
at quadrature points inside the element rather
than interpolated at nodes and then evaluated
at quadrature points. For instance

a=u*v/x[0]*dx

should not be well defined if the mesh touches
x[0]=0 axis but the quadrature points beeing inside
the domain 1/x[0] is still defined. This
is usefull for axi-symmetric problems;

V

-- 
Vuk Milisic
Chercheur CNRS
UMR 5224
Laboratoire Jean Kuntzman
Unversité Joseph Fourier
Grenoble
http://ljk.imag.fr/membres/Vuk.Milisic/

---

From: Kristian Oelgaard <[email-masked]>
Date: Fri, 11 Jul 2008 12:36:02 +0200

> at quadrature points. For instance

Yes, you can define the function on a QuadratureElement instead of a
FiniteElement. The FFC manual explains the QuadratureElement in more detail.

Kristian
 
> _______________________________________________
> FFC-dev mailing list
> [email-masked]
> http://www.fenics.org/mailman/listinfo/ffc-dev
>