Subject: [FFC-dev] const static double or static const double

From: Kristian Oelgaard <[email-masked]>
Date: Mon, 06 Jul 2009 12:44:57 +0200

Hi,

Just a minor issue. For some arrays in the generated code we use:

const static

others uses

static const

Is there a right or wrong way, if not, which one should we use (if we want
to be consistent in the code)?

It's just a small change in the format, but we will probably have to change the
references for the regression tests.

Kristian

---

From: Anders Logg <[email-masked]>
Date: Mon, 6 Jul 2009 13:02:18 +0200

> references for the regression tests.

I think it should be static const:

http://www.velocityreviews.com/forums/t291248-const-static-vs-static-const.html

-- 
Anders

---

From: Johan Hake <[email-masked]>
Date: Mon, 6 Jul 2009 13:29:14 +0200

On Monday 06 July 2009 13:02:18 Anders Logg wrote:
> > Is there a right or wrong way, if not, which one should we use (if we
> > want to be consistent in the code)?
> >
> > It's just a small change in the format, but we will probably have to
> > change the references for the regression tests.
>

From one of the last comments it says that the rule is that "static" should be 
in the beginning of a declaration.

Johan

---

From: Kristian Oelgaard <[email-masked]>
Date: Mon, 06 Jul 2009 13:57:31 +0200

> in the beginning of a declaration.

Agree, I've changed the ufcformat.py file accordingly and updated all references
for the regression tests. Thanks.

Kristian

> Johan
> _______________________________________________
> FFC-dev mailing list
> [email-masked]
> http://www.fenics.org/mailman/listinfo/ffc-dev
>