Subject: [FFC-dev] Suggestions for changes [...]

From: [email-masked]
Date: Mon, 23 May 2005 18:23:20 +0200

Commit from logg (2005-05-23 18:23 CEST)
----------------

Suggestions for changes

I updated the TODO list with two suggested changes for FFC.
Tell me what you think.

1. Projections
--------------

I'm thinking of adding projections to the language. A simple example:

    P0 = FiniteElement("Discontinuous vector Lagrange", "tetrahedron", 0)
    pi = Projection(P0)

pi would then be a projection onto piecewise constants.

This could be used to reduce the complexity of evaluating certain forms.
If w is a Function, one can replace w with its projection in a form:

    a = pi(w)*u.dx(i)*v.dx(i)*dx

2. Change .dx() --> .Dx()
-------------------------

Ridg suggested changing the notation for derivatives from .dx() to .Dx()
to avoid confusion with the integration operator *dx. What do you think?
Poisson would then change from

    a = u.dx(i)*v.dx(i)*dx

to

    a = u.Dx(i)*v.Dx(i)*dx

  ffc  TODO  1.34

---

From: Anders Logg <[email-masked]>
Date: Tue, 24 May 2005 09:17:26 -0500

I think there should be only one.

I also like .dx() (obviously since I chose it), but maybe it's just
because I'm used to it.

Maybe

    a = u.Dx(i)*v.Dx(i)*dx

looks pretty nice?

/Anders

On Tue, May 24, 2005 at 09:05:24AM +0200, [email-masked] wrote:
> 1. Sounds very good!
> 2. I don't have such a strong opinion about this. I like the .dx operator,
> but Ridg may have a point that it may be more readable using .Dx. Maybe we
> could allow for both?
> 
> /Johan
> 
> 
> > _______________________________________________
> > FFC-dev mailing list
> > [email-masked]
> > http://www.fenics.org/cgi-bin/mailman/listinfo/ffc-dev
> >
> 
> 
> 

-- 
Anders Logg
Research Assistant Professor
Toyota Technological Institute at Chicago
http://www.tti-c.org/logg/