Subject: [FFC-dev] [HG FFC] Rename abs to modulus in order to avoid conflict with builtin abs.

From: [email-masked] (FFC)
Date: Fri, 21 Sep 2007 12:05:59 +0200 (CEST)

One or more new changesets pushed to the primary ffc repository.
A short summary of the last three changesets is included below.

changeset:   979:4f8c7f328a97492d45b1e02fc2e67688b4c78af0
tag:         tip
user:        "Marie E. Rognes <[email-masked]>"
date:        Fri Sep 21 11:35:05 2007 +0200
files:       src/demo/FunctionOperators.form src/ffc/compiler/codegeneration/tensor/tensorgenerator.py src/ffc/compiler/language/algebra.py src/ffc/compiler/language/operators.py src/ffc/compiler/language/tokens.py
description:
Rename abs to modulus in order to avoid conflict with builtin abs.

changeset:   978:b37c51e0c7f37d0b801bd026fc3f9172e594837f
user:        "Marie E. Rognes <[email-masked]>"
date:        Fri Sep 21 11:21:17 2007 +0200
files:       src/ffc/compiler/language/algebra.py
description:
Bug fix in operators invert/abs/sqrt w.r.t numerics

changeset:   977:94ec9ccbefe8bf5118a27ae2439f61d06422b00e
user:        "Marie E. Rognes <[email-masked]>"
date:        Fri Sep 21 11:11:32 2007 +0200
files:       src/ffc/compiler/codegeneration/tensor/tensorgenerator.py
description:
Temporary bug fix for new determinants

----------------------------------------------------------------------
For more details, visit http://www.fenics.org/hg/ffc

---

From: Anders Logg <[email-masked]>
Date: Fri, 21 Sep 2007 12:11:35 +0200

Very nice. The manual also needs to be updated for this.

/Anders

FFC wrote:
> _______________________________________________
> FFC-dev mailing list
> [email-masked]
> http://www.fenics.org/mailman/listinfo/ffc-dev

---

From: Marie Rognes <[email-masked]>
Date: Fri, 21 Sep 2007 12:12:17 +0200

> Very nice. The manual also needs to be updated for this.

Will do.

--
Marie