Subject: [FFC-dev] FFC - UFL inconsistency

From: Kristian Oelgaard <[email-masked]>
Date: Mon, 02 Mar 2009 12:28:51 +0100

Hi,

I found the following when inconsistency when verifying some element tensors.

form = v*u*dx + f*v*dx

UFL rhs(form)

returns f*v*dx

FFC rhs(form)

return -f*v*dx

I think they should return the same thing, the question is what?
What does SyFi return? (if implemented)

Kristian

---

From: Martin Sandve Alnæs <[email-masked]>
Date: Mon, 2 Mar 2009 12:55:01 +0100

> What does SyFi return? (if implemented)

SyFi never had this (would be impossible since
there  never was a declarative input language).

The FFC way is the correct one, I'll fix it.

Martin