Subject: [FFC-dev] evaluate_basis and derivatives

From: Kristian Oelgaard <[email-masked]>
Date: Tue, 18 Aug 2009 21:12:49 +0200

Hello,

I want to eliminate a basis function value (i.e. not generate code for it) for
evaluate_basis() (and evaluate_basis_derivative()).

Calling tabulate(x) on the FIAT element FiniteElement("CG", "triangle", 3)
will return the dot product of the expansion coefficients (a matrix) and the
bvals (an array) which is evaluated at the point x.

In the current case the coefficients is a 10x10 matrix and the bvals is a 10x1.
If I just want to return the first 9 basis function values should I remove the
last row of the coefficient matrix only, or should I also remove the last
column as well along with the last row in the bvals?

Kristian

---

From: Anders Logg <[email-masked]>
Date: Tue, 18 Aug 2009 21:37:18 +0200

> column as well along with the last row in the bvals?

I think you should remove the last row to get a 9x10 matrix which you
multiply with a 10x1 vector to get a 9x1 vector with the values.

--
Anders

---

From: Robert Kirby <[email-masked]>
Date: Tue, 18 Aug 2009 15:43:54 -0500

Yes.  The columns of the coeff matrix correspond to the orthogonal basis
functions.You need those to construct the 9 "non-bubble" bases.

On Tue, Aug 18, 2009 at 2:37 PM, Anders Logg <[email-masked]> wrote:

> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v1.4.9 (GNU/Linux)
>
> iEYEARECAAYFAkqLAu4ACgkQTuwUCDsYZdEkfQCfYwIjbuiAeTS4gCUsLb4yqXuz
> NF4An3HHeqXGfxRcwWOFsW6qBgahlV8x
> =BxOj
> -----END PGP SIGNATURE-----
>
> _______________________________________________
> FFC-dev mailing list
> [email-masked]
> http://www.fenics.org/mailman/listinfo/ffc-dev
>
>

---

From: Kristian Oelgaard <[email-masked]>
Date: Wed, 19 Aug 2009 10:14:20 +0200

> functions.You need those to construct the 9 "non-bubble" bases.

OK, that's was how I understood things too, thanks.

Kristian