Subject: [FFC-dev] [HG FFC] Added comment about --output-directory to the man page and FFC manual.

From: [email-masked] (FFC)
Date: Mon, 29 Sep 2008 12:20:37 +0200 (CEST)

One or more new changesets pushed to the primary ffc repository.
A short summary of the last three changesets is included below.

changeset:   1223:3dc8f38f564c8514a2c3c1dcaf7fb89d38208b95
tag:         tip
user:        "Kristian Oelgaard <[email-masked]>"
date:        Mon Sep 29 12:20:15 2008 +0200
files:       doc/man/man1/ffc.1.gz doc/manual/chapters/manpagecopy.tex doc/manual/ffc-user-manual.pdf
description:
Added comment about --output-directory to the man page and FFC manual.

changeset:   1222:6165cfcf21e461dad74a609aa0ebd7b557663204
user:        "Kristian Oelgaard <[email-masked]>"
date:        Mon Sep 29 11:57:10 2008 +0200
files:       ffc/common/constants.py ffc/compiler/format/dolfinformat.py ffc/compiler/format/ufcformat.py scripts/ffc
description:
Added --output-directory=DIR to FFC compile options, default is '.'

changeset:   1221:94f9d832af72d9d08759a9a0514c6425bd3f7c2d
user:        Anders Logg <[email-masked]>
date:        Sun Sep 28 23:25:24 2008 +0200
files:       ffc/__init__.py
description:
Bug fix

----------------------------------------------------------------------
For more details, visit http://www.fenics.org/hg/ffc

---

From: "Garth N. Wells" <[email-masked]>
Date: Mon, 29 Sep 2008 11:40:22 +0100

Would it be simple to just have

    >ffc Foo.form -> ./Foo.h
    >ffc Foo.form /tmp/Foo.h -> /tmp/Foo.h

?

Garth

FFC wrote:
> _______________________________________________
> FFC-dev mailing list
> [email-masked]
> http://www.fenics.org/mailman/listinfo/ffc-dev

--

---

From: Anders Logg <[email-masked]>
Date: Mon, 29 Sep 2008 13:09:45 +0200

>     >ffc Foo.form /tmp/Foo.h -> /tmp/Foo.h

Yes, FFC can compile multiple files, for example

  ffc *.form

so it we would have to implement some non-trivial logic.

-- 
Anders

---

From: "Garth N. Wells" <[email-masked]>
Date: Mon, 29 Sep 2008 12:11:26 +0100

> so it we would have to implement some non-trivial logic.

OK. Looks good how Kristian has done it then.

Garth

> 
> 
> ------------------------------------------------------------------------
>

---

From: Kristian Oelgaard <[email-masked]>
Date: Mon, 29 Sep 2008 13:16:24 +0200

>     >ffc Foo.form /tmp/Foo.h -> /tmp/Foo.h

I think this will make the interface to FFC more complex. To achieve the above
one can just do:

ffc -o /tmp Foo.form

which is just as simple in my opinion.

FFC can also take a list of forms as argument, and this won't make it easier to
implement.

Kristian
 
> > files:       ffc/common/constants.py ffc/compiler/format/dolfinformat.py
> ffc/compiler/format/ufcformat.py scripts/ffc
> > description: