Subject: Re: [FFC-dev] division /

From: Anders Logg <[email-masked]>
Date: Fri, 30 Sep 2005 09:43:22 -0500

On Fri, Sep 30, 2005 at 01:40:55PM +0200, Garth N. Wells wrote:
> Hi Anders,
> 
> I noticed that while ffc does not allow division by constants, a/b does not raise
> an error. Might be good to print an error message - would be helpful for people
> who first try it, and read the manual later (if ever)!

FFC does allow division by constants:

    c = Constant()
    a = v*f/c*dx

I will add a note on this in the manual.

Or maybe you came across something that didn't work?
    
> BTW, the ffc manual is looking good and Chapter 5 is really helpful.

Thanks! It's just a start. It takes time to write manuals and it's a
bit boring but I'm trying to make some progress...

/Anders

---

From: "Garth N. Wells" <[email-masked]>
Date: Fri, 30 Sep 2005 17:01:34 +0200

> Or maybe you came across something that didn't work?

OK, looks like a bug then. If I do something like

c = Constant()
a = v*f*c/c*dx

then in the header file for DOLFIN, the bilinear form wants two reals, rather
than just one.

Garth

> _______________________________________________
> FFC-dev mailing list
> [email-masked]
> http://www.fenics.org/cgi-bin/mailman/listinfo/ffc-dev
>

---

From: Anders Logg <[email-masked]>
Date: Fri, 30 Sep 2005 10:27:28 -0500

Yes, it's a bug. I think I fixed it now. Try again.

/Anders

-- 
Anders Logg
Research Assistant Professor
Toyota Technological Institute at Chicago
http://www.tti-c.org/logg/