Subject: [FFC-dev] FFC limitation

From: Mehdi Nikbakht <[email-masked]>
Date: Wed, 10 May 2006 12:01:48 +0200

Dear Anders

I am trying to compile my form file for a complex mixed nonlinear problem(3
phase). I received this error:

*** Unable to find dimension for Index i0

I removed some of my terms in bilinear form of 3th phase(they don't have any
error themselves),then I could compile successfully. Is there any limitation in
the number of arguments that can be compiled in form file?

regards, 
 
-- 
Mehdi

---

From: Anders Logg <[email-masked]>
Date: Wed, 10 May 2006 13:16:17 +0200

> the number of arguments that can be compiled in form file?

No, there's no such limitation.

Try to do the opposite instead. Remove as many terms as you can while
you still get an error. Remove the easy ones and try to isolate the
term that gives you errors. Then I can take a look at it and find/fix
the problem.

Try to produce as simple an example as possible.

/Anders