Subject: [FFC-dev] [HG FFC] UFL quadrature representation seems to work for quite a few forms (cell integrals). Needs testing.

From: [email-masked] (FFC)
Date: Tue, 24 Feb 2009 11:31:13 +0100 (CET)

One or more new changesets pushed to the primary ffc repository.
A short summary of the last three changesets is included below.

changeset:   1327:4290605594500e5fbe61f7c57b0be4bf1c7f171b
tag:         tip
user:        "Kristian Oelgaard <[email-masked]>"
date:        Tue Feb 24 11:30:14 2009 +0100
files:       ffc/compiler/codegeneration/quadrature/__init__.py ffc/compiler/codegeneration/quadrature/uflquadraturegenerator.py ffc/compiler/codegeneration/quadrature/uflquadraturegenerator_utils.py ffc/compiler/representation/quadrature/uflquadraturerepresentation.py ffc/compiler/uflcompiler.py
description:
UFL quadrature representation seems to work for quite a few forms (cell integrals). Needs testing.

changeset:   1326:4929bd79f67f32b1b9abf9dbfd96c122d01d67f0
user:        Anders Logg <[email-masked]>
date:        Fri Feb 20 10:26:30 2009 +0100
files:       ffc/compiler/uflcompiler.py
description:
Testing monomial extraction in uflcompiler.py

changeset:   1325:aefc94d6c4198a38f724772c2a989dd6dc44cf97
user:        Anders Logg <[email-masked]>
date:        Thu Feb 19 09:00:35 2009 +0100
files:       ChangeLog
description:
Remove duplication in ChangeLog

----------------------------------------------------------------------
For more details, visit http://www.fenics.org/hg/ffc

---

From: Kristian Oelgaard <[email-masked]>
Date: Tue, 24 Feb 2009 11:34:32 +0100

Quoting FFC <[email-masked]>:

> files:       ffc/compiler/codegeneration/quadrature/__init__.py
> ffc/compiler/codegeneration/quadrature/uflquadraturegenerator.py
> ffc/compiler/codegeneration/quadrature/uflquadraturegenerator_utils.py
> ffc/compiler/representation/quadrature/uflquadraturerepresentation.py
> ffc/compiler/uflcompiler.py
> description:

When pushing this changeset, I received:

pushing to ssh://[email-masked]/hg/ffc
searching for changes
remote: adding changesets
remote: adding manifests
remote: adding file changes
remote: added 1 changesets with 5 changes to 5 files
remote: Traceback (most recent call last):
remote:   File
"/home/buildbot/local/lib/python2.5/site-packages/twisted/python/log.py", line
51, in callWithLogger
remote:     return callWithContext({"system": lp}, func, *args, **kw)
remote:   File
"/home/buildbot/local/lib/python2.5/site-packages/twisted/python/log.py", line
36, in callWithContext
remote:     return context.call({ILogContext: newCtx}, func, *args, **kw)
remote:   File
"/home/buildbot/local/lib/python2.5/site-packages/twisted/python/context.py",
line 59, in callWithContext
remote:     return self.currentContext().callWithContext(ctx, func, *args, **kw)
remote:   File
"/home/buildbot/local/lib/python2.5/site-packages/twisted/python/context.py",
line 37, in callWithContext
remote:     return func(*args,**kw)
remote: --- <exception caught here> ---
remote:   File
"/home/buildbot/local/lib/python2.5/site-packages/twisted/internet/selectreactor.py",
line 146, in _doReadOrWrite
remote:     why = getattr(selectable, method)()
remote:   File
"/home/buildbot/local/lib/python2.5/site-packages/twisted/internet/tcp.py", line
527, in doConnect
remote:     self.failIfNotConnected(error.getConnectError((err, strerror(err))))
remote:   File
"/home/buildbot/local/lib/python2.5/site-packages/twisted/internet/tcp.py", line
484, in failIfNotConnected
remote:     del self.connector
remote: exceptions.AttributeError: connector
abort: unexpected response:
'change NOT sent\n'

The changes does appear in the repository. Is there something wrong?

Kristian
 
> _______________________________________________
> FFC-dev mailing list
> [email-masked]
> http://www.fenics.org/mailman/listinfo/ffc-dev
>

---

From: Ilmar Wilbers <[email-masked]>
Date: Tue, 24 Feb 2009 11:46:43 +0100

Ah, sorry about that. We turned off the old buildbots, but your 
changeset triggered a warning which didn't make it through. These hooks 
are turned off now. The changeseet seems to be OK, so no further action 
is needed.

ilmar

---

From: Kristian Oelgaard <[email-masked]>
Date: Tue, 24 Feb 2009 11:52:01 +0100

> are turned off now. The changeseet seems to be OK, so no further action 

OK, thanks.

Kristian

---

From: "Garth N. Wells" <[email-masked]>
Date: Tue, 24 Feb 2009 10:56:06 +0000

> UFL quadrature representation seems to work for quite a few forms (cell integrals). Needs testing.

Very nice!

Any idea yet how the generation time compares to the old FFC quadrature 
for complicated forms?

Garth

---

From: Kristian Oelgaard <[email-masked]>
Date: Tue, 24 Feb 2009 12:03:06 +0100

> Any idea yet how the generation time compares to the old FFC quadrature 

No, I haven't tried. First I want to verify that the results are correct and
then I'll generalise it to include facet integrals and different representations
before worrying about speed.
I also expect the generated code to be slower than the old quadrature because
everything is just dumped in the same line when computing an entry of the
element tensor.

Kristian

---

From: Anders Logg <[email-masked]>
Date: Tue, 24 Feb 2009 12:54:30 +0100

> UFL quadrature representation seems to work for quite a few forms (cell integrals). Needs testing.

Really impressive!

And just go ahead and break anything you want in the jit compiler.

-- 
Anders