Subject: Re: [FFC-dev] [DOLFIN-dev] [HG DOLFIN] Get parallel logic working in UFCCell. Note new handling of local and

From: "Garth N. Wells" <[email-masked]>
Date: Fri, 19 Jun 2009 14:47:31 +0100

Anders Logg wrote:
> On Fri, Jun 19, 2009 at 12:38:28PM +0100, Garth N. Wells wrote:
>>
>> Anders Logg wrote:
>>> Sorry about that. I'll check on it later (if not fixed by
>>> then). Today's midsummer here in Sweden. :-)
>>>
>> The problem is that cell facets have not been initialised. Where should 
>> this be done?
> 
> It should be done in the constructor of DofMap.
>

This could be a FFC bug. For the Poisson DG example, looking at the 
generated contents of

     bool ufc::dof_map::needs_mesh_entities(unsigned int d) const

I see

    switch ( d )
       {
       case 0:
         return false;
         break;
       case 1:
         return false;
         break;
       case 2:
         return true;
         break;
       }

Shouldn't 'case 1' also return true (that is, cell edges are required)?

Garth

> 
> 
> ------------------------------------------------------------------------
> 
> _______________________________________________
> DOLFIN-dev mailing list
> [email-masked]
> http://www.fenics.org/mailman/listinfo/dolfin-dev

---

From: "Garth N. Wells" <[email-masked]>
Date: Fri, 19 Jun 2009 15:34:28 +0100

> Shouldn't 'case 1' also return true (that is, cell edges are required)?

The above is all OK. The bug was in UFCCell which I've now fixed.

Garth

> FFC-dev mailing list
> [email-masked]
> http://www.fenics.org/mailman/listinfo/ffc-dev