Subject: [FFC-dev] laTeX

From: [email-masked]
Date: Fri, 8 Jun 2007 11:56:37 +0100 (WEST)

It is written in the ffc-user-manual that adding the flag -l latex
ffc generates output in LATEX format. However, something else must be done
since I get:

\> ffc -l latex Poisson.form
This is FFC, the FEniCS Form Compiler, version 0.4.0-pre1.
For further information, go to http://www/fenics.org/ffc/.

Preprocessing form file: Poisson.form --> Poisson.py

*** Don't know how to compile code for language "latex".
*** To get more information about this error, rerun ffc with the option -d1.
paulo@alinex-2PUb8L poisson\> ffc -d1 -l latex Poisson.form
This is FFC, the FEniCS Form Compiler, version 0.4.0-pre1.
For further information, go to http://www/fenics.org/ffc/.

Preprocessing form file: Poisson.form --> Poisson.py

Traceback (most recent call last):
  File "/home/paulo/builds/bin/ffc", line 175, in ?
    sys.exit(main(sys.argv[1:]))
  File "/home/paulo/builds/bin/ffc", line 102, in main
    execfile(outname, ns)
  File "Poisson.py", line 30, in ?
    compile([a, L, M, element], "Poisson", "tensor", "latex", {'blas':
False, 'precision=': '15', 'optimize': False})
  File "/usr/lib/python2.4/site-packages/ffc/compiler/compiler.py", line
66, in compile
    __compile_forms(forms, prefix, representation, output_language, options)
  File "/usr/lib/python2.4/site-packages/ffc/compiler/compiler.py", line
81, in __compile_forms
    format = __choose_format(output_language)
  File "/usr/lib/python2.4/site-packages/ffc/compiler/compiler.py", line
234, in __choose_format
    raise RuntimeError, "Don't know how to compile code for language
\"%s\"." % output_language
RuntimeError: Don't know how to compile code for language "latex".

/Paulo

---

From: Anders Logg <[email-masked]>
Date: Fri, 8 Jun 2007 13:16:09 +0200

-l latex is no longer supported (but might be added again in future
versions if there is demand for it).

I'll remove this from the manual. Thanks for reminding me.

/Anders

On Fri, Jun 08, 2007 at 11:56:37AM +0100, [email-masked] wrote:
> _______________________________________________
> FFC-dev mailing list
> [email-masked]
> http://www.fenics.org/mailman/listinfo/ffc-dev