Subject: [FFC-dev] Protect the ASE import

From: Matthew Knepley <[email-masked]>
Date: Mon, 06 Jun 2005 20:14:58 -0500

Alright, I think it should finally work. As to the
second question, the situation is different here. You do not
need DOLFIN or LaTeX installed to generate them because you
are using a certain text generation technology. The ASE format
is using another "generation" technology, namely ASTs instead
of text. It could equally well generate C code for DOLFIN.

   Hope that is clearer,

        Matt

There are still problems if I import the ase module:

  File "../ffc/compiler/compiler.py", line 23, in ?
    from ffc.format import ase
  File "../ffc/format/ase.py", line 43, in ?
    format = { "sum": sum,
AttributeError: 'NoneType' object has no attribute 'getVar'

I'll keep the import under the if-case in compiler.py until we know
how to do this.

What things from ASE are you using in ase.py? It should be possible to
compile without having access to the system you are compiling for (you
don't need to have DOLFIN or LaTeX installed to use -dolfin or -latex).

(As a side note, I should change -c++ to -dolfin.)

/Anders

-- 
"Failure has a thousand explanations. Success doesn't need one" -- Sir Alec Guiness

---

From: Anders Logg <[email-masked]>
Date: Tue, 7 Jun 2005 09:25:25 -0500

ok, now I understand.

Good to see that the abstractions I made (the format dictionaries)
were almost general enough for you to actually add a new format.

Have you looked at dofmap.py and pointmap.py? These generate code for
mapping of dofs from the reference element. They are currently
somewhat DOLFIN specific but I think they could also be generalized.

/Anders

-- 
Anders Logg
Research Assistant Professor
Toyota Technological Institute at Chicago
http://www.tti-c.org/logg/

---

From: Matthew Knepley <[email-masked]>
Date: Tue, 07 Jun 2005 09:41:01 -0500

> somewhat DOLFIN specific but I think they could also be generalized.

  I will look at them next. I have something similar called System now
which I am making compatible.

      Matt