Subject: [FFC-dev] Forms

From: "Garth N. Wells" <[email-masked]>
Date: Sun, 07 Jun 2009 08:59:46 +0100

I couldn't find in the UFL manual whether or not there is something 
special about 'a' and 'L' denoting bilinear and linear forms, 
respectively, or if this determined by the form compiler?

Either way, it seems that some checks are missing in either UFL or FFC 
since

   element = FiniteElement("Lagrange", triangle, 1)
   v = TestFunction(element)
   u = TrialFunction(element)
   f = Function(element)

   a = inner(grad(v), grad(u))*dx + v*f*dx

doesn't result in an error. I would expect this to give an error.

Garth

---

From: Martin Sandve Alnæs <[email-masked]>
Date: Mon, 8 Jun 2009 09:53:23 +0200

By default, the variables "M", "L", and "a" are checked
and used if they are Form instances. Otherwise, any set
of forms (and elements) can be exported by defining lists
with the instances in:

  V = FiniteElement(...)
  ...
  a = ...*dx
  forms = (a, L, F, J)
  elements = (V, P, TH)

I'll update the manual.

Martin

On Sun, Jun 7, 2009 at 9:59 AM, Garth N. Wells<[email-masked]> wrote:
> _______________________________________________
> FFC-dev mailing list
> [email-masked]
> http://www.fenics.org/mailman/listinfo/ffc-dev
>

---

From: "Garth N. Wells" <[email-masked]>
Date: Mon, 08 Jun 2009 15:12:45 +0100

> of forms (and elements) can be exported by defining lists

OK.

Still, I would expect an error for the below form which is mixes linear 
and bilinear terms.

Garth