Subject: [FFC-dev] Error in compiling mixed problem with three fields using the new release

From: <[email-masked]>
Date: Thu, 17 Nov 2005 14:40:47 -0000

Hi,

I am running a mixed problem with 3 different fields in ffc: 

U = FiniteElement("Vector Lagrange", "triangle",2, 2)   
T = FiniteElement("Vector Lagrange", "triangle",1, 3)
P = FiniteElement("Lagrange", "triangle",1, 1)
TH = U + T + P

( v, vs, vp) = BasisFunctions(TH)
( u,  s,  p) = BasisFunctions(TH)
 
ffc was able to compile with the previous release but now I get this error :

*** global name 'finiteelement' is not defined

Do you know why this happens? 

Luisa

---

From: Anders Logg <[email-masked]>
Date: Thu, 17 Nov 2005 09:36:55 -0600

> Do you know why this happens? 

Thanks for reporting this. I have now fixed this in the current cvs,
which should propagate to ffc-cvs-current.tar.gz at

    http://www.fenics.org/pub/software/ffc/cvs/

on the next whole hour.

Here's a tip: add the flag -d1 (for debugging) when compiling a form
and FFC will printout the traceback for the error and you might be
able to know what goes wrong (in this case, a missing import of the
module finiteelement.py).

/Anders