Subject: [FFC-dev] [HG FFC] QuadratureElement: It is now possible to create mixed elements from QuadratureElement, VectorQuadratureElement has aslo been added with a functionality similar to VectorElement. Works with both tensor and quadrature representation.

From: [email-masked] (FFC)
Date: Thu, 17 Jan 2008 11:38:14 +0100 (CET)

One or more new changesets pushed to the primary ffc repository.
A short summary of the last three changesets is included below.

changeset:   1052:21eebc65e6fa13c9c35c4d3d12bbafc76c71f963
tag:         tip
user:        "Kristian Oelgaard <[email-masked]>"
date:        Thu Jan 17 11:37:24 2008 +0100
files:       src/ffc/__init__.py src/ffc/compiler/analysis/checks.py src/ffc/compiler/codegeneration/common/finiteelement.py src/ffc/compiler/representation/quadrature/monomialtabulation.py src/ffc/compiler/representation/tensor/monomialintegration.py src/ffc/fem/quadratureelement.py src/ffc/fem/vectorelement.py
description:
QuadratureElement: It is now possible to create mixed elements from QuadratureElement, VectorQuadratureElement has aslo been added with a functionality similar to VectorElement. Works with both tensor and quadrature representation.

changeset:   1051:7c65174c93bed6e2d17fa5e47ecd5fcffc512d9a
user:        "Kristian Oelgaard <[email-masked]>"
date:        Tue Jan 15 16:35:54 2008 +0100
files:       src/ffc/compiler/representation/quadrature/monomialtabulation.py src/ffc/compiler/representation/tensor/monomialintegration.py
description:
Quadrature representation should be working again.

changeset:   1050:93c0f3ef59e37b4cf6b02b1b9365115990012729
user:        "Kristian Oelgaard <[email-masked]>"
date:        Thu Jan 10 09:49:21 2008 +0100
files:       src/test/regression/reference/Constant.h src/test/regression/reference/Elasticity.h src/test/regression/reference/EnergyNorm.h src/test/regression/reference/Equation.h src/test/regression/reference/FunctionOperators.h src/test/regression/reference/Heat.h src/test/regression/reference/Mass.h src/test/regression/reference/MixedMixedElement.h src/test/regression/reference/MixedPoisson.h src/test/regression/reference/NavierStokes.h src/test/regression/reference/NeumannProblem.h src/test/regression/reference/Optimization.h src/test/regression/reference/P5tet.h src/test/regression/reference/P5tri.h src/test/regression/reference/Poisson.h src/test/regression/reference/PoissonDG.h src/test/regression/reference/PoissonSystem.h src/test/regression/reference/Projection.h src/test/regression/reference/Stokes.h src/test/regression/reference/TensorWeightedPoisson.h src/test/regression/reference/VectorLaplaceGradCurl.h
description:
Update references for UFC v1.1

----------------------------------------------------------------------
For more details, visit http://www.fenics.org/hg/ffc

---

From: Marie Rognes <[email-masked]>
Date: Fri, 18 Jan 2008 14:09:23 +0100

> QuadratureElement: It is now possible to create mixed elements from QuadratureElement, VectorQuadratureElement has aslo been added with a functionality similar to VectorElement. Works with both ten…

What is a QuadratureElement?

-- 
Marie E. Rognes
Ph.D Fellow, 
Centre of Mathematics for Applications, 
University of Oslo
http://folk.uio.no/meg

---

From: "Garth N. Wells" <[email-masked]>
Date: Fri, 18 Jan 2008 13:11:27 +0000

> What is a QuadratureElement?

It provides for functions which don't come from a finite element space, 
but the values of which are known (or evaluated) at discrete points. A 
typical example is the stress in a plasticity computation which is 
computed at quadrature points.

Garth

---

From: Anders Logg <[email-masked]>
Date: Fri, 18 Jan 2008 22:13:20 +0100

> computed at quadrature points.

Such functions can be used as coefficients in a form (when evaluated
using quadrature), but not differentiated.

-- 
Anders