Subject: [FFC-dev] [HG FFC] Make format a class in uflufcformat.py. Fix minor bug in ElementData for dolfin wrappers.

From: [email-masked] (FFC)
Date: Fri, 27 Feb 2009 11:04:48 +0100 (CET)

One or more new changesets pushed to the primary ffc repository.
A short summary of the last three changesets is included below.

changeset:   1343:6678c654784d663396bf5ac6415f9ca39ad95d1a
tag:         tip
user:        "Kristian Oelgaard <[email-masked]>"
date:        Fri Feb 27 11:04:19 2009 +0100
files:       ffc/compiler/analysis/elementdata.py ffc/compiler/compiler.py ffc/compiler/format/uflufcformat.py ffc/compiler/uflcompiler.py
description:
Make format a class in uflufcformat.py. Fix minor bug in ElementData for dolfin wrappers.

changeset:   1342:d6a6fe5a91786818b5a7b621c9ec0c501e3d5803
user:        "Kristian Oelgaard <[email-masked]>"
date:        Thu Feb 26 20:47:36 2009 +0100
files:       ffc/compiler/codegeneration/quadrature/uflquadraturegenerator.py ffc/compiler/codegeneration/quadrature/uflquadraturegenerator_utils.py ffc/compiler/uflcompiler.py
description:
Switch on code generation for interior facet integrals, code is not correct yet.

changeset:   1341:da1621607df684072f3aafcbca47866e4952a259
user:        "Kristian Oelgaard <[email-masked]>"
date:        Thu Feb 26 19:53:27 2009 +0100
files:       ffc/compiler/codegeneration/quadrature/uflquadraturegenerator.py ffc/compiler/codegeneration/quadrature/uflquadraturegenerator_utils.py ffc/compiler/format/uflufcformat.py ffc/compiler/uflcompiler.py
description:
Switch on code generation for exterior facet integrals.

----------------------------------------------------------------------
For more details, visit http://www.fenics.org/hg/ffc

---

From: Kristian Oelgaard <[email-masked]>
Date: Fri, 27 Feb 2009 11:11:32 +0100

Quoting FFC <[email-masked]>:

> files:       ffc/compiler/analysis/elementdata.py ffc/compiler/compiler.py
> ffc/compiler/format/uflufcformat.py ffc/compiler/uflcompiler.py
> description:

This works for both compilers. There's no need to check for which format to use,
just do

format = Format(options)

The format dictionary is a data member 'format.format'
It works for all forms in the demo directory, both UFC and DOLFIN formats.

Kristian
 
> files:       ffc/compiler/codegeneration/quadrature/uflquadraturegenerator.py
> ffc/compiler/codegeneration/quadrature/uflquadraturegenerator_utils.py
> ffc/compiler/uflcompiler.py
> description:
> files:       ffc/compiler/codegeneration/quadrature/uflquadraturegenerator.py
> ffc/compiler/codegeneration/quadrature/uflquadraturegenerator_utils.py
> ffc/compiler/format/uflufcformat.py ffc/compiler/uflcompiler.py
> description:
> _______________________________________________
> FFC-dev mailing list
> [email-masked]
> http://www.fenics.org/mailman/listinfo/ffc-dev
>

---

From: Anders Logg <[email-masked]>
Date: Fri, 27 Feb 2009 15:59:53 +0100

> It works for all forms in the demo directory, both UFC and DOLFIN formats.

Nice!

-- 
Anders