Subject: [FFC-dev] DG operators for BDM

From: Fredrik Bengzon <[email-masked]>
Date: Sun, 30 Sep 2007 22:09:22 +0200

Hello
I'm wondering if there is some simple way (i.e., other than component 
wise) of writing the term

integral ( [ outer(n, v) ] : < grad u > ) dS

where the test and trial functions u, and v are BDM functions. Here 
outer(n,v) is the outer product of the normal n and v, [] is the jump, 
and <> the average operator. Can you use some sort of python arrays to 
do the outer product, for instance? Also is there a way of imposing 
constraints using FFC; I'm thinking of the pressure in the Stokes 
equations for instance which sometimes is required to have a zero integral?

Regards
 
Fredrik Bengzon

---

From: Kristian Oelgaard <[email-masked]>
Date: Tue, 02 Oct 2007 10:52:27 +0200

> integral ( [ outer(n, v) ] : < grad u > ) dS

If I do the following:

element = FiniteElement("BDM", "triangle", 1)

v = TrialFunction(element)
u = TestFunction(element)
n = FacetNormal("triangle")

print "jump", jump(outer(n,v))
print "avg", avg(grad(u))

a = dot(jump(outer(n,v)), avg(grad(u)))*dS

print "a", a

at least the output (the print statements) looks OK as far as I can tell, but
have a look. The above form will however produce an error in simplify.py. Maybe
you can have a look and see what is going wrong?

Kristian

> _______________________________________________
> FFC-dev mailing list
> [email-masked]
> http://www.fenics.org/mailman/listinfo/ffc-dev
>

---

From: Marie Rognes <[email-masked]>
Date: Tue, 02 Oct 2007 12:29:18 +0200

> you can have a look and see what is going wrong?

A proper bug in simplify. Should be fixed now.

-- 
Marie E. Rognes
Ph.D Fellow, 
Centre of Mathematics for Applications, 

University of Oslo

http://folk.uio.no/meg

---

From: Kristian Oelgaard <[email-masked]>
Date: Tue, 02 Oct 2007 12:34:14 +0200

> A proper bug in simplify. Should be fixed now.

Exellent

Kristian