Subject: [FFC-dev] Re: [DOLFIN-dev] Heat: [...]

From: Anders Logg <[email-masked]>
Date: Thu, 3 Nov 2005 08:34:16 -0600

ok, it seems natural to implement .dt() similarly to .dx() and then
adding Dt() as an alternative notation corresponding to D( ,i) for
space derivatives.

To begin with, only time derivatives of basis functions will be
allowed (not of functions or other expressions).

/Anders

On Thu, Nov 03, 2005 at 09:32:12AM +0100, Johan Hoffman wrote:

> Since we have derivatives with respect to both x and t, I think it may be
> a good idea to have the t explicit: Dt(u) or maybe u.dt() ?
> 
> /Johan
> 
> 
> > It looks good:
> >
> >     a = u * v * dx
> >     L = (-dot(grad(u1), grad(v)) + f * v) * dx
> >
> > It's pretty close to what we want to have eventually:
> >
> >     a = Dt(u) * v * dx
> >     L = (-dot(grad(u1), grad(v)) + f * v) * dx
> >
> > Is Dt() a good choice? I would have liked to overload ' so one could
> > write
> >
> >     a = u' * v * dx
> >
> > but that does not seem to be possible.
> >
> > /Anders
> >
> > On Wed, Nov 02, 2005 at 06:02:31PM +0100, [email-masked] wrote:
> >> Commit from johanjan (2005-11-02 18:02 CET)
> >> --------------------
> >>
> >> Heat:
> >>
> >> Add mass matrix (lumped for now). Use dG(0). Cleanups.
> >>
> >>   dolfin  src/modules/heat/HeatSolver.cpp       1.10
> >>   dolfin  src/modules/heat/dolfin/Heat.form     1.2
> >>   dolfin  src/modules/heat/dolfin/Heat.h        1.2
> >>   dolfin  src/modules/heat/dolfin/HeatSolver.h  1.4
> >>   dolfin  src/demo/solvers/heat/main.cpp        1.8
> >>
> >> _______________________________________________
> >> DOLFIN-dev mailing list
> >> [email-masked]
> >> http://www.fenics.org/cgi-bin/mailman/listinfo/dolfin-dev
> >>
> >
> >
> > _______________________________________________
> > DOLFIN-dev mailing list
> > [email-masked]
> > http://www.fenics.org/cgi-bin/mailman/listinfo/dolfin-dev
> >
> 
> 
> 
> _______________________________________________
> DOLFIN-dev mailing list
> [email-masked]
> http://www.fenics.org/cgi-bin/mailman/listinfo/dolfin-dev
> 

-- 
Anders Logg
Research Assistant Professor
Toyota Technological Institute at Chicago
http://www.tti-c.org/logg/

---

From: "Johan Hoffman" <[email-masked]>
Date: Thu, 3 Nov 2005 16:26:07 +0100 (MET)

Good, the time differentiation of basis functions should cover a lot of
equations.

/Johan

> FFC-dev mailing list
> [email-masked]
> http://www.fenics.org/cgi-bin/mailman/listinfo/ffc-dev
>

-- 
Johan Hoffman, PhD
Assistant Professor
School of Computer Science and Communication
Royal Institute of Technology KTH
SE-100 44 Stockholm
Sweden

Email: [email-masked]
URL: www.nada.kth.se/~jhoffman