Subject: [FFC-dev] FFC errors

From: Ilmar Wilbers <[email-masked]>
Date: Thu, 07 Aug 2008 15:27:34 +0200

I am getting this error on several of the buildbots:

./../../demo/pde/stokes/stabilized/python (Python)
--------------------------------------------------------------------------
Solving linear PDE.
Form module in cache seems to be broken, need to rebuild module
Calling FFC just-in-time (JIT) compiler, this may take some time... done
Creating Python extension (compiling and linking), this may take some time... done
Traceback (most recent call last):
  File "./demo.py", line 95, in <module>
    (U, P) = pde.solve().split()
  File "/home/buildbot/local/tmp/lib/python2.5/site-packages/dolfin/pde.py", line 45, in solve
    (A, self.dof_maps) = assemble(self.a, self.mesh, return_dofmaps=True)
  File "/home/buildbot/local/tmp/lib/python2.5/site-packages/dolfin/assemble.py", line 47, in assemble
    (compiled_form, module, form_data) = jit(form, form_compiler_options)
  File "/home/buildbot/local/tmp/lib/python2.5/site-packages/dolfin/assemble.py", line 189, in jit
    return jit_compile(form, options)
  File "/home/buildbot/local/lib/python2.5/site-packages/ffc/jit/jit.py", line 130, in jit
    build_module(form, representation, language, _options, md5sum, form_dir, module_dir, prefix, cpp_args)
  File "/home/buildbot/local/lib/python2.5/site-packages/ffc/jit/jit.py", line 177, in build_module
    shutil.move(module_name, module_dir)
  File "/usr/lib/python2.5/shutil.py", line 196, in move
    copytree(src, dst, symlinks=True)
  File "/usr/lib/python2.5/shutil.py", line 110, in copytree
    os.makedirs(dst)
  File "/usr/lib/python2.5/os.py", line 173, in makedirs
    mkdir(name, mode)
OSError: [Errno 17] File exists: '/home/buildbot/.ffc/cache/form_28847c5fa4df496fc782ff950cd841c3/form_28847c5fa4df496fc782ff950cd841c3_module'

Although this is solved by running ffc-clean, this does not seem like 
the proper behaviour?

ilmar

---

From: Anders Logg <[email-masked]>
Date: Thu, 7 Aug 2008 21:25:37 +0200

> ./../../demo/pde/stokes/stabilized/python (Python)

I tried to reproduced this but I couldn't. It should be easy to fix if
I can get my hands on it.

-- 
Anders

---

From: Ilmar Wilbers <[email-masked]>
Date: Fri, 08 Aug 2008 14:11:54 +0200

I tried to reproduce it by altering the __init__ files in cache and 
various other things, without success. Will eave things as they are next 
time it happens, I really cannot understand how this can happen after 
having a closer look at jit.py.

ilmar