Subject: Re: [FFC-dev] - Fix bug in dofmap() for equal order mixed elements [...]

From: "Garth N. Wells" <[email-masked]>
Date: Mon, 26 Sep 2005 17:09:34 +0200

That fixes the problem. 

Also, I've tested a reasonably complex mixed problem using the new fcc mixed
element functionality against a previous implementation using a vector, and the
results are identical.

Garth 

Quoting [email-masked]:

> Commit from logg (2005-09-26 17:02 CEST)
> ----------------
> 
>  - Fix bug in dofmap() for equal order mixed elements
>  - Add compiler option -d debuglevel
> 
> Garth, see if this helps.
> 
> Also, there is now a new command-line flag -d debuglevel. If > 0, more
> debug info will be printed during compilation (level 1 is reasonable).
> Also, ffc won't catch exceptions with this option.
> 
>   ffc  ChangeLog                            1.80
>   ffc  src/bin/ffc                          1.23
>   ffc  src/ffc/common/debug.py              1.4
>   ffc  src/ffc/compiler/dofmap.py           1.21
>   ffc  src/ffc/compiler/referencetensor.py  1.12
> 
> _______________________________________________
> FFC-dev mailing list
> [email-masked]
> http://www.fenics.org/cgi-bin/mailman/listinfo/ffc-dev
>

---

From: Anders Logg <[email-masked]>
Date: Mon, 26 Sep 2005 10:16:50 -0500

Great. We should probably add some functionality on the DOLFIN side to
deal with subvectors/components of Functions so one can easily solve a
mixed system and save the different parts/components as different
fields for visualization. I assume you do this manually now?

/Anders

-- 
Anders Logg
Research Assistant Professor
Toyota Technological Institute at Chicago
http://www.tti-c.org/logg/

---

From: Anders Logg <[email-masked]>
Date: Mon, 26 Sep 2005 10:16:50 -0500

/Anders

---

From: "Garth N. Wells" <[email-masked]>
Date: Mon, 26 Sep 2005 17:40:49 +0200

Yep, I make a "dummy" element using ffc with the appropriate number of
components, then with this element I define a function, giving the function the
appropriate chunk of the solution vector. It would be nicer if a new function
could be 'extracted' from an existing function for given components.

Garth

---

From: Anders Logg <[email-masked]>
Date: Mon, 26 Sep 2005 11:14:47 -0500

ok, I'll put this in the queue.

/Anders

On Mon, Sep 26, 2005 at 05:40:49PM +0200, Garth N. Wells wrote:

> Yep, I make a "dummy" element using ffc with the appropriate number
> of components, then with this element I define a function, giving
> the function the appropriate chunk of the solution vector. It would
> be nicer if a new function could be 'extracted' from an existing
> function for given components.
> 
> Garth
> 
>