Subject: [FFC-dev] [HG FFC] Updated test.py in verify_tensors such that UFL files can be handled too.

From: [email-masked] (FFC)
Date: Mon, 16 Feb 2009 12:35:25 +0100 (CET)

One or more new changesets pushed to the primary ffc repository.
A short summary of the last three changesets is included below.

changeset:   1312:82bdc244ad7f6650e13da7e554d39fffc5ed6fc7
tag:         tip
user:        "Kristian Oelgaard <[email-masked]>"
date:        Mon Feb 16 12:34:35 2009 +0100
files:       ffc/compiler/codegeneration/quadrature/uflquadraturegenerator_utils.py test/verify_tensors/test.py
description:
Updated test.py in verify_tensors such that UFL files can be handled too.

changeset:   1311:eb089e56af7e4370ee04121318c6114e1ca54ef6
user:        "Kristian Oelgaard <[email-masked]>"
date:        Fri Feb 13 15:10:22 2009 +0100
files:       ffc/compiler/codegeneration/quadrature/uflquadraturegenerator.py ffc/compiler/codegeneration/quadrature/uflquadraturegenerator_utils.py ffc/compiler/representation/quadrature/uflquadraturerepresentation.py ffc/compiler/uflcompiler.py
description:
The UFL qudrature generator is now able to generate code for function products. However, the code is not optimal yet, and the design of the codegeneration will need many more iterations.

changeset:   1310:d35d7c0432e2a14182964689f3f859de214d7a9e
parent:      1309:6ad3dd2975d404e05d5f6fa19cd67ac3511d498e
parent:      1307:270dd8b7cedc39e61f5a0818da710fe031edcd46
user:        "Kristian Oelgaard <[email-masked]>"
date:        Thu Feb 12 13:32:34 2009 +0100
files:       ffc/compiler/uflcompiler.py
description:
merge

----------------------------------------------------------------------
For more details, visit http://www.fenics.org/hg/ffc

---

From: Kristian Oelgaard <[email-masked]>
Date: Mon, 16 Feb 2009 13:24:30 +0100

Quoting FFC <[email-masked]>:

> files:      
> ffc/compiler/codegeneration/quadrature/uflquadraturegenerator_utils.py
> test/verify_tensors/test.py
> description:

Should we add UFL equivalents of the forms in the demo directory? Or do we want
to put them in a separate directory?

Kristian
 
> files:       ffc/compiler/codegeneration/quadrature/uflquadraturegenerator.py
> ffc/compiler/codegeneration/quadrature/uflquadraturegenerator_utils.py
> ffc/compiler/representation/quadrature/uflquadraturerepresentation.py
> ffc/compiler/uflcompiler.py
> description:
> The UFL qudrature generator is now able to generate code for function
> products. However, the code is not optimal yet, and the design of the
> codegeneration will need many more iterations.
> 
> 
> _______________________________________________
> FFC-dev mailing list
> [email-masked]
> http://www.fenics.org/mailman/listinfo/ffc-dev
>

---

From: Anders Logg <[email-masked]>
Date: Mon, 16 Feb 2009 13:32:13 +0100

> to put them in a separate directory?

Yes, it would be good to add UFL equivalents of all the forms. We can
drop them in the same directory as the suffix (.ufl) will be
different.

All the FFC demo forms in UFL notation can be found in
test/ffcforms.py in UFL.

Will you add a try/except or similar for the UFL import in the
quadrature code generator so the buildbots won't complain?

-- 
Anders

---

From: Kristian Oelgaard <[email-masked]>
Date: Mon, 16 Feb 2009 13:44:35 +0100

> All the FFC demo forms in UFL notation can be found in

OK, I'll add them then.
 
> quadrature code generator so the buildbots won't complain?

I have switched them back on.

Kristian

> ffc/compiler/codegeneration/quadrature/uflquadraturegenerator.py

---

From: Anders Logg <[email-masked]>
Date: Mon, 16 Feb 2009 14:54:40 +0100

> > All the FFC demo forms in UFL notation can be found in

Looks nice. When we find the time, we can remove all the "FFC
notation" comments.

> I have switched them back on.

Great.

-- 
Anders

---

From: Kristian Oelgaard <[email-masked]>
Date: Mon, 16 Feb 2009 14:59:35 +0100

Quoting Anders Logg <[email-masked]>:

> > > > Should we add UFL equivalents of the forms in the demo directory? Or do
> we
> > > want

I left them there on purpose for quick reference, but of course one can open the
corresponding *.form file.
I can delete them if you want.

Kristian

---

From: Anders Logg <[email-masked]>
Date: Mon, 16 Feb 2009 15:17:10 +0100

> I can delete them if you want.

Yes, that would be good. The comments are still there in the UFL test
script so we can use it to write some kind of transition guide later.

-- 
Anders