Subject: Re: [FFC-dev] [DOLFIN-dev] Intel MKL CBLAS and DOLFIN

From: "Garth N. Wells" <[email-masked]>
Date: Thu, 28 Sep 2006 15:38:29 +0200

Dag Lindbo wrote:
> Hi,
> 
> Has anyone used Intel MKL CBLAS with DOLFIN and FFC CBLAS output?
> Compilation works fine if I include "mkl_cblas.h" instead, and link with
> libmkl. But at runtime I get:
> 
> *** Error at BLASFormData.cpp:47: init()  Inconsistent BLAS form data for
> interior contribution.
>

The FFC BLAS output format is currently broken. It hasn't been updated
for boundary integrals. I might get around to fixing it soon if it's not
too much work.

Garth

> Any suggestions?
> 
> /Dag
> 
> _______________________________________________
> DOLFIN-dev mailing list
> [email-masked]
> http://www.fenics.org/mailman/listinfo/dolfin-dev
>

---

From: "Dag Lindbo" <[email-masked]>
Date: Thu, 28 Sep 2006 15:41:50 +0200 (MEST)

> for boundary integrals. I might get around to fixing it soon if it's not

Well, I'm only using element integrals in FFC.

---

From: "Garth N. Wells" <[email-masked]>
Date: Thu, 28 Sep 2006 15:44:32 +0200

> Well, I'm only using element integrals in FFC.

Unfortunately, this doesn't help since FFC will still try to write
functions for the boundary integrals (they will be empty).

Garth

---

From: "Dag Lindbo" <[email-masked]>
Date: Thu, 28 Sep 2006 15:46:30 +0200 (MEST)

> functions for the boundary integrals (they will be empty).

Ok, I see. It's not very important to use BLAS for me, so I'll revert.

Thanks,
/Dag