Subject: [FFC-dev] ffc compile takes several hours

From: Chong Luo <[email-masked]>
Date: Mon, 22 Dec 2008 12:21:16 -0800 (PST)

Sometimes, ffc can take too much time to compile a form file. For example, for the file in the attachment, it takes more than two hours to compile (after two hours, I became impatient and killed the process). I've used "-r quadrature" switch, and my desktop is reasonablly fast (Intel Q6600+6G DDR2 1000).

The attachment is just one example. For the problem I'm trying to solve using fenics, it has the same slow compilation problem.

Is there any other trick that can speed up the compilation to be within, say, 10 minutes?

Best,
Chong

---

From: "Garth N. Wells" <[email-masked]>
Date: Mon, 22 Dec 2008 22:11:32 +0000

Chong Luo wrote:
> Sometimes, ffc can take too much time to compile a form file. For 
> example, for the file in the attachment, it takes more than two hours to 
> compile (after two hours, I became impatient and killed the process). 
> I've used "-r quadrature" switch, and my desktop is reasonablly fast 
> (Intel Q6600+6G DDR2 1000).
> 

This is a known issue with FFC for complicated forms. Hopefully it will 
be resolved after the transition to UFL since for quadrature code the 
UFL representation of forms should be more suitable.

Garth

> The attachment is just one example. For the problem I'm trying to solve 
> using fenics, it has the same slow compilation problem.
> 
> ------------------------------------------------------------------------
> 
> _______________________________________________
> FFC-dev mailing list
> [email-masked]
> http://www.fenics.org/mailman/listinfo/ffc-dev

---

From: Chong Luo <[email-masked]>
Date: Wed, 31 Dec 2008 08:08:14 -0800 (PST)

Thank you. The transition to UFL sounds promising. May I ask at what stage that transition is now?

The new year is coming, I wish a happy new year for all the developers of FEniCS, you guys are great!

Best,
Chong

________________________________
From: Garth N. Wells <[email-masked]>
To: Chong Luo <[email-masked]>
Cc: [email-masked]
Sent: Monday, December 22, 2008 4:11:32 PM
Subject: Re: [FFC-dev] ffc compile takes several hours

> Sometimes, ffc can take too much time to compile a form file. For example, for the file in the attachment, it takes more than two hours to compile (after two hours, I became impatient and killed th…

This is a known issue with FFC for complicated forms. Hopefully it will be resolved after the transition to UFL since for quadrature code the UFL representation of forms should be more suitable.

Garth

---

From: Anders Logg <[email-masked]>
Date: Wed, 31 Dec 2008 17:50:54 +0100

> Thank you. The transition to UFL sounds promising. May I ask at what stage that

The transition is at approximately 1% right now. We will get started
on the transition in January. UFL itself is in a very good shape (but
not finished). All demos in FFC can be expressed in UFL. It "just"
remains to use the new representation in FFC.

> FEniCS, you guys are great!

Happy new year.

-- 
Anders

> Best,
> Chong
> ━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
> > Sometimes, ffc can take too much time to compile a form file. For example,
> for the file in the attachment, it takes more than two hours to compile (after
> two hours, I became impatient and killed the process). I've used "-r
> quadrature" switch, and my desktop is reasonablly fast (Intel Q6600+6G DDR2
> 1000).
> >
> 
> This is a known issue with FFC for complicated forms. Hopefully it will be
> resolved after the transition to UFL since for quadrature code the UFL
> representation of forms should be more suitable.
> 
> Garth
> 
> > The attachment is just one example. For the problem I'm trying to solve using
> fenics, it has the same slow compilation problem.
> >

---

From: "Garth N. Wells" <[email-masked]>
Date: Wed, 31 Dec 2008 19:31:05 +0000

> remains to use the new representation in FFC.

Is an FFC release needed before starting the transition?

Garth

---

From: Anders Logg <[email-masked]>
Date: Wed, 31 Dec 2008 22:40:52 +0100

> Is an FFC release needed before starting the transition?

Yes, definitely. We need to make a release at the same time as we
release the new DOLFIN version. We also need a new Viper version.

Considering the rather big interface changes, it should probably be
FFC 0.6.0.

-- 
Anders