Subject: [FFC-dev] Release time

From: Anders Logg <[email-masked]>
Date: Tue, 22 Sep 2009 18:35:07 +0200

Are we ready for a release of FFC 0.7.0?

It would be good to release UFC/UFL/FFC a day or so before DOLFIN so
we can recompile all code in DOLFIN using FFC 0.7.0.

--
Anders

---

From: "Garth N. Wells" <[email-masked]>
Date: Tue, 22 Sep 2009 17:38:38 +0100

> Are we ready for a release of FFC 0.7.0?

I'd say yes.

Garth

> ------------------------------------------------------------------------
> 
> _______________________________________________
> FFC-dev mailing list
> [email-masked]
> http://www.fenics.org/mailman/listinfo/ffc-dev

---

From: Anders Logg <[email-masked]>
Date: Tue, 22 Sep 2009 18:44:26 +0200

> > Are we ready for a release of FFC 0.7.0?

ok, let's just wait for Kristian.

--
Anders

---

From: Kristian Oelgaard <[email-masked]>
Date: Tue, 22 Sep 2009 18:20:56 +0200

> ok, let's just wait for Kristian.

I think FFC is ready for a release. There is some cleaning up to do and at some
point we might want to improve the quality of the code.
pylint rates FFC 2.24/10.
Another issue is the coverage of our tests which I think can be improved.

Kristian

---

From: "Garth N. Wells" <[email-masked]>
Date: Tue, 22 Sep 2009 19:17:28 +0100

> pylint rates FFC 2.24/10.

How does FIAT score? ;)

Garth

---

From: Kristian Oelgaard <[email-masked]>
Date: Tue, 22 Sep 2009 19:22:49 +0200

> > pylint rates FFC 2.24/10.

Not too bad (compared to FFC):

1.19/10

Kristian

---

From: Anders Logg <[email-masked]>
Date: Sat, 26 Sep 2009 23:23:11 +0200

> Another issue is the coverage of our tests which I think can be improved.

I get 3.60. Here's some more statistics:

  DOLFIN: 4.95
  FFC     3.60
  FIAT    0.22

But we could definitely do some cleanups and improvements.

--
Anders