Subject: [FFC-dev] bubbles

From: Alessio Quaglino <[email-masked]>
Date: Mon, 24 Nov 2008 14:07:10 +0100

Hi,

I wonder if you are planning to support the generation of additional cubic bubbles to the elements (to enrich the spaces), or if I should move to sy-fi in order to try to do this.

Thank you
Alessio

---

From: Anders Logg <[email-masked]>
Date: Mon, 24 Nov 2008 14:09:24 +0100

> I wonder if you are planning to support the generation of additional cubic bubbles to the elements (to enrich the spaces), or if I should move to sy-fi in order to try to do this.

There are no immediate plans.

-- 
Anders

---

From: "Robert Kirby" <[email-masked]>
Date: Mon, 24 Nov 2008 08:41:27 -0600

FIAT is also a place to put this in the FFC context.  This is a holiday week
in the US, and I have one class day before going to family.
After break, I can put in a P1 + bubble element if it's needed.

Rob

On Mon, Nov 24, 2008 at 7:09 AM, Anders Logg <[email-masked]> wrote:

> > I wonder if you are planning to support the generation of additional
> cubic bubbles to the elements (to enrich the spaces), or if I should move to
> sy-fi in order to try to do this.
> >
> > Thank you
> > Alessio
>
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v1.4.9 (GNU/Linux)
>
> iEYEARECAAYFAkkqp4QACgkQTuwUCDsYZdGstQCfcPF5WRZKoYnWQ/lTzXGyRScs
> /7YAoIbqyMMlK3l9+/q+YntAQcf8UDuK
> =Nf5y
> -----END PGP SIGNATURE-----
>
> _______________________________________________
> FFC-dev mailing list
> [email-masked]
> http://www.fenics.org/mailman/listinfo/ffc-dev
>
>

---

From: "Garth N. Wells" <[email-masked]>
Date: Mon, 24 Nov 2008 14:48:39 +0000

Robert Kirby wrote:
> FIAT is also a place to put this in the FFC context.  
> This is a holiday week in the US, and I have one class day before going 
> to family.

Also, eliminating local degrees of freedom was somewhere on the DOLFIN 
todo list.

Garth

> Rob
> 
> On Mon, Nov 24, 2008 at 7:09 AM, Anders Logg <[email-masked] 
> <mailto:[email-masked]>> wrote:
> 
>      > I wonder if you are planning to support the generation of
>     additional cubic bubbles to the elements (to enrich the spaces), or
>     if I should move to sy-fi in order to try to do this.
>      >
>      > Thank you
>      > Alessio
> 
>     [email-masked] <mailto:[email-masked]>
> ------------------------------------------------------------------------
>

---

From: Anders Logg <[email-masked]>
Date: Mon, 24 Nov 2008 15:54:39 +0100

> Also, eliminating local degrees of freedom was somewhere on the DOLFIN 

I guess it's been put on hold by our recent adventures with
Function and FunctionSpace.

FunctionSpace could help with adding things like elimination of dofs,
both internal dofs and dofs constrained by boundary conditions.

But before then, we need to (1) finish up the current work (Python
interface still broken) and make a release, then (2) get on with the
parallelization.

-- 
Anders