Subject: [FFC-dev] [HG FFC] Generate form constructors also including coefficients in addition

From: [email-masked] (FFC)
Date: Thu, 6 Nov 2008 20:54:18 +0100 (CET)

One or more new changesets pushed to the primary ffc repository.
A short summary of the last three changesets is included below.

changeset:   1262:b1f3b35b1c445f890f3add3ac8efd70976b062be
tag:         tip
user:        Anders Logg <[email-masked]>
date:        Thu Nov 06 20:54:14 2008 +0100
files:       ffc/compiler/format/dolfinformat.py
description:
Generate form constructors also including coefficients in addition
to constructors without coefficients.

changeset:   1261:7601cdc35b76afa6c55e664a8f7baf70e3aecad9
user:        Anders Logg <[email-masked]>
date:        Sat Nov 01 22:04:15 2008 +0100
files:       ffc/compiler/analysis/formdata.py
description:
Allow compiler to generate code even if not all function names may be
extracted (will be named w0, w1 etc).

changeset:   1260:928510e8c89dd5b76011ef1f5aeaa95e64fc732a
user:        Anders Logg <[email-masked]>
date:        Sat Nov 01 21:28:30 2008 +0100
files:       ffc/compiler/format/dolfinformat.py
description:
Fix generation of FunctionSpace code for -l dolfin

----------------------------------------------------------------------
For more details, visit http://www.fenics.org/hg/ffc

---

From: "Garth N. Wells" <[email-masked]>
Date: Thu, 06 Nov 2008 20:14:47 +0000

For the 'shared' versions, shouldn't the coefficients also be shared 
pointers?

There's still a problem with duplicate constructors for functionals 
which prevents compilation.

Garth

FFC wrote:
> _______________________________________________
> FFC-dev mailing list
> [email-masked]
> http://www.fenics.org/mailman/listinfo/ffc-dev

---

From: Anders Logg <[email-masked]>
Date: Thu, 6 Nov 2008 21:49:11 +0100

> For the 'shared' versions, shouldn't the coefficients also be shared 

It's not necessary since these arguments will not be stored as
data. They will just be assigned to the coefficients.

> which prevents compilation.

I'm working on it. It's a mess to generate code when we want to
provide various versions of all constructors: with and without
shared pointers, and with our without coefficients, and in some cases
with coefficients may mean without coefficients (if there are no
coefficients) so we get duplicate constructors that look the
same...

-- 
Anders