Subject: [FFC-dev] demo dg

From: [email-masked]
Date: Wed, 6 Jun 2007 19:34:52 +0100 (WEST)

> When trying to create Poisson.h with ffc it returns
> FIRST:
>
> >ffc -l dolfin Poisson.form
> This is FFC, the FEniCS Form Compiler, version 0.3.5.
> For further information, go to http://www/fenics.org/ffc/.
>
> Preprocessing form file: Poisson.form --> Poisson.py
>
> Phase 1: Analyzing form
> -----------------------
>
>   Checking validity of form...
> *** Error at -w1_a148(dXa147/dx0) |
> ((d/dXa147)vi-2)*vi-1(+)*va148[0](+)*ds(0)
> *** Integrand may not be restricted in an exterior facet integral.
> *** To get more information about this error, rerun ffc with the option
-d1.

> AND THEN
>
> >ffc -d1 -l dolfin Poisson.form
> This is FFC, the FEniCS Form Compiler, version 0.3.5.
> For further information, go to http://www/fenics.org/ffc/.
>
> Preprocessing form file: Poisson.form --> Poisson.py
>
> Phase 1: Analyzing form
> -----------------------
>
>   Checking validity of form...
> Traceback (most recent call last):
>   File "/home/paulo/builds/bin/ffc", line 190, in ?
>     sys.exit(main(sys.argv[1:]))
>   File "/home/paulo/builds/bin/ffc", line 103, in main
>     execfile(outname, ns)
>   File "Poisson.py", line 52, in ?
>     compile([a, L, M, element], "Poisson", "tensor", "dolfin", {'blas':
> False, 'precision=': '15', 'optimize': False})
>   File "/usr/lib/python2.4/site-packages/ffc/compiler/compiler.py", line
> 63, in compile
>     __compile_forms(forms, prefix, representation, output_language,
options)
>   File "/usr/lib/python2.4/site-packages/ffc/compiler/compiler.py", line
> 86, in __compile_forms
>     form_data = analyze_form(form)
>   File "/usr/lib/python2.4/site-packages/ffc/compiler/compiler.py", line
> 166, in analyze_form
>     form_data = analyze(form)
>   File
> "/usr/lib/python2.4/site-packages/ffc/compiler/analysis/analyze.py",
> line 27, in analyze
>     check_form(form)
>   File "/usr/lib/python2.4/site-packages/ffc/compiler/analysis/checks.py",
> line 23, in check_form
>     check_restrictions(form)
>   File "/usr/lib/python2.4/site-packages/ffc/compiler/analysis/checks.py",
> line 48, in check_restrictions
>     raise FormError, (p, "Integrand may not be restricted in an exterior
> facet integral.")
> ffc.common.exceptions.FormError
>
> I created a directory with the originals 'main.cpp', 'Makefile' and
> Poisson.form. I did the same proceeding in the case of pde/Poisson and
pde/convection-diffusion and it
> worked.
> /Paulo

---

From: Anders Logg <[email-masked]>
Date: Wed, 6 Jun 2007 20:44:45 +0200

Looks like you have an old version of FFC. Update and it should work.
(I recognize the error message as something we fixed a few days back.)

/Anders

On Wed, Jun 06, 2007 at 07:34:52PM +0100, [email-masked] wrote:
> _______________________________________________
> FFC-dev mailing list
> [email-masked]
> http://www.fenics.org/mailman/listinfo/ffc-dev

---

From: Kristian Oelgaard <[email-masked]>
Date: Thu, 07 Jun 2007 08:33:38 +0200

Quoting [email-masked]:

> I updated FFC but it keeps giving the very same error message...
> 
> /paulo

Then something is wrong with your installation, I just cloned FFC and the line
that gives you an error is commented out.

Kristian
 
> >> "/usr/lib/python2.4/site-packages/ffc/compiler/analysis/checks.py",
> >> > line 23, in check_form
> >> >     check_restrictions(form)
> >> >   File
> >> "/usr/lib/python2.4/site-packages/ffc/compiler/analysis/checks.py",
> DOLFIN-dev mailing list
> [email-masked]
> http://www.fenics.org/mailman/listinfo/dolfin-dev
>