Subject: [FFC-dev] [HG FFC] Use propagate_restrictions for -O quadrature.

From: [email-masked] (FFC)
Date: Tue, 20 Oct 2009 10:02:01 +0200 (CEST)

One or more new changesets pushed to the primary ffc repository.
A short summary of the last three changesets is included below.

changeset:   1702:b974130238c8
tag:         tip
user:        "Kristian Oelgaard <[email-masked]>"
date:        Tue Oct 20 10:01:48 2009 +0200
files:       ffc/compiler/quadrature/optimisedquadraturetransformer.py
description:
Use propagate_restrictions for -O quadrature.

changeset:   1701:2ed6d6c84bef
user:        "Kristian Oelgaard <[email-masked]>"
date:        Mon Oct 19 17:54:28 2009 +0200
files:       ffc/compiler/quadrature/optimisedquadraturetransformer.py ffc/compiler/quadrature/quadraturetransformer.py ffc/compiler/quadrature/symbolics.py
description:
Comment hotshot import to make buildbot happy.

changeset:   1700:835b1ae2977c
parent:      1699:abd4102e7d16
parent:      1692:a898293f3256
user:        "Kristian Oelgaard <[email-masked]>"
date:        Mon Oct 19 17:37:41 2009 +0200
files:       ffc/compiler/language/README ffc/compiler/language/algebra.py
description:
merge

----------------------------------------------------------------------
For more details, visit http://www.fenics.org/hg/ffc

---

From: "Garth N. Wells" <[email-masked]>
Date: Tue, 20 Oct 2009 18:16:31 +0100

> Use propagate_restrictions for -O quadrature.

It looks like some of the recent changes to the quadrature code have 
broken restrictions to cell facets. My solver worked fine at

   changeset 9c35a629d382

but is broken at

   changeset 300e62f9d068

Doesn't work with or without optimisation.

Garth

> _______________________________________________
> FFC-dev mailing list
> [email-masked]
> http://www.fenics.org/mailman/listinfo/ffc-dev

---

From: Anders Logg <[email-masked]>
Date: Wed, 21 Oct 2009 13:31:58 +0200

> Doesn't work with or without optimisation.

I also have problems with the latest version.

I'm seeing things like

 File
 "/home/logg/scratch/lib/fenics-dev/lib/python2.6/site-packages/ufl/algorithms/transformations.py",
 line 132, in visit
    r = h(o)
  File
  "/home/logg/scratch/lib/fenics-dev/lib/python2.6/site-packages/ffc/compiler/quadrature/quadraturetransformerbase.py",
  line 208, in zero
    error("Zero is not supported (yet).")
  File "<string>", line 1, in <lambda>
  File
  "/home/logg/scratch/lib/fenics-dev/lib/python2.6/site-packages/ufl/log.py",
  line 106, in error
    raise UFLException(self._format_raw(*message))
ufl.log.UFLException: Zero is not supported (yet).

--
Anders

---

From: Kristian Oelgaard <[email-masked]>
Date: Wed, 21 Oct 2009 13:00:27 +0200

> ufl.log.UFLException: Zero is not supported (yet).

I just pushed a changeset that should take care of your problem Anders.

Kristian

> ffc/compiler/quadrature/quadraturetransformer.py
> ffc/compiler/quadrature/symbolics.py
> > > description:

---

From: Anders Logg <[email-masked]>
Date: Wed, 21 Oct 2009 14:03:28 +0200

> I just pushed a changeset that should take care of your problem Anders.

Thanks! It did.

--
Anders

---

From: Kristian Oelgaard <[email-masked]>
Date: Wed, 21 Oct 2009 14:44:25 +0200

> > Doesn't work with or without optimisation.

I just pushed a changeset which should fix your problem Garth.

Kristian