Subject: [FFC-dev] Test functions which are zero on the Dirichlet boundary?

From: Chong Luo <[email-masked]>
Date: Fri, 6 Jun 2008 19:15:33 -0700 (PDT)

Is it possible to specify test functions which are zero on the Dirichlet boundary?

For example, let's say we want to use mixed finite element to solve Poisson's equation with both Neumann and Dirichlet boundary conditions:
- Laplace (p) = f  in Omega
p = pD on Gamma0
dp/dn = uN on Gamma1

So we introduce velocity u = - grad(p), and get the following mixed formulation:
(u, v) + (v, grad(p)) = 0                           for all v in X
(u, grad(q))  = -(f,q) + <q, uN>              for all q in M
where (,) is integration on Omega, while <,> is integration on the boundary of Omega.

I found that I need to take test function q such that q is zero on the Dirichlet boundary Gamma0 (which has to be nonempty), for this mixed formulation to satisfy LBB condition.  Is it possible to specify this constraint in FFC/FEniCS?

Thank you!

Best,
Chong Luo

---

From: Anders Logg <[email-masked]>
Date: Sat, 7 Jun 2008 10:19:33 +0200

> Is it possible to specify test functions which are zero on the Dirichlet

No, you have to apply such constraints afterwards to the linear
system, using the DirichletBC class in DOLFIN.

> For example, let's say we want to use mixed finite element to solve Poisson's
> equation with both Neumann and Dirichlet boundary conditions:
> I found that I need to take test function q such that q is zero on the
> Dirichlet boundary Gamma0 (which has to be nonempty), for this mixed
> formulation to satisfy LBB condition.  Is it possible to specify this
> constraint in FFC/FEniCS?
> 
> Thank you!

There is a demo that demonstrates how to implement the mixed Poisson
system in DOLFIN. Take a look in

  demo/pde/mixed-poisson/

This demo uses BDM1 elements for the flux and DG0 elements for the
pressure to get stability.

-- 
Anders