Subject: [FFC-dev] Patch with changes to ffc

From: Johan Hake <[email-masked]>
Date: Fri, 20 Mar 2009 14:42:00 +0100

Hello!

Provided is a patch with changes to ffc.jit for the new interface of 
ufc_utils.build_ufc_module.

Johan
# HG changeset patch
# User "Johan Hake <[email-masked]>"
# Date 1237556399 -3600
# Node ID cc41c528d8a021ca8047a6511f43ce12f9a82eb0
# Parent  8a54bfbdbe412e91fcb178dd6f9ad2c785e323ce
Updates to ffc.jit() to use the new interface of ufc_utils.build_ufc_module()

diff -r 8a54bfbdbe41 -r cc41c528d8a0 ffc/jit/jit.py
--- a/ffc/jit/jit.py	Fri Mar 20 13:43:18 2009 +0100
+++ b/ffc/jit/jit.py	Fri Mar 20 14:39:59 2009 +0100
@@ -104,10 +104,11 @@
 
     # Create python extension module
     module = ufc_utils.build_ufc_module(
-        signature,
-        signature + ".h",
-        cpp_files = signature + ".cpp" if options["split_implementation"] else None,
-        cpp_args  = ["-O2"] if options["cpp optimize"] else ["-O0"] ,
+        signature + ".h", 
+        source_directory = os.curdir,
+        signature = signature,
+        sources = signature + ".cpp" if options["split_implementation"] else [],
+        cppargs  = ["-O2"] if options["cpp optimize"] else ["-O0"] ,
         cache_dir = options["cache_dir"])
 
     # Remove code

---

From: Anders Logg <[email-masked]>
Date: Fri, 20 Mar 2009 14:55:09 +0100

> +++ b/ffc/jit/jit.py	Fri Mar 20 14:39:59 2009 +0100

Thanks! Applied and pushed.

-- 
Anders