Subject: [FFC-dev] numbering module

From: "Alessio Quaglino" <[email-masked]>
Date: Wed, 27 Jun 2007 00:55:50 +0200 (CEST)

I've upgraded to the new version of dolfin/ffc/FIAT and I'm not able to
compile the form files anymore. I get the following error:

alessio@alessio-laptop:~/FEniCS/dolfin-0.7.0-1/src/kernel/elasticity-updated/dolfin$
sudo ffc *.form
*** Warning: Unable to reorder entities. You need to patch or update your
*** Warning: installation of FIAT. Variable numbering_scheme is missing.
*** Warning: Results may be incorrect for higher order elements on tets
Traceback (most recent call last):
  File "/usr/bin/ffc", line 26, in <module>
    from ffc.common.debug import *
  File "/usr/lib/python2.5/site-packages/ffc/__init__.py", line 14, in
<module>
    from ffc.fem.finiteelement import FiniteElement
  File "/usr/lib/python2.5/site-packages/ffc/fem/finiteelement.py", line
14, in <module>
    from FIAT.shapes import *
  File "/usr/lib/python2.5/site-packages/FIAT/shapes.py", line 19, in
<module>
    import numbering
ImportError: No module named numbering

Is there some module missing? Both numeric and numpy are installed on my
ubuntu system. Thanks.

Regards,
Alessio Quaglino

---

From: "Garth N. Wells" <[email-masked]>
Date: Wed, 27 Jun 2007 07:05:19 +0200

It doesn't look like you have the latest release of FIAT installed.

Garth

> _______________________________________________
> FFC-dev mailing list
> [email-masked]
> http://www.fenics.org/mailman/listinfo/ffc-dev
>

---

From: "Alessio Quaglino" <[email-masked]>
Date: Wed, 27 Jun 2007 07:50:47 +0200 (CEST)

I've deleted the old FIAT folder, downloaded the version 0.3.1 of FIAT and
then done:

alessio@alessio-laptop:~/FEniCS/FIAT-0.3.1$ sudo python setup.py install
running install
running build
running build_py
creating build
creating build/lib
creating build/lib/FIAT
copying FIAT/BDFM.py -> build/lib/FIAT
copying FIAT/BDM.py -> build/lib/FIAT
copying FIAT/CrouzeixRaviart.py -> build/lib/FIAT
copying FIAT/DiscontinuousLagrange.py -> build/lib/FIAT
copying FIAT/Lagrange.py -> build/lib/FIAT
copying FIAT/Nedelec.py -> build/lib/FIAT
copying FIAT/P0.py -> build/lib/FIAT
copying FIAT/PhiK.py -> build/lib/FIAT
copying FIAT/RaviartThomas.py -> build/lib/FIAT
copying FIAT/__init__.py -> build/lib/FIAT
copying FIAT/divfree.py -> build/lib/FIAT
copying FIAT/dualbasis.py -> build/lib/FIAT
copying FIAT/expansions.py -> build/lib/FIAT
copying FIAT/factorial.py -> build/lib/FIAT
copying FIAT/functional.py -> build/lib/FIAT
copying FIAT/functionalset.py -> build/lib/FIAT
copying FIAT/gamma.py -> build/lib/FIAT
copying FIAT/jacobi.py -> build/lib/FIAT
copying FIAT/polynomial.py -> build/lib/FIAT
copying FIAT/quadrature.py -> build/lib/FIAT
copying FIAT/shapes.py -> build/lib/FIAT
copying FIAT/test.py -> build/lib/FIAT
copying FIAT/testBDM.py -> build/lib/FIAT
copying FIAT/testRT.py -> build/lib/FIAT
copying FIAT/testned.py -> build/lib/FIAT
running install_lib
running install_egg_info
Removing /usr/lib/python2.5/site-packages/FIAT-0.3.1.egg-info
Writing /usr/lib/python2.5/site-packages/FIAT-0.3.1.egg-info

Did I forget something?

Alessio

---

From: "Garth N. Wells" <[email-masked]>
Date: Wed, 27 Jun 2007 08:03:54 +0200

Rob,

Looks like there is a problem with the FIAT release (0.3.1). The file 
"numbering.py is missing.

Garth

---

From: "Garth N. Wells" <[email-masked]>
Date: Wed, 27 Jun 2007 08:05:36 +0200

There's a problem with the FIAT release. You can clone the development 
version until the release is fixed.

Garth

---

From: Anders Logg <[email-masked]>
Date: Fri, 13 Jul 2007 23:20:31 +0200

Rob, I have updated the tarball for FIAT on fenics.org with the missing 
module (numbering.py) taken from the hg repository. I hope this is ok.

The new version number is 0.3.1-1.

/Anders