Subject: [FFC-dev] ffc-0.3.1 version problem with demos

From: osman b <[email-masked]>
Date: Tue, 28 Mar 2006 23:08:32 -0500

Hello,
Demos Projection.py, and TensorWeightedPoisson.form fail with:
ffc-0.3.1/src/demo> ffc Projection.form
*** 'module' object has no attribute 'dims'

rest work OK.
-- 
Osman F. Buyukisik

---

From: Anders Logg <[email-masked]>
Date: Tue, 28 Mar 2006 23:11:52 -0600

> *** 'module' object has no attribute 'dims'

Do you have the latest version of FIAT?

Both demos work for me. Try adding the flag -d1 to get extra debugging
info:

    ffc -d 1 Projection.form

What error message do you get?

/Anders

---

From: osman b <[email-masked]>
Date: Wed, 29 Mar 2006 06:57:40 -0500

> Do you have the latest version of FIAT?

FIAT-0.2.3

> What error message do you get?
osman@linux:~/SRC/ffc-0.3.1/src/demo> ffc -d1 Projection.form
This is FFC, the FEniCS Form Compiler, version 0.3.1.
For further information, go to http://www/fenics.org/ffc/.
Parsing Projection.form
Output written to Projection.py
Traceback (most recent call last):
  File "/usr/bin/ffc", line 124, in ?
    main(sys.argv[1:])
  File "/usr/bin/ffc", line 82, in main
    execfile(outname, ns)
  File "Projection.py", line 20, in ?
    P0 = FiniteElement("Discontinuous Lagrange", "triangle", 0)
  File "/usr/lib/python2.4/site-packages/ffc/compiler/finiteelement.py", line 
75, in __init__
    self.element = DiscontinuousLagrange(self.fiat_shape, degree)
  File "/usr/lib/python2.4/site-packages/FIAT/DiscontinuousLagrange.py", line 
87, in DiscontinuousLagrange
    if n == 0: return P0.P0( shape )
  File "/usr/lib/python2.4/site-packages/FIAT/P0.py", line 35, in __init__
    Udual = P0Dual( shape , U )
  File "/usr/lib/python2.4/site-packages/FIAT/P0.py", line 21, in __init__
    d = shapes.dims[ shape ]
AttributeError: 'module' object has no attribute 'dims'
osman@linux:~/SRC/ffc-0.3.1/src/demo>

-- 
Osman F. Buyukisik

---

From: "Garth N. Wells" <[email-masked]>
Date: Wed, 29 Mar 2006 14:08:57 +0200

> > Do you have the latest version of FIAT?
Try the latest FIAT (http://www.fenics.org/pub/software/fiat/snapshot/).
This should fix the problem.

Garth

---

From: Anders Logg <[email-masked]>
Date: Wed, 29 Mar 2006 14:14:50 -0600

I keep forgetting this all the time... There's a bug in P0.py in FIAT
0.2.3 which has been fixed in the CVS version.

Rob, could you make a new version 0.2.4 (or something) from the
current CVS of FIAT so the latest FIAT is up to date?

/Anders

On Wed, Mar 29, 2006 at 02:08:57PM +0200, Garth N. Wells wrote:
> _______________________________________________
> FFC-dev mailing list
> [email-masked]
> http://www.fenics.org/cgi-bin/mailman/listinfo/ffc-dev
> 

-- 
Anders Logg
Research Assistant Professor
Toyota Technological Institute at Chicago
http://www.tti-c.org/logg/

---

From: "Robert C. Kirby" <[email-masked]>
Date: Wed, 29 Mar 2006 14:28:44 -0600

OK.  It's almost seminar time.  It might be tomorrow.

On Mar 29, 2006, at 2:14 PM, Anders Logg wrote:

> FIAT-dev mailing list
> [email-masked]
> http://www.fenics.org/cgi-bin/mailman/listinfo/fiat-dev