Subject: [FIAT-dev] FIAT 0.2.3 released

From: "Garth N. Wells" <[email-masked]>
Date: Wed, 06 Jul 2005 08:59:10 +0200

The removal of FIAT/shapespoints.py seems to have caused a problem in FIAT
0.2.3. BDM.py tries to import shapespoints.py, but shapespoints.py doesn't exist
which leads to an error.

Garth

---

From: "Robert C. Kirby" <[email-masked]>
Date: Wed, 6 Jul 2005 09:27:26 -0500

Fixed -- renamed the file and just replaced the tarball on fenics.org
What are you doing with BDM, anyway?  Just curious...

Rob

On Jul 6, 2005, at 1:59 AM, Garth N. Wells wrote:

> _______________________________________________
> FIAT-dev mailing list
> [email-masked]
> http://www.fenics.org/cgi-bin/mailman/listinfo/fiat-dev
>

---

From: Anders Logg <[email-masked]>
Date: Wed, 6 Jul 2005 09:36:51 -0500

> 0.2.3. BDM.py tries to import shapespoints.py, but shapespoints.py doesn't exist

Strange. I don't have this problem and I can't see that BDM.py tries
to import shapespoints.py:

galerkin:~/work/src/fenics/fiat/FIAT-0.2.3> ls
build  FIAT  PKG-INFO  setup.py

galerkin:~/work/src/fenics/fiat/FIAT-0.2.3> grep shapespoints FIAT/*.py | wc
      0       0       0

/Anders

---

From: "Garth N. Wells" <[email-masked]>
Date: Wed, 06 Jul 2005 16:42:00 +0200

> galerkin:~/work/src/fenics/fiat/FIAT-0.2.3> grep shapespoints FIAT/*.py | wc

Here's line 9 in BDM.py from yesterdays FIAT 0.2.3 which caused the problem.

   import dualbasis, polynomial, functionalset, functional, shapespoints, PhiK

The new 0.2.3 tarball works fine.

Garth