Subject: [FIAT-dev] minor bug fix in P0 for entity_ids

From: [email-masked]
Date: Mon, 06 Jun 2005 23:19:30 +0200

Commit from kirby (2005-06-06 23:19 CEST)
-----------------

minor bug fix in P0 for entity_ids

  fiat  FIAT/P0.py  1.4

---

From: Anders Logg <[email-masked]>
Date: Mon, 6 Jun 2005 16:23:57 -0500

Looks good.

Johan, try again (latest cvs of both FIAT and FFC) and see if it works
now.

/Anders

On Mon, Jun 06, 2005 at 11:19:30PM +0200, [email-masked] wrote:
> _______________________________________________
> FIAT-dev mailing list
> [email-masked]
> http://www.fenics.org/cgi-bin/mailman/listinfo/fiat-dev
> 

-- 
Anders Logg
Research Assistant Professor
Toyota Technological Institute at Chicago
http://www.tti-c.org/logg/

---

From: Johan Jansson <[email-masked]>
Date: Tue, 7 Jun 2005 02:17:56 +0200

> Johan, try again (latest cvs of both FIAT and FFC) and see if it works

It seems to work correctly now, here's the relevant output:

    void dofmap(int dofs[], const Cell& cell, const Mesh& mesh) const
    {
      dofs[0] = cell.id();
      int offset = mesh.noCells();
      dofs[1] = offset + cell.id();
      offset = offset + mesh.noCells();
      dofs[2] = offset + cell.id();
    }

  Johan