Subject: [FIAT-dev] Bug in BDM entity_ids?

From: Anders Logg <[email-masked]>
Date: Thu, 25 Jan 2007 23:44:45 +0100

When running the following code:

    from FIAT.BDM import *
    from FIAT.shapes import *

    BDM1 = BDM(TRIANGLE, 1)

    print BDM1.dual_basis().entity_ids

I get

    {0: {0: [], 1: [], 2: []},
     1: {0: [0, 1], 1: [2, 3], 2: [4, 5]},
     2: []}

I'm expecting something like

    {0: {0: [], 1: [], 2: []},
     1: {0: [0, 1], 1: [2, 3], 2: [4, 5]},
     2: {0: []}}

So instead of an empty list for dimension 2, there should be a
dictionary containing one entity (the triangle) which has an empty
list of dofs.

?

/Anders

---

From: Anders Logg <[email-masked]>
Date: Fri, 26 Jan 2007 00:03:24 +0100

Excellent!

/Anders

On Thu, Jan 25, 2007 at 04:57:48PM -0600, Kirby, Robert C wrote:
> got it.  Easy to fix.  Should show up in the repository shortly.
> 
> 
> Robert C. Kirby
> Associate Professor
> Department of Mathematics and Statistics
> Texas Tech University
> 
> "Mathematical software should be mathematical"
> 
> 
> 
> -----Original Message-----
> From: [email-masked] on behalf of Anders Logg
> Sent: Thu 1/25/2007 4:44 PM
> To: Discussion of FIAT development
> Subject: [FIAT-dev] Bug in BDM entity_ids?
>  
> _______________________________________________
> FIAT-dev mailing list
> [email-masked]
> http://www.fenics.org/mailman/listinfo/fiat-dev
>