Subject: [FIAT-dev] RaviartThomas

From: Marie Rognes <[email-masked]>
Date: Tue, 13 Mar 2007 00:04:23 +0100

Hi,

when trying to run the following line of code:

        P1 = FiniteElement("RT", "triangle", 1)

with FIAT 0.3.0 and ffc 0.3.5, I get the following error:

Traceback (most recent call last):
  File "/usr/local/bin/ffc", line 130, in ?
    main(sys.argv[1:])
  File "/usr/local/bin/ffc", line 84, in main
    execfile(outname, ns)
  File "MixedPoisson.py", line 16, in ?
    P1 = FiniteElement("RT", "triangle", 1)
  File "/usr/lib/python2.4/site-packages/ffc/compiler/finiteelement.py", 
line 85, in __init__
    self.element = RaviartThomas(self.fiat_shape, degree)
  File "/usr/local/lib/python/FIAT/RaviartThomas.py", line 130, in __init__
    U = RTSpace( shape , n )
  File "/usr/local/lib/python/FIAT/RaviartThomas.py", line 48, in RTSpace
    [ range(i*dimPkp1,i*dimPkp1+dimPk) \
  File "/usr/local/lib/python2.4/site-packages/FIAT/polynomial.py", line 
139, in take
    return PolynomialSet( self.base , numpy.take( self.coeffs , items ) )
  File "/usr/local/lib/python2.4/site-packages/FIAT/polynomial.py", line 
333, in PolynomialSet
    raise RuntimeError, "Unknown error, PolynomialSet"                     
RuntimeError: Unknown error, PolynomialSet

(/usr/local/lib/python2.4/site-packages/FIAT links to 
/usr/local/lib/python/FIAT btw.)

Anyone else encountered this?

--
Marie

---

From: Anders Logg <[email-masked]>
Date: Tue, 13 Mar 2007 00:16:11 +0100

> Anyone else encountered this?

I get the same error with the following FIAT-only code:

from FIAT.RaviartThomas import *
from FIAT.shapes import *

RT1 = RaviartThomas(TRIANGLE, 1)

/Anders