Subject: [FIAT-dev] Bug in DiscontinuousVectorLagrange

From: Anders Logg <[email-masked]>
Date: Tue, 29 Nov 2005 23:40:17 -0600

It seems that the number of components for a discontinuous vector
Lagrange finite element is always set to the dimension of the shape
and not to the specified number of dimensions.

The output of the following code is

    (3,) (5,)

when it should be

    (5,) (5,)

from FIAT.DiscontinuousLagrange import DiscontinuousVectorLagrange
from FIAT.Lagrange import VectorLagrange
from FIAT.shapes import *

P0 = DiscontinuousVectorLagrange(TETRAHEDRON, 0, 5)
P1 = VectorLagrange(TETRAHEDRON, 1, 5)

print P0.function_space().tensor_dim()
print P1.function_space().tensor_dim()

/Anders

---

From: Johan Jansson <[email-masked]>
Date: Wed, 30 Nov 2005 14:55:28 +0100

On Tue, Nov 29, 2005 at 11:40:17PM -0600, Anders Logg wrote:
> _______________________________________________
> FIAT-dev mailing list
> [email-masked]
> http://www.fenics.org/cgi-bin/mailman/listinfo/fiat-dev

Hi!

Garth Wells sent a patch (to this list IIRC) which fixes this
bug. Here's his message:

http://www.fenics.org/pipermail/fiat-dev/2005-August/000060.html

and here's a direct link to the patch:

http://www.fenics.org/pipermail/fiat-dev/attachments/20050817/ae24c432/P0_patch.obj

I have successfully used this patch for the updated elasticity forms
in DOLFIN, so it seems to work ok.

Please apply this patch ;).

  Johan

---

From: Anders Logg <[email-masked]>
Date: Wed, 30 Nov 2005 08:40:05 -0600

> Please apply this patch ;).

Aha. It's been so long I forgot about it.

Strange that this hasn't been in the news: "Critical security bug in
FIAT remains unpatched for months"... :-)

/Anders

---

From: "Robert C. Kirby" <[email-masked]>
Date: Wed, 30 Nov 2005 10:02:19 -0600

Will patch this afternoon -- the bug came while I was in California  
for a month this summer...
Rob Kirby

"Mathematical software should be mathematical."