Subject: Re: [FIAT-dev] [UFC-dev] [DOLFIN-dev] Plans for release

From: Anders Logg <[email-masked]>
Date: Thu, 14 Feb 2008 14:33:25 +0100

Status update:

  UFC 1.1 looks ready to be released.

For FFC / DOLFIN / FIAT we're possibly waiting for Rob to apply a
patch from Marie for handling degrees of freedom. Then a corresponding
patch must be applied to FFC. Then we need to recompile all forms in
DOLFIN and see that things don't break.

And then release.

-- 
Anders

---

From: Andy Ray Terrel <[email-masked]>
Date: Thu, 14 Feb 2008 11:40:55 -0600

Hey Rob,

We have some small changes that we have been using in a local repo for 
Sieve.  It might be nice to get them into the next release so we don't 
have to tell people to get our local copies.  I have attached the bundle.

-- ART

-- 

====================
Andy Terrel
Computer Science Dept
University of Chicago
[email-masked]
---------------------

Flying is simple. 
You just throw yourself at the ground and miss.
              -Hitchhiker's Guide to the Galaxy

---

From: Marie Rognes <[email-masked]>
Date: Fri, 15 Feb 2008 00:26:07 +0100

Anders Logg wrote:
> patch must be applied to FFC. 

Check.

-- 
Marie E. Rognes
Ph.D Fellow, 
Centre of Mathematics for Applications, 
University of Oslo
http://folk.uio.no/meg

---

From: Anders Logg <[email-masked]>
Date: Fri, 15 Feb 2008 13:57:25 +0100

> > patch must be applied to FFC. 

Looks good, excellent.

I've just started looking over everything to see if everything works.
New releases should appear today.

This will be a massive release: UFC, FFC, FIAT, DOLFIN and then I've
also asked for new releases of Viper and Instant which I think are
also required for compatibility...

Hopefully, we can make quicker (and smaller) releases henceforth.

-- 
Anders