Subject: Re: [FIAT-dev] Re: [FFC-dev] problem with ffc and numeric

From: <[email-masked]>
Date: Tue, 2 May 2006 10:02:46 -1100

I think there have been problems with Numeric on other 64-bit machines.  
Anders, didn't you have this problem?

Rob

---- Original message ----
>Date: Tue, 02 May 2006 19:54:58 +0000
>From: Alexander Jarosch <[email-masked]>  
>Subject: Re: [FIAT-dev] Re: [FFC-dev] problem with ffc and numeric  
>To: "Robert C. Kirby" <[email-masked]>
>Cc: Anders Logg <[email-masked]>, Discussion of FFC development <ffc-
[email-masked]>, Discussion of FIAT development <[email-masked]>
>
>It works fine on my 32 bit gentoo, with same numeric package, gcc 3.4.4 
>and Python 2.4.2. The problem causes a 64bit amd gentoo. well I will 
>further investigate and let you know
>
>Alex
>
>Robert C. Kirby wrote:
>
>> The same code works fine for me.  I am using Python 2.3.5 on a Mac.   
>> Python and the Numeric/LinearAlgebra extension were built with GCC  
>> 4.0.1.
>>
>> Also works fine on the Debian Python 2.3.4 on our department Linux  
>> machines (built with gcc 3.3.5).
>>
>> Since it seems to be dying on the reshape, it makes sense to print  
>> out a.shape and newshape and see if their product is the same
>> print reduce(lambda x,y:x*y , a.shape)
>> print reduce(lambda x,y:x*y, newshape)
>>
>> Also check to see if the problem is in the gentoo package?
>>
>> Rob
>>
>>
>>> from FIAT.Lagrange import*
>>> from FIAT.shapes import *
>>> element = VectorLagrange(TRIANGLE, 2)
>>
>>
>
>
>-- 
>Alexander H. Jarosch
>
>Jarðvísindastofnun Háskólans
>Institute of Earth Sciences, University of Iceland
>Náttúrufræðahús, Askja
>Building of Natural Sciences, Askja
>Sturlugata 7
>IS - 101 Reykjavík
>Iceland
>
>Tel.: +354 525 4906
>http://raunvis.hi.is/~jarosch/
>

---

From: Anders Logg <[email-masked]>
Date: Tue, 2 May 2006 23:17:36 +0200

Yes, I vaguely remember. I dug through my old emails and found the
following references (from Johan Jansson):

    python-numeric: assignment to shape fails on 64bit arch

    http://www.mail-archive.com/[email-masked]/msg03829.html

    http://sourceforge.net/tracker/index.php?func=detail&aid=1108739&group_id=1369&atid=301369

So the solution seems to be to upgrade Python Numeric with the patch for
64-bit systems.

/Anders