Subject: [Instant-dev] [HG instant] Added assertion for "a != b", this should never be the case.

From: [email-masked] (Instant)
Date: Wed, 3 Sep 2008 12:33:31 +0200 (CEST)

One or more new changesets pushed to the primary instant repository.
A short summary of the last three changesets is included below.

changeset:   214:3572d86cc7496bdc3224159e10b5392fd9749a99
tag:         tip
user:        "Martin Sandve Alnæs <[email-masked]>"
date:        Wed Sep 03 12:33:30 2008 +0200
files:       src/instant/build_module.py
description:
Added assertion for "a != b", this should never be the case.
If applications pass bad input, it should cause an error, not be worked around in instant.

changeset:   213:be0d55f80ebc8ea8476607cf792e524dfc88ba3c
user:        "Martin Sandve Alnæs <[email-masked]>"
date:        Wed Sep 03 12:22:53 2008 +0200
files:       TODO src/instant/build_module.py tests/run_pychecker.py
description:
Added FIXME for in-memory cache bug.

Ensuring module_path is absolute path.

changeset:   212:494e09a82ecf6b81ea8030792952f869fcc7c5ee
user:        Ilmar Wilbers <[email-masked]>
date:        Wed Sep 03 11:56:52 2008 +0200
files:       src/instant/build_module.py
description:
Remove file to be overwritten before shutil.copyfile to avoid exception.

----------------------------------------------------------------------
For more details, visit http://www.fenics.org/hg/instant

---

From: Ilmar Wilbers <[email-masked]>
Date: Wed, 03 Sep 2008 13:06:13 +0200

Agree, however, FFC's JIT is using absolute paths, causing all the demos 
to break: http://fenics.org:8010/dolfin/linux_64/builds/721/step-test/1

Why should we not allow for absolute paths?
ilmar

Instant wrote:
> user:        "Martin Sandve AlnÃ¦s <[email-masked]>"
> user:        "Martin Sandve AlnÃ¦s <[email-masked]>"
> ------------------------------------------------------------------------
>
> _______________________________________________
> Instant-dev mailing list
> [email-masked]
> http://fenics.org/mailman/listinfo/instant-dev
>

---

From: "Martin Sandve Alnæs" <[email-masked]>
Date: Wed, 3 Sep 2008 13:10:05 +0200

> to break: http://fenics.org:8010/dolfin/linux_64/builds/721/step-test/1

This is not a reason to change instant. I see this kind of backwards workflow
as a major part of the reason instant became so messed up in the first place.

> Why should we not allow for absolute paths?

We're copying files around, and these files are included from the
generated interface file.

I've added a source_directory argument, use that instead.

-- 
Martin