Subject: [Instant-dev] [HG instant] Prepend source_directory to sources, wrap_headers, and local_headers for checksum calculation.

From: [email-masked] (Instant)
Date: Fri, 17 Apr 2009 16:49:18 +0200 (CEST)

One or more new changesets pushed to the primary instant repository.
A short summary of the last three changesets is included below.

changeset:   295:92ed546452358f7ebb49710eccae2faba91feca0
tag:         tip
user:        Ilmar Wilbers <[email-masked]>
date:        Fri Apr 17 16:49:15 2009 +0200
files:       src/instant/build.py
description:
Prepend source_directory to sources, wrap_headers, and local_headers for checksum calculation.

changeset:   294:ecf1c0a21ea4bfdca7aaf71619668caeb3989b89
user:        Ilmar Wilbers <[email-masked]>
date:        Fri Apr 17 16:07:39 2009 +0200
files:       src/instant/build.py
description:
Add source_directory to debug output.

changeset:   293:65597053892db397c1098d812ea1e72c38cdb9e7
user:        Ilmar Wilbers <[email-masked]>
date:        Thu Apr 16 14:15:20 2009 +0200
files:       tests/run_omp_test.sh
description:
Reflect file name change in test script.

----------------------------------------------------------------------
For more details, visit http://www.fenics.org/hg/instant

---

From: Martin Sandve Alnæs <[email-masked]>
Date: Fri, 17 Apr 2009 16:53:41 +0200

No!

The checksum can't depend on the place the code was generated!

Martin

On Fri, Apr 17, 2009 at 4:49 PM, Instant <[email-masked]> wrote:
> _______________________________________________
> Instant-dev mailing list
> [email-masked]
> http://fenics.org/mailman/listinfo/instant-dev
>

---

From: Martin Sandve Alnæs <[email-masked]>
Date: Fri, 17 Apr 2009 16:55:25 +0200

Please don't change the behaviour of instant like that without asking
the list for possible side effects first. Not everything is covered by
the tests.

Martin

---

From: Ilmar Wilbers <[email-masked]>
Date: Fri, 17 Apr 2009 17:09:23 +0200

I know that. But computing the checksum for these files is done by 
looking at their contents, not their names. If this is not done, Instant 
will fail, saying that it cannot find the file in the case the arguments 
'source_directory' is used (as it is looking for the file in the cwd 
instead of the given directory).

ilmar

---

From: Ilmar Wilbers <[email-masked]>
Date: Fri, 17 Apr 2009 17:11:06 +0200

OK, I saw it as a minor bug and investigated the side effects, 
concluding that this wouldn't affect the behaviour of Instant. Of 
course, I could be wrong...

ilmar

---

From: Martin Sandve Alnæs <[email-masked]>
Date: Fri, 17 Apr 2009 17:31:47 +0200

I think I may have misunderstood the commit comment. Hold on, I'll
check with SFC.

Martin

On Fri, Apr 17, 2009 at 5:11 PM, Ilmar Wilbers <[email-masked]> wrote:
> OK, I saw it as a minor bug and investigated the side effects, concluding
> that this wouldn't affect the behaviour of Instant. Of course, I could be
> wrong...
>
> ilmar
>

---

From: Martin Sandve Alnæs <[email-masked]>
Date: Fri, 17 Apr 2009 17:38:03 +0200

You're right, this was a bug. SFC uses source_directory, but it
passes its own signature so the checksum code isn't used.

s/No!/Thanks :)/

Martin

On Fri, Apr 17, 2009 at 5:09 PM, Ilmar Wilbers <[email-masked]> wrote:
> I know that. But computing the checksum for these files is done by looking
> at their contents, not their names. If this is not done, Instant will fail,
> saying that it cannot find the file in the case the arguments
> 'source_directory' is used (as it is looking for the file in the cwd instead
> of the given directory).
>
> ilmar
>