Subject: Re: [Instant-dev] [DOLFIN-dev] Release?

From: Anders Logg <[email-masked]>
Date: Mon, 28 Apr 2008 13:23:03 +0200

On Mon, Apr 28, 2008 at 12:17:07PM +0200, Ola Skavhaug wrote:
> Anders Logg skrev den 28/04-2008 følgende:
> > Are there any outstanding issues we need to fix before the release?
> > 
> > (Other than adding "virtual" in LA subclasses if there are no further
> > opinions on that.)
> > 
> > I guess it will be version 0.7.3 we release now, and then we can
> > release 0.8.0 in may/june after some more fixes.
> > 
> > New releases of FFC, Instant, FIAT and Viper will also be needed I guess.
> 
> Yes.
> 
> Should we set a release-date?
> 
> Ola

Any time this week works for me.

How about Wednesday?

I'm cc:ing fiat, instant, syfi here:

1. Rob, has anything happened in FIAT since the latest release that
requires a new release?

2. Kent, new release of Instant on Wednesday?

3. Kent, Martin, new release of SyFi on Wednesday?

I'm assuming FFC and Viper are ok for release on Wednesday.

-- 
Anders

---

From: "Martin Sandve Alnæs" <[email-masked]>
Date: Mon, 28 Apr 2008 14:08:14 +0200

>  > > (Other than adding "virtual" in LA subclasses if there are no further

Can we add min() and max() to GenericVector?

>  3. Kent, Martin, new release of SyFi on Wednesday?

Ok.

--
Martin

---

From: Kent-Andre Mardal <[email-masked]>
Date: Mon, 28 Apr 2008 15:07:09 +0200

> I'm assuming FFC and Viper are ok for release on Wednesday.

ok

---

From: "Martin Sandve Alnæs" <[email-masked]>
Date: Mon, 28 Apr 2008 18:25:22 +0200

I've done this, and added virtual keywords like discussed, but there's
a segmentation fault I need to debug before I check in. Please don't
touch the vector and matrix classes now :-)

-- 
Martin

2008/4/28 Kent-Andre Mardal <[email-masked]>:
>  _______________________________________________
>  SyFi-dev mailing list
>  [email-masked]
>  http://fenics.org/mailman/listinfo/syfi-dev
>

---

From: Anders Logg <[email-masked]>
Date: Tue, 29 Apr 2008 15:55:50 +0200

> I'm assuming FFC and Viper are ok for release on Wednesday.

The buildbot is all green, so I guess we're ready for a release?
(If I haven't missed any outstanding issues.)

So, if anyone has issues, scream today, or else it's release at will
tomorrow.

-- 
Anders

---

From: "Martin Sandve Alnæs" <[email-masked]>
Date: Tue, 29 Apr 2008 16:48:47 +0200

> So, if anyone has issues, scream today, or else it's release at will

There's a plotting bug with viper, don't know if it's in viper or
dolfin or even vtk.
But it looks like a tricky bastard, so I guess it can wait.

--
Martin