Subject: [Instant-dev] [HG instant] when using USE_CACHE nothing is stored in the working directory

From: [email-masked] (Instant)
Date: Wed, 12 Dec 2007 19:51:03 +0100 (CET)

One or more new changesets pushed to the primary instant repository.
A short summary of the last three changesets is included below.

changeset:   113:c35667fd48a99c0eb28d6cb957dcb1dcd5e44ca0
tag:         tip
user:        kent-and@localhost
date:        Wed Dec 12 12:08:39 2007 +0100
files:       src/instant.py tests/clean.sh
description:
when using USE_CACHE nothing is stored in the working directory
COPY is not used anymore, use USE_CACHE instead

changeset:   112:c43935727fe05dbbabbc751ffdec72dd9e928e98
user:        kent-and@localhost
date:        Tue Dec 11 15:22:54 2007 +0100
files:       src/instant.py tests/clean.sh
description:
added optimization flag

changeset:   111:7a8e32b36d569cd3dcbb253177e7d56c9518ee33
user:        kent-and@localhost
date:        Fri Dec 07 12:07:02 2007 +0100
files:       src/instant.py
description:
bug fix

----------------------------------------------------------------------
For more details, visit http://www.fenics.org/hg/instant

---

From: [email-masked]
Date: Wed, 12 Dec 2007 19:56:40 +0100 (CET)

BTW: I am not sure this fixes the bug with demo.py in dolfin/ffc.
I have still not managed to run this example, due to seg. fault
associated with mpi.

Kent

> _______________________________________________
> Instant-dev mailing list
> [email-masked]
> http://fenics.org/mailman/listinfo/instant-dev
>

---

From: Anders Logg <[email-masked]>
Date: Wed, 12 Dec 2007 19:58:47 +0100

> COPY is not used anymore, use USE_CACHE instead

This seems to have broken the FFC JIT compiler. Earlier we just the
relative path for the file to be wrapped:

  instant.create_extension(wrap_headers=["../" + prefix + ".h"], ...)

But now it can't be found, probably since the module is not being
generated in the current directory (see below).

../ffc_form_0.h: Can't open: [Errno 2] No such file or directory:
'../ffc_form_0.h'
../ffc_form_0.h: Can't open: [Errno 2] No such file or directory:
'../ffc_form_0.h'
Traceback (most recent call last):
  File
  "/scratch/dolfin/dolfin-dev/src/demo/pde/poisson/python/demo.py",
  line 66, in <module>
    u = pde.solve()
  File
  "/home/logg/work/src/fenics/dolfin/current/dolfin-dev/local/lib/python2.5/site-packages/dolfin/assemble.py", line 142, in solve
    (A, self.dof_maps) = assemble(self.a, self.mesh)
  File
  "/home/logg/work/src/fenics/dolfin/current/dolfin-dev/local/lib/python2.5/site-packages/dolfin/assemble.py", line 24, in assemble
    (compiled_form, module, form_data) = jit(form)
  File "/usr/lib/python2.5/site-packages/ffc/jit/jit.py", line 60, in
  jit
    instant.create_extension(wrap_headers=[filename],
    module=module_name, additional_declarations=ufc_include,
    include_dirs=path)
  File "/usr/lib/python2.5/site-packages/instant.py", line 660, in
  create_extension
    ext.create_extension(**args)
  File "/usr/lib/python2.5/site-packages/instant.py", line 228, in
  create_extension
    if self.check_md5sum():
  File "/usr/lib/python2.5/site-packages/instant.py", line 497, in
  check_md5sum
    self.writemd5sumfile(md5sum_files, self.module + ".md5")
  File "/usr/lib/python2.5/site-packages/instant.py", line 473, in
  writemd5sumfile
    fp.write(result)
TypeError: argument 1 must be string or read-only character buffer,
not None

-- 
Anders