Subject: [Instant-dev] Public functions

From: Ilmar Wilbers <[email-masked]>
Date: Wed, 22 Apr 2009 16:56:26 +0200

What Instant functions are supposed to be used (visible) by the 
end-users directly (i.e. need to be documented). On my list so far are:
build_module
inline
inline_module
inline_with_numpy
inline_module_with_numpy
inline_with_numeric
inline_module_with_numeric
inline_with_numarray
inline_module_with_numarray
import_module

Any more?

ilmar

---

From: Martin Sandve Alnæs <[email-masked]>
Date: Wed, 22 Apr 2009 17:02:07 +0200

These at least, they are used in for example ufc:

header_and_libs_from_pkgconfig
get_status_output
check_swig_version

Martin

On Wed, Apr 22, 2009 at 4:56 PM, Ilmar Wilbers <[email-masked]> wrote:
> _______________________________________________
> Instant-dev mailing list
> [email-masked]
> http://fenics.org/mailman/listinfo/instant-dev
>

---

From: Johan Hake <[email-masked]>
Date: Wed, 22 Apr 2009 17:11:50 +0200

> header_and_libs_from_pkgconfig

Add to that:

 get_swig_version

Johan