Subject: [Instant-dev] Bug in instant-clean

From: Johan Hake <[email-masked]>
Date: Mon, 30 Mar 2009 12:30:01 +0200

Hello!

After using instant-clean I get a report on the removed modules. But looking 
into ~/.instant/cache I see alot of 
  
  dolfin_compile_function_bed6c8052d8f9b3c634adc69da7ea158.lock 
  form_7646c77a00f5c23b5fcf7f3716d61e733c6cae74.lock

files. When I then hit instant-clean again I get a report that instant removes 
all these modules again, but they are of coursed allready removed, but 
the .lock files still excists.

Johan

---

From: Martin Sandve Alnæs <[email-masked]>
Date: Mon, 30 Mar 2009 12:38:49 +0200

In simpler words, "instant-clean doesn't remove the lock files"?
I'll fix it. Doesn't really do any harm though, except over long time.

Martin

On Mon, Mar 30, 2009 at 12:30 PM, Johan Hake <[email-masked]> wrote:
> _______________________________________________
> Instant-dev mailing list
> [email-masked]
> http://fenics.org/mailman/listinfo/instant-dev
>

---

From: Johan Hake <[email-masked]>
Date: Mon, 30 Mar 2009 12:43:13 +0200

On Monday 30 March 2009 12:38:49 Martin Sandve Alnæs wrote:
> I'll fix it. 

Thanks my english is in a mess these days :)

> Doesn't really do any harm though, except over long time.

Well you get a report that instant find some modules it want to remove that 
allready are removed.

Johan

> > After using instant-clean I get a report on the removed modules. But
> > looking into ~/.instant/cache I see alot of
> >
> > files. When I then hit instant-clean again I get a report that instant
> > removes all these modules again, but they are of coursed allready
> > removed, but the .lock files still excists.
> >
> > Johan