Subject: [Fenics-ufc] buildbot failure in FEniCS Buildbot on ufc-maverick-i386

From: [email-masked]
Date: Mon, 21 Feb 2011 14:31:36 +0100

The Buildbot has detected a new failure of ufc-maverick-i386 on FEniCS Buildbot.
Full details are available at:
 http://fenicsproject.org:8080/builders/ufc-maverick-i386/builds/14

Buildbot URL: http://fenicsproject.org:8080/

Buildslave for this Build: maverick-i386

Build Reason: 
Build Source Stamp: HEAD
Blamelist: Anders Logg

BUILD FAILED: failed ufc build

sincerely,
 -The Buildbot

---

From: Johannes Ring <[email-masked]>
Date: Mon, 21 Feb 2011 15:10:05 +0100

I think the patch below should fix this problem.

Johannes

=== modified file 'CMakeLists.txt'
--- CMakeLists.txt	2010-09-01 19:08:38 +0000
+++ CMakeLists.txt	2011-02-21 14:07:27 +0000
@@ -102,6 +102,7 @@

   # SWIG sources
   set(SWIG_SOURCES src/ufc/ufc.i)
+  set(SWIG_MODULE_${SWIG_MODULE_NAME}_EXTRA_DEPS ${UFC_H})

   set_source_files_properties(${SWIG_SOURCES} PROPERTIES CPLUSPLUS ON)

On Mon, Feb 21, 2011 at 2:31 PM,  <[email-masked]> wrote:
> _______________________________________________
> Mailing list: https://launchpad.net/~fenics-ufc
> Post to     : [email-masked]
> Unsubscribe : https://launchpad.net/~fenics-ufc
> More help   : https://help.launchpad.net/ListHelp
>

---

From: Anders Logg <[email-masked]>
Date: Mon, 21 Feb 2011 15:29:15 +0100

> I think the patch below should fix this problem.

Are you sure? It should be related to the recent changes in the UFC
interface.

Should the below flags be added anyway?

--
Anders

---

From: Johannes Ring <[email-masked]>
Date: Mon, 21 Feb 2011 15:37:17 +0100

> Should the below flags be added anyway?

Yes, the line

  set(SWIG_MODULE_${SWIG_MODULE_NAME}_EXTRA_DEPS ${UFC_H})

should be added to CMakeLists.txt somewhere before calling
swig_add_module since ufc.i includes ufc.h.

Johannes

---

From: Anders Logg <[email-masked]>
Date: Mon, 21 Feb 2011 15:57:44 +0100

> swig_add_module since ufc.i includes ufc.h.

Why hasn't this been needed before?

--
Anders

---

From: Johannes Ring <[email-masked]>
Date: Mon, 21 Feb 2011 16:06:21 +0100

> Why hasn't this been needed before?

I don't know but there hasn't been that many changes in UFC after the
move from SCons to CMake. Removing the CMake cache will also fix the
problem but that is not the correct fix. By adding ufc.h to
SWIG_MODULE_ufc_EXTRA_DEPS we will make sure that CMake rerun swig
whenever we make changes in ufc.h. We do it similar in DOLFIN.

Johannes

---

From: Anders Logg <[email-masked]>
Date: Mon, 21 Feb 2011 18:27:14 +0100

> whenever we make changes in ufc.h. We do it similar in DOLFIN.

ok. Fixed now. Thanks.

--
Anders