Subject: [UFC-dev] [HG ufc] added sketch for IJCSE paper

From: [email-masked] (UFC)
Date: Tue, 11 Dec 2007 16:41:58 +0100 (CET)

One or more new changesets pushed to the primary UFC repository.
A short summary of the last three changesets is included below.

changeset:   195:dfe009acb494d1188be1e4a54f0626b00f021fcd
tag:         tip
user:        "Kent-Andre Mardal <[email-masked]>"
date:        Tue Dec 11 17:43:43 2007 +0100
files:       doc/IJCSE/.ufc-ijcse.tex.swo doc/IJCSE/Makefile doc/IJCSE/doublecol.cls doc/IJCSE/ufc-ijcse.tex
description:
added sketch for IJCSE paper

changeset:   194:9d003fd4a11f8e34d850735fda0d092516c09a53
user:        "Martin Sandve Alnæs <[email-masked]>"
date:        Fri Nov 23 13:29:09 2007 +0100
files:       src/utils/python/ufc_benchmark/ufc_benchmark.cpp
description:
Added assertions in utility code.

changeset:   193:fb32dfe2fe20ab0f3f908f94ed7b8233c1b71851
user:        "Martin Sandve Alnæs <[email-masked]>"
date:        Thu Nov 22 17:40:25 2007 +0100
files:       src/utils/python/ufc_benchmark/Makefile src/utils/python/ufc_benchmark/ufc_benchmark.cpp src/utils/python/ufc_benchmark/ufc_benchmark.h src/utils/python/ufc_benchmark/ufc_benchmark.i src/utils/python/ufc_benchmark/ufc_data.h src/utils/python/ufc_benchmark/ufc_reference_cell.h
description:
Cleaned up some code by moving construction and allocation stuff to a class ufc_data (similar to what's done in the dolfin assembler class).
Added tabulate_cell_tensor function, which takes w as a vector<vector<double>> and returns a computed element tensor as a vector<vector<double>>.
Maybe we should collect utilities in a ufc_utilities module instead, useable from C++ and with python wrappers.

----------------------------------------------------------------------
For more details, visit http://www.fenics.org/hg/ufc

---

From: Anders Logg <[email-masked]>
Date: Tue, 11 Dec 2007 19:13:23 +0100

> added sketch for IJCSE paper

I don't think this should be in the UFC repository (which I think
should be just for the code and the manual). Let's just create a
repository at ~ufc/hg/ufc-paper instead.

-- 
Anders

---

From: [email-masked]
Date: Tue, 11 Dec 2007 21:43:29 +0100 (CET)

OK, I've set it up.

hg clone ssh://[email-masked]/hg/ufc-paper

Kent

>> files:       doc/IJCSE/.ufc-ijcse.tex.swo doc/IJCSE/Makefile
>> doc/IJCSE/doublecol.cls doc/IJCSE/ufc-ijcse.tex
>> description:
> _______________________________________________
> UFC-dev mailing list
> [email-masked]
> http://fenics.org/mailman/listinfo/ufc-dev
>

---

From: Anders Logg <[email-masked]>
Date: Tue, 11 Dec 2007 21:57:49 +0100

> hg clone ssh://[email-masked]/hg/ufc-paper

Excellent.

-- 
Anders