Subject: [UFC-dev] Release

From: Anders Logg <[email-masked]>
Date: Tue, 22 Sep 2009 18:47:26 +0200

New releases are needed for UFC and UFL. Which version numbers?

We have added some new functions for UFC, so I'd suggest UFC 1.2:

 - Add new function ufc::dof_map::max_local_dimension()
 - Change ufc::dof_map::local_dimension() to ufc::dof_map::local_dimension(const ufc::cell c)

In UFL, there have been bug fixes to lhs/rhs and some changes in the
log system. Should this be version 0.4.1? Martin?

--
Anders

---

From: "Garth N. Wells" <[email-masked]>
Date: Tue, 22 Sep 2009 17:48:58 +0100

> We have added some new functions for UFC, so I'd suggest UFC 1.2:

Agree.

> log system. Should this be version 0.4.1? Martin?

There has also been some work on restrictions.

Garth

> --
> Anders
> 
> 
> ------------------------------------------------------------------------
> 
> _______________________________________________
> UFC-dev mailing list
> [email-masked]
> http://fenics.org/mailman/listinfo/ufc-dev

---

From: Kristian Oelgaard <[email-masked]>
Date: Tue, 22 Sep 2009 18:08:37 +0200

Quoting "Garth N. Wells" <[email-masked]>:

> >  - Change ufc::dof_map::local_dimension() to
> ufc::dof_map::local_dimension(const ufc::cell c)
> >

I added this to the ChangeLog. I think the UFL is ready.

Kristian

> UFL-dev mailing list
> [email-masked]
> http://fenics.org/mailman/listinfo/ufl-dev
>

---

From: Anders Logg <[email-masked]>
Date: Tue, 22 Sep 2009 19:12:57 +0200

> I added this to the ChangeLog. I think the UFL is ready.

ok, let's just wait for Martin to comment.

--
Anders

---

From: Anders Logg <[email-masked]>
Date: Wed, 23 Sep 2009 21:53:51 +0200

> log system. Should this be version 0.4.1? Martin?

What I meant here was 0.3.1 (I misinterpreted an entry in ChangeLog),
but 0.4.0 is also good. :-)

-- 
Anders