Subject: [UFC-dev] [HG UFC] Added a missing file and removed some uncommented old code.

From: [email-masked] (UFC)
Date: Tue, 13 Jan 2009 15:08:41 +0100 (CET)

One or more new changesets pushed to the primary ufc repository.
A short summary of the last three changesets is included below.

changeset:   233:49d6988c66c81d455353771e39dae57b98f7321f
tag:         tip
user:        "Johan Hake <[email-masked]>"
date:        Tue Jan 13 11:44:38 2009 +0100
files:       setup.py src/ufc/ufc.i
description:
Added a missing file and removed some uncommented old code.

changeset:   232:84fcf149cbe3d33b65338a4d2b2b004ca4387d4c
user:        "Johan Hake <[email-masked]>"
date:        Tue Jan 13 11:42:11 2009 +0100
files:       setup.py
description:
Added a swig interface file, ufc.i
  - In this shared_ptr typemaps is added for the main classes in ufc.h.
  - Changed name of the python module ufc/ to ufc_utils/

NOTE:
  - If installing from source, i.e., python setup.py install, you need to
    delete your old build before you install it again. Otherwise you will reinstall
    the old python module ufc/

changeset:   231:221217c6d6ddc83645d4b4b2b95cf5a62a0bb6b8
user:        "Martin Sandve Alnæs <[email-masked]>"
date:        Tue Dec 23 11:40:18 2008 +0100
files:       TODO
description:
Update TODO for 1.2: add value_size to finite_element and function.

----------------------------------------------------------------------
For more details, visit http://www.fenics.org/hg/ufc

---

From: Kent Andre <[email-masked]>
Date: Tue, 13 Jan 2009 20:55:52 +0100

The ufc.i is not being installed, is it ? 

Kent

On ti., 2009-01-13 at 15:08 +0100, UFC wrote:
> _______________________________________________
> UFC-dev mailing list
> [email-masked]
> http://fenics.org/mailman/listinfo/ufc-dev

---

From: Johan Hake <[email-masked]>
Date: Tue, 13 Jan 2009 21:03:46 +0100

> The ufc.i is not being installed, is it ?

That is the intention.

This part in the setup.py file should ensure that:

      data_files = [("include", [pjoin("src","ufc","ufc.h")]),
                    (pjoin("lib","pkgconfig"), ["ufc-%d.pc" % major]),
--->                (pjoin("include","swig"),[pjoin("src","ufc","ufc.i")])],

and it should be installed in PREFIX/include/swig/

Anders reported an error while compiling functions from dolfin where the ufc.i 
file was not found, but I am on to it.

Johan

> >     delete your old build before you install it again. Otherwise you will
> > reinstall the old python module ufc/
> >
> >

---

From: Shawn Walker <[email-masked]>
Date: Tue, 13 Jan 2009 15:08:02 -0500 (EST)

This is probably what you are doing, but just to make sure, here is the 
error I get when I install the new UFC:

Installing UFC under /home/walker/build...
running install
running build
running build_py
copying src/ufc/ufc.py -> build/lib.linux-x86_64-2.5
running build_ext
building '_ufc' extension
gcc -pthread -fno-strict-aliasing -DNDEBUG -g -fwrapv -O3 -Wall 
-Wstrict-prototypes -fPIC -Isrc/ufc 
-I/usr/local/pkg/Python-2.5/include/python2.5 -c src/ufc/ufc_wrap.cxx -o 
build/temp.linux-x86_64-2.5/src/ufc/ufc_wrap.o
cc1plus: warning: command line option "-Wstrict-prototypes" is valid for 
Ada/C/ObjC but not for C++
src/ufc/ufc_wrap.cxx: In function nt 
SWIG_Python_ConvertFunctionPtr(PyObject*, void**, swig_type_info*)
src/ufc/ufc_wrap.cxx:2051: error: invalid conversion from onst char*to 
har*src/ufc/ufc_wrap.cxx: In function oid 
SWIG_Python_FixMethods(PyMethodDef*, swig_const_info*, swig_type_info**, 
swig_type_info**)
src/ufc/ufc_wrap.cxx:3036: error: invalid conversion from onst char*to 
har*error: command 'gcc' failed with exit status 1

- Shawn

---

From: Johan Hake <[email-masked]>
Date: Tue, 13 Jan 2009 21:19:25 +0100

> error I get when I install the new UFC:

Hello Shawn!

What version of swig/gcc do you have and on what platform are you. 

This looks like swig producing erronious code or gcc being too sensitive. I do 
not get this error. Using latest swig and gcc-4.2.4 on hardy linux.

Johan

> > --->               
> > (pjoin("include","swig"),[pjoin("src","ufc","ufc.i")])],
> >
> > Anders reported an error while compiling functions from dolfin where the
> > ufc.i file was not found, but I am on to it.
> >
> > Johan
> >
> >> Kent
> >>
> >>>   - If installing from source, i.e., python setup.py install, you need
> >>> to delete your old build before you install it again. Otherwise you
> >>> will reinstall the old python module ufc/
> >>>
> >>>

---

From: Kent Andre <[email-masked]>
Date: Tue, 13 Jan 2009 21:46:00 +0100

> file was not found, but I am on to it.

And how does PREFIX relate to the --prefix I use
when I type
python setup.py install --prefix=/usr/local

Is PREFIX an environment variable ? 

Kent

---

From: Johan Hake <[email-masked]>
Date: Tue, 13 Jan 2009 21:54:21 +0100

> python setup.py install --prefix=/usr/local

The same. 

> Is PREFIX an environment variable ?

No, just a dummy word I used in the email to reflect your installation 
directory.

Johan

> > > >   - In this shared_ptr typemaps is added for the main classes in
> > > > ufc.h. - Changed name of the python module ufc/ to ufc_utils/
> > > >
> > > > NOTE:
> > > >   - If installing from source, i.e., python setup.py install, you
> > > > need to delete your old build before you install it again. Otherwise
> > > > you will reinstall the old python module ufc/
> > > >
> > > >
> > > > ---------------------------------------------------------------------
> > > >- For more details, visit http://www.fenics.org/hg/ufc

---

From: Kent Andre <[email-masked]>
Date: Tue, 13 Jan 2009 21:59:30 +0100

> No, just a dummy word I used in the email to reflect your installation 

sorry, I think my brain has gone to sleep, somehow I had a different
setup.py than the one you apparently have. 

Kent

---

From: Shawn Walker <[email-masked]>
Date: Tue, 13 Jan 2009 16:50:53 -0500 (EST)

Well, up until now, it seemed to be compiling ok.  But I had not actually 
used the PyDOLFIN stuff, so I never really checked.

Yeah, I can install the newer one locally, but I never got around to it. 
I actually had the admin people do a local install of Python 2.5 for me 
(the default was 2.4).  Anyway, thanks for the concern!

- Shawn

On Tue, 13 Jan 2009, Johan Hake wrote:

> On Tuesday 13 January 2009 22:18:27 Shawn Walker wrote:
>> oh, yeah, I have SWIG 1.3.29, because the admin people will not upgrade
>> it!
>
> That kind of sucks!
>
> Can't you install it locally? I assume you also have problem with the PyDOLFIN
> compilation?
>
> Johan
>
>> - Shawn
>>
>>> This looks like swig producing erronious code or gcc being too sensitive.
>>> I do not get this error. Using latest swig and gcc-4.2.4 on hardy linux.
>>>
>>> Johan
>>>
>>>>> Anders reported an error while compiling functions from dolfin where
>>>>> the ufc.i file was not found, but I am on to it.
>>>>>
>>>>> Johan
>>>>>
>>>>>> Kent
>>>>>>