Subject: [Fenics-ufc] Compile error

From: Harish Narayanan <[email-masked]>
Date: Thu, 24 Feb 2011 12:43:07 +0100

I receive the following compilation error when building the new UFC. I
did this after completely cleaning my old source folder and checking out
everything new.

Where do I get python.swg and boost_shared_ptr.i?

Harish

-- The C compiler identification is GNU
-- The CXX compiler identification is GNU
-- Checking whether C compiler has -isysroot
-- Checking whether C compiler has -isysroot - yes
-- Checking whether C compiler supports OSX deployment target flag
-- Checking whether C compiler supports OSX deployment target flag - yes
-- Check for working C compiler: /opt/local/bin/gcc
-- Check for working C compiler: /opt/local/bin/gcc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Checking whether CXX compiler has -isysroot
-- Checking whether CXX compiler has -isysroot - yes
-- Checking whether CXX compiler supports OSX deployment target flag
-- Checking whether CXX compiler supports OSX deployment target flag - yes
-- Check for working CXX compiler: /opt/local/bin/c++
-- Check for working CXX compiler: /opt/local/bin/c++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
SWIG_MODULE_LOCATION
/Users/harish/Work/FEniCS/dev/src/ufc/dorsal_build_dir/_ufc.so
-- Configuring done
-- Generating done
-- Build files have been written to:
/Users/harish/Work/FEniCS/dev/src/ufc/dorsal_build_dir
[ 50%] Swig source
:3: Error: Unable to find 'python.swg'
/Users/harish/Work/FEniCS/dev/src/ufc/src/ufc/ufc.i:14: Error: Unable to
find 'boost_shared_ptr.i'
make[2]: *** [src/ufc/ufcPYTHON_wrap.cxx] Error 1
make[1]: *** [CMakeFiles/_ufc.dir/all] Error 2
make: *** [all] Error 2

---

From: Johan Hake <[email-masked]>
Date: Thu, 24 Feb 2011 08:05:20 -0800

> did this after completely cleaning my old source folder and checking out

I guess you also cleaned the build folder?

> Where do I get python.swg and boost_shared_ptr.i?

These all comes with the SWIG distribution. Can you manually set the SWIG 
folder and binary from within the cmake-gui, and check if you still get the 
error?

Johan
 
> _______________________________________________
> Mailing list: https://launchpad.net/~fenics-ufc
> Post to     : [email-masked]
> Unsubscribe : https://launchpad.net/~fenics-ufc
> More help   : https://help.launchpad.net/ListHelp