Subject: [Viper-dev] Plotting MeshFunctions

From: Anders Logg <[email-masked]>
Date: Tue, 8 May 2007 15:21:42 +0200

Ola, would it be much work to add support for plotting mesh functions
taking values on cells (not only vertices). We need this to visualize
mesh partitions.

  File "/usr/lib/python2.5/site-packages/viper/viper_dolfin.py", line
  86, in plot_meshfunction
    raise RuntimeError, "Only vertex valued meshfunctions can be
    plotted"

/Anders

---

From: Ola Skavhaug <[email-masked]>
Date: Tue, 8 May 2007 15:24:51 +0200

>     raise RuntimeError, "Only vertex valued meshfunctions can be

Point me to a relevant test case, and I will make sure it works soon.

Ola
 
> /Anders
> _______________________________________________
> Viper-dev mailing list
> [email-masked]
> http://fenics.org/mailman/listinfo/viper-dev

---

From: Anders Logg <[email-masked]>
Date: Tue, 8 May 2007 15:33:17 +0200

> Point me to a relevant test case, and I will make sure it works soon.

    src/demo/mesh/partition

You will only get an non-informative error message from DOLFIN:

    Unable to plot (PyDOLFIN or Viper plotter not available).

To get the full Python traceback from Viper, run the script

    ls -rt /tmp/*.py | tail -1

:-)

/Anders

---

From: Ola Skavhaug <[email-masked]>
Date: Tue, 8 May 2007 21:10:36 +0200

> > Point me to a relevant test case, and I will make sure it works soon.

No such directory. Do you mean src/demo/mesh/refinement?

Ola

---

From: Anders Logg <[email-masked]>
Date: Tue, 8 May 2007 22:10:45 +0200

> No such directory. Do you mean src/demo/mesh/refinement?

No, I meant src/demo/mesh/partition but forgot to add it.

It's there now.

/Anders

---

From: Ola Skavhaug <[email-masked]>
Date: Tue, 8 May 2007 23:45:23 +0200

> No, I meant src/demo/mesh/partition but forgot to add it.

And I hope things are working ok now.

Ola

---

From: Anders Logg <[email-masked]>
Date: Wed, 9 May 2007 11:14:17 +0200

> And I hope things are working ok now.

Works! Thanks!

/Anders