Subject: [Viper-dev] Plotting error

From: "Martin Sandve Alnæs" <[email-masked]>
Date: Thu, 3 Apr 2008 15:19:32 +0200

I have the latest viper and dolfin, this line worked at least last week.

Plot active, press 'q' to continue.
Traceback (most recent call last):
  File "demo.py", line 211, in <module>
    plot(u0_func, mode = "displacement", interactive=True)
  File "/usr/lib/python2.5/site-packages/viper/viper_dolfin.py", line
247, in plot
    _plotter.interactive()
  File "/usr/lib/python2.5/site-packages/viper/viper_dolfin.py", line
231, in interactive
    self.plots[k][0].interactive()
  File "/usr/lib/python2.5/site-packages/viper/viper.py", line 217, in
interactive
    self.iren.Start()
AttributeError: 'NoneType' object has no attribute 'Start'

-- 
Martin

---

From: "Ola Skavhaug" <[email-masked]>
Date: Fri, 4 Apr 2008 07:57:59 +0200 (CEST)

> I have the latest viper and dolfin, this line worked at least last week.

Please let me know which demo that fails when sending error-reports. That
will make the debugging simpler.

Ola

> _______________________________________________
> Viper-dev mailing list
> [email-masked]
> http://fenics.org/mailman/listinfo/viper-dev
>

---

From: "Martin Sandve Alnæs" <[email-masked]>
Date: Fri, 4 Apr 2008 10:31:26 +0200

The error is viper using Function again and not cpp_Function.
When plot gets a cpp_Function, it fails with the error below.
I'll make a patch.

The demo (may be buggy):
syfi/examples/solvers/linear_elasticity/demo.py

-- 
Martin

---

From: Ola Skavhaug <[email-masked]>
Date: Fri, 4 Apr 2008 13:29:51 +0200

Martin Sandve Alnæs skrev den 04/04-2008 følgende:
> Patch.

Thanks.

Ola
 
> Using cpp_Function directly instead of the "import ...cpp_Function as
> Function", hopefully avoiding this confusion later.
> 
> -- 
> Martin
> 
> 
> 2008/4/4, Martin Sandve Alnæs <[email-masked]>: