Subject: [Viper-dev] Plotting MeshFunction

From: "Garth N. Wells" <[email-masked]>
Date: Fri, 28 Mar 2008 09:59:36 +0000

When plotting a MeshFunction, the plot window opens and then closes 
again quickly. Seems to be OK for a regular Function.

Garth

---

From: Ola Skavhaug <[email-masked]>
Date: Fri, 28 Mar 2008 11:06:12 +0100

> again quickly. Seems to be OK for a regular Function.

OK, that's a simple fix. Will do.

Ola
 
> Garth
> _______________________________________________
> DOLFIN-dev mailing list
> [email-masked]
> http://www.fenics.org/mailman/listinfo/dolfin-dev

---

From: "Garth N. Wells" <[email-masked]>
Date: Sat, 29 Mar 2008 15:41:55 +0000

> OK, that's a simple fix. Will do.

Things appear to be fixed for cpp demos, but not for the python demos. 
Plots disappear quickly.

Garth

---

From: Ola Skavhaug <[email-masked]>
Date: Sat, 29 Mar 2008 18:18:42 +0100

> Things appear to be fixed for cpp demos, but not for the python demos.  

OK, we have made the plot(u) non-interactive. This makes the plotting less
verbose when done in a loop, a-la:

for i in xrange(N):
    u = compute_somthing()
    plot(u)

In the demos, the call interactive() should be placed at the end.

Ola

---

From: "Garth N. Wells" <[email-masked]>
Date: Mon, 31 Mar 2008 11:14:54 +0100

> In the demos, the call interactive() should be placed at the end.

This works. although there is no 'press q to continue' message.

Garth

---

From: Anders Logg <[email-masked]>
Date: Mon, 31 Mar 2008 13:54:23 +0200

> This works. although there is no 'press q to continue' message.

Should this be added to Viper? Something like:

  "Plot active, press 'q' to continue"

-- 
Anders

---

From: Ola Skavhaug <[email-masked]>
Date: Mon, 31 Mar 2008 14:08:48 +0200

>   "Plot active, press 'q' to continue"

Done.

Ola