Subject: [Viper-dev] Time for release

From: Anders Logg <[email-masked]>
Date: Tue, 7 Apr 2009 13:55:02 +0200

The buildbots are finally green so it's time for a release.

The point of this release is to release a version with experimental
support for UFL still working with the old .form format.

After this release, there's plenty to be done:

  - Clean out the old .form format (DOLFIN and FFC)
  - Move to the new XML format (DOLFIN)
  - MeshGeometry patches (DOLFIN)
  - Consistency/design fixes for Function classes

Version numbers as follows (please correct me if I'm wrong):

  DOLFIN 0.9.2
  FFC 0.6.2
  UFC 1.1.2
  Viper 0.4.2
  UFL 0.1.0
  SyFi 0.5.2

I can do DOLFIN, FFC, UFC.

Ola: Viper?

Martin: UFL, SyFi?

Hopefully, the introduction of UFL and moving the DOLFIN wrapper code
generation to DOLFIN (from FFC) will mean that the need for
synchronized releases like this will vanish.

But it might anyway be good to try to keep some kind of regular
release schedule. It's April, so one option would be to follow the
Ubuntu release schedule and call this FEniCS 9.04. I think this is
already done for the Debian packages.

-- 
Anders

---

From: Anders Logg <[email-masked]>
Date: Tue, 7 Apr 2009 20:42:28 +0200

> already done for the Debian packages.

New releases are out for DOLFIN, FFC, UFC, UFL and SyFi.

Only Viper is missing.

-- 
Anders