Subject: [Fenics] Release of web pages

From: Anders Logg <[email-masked]>
Date: Tue, 16 Aug 2011 13:22:43 +0200

After some discussion with Harish, we have decided to make a release
of the web pages on Thursday 12.00, meaning that they will go live and
be placed at www.fenicsproject.org.

If anyone has objections to this, please let us know.

Even better, help review the contents of the pages and help us fix the
things that need fixing.

References:

  http://fenicsproject.org/new/
  https://bugs.launchpad.net/fenics-web

--
Anders

---

From: Anders Logg <[email-masked]>
Date: Thu, 18 Aug 2011 10:01:55 +0200

>   https://bugs.launchpad.net/fenics-web

Last minute reminder. Pages will go live in 2 hours. Please help out
reviewing the pages before they are released upon the world.

--
Anders

---

From: Anders Logg <[email-masked]>
Date: Thu, 18 Aug 2011 10:46:29 +0200

Yes, please provide a patch. :-)

We're waiting for FEniCS Apps to submit something sensible to replace
that gibberish. As soon as we have one or two submissions (it's just
a couple of lines needed), we can update the page.

I'll fix something for CBC.Solve right away. Anyone else who can
contribute a picture + some short words for any of the other apps?

--
Anders

On Thu, Aug 18, 2011 at 10:43:38AM +0200, Martin Sandve Alnæs wrote:
> This has gibberish in it:
> http://fenicsproject.org/new/applications/
>
> Martin
>
> On 18 August 2011 10:01, Anders Logg <[email-masked]> wrote:
> > _______________________________________________
> > Mailing list: https://launchpad.net/~fenics
> > Post to     : [email-masked]
> > Unsubscribe : https://launchpad.net/~fenics
> > More help   : https://help.launchpad.net/ListHelp
> >

---

From: Martin Sandve Alnæs <[email-masked]>
Date: Thu, 18 Aug 2011 10:52:22 +0200

The pages look really good now!

On
http://fenicsproject.org/new/citing/

Can someone please add this citation?

SyFi
----
Alnaes, M. S. and Mardal, K.-A. (2010). On the Efficiency of Symbolic
Computations Combined with Code Generation for Finite Element Methods,
ACM Transactions on Mathematical Software 37(1).
[dx.doi.org/10.1145/1644001.1644007]

Thanks!

Martin

---

From: Anders Logg <[email-masked]>
Date: Thu, 18 Aug 2011 10:56:40 +0200

> The pages look really good now!

:-)

> [dx.doi.org/10.1145/1644001.1644007]

I will. It's on my stack to review the reference list. There are other
missing references.

--
Anders

---

From: Harish Narayanan <[email-masked]>
Date: Thu, 18 Aug 2011 10:57:02 +0200

> [dx.doi.org/10.1145/1644001.1644007]

Added.

Harish

---

From: Harish Narayanan <[email-masked]>
Date: Thu, 18 Aug 2011 16:36:48 +0200

>   https://bugs.launchpad.net/fenics-web

Hello all,

As Anders pointed out, we've now made our most recent attempt at the
FEniCS project web site live. Check it out at:

  http://www.fenicsproject.org/

Most pages are in reasonable shape, but we still need your help with:

1. Finding and helping fix bugs. We already know of a few which we hope
to squash soon: https://launchpad.net/fenics-web/+bugs

2. Augmenting the content of some pages. In particular the
/applications/ page and /featured/ pages. (These could provide another
great way to publicise your research!)

Happy browsing,
Harish

---

From: Nuno Lopes <[email-masked]>
Date: Tue, 23 Aug 2011 11:19:42 +0100

Hi,

Could you please apply the patch for DOLFWAVE.

Thanks.

Nuno Lopes

-- 
----------------------------------------------------
Nuno David Lopes

e-mail:ndl (at) ptmat.fc.ul.pt        (FCUL/CMAF)
       nlopes (at) dec.isel.ipl.pt    (ISEL)
       ndlopes (at) gmail.com
http://ptmat.ptmat.fc.ul.pt/%7Endl/ 
-------------Dolfwave Project-----------------------
https://launchpad.net/dolfwave 
----------------------------------------------------

# Bazaar merge directive format 2 (Bazaar 0.90)
# revision_id: [email-masked]
# target_branch: bzr+ssh://bazaar.launchpad.net/%2Bbranch/fenics-web/
# testament_sha1: 93ca88e4596aca1af217e11bbfe6b1e3279cb60c
# timestamp: 2011-08-23 11:12:07 +0100
# base_revision_id: [email-masked]\
#   yearauokovdf00fd
# 
# Begin patch
=== added file 'source/_static/images/dolfwave_tsunami.png'
Binary files source/_static/images/dolfwave_tsunami.png	1970-01-01 00:00:00 +0000 and source/_static/images/dolfwave_tsunami.png	2011-08-23 10:11:12 +0000 differ
=== modified file 'source/applications/index.inc'
--- source/applications/index.inc	2011-08-22 21:37:36 +0000
+++ source/applications/index.inc	2011-08-23 10:11:12 +0000
@@ -63,6 +63,26 @@
 
         </div><!-- #front-block-3 .front-block .block-->
 
+      	<div id="front-block-4" class="front-block block">
+
+	  <h3>DOLFWAVE &mdash; A library for surface water waves</h3>
+          <img alt='' src='/_static/images/dolfwave_tsunami.png'
+          class='avatar avatar-84 photo' height='84' width='84' />
+
+	   <p>DOLFWAVE is a FEniCS based  library for solving surface water waves
+          problems such as Tsunami generation and propagation.
+          It is developed at <a href="http://ptmat.fc.ul.pt/lab_analise_num.html">
+          LAN </a> hosted by <a href="http://ptmat.fc.ul.pt"> CMAF </a> in Lisbon.
+          The main goal of DOLFWAVE is to provide a framework for the analysis,
+          development and computation of Boussinesq-type models.
+    </p>
+
+          <p><a href="https://launchpad.net/dolfwave"
+          rel="nofollow">Visit the project&#8217;s web site to learn more
+          &raquo;</a></p>
+
+        </div><!-- #front-block-4 .front-block .block-->
+
       </div><!-- #sub-feature -->
     </div><!-- #content -->
   </div><!-- #container .feature -->

# Begin bundle

---

From: Harish Narayanan <[email-masked]>
Date: Tue, 23 Aug 2011 13:24:16 +0200

> Could you please apply the patch for DOLFWAVE.

I have applied it. Thanks!

Harish