Subject: Re: [FEniCS-dev] IndexError: index (4) out of range (0<=index<=4) in dimension 1

From: Chong Luo <[email-masked]>
Date: Sat, 22 Mar 2008 16:50:13 -0700 (PDT)

Ah, it worked after defining (u,p) as a system, like this:

deg=1
vector = VectorElement("Lagrange", "tetrahedron", deg)
scalar = FiniteElement("Lagrange", "tetrahedron", deg)
system = vector + scalar

(v, q) = TestFunctions(system)
(u, p) = TrialFunctions(system)

Sorry for creating so much garbage in the mailing list. 
Maybe I should think more before I post to the mailing list. 

Best,
Chong Luo
----- Original Message ----
From: Chong Luo <[email-masked]>
To: [email-masked]
Sent: Saturday, March 22, 2008 5:54:07 PM
Subject: [FEniCS-dev] IndexError: index (4) out of range (0<=index<=4) in dimension 1

Hi,

After careful thinking, I almost got the form compiled, except one error which I don't understand:
  File "/home/aharon/local/lib/python2.4/site-packages/ffc/compiler/codegeneration/tensor/tensorgenerator.py", line 296, in __generate_element_tensor
    a0 = A0.A0[tuple(i + a)]
IndexError: index (4) out of range (0<=index<=4) in dimension 1

And the form file is in the attachment, which I wrote to solve incompressible nonlinear elasticity problem.

Thank you!

Best,
Chong Luo

      Be a better friend, newshound, and know-it-all with Yahoo! Mobile.  Try it now.

-----Inline Attachment Follows-----

_______________________________________________
FEniCS-dev mailing list
[email-masked]
http://www.fenics.org/mailman/listinfo/fenics-dev

      ____________________________________________________________________________________
Be a better friend, newshound, and 
know-it-all with Yahoo! Mobile.  Try it now.  http://mobile.yahoo.com/;_ylt=Ahu06i62sR8HDtDypao8Wcj9tAcJ

---

From: Anders Logg <[email-masked]>
Date: Sun, 23 Mar 2008 09:28:21 +0100

> Maybe I should think more before I post to the mailing list.

No problem. Good to see that it works. For further questions about
implementing forms, try posting to [email-masked] instead.

Thanks
-- 
Anders

>   File "/home/aharon/local/lib/python2.4/site-packages/ffc/compiler/
> codegeneration/tensor/tensorgenerator.py", line 296, in
> __generate_element_tensor
>     a0 = A0.A0[tuple(i + a)]
> ━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
> ━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
> Looking for last minute shopping deals? Find them fast with Yahoo! Search.