Subject: [FEniCS-dev] A question about installation

From: "Jiping Xin" <[email-masked]>
Date: Thu, 31 Jan 2008 18:44:16 +0100 (CET)

Hello,

I am trying to install FEniCS following
"http://www.fenics.org/wiki/A_detailed_guide_to_installing_DOLFIN". When i
install PETSc 2.3.2-p8, it show me the following result. Would you please
tell me what is the problem? Thanks.

bash-3.00$ ./config/configure.py --with-mpi-dir=$INSTALL_PATH
--with-clanguage=c xx --download-hypre=yes --enable-hypre=1
--download-umfpack=yes --enable-umfpack =1
================================================================================
=
             Configuring PETSc to compile on your system
================================================================================
=
TESTING: checkFortranLibraries from
config.compilers(python/BuildSystem/config/c*********
************************************************************************
         UNABLE to CONFIGURE with GIVEN OPTIONS    (see configure.log for
details):
---------------------------------------------------------------------------------------
Fortran libraries cannot be used with C compiler
*********************************************************************************

Best regards,
JIping

-- 
Jiping Xin
Engineering Mathematics, Mathematics School of Chalmers University of
Technology
Brahegatan 9, 1207 Room, Gothenburg

---

From: "Matthew Knepley" <[email-masked]>
Date: Thu, 31 Jan 2008 11:53:05 -0600

1) Please send PETSc questions to [email-masked]

2) Please send configure.log which has all the information we need

3) There was a problem linking Fortran code with the C linker. You can
     turn off Fortran using --with-fc=0 (which most people want who use
     FEniCS).

  Thanks,

     Matt

On Jan 31, 2008 11:44 AM, Jiping Xin <[email-masked]> wrote:
> _______________________________________________
> FEniCS-dev mailing list
> [email-masked]
> http://www.fenics.org/mailman/listinfo/fenics-dev
>

-- 
What most experimenters take for granted before they begin their
experiments is infinitely more interesting than any results to which
their experiments lead.
-- Norbert Wiener

---

From: "Matthew Knepley" <[email-masked]>
Date: Thu, 31 Jan 2008 12:50:32 -0600

On Jan 31, 2008 12:12 PM, Jiping Xin <[email-masked]> wrote:
> Thanks. So does this mean that we don't need Fortran in FEniCS? Jiping

I believe that is true.

  Matt

> Matthew Knepley wrote:

---

From: Anders Logg <[email-masked]>
Date: Thu, 31 Jan 2008 20:26:18 +0100

> > Thanks. So does this mean that we don't need Fortran in FEniCS? Jiping

Yes, definitely true...

-- 
Anders

---

From: "Matthew Knepley" <[email-masked]>
Date: Sun, 3 Feb 2008 20:40:45 -0600

If you want to have an install path other than /usr then you must put this
in CFLAGS (-I/install/path/include) and LDFLAGS (-L/install/path/lib)

    Matt

On Feb 2, 2008 7:14 AM, Jiping Xin <[email-masked]> wrote:
> Hi Matt,
>
> The last question is not clear.
> I have used the following command to install CLN 1.1.13.
> ..........................................................
> cd $DOWNLOAD_PATH
> wget http://www.ginac.de/CLN/cln-1.1.13.tar.bz2
> tar -xjf cln-1.1.13.tar.bz2
> cd cln-1.1.13
> ./configure --prefix=$INSTALL_PATH
> make
> make install
> ..........................................................
> And i also tried to use the following command to install GiNaC 1.3.7.
> ..........................................................
> cd $DOWNLOAD_PATH
> wget ftp://ftpthep.physik.uni-mainz.de/pub/GiNaC/ginac-1.3.7.tar.bz2
> tar -xjf ginac-1.3.7.tar.bz2
> cd ginac-1.3.7
> ./configure --prefix=$INSTALL_PATH
> make
> make install
> ..........................................................
> But when i use "./configure --prefix=$INSTALL_PATH", i always get the
> result as the follwing.
> ..........................................................
> **** The following problems have been detected by configure.
> **** Please check the messages below before running "make".
> **** (see the section 'Common Problems' in the INSTALL file)
>
> ** No suitable installed version of CLN could be found.
> ..........................................................
>
> Would you please tell me what is the problem? Thanks.
>
> Best regards,
> Jiping
>
> Matthew Knepley wrote:
> >> >> "http://www.fenics.org/wiki/A_detailed_guide_to_installing_DOLFIN".
> >> When
> >> >> i

---

From: "Matthew Knepley" <[email-masked]>
Date: Sun, 3 Feb 2008 20:41:42 -0600

I do not maintain that part. Perhaps someone here can help.

  Matt

---------- Forwarded message ----------
From: Jiping Xin <[email-masked]>
Date: Feb 2, 2008 7:26 AM
Subject: Re: [FEniCS-dev] A question about installation
To: Matthew Knepley <[email-masked]>

Hi Matt,

I have another question.

I have used the following command to install gts 0.7.6.
................................................................
cd $DOWNLOAD_PATH
wget http://easynews.dl.sourceforge.net/sourceforge/gts/gts-0.7.6.tar.gz
tar -xzf gts-0.7.6.tar.gz
cd gts-0.7.6
./configure --prefix=$INSTALL_PATH
make
make install
.................................................................
And i also use the following command to install UFC.
.................................................................
cd $DOWNLOAD_PATH/fenics
hg clone http://www.fenics.org/hg/ufc
cd ufc
python setup.py install --prefix=$INSTALL_PATH
.................................................................
I try to use the following command to install Dolphin,
.................................................................
./configure --prefix=$INSTALL_PATH --enable-static --enable-optimization
--enable-petsc --enable-mpi --with-petsc-dir=$PETSC_DIR
--with-boost=$INSTALL_PATH
--with-umfpack-lib=$PETSC_DIR/externalpackages/UMFPACKv4.3/$PETSC_ARCH/UMFPACK/Lib

--with-amd-lib=$PETSC_DIR/externalpackages/UMFPACKv4.3/$PETSC_ARCH/AMD/Lib
--with-umfpack-include=$PETSC_DIR/externalpackages/UMFPACKv4.3/$PETSC_ARCH/UMFPACK/Include
--disable-pydolfin
.................................................................
But I got the follwing result.
.................................................................
Perhaps you should add the directory containing `gts.pc'
to the PKG_CONFIG_PATH environment variable
No package 'gts' found
no
Missing GTS
checking for UFC... Package ufc-1 was not found in the pkg-config search
path.
Perhaps you should add the directory containing `ufc-1.pc'
to the PKG_CONFIG_PATH environment variable
No package 'ufc-1' found
configure: error: Package requirements (ufc-1) were not met:

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables UFC_CFLAGS
and UFC_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.
.................................................................
I have checked the directory $HOME/builds/lib/pkgconfig/ and i found
gtc.pc and ufc-1.pc have already been there. I also keep
"PKG_CONFIG_PATH=$INSTALL_PATH/lib/pkgconfig". It is strange. Would you

please tell me what is the problem? Thanks.

Best regards,
Jiping