Subject: [Fenics] Equations in documentation

From: "Garth N. Wells" <[email-masked]>
Date: Tue, 27 Apr 2010 09:30:03 +0100

Has anyone looked into including equations in the new documentation? I 
had a quick look and there appears to be no easy solution which works 
for both LaTeX and HTML. See

http://docutils.sourceforge.net/FAQ.html#how-can-i-include-mathematical-equations-in-documents

Garth

---

From: Kristian Oelgaard <[email-masked]>
Date: Tue, 27 Apr 2010 10:58:30 +0200 (CET)

On 27 April 2010 10:30, Garth N. Wells <[email-masked]> wrote:
> Has anyone looked into including equations in the new documentation? I had a
> quick look and there appears to be no easy solution which works for both
> LaTeX and HTML. See
>

I see you found the .. math:: directive. I think it looks pretty good with the png equations, the alternative is to use the jsmath extension to render the equations, but I didn't look into how it works.

Kristian

> Garth
>
> _______________________________________________
> Mailing list: https://launchpad.net/~fenics
> Post to     : [email-masked]
> Unsubscribe : https://launchpad.net/~fenics
> More help   : https://help.launchpad.net/ListHelp
>

---

From: "Garth N. Wells" <[email-masked]>
Date: Tue, 27 Apr 2010 10:04:03 +0100

On 27/04/10 09:58, Kristian Oelgaard wrote:
>> had a
> I see you found the .. math:: directive. I think it looks pretty good
> with the png equations, the alternative is to use the jsmath extension
> to render the equations, but I didn't look into how it works.
>

It turns out to be pretty easy. The issues was that reStructuredText 
doesn't support equations in a way that is independent of the output 
format, but Sphinx does.

Garth

---

From: Anders Logg <[email-masked]>
Date: Tue, 27 Apr 2010 11:28:57 +0200

> doesn't support equations in a way that is independent of the output

But we're using Sphinx so there is no problem then?

--
Anders

---

From: Kristian Oelgaard <[email-masked]>
Date: Tue, 27 Apr 2010 11:35:11 +0200 (CET)

> But we're using Sphinx so there is no problem then?

No, it should be OK. The only question is if using the jsmath rendering instead of png looks better (it's only an issue for HTML the LaTeX will always look good), but I haven't looked into getting jsmath to work yet.

Kristian

> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v1.4.9 (GNU/Linux)
>
> iEYEARECAAYFAkvWrlgACgkQTuwUCDsYZdGw8gCeJkgd68aLa46VW4YKtnzE5POO
> dj8AoI41B9+EKdz1zIPP8/UUeWLTcxgb
> =znZy
> -----END PGP SIGNATURE-----
>
>