Subject: Re: [FEniCS-dev] Numerical Python 64-bit machines

From: Anders Logg <[email-masked]>
Date: Thu, 10 Aug 2006 16:42:56 +0200

On Thu, Aug 10, 2006 at 09:35:38AM -0500, Robert C. Kirby wrote:
> Hi all,
> I recall that a while back that some of you had issues with FIAT on a  
> 64-bit machine because of some funny business in Numeric.  A few  
> questions for whoever knows the answers:
> 
> - on what particular processor and Linux versions did the problems  
> arise?
> - does anyone know if this is fixed in the successor to Numeric?
> 
> 
> Thanks,
> Rob Kirby

The bug seems to be closed:

http://sourceforge.net/tracker/index.php?func=detail&aid=1108739&group_id=1369&atid=301369

I haven't played with any 64-bit machine for a while so I don't know
if the problem is still there. I'd guess you should be ok with a
recent version of Numeric.

Is it about time to move on to NumPy?

/Anders

---

From: Anders Logg <[email-masked]>
Date: Thu, 10 Aug 2006 20:07:43 +0200

On Thu, Aug 10, 2006 at 10:00:42AM -0500, Robert C. Kirby wrote:
> Thanks for checking -- I was also thinking that it would be time to  
> move on (especially since they are making it harder to download  
> Numeric).
> 
> They claim the transition is easy.  On the other hand, DOLFIN is  
> getting ready for a release, and it might make sense to wait until  
> after to move the whole thing over.

Yes, it's a good idea to wait until after our next release, which I
hope will be in 1 or 2 weeks.

> I will be glad to transfer FIAT over and make a new release when done.
> The current version seems stable enough that Numeric users would be  
> able to continue
> with it indefinitely (especially since everybody is only using  
> Lagrange anyway).

:-)

FFC will also need some minor work but it should be fairly smooth.

/Anders

> Rob
> 
> 
> On Aug 10, 2006, at 9:42 AM, Anders Logg wrote:
> 
> >http://sourceforge.net/tracker/index.php? 
> >func=detail&aid=1108739&group_id=1369&atid=301369
> >