Subject: [FEniCS-dev] Differential equations on manifolds

From: Harish Narayanan <[email-masked]>
Date: Mon, 18 Feb 2008 14:02:14 -0500

Hello all,

I've been curious about (FEM-based) computational frameworks for solving 
PDEs on (connected, compact, curved) Riemannian manifolds with 
(Lipschitz) continuous boundaries. Does anyone have any experience with 
this?

If one were to approach such a problem with FEniCS, at what level should 
they begin to look into extending (FIAT? FFC?) to allow for operations 
such as element assembly using an atlas of charts?

Thanks,
Harish

---

From: Anders Logg <[email-masked]>
Date: Mon, 18 Feb 2008 20:15:22 +0100

> such as element assembly using an atlas of charts?

Try this:

  hg clone http://www.fenics.org/dev/exterior

It's currently restricted to simplices (in R^n for any n > 0), but
it should be possible to extend. (At least it's small enough that it
should be possible to experiment with.)

-- 
Anders

---

From: Harish Narayanan <[email-masked]>
Date: Mon, 18 Feb 2008 14:28:02 -0500

> should be possible to experiment with.)

Cool, thanks. I will play with this as soon as I get Swiginac working.

---

From: Anders Logg <[email-masked]>
Date: Mon, 18 Feb 2008 20:38:25 +0100

> Cool, thanks. I will play with this as soon as I get Swiginac working.

One may also consider implementing it on top of sympy (which is easier
to install) but a good deal slower than swiginac (may change).

-- 
Anders

---

From: "Johan Hoffman" <[email-masked]>
Date: Tue, 19 Feb 2008 09:31:35 +0100 (MET)

> to install) but a good deal slower than swiginac (may change).

This sounds really interesting. Is there going to be a presentation on
this at LSU?

/Johan

> _______________________________________________
> FEniCS-dev mailing list
> [email-masked]
> http://www.fenics.org/mailman/listinfo/fenics-dev
>

---

From: "Johan Hoffman" <[email-masked]>
Date: Tue, 19 Feb 2008 09:32:37 +0100 (MET)

> to install) but a good deal slower than swiginac (may change).

Sounds really interesting, is there going to be a presentation at LSU?

/Johan

---

From: Anders Logg <[email-masked]>
Date: Tue, 19 Feb 2008 09:45:40 +0100

> Sounds really interesting, is there going to be a presentation at LSU?

That's the plan.

-- 
Anders

---

From: "Johan Hoffman" <[email-masked]>
Date: Tue, 19 Feb 2008 11:52:24 +0100 (MET)

>> Sounds really interesting, is there going to be a presentation at LSU?

Looking forward to it!

/Johan

---

From: Anders Logg <[email-masked]>
Date: Tue, 19 Feb 2008 12:00:24 +0100

> >> Sounds really interesting, is there going to be a presentation at LSU?

Don't expect too much. It's just a toy project.

-- 
Anders

---

From: "Johan Hoffman" <[email-masked]>
Date: Tue, 19 Feb 2008 12:08:25 +0100 (MET)

>> >> >> > it should be possible to extend. (At least it's small enough
>> that
>> >> it

Toys are fun! ;)

/Johan