Subject: [Fenics] error building doc

From: "Garth N. Wells" <[email-masked]>
Date: Wed, 25 Aug 2010 17:46:14 +0100

I get the error

  Theme error:
  no theme named 'agogo' found (missing theme.conf?)
  make: *** [html] Error 1

when I try to build to doc. Should this theme be added?

Garth

---

From: Anders Logg <[email-masked]>
Date: Wed, 25 Aug 2010 20:04:58 +0200

> when I try to build to doc. Should this theme be added?

You need to upgrade your Sphinx:

  sudo apt-get install python-setuptools
  sudo apt-get remove python-sphinx
  sudo easy_install -U Sphinx

--
Anders

---

From: Harish Narayanan <[email-masked]>
Date: Thu, 26 Aug 2010 11:41:07 +0530

>   sudo easy_install -U Sphinx

While on this topic, the existing themes in Sphinx are as follows:

agogo
basic
default
epub
haiku
nature
scrolls
sphinxdoc
traditional

You can try each one out by changing html_theme in source/conf.py and
re-making the documentation. I personally like 'nature'. Also, see the
following thread for ideas: http://bit.ly/cC5oTC

What is everyone's personal opinion on how the documentation should
look? (This information will be used as "community design input" toward
the web site.)

Harish

---

From: Anders Logg <[email-masked]>
Date: Thu, 26 Aug 2010 09:21:18 +0200

> look? (This information will be used as "community design input" toward

I think the matplotlib documentation looks good:

http://matplotlib.sourceforge.net/

Ultimately, our documentation should have the look and feel of our
(new) web site.

I just changed from the old style since that made sections and
subsections look very similar.

--
Anders

---

From: Kristian Ølgaard <[email-masked]>
Date: Thu, 26 Aug 2010 10:57:15 +0200

>> While on this topic, the existing themes in Sphinx are as follows:

This is how I rate them:
agogo       # 4 (I would rate this number #2, maybe #1 if there was
more difference between
                      -- and ^^ sections in the table of contents, and
'note' and 'warning' did not look the same.)
basic        # 8
default      # 3
epub         # 7
haiku        # 6
nature       # 1
scrolls      # 9
sphinxdoc # 2
traditional  # 5

I will object to using 5-9.

Kristian

> http://matplotlib.sourceforge.net/

Looks a lot like the sphinxdoc theme.

Kristian

> _______________________________________________
> Mailing list: https://launchpad.net/~fenics
> Post to     : [email-masked]
> Unsubscribe : https://launchpad.net/~fenics
> More help   : https://help.launchpad.net/ListHelp
>

---

From: Anders Logg <[email-masked]>
Date: Thu, 26 Aug 2010 11:08:24 +0200

> 'note' and 'warning' did not look the same.)

nature:

  Layout/organization looks good but I think it looks too bleak and
  washed-out. Maybe it would be simple to just change the colors.

sphinxdoc:

  I like this better than 'nature', but it looks too much like the
  Sphinx documentation. :-)

  But it's better than 'agogo' in formatting code (the blue box).

default:

  Can't see the difference between sections and subsections.

My rating would be

 1. sphinxdoc
 2. agogo
 3. nature
 4. default

I'll change to sphinxdoc for now.

--
Anders