Subject: [Fenics] Ubuntu packages broken?

From: Douglas N Arnold <[email-masked]>
Date: Sat, 26 Jun 2010 16:29:58 -0500

The Ubuntu packages don't seem to work anymore.  After a fresh
download with "apt-get install fenics" following the instructions at the
top of http://www.fenics.org/wiki/Download
the packages seem to install OK, but when I try to run, e.g., the 
poisson demo.py, I get a complaint about a swig version mismatch.

python /usr/share/doc/dolfin-doc/demo/pde/poisson/python/demo.py
Calling FFC just-in-time (JIT) compiler, this may take some time.
Traceback (most recent call last):
   File "/usr/share/doc/dolfin-doc/demo/pde/poisson/python/demo.py", 
line 24, in <module>
     V = FunctionSpace(mesh, "CG", 1)
   File 
"/usr/lib/python2.6/dist-packages/dolfin/function/functionspace.py", 
line 226, in __init__
     FunctionSpaceBase.__init__(self, mesh, element)
   File 
"/usr/lib/python2.6/dist-packages/dolfin/function/functionspace.py", 
line 44, in __init__
     ufc_element, ufc_dofmap = jit(self._ufl_element)
   File "/usr/lib/python2.6/dist-packages/dolfin/compilemodules/jit.py", 
line 44, in mpi_jit
     return local_jit(*args, **kwargs)
   File "/usr/lib/python2.6/dist-packages/dolfin/compilemodules/jit.py", 
line 103, in jit
     return jit_compile(form, parameters=p, common_cell=common_cell)
   File "/usr/lib/python2.6/dist-packages/ffc/jitcompiler.py", line 56, 
in jit
     return jit_element(object, parameters)
   File "/usr/lib/python2.6/dist-packages/ffc/jitcompiler.py", line 135, 
in jit_element
     (compiled_form, module, form_data) = jit_form(form, parameters)
   File "/usr/lib/python2.6/dist-packages/ffc/jitcompiler.py", line 107, 
in jit_form
     cache_dir = cache_dir)
   File "/usr/lib/python2.6/dist-packages/ufc_utils/build.py", line 53, 
in build_ufc_module
     (cpp_path, swig_path) = configure_instant()
   File "/usr/lib/python2.6/dist-packages/ufc_utils/build.py", line 96, 
in configure_instant
     """ % ufc.__swigversion__
OSError: The python extension module of UFC was not compiled with the 
present version of swig.
Install swig version 1.3.36 or recompiled UFC with present swig

---

From: Johannes Ring <[email-masked]>
Date: Sun, 27 Jun 2010 00:44:02 +0200

Hi Douglas,

Which version of Ubuntu do you have? Could you also give me the output
of these two commands:

  dpkg -s libdolfin0
  dpkg -s python-ufc

Thanks,

Johannes

On Saturday, June 26, 2010, Douglas N Arnold <[email-masked]> wrote:
> the packages seem to install OK, but when I try to run, e.g., the poisson demo.py, I get a complaint about a swig version mismatch.
>
>   File "/usr/share/doc/dolfin-doc/demo/pde/poisson/python/demo.py", line 24, in <module>
>   File "/usr/lib/python2.6/dist-packages/dolfin/function/functionspace.py", line 226, in __init__
>   File "/usr/lib/python2.6/dist-packages/dolfin/function/functionspace.py", line 44, in __init__
>   File "/usr/lib/python2.6/dist-packages/dolfin/compilemodules/jit.py", line 44, in mpi_jit
>   File "/usr/lib/python2.6/dist-packages/dolfin/compilemodules/jit.py", line 103, in jit
>   File "/usr/lib/python2.6/dist-packages/ffc/jitcompiler.py", line 56, in jit
>   File "/usr/lib/python2.6/dist-packages/ffc/jitcompiler.py", line 135, in jit_element
>   File "/usr/lib/python2.6/dist-packages/ffc/jitcompiler.py", line 107, in jit_form
>     cache_dir = cache_dir)
>   File "/usr/lib/python2.6/dist-packages/ufc_utils/build.py", line 53, in build_ufc_module
>   File "/usr/lib/python2.6/dist-packages/ufc_utils/build.py", line 96, in configure_instant
> OSError: The python extension module of UFC was not compiled with the present version of swig.
> _______________________________________________
> Mailing list: https://launchpad.net/~fenics
> Post to     : [email-masked]
> Unsubscribe : https://launchpad.net/~fenics
> More help   : https://help.launchpad.net/ListHelp
>

---

From: Douglas N Arnold <[email-masked]>
Date: Sat, 26 Jun 2010 18:13:36 -0500

I have Ubuntu 10.04 (lucid).  The output you requested is below.

: gibbs 501; cat /etc/issue
Ubuntu 10.04 LTS \n \l

: gibbs 502; dpkg -s libdolfin0
Package: libdolfin0
Status: install ok installed
Priority: extra
Section: libs
Installed-Size: 3516
Maintainer: Johannes Ring <[email-masked]>
Architecture: amd64
Source: dolfin
Version: 0.9.7-2~ppa1~lucid1
Replaces: libdolfin
Provides: libdolfin
Depends: ufc (>= 1.2.0), python-ffc (>= 0.7.0), python-viper (>= 0.4.2), 
libamd2.2.0 (>= 1:3.4.0), libarpack2 (>= 2.1+parpack96.dfsg), libblas3gf 
| libblas.so.3gf | libatlas3gf-base, libboost-filesystem1.40.0 (>= 
1.40.0-1), libboost-program-options1.40.0 (>= 1.40.0-1), libc6 (>= 2.4), 
libcamd2.2.0 (>= 1:3.4.0), libccolamd2.7.1 (>= 1:3.4.0), libcgal4, 
libcholmod1.7.1 (>= 1:3.4.0), libcolamd2.7.1 (>= 1:3.4.0), libgcc1 (>= 
1:4.1.1), liblapack3gf | liblapack.so.3gf | libatlas3gf-base, 
libopenmpi1.3, libparmetis3.1, libpetsc3.0.0, libslepc3.0.0, libstdc++6 
(>= 4.4.0), libumfpack5.4.0 (>= 1:3.4.0), libx11-6, libxml2 (>= 2.7.4), 
zlib1g (>= 1:1.1.4)
Suggests: dolfin-doc, libdolfin0-dbg, python-pydolfin0
Conflicts: libdolfin
Description: shared libraries for DOLFIN
  DOLFIN is the C++/Python interface of FEniCS, providing a consistent PSE
  (Problem Solving Environment) for ordinary and partial differential 
equations.
  .
  This package contains the shared libraries.
Homepage: http://www.fenics.org/wiki/DOLFIN
Original-Maintainer: Debian Scientific Computing Team 
<[email-masked]>
: gibbs 503; dpkg -s python-ufc
Package: python-ufc
Status: install ok installed
Priority: extra
Section: python
Installed-Size: 316
Maintainer: Johannes Ring <[email-masked]>
Architecture: amd64
Source: ufc
Version: 1.4.0-2~ppa1~karmic1
Depends: ufc (= 1.4.0-2~ppa1~karmic1), python (<< 2.7), python (>= 2.6), 
python-central (>= 0.6.11), libc6 (>= 2.4), libgcc1 (>= 1:4.1.1), 
libstdc++6 (>= 4.1.1)
Description: unified code generation interface for form-compilers
  UFC (Unified Form-assembly Code) is a unified framework for finite element
  assembly. More precisely, it defines a fixed interface for 
communicating low
  level routines (functions) for evaluating and assembling finite element
  variational forms. The UFC interface consists of a single header file 
ufc.h
  that specifies a C++ interface that must be implemented by code that 
complies
  with the UFC specification. Examples of form compilers that support 
the UFC
  interface are FFC and SyFi.
  .
  This package contains the Python bindings for UFC.
Homepage: http://www.fenics.org/wiki/UFC
Original-Maintainer: Debian Scientific Computing Team 
<[email-masked]>
Python-Version: 2.6
: gibbs 504; python demo.py
Calling FFC just-in-time (JIT) compiler, this may take some time.
Traceback (most recent call last):
   File "demo.py", line 24, in <module>
     V = FunctionSpace(mesh, "CG", 1)
   File 
"/usr/lib/python2.6/dist-packages/dolfin/function/functionspace.py", 
line 226, in __init__
     FunctionSpaceBase.__init__(self, mesh, element)
   File 
"/usr/lib/python2.6/dist-packages/dolfin/function/functionspace.py", 
line 44, in __init__
     ufc_element, ufc_dofmap = jit(self._ufl_element)
   File "/usr/lib/python2.6/dist-packages/dolfin/compilemodules/jit.py", 
line 44, in mpi_jit
     return local_jit(*args, **kwargs)
   File "/usr/lib/python2.6/dist-packages/dolfin/compilemodules/jit.py", 
line 103, in jit
     return jit_compile(form, parameters=p, common_cell=common_cell)
   File "/usr/lib/python2.6/dist-packages/ffc/jitcompiler.py", line 56, 
in jit
     return jit_element(object, parameters)
   File "/usr/lib/python2.6/dist-packages/ffc/jitcompiler.py", line 135, 
in jit_element
     (compiled_form, module, form_data) = jit_form(form, parameters)
   File "/usr/lib/python2.6/dist-packages/ffc/jitcompiler.py", line 107, 
in jit_form
     cache_dir = cache_dir)
   File "/usr/lib/python2.6/dist-packages/ufc_utils/build.py", line 53, 
in build_ufc_module
     (cpp_path, swig_path) = configure_instant()
   File "/usr/lib/python2.6/dist-packages/ufc_utils/build.py", line 96, 
in configure_instant
     """ % ufc.__swigversion__
OSError: The python extension module of UFC was not compiled with the 
present version of swig.
Install swig version 1.3.36 or recompiled UFC with present swig

On 06/26/2010 05:44 PM, Johannes Ring wrote:
> On Saturday, June 26, 2010, Douglas N Arnold<[email-masked]>  wrote:
>>    File "/usr/share/doc/dolfin-doc/demo/pde/poisson/python/demo.py", line 24, in<module>

---

From: Johannes Ring <[email-masked]>
Date: Sun, 27 Jun 2010 14:20:21 +0200

On Sun, Jun 27, 2010 at 1:13 AM, Douglas N Arnold <[email-masked]> wrote:
> libamd2.2.0 (>= 1:3.4.0), libarpack2 (>= 2.1+parpack96.dfsg), libblas3gf |
> libblas.so.3gf | libatlas3gf-base, libboost-filesystem1.40.0 (>= 1.40.0-1),
> libboost-program-options1.40.0 (>= 1.40.0-1), libc6 (>= 2.4), libcamd2.2.0
> (>= 1:3.4.0), libccolamd2.7.1 (>= 1:3.4.0), libcgal4, libcholmod1.7.1 (>=
> 1:3.4.0), libcolamd2.7.1 (>= 1:3.4.0), libgcc1 (>= 1:4.1.1), liblapack3gf |
> liblapack.so.3gf | libatlas3gf-base, libopenmpi1.3, libparmetis3.1,
> libpetsc3.0.0, libslepc3.0.0, libstdc++6 (>= 4.4.0), libumfpack5.4.0 (>=
> 1:3.4.0), libx11-6, libxml2 (>= 2.7.4), zlib1g (>= 1:1.1.4)

It seems that UFC hasn't been upgraded yet. Try to run

  sudo apt-get upgrade

and see if that helps. If not, try instead

  sudo apt-get dist-upgrade

Please let me know if this fixes your issue.

Johannes

> python-central (>= 0.6.11), libc6 (>= 2.4), libgcc1 (>= 1:4.1.1), libstdc++6
> (>= 4.1.1)
>  assembly. More precisely, it defines a fixed interface for communicating
> low
>  variational forms. The UFC interface consists of a single header file ufc.h
>  with the UFC specification. Examples of form compilers that support the UFC
>>> the packages seem to install OK, but when I try to run, e.g., the poisson
>>> demo.py, I get a complaint about a swig version mismatch.
>>>
>>> "/usr/lib/python2.6/dist-packages/dolfin/function/functionspace.py", line
>>> 226, in __init__
>>> "/usr/lib/python2.6/dist-packages/dolfin/function/functionspace.py", line
>>> 44, in __init__

---

From: Douglas N Arnold <[email-masked]>
Date: Mon, 28 Jun 2010 12:01:28 +0200

sudo apt-get upgrade    fixed it.  Thanks!

On 06/27/2010 02:20 PM, Johannes Ring wrote:
> On Sun, Jun 27, 2010 at 1:13 AM, Douglas N Arnold<[email-masked]>  wrote:
>> Maintainer: Johannes Ring<[email-masked]>
>> Architecture: amd64
>> Source: dolfin
>> Maintainer: Johannes Ring<[email-masked]>
>> Architecture: amd64
>> Source: ufc
>>   File "demo.py", line 24, in<module>