Subject: Re: [Fenics] [Branch ~fenics-core/fenics-doc/main] Rev 151: Fix comment to match code to make verify_demo script more happy.

From: Anders Logg <[email-masked]>
Date: Wed, 1 Sep 2010 14:05:19 +0200

On Wed, Sep 01, 2010 at 11:55:34AM -0000, [email-masked] wrote:
> ------------------------------------------------------------
> revno: 151
> committer: Marie E. Rognes <[email-masked]>
> branch nick: fenics-doc
> timestamp: Wed 2010-09-01 13:52:09 +0200
> message:
>   Fix comment to match code to make verify_demo script more happy.
> modified:
>   source/demos/la/eigenvalue/python/documentation.rst
>
>

> === modified file 'source/demos/la/eigenvalue/python/documentation.rst'
> --- source/demos/la/eigenvalue/python/documentation.rst	2010-08-31 19:57:18 +0000
> +++ source/demos/la/eigenvalue/python/documentation.rst	2010-09-01 11:52:09 +0000
> @@ -50,7 +50,7 @@
>    mesh = Mesh("box_with_dent.xml.gz")
>    V = FunctionSpace(mesh, "CG", 1)
>
> -  # Define basis and then form the stiffness matrix
> +  # Define basis and bilinear form
>    u = TrialFunction(V)
>    v = TestFunction(V)
>    a = dot(grad(v), grad(u))*dx

Another thing to fix is a(u, v) in all the new demos.

--
Anders

---

From: Marie Rognes <[email-masked]>
Date: Wed, 01 Sep 2010 14:12:29 +0200

> Another thing to fix is a(u, v) in all the new demos.

Ok.  Am reading through the demo documentation -- will  fix as I go along.

--
Marie

---

From: Anders Logg <[email-masked]>
Date: Wed, 1 Sep 2010 14:15:44 +0200

> Ok.  Am reading through the demo documentation -- will  fix as I go along.

Great. Watch out for the NS docs, they're not proofread at all but
they do have a(u, v)...

--
Anders

---

From: Marie Rognes <[email-masked]>
Date: Wed, 01 Sep 2010 14:35:15 +0200

> Great. Watch out for the NS docs, they're not proofread at all but

PS: What is the status of the two different demo directories -- which
contains the "correct ones"?

--
Marie

---

From: Anders Logg <[email-masked]>
Date: Wed, 1 Sep 2010 14:36:59 +0200

> contains the "correct ones"?

You mean fenics-doc or DOLFIN?

The status is that everything should be edited only as part of DOLFIN,
then automatically copied over to the fenics-doc repository.

--
Anders

---

From: "Garth N. Wells" <[email-masked]>
Date: Wed, 01 Sep 2010 14:08:24 +0100

> then automatically copied over to the fenics-doc repository.

Would be good to add a simple rsync script asap to help with this.

Garth

> --
> Anders
> 
> _______________________________________________
> Mailing list: https://launchpad.net/~fenics
> Post to     : [email-masked]
> Unsubscribe : https://launchpad.net/~fenics
> More help   : https://help.launchpad.net/ListHelp

/

---

From: Anders Logg <[email-masked]>
Date: Wed, 1 Sep 2010 15:09:50 +0200

> Would be good to add a simple rsync script asap to help with this.

I'm working on it.

--
Anders

---

From: Anders Logg <[email-masked]>
Date: Wed, 1 Sep 2010 15:26:19 +0200

> > Would be good to add a simple rsync script asap to help with this.

Have there been any changes since last night to the demos in
fenics-doc? Is it ok to run the script now to copy things over from DOLFIN?

--
Anders

---

From: "Garth N. Wells" <[email-masked]>
Date: Wed, 01 Sep 2010 14:42:01 +0100

> fenics-doc? Is it ok to run the script now to copy things over from DOLFIN?

No idea. Go ahead and sync - we can always use version control to get
things back.

Garth

---

From: Anders Logg <[email-masked]>
Date: Wed, 1 Sep 2010 15:50:28 +0200

> No idea. Go ahead and sync - we can always use version control to get

Looks like there have been a number of small changes. Please everyone
stop touching the demos in fenics-doc. I'll go through them one by one.

--
Anders

---

From: Anders Logg <[email-masked]>
Date: Wed, 1 Sep 2010 15:53:42 +0200

> stop touching the demos in fenics-doc. I'll go through them one by one.

There are two different la demos: 'eigenvalue' in fenics-doc and
'eigensolver' in DOLFIN.

Are these supposed to be the same demo? The main.cpp file in
fenics-doc is empty.

--
Anders

---

From: Anders Logg <[email-masked]>
Date: Wed, 1 Sep 2010 16:03:16 +0200

> Are these supposed to be the same demo? The main.cpp file in

I think I know what has changed now. The only problematic demo is the
Cahn-Hilliard C++ demo. Which version should I pick? The one in DOLFIN
or fenics-doc?

--
Anders

---

From: Marie Rognes <[email-masked]>
Date: Wed, 01 Sep 2010 16:04:51 +0200

On 01. sep. 2010 15:53, Anders Logg wrote:
> Are these supposed to be the same demo? 

They are supposed to be the same from now on... I added a new la demo in
fenics-doc and moved that one to DOLFIN -- at some point last night. So
they should have been the same ...

> The main.cpp file in

I seem to remember adding one at some point.

--
Marie

---

From: "Garth N. Wells" <[email-masked]>
Date: Wed, 01 Sep 2010 15:05:16 +0100

> Cahn-Hilliard C++ demo. Which version should I pick? The one in DOLFIN

DOLFIN.

Garth