Subject: [Fenics] Author credits on web page

From: Anders Logg <[email-masked]>
Date: Thu, 16 Jun 2011 07:56:08 +0200

I have started a sketch of a list of FEniCS components for the new web page:

http://www.fenicsproject.org/new/about/components.html

Please comment on the remarks/questions, help me correct any missing
credits and supply texts for describing the various components.

--
Anders

---

From: Josef Höök <[email-masked]>
Date: Thu, 16 Jun 2011 09:01:50 +0000

Hi,

Perhaps it's too early to announce, but I'm working on a generalized Fokker-Planck solver: https://launchpad.net/genfoo

Cheers
/Josef

________________________________________
Från: fenics-bounces+joh=[email-masked] [fenics-bounces+joh=[email-masked]] f&#246;r Anders Logg [[email-masked]]
Skickat: den 16 juni 2011 07:56
Till: FEniCS Mailing List
Ämne: [Fenics] Author credits on web page

--
Anders

_______________________________________________
Mailing list: https://launchpad.net/~fenics
Post to     : [email-masked]
Unsubscribe : https://launchpad.net/~fenics
More help   : https://help.launchpad.net/ListHelp

---

From: Anders Logg <[email-masked]>
Date: Thu, 16 Jun 2011 11:45:34 +0200

Added. I've made some changes to the structure of the page to
accomodate for a large list of contributed applications.

This also needs to be updated on the FEniCS Apps Launchpad page.

Some points for the FEniCS Apps maintainers (Kristian and Andy):

1. Could you take a look at the list of Apps on both the web page and
the Launchpad page and help me fix any missing apps or inconsistencies
(on both pages).

2. I also noticed that the answer contact for the Answers page for FEniCS
Apps is missing. There's a question there that should have been
redirected to the CBC.Solve answers page.

3. Should it be "FEniCS Apps" or "FEniCS-Apps"? I like the first one
better.

4. Is the address for FEniCS Apps correct? fenics-groups doesn't seem
like the natural choice to me.

--
Anders

---

From: Kristian Ølgaard <[email-masked]>
Date: Wed, 22 Jun 2011 14:08:48 +0200

> the Launchpad page and help me fix any missing apps or inconsistencies

The two lists are almost in sync.
Please apply attached patch to fenics-web as I don't have write access.

I don't know if ascot is an application or component and I'm not fussed either.

> redirected to the CBC.Solve answers page.

Is this still an issue? I only see 3 questions for cbc.solve at:
https://answers.launchpad.net/fenics-group
and they are all at:
https://answers.launchpad.net/cbc.solve/

> 3. Should it be "FEniCS Apps" or "FEniCS-Apps"? I like the first one

Me too, I changed it to 'FEniCS Apps'

> like the natural choice to me.

As far as I remember, something went wrong when Andy registered the
project fenics-apps
which should have been a project group but he can elaborate on that.

Kristian

# Bazaar merge directive format 2 (Bazaar 0.90)
# revision_id: [email-masked]
# target_branch: bzr+ssh://bazaar.launchpad.net/%2Bbranch/fenics-web/
# testament_sha1: 0222f4407bf0a6717c11ab6cee8d85d7bea4e6ad
# timestamp: 2011-06-22 13:52:06 +0200
# base_revision_id: [email-masked]\
#   09chtkt5bbp1pbhz
# 
# Begin patch
=== modified file 'source/about/components.rst'
--- source/about/components.rst	2011-06-16 09:45:40 +0000
+++ source/about/components.rst	2011-06-22 11:51:58 +0000
@@ -254,19 +254,29 @@
 this list, contact the `FEniCS Apps maintainers
 <https://launchpad.net/~fenics-apps-core>`__.
 
-* CBC.RANS
-* CBC.Block
+* `CBC.RANS <https://launchpad.net/cbc.rans>`__,
+  solvers for RANS modelling of turbulent flows
+* `CBC.Block <https://launchpad.net/cbc.block>`__,
+  block operators and algebra for DOLFIN
 * `CBC.Solve <https://launchpad.net/cbc.solve>`__,
   a collection of Python-based PDE solvers
-* DOLFWAVE
-* DiffSim
-* FEniCS Plasticity
+* `DOLFWAVE <https://launchpad.net/dolfwave>`__,
+  a library for solving surface water waves problems
+* `DiffSim <https://launchpad.net/diffsim>`__,
+  a library for solving discrete and stochastic systems coupled with continuous
+  and deterministic systems
+* `FEniCS Plasticity <https://launchpad.net/fenics-plasticity>`__,
+  a library that implements the plasticity models using FEniCS software
 * `GenFoo <https://launchpad.net/genfoo>`__,
   a generalized Fokker-Planck solver
-* PUM Compiler
-* PUM solver
-* rheagen
-* TriTetMesh
+* `PUM Compiler <https://launchpad.net/ffc-pum>`__,
+  a form compiler for the partition of unity method
+* `PUM solver <https://launchpad.net/dolfin-pum>`__,
+  a partition of unity method solver
+* `rheagen <https://launchpad.net/rheagen>`__,
+  a non-Newtonian fluid solver platform
+* `TriTetMesh <https://launchpad.net/tritetmesh>`__,
+  a library for producing high quality meshes for DOLFIN
 * `Unicorn <https://launchpad.net/unicorn>`__,
   a unified continuum mechanics solver

# Begin bundle