Subject: [FEniCS-dev] problem building trilinos on mac OS 10.5

From: Aron Wahlberg <[email-masked]>
Date: Fri, 11 Sep 2009 10:26:44 +0200

Hi,

I try to build dolfin using dorsal. I get stuck at the trilinos build.  
I have deleted the entire trilinos directory between builds. The  
problem seems to be about fortran: Isn't fortran part of the developer  
tools or in Xcode? Here is the error output.

Thanks,

Aron Wahlberg

...
checking whether to use tests... yes
checking whether to use teuchos-tests... yes
checking whether to use examples... yes
checking whether to use teuchos-examples... yes
checking whether to use libcheck... yes
checking whether additional library search paths defined... no
checking whether additional include search paths defined... no
checking for library specification errors ... no errors detected
checking whether to use teuchos-abc... no
checking whether to use gcc-checkedstl... no
checking whether to use teuchos-explicit_instantiation... no
checking whether to use teuchos-complex... yes
checking whether to use teuchos-long_long... no
checking whether to use teuchos-extended... yes
checking whether to use teuchos-arprec... no
checking whether to use teuchos-blasfloat... yes
checking whether to use teuchos-gmp... no
checking whether to use teuchos-expat... no
checking whether to use teuchos-libxml2... no
checking whether to use teuchos-boost... no
checking whether to use teuchos-comm_timers... yes
checking whether to use teuchos-debug... no
checking whether to use teuchos-demangle... yes
checking how to get verbose linking output from mpif77... configure:  
WARNING: compilation failed

checking for Fortran 77 libraries of mpif77... rm: conftest.dSYM: is a  
directory

checking for dummy main to link with Fortran 77 libraries... rm:  
conftest.dSYM: is a directory
none
checking for Fortran 77 name-mangling scheme... configure: error:  
cannot compile a simple Fortran program
See `config.log' for more details.
configure: error: ./configure failed for packages/teuchos
Failure with exit status: 1
Exit message: There was a problem configuring build for trilinos-9.0.2.

---

From: Harish Narayanan <[email-masked]>
Date: Fri, 11 Sep 2009 10:52:11 +0200

> tools or in Xcode? Here is the error output.

Fortran is not part of Xcode. Installing gcc from fink gives you gfortran.

Harish