Subject: [Fenics] [[email-masked]: [Bug 791120] [NEW] Missing copyright/license header]

From: Anders Logg <[email-masked]>
Date: Wed, 1 Jun 2011 13:05:58 +0200

The extra space bothers me:

 You should have received a copy of the GNU Lesser General Public
 License along with Instant.  If not, see <http://www.gnu.org/licenses/>.
                            ~~

Is it intentional, or can we remove it?

--
Anders

Subject: [Bug 791120] [NEW] Missing copyright/license header
From: Johannes Ring <[email-masked]>
To: [email-masked]
Date: Wed, 01 Jun 2011 09:16:16 -0000

Public bug reported:

Most files in Instant does not have a proper copyright/license header.
Please add this in all files. The header should preferably look like
this:

# Copyright (C) <date> <name of first author>
# Copyright (C) <date> <name of second author>
#
# This file is part of Instant.
#
# Instant is free software: you can redistribute it and/or modify
# it under the terms of the GNU Lesser General Public License as published by
# the Free Software Foundation, either version 3 of the License, or
# (at your option) any later version.
#
# Instant is distributed in the hope that it will be useful,
# but WITHOUT ANY WARRANTY; without even the implied warranty of
# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
# GNU Lesser General Public License for more details.
#
# You should have received a copy of the GNU Lesser General Public License
# along with Instant.  If not, see <http://www.gnu.org/licenses/>.
#
# Alternatively, Instant may be distributed under the terms of the BSD license.

** Affects: instant
     Importance: Undecided
         Status: Confirmed

** Changed in: instant
       Status: New => Confirmed

-- 
You received this bug notification because you are a member of Instant
Core Team, which is the registrant for Instant.
https://bugs.launchpad.net/bugs/791120

Title:
  Missing copyright/license header

Status in Instant:
  Confirmed

Bug description:
  Most files in Instant does not have a proper copyright/license header.
  Please add this in all files. The header should preferably look like
  this:

  # Copyright (C) <date> <name of first author>
  # Copyright (C) <date> <name of second author>
  #
  # This file is part of Instant.
  #
  # Instant is free software: you can redistribute it and/or modify
  # it under the terms of the GNU Lesser General Public License as published by
  # the Free Software Foundation, either version 3 of the License, or
  # (at your option) any later version.
  #
  # Instant is distributed in the hope that it will be useful,
  # but WITHOUT ANY WARRANTY; without even the implied warranty of
  # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
  # GNU Lesser General Public License for more details.
  #
  # You should have received a copy of the GNU Lesser General Public License
  # along with Instant.  If not, see <http://www.gnu.org/licenses/>.
  #
  # Alternatively, Instant may be distributed under the terms of the BSD license.

---

From: Johannes Ring <[email-masked]>
Date: Wed, 1 Jun 2011 13:17:09 +0200

> Is it intentional, or can we remove it?

It is simply copied and pasted directly from the GPL. See the bottom here:

  http://www.gnu.org/licenses/gpl.html

We can certainly remove it if we don't want it. In that case, there is
also one extra space in the paragraph above this.

Johannes

> --
> Anders
>
>
> ---------- Forwarded message ----------
> _______________________________________________
> Mailing list: https://launchpad.net/~fenics
> Post to     : [email-masked]
> Unsubscribe : https://launchpad.net/~fenics
> More help   : https://help.launchpad.net/ListHelp
>
>

---

From: Joe Morris <[email-masked]>
Date: Wed, 01 Jun 2011 08:27:44 -0400

On 6/1/2011 7:17 AM, Johannes Ring wrote:
> On Wed, Jun 1, 2011 at 1:05 PM, Anders Logg<[email-masked]>  wrote:
>>   License along with Instant.  If not, see<http://www.gnu.org/licenses/>.
>>                             ~~
>>

This might be a throw-back to the typewriter convention where all 
periods were followed by two spaces? These days it does look a little odd.

Joe.

>> From: Johannes Ring<[email-masked]>
>> To: [email-masked]
>> # Copyright (C)<date>  <name of first author>
>> # Copyright (C)<date>  <name of second author>
>> #
>> # along with Instant.  If not, see<http://www.gnu.org/licenses/>.
>> #
>>   # Copyright (C)<date>  <name of first author>
>>   # Copyright (C)<date>  <name of second author>
>>   #
>>   # along with Instant.  If not, see<http://www.gnu.org/licenses/>.
>>   #

---

From: Anders Logg <[email-masked]>
Date: Wed, 1 Jun 2011 14:29:48 +0200

> periods were followed by two spaces? These days it does look a

ok, let's change it then.

Johannes, can you script it?

--
Anders

---

From: Johannes Ring <[email-masked]>
Date: Wed, 1 Jun 2011 16:55:50 +0200

> Johannes, can you script it?

Yes, but not until tomorrow.

Johannes

---

From: Anders Logg <[email-masked]>
Date: Wed, 1 Jun 2011 17:08:29 +0200

> Yes, but not until tomorrow.

No rush...

--
Anders