Subject: [FEniCS-dev] Project summaries

From: Anders Logg <[email-masked]>
Date: Thu, 28 May 2009 22:42:36 +0200

Dear all,

At the FEniCS'09 workshop in June, we are planning to present a
summary of the status of all the projects. I would therefore like to
ask all projects to send a summary of the most important changes and
milestones since last year, including any pretty pictures you would
like to show.

It would be helpful to get the following information:

  * Project name

  * Project description (one-liner, like on web page)

  * Project members/contributors

  * Important milestones/results

  * Current activities (if any :-)

  * Future goals (if any :-)

It would also be helpful to get this before Friday June 5 so we have
time to prepare the presentation.

Thanks
-- 
Anders

---

From: Robert Kirby <[email-masked]>
Date: Fri, 5 Jun 2009 15:48:13 -0500

> It would be helpful to get the following information:
FIAT

>  * Project description (one-liner, like on web page)
FIAT automates the construction and tabulation of high-order finite bases on
simplicial domains

>  * Project members/contributors

Robert Kirby
Marie Rognes

>  * Important milestones/results

Integration of H(div) & H(curl) elements with FFC
New recurrence relations for orthogonal bases that support automatic
differentiation
Experimentation with symbolic techniques via sympy
Experimental version that supports arbitrary reference cell
geometry/topology

>  * Current activities (if any :-)
I'll call them future goals given that my plate is full

>  * Future goals (if any :-)

Incorporate experimental milestones in a release (the interface will change,
requiring coordination with form compilers)
Include generalized transformations to provide for some more unusual
elements.

I think it's still June 5 in Oslo :)

Rob

---

From: Anders Logg <[email-masked]>
Date: Fri, 5 Jun 2009 23:44:36 +0200

On Fri, Jun 05, 2009 at 03:48:13PM -0500, Robert Kirby wrote:
> Experimental version that supports arbitrary reference cell geometry/topology
>  
> 
> 
> Include generalized transformations to provide for some more unusual elements.
> 

Yes, and Smögen is in the same time zone so you made it in time. :-)

Now I'm just waiting for the summaries for DOLFIN, FErari, FFC, Instant,
Puffin, SyFi, UFC and Viper...

-- 
Anders

---

From: Kent Andre <[email-masked]>
Date: Mon, 08 Jun 2009 12:15:55 +0200

> It would be helpful to get the following information:

Instant 

>   * Project description (one-liner, like on web page)

Instant inlining of C and C++ code in Python

>   * Project members/contributors

Martin Alnæs, Kent-Andre Mardal, Ilmar Wilbers

>   * Important milestones/results

Alnæs has refactored the code. 
Wilbers has written a lot of documentation and added a
new typemap system based on numpy.i  

> _______________________________________________
> FEniCS-dev mailing list
> [email-masked]
> http://www.fenics.org/mailman/listinfo/fenics-dev

---

From: Ilmar Wilbers <[email-masked]>
Date: Mon, 08 Jun 2009 13:18:47 +0200

> new typemap system based on numpy.i  
Alnæs also improved the caching system and added functionality for 
locking files, avoiding problems with race conditions.

---

From: Anders Logg <[email-masked]>
Date: Mon, 8 Jun 2009 13:24:21 +0200

On Mon, Jun 08, 2009 at 01:18:47PM +0200, Ilmar Wilbers wrote:
>> Alnæs has refactored the code. Wilbers has written a lot of 
>> documentation and added a

ok, thanks.

-- 
Anders