Subject: Re: [Fenics] [Branch ~fenics-core/fenics-doc/main] Rev 122: Try to fix error in mixed Poisson demo reported by testing script

From: Marie Rognes <[email-masked]>
Date: Tue, 31 Aug 2010 10:55:28 +0200

On 31. aug. 2010 10:46, [email-masked] wrote:
> ------------------------------------------------------------
> revno: 122
> committer: Anders Logg <[email-masked]>
> branch nick: fenics-doc
> timestamp: Tue 2010-08-31 10:43:34 +0200
> message:
>   Try to fix error in mixed Poisson demo reported by testing script
>   but the script still reports that something is wrong. Any ideas?
>   

Don't touch mixed Poisson ;) I will fix.

--
Marie

---

From: Anders Logg <[email-masked]>
Date: Tue, 31 Aug 2010 10:55:57 +0200

> Don't touch mixed Poisson ;) I will fix.

ok!

--
Anders

---

From: Marie Rognes <[email-masked]>
Date: Tue, 31 Aug 2010 12:11:17 +0200

On 31. aug. 2010 10:46, [email-masked] wrote:
> modified:
>   source/demos/python/pde/mixed-poisson/mixed-poisson.rst
>   source/styleguides/documentationstyleguides.rst
>   

Which error reported by which test script?

Running verify_demo_code_snippets gives me:

    meg@localhost ~/local/src/fenics/fenics-doc/test $ python
    verify_demo_code_snippets.py

    Testing that all code snippets are valid.

      cpp/pde/cahn-hilliard, OK.
      cpp/pde/hyperelasticity, OK.
      cpp/pde/poisson, OK.
      python/pde/cahn-hilliard
    Error:

    code block:
    # Model parameters
    lmbda = 1.0e-02 # surface parameter
    factor = 100 # chemical free energy multiplier
    dt = 5.0e-06 # time step
    theta = 0.5 # time stepping family, e.g. theta=1 -> backward Euler,
    theta=0.5 -> Crank-Nicolson

    source_files:
    ['demo.py']

    in directory: 
    /home/meg/local/src/fenics/fenics-doc/source/demos/python/pde/cahn-hilliard

    Traceback (most recent call last):
      File "verify_demo_code_snippets.py", line 132, in <module>
        verify_blocks(rst_file, source_files, block_source[directory])
      File "verify_demo_code_snippets.py", line 36, in verify_blocks
        if path.splitext(sf)[-1] == source_type])
      File "verify_demo_code_snippets.py", line 109, in block_in_source
        raise RuntimeError("Illegal code block.")
    RuntimeError: Illegal code block.

-- Marie

---

From: Anders Logg <[email-masked]>
Date: Tue, 31 Aug 2010 12:17:41 +0200

On Tue, Aug 31, 2010 at 12:11:17PM +0200, Marie Rognes wrote:
>     theta = 0.5 # time stepping family, e.g. theta=1 -> backward Euler, theta=
>     0.5 -> Crank-Nicolson
>
>     source_files:
>     ['demo.py']
>
>     in directory:  /home/meg/local/src/fenics/fenics-doc/source/demos/python/
>     pde/cahn-hilliard
>

Strange, I got a different error. You had used 'product space' in one
place and 'combined space' in the other. I tried to change it but the
error message was still there.

--
Anders

---

From: Marie Rognes <[email-masked]>
Date: Tue, 31 Aug 2010 12:21:12 +0200

On 31. aug. 2010 12:17, Anders Logg wrote:
> Strange, I got a different error. 

Is that "got" or "get"?

--
Marie

> You had used 'product space' in one

---

From: Anders Logg <[email-masked]>
Date: Tue, 31 Aug 2010 12:24:51 +0200

> > Strange, I got a different error.

Don't know. I'm getting lots of errors from the demo I'm currently
developing so it crashes before then. I'll let you know if it
continues to fail after I have fixed my demo.

--
Anders

---

From: Kristian Ølgaard <[email-masked]>
Date: Tue, 31 Aug 2010 12:26:06 +0200

> On 31. aug. 2010 10:46, [email-masked] wrote:

It's the 'factor' line causing the error, should we delete or keep it?
I can find it anywhere else in the code.

Kristian

> _______________________________________________
> Mailing list: https://launchpad.net/~fenics
> Post to     : [email-masked]
> Unsubscribe : https://launchpad.net/~fenics
> More help   : https://help.launchpad.net/ListHelp
>
>