Subject: [Fenics] Issues

From: Anders Logg <[email-masked]>
Date: Fri, 12 Apr 2013 12:41:51 +0200

Does anyone know how to refer to issues on Bitbucket?

I would expect every issue to have a hashtag or unique number so it
can be referred to in a changeset or changelog.

--
Anders

---

From: Benjamin Kehlet <[email-masked]>
Date: Fri, 12 Apr 2013 13:04:01 +0200

I think it is the number next to the hash symbol in the title of the issue.

You can refer to this id in commit messages and change status of the issues
automatically (if the issue service is enabled in bitbucket). Look here:
https://confluence.atlassian.com/display/BITBUCKET/Markup+for+Comments,+Issues,+and+Commit+Messages

Benjamin

2013/4/12 Anders Logg <[email-masked]>

> _______________________________________________
> Mailing list: https://launchpad.net/~fenics
> Post to     : [email-masked]
> Unsubscribe : https://launchpad.net/~fenics
> More help   : https://help.launchpad.net/ListHelp
>

---

From: Anders Logg <[email-masked]>
Date: Fri, 12 Apr 2013 13:14:13 +0200

ok. So the tag is just #3 for this issue?

https://bitbucket.org/fenics-project/dolfin/issue/3/dirichlet-bc-for-geometric-search-broken

--
Anders

On Fri, Apr 12, 2013 at 01:04:01PM +0200, Benjamin Kehlet wrote:
>    You can refer to this id in commit messages and change status of the
>    issues automatically (if the issue service is enabled in bitbucket).
>    Look here:
>    [1]https://confluence.atlassian.com/display/BITBUCKET/Markup+for+Commen
>    ts,+Issues,+and+Commit+Messages
>    Benjamin
>    2013/4/12 Anders Logg <[2][email-masked]>
>
> Referenser
>    1. https://confluence.atlassian.com/display/BITBUCKET/Markup+for+Comments,+Issues,+and+Commit+Messages
>    2. mailto:[email-masked]
>    3. https://launchpad.net/~fenics
>    4. mailto:[email-masked]
>    5. https://launchpad.net/~fenics
>    6. https://help.launchpad.net/ListHelp

---

From: Benjamin Kehlet <[email-masked]>
Date: Fri, 12 Apr 2013 13:17:52 +0200

> https://bitbucket.org/fenics-project/dolfin/issue/3/dirichlet-bc-for-geometric-search-broken

Yes, I think so.

Benjamin

> >    [1]
> >    1.

---

From: Florian Rathgeber <[email-masked]>
Date: Fri, 12 Apr 2013 16:51:54 +0100

On 12/04/13 12:17, Benjamin Kehlet wrote:
> 
> 2013/4/12 Anders Logg <[email-masked] <mailto:[email-masked]>>
> 

That's correct. Note that issue numbers in launchpad are global i.e.
unique to the platform whereas in BitBucket/GitHub they are local i.e.
unique to the repository. They only append the issue title to optimize
for search engines.

Note that to reference, close etc. issues from commit messages, it's
necessary to enable the issues service:
https://confluence.atlassian.com/display/BITBUCKET/Setting+Up+the+Issues+Service

Florian

>     >    I think it is the number next to the hash symbol in the title
>     of the
>     >    issue.
>     >    2013/4/12 Anders Logg <[2][email-masked] <mailto:[email-masked]>>
>     >
>     >    2. mailto:[email-masked] <mailto:[email-masked]>
>     <mailto:[email-masked]>