Subject: [Fenics] Plan for release of 1.0

From: Anders Logg <[email-masked]>
Date: Mon, 28 Nov 2011 22:38:35 +0100

The following releases have now been made:

  DOLFIN 1.0-rc2
  FFC 1.0-rc1
  UFC 2.0.4

I expect DOLFIN and FFC can be (or are already) ready for
1.0.0 next week. I think the same is true for UFL.

I don't think a release candidate is needed for FIAT so we can just
release 1.0.0 next week together with the other packages. Same goes
for Viper.

My suggestion is to release 1.0.0 next Wednesday Dec 7. The main
concern until then is to test the new releases and review the web
pages and documentation before the release.

Is that ok for everyone?

--
Anders

---

From: Kristian Ølgaard <[email-masked]>
Date: Mon, 28 Nov 2011 23:06:10 +0100

> pages and documentation before the release.

Fine with me.

Kristian

> --
> Anders
>
> _______________________________________________
> Mailing list: https://launchpad.net/~fenics
> Post to     : [email-masked]
> Unsubscribe : https://launchpad.net/~fenics
> More help   : https://help.launchpad.net/ListHelp
>

---

From: Martin Sandve Alnæs <[email-masked]>
Date: Tue, 29 Nov 2011 08:29:53 +0100

Great!

Martin
Den 28. nov. 2011 23.06 skrev "Kristian Ølgaard" <[email-masked]>

---

From: Anders Logg <[email-masked]>
Date: Tue, 29 Nov 2011 11:14:32 +0100

ok! Let's do it.

Note that we need to make the FFC, UFL, UFC, Instant, FIAT releases
early that day so we have time to run the buildbots with all forms
recompiled with the latest 1.0.0 versions before we make the DOLFIN
release.

--
Anders

On Tue, Nov 29, 2011 at 08:29:53AM +0100, Martin Sandve Alnæs wrote:
> Great!
> Martin
> Den 28. nov. 2011 23.06 skrev &quot;Kristian Ølgaard&quot;
> <[email-masked]> følgende:

---

From: Martin Sandve Alnæs <[email-masked]>
Date: Tue, 29 Nov 2011 11:19:17 +0100

Ok. I also suggest we postphone announcing the releases
until they have all been uploaded and we have been able
to download and test the tarballs on some platforms.
Just to be on the safe side.

Martin

On 29 November 2011 11:14, Anders Logg <[email-masked]> wrote:
>>      > The following releases have now been made:
>>      >
>>      >  DOLFIN 1.0-rc2
>>      >  FFC 1.0-rc1
>>      >  UFC 2.0.4
>>      >
>>      > I expect DOLFIN and FFC can be (or are already) ready for
>>      > 1.0.0 next week. I think the same is true for UFL.
>>      >
>>      > I don't think a release candidate is needed for FIAT so we can just
>>      > release 1.0.0 next week together with the other packages. Same goes
>>      > for Viper.
>>      >
>>      > My suggestion is to release 1.0.0 next Wednesday Dec 7. The main
>>      > concern until then is to test the new releases and review the web
>>      > pages and documentation before the release.
>>      >
>>      > Is that ok for everyone?
>>
>>      Fine with me.
>>
>>      Kristian
>>
>>      >
>>      > _______________________________________________
>>      > Mailing list: https://launchpad.net/~fenics
>>      > Post to     : [email-masked]
>>      > Unsubscribe : https://launchpad.net/~fenics
>>      > More help   : https://help.launchpad.net/ListHelp
>>      >
>>

---

From: Anders Logg <[email-masked]>
Date: Tue, 29 Nov 2011 11:26:17 +0100

Yes, that plus Johannes needs to build the binary packages. That takes
some time. Let's just upload the packages but postpone the
announcements.

--
Anders