Subject: [Fenics] [[email-masked]: [Branch ~fenics-core/fenics-doc/main] Rev 128: Consistent naming for demos]

From: Anders Logg <[email-masked]>
Date: Tue, 31 Aug 2010 16:04:31 +0200

"Poisson equation" sounds strange to me. Shouldn't it be either
"Poisson's equation", "The Poisson equation", or "A Poisson equation"?

--
Anders

Subject: [Branch ~fenics-core/fenics-doc/main] Rev 128: Consistent naming for demos
From: [email-masked]
To: Anders Logg <[email-masked]>
Date: Tue, 31 Aug 2010 14:02:20 -0000

------------------------------------------------------------
revno: 128
committer: Garth N. Wells <[email-masked]>
branch nick: fenics-doc
timestamp: Tue 2010-08-31 14:58:53 +0100
message:
  Consistent naming for demos
modified:
  source/demos/pde/mixed-poisson/common.txt
  source/demos/pde/mixed-poisson/cpp/documentation.rst
  source/demos/pde/mixed-poisson/python/documentation.rst
  source/demos/pde/navier-stokes/cpp/documentation.rst
  source/demos/pde/navier-stokes/python/documentation.rst
  source/demos/pde/poisson/cpp/documentation.rst
  source/demos/pde/poisson/python/documentation.rst

--
lp:fenics-doc
https://code.launchpad.net/~fenics-core/fenics-doc/main

You are subscribed to branch lp:fenics-doc.
To unsubscribe from this branch go to https://code.launchpad.net/~fenics-core/fenics-doc/main/+edit-subscription
=== modified file 'source/demos/pde/mixed-poisson/common.txt'
--- source/demos/pde/mixed-poisson/common.txt	2010-08-31 13:48:23 +0000
+++ source/demos/pde/mixed-poisson/common.txt	2010-08-31 13:58:53 +0000
@@ -5,7 +5,7 @@
     sections of the programmer's reference (for class names) are
     needed.
 
-This demo illustrates how to solve Poisson's equation using a mixed
+This demo illustrates how to solve Poisson equation using a mixed
 (two-field) formulation. In particular, it illustrates how to
 
 * Use mixed and non-continuous finite element spaces
@@ -15,7 +15,7 @@
 Equation and problem definition
 -------------------------------
 
-An alternative formulation of Poisson's equation can be formulated by
+An alternative formulation of Poisson equation can be formulated by
 introducing an additional (vector) variable, namely the (negative)
 flux: :math:`\sigma = \nabla u`. The partial differential equations
 then read

=== modified file 'source/demos/pde/mixed-poisson/cpp/documentation.rst'
--- source/demos/pde/mixed-poisson/cpp/documentation.rst	2010-08-31 13:48:23 +0000
+++ source/demos/pde/mixed-poisson/cpp/documentation.rst	2010-08-31 13:58:53 +0000
@@ -2,8 +2,8 @@
 
 .. _demos_cpp_pde_mixed-poisson:
 
-Mixed formulation for Poisson's equation
-========================================
+Mixed formulation for Poisson equation
+======================================
 
 .. include:: ../common.txt

=== modified file 'source/demos/pde/mixed-poisson/python/documentation.rst'
--- source/demos/pde/mixed-poisson/python/documentation.rst	2010-08-31 13:48:23 +0000
+++ source/demos/pde/mixed-poisson/python/documentation.rst	2010-08-31 13:58:53 +0000
@@ -2,8 +2,8 @@
 
 .. _demos_python_pde_mixed-poisson:
 
-Mixed formulation for Poisson's equation
-========================================
+Mixed formulation for Poisson equation
+======================================
 
 This demo is implemented in a single Python file, :download:`demo.py`,
 which contains both the variational forms and the solver.

=== modified file 'source/demos/pde/navier-stokes/cpp/documentation.rst'
--- source/demos/pde/navier-stokes/cpp/documentation.rst	2010-08-31 13:48:23 +0000
+++ source/demos/pde/navier-stokes/cpp/documentation.rst	2010-08-31 13:58:53 +0000
@@ -1,7 +1,7 @@
 .. _demos_cpp_pde_navier_stokes:
 
-The Incompressible Navier-Stokes Equations
-==========================================
+Incompressible Navier-Stokes equations
+======================================
 
 This demo is implemented the C++ source file :download:`main.cpp`.  In
 addition, this program requires the following header files that define

=== modified file 'source/demos/pde/navier-stokes/python/documentation.rst'
--- source/demos/pde/navier-stokes/python/documentation.rst	2010-08-31 13:48:23 +0000
+++ source/demos/pde/navier-stokes/python/documentation.rst	2010-08-31 13:58:53 +0000
@@ -1,7 +1,7 @@
 .. _demos_python_pde_navier_stokes:
 
-The Incompressible Navier-Stokes Equations
-==========================================
+Incompressible Navier-Stokes equations
+======================================
 
 This demo is implemented in a single Python file, :download:`demo.py`,
 which contains both the variational forms and the solver.

=== modified file 'source/demos/pde/poisson/cpp/documentation.rst'
--- source/demos/pde/poisson/cpp/documentation.rst	2010-08-31 13:48:23 +0000
+++ source/demos/pde/poisson/cpp/documentation.rst	2010-08-31 13:58:53 +0000
@@ -3,8 +3,8 @@
 .. _demos_cpp_pde_poisson:

-Poisson's equation
-==================
+Poisson equation
+================
 
 .. include:: ../common.txt

=== modified file 'source/demos/pde/poisson/python/documentation.rst'
--- source/demos/pde/poisson/python/documentation.rst	2010-08-31 13:48:23 +0000
+++ source/demos/pde/poisson/python/documentation.rst	2010-08-31 13:58:53 +0000
@@ -2,8 +2,8 @@
 
 .. _demos_python_pde_poisson:
 
-Poisson's equation
-==================
+Poisson equation
+================
 
 This demo is implemented in a single Python file, :download:`demo.py`,
 which contains both the variational forms and the solver.

---

From: "Garth N. Wells" <[email-masked]>
Date: Tue, 31 Aug 2010 15:07:32 +0100

> "Poisson's equation", "The Poisson equation", or "A Poisson equation"?

"Poisson equation" is commonly used. So is "Poisson's equation", but we
don't use "Stokes'", "Cahn-Hilliard's", "Navier-Stokes'", etc. It's not
"A", because there is only one.

Garth

> --
> Anders
> 
> 
> 
> _______________________________________________
> Mailing list: https://launchpad.net/~fenics
> Post to     : [email-masked]
> Unsubscribe : https://launchpad.net/~fenics
> More help   : https://help.launchpad.net/ListHelp

---

From: Anders Logg <[email-masked]>
Date: Tue, 31 Aug 2010 16:15:06 +0200

On Tue, Aug 31, 2010 at 03:07:32PM +0100, Garth N. Wells wrote:
> "Poisson equation" is commonly used.

I've never seen it and think it looks strange.

> So is "Poisson's equation", but we

I don't use "Navier-Stokes' equations". I write "the Navier-Stokes
equations" to get around that.

--
Anders

---

From: Anders Logg <[email-masked]>
Date: Tue, 31 Aug 2010 21:03:35 +0200

ok. I guess I didn't trust the Australian well enough. :-)

--
Anders

On Tue, Aug 31, 2010 at 11:59:08AM -0700, Ridgway Scott wrote:
> It is a small point of the English language that allows a title to
> be shorter
> than what you would say in a phrase. You would say "now we study
> THE Poisson equation" but the formal title is shorter. For example, I
> think the formal title is University of Chicago, whereas it is The
> University
> of Michigan. Titles can be jarring, such as the Art Institute of Chicago
> (which should instead be the Chicago Institute of Art) or the one I
> created: the Computation Institute (which many people called the
> Computational Institute for a long time).
>
> So Poisson Equation is a fine title, but other terms are equally valid.
>
> Ridg
>
> On Aug 31, 2010, at 7:15 AM, Anders Logg wrote:
>

--
Anders