Subject: [Fenics] [[email-masked]: [Branch ~fenics-web-core/fenics-web/main] Rev 414: Made top level links more descriptive]

From: Anders Logg <[email-masked]>
Date: Fri, 8 Jul 2011 20:11:54 +0200

I changed these to fpo/doc etc for ease of access. We have pub/ so I
thought it natural to also have doc/ and dev/

Which is better? doc/ or documentation/?

--
Anders

Subject: [Branch ~fenics-web-core/fenics-web/main] Rev 414: Made top level links more descriptive
From: [email-masked]
To: Anders Logg <[email-masked]>
Date: Fri, 08 Jul 2011 11:31:27 -0000

------------------------------------------------------------
revno: 414
committer: Harish Narayanan <[email-masked]>
branch nick: fenics-web
timestamp: Fri 2011-07-08 13:29:25 +0200
message:
  Made top level links more descriptive
renamed:
  source/apps/ => source/applications/
  source/dev/ => source/contributing/
  source/doc/ => source/documentation/
modified:
  source/_themes/pylons/layout.html
  source/contributing/contributing_code.rst
  source/index.rst

--
lp:fenics-web
https://code.launchpad.net/~fenics-web-core/fenics-web/main

Your team FEniCS Web Team is subscribed to branch lp:fenics-web.
To unsubscribe from this branch go to https://code.launchpad.net/~fenics-web-core/fenics-web/main/+edit-subscription
=== modified file 'source/_themes/pylons/layout.html'
--- source/_themes/pylons/layout.html	2011-06-26 13:35:10 +0000
+++ source/_themes/pylons/layout.html	2011-07-08 11:29:25 +0000
@@ -16,12 +16,13 @@
   <div id="access">
     <div class="menu">
       <ul>
-	<li class="page_item"><a href="{{ pathto('about/index') }}" title="Find out more about the FEniCS project">About</a></li>
-	<li class="page_item"><a href="{{ pathto('download/index') }}" title="Obtain the FEniCS project">Download</a></li>
-	<li class="page_item"><a href="{{ pathto('doc/index') }}" title="Learn how to use the FEniCS project">Documentation</a></li>
-	<li class="page_item"><a href="{{ pathto('dev/index') }}" title="Learn how to contribute to the FEniCS project">Contributing</a></li>
-	<li class="page_item"><a href="{{ pathto('citing/index') }}" title="Learn how to cite the FEniCS project">Citing</a></li>
-	<li class="page_item"><a href="{{ pathto('support/index') }}" title="Where to go for more help">Support</a></li>
+	<li class="page_item"><a href="/new/about/" title="Find out more about the FEniCS project">About</a></li>
+	<li class="page_item"><a href="/new/download/" title="Obtain the FEniCS project">Download</a></li>
+	<li class="page_item"><a href="/new/documentation/" title="Learn how to use the FEniCS project">Documentation</a></li>
+	<li class="page_item"><a href="/new/applications/" title="Learn how others are using the FEniCS project">Applications</a></li>
+	<li class="page_item"><a href="/new/contributing/" title="Learn how to contribute to the FEniCS project">Contributing</a></li>
+	<li class="page_item"><a href="/new/citing/" title="Learn how to cite the FEniCS project">Citing</a></li>
+	<li class="page_item"><a href="/new/support/" title="Where to go for more help">Support</a></li>
       </ul>
     </div><!-- .menu -->
   </div><!-- #access -->

=== renamed directory 'source/apps' => 'source/applications'
=== renamed directory 'source/dev' => 'source/contributing'
=== modified file 'source/contributing/contributing_code.rst'
--- source/dev/contributing_code.rst	2011-06-29 12:22:24 +0000
+++ source/contributing/contributing_code.rst	2011-07-08 11:29:25 +0000
@@ -31,7 +31,7 @@
 is accompanied by a suitable set of unit tests. You should also review
 the :ref:`recommended coding style <developers_writing_code>`.
 
-.. _copyright_consent
+.. _copyright_consent:
 
 Copyright and licensing consent
 ===============================

=== renamed directory 'source/doc' => 'source/documentation'
=== modified file 'source/index.rst'
--- source/index.rst	2011-06-29 12:56:33 +0000
+++ source/index.rst	2011-07-08 11:29:25 +0000
@@ -6,10 +6,10 @@
     :hidden:
 
     about/index
-    apps/index
+    applications/index
     download/index
-    doc/index
-    dev/index
+    documentation/index
+    contributing/index
     citing/index
     book/index
     support/index

---

From: Harish Narayanan <[email-masked]>
Date: Fri, 08 Jul 2011 22:24:16 +0200

> Which is better? doc/ or documentation/?

I don't know about "better," but I prefer the longer, descriptive
titles. For example, I like how the following sound:

http://fenicsproject.org/documentation/tutorial/
http://fenicsproject.org/contributing/

as opposed to,

http://fenicsproject.org/doc/tutorial/
http://fenicsproject.org/dev/

respectively. Firstly, because they are clearer. Secondly, there might
be other ways to contribute that can't be encompassed in /dev/.

Harish

---

From: Anders Logg <[email-masked]>
Date: Sat, 9 Jul 2011 00:15:11 +0200

> be other ways to contribute that can't be encompassed in /dev/.

How about some Apache aliases so one can type /doc and end up at
/documentation?

--
Anders

---

From: Harish Narayanan <[email-masked]>
Date: Sat, 09 Jul 2011 07:12:28 +0200

> How about some Apache aliases so one can type /doc and end up at

I will do that. But in general, for Google juice and other niceness
reasons, I think it is better to have one canonical URL and stick to it.

On that note, I am thinking of redirecting www.fpo and to fpo. Right
now, both are legitimate means of accessing the site.

Harish