Subject: [Fenics] Documentation style, refereces to classes

From: Marie Rognes <[email-masked]>
Date: Wed, 01 Sep 2010 19:52:01 +0200

What is the difference between e.g:

    ``Expression``

and

    py:class:`Expression`

? Or, more precisely, when should which be used?

--
Marie

---

From: Anders Logg <[email-masked]>
Date: Wed, 1 Sep 2010 20:00:16 +0200

> ? Or, more precisely, when should which be used?

My first answer would be that we should always use
py:class`Expression` in the text.

--
Anders

---

From: Marie Rognes <[email-masked]>
Date: Wed, 01 Sep 2010 20:01:13 +0200

> py:class`Expression` in the text.

Is there a second answer?

Is there something similar for functions?

--
Marie

---

From: Anders Logg <[email-masked]>
Date: Wed, 1 Sep 2010 20:07:13 +0200

> Is there a second answer?

Not yet, but my first answer may turn out not to be practical. I think
I tried to use it everywhere in the NS demo.

> Is there something similar for functions?

I don't know. We can fix that later.

--
Anders

---

From: Kristian Ølgaard <[email-masked]>
Date: Wed, 1 Sep 2010 23:12:16 +0200

>> Is there a second answer?

I used ``Mesh`` in the styleguides because I was using the Mesh class
as vehicle to describe the procedure to document the two interfaces.
When one could not distinguish between the two I used ``Mesh`` else
the appropriate :py:class: or :cpp:class: reference.

>> Is there something similar for functions?

Sure, :py:func:`bar`, but remember if bar is a method of class Foo
(defined in module cpp) do :py:func:`cpp.Foo.bar`

Kristian

> _______________________________________________
> Mailing list: https://launchpad.net/~fenics
> Post to     : [email-masked]
> Unsubscribe : https://launchpad.net/~fenics
> More help   : https://help.launchpad.net/ListHelp
>