Subject: [Fenics] Ubuntu release schedule

From: Johannes Ring <[email-masked]>
Date: Tue, 15 Jun 2010 12:13:49 +0200

Hi,

This is just a reminder about the release schedule [1] for the next
Ubuntu release, code name Maverick Meerkat. There are two important
dates when it comes to getting the latest FEniCS packages into this
version of Ubuntu: June 24th (DebianImportFreeze) and August 12th
(FeatureFreeze). There will be no automatic imports from Debian after
DebianImportFreeze but it will be possible to request manual imports
up until FeatureFreeze. This means that we should try to get out any
new releases in good time before August 12th if we want them to be
included in the upcoming Ubuntu.

[1] https://wiki.ubuntu.com/MaverickReleaseSchedule

Johannes

---

From: Anders Logg <[email-masked]>
Date: Tue, 15 Jun 2010 13:27:57 +0200

Thanks,

I think we should try to get a release of DOLFIN 0.9.8 ready before
June 24th. There have been quite a few improvements since 0.9.7.
We also need releases of at least FFC (0.9.3) and UFL (0.5.2).

--
Anders

On Tue, Jun 15, 2010 at 12:13:49PM +0200, Johannes Ring wrote:
> _______________________________________________
> Mailing list: https://launchpad.net/~fenics
> Post to     : [email-masked]
> Unsubscribe : https://launchpad.net/~fenics
> More help   : https://help.launchpad.net/ListHelp

---

From: Anders Logg <[email-masked]>
Date: Wed, 16 Jun 2010 11:27:54 +0200

When should the deadline be for making the new releases?

Is it too later if we finish by June 23rd?

--
Anders

---

From: Johannes Ring <[email-masked]>
Date: Wed, 16 Jun 2010 11:49:32 +0200

> Is it too later if we finish by June 23rd?

Well, it might be too late for automatic imports from Debian to
Ubuntu, but I can request manual imports later. It worked out fine the
last time. So June 23rd sounds good for me.

Johannes

> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v1.4.10 (GNU/Linux)
>
> iEYEARECAAYFAkwYmRoACgkQTuwUCDsYZdEoawCfXJqhSOvaieGNtK7+UJhdMO3U
> LwUAn3jFNI4E7aRJYFks0OFYeptX3yzD
> =KHhL
> -----END PGP SIGNATURE-----
>
>

---

From: Anders Logg <[email-masked]>
Date: Mon, 21 Jun 2010 13:53:45 +0200

> last time. So June 23rd sounds good for me.

ok, let's aim for 23rd (Wednesday this week).

Anything that we need to fix before the release?

The buildbot fails with this message when running the extrapolation demo:

  run-time error: auxlib::solve_od(): need LAPACK

Is there something that needs to be installed on the buildbot?

--
Anders

---

From: "Garth N. Wells" <[email-masked]>
Date: Mon, 21 Jun 2010 22:39:44 -0400

On 21/06/10 07:53, Anders Logg wrote:
>> On Wed, Jun 16, 2010 at 11:27 AM, Anders Logg<[email-masked]>  wrote:

There are quite a few bugs on Launchpad that need to be looked at.

Garth

---

From: Anders Logg <[email-masked]>
Date: Mon, 28 Jun 2010 16:02:28 +0200

> There are quite a few bugs on Launchpad that need to be looked at.

I've had some more discussions with Garth and Johannes.

The plan is now to make the release on or before Thursday:

  DOLFIN 0.9.8
  FFC 0.9.3
  UFL 0.5.3
  FIAT 0.9.2
  Viper 0.4.6

Anything else?

Please help out fixing bugs/blueprints.

--
Anders

---

From: Anders Logg <[email-masked]>
Date: Tue, 29 Jun 2010 20:39:33 +0200

> Please help out fixing bugs/blueprints.

Looks to me like everything is ready for release.

Let's keep tomorrow open for last minute fixes and then we make a
release on Thursday.

--
Anders

---

From: "Garth N. Wells" <[email-masked]>
Date: Tue, 29 Jun 2010 23:18:38 +0100

> Please help out fixing bugs/blueprints.

A FFC bug has popped up today which needs to be fixed before a release. 
Hopefully Kristian can take a look,

Garth

---

From: Kristian Oelgaard <[email-masked]>
Date: Wed, 30 Jun 2010 00:55:47 +0200

> Hopefully Kristian can take a look,

The fix should be simple, do you have an example form that I can look
at? I'll fix it tomorrow, morning.

Kristian

---

From: Johannes Ring <[email-masked]>
Date: Wed, 30 Jun 2010 09:21:34 +0200

> Let's keep tomorrow open for last minute fixes and then we make a

The buildbot also reports problems with demo/mesh/refinement/python:

  Traceback (most recent call last):
    File "demo.py", line 31, in <module>
      mesh = coarsen(mesh, cell_markers)
  NameError: name 'coarsen' is not defined

This happened in changeset 4820:

  http://bazaar.launchpad.net/~dolfin-core/dolfin/main/revision/4820

Johannes

---

From: Anders Logg <[email-masked]>
Date: Wed, 30 Jun 2010 09:26:51 +0200

>   http://bazaar.launchpad.net/~dolfin-core/dolfin/main/revision/4820

I don't remember removing the coarsening function but it looks like
it's been removed. Did anyone else remove it? The quality of the
coarsening is not very good so perhaps it should be removed until we
improve it, but I would prefer keeping it an issuing a warning about
the bad quality.

--
Anders

---

From: Kristian Oelgaard <[email-masked]>
Date: Wed, 30 Jun 2010 12:03:26 +0200

> Hopefully Kristian can take a look,

This bug has been fixed, unless anything else pops up I'd say FFC is
ready for release.

Kristian

---

From: Anders Logg <[email-masked]>
Date: Wed, 30 Jun 2010 17:32:39 +0200

> This bug has been fixed, unless anything else pops up I'd say FFC is

Everything else is also ready as far as I can tell.

Let's make the release tomorrow.

--
Anders