Subject: [Fenics] fenics-web application gallery patch

From: Kristian Ølgaard <[email-masked]>
Date: Mon, 22 Aug 2011 23:52:17 +0200

Hi,

Attached is a patch which adds FEniCS Plasticity to the application gallery.

BTW, is it possible to build the web pages such that paths to images
etc. will appear as:
'/home/oelgaard/fenics-web/build/html/_static/images/foo.png' instead of just
'/_static/images/foo.png'
which will make it easier to test?

Kristian
# Bazaar merge directive format 2 (Bazaar 0.90)
# revision_id: [email-masked]
# target_branch: bzr+ssh://bazaar.launchpad.net/%2Bbranch/fenics-web/
# testament_sha1: bc7d3b6f7c2040daf27f853e4c2fbe768759c5c4
# timestamp: 2011-08-22 23:40:03 +0200
# base_revision_id: [email-masked]
# 
# Begin patch
=== added file 'source/_static/images/fenics_plasticity.png'
Binary files source/_static/images/fenics_plasticity.png	1970-01-01 00:00:00 +0000 and source/_static/images/fenics_plasticity.png	2011-08-22 21:37:36 +0000 differ
=== modified file 'source/applications/index.inc'
--- source/applications/index.inc	2011-08-18 13:18:06 +0000
+++ source/applications/index.inc	2011-08-22 21:37:36 +0000
@@ -45,6 +45,24 @@
 
         </div><!-- #front-block-2 .front-block .block-->
 
+      	<div id="front-block-3" class="front-block block">
+
+	  <h3>FEniCS Plasticity &mdash; A plasticity library for FEniCS</h3>
+          <img alt='' src='/_static/images/fenics_plasticity.png'
+          class='avatar avatar-84 photo' height='84' width='84' />
+
+	  <p>FEniCS Plasticity is a library that implements the Von Mises and
+       Drucker-Prager plasticity models using FEniCS software.
+       However, the structure of the library should be general enough to also
+       allow other models to be implemented with little effort.
+    </p>
+
+          <p><a href="https://launchpad.net/fenics-plasticity"
+          rel="nofollow">Visit the project&#8217;s web site to learn more
+          &raquo;</a></p>
+
+        </div><!-- #front-block-3 .front-block .block-->
+
       </div><!-- #sub-feature -->
     </div><!-- #content -->
   </div><!-- #container .feature -->

# Begin bundle

---

From: Harish Narayanan <[email-masked]>
Date: Tue, 23 Aug 2011 08:39:49 +0200

> which will make it easier to test?

Hi, I've applied this patch. Thanks!

I am not sure it is easy to change the paths that way. If you want to
test it easily, try starting a local Apache server loading the
fenics-web/build/html folder. This works well for me.

Harish

---

From: Kristian Ølgaard <[email-masked]>
Date: Wed, 24 Aug 2011 14:49:49 +0200

> fenics-web/build/html folder. This works well for me.

OK, I got this working too by creating a symbolic link /var/www ->
/home/oelgaard/fenics-web/build/html/.
Don't know if this is the best solution, I couldn't figure out how to
set the 'DocumentRoot'
variable in the configuration file.

Kristian

---

From: Anders Logg <[email-masked]>
Date: Wed, 24 Aug 2011 14:56:13 +0200

> /home/oelgaard/fenics-web/build/html/.

That looks like a good solution. We use something similar on the web
server.

--
Anders

> _______________________________________________
> Mailing list: https://launchpad.net/~fenics
> Post to     : [email-masked]
> Unsubscribe : https://launchpad.net/~fenics
> More help   : https://help.launchpad.net/ListHelp