Subject: [FEniCS-dev] incompressible elasticity?

From: Chong Luo <[email-masked]>
Date: Thu, 20 Mar 2008 09:12:28 -0700 (PDT)

Hi,

I saw a nice example of linear elasticity demo in dolfin. 
I am trying to use FEniCS to solve incompressible
non-linear elasticity problems.

For incompressible neo-Hookean materials, the stress is
T = 2*C10*(Id + grad(u)) - p*(Id + grad(u))^{-T},
where the last "^{-T}" means transpose of inverse.

Is it possible to specify an inverse of a matrix in the .form file?

Thank you!

Best,
Chong Luo 

      ___________________________________________________________ 
雅虎邮箱传递新年祝福，个性贺卡送亲朋！ 
http://cn.mail.yahoo.com/gc/index.html?entry=5&souce=mail_mailletter_tagline

---

From: Chong Luo <[email-masked]>
Date: Thu, 20 Mar 2008 14:53:43 -0700 (PDT)

Ah, please forgive my ignorance. 

Now I understand that I have to linearize the problem,
before using FEniCS to solve it.

Sorry about my ignorance and have a nice day!

Best,
Chong Luo
----- Original Message ----
From: Chong Luo <[email-masked]>
To: [email-masked]; [email-masked]
Cc: [email-masked]
Sent: Thursday, March 20, 2008 11:12:28 AM
Subject: incompressible elasticity?

Hi,

Thank you!

Best,
Chong Luo 

      雅虎邮箱传递新年祝福，个性贺卡送亲朋！ 

      ____________________________________________________________________________________
Looking for last minute shopping deals?  
Find them fast with Yahoo! Search.  http://tools.search.yahoo.com/newsearch/category.php?category=shopping