Subject: Re: [Fenics] [Branch ~fenics-core/fenics-doc/main] Rev 222: Added Hans-Petter's FEniCS tutorial (in Python).

From: "Marie E. Rognes" <[email-masked]>
Date: Wed, 02 Feb 2011 22:33:20 +0100

On 02/02/2011 03:45 PM, [email-masked] wrote:
> ------------------------------------------------------------
> revno: 222
> committer: Kristian B. Ølgaard<[email-masked]>
> branch nick: fenics-doc
> timestamp: Wed 2011-02-02 15:43:19 +0100
> message:
>    Added Hans-Petter's FEniCS tutorial (in Python).
> added:
>    source/doc/tutorial/python/eps/
>    source/doc/tutorial/python/eps/Poisson2D_Dvc_contour1.png
>    source/doc/tutorial/python/eps/Poisson2D_Dvc_flux_x.png
>    source/doc/tutorial/python/eps/Poisson2D_Dvc_mesh1.png
>    source/doc/tutorial/python/eps/Poisson2D_Dvc_surf1.png
>    source/doc/tutorial/python/eps/daynight.png
>    source/doc/tutorial/python/eps/hollow_cylinder.png
>    source/doc/tutorial/python/eps/membrane_waxis.png
>    source/doc/tutorial/python/tu2.rst
>

Pressing any of the links in the html version of the tutorial gives

     "The requested URL /doc/tutorial/python/tu2.html was not found on 
this server."

Intended?

--
Marie

---

From: Kristian Ølgaard <[email-masked]>
Date: Wed, 2 Feb 2011 23:46:50 +0100

On 2 February 2011 22:33, Marie E. Rognes <[email-masked]> wrote:
> committer: Kristian B. Ølgaard <[email-masked]>
> branch nick: fenics-doc
>     "The requested URL /doc/tutorial/python/tu2.html was not found on this
> server."
>
> Intended?

No, don't know what's going on. It works fine here when I tested it
locally and I think I added all files. Does it work for you if you
build it yourself?

Kristian

> --
> Marie
>
> _______________________________________________
> Mailing list: https://launchpad.net/~fenics
> Post to     : [email-masked]
> Unsubscribe : https://launchpad.net/~fenics
> More help   : https://help.launchpad.net/ListHelp
>
>

---

From: "Marie E. Rognes" <[email-masked]>
Date: Wed, 02 Feb 2011 23:51:53 +0100

On 02/02/2011 11:46 PM, Kristian Ølgaard wrote:
> On 2 February 2011 22:33, Marie E. Rognes<[email-masked]>  wrote:

Will try.

--
Marie

---

From: "Marie E. Rognes" <[email-masked]>
Date: Thu, 03 Feb 2011 00:37:37 +0100

On 02/02/2011 11:51 PM, Marie E. Rognes wrote:
>>> On 02/02/2011 03:45 PM,[email-masked]  wrote:
>>>

So far 'make all' is producing a barely countable number of errors. Will 
try again tomorrow.

--
Marie

---

From: Johannes Ring <[email-masked]>
Date: Thu, 3 Feb 2011 09:33:03 +0100

On Thu, Feb 3, 2011 at 12:37 AM, Marie E. Rognes <[email-masked]> wrote:
> So far 'make all' is producing a barely countable number of errors. Will try
> again tomorrow.

I tried to build it manually on fenicsporject.org and I got this error:

writing output... [ 99%] doc/tutorial/python/tu2
Exception occurred:
  File "/home/fenics-doc/local/lib/python2.6/site-packages/Pygments-1.0-py2.6.egg/pygments/lexers/__init__.py",
line 83, in get_lexer_by_name
    raise ClassNotFound('no lexer for alias %r found' % _alias)
ClassNotFound: no lexer for alias u'console' found
The full traceback has been saved in /tmp/sphinx-err-ga9VUR.log, if
you want to report the issue to the developers.
Please also report this if it was a user error, so that a better error
message can be provided next time.
Either send bugs to the mailing list at
<http://groups.google.com/group/sphinx-dev/>,
or report them in the tracker at
<http://bitbucket.org/birkenfeld/sphinx/issues/>. Thanks!
make: *** [html] Error 1

Any idea what lexer is needed?

Johannes

Contents of /tmp/sphinx-err-ga9VUR.log:

# Sphinx version: 1.0.3
# Docutils version: 0.5 release
# Jinja2 version: 2.5.2
Traceback (most recent call last):
  File "/home/fenics-doc/local/lib/python2.6/site-packages/Sphinx-1.0.3-py2.6.e\
gg/sphinx/cmdline.py", line 173, in main
    app.build(force_all, filenames)
  File "/home/fenics-doc/local/lib/python2.6/site-packages/Sphinx-1.0.3-py2.6.e\
gg/sphinx/application.py", line 207, in build
    self.builder.build_update()
  File "/home/fenics-doc/local/lib/python2.6/site-packages/Sphinx-1.0.3-py2.6.e\
gg/sphinx/builders/__init__.py", line 198, in build_update
    'out of date' % len(to_build))
  File "/home/fenics-doc/local/lib/python2.6/site-packages/Sphinx-1.0.3-py2.6.e\
gg/sphinx/builders/__init__.py", line 254, in build
    self.write(docnames, list(updated_docnames), method)
  File "/home/fenics-doc/local/lib/python2.6/site-packages/Sphinx-1.0.3-py2.6.e\
gg/sphinx/builders/__init__.py", line 293, in write
    self.write_doc(docname, doctree)
  File "/home/fenics-doc/local/lib/python2.6/site-packages/Sphinx-1.0.3-py2.6.e\
gg/sphinx/builders/html.py", line 399, in write_doc
    self.docwriter.write(doctree, destination)
  File "/home/fenics-doc/local/lib/python2.6/site-packages/docutils-0.5-py2.6.e\
gg/docutils/writers/__init__.py", line 76, in write
    self.translate()
  File "/home/fenics-doc/local/lib/python2.6/site-packages/Sphinx-1.0.3-py2.6.e\
gg/sphinx/writers/html.py", line 38, in translate
    self.document.walkabout(visitor)
  File "/home/fenics-doc/local/lib/python2.6/site-packages/docutils-0.5-py2.6.e\
gg/docutils/nodes.py", line 176, in walkabout
    if child.walkabout(visitor):
  File "/home/fenics-doc/local/lib/python2.6/site-packages/docutils-0.5-py2.6.e\
gg/docutils/nodes.py", line 176, in walkabout
    if child.walkabout(visitor):
  File "/home/fenics-doc/local/lib/python2.6/site-packages/docutils-0.5-py2.6.e\
gg/docutils/nodes.py", line 176, in walkabout
    if child.walkabout(visitor):
  File "/home/fenics-doc/local/lib/python2.6/site-packages/docutils-0.5-py2.6.e\
gg/docutils/nodes.py", line 168, in walkabout
    visitor.dispatch_visit(self)
  File "/home/fenics-doc/local/lib/python2.6/site-packages/docutils-0.5-py2.6.e\
gg/docutils/nodes.py", line 1535, in dispatch_visit
    return method(node)
  File "/home/fenics-doc/local/lib/python2.6/site-packages/Sphinx-1.0.3-py2.6.e\
gg/sphinx/writers/html.py", line 525, in visit_literal_block
    HTMLTranslator.visit_literal_block(self, node)
  File "/home/fenics-doc/local/lib/python2.6/site-packages/Sphinx-1.0.3-py2.6.e\
gg/sphinx/writers/html.py", line 236, in visit_literal_block
    lang, linenos)
  File "/home/fenics-doc/local/lib/python2.6/site-packages/Sphinx-1.0.3-py2.6.e\
gg/sphinx/highlighting.py", line 207, in highlight_block
    lexer = lexers[lang] = get_lexer_by_name(lang)
  File "/home/fenics-doc/local/lib/python2.6/site-packages/Pygments-1.0-py2.6.e\
gg/pygments/lexers/__init__.py", line 83, in get_lexer_by_name
    raise ClassNotFound('no lexer for alias %r found' % _alias)
ClassNotFound: no lexer for alias u'console' found

---

From: Kristian Ølgaard <[email-masked]>
Date: Thu, 3 Feb 2011 11:11:44 +0100

> # Docutils version: 0.5 release

I have:

# Sphinx version: 1.0.5
# Docutils version: 0.6 release
# Jinja2 version: 2.5.2

and it seems to work fine.

Kristian

---

From: Johannes Ring <[email-masked]>
Date: Thu, 3 Feb 2011 11:14:05 +0100

> and it seems to work fine.

I installed the latest Sphinx (1.0.7) and then it worked fine.

Johannes

---

From: Kristian Ølgaard <[email-masked]>
Date: Thu, 3 Feb 2011 11:25:59 +0100

> I installed the latest Sphinx (1.0.7) and then it worked fine.

OK, good.

Kristian

---

From: "Marie E. Rognes" <[email-masked]>
Date: Thu, 03 Feb 2011 17:35:54 +0100

> locally and I think I added all files. Does it work for you if you

Yes, it works when I build it myself.

Anyone knows what is going on on the server?

--
Marie

---

From: "Garth N. Wells" <[email-masked]>
Date: Thu, 03 Feb 2011 16:40:05 +0000

> Anyone knows what is going on on the server?

I think I added a README file somewhere with instructions on updating
the server.

Garth

---

From: Johannes Ring <[email-masked]>
Date: Thu, 3 Feb 2011 17:52:21 +0100

> I think I added a README file somewhere with instructions on updating

This is not necessary to do manually. We have cron jobs that updates
the documentation quite frequently (triggered by a push to
lp:fenics-doc).

Marie: Are your sure you have refreshed the web page properly? The
tutorial works fine for me.

Johannes

---

From: "Marie E. Rognes" <[email-masked]>
Date: Thu, 3 Feb 2011 18:44:58 +0100

> tutorial works fine for me.

I don't think I even thought of checking... Problem resolved then :) 

Marie

---

From: Anders Logg <[email-masked]>
Date: Fri, 4 Feb 2011 00:59:38 +0100

> I don't think I even thought of checking... Problem resolved then :)

The tutorial looks pretty good on the web page!

--
Anders