Subject: [fenics-dev] FEniCS, Sieve and AMR

From: "tomtzigt" <[email-masked]>
Date: Tue, 15 Nov 2005 16:06:20 -0500

What is the roadmap of the functionality integration between FEniCS and
Sieve? I am looking at using CUBIT for some industrial strength meshing but
need some help understanding the impact of that choice in the context of AMR
within FEniCS.

Theo

---

From: Matthew Knepley <[email-masked]>
Date: Tue, 15 Nov 2005 15:18:42 -0600

"tomtzigt" <[email-masked]> writes:

> :o="urn:schemas-microsoft-com:office:office" xmlns:w="urn:schemas-microsoft-com:office:word" xmlns="http://www.w3.org/TR/REC-html40">
>
> What is the roadmap of the functionality integration between FEniCS and Sieve? I am looking at using CUBIT for some industrial strength meshing but need some help understanding the impact of that choice in the context of AMR
> within FEniCS.:p>

  The idea is to represent meshes in a way that allows us to easily construct algebraic structures
over them. Any mesh generator could be used. The downside is really in the flexibility/optimization
tradeoff. Currently, our implementation would be slower/bigger than some custom structured AMR like
Chombo (or at least shuold be :) However, our approach to this will be to generate custom code for
EACH mesh that is output and compiled, much like the FFC philosophy of generating code for EACH
weak form. Does this help?

     Matt
-- 
"Failure has a thousand explanations. Success doesn't need one" -- Sir Alec Guiness

---

From: Anders Logg <[email-masked]>
Date: Tue, 15 Nov 2005 15:21:25 -0600

For DOLFIN, it will take some work to port our current data structures
and functionality (including adaptive mesh refinement) to Sieve, see

    http://www.fenics.org/pipermail/dolfin-dev/2005-November/001513.html

but this should be independent of which mesh generator is used to
create the mesh you feed to DOLFIN. We can have support for a range of
formats, including meshes from CUBIT (if someone wants to write the
code and maintain it).

/Anders

On Tue, Nov 15, 2005 at 04:06:20PM -0500, tomtzigt wrote:
> 
> What is the roadmap of the functionality integration between FEniCS and Sieve?
> I am looking at using CUBIT for some industrial strength meshing but need some
> help understanding the impact of that choice in the context of AMR within
> FEniCS.
>  
> Theo

> _______________________________________________
> fenics-dev mailing list
> [email-masked]
> http://www.fenics.org/cgi-bin/mailman/listinfo/fenics-dev

-- 
Anders Logg
Research Assistant Professor
Toyota Technological Institute at Chicago
http://www.tti-c.org/logg/