Subject: [Fenics] Web server

From: Anders Logg <[email-masked]>
Date: Thu, 28 Jun 2012 22:59:59 +0200

The web server has been down since ca lunch today due to some broken
cable. I have no information on when it will be back up again.

It seems that the current host (Simula IT services) is somewhat
unreliable so I'm investigating the possibility of moving the server
to an external host.

I've had good experience with http://www.scorpiondata.com/ in the
past. Comments and input on other options are welcome.

--
Anders

---

From: Anders Logg <[email-masked]>
Date: Fri, 29 Jun 2012 09:41:24 +0200

> past. Comments and input on other options are welcome.

Server is still down... Johannes has put up a backup page here:

  http://folk.uio.no/johannr/fenicsproject/

--
Anders

---

From: Harish Narayanan <[email-masked]>
Date: Fri, 29 Jun 2012 10:49:20 +0200

> past. Comments and input on other options are welcome.

Since the site is just a collection of static pages, the details of the
server end don't matter too much. If you've experienced decent uptime
with scorpiondata and it you can check[1] that it a site on it loads
reasonably quickly from different places--outside Sweden :)--then it
will work for our needs.

Harish

[1] Google Analytics suggests that fenicsproject.org has received
maximum traffic from the following countries over the past few months.

United States
Germany
United Kingdom
France
Norway

Perhaps we can make sure the host we pick isn't too slow in these
places. This can be checked using a site like http://loads.in/

---

From: Anders Logg <[email-masked]>
Date: Fri, 29 Jun 2012 11:23:45 +0200

> places. This can be checked using a site like http://loads.in/

Thanks! I'll check this.

I've contacted scorpiondata with some specs to get a quote.

--
Anders

---

From: Johan Jansson <[email-masked]>
Date: Fri, 29 Jun 2012 12:03:02 +0200

On Thu, Jun 28, 2012 at 10:59 PM, Anders Logg <[email-masked]> wrote:
> _______________________________________________
> Mailing list: https://launchpad.net/~fenics
> Post to     : [email-masked]
> Unsubscribe : https://launchpad.net/~fenics
> More help   : https://help.launchpad.net/ListHelp

Hi,

>From a web search I found two testimonials which don't look so good
for Scorpion Data:

http://www.johaneckman.se/tag/sheimo-scorpion-data/
http://translate.google.com/translate?sl=sv&tl=en&js=n&prev=_t&hl=en&ie=UTF-8&layout=2&eotf=1&u=http%3A%2F%2Fwww.johaneckman.se%2Ftag%2Fsheimo-scorpion-data%2F
http://www.henrikcarlsson.se/2010/07/12/nytt-webbhotell-ny-doman/
http://translate.google.com/translate?sl=sv&tl=en&js=n&prev=_t&hl=en&ie=UTF-8&layout=2&eotf=1&u=http%3A%2F%2Fwww.henrikcarlsson.se%2F2010%2F07%2F12%2Fnytt-webbhotell-ny-doman%2F

They recommend Binero instead, which I've also seen get good scores in
tests. They won the Internetworld test for web hotels 2009 and 2010:

http://internetworld.idg.se/2.1006/1.309237/sveriges-basta-webbhotell---fjolarets-favorit-slar-till-igen
http://translate.google.com/translate?sl=sv&tl=en&js=n&prev=_t&hl=en&ie=UTF-8&layout=2&eotf=1&u=http%3A%2F%2Finternetworld.idg.se%2F2.1006%2F1.309237%2Fsveriges-basta-webbhotell---fjolarets-favorit-slar-till-igen

Maybe that would be a good candidate?

Best,
  Johan

---

From: Anders Logg <[email-masked]>
Date: Fri, 29 Jun 2012 12:46:57 +0200

> Maybe that would be a good candidate?

Perhaps, but I'm also finding some bad reviews for Binero:

  http://www.rejta.se/omdome/103517/Binero+AB
  http://translate.google.se/translate?sl=en&tl=sv&js=n&prev=_t&hl=sv&ie=UTF-8&layout=2&eotf=1&u=http%3A%2F%2Fwww.rejta.se%2Fomdome%2F103517%2FBinero%2BAB&act=url

(and many good reviews).

A priority will be response time and willingness to arrange billing
according to our needs (paying in advance for an extended period). I
had a very bad experience with Bahnhof billing (where the domains are
registered) last year and moved the registration to nameisp.se (who
were very responsive).

I emailed scorpionshops this morning and they were very
responsive. I'll see how it goes. My suggestion is to try to move the
server there quickly (as a test). If all goes well and we find the
service is both flexible and reliable, we can pay for an extended
period.

--
Anders

---

From: Anders Logg <[email-masked]>
Date: Fri, 29 Jun 2012 16:21:03 +0200

New server is up and running:

  http://82.118.24.73/

The documentation is currently missing but I will rebuild and
upload. Please report any issues.

DNS has not yet been moved but I will do so as soon as possible.

I'm very happy with the service so far. It took just 1 hour from the
point I asked for it until I could log in to the new (virtual)
machine. :-)

--
Anders

---

From: Florian Rathgeber <[email-masked]>
Date: Sat, 30 Jun 2012 00:56:15 +0100

Just throwing in the idea: Static pages can be hosted free of charge
on GitHub, via github pages (http://pages.github.com/). The sites are
served from the Rackspace cloud, which promises high reliability (they
boast 99.63% uptime over the last 365 days) and low latency.

Since the FEniCS site is powered by sphinx, deployment is really
straightforward. There is even a python module for deploying sphinx on
GitHub pages: http://pypi.python.org/pypi/github-tools/

Let me know if you'd consider this option and I'll be happy to assist.

Florian

On 29/06/12 11:46, Anders Logg wrote:
>>> The web server has been down since ca lunch today due to some
>>> broken cable. I have no information on when it will be back up
>>> again.
>>> 
>>> It seems that the current host (Simula IT services) is
>>> somewhat unreliable so I'm investigating the possibility of
>>> moving the server to an external host.
>>> 
>>> I've had good experience with http://www.scorpiondata.com/ in
>>> the past. Comments and input on other options are welcome.
>>> 
>>> 
>>> _______________________________________________ Mailing list:
>>> https://launchpad.net/~fenics Post to     :
>>> [email-masked] Unsubscribe :
>>> https://launchpad.net/~fenics More help   :
>>> https://help.launchpad.net/ListHelp
>> 
>> 
>> Hi,
>> 
>> From a web search I found two testimonials which don't look so
>> good for Scorpion Data:
>> 
> A priority will be response time and willingness to arrange
> billing according to our needs (paying in advance for an extended
> period). I had a very bad experience with Bahnhof billing (where
> the domains are registered) last year and moved the registration to
> nameisp.se (who were very responsive).
> 
> I emailed scorpionshops this morning and they were very responsive.
> I'll see how it goes. My suggestion is to try to move the server
> there quickly (as a test). If all goes well and we find the service
> is both flexible and reliable, we can pay for an extended period.
> 
> -- Anders
> 
> _______________________________________________ Mailing list:
> https://launchpad.net/~fenics Post to     :
> [email-masked] Unsubscribe :
> https://launchpad.net/~fenics More help   :
> https://help.launchpad.net/ListHelp
>

---

From: Harish Narayanan <[email-masked]>
Date: Sat, 30 Jun 2012 06:51:34 +0200

This is almost the ideal solution, except that fpo needs a little bit of
server side functionality to dynamically generate some of its content.

Harish

---

From: Anders Logg <[email-masked]>
Date: Sat, 30 Jun 2012 10:14:55 +0200

Can we map the web address?

In any case, the new server is booked, installed and up and running
but this is something to consider next time.

--
Anders

---

From: Florian Rathgeber <[email-masked]>
Date: Sat, 30 Jun 2012 10:07:13 +0100

> Can we map the web address?

Yes, you can set the CNAME record to map to any domain. I'm doing that
for a project and it works flawlessly. It does not support https though.

> In any case, the new server is booked, installed and up and
> running but this is something to consider next time.

When is "next time"? How long is the contract for the server?

>> This is almost the ideal solution, except that fpo needs a little
>> bit of server side functionality to dynamically generate some of
>> its content.

Which parts of the site are dynamic?

Florian

>>> Just throwing in the idea: Static pages can be hosted free of
>>> charge on GitHub, via github pages (http://pages.github.com/).
>>> The sites are served from the Rackspace cloud, which promises
>>> high reliability (they boast 99.63% uptime over the last 365
>>> days) and low latency.
>>> 
>>> Since the FEniCS site is powered by sphinx, deployment is
>>> really straightforward. There is even a python module for
>>> deploying sphinx on GitHub pages:
>>> http://pypi.python.org/pypi/github-tools/
>>> 
>>>>>> The web server has been down since ca lunch today due to
>>>>>> some broken cable. I have no information on when it will
>>>>>> be back up again.
>>>>>> 
>>>>>> somewhat unreliable so I'm investigating the possibility
>>>>>> of moving the server to an external host.
>>>>>> 
>>>>>> I've had good experience with
>>>>>> http://www.scorpiondata.com/ in the past. Comments and
>>>>>> input on other options are welcome.
>>>>>> 
>>>>>> 
>>>>>> _______________________________________________ Mailing
>>>>>> list: https://launchpad.net/~fenics Post to     : 
>>>>> From a web search I found two testimonials which don't look
>>>>> so good for Scorpion Data:
>>>>> 
(and many good reviews).
>>>> billing according to our needs (paying in advance for an
>>>> extended period). I had a very bad experience with Bahnhof
>>>> billing (where the domains are registered) last year and
>>>> moved the registration to nameisp.se (who were very
>>>> responsive).
>>> 
>>>> responsive. I'll see how it goes. My suggestion is to try to
>>>> move the server there quickly (as a test). If all goes well
>>>> and we find the service is both flexible and reliable, we can
>>>> pay for an extended period.
>>> 
>>>> -- Anders
>>> 
>>>> _______________________________________________ Mailing
>>>> list: https://launchpad.net/~fenics Post to     :

---

From: Anders Logg <[email-masked]>
Date: Sat, 30 Jun 2012 12:25:46 +0200

On Sat, Jun 30, 2012 at 10:07:13AM +0100, Florian Rathgeber wrote:
> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
>

ok.

> When is "next time"? How long is the contract for the server?

I don't know. Next time we set up a new domain, the server goes down,
we're not happy with the service etc...

> Which parts of the site are dynamic?

There's a javascript for the slideshow and we run some cronjobs to
generate stuff, rebuild documentation, fetch news + it's practical to
have a server at our disposal when we need it.

--
Anders

> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v1.4.11 (GNU/Linux)
>
> iEYEARECAAYFAk/uwcAACgkQ8Z6llsctAxZtMwCfYik5bQeZNmgLdvxet9FZZ+ET
> XhwAn3In4Ga0PDnQz3EvV1PTZQmSWLQq
> =VctN
> -----END PGP SIGNATURE-----
>

---

From: Florian Rathgeber <[email-masked]>
Date: Sat, 30 Jun 2012 11:44:05 +0100

On 30/06/12 11:25, Anders Logg wrote:
> Yes, you can set the CNAME record to map to any domain. I'm doing
> that for a project and it works flawlessly. It does not support
> https though.
> 
>> ok.
> 
>> I don't know. Next time we set up a new domain, the server goes
>> down, we're not happy with the service etc...
> 
>>>> -- Anders
>>>> 
>>>>> This is almost the ideal solution, except that fpo needs a
>>>>> little bit of server side functionality to dynamically
>>>>> generate some of its content.
> 
>> There's a javascript for the slideshow and we run some cronjobs
>> to generate stuff, rebuild documentation, fetch news + it's
>> practical to have a server at our disposal when we need it.

JavaScript is not an issue (unless you want it to run server-side -
not the case for a slide show). Cron jobs are not possible, they would
need to run on some other machine before deployment to github pages
(which is easily scriptable). No doubt it's useful to have a dedicated
server.

Anyway, as I said I'm happy to assist if you ever want to revisit the
issue.

Florian

>>>>>> Just throwing in the idea: Static pages can be hosted
>>>>>> free of charge on GitHub, via github pages
>>>>>> (http://pages.github.com/). The sites are served from the
>>>>>> Rackspace cloud, which promises high reliability (they
>>>>>> Since the FEniCS site is powered by sphinx, deployment
>>>>>> is really straightforward. There is even a python module
>>>>>> for deploying sphinx on GitHub pages: 
>>>>>>>>> The web server has been down since ca lunch today
>>>>>>>>> due to some broken cable. I have no information on
>>>>>>>>> when it will be back up again.
>>>>>>>>> 
>>>>>>>>> It seems that the current host (Simula IT services)
>>>>>>>>> is somewhat unreliable so I'm investigating the
>>>>>>>>> possibility of moving the server to an external
>>>>>>>>> host.
>>>>>>>>> 
>>>>>>>>> http://www.scorpiondata.com/ in the past. Comments
>>>>>>>>> and input on other options are welcome.
>>>>>>>>> 
>>>>>>>>> 
>>>>>>>>> Mailing list: https://launchpad.net/~fenics Post to
>>>>>>>>> : [email-masked] Unsubscribe : 
>>>>>>>> From a web search I found two testimonials which
>>>>>>>> don't look so good for Scorpion Data:
>>>>>>>> 
(and many good reviews).
>>>>>> 
>>>>>>> A priority will be response time and willingness to
>>>>>>> arrange billing according to our needs (paying in
>>>>>>> advance for an extended period). I had a very bad
>>>>>>> experience with Bahnhof billing (where the domains are
>>>>>>> registered) last year and moved the registration to
>>>>>>> I emailed scorpionshops this morning and they were
>>>>>>> very responsive. I'll see how it goes. My suggestion is
>>>>>>> to try to move the server there quickly (as a test). If
>>>>>>> all goes well and we find the service is both flexible
>>>>>>> and reliable, we can pay for an extended period.
>>>>>> 
>>>>>>> -- Anders
>>>>>> 
>>>>>>> Mailing list: https://launchpad.net/~fenics Post to
>>>>>>> : [email-masked] Unsubscribe :

---

From: Anders Logg <[email-masked]>
Date: Sat, 30 Jun 2012 19:45:42 +0200

> Anyway, as I said I'm happy to assist if you ever want to revisit the

Good to know! Thanks.

--
Anders

> iEYEARECAAYFAk/u2HUACgkQ8Z6llsctAxaSdwCg2V+cTcU4JdWb1JEMcQlLxFU1
> DiwAn2O/OAkoQ/hPCDqRrjRXNUKvgnmx
> =G0Vg

---

From: Andre Massing <[email-masked]>
Date: Sun, 1 Jul 2012 07:45:16 +0530

> upload. Please report any issues.

Great to see that the fenicsproject website is back! Works flawlessly
(from India) even with domain name.
Has the documentation been rebuilt/up-loaded?

Cheers,
Andre

---

From: Anders Logg <[email-masked]>
Date: Sun, 1 Jul 2012 10:01:33 +0200

> (from India) even with domain name.

Great!

> Has the documentation been rebuilt/up-loaded?

Yes, it should be. Please check if anything is missing.

--
Anders

---

From: Anders Logg <[email-masked]>
Date: Sun, 1 Jul 2012 10:03:04 +0200

> Has the documentation been rebuilt/up-loaded?

And good luck with the tutorial!

Let's hope you can attract 1.2 billion new FEniCS users. :-)

--
Anders

---

From: Andre Massing <[email-masked]>
Date: Sun, 1 Jul 2012 13:39:04 +0530

> Yes, it should be. Please check if anything is missing.

That is strange, I only get a 404 page not found when I try to access
the api documentation via
http://82.118.24.73/documentation/dolfin/dev/python/
(same using the domain name and for the c++ documentation)

--
Andre

---

From: Andre Massing <[email-masked]>
Date: Sun, 1 Jul 2012 13:41:58 +0530

> And good luck with the tutorial!

Thanks, I am looking forward to it...

> Let's hope you can attract 1.2 billion new FEniCS users. :-)

Well, let's start with the approximately 40 students and try to make
them spreading the word :)
--
Andre

---

From: Anders Logg <[email-masked]>
Date: Sun, 1 Jul 2012 11:50:14 +0200

> (same using the domain name and for the c++ documentation)

I have only updated the 1.0 version, which I assume is what you will
use at the tutorial. All the links from the main documentation page
seem to be working (as they point to the 1.0 versions), for example

http://fenicsproject.org/documentation/dolfin/1.0.0/python/quick_reference.html

--
Anders

---

From: Andre Massing <[email-masked]>
Date: Sun, 1 Jul 2012 15:39:29 +0530

> http://fenicsproject.org/documentation/dolfin/1.0.0/python/quick_reference.html

Yes, that is exactly  what I looked for. Thanks for the link!
--
Andre