Subject: Re: [Fenics] [Fenics-web] [Branch ~fenics-web-core/fenics-web/main] Rev 413: Added download button to revision control

From: Anders Logg <[email-masked]>
Date: Fri, 8 Jul 2011 20:39:43 +0200

On Fri, Jul 08, 2011 at 08:23:59PM +0200, Marie E. Rognes wrote:
> On 07/08/11 20:19, Anders Logg wrote:
> >On Fri, Jul 08, 2011 at 08:13:32PM +0200, Marie E. Rognes wrote:
> >>On 07/08/11 20:10, Anders Logg wrote:
> >>>On Fri, Jul 08, 2011 at 12:59:28PM +0200, Marie E. Rognes wrote:
> >>>>On 07/08/11 12:56, [email-masked] wrote:
> >>>>>------------------------------------------------------------
> >>>>>revno: 413
> >>>>>committer: Harish Narayanan<[email-masked]>
> >>>>>branch nick: fenics-web
> >>>>>timestamp: Fri 2011-07-08 12:54:33 +0200
> >>>>>message:
> >>>>>   Added download button to revision control
> >>>>>added:
> >>>>>   source/_themes/pylons/static/download-button.png
> >>>>>
> >>>>That is one big download button :-)
> >>>It's what I've always dreamed of. Notice the clever downward pointing
> >>>triangle.
> >>>
> >>>
> >>Unfortunately, it seems to have gone missing again, so I'm
> >>momentarily unable to fully appreciate its advanced features.
> >It's in the repository:
> >
> >   source/_themes/pylons/static/download-button.png
> >
>
> Ah, of course :-) (Just curious: why was it removed from the page?

I don't know about that. Ask Harish.

> Also, why not Linux/Mac/Windows?)

It's just example text. It should be replaced by text generated by the
platform sniffer. For example, it could say

  FEniCS 1.0.3 for Ubuntu 11.10

if that is the appropriate choice.

If the sniffer cannot detect the platform, I suggest the general test
should be

  FEniCS x.y.z for GNU/Linux, Mac or Windows

--
Anders

---

From: Harish Narayanan <[email-masked]>
Date: Fri, 08 Jul 2011 22:12:45 +0200

> I don't know about that. Ask Harish.

I removed it because it didn't fit right with the current placeholder
content. I will add it back when it fits in nicely.
>   FEniCS x.y.z for GNU/Linux, Mac or Windows

Good idea. Will attempt this.

Harish