Subject: Re: [Fenics] [Dolfin] docstring.i bug

From: "Garth N. Wells" <[email-masked]>
Date: Thu, 02 Sep 2010 23:40:06 +0100

I've commented out this change:

http://bazaar.launchpad.net/~dolfin-core/dolfin/main/revision/5082#dolfin/swig/generate.py

in dolfin/swig/generate.py to get things compiling again. Could someone 
have a look at it?

Garth

On 02/09/10 23:15, Garth N. Wells wrote:
> There is a problem in the file docstring.i file that leads to a build
> failure. The C++ function
>
> KrylovSolver(std::string solver_type = "default",
> std::string pc_type = "default");
>
> is being turned into
>
> __init__(self, string solver_type = "default",
> string pc_type = "default") -> KrylovSolver
> __init__(self, string solver_type = "default") -> KrylovSolver
> __init__(self) -> KrylovSolver
>
> in docstring.i, which is obviously ambiguous with the default arguments.
>
> Garth
>
> _______________________________________________
> Mailing list: https://launchpad.net/~dolfin
> Post to : [email-masked]
> Unsubscribe : https://launchpad.net/~dolfin
> More help : https://help.launchpad.net/ListHelp

---

From: Johan Hake <[email-masked]>
Date: Thu, 2 Sep 2010 15:51:49 -0700

It is an easy fix.

We need to escape the '"'. You pushed your revert a second before I could push 
the fix...

Will see to it.

Johan