Subject: [Fenics] Announcing cbc.block

From: Joachim Berdal Haga <[email-masked]>
Date: Fri, 1 Apr 2011 23:43:19 +0200

Today seems like a good day to announce the cbc.block project -- Block
operators for DOLFIN (in Python). Some of you attended my presentation
earlier this year and know this work already (although it is now in a
much better state). For everyone else, a short description:

- Block operators may be defined from standard DOLFIN matrices and vectors
    A = assemble(...); B = assemble(...); # etc
    AA = block_mat([[A,B], [C,D]])

- Preconditioners, inverses, and inner solvers are supported
    AAprec = AA.scheme('gauss-seidel', inverse=ML)

- A good selection of iterative solvers
    AAinv = SymmLQ(AA, precond=AAprec)
    x = AAinv*b

- Matrix algebra is supported both through composition of operators...
    S = C*ILU(A)*B-D
    Spre = ConjGrad(S)

  ...and through explicit matrix calculation via PyTrilinos
    S = C*InvDiag(A)*B-D
    Spre = ML(collapse(S))

- And lots of demos! Have a look: http://launchpad.net/cbc.block

(I will be on holiday the next weeks and may be slow to answer questions.)

-- 
-j.

---

From: Kent-Andre Mardal <[email-masked]>
Date: Sat, 2 Apr 2011 10:25:10 +0200

Superb!

Kent

On 1 April 2011 23:43, Joachim Berdal Haga <[email-masked]> wrote:

> _______________________________________________
> Mailing list: https://launchpad.net/~fenics
> Post to     : [email-masked]
> Unsubscribe : https://launchpad.net/~fenics
> More help   : https://help.launchpad.net/ListHelp
>

---

From: Kent-Andre Mardal <[email-masked]>
Date: Sat, 2 Apr 2011 10:40:39 +0200

Kan du si ifra til Andy slik at han får oppdatert
https://launchpad.net/fenics-group

Kent

---

From: Anders Logg <[email-masked]>
Date: Mon, 4 Apr 2011 12:19:22 +0200

> (I will be on holiday the next weeks and may be slow to answer questions.)

Very nice!

--
Anders