Subject: [Fenics] [[email-masked]: [Branch ~fenics-web-core/fenics-web/main] Rev 742: Add UFL pre-print]

From: Anders Logg <[email-masked]>
Date: Thu, 3 Jan 2013 20:38:00 +0100

Bibitems should be autogenerated from within source/_static/bibliography

--
Anders

Subject: [Branch ~fenics-web-core/fenics-web/main] Rev 742: Add UFL pre-print
From: [email-masked]
To: Anders Logg <[email-masked]>
Date: Thu, 03 Jan 2013 19:00:22 -0000

------------------------------------------------------------
revno: 742
committer: Garth N. Wells <[email-masked]>
branch nick: fenics-web
timestamp: Thu 2013-01-03 18:59:14 +0000
message:
  Add UFL pre-print
modified:
  source/citing/fenics.rst_
  source/citing/index.rst

--
lp:fenics-web
https://code.launchpad.net/~fenics-web-core/fenics-web/main

Your team FEniCS Web Team is subscribed to branch lp:fenics-web.
To unsubscribe from this branch go to https://code.launchpad.net/~fenics-web-core/fenics-web/main/+edit-subscription
=== modified file 'source/citing/fenics.rst_'
--- source/citing/fenics.rst_	2012-06-20 10:12:48 +0000
+++ source/citing/fenics.rst_	2013-01-03 18:59:14 +0000
@@ -116,6 +116,11 @@
   34(1),
   pp. C24-C41.
 
+* **M. S. Alnæs, A. Logg, K. B. Ølgaard, M. E. Rognes, G. N. Wells (2012)**.
+  *Unified Form Language: A domain-specific language for weak formulations
+  of partial differential equations*.
+  [`arXiv:1211.4047 <http://arxiv.org/abs/1211.4047>`_]
+
 Books
 =====
 
@@ -124,6 +129,7 @@
   Springer,
   [`doi:10.1007/978-3-642-23099-8 <http://dx.doi.org/10.1007/978-3-642-23099-8>`_].
 
+
 Chapters in Books
 =================

=== modified file 'source/citing/index.rst'
--- source/citing/index.rst	2012-06-20 10:12:48 +0000
+++ source/citing/index.rst	2013-01-03 18:59:14 +0000
@@ -19,7 +19,7 @@
 
 * **A. Logg, K.-A. Mardal, G. N. Wells et al. (2012)**.
   *Automated Solution of Differential Equations by the Finite Element Method*,
-  Springer,
+  Springer.
   [`doi:10.1007/978-3-642-23099-8 <http://dx.doi.org/10.1007/978-3-642-23099-8>`_].
 
 DOLFIN
@@ -28,9 +28,9 @@
 * **A. Logg and G. N. Wells (2010)**.
   *DOLFIN: Automated Finite Element Computing*,
   ACM Transactions on Mathematical Software,
-  37(2),
-  [`doi:10.1145/1731022.1731030 <http://dx.doi.org/10.1145/1731022.1731030>`_],
-  [`arXiv:1103.6248 <http://arxiv.org/abs/1103.6248>`_].
+  37(2).
+  [`doi:10.1145/1731022.1731030 <http://dx.doi.org/10.1145/1731022.1731030>`_]
+  [`arXiv:1103.6248 <http://arxiv.org/abs/1103.6248>`_]
 
 * **A. Logg, G. N. Wells and J. Hake (2012)**.
   *DOLFIN: a C++/Python Finite Element Library*,
@@ -44,9 +44,9 @@
 * **R. C. Kirby and A. Logg (2006)**.
   *A Compiler for Variational Forms*,
   ACM Transactions on Mathematical Software,
-  32(3),
-  [`doi:10.1145/1163641.1163644 <http://dx.doi.org/10.1145/1163641.1163644>`_],
-  [`arXiv:1112.0402 <http://arxiv.org/abs/1112.0402>`_].
+  32(3).
+  [`doi:10.1145/1163641.1163644 <http://dx.doi.org/10.1145/1163641.1163644>`_]
+  [`arXiv:1112.0402 <http://arxiv.org/abs/1112.0402>`_]
 
 * **A. Logg, K. B. Ølgaard, M. E. Rognes and G. N. Wells (2012)**.
   *FFC: the FEniCS Form Compiler*,
@@ -57,9 +57,9 @@
 * **K. B. Ølgaard and G. N. Wells (2010)**.
   *Optimisations for Quadrature Representations of Finite Element Tensors Through Automated Code Generation*,
   ACM Transactions on Mathematical Software,
-  37,
-  [`doi:10.1145/1644001.1644009 <http://dx.doi.org/10.1145/1644001.1644009>`_],
-  [`arXiv:1104.0199 <http://arxiv.org/abs/1104.0199>`_].
+  37.
+  [`doi:10.1145/1644001.1644009 <http://dx.doi.org/10.1145/1644001.1644009>`_]
+  [`arXiv:1104.0199 <http://arxiv.org/abs/1104.0199>`_]
 
 FIAT
 ----
@@ -68,8 +68,8 @@
   *Algorithm 839: FIAT, a New Paradigm for Computing Finite Element Basis Functions*,
   ACM Transactions on Mathematical Software,
   30(4),
-  pp. 502-516,
-  [`doi:10.1145/1039813.1039820 <http://dx.doi.org/10.1145/1039813.1039820>`_].
+  pp. 502-516.
+  [`doi:10.1145/1039813.1039820 <http://dx.doi.org/10.1145/1039813.1039820>`_]
 
 * **R. C. Kirby (2012)**.
   *FIAT: Numerical Construction of Finite Element Basis Functions,*,
@@ -84,21 +84,30 @@
   *Unified Framework for Finite Element Assembly*,
   International Journal of Computational Science and Engineering,
   4(4),
-  pp. 231-244,
-  [`doi:10.1504/IJCSE.2009.029160 <http://dx.doi.org/10.1504/IJCSE.2009.029160>`_].
+  pp. 231-244.
+  [`doi:10.1504/IJCSE.2009.029160 <http://dx.doi.org/10.1504/IJCSE.2009.029160>`_]
 
 * **M. S. Alnæs, A. Logg and K.-A. Mardal (2012)**.
   *UFC: a Finite Element Code Generation Interface*,
-  Automated Solution of Differential Equations by the Finite Element Method, Volume 84 of Lecture Notes in Computational Science and Engineering,
+  Automated Solution of Differential Equations by the Finite Element
+  Method, Volume 84 of Lecture Notes in Computational Science and
+  Engineering,
   Springer,
   Chapter 16.
 
 UFL
 ---
 
+* **M. S. Alnæs, A. Logg, K. B. Ølgaard, M. E. Rognes, G. N. Wells (2012)**.
+  *Unified Form Language: A domain-specific language for weak formulations
+  of partial differential equations*.
+  [`arXiv:1211.4047 <http://arxiv.org/abs/1211.4047>`_]
+
 * **M. S. Alnæs (2012)**.
   *UFL: a Finite Element Form Language*,
-  Automated Solution of Differential Equations by the Finite Element Method, Volume 84 of Lecture Notes in Computational Science and Engineering,
+  Automated Solution of Differential Equations by the Finite Element
+  Method, Volume 84 of Lecture Notes in Computational Science and
+  Engineering,
   Springer,
   Chapter 17.
 
@@ -108,8 +117,8 @@
 * **M. S. Alnæs and K.-A. Mardal (2010)**.
   *On the Efficiency of Symbolic Computations Combined With Code Generation for Finite Element Methods*,
   ACM Transactions on Mathematical Software,
-  37(1),
-  [`doi:10.1145/1644001.1644007 <http://dx.doi.org/10.1145/1644001.1644007>`_].
+  37(1).
+  [`doi:10.1145/1644001.1644007 <http://dx.doi.org/10.1145/1644001.1644007>`_]
 
 * **M. S. Alnæs and K.-A. Mardal (2010)**.
   *SyFi and SFC: Symbolic Finite Elements and Form Compilation*,

---

From: "Garth N. Wells" <[email-masked]>
Date: Thu, 3 Jan 2013 19:49:06 +0000

> Bibitems should be autogenerated from within source/_static/bibliography

A README or comment in the generated file would have been helpful.

Garth

> --
> Anders
>
>
> ---------- Forwarded message ----------
> Cc:
> _______________________________________________
> Mailing list: https://launchpad.net/~fenics
> Post to     : [email-masked]
> Unsubscribe : https://launchpad.net/~fenics
> More help   : https://help.launchpad.net/ListHelp
>