Subject: [Fenics] Question Installation Example not running

From: Martin Hediger <[email-masked]>
Date: Mon, 11 Jul 2011 17:28:55 +0200

Dear List
I'm new to FE methods and I hope to learn about FE methods through 
FEniCS. I posted this question on the FEniCS answers page, but I guess 
that was the wrong place since I have not received any feedback. I hope 
I'll get some help here, because I'm rather unsure about what the 
problem could be.
I installed the FEniCS binary on my MacBook Pro running under MacOS X 
10.6.3 as described in the installation instructions.
Installation seems successful, at least i can open the fenics terminal.
So I 'cd' into

$ 
/Applications/FEniCS.app/Contents/Resources/share/dolfin/demo/pde/poisson/python

and hit

$ python demo_poisson.py

This is what I get:

Traceback (most recent call last):
   File "demo_poisson.py", line 37, in <module>
     from dolfin import *
   File 
"/Applications/FEniCS.app/Contents/Resources/lib/python2.6/site-packages/dolfin/__init__.py", 
line 13, in <module>
     from dolfin.cppimports import *
   File 
"/Applications/FEniCS.app/Contents/Resources/lib/python2.6/site-packages/dolfin/cppimports.py", 
line 4, in <module>
     import dolfin.cpp as cpp
   File 
"/Applications/FEniCS.app/Contents/Resources/lib/python2.6/site-packages/dolfin/cpp.py", 
line 28, in <module>
     _cpp = swig_import_helper()
   File 
"/Applications/FEniCS.app/Contents/Resources/lib/python2.6/site-packages/dolfin/cpp.py", 
line 24, in swig_import_helper
     _mod = imp.load_module('_cpp', fp, pathname, description)
ImportError: 
dlopen(/Applications/FEniCS.app/Contents/Resources/lib/python2.6/site-packages/dolfin/_cpp.so, 
2): no suitable image found. Did find:
  /Applications/FEniCS.app/Contents/Resources/lib/python2.6/site-packages/dolfin/_cpp.so: mach-o, but wrong architecture

Any help would be very appreciated. I though before I start screwing up 
a clean installation, I just ask for help because it might be a minor 
thing to fix.
Kind regards and thank you for the great work.
Martin

---

From: Martin Hediger <[email-masked]>
Date: Tue, 12 Jul 2011 09:15:16 +0200

Hi Bo,
Thanks for the feedback. I just tried it. I start the FEniCS shell, cd 
into the
/Applications/FEniCS.app/Contents/Resources/share/dolfin
directory and hit
$ source dolfin.conf
Then I run the same comand as below to try to run the demo_poisson.py 
example. I still get the same error.
What could this be? As I understand, I dont require to install other 
things seperately, everything should come with the FEniCS package, right?

Martin

On 11.07.11 21:57, Bo Yang wrote:
> Hi Martin, --- Did you find the dolfin.conf file and source it? Like
>
> $ source  dolfin.conf
>
> --- Bo
>
> On Mon, Jul 11, 2011 at 10:28 AM, Martin Hediger <[email-masked] 
> <mailto:[email-masked]>> wrote:
>
>     Dear List
>     FEniCS. I posted this question on the FEniCS answers page, but I
>     guess that was the wrong place since I have not received any
>     feedback. I hope I'll get some help here, because I'm rather
>     unsure about what the problem could be.
>     I installed the FEniCS binary on my MacBook Pro running under
>     MacOS X 10.6.3 as described in the installation instructions.
>     Any help would be very appreciated. I though before I start
>     screwing up a clean installation, I just ask for help because it
>     might be a minor thing to fix.
>     _______________________________________________
>     Mailing list: https://launchpad.net/~fenics
>     <https://launchpad.net/%7Efenics>
>     Post to     : [email-masked]
>     <mailto:[email-masked]>
>     Unsubscribe : https://launchpad.net/~fenics
>     <https://launchpad.net/%7Efenics>
>     More help   : https://help.launchpad.net/ListHelp
>
>