Subject: [Fenics] [[email-masked]: [Branch ~fenics-core/fenics-doc/1.0] Rev 287: Started fixing the news reader.]

From: Anders Logg <[email-masked]>
Date: Mon, 23 May 2011 20:28:48 +0200

The plan is to make it the default branch at the time of the release
of 1.0.

--
Anders

Subject: [Branch ~fenics-core/fenics-doc/1.0] Rev 287: Started fixing the news reader.
From: [email-masked]
To: Anders Logg <[email-masked]>
Date: Mon, 23 May 2011 18:20:39 -0000

------------------------------------------------------------
revno: 287
committer: Harish Narayanan <[email-masked]>
branch nick: fenics-doc
timestamp: Mon 2011-05-23 20:16:53 +0200
message:
  Started fixing the news reader.
  
  (Someone should make 1.0 the default branch.)
added:
  utils/newsfetcher/cache/
modified:
  .bzrignore
  scripts/fetch_news
  source/newsfeed.inc
  utils/newsfetcher/sources.ini

--
lp:~fenics-core/fenics-doc/1.0
https://code.launchpad.net/~fenics-core/fenics-doc/1.0

You are subscribed to branch lp:~fenics-core/fenics-doc/1.0.
To unsubscribe from this branch go to https://code.launchpad.net/~fenics-core/fenics-doc/1.0/+edit-subscription
=== modified file '.bzrignore'
--- .bzrignore	2010-11-30 19:14:30 +0000
+++ .bzrignore	2011-05-23 18:16:53 +0000
@@ -1,1 +1,5 @@
 build
+utils/newsfetcher/cache/*
+utils/newsfetcher/output/*
+*.tmplc
+

=== modified file 'scripts/fetch_news'
--- scripts/fetch_news	2011-05-04 18:16:45 +0000
+++ scripts/fetch_news	2011-05-23 18:16:53 +0000
@@ -13,7 +13,7 @@
 # Modified by Anders Logg, 2011.
 
 # Fetch the news
-cd utils/newsfetcher
+cd ../utils/newsfetcher
 python planet.py sources.ini
 
 # Clean up the resulting output

=== modified file 'source/newsfeed.inc'
--- source/newsfeed.inc	2011-05-04 18:16:45 +0000
+++ source/newsfeed.inc	2011-05-23 18:16:53 +0000
@@ -2,146 +2,58 @@

 <div class="news-item">
-<div class="title"><a href="https://launchpad.net/unicorn/+announcement/8253">: apps: Unicorn HPC 0.1.2</a></div>
-<div class="author"></div>
-<div class="date">April 29, 2011 10:07 PM</div>
-<div class="content"><p>A new version of Unicorn has been released. This release fixes various bugs and portability issues.</p></div>
-</div>
-
-
-<div class="news-item">
-<div class="title"><a href="https://launchpad.net/dorsal/+announcement/7870">: dorsal: Dorsal 0.8.2 Released!</a></div>
-<div class="author"></div>
-<div class="date">February 28, 2011 02:48 PM</div>
-<div class="content"><p>This is a bug-fix release that makes sure all the packages are up-to-date.</p></div>
-</div>
-
-
-<div class="news-item">
-<div class="title"><a href="https://launchpad.net/dolfin/+announcement/7847">: dolfin: DOLFIN 0.9.10</a></div>
-<div class="author"></div>
-<div class="date">February 23, 2011 09:26 PM</div>
-<div class="content"><p>A new version of DOLFIN has been released. This release adds a large number of improvements and bug fixes, most notably improved parallel scaling and experimental support for multi-core computing.</p></div>
-</div>
-
-
-<div class="news-item">
-<div class="title"><a href="https://launchpad.net/instant/+announcement/7846">: instant: Instant 0.9.9</a></div>
-<div class="author"></div>
-<div class="date">February 23, 2011 09:07 PM</div>
-<div class="content"><p>A new version of Instant has been released. This version brings speed improvements to JIT compilation.</p></div>
-</div>
-
-
-<div class="news-item">
-<div class="title"><a href="https://launchpad.net/fenics-viper/+announcement/7845">: viper: Viper 0.4.7</a></div>
-<div class="author"></div>
-<div class="date">February 23, 2011 08:41 PM</div>
-<div class="content"><p>A new version of Viper has been released. This version contains a number of small fixes/improvements.</p></div>
-</div>
-
-
-<div class="news-item">
-<div class="title"><a href="https://launchpad.net/ufl/+announcement/7844">: ufl: UFL 0.9.0</a></div>
-<div class="author"></div>
-<div class="date">February 23, 2011 08:33 PM</div>
-<div class="content"><p>A new version of UFL has been released. This release fixes some minor bugs.</p></div>
-</div>
-
-
-<div class="news-item">
-<div class="title"><a href="https://launchpad.net/ffc/+announcement/7842">: ffc: FFC 0.9.9</a></div>
-<div class="author"></div>
-<div class="date">February 23, 2011 07:42 PM</div>
-<div class="content"><p>A new version of FFC has been released. This version adds support for UFC 2.0 and plotting of elements.</p></div>
-</div>
-
-
-<div class="news-item">
-<div class="title"><a href="https://launchpad.net/ufc/+announcement/7841">: ufc: UFC 2.0.0</a></div>
-<div class="author"></div>
-<div class="date">February 23, 2011 06:33 PM</div>
-<div class="content"><p>A new version of UFC has been released. This version adds new functionality to the UFC interface and makes some minor modifications to the existing UFC interface.</p></div>
-</div>
-
-
-<div class="news-item">
-<div class="title"><a href="https://launchpad.net/unicorn/+announcement/7703">: apps: Unicorn HPC 0.1.1</a></div>
-<div class="author"></div>
-<div class="date">February 04, 2011 07:36 AM</div>
-<div class="content"><p>A new version of Unicorn has been released. This release adds support for parallel elastic smoothing, adaptive projection and fixes various bugs and portability issues. It also adds support for the new Cray XE6 platform.</p></div>
-</div>
-
-
-<div class="news-item">
-<div class="title"><a href="https://launchpad.net/fenics/+announcement/7535">: fenics: Windows installer now available</a></div>
-<div class="author"></div>
-<div class="date">January 07, 2011 03:08 PM</div>
-<div class="content"><p>A binary installer for Windows users is now available for download from the installation page at <a href="http://www.fenicsproject.org" rel="nofollow">http://&lt;wbr&gt;&lt;/wbr&gt;www.fenicsproje&lt;wbr&gt;&lt;/wbr&gt;ct.org</a>. It includes everything necessary to run FEniCS on Windows and runs on XP, Vista, and on Windows 7.</p></div>
-</div>
-
-
-<div class="news-item">
-<div class="title"><a href="https://launchpad.net/unicorn/+announcement/8253">apps: Unicorn HPC 0.1.2</a></div>
-<div class="author"></div>
-<div class="date">April 29, 2011 10:07 PM</div>
-<div class="content"><p>A new version of Unicorn has been released. This release fixes various bugs and portability issues.</p></div>
-</div>
-
-
-<div class="news-item">
-<div class="title"><a href="https://launchpad.net/dorsal/+announcement/7870">dorsal: Dorsal 0.8.2 Released!</a></div>
-<div class="author"></div>
-<div class="date">February 28, 2011 02:48 PM</div>
-<div class="content"><p>This is a bug-fix release that makes sure all the packages are up-to-date.</p></div>
-</div>
-
-
-<div class="news-item">
-<div class="title"><a href="https://launchpad.net/dolfin/+announcement/7847">dolfin: DOLFIN 0.9.10</a></div>
-<div class="author"></div>
-<div class="date">February 23, 2011 09:26 PM</div>
-<div class="content"><p>A new version of DOLFIN has been released. This release adds a large number of improvements and bug fixes, most notably improved parallel scaling and experimental support for multi-core computing.</p></div>
-</div>
-
-
-<div class="news-item">
-<div class="title"><a href="https://launchpad.net/instant/+announcement/7846">instant: Instant 0.9.9</a></div>
-<div class="author"></div>
-<div class="date">February 23, 2011 09:07 PM</div>
-<div class="content"><p>A new version of Instant has been released. This version brings speed improvements to JIT compilation.</p></div>
-</div>
-
-
-<div class="news-item">
-<div class="title"><a href="https://launchpad.net/fenics-viper/+announcement/7845">viper: Viper 0.4.7</a></div>
-<div class="author"></div>
-<div class="date">February 23, 2011 08:41 PM</div>
-<div class="content"><p>A new version of Viper has been released. This version contains a number of small fixes/improvements.</p></div>
-</div>
-
-
-<div class="news-item">
-<div class="title"><a href="https://launchpad.net/ufl/+announcement/7844">ufl: UFL 0.9.0</a></div>
-<div class="author"></div>
-<div class="date">February 23, 2011 08:33 PM</div>
-<div class="content"><p>A new version of UFL has been released. This release fixes some minor bugs.</p></div>
-</div>
-
-
-<div class="news-item">
-<div class="title"><a href="https://launchpad.net/ffc/+announcement/7842">ffc: FFC 0.9.9</a></div>
-<div class="author"></div>
-<div class="date">February 23, 2011 07:42 PM</div>
-<div class="content"><p>A new version of FFC has been released. This version adds support for UFC 2.0 and plotting of elements.</p></div>
-</div>
-
-
-<div class="news-item">
-<div class="title"><a href="https://launchpad.net/ufc/+announcement/7841">ufc: UFC 2.0.0</a></div>
-<div class="author"></div>
-<div class="date">February 23, 2011 06:33 PM</div>
-<div class="content"><p>A new version of UFC has been released. This version adds new functionality to the UFC interface and makes some minor modifications to the existing UFC interface.</p></div>
+<div class="title"><a href="https://launchpad.net/fenics/+announcement/8369">Mac OS X and Windows binaries updated</a></div>
+<div class="author">Johannes Ring</div>
+<div class="date">May 18, 2011 03:17 PM</div>
+<div class="content"><p>The Mac OS X and Windows binaries have been updated and now features DOLFIN 0.9.11, FFC 0.9.10, Instant 0.9.10, UFC 2.0.1 and UFL 0.9.1. They are available from the installation page at <a href="http://www.fenicsproject.org" rel="nofollow">http://&lt;wbr&gt;&lt;/wbr&gt;www.fenicsproje&lt;wbr&gt;&lt;/wbr&gt;ct.org</a>.</p></div>
+</div>
+
+
+<div class="news-item">
+<div class="title"><a href="https://launchpad.net/instant/+announcement/8364">Instant 0.9.10</a></div>
+<div class="author">Garth Wells</div>
+<div class="date">May 16, 2011 04:41 PM</div>
+<div class="content"><p>A new version of Instant has been released. This version permits the SWIG executable to be set.</p></div>
+</div>
+
+
+<div class="news-item">
+<div class="title"><a href="https://launchpad.net/ufl/+announcement/8363">UFL 0.9.1</a></div>
+<div class="author">Garth Wells</div>
+<div class="date">May 16, 2011 04:40 PM</div>
+<div class="content"><p>A new version of UFL has been released.  The release provides some new features, and a range of behind-the-scenes improvements. A list of changes can be found the in ChangeLog.</p></div>
+</div>
+
+
+<div class="news-item">
+<div class="title"><a href="https://launchpad.net/dolfin/+announcement/8362">DOLFIN 0.9.11</a></div>
+<div class="author">Garth Wells</div>
+<div class="date">May 16, 2011 04:38 PM</div>
+<div class="content"><p>A new version of DOLFIN has been released with a number of improvements and a significant number of bug fixes.  A comprehensive list of new features and bug fixes can be found in the ChangeLog.</p></div>
+</div>
+
+
+<div class="news-item">
+<div class="title"><a href="https://launchpad.net/ffc/+announcement/8361">FFC 0.9.10</a></div>
+<div class="author">Garth Wells</div>
+<div class="date">May 16, 2011 04:37 PM</div>
+<div class="content"><p>A new version of FFC has been released. This release makes optimised quadrature schemes for simplices available, and includes a number of behind-the-scenes improvements.</p></div>
+</div>
+
+
+<div class="news-item">
+<div class="title"><a href="https://launchpad.net/ufc/+announcement/8360">UFC 2.0.1</a></div>
+<div class="author">Garth Wells</div>
+<div class="date">May 16, 2011 04:35 PM</div>
+<div class="content"><p>A new version of UFC has been released.  With this release, UFC moves to SWIG version &gt;= 2.0. This release also fixes a const bug in the interface.</p></div>
+</div>
+
+
+<div class="news-item">
+<div class="title"><a href="https://launchpad.net/ffc/+announcement/8357">Simplex quadrature improvements</a></div>
+<div class="author">Garth Wells</div>
+<div class="date">May 16, 2011 10:18 AM</div>
+<div class="content"><p>The development version of FFC now provides optimised rules for quadrature on triangles and tetrahedra. The provides a performance boost when using the quadrature representation, especially for lower order forms.</p></div>
 </div>

@@ -169,44 +81,4 @@
 </div>

-<div class="news-item">
-<div class="title"><a href="https://launchpad.net/instant/+announcement/7846">Instant 0.9.9</a></div>
-<div class="author">Anders Logg</div>
-<div class="date">February 23, 2011 09:07 PM</div>
-<div class="content"><p>A new version of Instant has been released. This version brings speed improvements to JIT compilation.</p></div>
-</div>
-
-
-<div class="news-item">
-<div class="title"><a href="https://launchpad.net/fenics-viper/+announcement/7845">Viper 0.4.7</a></div>
-<div class="author">Anders Logg</div>
-<div class="date">February 23, 2011 08:41 PM</div>
-<div class="content"><p>A new version of Viper has been released. This version contains a number of small fixes/improvements.</p></div>
-</div>
-
-
-<div class="news-item">
-<div class="title"><a href="https://launchpad.net/ufl/+announcement/7844">UFL 0.9.0</a></div>
-<div class="author">Anders Logg</div>
-<div class="date">February 23, 2011 08:33 PM</div>
-<div class="content"><p>A new version of UFL has been released. This release fixes some minor bugs.</p></div>
-</div>
-
-
-<div class="news-item">
-<div class="title"><a href="https://launchpad.net/ffc/+announcement/7842">FFC 0.9.9</a></div>
-<div class="author">Anders Logg</div>
-<div class="date">February 23, 2011 07:42 PM</div>
-<div class="content"><p>A new version of FFC has been released. This version adds support for UFC 2.0 and plotting of elements.</p></div>
-</div>
-
-
-<div class="news-item">
-<div class="title"><a href="https://launchpad.net/ufc/+announcement/7841">UFC 2.0.0</a></div>
-<div class="author">Anders Logg</div>
-<div class="date">February 23, 2011 06:33 PM</div>
-<div class="content"><p>A new version of UFC has been released. This version adds new functionality to the UFC interface and makes some minor modifications to the existing UFC interface.</p></div>
-</div>
-
-
 </div>

=== added directory 'utils/newsfetcher/cache'
=== modified file 'utils/newsfetcher/sources.ini'
--- utils/newsfetcher/sources.ini	2011-05-04 18:16:45 +0000
+++ utils/newsfetcher/sources.ini	2011-05-23 18:16:53 +0000
@@ -4,7 +4,7 @@
 owner_name = FEniCS Project
 owner_email = [email-masked]
 
-cache_directory = output
+cache_directory = cache
 log_level = DEBUG
 feed_timeout = 20

---

From: "Garth N. Wells" <[email-masked]>
Date: Mon, 23 May 2011 20:24:29 +0100

> The plan is to make it the default branch at the time of the release

Do we have to wait so long? It would be good to get an updated web page
online sooner.

Garth

> --
> Anders
> 
> 
> 
> _______________________________________________
> Mailing list: https://launchpad.net/~fenics
> Post to     : [email-masked]
> Unsubscribe : https://launchpad.net/~fenics
> More help   : https://help.launchpad.net/ListHelp

---

From: Anders Logg <[email-masked]>
Date: Mon, 23 May 2011 21:51:15 +0200

> Do we have to wait so long? It would be good to get an updated web page

I'd like the page to be ready before it's launched so we can say: look
at our new web page.

I'm sure there will be a couple of iterations before everything is
ready and I don't expect it to be ready long before the code is (if
that doesn't drag out).

Things that still need fixin for the web page:

1. Newsfeed: Harish will fix

2. Download button: Harish will work on the sniffer, need to
coordinate with Johannes to connect to the right download links

3. Get documentation in place: Marie is working on this

4. Get new design in place: I'm meeting with the designer I hired on
Thursday to evaluate some proposals

5. Add missing information on pages: break up installation page in
smaller pieces / separate pages, complete citing page

6. Add a "featured item" on the front page. My idea (originally from
Harish) is to dedicate the upper left corner of the front page to a
featured item which will occupy the page for a number of weeks. This
will showcase interesting results obtained with FEniCS, and other
"articles" related to FEniCS.

--
Anders

---

From: Harish Narayanan <[email-masked]>
Date: Mon, 23 May 2011 22:44:28 +0200

> "articles" related to FEniCS.

Is the following still the overall layout inspiration?
http://home.simula.no/~harish/files/tmp/fenics-web-trial.png

harish

---

From: Anders Logg <[email-masked]>
Date: Mon, 23 May 2011 22:49:56 +0200

> http://home.simula.no/~harish/files/tmp/fenics-web-trial.png

Yes, with the addition that I'd like a big shiny download button with
some auto-detected text like so: http://getfirefox.com.

I'm imagining this somewhere in the upper right corner. Perhaps this
can be handled by giving the featured item 3/4 of the space, then the
download button + some short introductory text ("FEniCS is ... try it
out today") in the right 1/4 space just below the download button.

--
Anders

---

From: "Garth N. Wells" <[email-masked]>
Date: Tue, 24 May 2011 08:24:57 +0100

> I'd like the page to be ready before it's launched so we can say: look

OK. For me it's more important to have an improved page online as soon
as possible/now to replace the holding page that we've had up for a long
time.

Garth

---

From: Anders Logg <[email-masked]>
Date: Tue, 24 May 2011 09:30:06 +0200

> as possible/now to replace the holding page that we've had up for a long

The page is simply not ready yet. Since we are still working on the
design of the new page, I prefer to wait until it's ready.

But I have no objections to (you) backporting the text or any other
updates from the 1.0 branch to the old branch (but keeping the old
styling).

--
Anders