Subject: [Fenics] Trouble in Importing Dolfin

From: "Lorenzo Isella" <[email-masked]>
Date: Wed, 16 May 2012 01:15:42 +0200

Dear All,
I have recently installed fenics on my box (I am running debian testing  
for the amd64 architecture).
I was not able to run the Poisson "classic" example and the reason is that  
something goes wrong at the very beginning when I import dolfin (see the  
text at the end of the email).
Any idea about how to fix this?
Many thanks.

Lorenzo

In [1]: from dolfin import *
---------------------------------------------------------------------------
ImportError                               Traceback (most recent call last)
/home/lorenzo/temp/<ipython-input-1-f9fe29351801> in <module>()
----> 1 from dolfin import *

/usr/lib/python2.7/dist-packages/dolfin/__init__.pyc in <module>()
      21
      22 # Import names from the compiled cpp module

---> 23 from dolfin.cppimports import *
      24 from dolfin.cppimports import __version__, __swigversion__
      25

/usr/lib/python2.7/dist-packages/dolfin/cppimports.py in <module>()
       2
       3 #--- Imports the SWIG-generated Python code (C++ interface) ---

----> 4 import dolfin.cpp as cpp
       5 __swigversion__ = cpp.__swigversion__
       6 __version__ = cpp.__dolfinversion__

ImportError: No module named cpp

---

From: Johannes Ring <[email-masked]>
Date: Wed, 16 May 2012 09:16:56 +0200

Hi Lorenzo,

On Wed, May 16, 2012 at 1:15 AM, Lorenzo Isella
<[email-masked]> wrote:
> Dear All,
> I have recently installed fenics on my box (I am running debian testing for
> the amd64 architecture).

I think you have run into this bug:

  http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=672208

This was recently fixed in Debian unstable but the fix is not
available in testing yet.

Johannes