Subject: [Fenics] Upcoming release

From: Anders Logg <[email-masked]>
Date: Wed, 13 Jun 2012 22:41:13 +0200

We're approaching the June 20 deadline for making new releases
(deadline set by Debian freeze).

Which releases are in the pipeline? I would think

  DOLFIN 1.0.1
  DOLFIN 1.1.0
  FFC    1.0.1

What else?

The buildbot is green and my take is that as long as it's green, we
can make a release, but it would be good to fix a bug or two. I will be
mostly occupied over the coming week but I can try to find time to fix
some bugs.

--
Anders

---

From: "Marie E. Rognes" <[email-masked]>
Date: Thu, 14 Jun 2012 13:55:02 +0200

> Which releases are in the pipeline? I would think

There is definitely a significant amount of changes in UFL,
and a minor addition to FIAT; so I would expect releases of
those too.

--
Marie

> _______________________________________________
> Mailing list: https://launchpad.net/~fenics
> Post to     : [email-masked]
> Unsubscribe : https://launchpad.net/~fenics
> More help   : https://help.launchpad.net/ListHelp

---

From: Johannes Ring <[email-masked]>
Date: Thu, 14 Jun 2012 13:56:27 +0200

> Which releases are in the pipeline? I would think

The FFC release should be made from lp:ffc/1.0.x, right?

> What else?

For DOLFIN 1.0.1 we will also need a new release of UFC:

 UFC 2.0.6 (from lp:ufc/2.0.x)

And there has also been a few bug fixes in Instant and Viper so we
should have new releases of those as well:

 Instant 1.0.1 (from lp:instant/1.0.x)
 Viper 1.0.1 (from lp:fenics-viper/1.0.x)

For DOLFIN 1.1.0 we need new releases of the same FEniCS components as
for DOLFIN 1.0.1 and we might also need a new release of UFL? However,
these releases should be made from the trunk series and should have
different version numbers than the ones for DOLFIN 1.0.1.

Johannes

---

From: Anders Logg <[email-masked]>
Date: Thu, 14 Jun 2012 14:00:19 +0200

> and a minor addition to FIAT; so I would expect releases of

So we have

  DOLFIN 1.0.1
  DOLFIN 1.1.0
  FFC    1.0.1
  FIAT   1.0.1 (or 1.1.0 since a new element was added?)
  Viper  1.0.1
  UFL    1.1.0 (Martin?)
  UFC    2.0.6

--
Anders

---

From: "Marie E. Rognes" <[email-masked]>
Date: Thu, 14 Jun 2012 14:04:43 +0200

>    FIAT   1.0.1 (or 1.1.0 since a new element was added?)

I'm confused by the numbering. Which of these should now talk together?

--
Marie

---

From: Martin Sandve Alnæs <[email-masked]>
Date: Thu, 14 Jun 2012 18:13:50 +0200

UFL and ffc both need 1.0.1 and 1.1.0.

Martin
Den 14. juni 2012 14:04 skrev "Marie E. Rognes" <[email-masked]> følgende:

> ______________________________**_________________
> More help   : https://help.launchpad.net/**ListHelp<https://help.launchpad.net/ListHelp>
>

---

From: Johannes Ring <[email-masked]>
Date: Fri, 15 Jun 2012 12:01:45 +0200

> UFL and ffc both need 1.0.1 and 1.1.0.

There are no changes in lp:ufl/1.0.x since 1.0.0 so why do we need two
releases of UFL?

I agree with Marie that it is confusing. The changes between UFC trunk
and 2.0.x are minimal, so we should only need one release of UFC.

Johannes

---

From: Martin Sandve Alnæs <[email-masked]>
Date: Fri, 15 Jun 2012 13:47:22 +0200

> There are no changes in lp:ufl/1.0.x since 1.0.0 so why do we need two

I have some changes to add. Just needs testing.

> and 2.0.x are minimal, so we should only need one release of UFC.

In general, 1.0.x fit together, and 1.1.x fit together.

UFC is the exception for historical reasons.
Once UFC becomes incompatible with the 1.0.x line, make it 2.1.x.

Martin

---

From: Johannes Ring <[email-masked]>
Date: Fri, 15 Jun 2012 14:04:27 +0200

> I have some changes to add. Just needs testing.

OK.

> Once UFC becomes incompatible with the 1.0.x line, make it 2.1.x.

OK, so we will need

 DOLFIN 1.0.1
 FFC 1.0.1
 Instant 1.0.1
 UFC 2.0.6
 UFL 1.0.1
 Viper 1.0.1

and

 DOLFIN 1.1.0
 FFC 1.1.0
 FIAT 1.1.0
 Instant 1.1.0
 UFC 2.0.6 (same as above)
 UFL 1.1.0
 Viper 1.1.0

?

Johannes

---

From: Anders Logg <[email-masked]>
Date: Tue, 19 Jun 2012 15:15:11 +0200

>  UFC 2.0.6 (same as above)

It seems like reality is catching up with us. I'm at a conference,
Garth is busy and we have not had time to make a release candidate.

So let's just relax and make the release when we've found time for a
code/bug sprint and one or more release candidates.

--
Anders

---

From: Johannes Ring <[email-masked]>
Date: Thu, 21 Jun 2012 14:36:20 +0200

> code/bug sprint and one or more release candidates.

OK, so I guess this means no 1.1.0 release before the summer, but is
there any chance for a 1.0.1 release? The Debian freeze has now been
set to June 30 [1] and IMHO it would good to get the fixes in 1.0.1
into the upcoming Debian stable release.

[1] https://lists.debian.org/debian-devel-announce/2012/06/msg00006.html

Johannes