Subject: [Fenics] UFL 1.0.0?

From: Anders Logg <[email-masked]>
Date: Mon, 21 Nov 2011 20:12:26 +0100

What is the status on a release of UFL 1.0.0?

I hope we can release DOLFIN 1.0-rc1 tonight, and FFC 1.0-rc1 later
this week. Then maybe 1.0.0 can follow for all components next week.

--
Anders

---

From: Martin Sandve Alnæs <[email-masked]>
Date: Mon, 21 Nov 2011 23:41:55 +0100

They should all hit 1.0 simultaneously. Ufl rc1 can be released together
with dolfin and ffc rc1. There are some fixes.

Martin
Den 21. nov. 2011 23.36 skrev "Anders Logg" <[email-masked]> følgende:

> _______________________________________________
> Mailing list: https://launchpad.net/~fenics
> Post to     : [email-masked]
> Unsubscribe : https://launchpad.net/~fenics
> More help   : https://help.launchpad.net/ListHelp
>

---

From: Anders Logg <[email-masked]>
Date: Mon, 21 Nov 2011 23:45:12 +0100

Good. I think we need to make UFL, UFC, FFC, FIAT before DOLFIN
so that we can recompile all forms in DOLFIN prior to the release:

  https://bugs.launchpad.net/dolfin/+milestone/1.0

--
Anders

On Mon, Nov 21, 2011 at 11:41:55PM +0100, Martin Sandve Alnæs wrote:
> They should all hit 1.0 simultaneously. Ufl rc1 can be released together with
> dolfin and ffc rc1. There are some fixes.
> Martin
> Den 21. nov. 2011 23.36 skrev &quot;Anders Logg&quot; <[email-masked]>
> følgende:

---

From: Martin Sandve Alnæs <[email-masked]>
Date: Tue, 22 Nov 2011 10:43:32 +0100

Is it time to branch off all projects in 1.0.x branches when releasing
1.0-rc1 or can we hold off until 1.0.0?

Martin

---

From: Anders Logg <[email-masked]>
Date: Tue, 22 Nov 2011 12:28:16 +0100

What are the reasons for waiting? We hope it should be a short period
anyway before 1.0 is released.

--
Anders

---

From: Martin Sandve Alnæs <[email-masked]>
Date: Tue, 22 Nov 2011 12:30:31 +0100

Nothing big. Dual commits, buildbot setup. I'll make a 1.0.x series
and branch for UFL.

Martin

---

From: Anders Logg <[email-masked]>
Date: Tue, 22 Nov 2011 13:25:06 +0100

ok, someone will do the same for FFC.

--
Anders