Subject: [Fenics] [[email-masked]: [Branch ~fenics-core/fenics-doc/1.0] Rev 288: Added more recent version of news styling (with tiny project-dependent images)]

From: Anders Logg <[email-masked]>
Date: Mon, 23 May 2011 20:50:34 +0200

Great work! Some suggestions:

1. Remove the time of day from the news items.

2. Bold font only on the date.

3. Place it in the lower right as in the wordpress design.

4. I hope we'll soon have a default icon in place of the orange box.

5. You can run ./publish.sh to update the web page on fpo/new

--
Anders

Subject: [Branch ~fenics-core/fenics-doc/1.0] Rev 288: Added more recent version of news styling (with tiny project-dependent images)
From: [email-masked]
To: Anders Logg <[email-masked]>
Date: Mon, 23 May 2011 18:41:27 -0000

------------------------------------------------------------
revno: 288
committer: Harish Narayanan <[email-masked]>
branch nick: fenics-doc
timestamp: Mon 2011-05-23 20:40:27 +0200
message:
  Added more recent version of news styling (with tiny project-dependent images)
added:
  source/_themes/fenics/static/dolfin.png
  source/_themes/fenics/static/dorsal.png
  source/_themes/fenics/static/unknown.png
modified:
  source/newsfeed.inc
  utils/newsfetcher/sources.ini
  utils/newsfetcher/themes/fenics/include.html.tmpl

--
lp:~fenics-core/fenics-doc/1.0
https://code.launchpad.net/~fenics-core/fenics-doc/1.0

You are subscribed to branch lp:~fenics-core/fenics-doc/1.0.
To unsubscribe from this branch go to https://code.launchpad.net/~fenics-core/fenics-doc/1.0/+edit-subscription
=== added file 'source/_themes/fenics/static/dolfin.png'
Binary files source/_themes/fenics/static/dolfin.png	1970-01-01 00:00:00 +0000 and source/_themes/fenics/static/dolfin.png	2011-05-23 18:40:27 +0000 differ
=== added file 'source/_themes/fenics/static/dorsal.png'
Binary files source/_themes/fenics/static/dorsal.png	1970-01-01 00:00:00 +0000 and source/_themes/fenics/static/dorsal.png	2011-05-23 18:40:27 +0000 differ
=== added file 'source/_themes/fenics/static/unknown.png'
Binary files source/_themes/fenics/static/unknown.png	1970-01-01 00:00:00 +0000 and source/_themes/fenics/static/unknown.png	2011-05-23 18:40:27 +0000 differ
=== modified file 'source/newsfeed.inc'
--- source/newsfeed.inc	2011-05-23 18:16:53 +0000
+++ source/newsfeed.inc	2011-05-23 18:40:27 +0000
@@ -1,84 +1,44 @@
 <div class="fetched-news">
 
-
-<div class="news-item">
-<div class="title"><a href="https://launchpad.net/fenics/+announcement/8369">Mac OS X and Windows binaries updated</a></div>
-<div class="author">Johannes Ring</div>
-<div class="date">May 18, 2011 03:17 PM</div>
-<div class="content"><p>The Mac OS X and Windows binaries have been updated and now features DOLFIN 0.9.11, FFC 0.9.10, Instant 0.9.10, UFC 2.0.1 and UFL 0.9.1. They are available from the installation page at <a href="http://www.fenicsproject.org" rel="nofollow">http://&lt;wbr&gt;&lt;/wbr&gt;www.fenicsproje&lt;wbr&gt;&lt;/wbr&gt;ct.org</a>.</p></div>
-</div>
-
-
-<div class="news-item">
-<div class="title"><a href="https://launchpad.net/instant/+announcement/8364">Instant 0.9.10</a></div>
-<div class="author">Garth Wells</div>
-<div class="date">May 16, 2011 04:41 PM</div>
-<div class="content"><p>A new version of Instant has been released. This version permits the SWIG executable to be set.</p></div>
-</div>
-
-
-<div class="news-item">
-<div class="title"><a href="https://launchpad.net/ufl/+announcement/8363">UFL 0.9.1</a></div>
-<div class="author">Garth Wells</div>
-<div class="date">May 16, 2011 04:40 PM</div>
-<div class="content"><p>A new version of UFL has been released.  The release provides some new features, and a range of behind-the-scenes improvements. A list of changes can be found the in ChangeLog.</p></div>
-</div>
-
-
-<div class="news-item">
-<div class="title"><a href="https://launchpad.net/dolfin/+announcement/8362">DOLFIN 0.9.11</a></div>
-<div class="author">Garth Wells</div>
-<div class="date">May 16, 2011 04:38 PM</div>
-<div class="content"><p>A new version of DOLFIN has been released with a number of improvements and a significant number of bug fixes.  A comprehensive list of new features and bug fixes can be found in the ChangeLog.</p></div>
-</div>
-
-
-<div class="news-item">
-<div class="title"><a href="https://launchpad.net/ffc/+announcement/8361">FFC 0.9.10</a></div>
-<div class="author">Garth Wells</div>
-<div class="date">May 16, 2011 04:37 PM</div>
-<div class="content"><p>A new version of FFC has been released. This release makes optimised quadrature schemes for simplices available, and includes a number of behind-the-scenes improvements.</p></div>
-</div>
-
-
-<div class="news-item">
-<div class="title"><a href="https://launchpad.net/ufc/+announcement/8360">UFC 2.0.1</a></div>
-<div class="author">Garth Wells</div>
-<div class="date">May 16, 2011 04:35 PM</div>
-<div class="content"><p>A new version of UFC has been released.  With this release, UFC moves to SWIG version &gt;= 2.0. This release also fixes a const bug in the interface.</p></div>
-</div>
-
-
-<div class="news-item">
-<div class="title"><a href="https://launchpad.net/ffc/+announcement/8357">Simplex quadrature improvements</a></div>
-<div class="author">Garth Wells</div>
-<div class="date">May 16, 2011 10:18 AM</div>
-<div class="content"><p>The development version of FFC now provides optimised rules for quadrature on triangles and tetrahedra. The provides a performance boost when using the quadrature representation, especially for lower order forms.</p></div>
-</div>
-
-
-<div class="news-item">
-<div class="title"><a href="https://launchpad.net/unicorn/+announcement/8253">Unicorn HPC 0.1.2</a></div>
-<div class="author">Niclas Jansson</div>
-<div class="date">April 29, 2011 10:07 PM</div>
-<div class="content"><p>A new version of Unicorn has been released. This release fixes various bugs and portability issues.</p></div>
-</div>
-
-
-<div class="news-item">
-<div class="title"><a href="https://launchpad.net/dorsal/+announcement/7870">Dorsal 0.8.2 Released!</a></div>
-<div class="author">Harish Narayanan</div>
-<div class="date">February 28, 2011 02:48 PM</div>
-<div class="content"><p>This is a bug-fix release that makes sure all the packages are up-to-date.</p></div>
-</div>
-
-
-<div class="news-item">
-<div class="title"><a href="https://launchpad.net/dolfin/+announcement/7847">DOLFIN 0.9.10</a></div>
-<div class="author">Anders Logg</div>
-<div class="date">February 23, 2011 09:26 PM</div>
-<div class="content"><p>A new version of DOLFIN has been released. This release adds a large number of improvements and bug fixes, most notably improved parallel scaling and experimental support for multi-core computing.</p></div>
-</div>
-
+<li>
+<img class="avatar" src="_static/unknown.png" width="14" height="14" alt="FEniCS Project Announcements icon">
+<a href="https://launchpad.net/fenics/+announcement/8369">May 18, 2011 03:17 PM: Mac OS X and Windows binaries updated</a>
+</li>
+<li>
+<img class="avatar" src="_static/unknown.png" width="14" height="14" alt="Instant Announcements icon">
+<a href="https://launchpad.net/instant/+announcement/8364">May 16, 2011 04:41 PM: Instant 0.9.10</a>
+</li>
+<li>
+<img class="avatar" src="_static/unknown.png" width="14" height="14" alt="UFL Announcements icon">
+<a href="https://launchpad.net/ufl/+announcement/8363">May 16, 2011 04:40 PM: UFL 0.9.1</a>
+</li>
+<li>
+<img class="avatar" src="_static/dolfin.png" width="14" height="14" alt="DOLFIN Announcements icon">
+<a href="https://launchpad.net/dolfin/+announcement/8362">May 16, 2011 04:38 PM: DOLFIN 0.9.11</a>
+</li>
+<li>
+<img class="avatar" src="_static/unknown.png" width="14" height="14" alt="FFC Announcements icon">
+<a href="https://launchpad.net/ffc/+announcement/8361">May 16, 2011 04:37 PM: FFC 0.9.10</a>
+</li>
+<li>
+<img class="avatar" src="_static/unknown.png" width="14" height="14" alt="UFC Announcements icon">
+<a href="https://launchpad.net/ufc/+announcement/8360">May 16, 2011 04:35 PM: UFC 2.0.1</a>
+</li>
+<li>
+<img class="avatar" src="_static/unknown.png" width="14" height="14" alt="FFC Announcements icon">
+<a href="https://launchpad.net/ffc/+announcement/8357">May 16, 2011 10:18 AM: Simplex quadrature improvements</a>
+</li>
+<li>
+<img class="avatar" src="_static/unknown.png" width="14" height="14" alt="The FEniCS-Apps Project Announcements icon">
+<a href="https://launchpad.net/unicorn/+announcement/8253">April 29, 2011 10:07 PM: Unicorn HPC 0.1.2</a>
+</li>
+<li>
+<img class="avatar" src="_static/dorsal.png" width="14" height="14" alt="Dorsal Announcements icon">
+<a href="https://launchpad.net/dorsal/+announcement/7870">February 28, 2011 02:48 PM: Dorsal 0.8.2 Released!</a>
+</li>
+<li>
+<img class="avatar" src="_static/dolfin.png" width="14" height="14" alt="DOLFIN Announcements icon">
+<a href="https://launchpad.net/dolfin/+announcement/7847">February 23, 2011 09:26 PM: DOLFIN 0.9.10</a>
+</li>
 
 </div>

=== modified file 'utils/newsfetcher/sources.ini'
--- utils/newsfetcher/sources.ini	2011-05-23 18:16:53 +0000
+++ utils/newsfetcher/sources.ini	2011-05-23 18:40:27 +0000
@@ -14,30 +14,40 @@
 
 [http://feeds.launchpad.net/fenics/announcements.atom]
 name = fenics
+face = unknown.png
 
 [http://feeds.launchpad.net/dolfin/announcements.atom]
 name = dolfin
+face = dolfin.png
 
 [http://feeds.launchpad.net/ffc/announcements.atom]
 name = ffc
+face = unknown.png
 
 [http://feeds.launchpad.net/fenics-syfi/announcements.atom]
 name = syfi
+face = unknown.png
 
 [http://feeds.launchpad.net/ufl/announcements.atom]
 name = ufl
+face = unknown.png
 
 [http://feeds.launchpad.net/ufc/announcements.atom]
 name = ufc
+face = unknown.png
 
 [http://feeds.launchpad.net/instant/announcements.atom]
 name = instant
+face = unknown.png
 
 [http://feeds.launchpad.net/fenics-viper/announcements.atom]
 name = viper
+face = unknown.png
 
 [http://feeds.launchpad.net/dorsal/announcements.atom]
 name = dorsal
+face = dorsal.png
 
 [http://feeds.launchpad.net/fenics-group/announcements.atom]
 name = apps
+face = unknown.png

=== modified file 'utils/newsfetcher/themes/fenics/include.html.tmpl'
--- utils/newsfetcher/themes/fenics/include.html.tmpl	2011-05-04 18:16:45 +0000
+++ utils/newsfetcher/themes/fenics/include.html.tmpl	2011-05-23 18:40:27 +0000
@@ -1,14 +1,10 @@
 <div class="fetched-news">
 
 <TMPL_LOOP Items>
-
-<div class="news-item">
-<div class="title"><a href="<TMPL_VAR link>"><TMPL_VAR title></a></div>
-<div class="author"><TMPL_VAR author></div>
-<div class="date"><TMPL_VAR date></div>
-<div class="content"><TMPL_VAR content></div>
-</div>
-
+<li>
+<img class="avatar" src="_static/<TMPL_VAR channel_face ESCAPE="HTML">" width="14" height="14" alt="<TMPL_VAR channel_title_plain ESCAPE="HTML"> icon">
+<a href="<TMPL_VAR link ESCAPE="HTML">"><TMPL_VAR date>: <TMPL_VAR title></a>
+</li>
 </TMPL_LOOP>
 
 </div>

---

From: Harish Narayanan <[email-masked]>
Date: Mon, 23 May 2011 21:21:56 +0200

> 5. You can run ./publish.sh to update the web page on fpo/new

I will do these. I just merged an older style (spent way too much time
on working with the wrong branch) just to show that it can be styled.

Should the news content be included as an apache server side include
(SSI) so that it doesn't require rebuilding the content each time the
news is updated?

Harish

---

From: Anders Logg <[email-masked]>
Date: Mon, 23 May 2011 21:45:24 +0200

> (SSI) so that it doesn't require rebuilding the content each time the

Yes, that would be great. I tried to make the changes required for SSI
on the web server a couple of weeks back but without luck. Perhaps you
have better Apache skills.

--
Anders