Subject: [Fenics] [[email-masked]: [Branch ~fenics-web-core/fenics-web/tip] Rev 335: Started making the pylons sphinx theme look more like their web site]

From: Anders Logg <[email-masked]>
Date: Wed, 15 Jun 2011 15:45:00 +0200

Shouldn't you be making it look more like our website? :-)

--
Anders

Subject: [Branch ~fenics-web-core/fenics-web/tip] Rev 335: Started making the pylons sphinx theme look more like their web site
From: [email-masked]
To: Anders Logg <[email-masked]>
Date: Wed, 15 Jun 2011 13:01:27 -0000

------------------------------------------------------------
revno: 335
committer: Harish Narayanan <[email-masked]>
branch nick: fenics-web
timestamp: Wed 2011-06-15 14:59:26 +0200
message:
  Started making the pylons sphinx theme look more like their web site
modified:
  source/_themes/pylons/layout.html
  source/_themes/pylons/static/pylons.css_t

--
lp:fenics-web
https://code.launchpad.net/~fenics-web-core/fenics-web/tip

Your team FEniCS Web Team is subscribed to branch lp:fenics-web.
To unsubscribe from this branch go to https://code.launchpad.net/~fenics-web-core/fenics-web/tip/+edit-subscription
=== modified file 'source/_themes/pylons/layout.html'
--- source/_themes/pylons/layout.html	2011-06-13 14:27:32 +0000
+++ source/_themes/pylons/layout.html	2011-06-15 12:59:26 +0000
@@ -1,5 +1,12 @@
 {% extends "basic/layout.html" %}
 
+{# do not display relbars #}
+{% block relbar1 %}{% endblock %}
+{% block relbar2 %}{% endblock %}
+
+{% block sidebar1 %}{{ sidebar() }}{% endblock %}
+{% block sidebar2 %}{% endblock %}
+
 {%- block extrahead %}
 <link rel="stylesheet" href="http://static.pylonsproject.org/fonts/nobile/stylesheet.css" type="text/css" media="screen" charset="utf-8" />
 <link rel="stylesheet" href="http://static.pylonsproject.org/fonts/neuton/stylesheet.css" type="text/css" media="screen" charset="utf-8" />

=== modified file 'source/_themes/pylons/static/pylons.css_t'
--- source/_themes/pylons/static/pylons.css_t	2011-06-13 14:27:32 +0000
+++ source/_themes/pylons/static/pylons.css_t	2011-06-15 12:59:26 +0000
@@ -28,7 +28,9 @@
 }
 
 div.bodywrapper {
-    margin: 0 0 0 230px;
+   width: 900px;
+   margin-left: auto;
+   margin-right: auto;
 }
 
 hr {
@@ -36,14 +38,13 @@
 }
  
 div.document {
-    background-color: #eee;
+    background-color: #fff;
 }
 
 div.header{
     width:100%;
     height:230px;
     background: #f98131 url(headerbg.png) repeat-x 0 top;
-    border-bottom: 2px solid #ffffff;
 }
 
 div.header-small{
@@ -68,9 +69,7 @@
     color: #3E4349;
     padding: 0 30px 30px 30px;
     font-size: 14px;
-	border: 2px solid #ddd;
-	border-right-style: none;
-	overflow: auto;
+    overflow: auto;
 }
  
 div.footer {
@@ -108,63 +107,6 @@
 	padding-left: 240px;
 }
  
-div.sphinxsidebar {
-    font-size: 12px;
-    line-height: 1.5em;
-}
-
-div.sphinxsidebarwrapper{
-    padding: 10px 0;
-}
- 
-div.sphinxsidebar h3,
-div.sphinxsidebar h4 {
-    font-family: "NeutonRegular", sans-serif;
-    color: #373839;
-    font-size: 1.4em;
-    font-weight: normal;
-    margin: 0;
-    padding: 5px 10px;
-	border-bottom: 2px solid #ddd;
-}
-
-div.sphinxsidebar h4{
-    font-size: 1.3em;
-}
- 
-div.sphinxsidebar h3 a {
-    color: #000000;
-}
- 
- 
-div.sphinxsidebar p {
-    color: #888;
-    padding: 5px 20px;
-}
- 
-div.sphinxsidebar p.topless {
-}
- 
-div.sphinxsidebar ul {
-    margin: 10px 20px;
-    padding: 0;
-    color: #373839;
-}
- 
-div.sphinxsidebar a {
-    color: #444;
-}
- 
-div.sphinxsidebar input {
-    border: 1px solid #ccc;
-    font-family: sans-serif;
-    font-size: 1em;
-}
-
-div.sphinxsidebar input[type=text]{
-    margin-left: 20px;
-}
-
 /* -- sidebars -------------------------------------------------------------- */
 
 div.sidebar {

---

From: Harish Narayanan <[email-masked]>
Date: Wed, 15 Jun 2011 17:52:39 +0200

First step is to make their sphinx theme look like their web site (not
sphinx), and then make that look like a new FEniCS site. :)

Harish

On 6/15/11 3:45 PM, Anders Logg wrote:
> _______________________________________________
> Mailing list: https://launchpad.net/~fenics
> Post to     : [email-masked]
> Unsubscribe : https://launchpad.net/~fenics
> More help   : https://help.launchpad.net/ListHelp

---

From: Anders Logg <[email-masked]>
Date: Wed, 15 Jun 2011 17:59:21 +0200

ok, I'm holding my breath. :-)

--
Anders