Subject: [Fenics] Getting build and install commands from dorsal

From: Martin Sandve Alnæs <[email-masked]>
Date: Thu, 12 May 2011 20:45:43 +0200

Hi,
is it possible to get just the commands that dorsal would have run
without actually running them?

--
Martin

---

From: Johan Hake <[email-masked]>
Date: Thu, 12 May 2011 14:20:20 -0700

Don't think so without some hack.

dorsal generates two scripts dorsal_configure and dorsal_build. The relevant 
commands are written to these two files. If you out-comment the call to these 
scripts in dorsal.sh you should be able to not install the package.

I guess outcomment these lines would do the trick.

...
    ./dorsal_configure
    quit_if_fail "There was a problem configuring ${NAME}."

    ./dorsal_build
    quit_if_fail "There was a problem building ${NAME}."
...

Johan 

On Thursday May 12 2011 11:45:43 Martin Sandve Alnæs wrote:
> _______________________________________________
> Mailing list: https://launchpad.net/~fenics
> Post to     : [email-masked]
> Unsubscribe : https://launchpad.net/~fenics
> More help   : https://help.launchpad.net/ListHelp

---

From: Harish Narayanan <[email-masked]>
Date: Fri, 13 May 2011 09:16:20 +0200

>     quit_if_fail "There was a problem building ${NAME}."

I too think this is the way to do it. You can get both the build command
as well as all the environment variables.

Harish

---

From: Martin Sandve Alnæs <[email-masked]>
Date: Fri, 13 May 2011 09:51:44 +0200

> as well as all the environment variables.

Great, thanks.

Martin