Subject: Re: [Fenics] [Branch ~fenics-core/fenics-doc/1.0] Rev 248: Fix Bug #761516. (python/index.rst incomplete)

From: "Garth N. Wells" <[email-masked]>
Date: Fri, 15 Apr 2011 17:44:38 +0100

I get the error:

 File
"/home/garth/code/fenics/dolfin.d/dolfin-all/local/lib/python2.7/site-packages/dolfin/function/ufc_functionspace.py",
line 1, in <module>
    import cpp
ImportError: No module named cpp

Garth

On 15/04/11 17:20, [email-masked] wrote:
> ------------------------------------------------------------
> revno: 248
> committer: Kristian B. Ølgaard <[email-masked]>
> branch nick: 1.0
> timestamp: Fri 2011-04-15 18:15:43 +0200
> message:
>   Fix Bug #761516. (python/index.rst incomplete)
> modified:
>   source/doc/dolfin/programmers-reference/python/index.rst
>   utils/generate_dolfin_python_doc.py
> 
> 
> --
> lp:~fenics-core/fenics-doc/1.0
> https://code.launchpad.net/~fenics-core/fenics-doc/1.0
> 
> You are subscribed to branch lp:~fenics-core/fenics-doc/1.0.
> To unsubscribe from this branch go to https://code.launchpad.net/~fenics-core/fenics-doc/1.0/+edit-subscription

---

From: Kristian Ølgaard <[email-masked]>
Date: Fri, 15 Apr 2011 18:58:08 +0200

> ImportError: No module named cpp

I fixed this, we should always use absolute package paths when
importing modules:

http://www.python.org/dev/peps/pep-0008/

Kristian

> _______________________________________________
> Mailing list: https://launchpad.net/~fenics
> Post to     : [email-masked]
> Unsubscribe : https://launchpad.net/~fenics
> More help   : https://help.launchpad.net/ListHelp
>