Subject: Re: [Fenics] [Branch ~fenics-core/fenics-doc/main] Rev 123: Add Navier-Stokes demo documentation

From: Marie Rognes <[email-masked]>
Date: Tue, 31 Aug 2010 16:23:53 +0200

On 31. aug. 2010 15:15, [email-masked] wrote:
> ------------------------------------------------------------
> revno: 123
> committer: Anders Logg <[email-masked]>
> branch nick: fenics-doc
> timestamp: Tue 2010-08-31 15:11:27 +0200
> message:
>   Add Navier-Stokes demo documentation
>   

Nice! But it doesn't run:

    meg@localhost
~/local/src/fenics/fenics-doc/source/demos/pde/navier-stokes/python $
python demo.py
Traceback (most recent call last):
  File "demo.py", line 57, in <module>
    L1 = (1/k)*inner(u0, v) + inner(f, v)*dx
TypeError: unsupported operand type(s) for +: 'Product' and 'Form'

(Yes, I know how to fix this one -- but there are some more...)

--
Marie

---

From: Anders Logg <[email-masked]>
Date: Tue, 31 Aug 2010 17:11:27 +0200

> (Yes, I know how to fix this one -- but there are some more...)

I know. I did some "improvements" to the working code while
documenting it so I expect it will be partly broken. I will copy
things over to DOLFIN to check that things work. I also need to
proofread the documentation.

--
Anders