Subject: [FFC-dev] [HG FFC] Tiny fix for Nedelec.

From: [email-masked] (FFC)
Date: Mon, 22 Oct 2007 18:14:17 +0200 (CEST)

One or more new changesets pushed to the primary ffc repository.
A short summary of the last three changesets is included below.

changeset:   988:148ead11f573a002a44b715bea62ef15dc85ff5a
user:        "Anders Logg <[email-masked]>"
date:        Tue Oct 16 00:45:55 2007 +0200
files:       src/test/unit/test.py
description:
Warning! Don't pull this changeset yet.

Merge work on optional remapping of FIAT reference cell by Marie.
This changeset assumes that FIAT has been patched (patch to follow
on fiat-dev) to allow remapping of the reference cell.

Remapping the reference cell on the FIAT side will help with the
following issues:

1. Both FiniteElement.basis() and FiniteElement.tabulate() are
evaluated on the UFC reference element.

2. Scaling integrals and derivatives is no longer necessary in
FFC, which should simplify finding bugs.

changeset:   989:cc2b38891d676040e0f55d02498b22243280ae26
user:        "Kristian Oelgaard <[email-masked]>"
date:        Wed Oct 17 16:33:12 2007 +0200
files:       src/ffc/compiler/codegeneration/common/evaluatebasis.py src/ffc/compiler/codegeneration/common/evaluatebasisderivatives.py src/ffc/compiler/format/codesnippets.py src/ffc/compiler/representation/quadrature/monomialtabulation.py
description:
Warning! Don't pull this changeset yet, need changes in FIAT. Changed the reference element from FIAT to FFC in evaluate_basis() and evaluate_basis_derivatives(). Also removed vscaling and dscaling in monomialtabulation.py as a consequence of the change in reference element.

changeset:   990:b03bb96da30e703021e7acb6239a71288ebc3068
tag:         tip
user:        "Marie E. Rognes <[email-masked]>"
date:        Mon Oct 22 18:10:31 2007 +0200
files:       src/ffc/fem/finiteelement.py
description:
Tiny fix for Nedelec.

----------------------------------------------------------------------
For more details, visit http://www.fenics.org/hg/ffc

---

From: Anders Logg <[email-masked]>
Date: Mon, 22 Oct 2007 21:52:29 +0200

The changesets below appear in the wrong order (latest should be on
top). This bug snuck in while I fixed the "'"/"(" bug but should now
be fixed (hg-notify updated on the server).

/Anders

On Mon, Oct 22, 2007 at 06:14:17PM +0200, FFC wrote:
> _______________________________________________
> FFC-dev mailing list
> [email-masked]
> http://www.fenics.org/mailman/listinfo/ffc-dev