Subject: [FFC-dev] [HG FFC] Finish work on using n = element.cell().n in demos (update references).

From: [email-masked] (FFC)
Date: Tue, 6 Oct 2009 14:49:17 +0200 (CEST)

One or more new changesets pushed to the primary ffc repository.
A short summary of the last three changesets is included below.

changeset:   1677:f6410b6b092a
tag:         tip
user:        "Kristian Oelgaard <[email-masked]>"
date:        Tue Oct 06 14:49:04 2009 +0200
files:       test/regression/reference/quadrature/Biharmonic.h test/regression/reference/quadrature/FacetIntegrals.h test/regression/reference/quadrature/PoissonDG.h test/regression/test.py test/simple_verify_tensors/reference.pickle test/simple_verify_tensors/test.py
description:
Finish work on using n = element.cell().n in demos (update references).

changeset:   1676:0f16b823a975
user:        "Garth N. Wells <[email-masked]>"
date:        Tue Oct 06 12:09:27 2009 +0100
files:       demo/Biharmonic.ufl demo/FacetIntegrals.ufl demo/PoissonDG.ufl
description:
Use n = element.cell().n in demos.

changeset:   1675:860e803f3361
user:        "Kristian Oelgaard <[email-masked]>"
date:        Thu Oct 01 12:19:43 2009 +0200
files:       ffc/compiler/finiteelement.py ffc/fem/createelement.py ffc/fem/finiteelement.py ffc/fem/mixedelement.py ffc/fem/quadratureelement.py test/regression/reference/quadrature/TensorWeightedPoisson.h
description:
A dirty hack to 'support' tensor elements by attaching the rank to mixed elements explicitly when calling create_element().

----------------------------------------------------------------------
For more details, visit http://www.fenics.org/hg/ffc

---

From: Kristian Oelgaard <[email-masked]>
Date: Tue, 06 Oct 2009 13:56:34 +0200

Quoting FFC <[email-masked]>:

> files:       test/regression/reference/quadrature/Biharmonic.h
> test/regression/reference/quadrature/FacetIntegrals.h
> test/regression/reference/quadrature/PoissonDG.h test/regression/test.py
> test/simple_verify_tensors/reference.pickle
> test/simple_verify_tensors/test.py
> description:

Notice that this change made the tests in simple_verify_tensors fail for:

Biharmonic.ufl
FacetIntegrals.ufl
PoissonDG.ufl

because we previously used a vector valued function for the facet normals and we
use a fixed set of coefficient values when computing the element tensors in the
test.
However, the demos in DOLFIN suggests that the implementation is correct so I
simply updated the references.

Kristian

> files:       ffc/compiler/finiteelement.py ffc/fem/createelement.py
> ffc/fem/finiteelement.py ffc/fem/mixedelement.py ffc/fem/quadratureelement.py
> test/regression/reference/quadrature/TensorWeightedPoisson.h
> description:
> A dirty hack to 'support' tensor elements by attaching the rank to mixed
> elements explicitly when calling create_element().
>
> _______________________________________________
> FFC-dev mailing list
> [email-masked]
> http://www.fenics.org/mailman/listinfo/ffc-dev
>

---

From: Anders Logg <[email-masked]>
Date: Tue, 6 Oct 2009 15:37:55 +0200

> simply updated the references.

ok, good.

--
Anders