Subject: [FFC-dev] buildbot failure in FEniCS Buildbot on ffc-linux-64

From: [email-masked]
Date: Wed, 04 Mar 2009 12:21:24 +0100

The Buildbot has detected a new failure of ffc-linux-64 on FEniCS Buildbot.
Full details are available at:
 http://fenics.org:8080/builders/ffc-linux-64/builds/3

Buildbot URL: http://fenics.org:8080/

Buildslave for this Build: linux-64

Build Reason: 
Build Source Stamp: HEAD
Blamelist: k.b.oelgaard

BUILD FAILED: failed ffc check

sincerely,
 -The Buildbot

---

From: Kristian Oelgaard <[email-masked]>
Date: Wed, 04 Mar 2009 12:39:31 +0100

> BUILD FAILED: failed ffc check

I don't get this error. It complains about the JIT compiler not being fast
enough, but it is OK on my computer.

JIT in-memory cache: 9.08374786377e-05
JIT disk cache:      0.116662979126
Reasonable values are 0.002 and 0.03
F..
======================================================================
FAIL: Test that JIT compiler is fast enough.
----------------------------------------------------------------------
Traceback (most recent call last):
  File "test.py", line 254, in testPoisson
    self.assertTrue(dt1 < 0.1) ## Is this threshold too strict??
AssertionError

Kristian

> sincerely,
>  -The Buildbot
>
> _______________________________________________
> FFC-dev mailing list
> [email-masked]
> http://www.fenics.org/mailman/listinfo/ffc-dev
>

---

From: Anders Logg <[email-masked]>
Date: Wed, 4 Mar 2009 13:18:08 +0100

> Reasonable values are 0.002 and 0.03

Something seems to have happened with the disk cache. You get 0.1
seconds. I have

  JIT in-memory cache: 9.70363616943e-05
  JIT disk cache:      0.0144801139832

The disk cache involves computing the signature. Has something change
wrt computing signatures?

-- 
Anders

---

From: Kristian Oelgaard <[email-masked]>
Date: Wed, 04 Mar 2009 13:52:06 +0100

>   JIT disk cache:      0.0144801139832

Yes, I get similar numbers on my machine. The numbers I reported above is from
the buildbot.

> wrt computing signatures?

Not as far as I know.

Kristian

---

From: Anders Logg <[email-masked]>
Date: Wed, 4 Mar 2009 14:08:09 +0100

> Yes, I get similar numbers on my machine. The numbers I reported above is from

ok, so the disk cache/signature computation may be slow on the build
bot. Perhaps we should increase the limit to 0.5s?

-- 
Anders

---

From: Kristian Oelgaard <[email-masked]>
Date: Wed, 04 Mar 2009 14:51:22 +0100

> bot. Perhaps we should increase the limit to 0.5s?

Done.

Kristian