Subject: [FFC-dev] ffc define header error

From: "Andy Ray Terrel" <[email-masked]>
Date: Fri, 26 Sep 2008 15:17:30 +0200

Could we get ffc to be smarter about the header defines.  For example
if I compile a form from a different directory than the form file is
in I get a "/" in the name.

For example:

#ifndef __NORMS/P4VECDIVL2_H
#define __NORMS/P4VECDIVL2_H

But I would prefer:

#ifndef __P4VECDIVL_H
#define __P4VECDIVL2_H

 or

#ifndef __NORMS_P4VECDIVL2_H
#define __NORMS_P4VECDIVL2_H

---

From: Kristian Oelgaard <[email-masked]>
Date: Fri, 26 Sep 2008 16:22:12 +0200

> #define __NORMS/P4VECDIVL2_H

I've implemented this solution, the output from FFC will be located in the same
directory as the form file i.e.,

ffc foo/bar/Poisson.form  --> foo/bar/Poisson.h

but the idefs and class names etc. will only have 'Poisson' as prefix.

Kristian
 
> _______________________________________________
> FFC-dev mailing list
> [email-masked]
> http://www.fenics.org/mailman/listinfo/ffc-dev
>

---

From: "Garth N. Wells" <[email-masked]>
Date: Fri, 26 Sep 2008 22:25:04 +0100

> ffc foo/bar/Poisson.form  --> foo/bar/Poisson.h

I think that

   ffc foo/bar/Poisson.form  --> ./Poisson.h

is what a user would expect.

Garth

---

From: Anders Logg <[email-masked]>
Date: Sat, 27 Sep 2008 08:54:06 +0200

> is what a user would expect.

I agree. In particular, both latex and gcc work like this.

-- 
Anders

---

From: "Andy Ray Terrel" <[email-masked]>
Date: Sat, 27 Sep 2008 10:19:14 +0200

> I agree. In particular, both latex and gcc work like this.

It would probably be good to allow the user to determine where the
file gets written to, both gcc and latex take command line options for
this.

-- Andy