Subject: [Ffc] Misc bugs

From: Anders Logg <[email-masked]>
Date: Tue, 26 Jan 2010 11:12:14 +0100

A list of misc bugs detected by the regression tests:

1. global_dimension

   old = 10003
   new = 10001

2. num_entity_dofs_2

   old = 0
   new = 1

   (related to global_dimension error?)

3. interpolate_vertex_values

   old = 0 0 0
   new = 0.306 0.4256 0.7644

   (strange)

4. evaluate_basis[_derivatives][_all]

   Lots of errors

   One thing to consider might be if the points are chosen
   in a bad way in the regression tests (like outside the cell)

--
Anders

---

From: Marie Rognes <[email-masked]>
Date: Tue, 26 Jan 2010 11:34:49 +0100

>    new = 0.306 0.4256 0.7644

Will look and fix above, unless you have already done so.

--
Marie

> ------------------------------------------------------------------------
>
> _______________________________________________
> Mailing list: https://launchpad.net/~ffc
> Post to     : [email-masked]
> Unsubscribe : https://launchpad.net/~ffc
> More help   : https://help.launchpad.net/ListHelp
>

---

From: Anders Logg <[email-masked]>
Date: Tue, 26 Jan 2010 11:36:19 +0100

> Will look and fix above, unless you have already done so.

No, I was hoping you would fix it.

I'll just sit back now and watch the changesets roll in. :-)

--
Anders

---

From: Marie Rognes <[email-masked]>
Date: Tue, 26 Jan 2010 12:24:15 +0100

>>>   (related to global_dimension error?)

This one seems slightly unfair: num_entity_dofs with modded ffc-0.7.1
always returns zero.

--
Marie

---

From: Anders Logg <[email-masked]>
Date: Tue, 26 Jan 2010 12:28:21 +0100

> This one seems slightly unfair: num_entity_dofs with modded ffc-0.7.1

I forgout about that, so we can do grep -v num_entity_dofs on
errors.log.

--
Anders

---

From: Marie Rognes <[email-masked]>
Date: Tue, 26 Jan 2010 12:34:34 +0100

>>>   new = 0.306 0.4256 0.7644

This one is caused by the very clever reuse of 'values'
in ufctest.h. The argument 'values' is filled by evaluate_dofs, which
(wildly guessing) probably returns zero in the modded 0.7.1 ffc.
Hence the interpolated values are also zero. 

--
Marie