Subject: [Ffc] [Fwd: [Branch ~ffc-core/ffc/main] Rev 1412: Fix silly bug introduced in JIT compiler]

From: "Garth N. Wells" <[email-masked]>
Date: Sun, 07 Feb 2010 22:09:10 +0000

There is a problem when running the DOLFIN demos:

File "/usr/local/lib/python2.6/dist-packages/ffc/jitcompiler.py", line
75, in jit_form
    if form.form_data() is None:
AttributeError: 'Form' object has no attribute 'form_data'

Garth

-------- Original Message --------
Subject: [Branch ~ffc-core/ffc/main] Rev 1412: Fix silly bug
introduced in JIT	compiler
Date: Sun, 07 Feb 2010 21:38:11 -0000
From: [email-masked]
Reply-To: [email-masked]
To: Garth Wells <[email-masked]>

------------------------------------------------------------
revno: 1412
committer: Anders Logg <[email-masked]>
branch nick: ffc-main
timestamp: Sun 2010-02-07 22:36:18 +0100
message:
  Fix silly bug introduced in JIT compiler
modified:
  ffc/jitcompiler.py

--
lp:ffc
https://code.launchpad.net/~ffc-core/ffc/main

Your team FFC Core Team is subscribed to branch lp:ffc.
To unsubscribe from this branch go to
https://code.launchpad.net/~ffc-core/ffc/main/+edit-subscription.

---

From: Anders Logg <[email-masked]>
Date: Sun, 7 Feb 2010 23:54:29 +0100

Looks like you need a new UFL version.

--
Anders

---

From: "Garth N. Wells" <[email-masked]>
Date: Sun, 07 Feb 2010 23:00:19 +0000

> Looks like you need a new UFL version.

I have the latest.

Looking in ufl.Form, I see

   self._form_data = None

and

    def is_preprocessed(self):
        "Check if form has been preprocessed"
        return self._form_data is not None

There is no 'self.form_data'

Garth

> o

---

From: Anders Logg <[email-masked]>
Date: Mon, 8 Feb 2010 00:03:48 +0100

> There is no 'self.form_data'

Sorry, my fault. I pushed the UFL update a while ago but didn't notice
that Kristian had pushed a change to my push was rejected. Merged and
pushed now.

--
Anders