Subject: [Ffc] verbose output

From: "Garth N. Wells" <[email-masked]>
Date: Mon, 03 May 2010 13:09:41 +0100

The FFC man pages says:

-d, --debug
               Debug mode, more output is printed. Conflicts with -s.

The description sounds to me like it should be '-v, --verbose' The 
current flag is confusing when we have '-O' for code optimisation.

Garth

---

From: Anders Logg <[email-masked]>
Date: Mon, 3 May 2010 14:22:59 +0200

> current flag is confusing when we have '-O' for code optimisation.

Yes, -v might be a better choice, but how is it especially confusing
when -O is used?

--
Anders

---

From: "Garth N. Wells" <[email-masked]>
Date: Mon, 03 May 2010 13:28:11 +0100

> Yes, -v might be a better choice, but how is it especially confusing

Because 'debug' and 'optimise' are like brother and sister - both should 
relate to the code (like for gcc). A perfect valid choice would be '-d 
-O' - it is unclear if it's debug or optimise or both?

Garth

---

From: Anders Logg <[email-masked]>
Date: Mon, 3 May 2010 14:41:45 +0200

On Mon, May 03, 2010 at 01:28:11PM +0100, Garth N. Wells wrote:
> Because 'debug' and 'optimise' are like brother and sister - both
> should relate to the code (like for gcc). A perfect valid choice
> would be '-d -O' - it is unclear if it's debug or optimise or both?
>
> Garth

ok, I see. Let's change it.

--
Anders