Subject: [FFC-dev] [Bug 424367] [NEW] compiler stage 3 output

From: oelgaard <[email-masked]>
Date: Fri, 04 Sep 2009 14:38:01 -0000

Public bug reported:

When compiling a form one will always get the output:

Compiler stage 3: Optimizing form representation
------------------------------------------------
  Optimization of tensor contraction representation currently broken (to be fixed).

even if the quadrature representation is being used, which is the
default.

This output should only become active if:
ffc -O -r tensor foo.ufl
was invoked on the command line.

In all other cases there should only be 4 stages.

** Affects: ffc
     Importance: Low
         Status: New

-- 
compiler stage 3 output
https://bugs.launchpad.net/bugs/424367
You received this bug notification because you are subscribed to FFC.

Status in FEniCS Form Compiler: New

Bug description:
When compiling a form one will always get the output:

Compiler stage 3: Optimizing form representation
------------------------------------------------
  Optimization of tensor contraction representation currently broken (to be fixed).

even if the quadrature representation is being used, which is the default.

This output should only become active if:
ffc -O -r tensor foo.ufl
was invoked on the command line.

In all other cases there should only be 4 stages.

---

From: Garth Wells <[email-masked]>
Date: Fri, 04 Sep 2009 14:45:48 -0000

** Changed in: ffc
       Status: New => Confirmed

Status in FEniCS Form Compiler: Confirmed

Bug description:

---

From: Garth Wells <[email-masked]>
Date: Thu, 24 Sep 2009 07:38:38 -0000

** Changed in: ffc
    Milestone: None => 0.7.1

Bug description: