Subject: [FFC-dev] another ffc issue

From: Robert C. Kirby <[email-masked]>
Date: Wed, 15 Feb 2006 16:07:06 -0600

Hi, I have the latest ffc from mercurial, I'm trying to compile
the weighted Laplacian to do some ferari tests and get coefficient
errors

def main():
     shape = "triangle"
     degree = 2
     el = FiniteElement("Lagrange",shape,degree)
     k = Index()
     dx = Integral( "interior" )
     u = BasisFunction( el )
     v = BasisFunction( el )
     w = Function( el )
     lap = w * u.dx(k)*v.dx(k)*dx
     formc = build( lap , "ferariform" , "raw"
     .
     .
     .

Gives the message:

Compiling form: w0_a0(dXa1/dxb0)(dXa2/dxb0) |  
va0*((d/dXa1)vi0)*((d/dXa2)vi1)*dX
Finite element of test space:  Lagrange finite element of degree 2 on a  
Triangle with 1 components
Finite element of trial space: Lagrange finite element of degree 2 on a  
Triangle with 1 components
Finite elements for functions: [Lagrange finite element of degree 2 on  
a Triangle with 1 components]
Compiling tensor representation for interior
Computing reference tensor, this may take some time...
Computing the reference tensor (864 entries), this may take some time...
........................................................................ 
........
Reference tensor computed in 0.0297 seconds.
Compiling tensor representation for boundary
Traceback (most recent call last):
   File "pg.py", line 394, in ?
     main()
   File "pg.py", line 364, in main
     formc = build( lap , "ferariform" , "raw" )
   File  
"/Users/kirby//lib/python2.4/site-packages/ffc/compiler/compiler.py",  
line 139, in build
     form.cK = __compute_coefficients(form.projections, format, cK_used)
   File  
"/Users/kirby//lib/python2.4/site-packages/ffc/compiler/compiler.py",  
line 202, in __compute_coefficients
     value = format.format["coefficient table"](n0, k)
KeyError: 'coefficient table'

Robert C. Kirby
Assistant Professor
Department of Computer Science
The University of Chicago
http://people.cs.uchicago.edu/~kirby
"Mathematical software should be mathematical."

---

From: Anders Logg <[email-masked]>
Date: Wed, 15 Feb 2006 16:08:14 -0600

Seems I forgot to update the "raw" format when modifying the format
dictionary. I'll make a fix.

/Anders

On Wed, Feb 15, 2006 at 04:07:06PM -0600, Robert C.Kirby wrote:
> _______________________________________________
> FFC-dev mailing list
> [email-masked]
> http://www.fenics.org/cgi-bin/mailman/listinfo/ffc-dev
> 

-- 
Anders Logg
Research Assistant Professor
Toyota Technological Institute at Chicago
http://www.tti-c.org/logg/