Subject: [Ffc] Regression test update

From: Anders Logg <[email-masked]>
Date: Fri, 29 Jan 2010 18:56:45 +0100

It keeps getting better. Here are the current tests that fail.

Generating code (33 form files found)
-------------------------------------
  ElementRestriction.ufl failed
  QuadratureElement.ufl

Validating generated programs (31 programs found)
-------------------------------------------------
  MixedPoisson.out differs
    evaluate_basis_derivatives
    interpolate_vertex_values

  P5tet.out differs
    round-off errors

  P5tri.out differs
    round-off errors

  SubDomain.out differs
    changed behavior

  VectorLaplaceGradCurl.out differs
    evaluate_basis_derivatives
    interpolate_vertex_values

I think P5tri, P5tet and SubDomain can be safely ignored. Can the
others also be ignored?

I've attached error.log.

--
Anders

---

From: Kristian Oelgaard <[email-masked]>
Date: Fri, 29 Jan 2010 19:26:46 +0100 (CET)

> Generating code (33 form files found)

I fixed QuadratureElement, but it won't work until we figure out how to handle the degrees of forms and elements.

> Validating generated programs (31 programs found)

I get matching results for linear BDM and N1curl, so I would expect the derivatives to work as well.
On the positive side, it looks like evaluate_basis agrees with FIAT on all supported elements on the reference cells.

Kristian

> I've attached error.log.
>
> --
> Anders
>
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v1.4.9 (GNU/Linux)
>
> iEYEARECAAYFAktjIVwACgkQTuwUCDsYZdHDfwCfVJ1+r5SMwYjXrAE8GsZmhd95
> FpkAn2IzPU/B5bSUS5/2AI0XZsvceMvP
> =bJUz
> -----END PGP SIGNATURE-----
>
> _______________________________________________
> Mailing list: https://launchpad.net/~ffc
> Post to     : [email-masked]
> Unsubscribe : https://launchpad.net/~ffc
> More help   : https://help.launchpad.net/ListHelp
>
>

---

From: Anders Logg <[email-masked]>
Date: Fri, 29 Jan 2010 21:47:50 +0100

> I fixed QuadratureElement, but it won't work until we figure out how to handle the degrees of forms and elements.

I've fixed the representation selection now so that quadrature is
selected. It now fails with another error:

  File
  "/home/logg/scratch/lib/fenics-dev/lib/python2.6/site-packages/ffc/quadrature/quadraturetransformerbase.py",
  line 1110, in _create_function_name
    quad_offset += ffc_element.sub_element(i).space_dimension()
AttributeError: MixedElement instance has no attribute 'sub_element'

--
Anders

---

From: Kristian Oelgaard <[email-masked]>
Date: Fri, 29 Jan 2010 22:11:19 +0100 (CET)

> selected. It now fails with another error:

Not with the latest FFC :)

Kristian

> iEYEARECAAYFAktjSXUACgkQTuwUCDsYZdG3ZwCffkOenqodhtZivSLVr1CsBahO
> TeoAniXH4/e2sfeBtIm8+eG5dd8xwGIQ
> =DDkU

---

From: Anders Logg <[email-masked]>
Date: Sat, 30 Jan 2010 00:22:31 +0100

> Not with the latest FFC :)

Yes, sorry my fault. I didn't notice you had pushed.

It works perfectly now! :-)

Looks like it's just the restriction thing that is missing now.

--
Anders

---

From: Marie Rognes <[email-masked]>
Date: Sat, 30 Jan 2010 15:34:30 +0100

> Looks like it's just the restriction thing that is missing now.

The ElementRestriction demo is now running.  Don't know if it is 
correct. Need reference.

Constructing restricted elements should work for wild combinations of 
mixed elements etc,
but something seems to go wrong in the monomialtransformation for the 
commented
part of the ElementRestriction demo.

--
Marie

> --
> Anders
>   
> ------------------------------------------------------------------------
>

---

From: "Garth N. Wells" <[email-masked]>
Date: Sat, 30 Jan 2010 14:51:06 +0000

Marie Rognes wrote:
>>>>> I fixed QuadratureElement, but it won't work until we figure out
>>>>> how to handle the degrees of forms and elements.
>>>>>         

I've just fixed the commented parts. The syntax was wrong.

Garth