Subject: Re: [Ffc] [Branch ~ffc-core/ffc/main] Rev 1438: Added support for Bubble elements, using ElementRestriction of a

From: "Garth N. Wells" <[email-masked]>
Date: Sun, 07 Mar 2010 18:56:48 +0000

[email-masked] wrote:
> ------------------------------------------------------------
> revno: 1438
> committer: Marie E. Rognes <[email-masked]>
> branch nick: ffc
> timestamp: Sun 2010-03-07 19:15:05 +0100
> message:
>   Added support for Bubble elements, using ElementRestriction of a
>   Lagrange element of degree (geometric_dimension + 1) to interior.
>   

Nice. Any thoughts on how to solve for the internal dof? Static
condensation is on the DOLFIN Blueprint list.

Garth

>   Example: For triangles, the bubble element is the span of the single
>   CG_3 interior basis function.
> modified:
>   ffc/fiatinterface.py
> 
> 
> --
> lp:ffc
> https://code.launchpad.net/~ffc-core/ffc/main
> 
> Your team FFC Core Team is subscribed to branch lp:ffc.
> To unsubscribe from this branch go to https://code.launchpad.net/~ffc-core/ffc/main/+edit-subscription.
>

---

From: Marie Rognes <[email-masked]>
Date: Sun, 07 Mar 2010 21:45:59 +0100

Garth N. Wells wrote:
> Nice. Any thoughts on how to solve for the internal dof? 

Within ffc? No, not really.

> Static condensation is on the DOLFIN Blueprint list.
>
>   

Well, that sounds like a good plan to carry out then ;)

What is static condensation exactly? (Beyond being an algorithm for
eliminating internal dofs.)

--
Marie

> _______________________________________________
> Mailing list: https://launchpad.net/~ffc
> Post to     : [email-masked]
> Unsubscribe : https://launchpad.net/~ffc
> More help   : https://help.launchpad.net/ListHelp
>

---

From: "Garth N. Wells" <[email-masked]>
Date: Sun, 07 Mar 2010 20:59:09 +0000

> eliminating internal dofs.)

That's all it is. The name is historical.

Garth

>>> To unsubscribe from this branch go to
>>> https://code.launchpad.net/~ffc-core/ffc/main/+edit-subscription.
>>>
>>>     
>>