Subject: [FFC-dev] commented lines

From: "Garth N. Wells" <[email-masked]>
Date: Mon, 30 Apr 2007 10:01:14 +0200

For some forms, a lot of lines are commented out in the FFC output. 
Could these lines be removed? For the Cahn-Hilliard demo, the output 
files are huge (>6MB for 3D).

Garth

---

From: Anders Logg <[email-masked]>
Date: Mon, 30 Apr 2007 13:24:36 +0200

> files are huge (>6MB for 3D).

The commented lines are for variables that are never used (which gcc
will complain about). FFC searches the generated code (backwards) to
find variables that are not used and removes those variables (and any
other variables that be become unused as a result).

I currently replace those lines with a comment for clarity, but it's
just as simple just to remove the lines.

/Anders