Subject: [Ffc] Some various questions

From: Marie Rognes <[email-masked]>
Date: Wed, 24 Mar 2010 17:31:33 +0100

(1) ffc does not expose ufl. Is this intentional? For instance, the
following gives a "FiniteElement not defined error"

    from ffc import *
    element = FiniteElement("CG", "triangle", 1)

(2) What is the purpose of the argument 'object_names' to
'compile_element'? It does not seem to be used anywhere.

(3) Where is the output argument 'forms' of 'compile_form' used? I
thought it was used by the jitcompiler, but that does not seem to be
the case.

--
Marie

---

From: Kristian Oelgaard <[email-masked]>
Date: Wed, 24 Mar 2010 19:36:33 +0100 (CET)

>   element = FiniteElement("CG", "triangle", 1)

I don't think we should make FiniteElement part of ffc. It belongs in UFL and when you need it, import it.

> 'compile_element'? It does not seem to be used anywhere.

I think it only makes sense in compile_form, to get correct names for Coefficients (like f, g) and stuff, so that can be deleted.

> thought it was used by the jitcompiler, but that does not seem to be

Don't know.

Kristian

> --
> Marie
>
>
> _______________________________________________
> Mailing list: https://launchpad.net/~ffc
> Post to     : [email-masked]
> Unsubscribe : https://launchpad.net/~ffc
> More help   : https://help.launchpad.net/ListHelp
>

---

From: Anders Logg <[email-masked]>
Date: Wed, 24 Mar 2010 20:21:32 +0100

> I don't think we should make FiniteElement part of ffc. It belongs in UFL and when you need it, import it.

Agree.

> I think it only makes sense in compile_form, to get correct names for Coefficients (like f, g) and stuff, so that can be deleted.

Agree.

> >thought it was used by the jitcompiler, but that does not seem to be

It was used before, but not since we changed the JIT compiler so that
it calls preprocess itself before calling compile_form.

So it can be removed.

--
Anders

---

From: Marie Rognes <[email-masked]>
Date: Wed, 24 Mar 2010 20:22:34 +0100

> it calls preprocess itself before calling compile_form.

Ok!

--
Marie

---

From: Anders Logg <[email-masked]>
Date: Thu, 25 Mar 2010 22:19:13 +0100

> >it calls preprocess itself before calling compile_form.

Done!

--
Anders