Subject: [Ffc] Patch for a bugg in FFC

From: Johan Hake <[email-masked]>
Date: Mon, 22 Nov 2010 12:43:53 -0800

Hello!

A well hidden bug is fixed in the attached patch. 

When unused variables are removed by just removing the line it is defined on 
it is good to define the variable on a single line. Otherwise the code wont 
compile...

Johan
# Bazaar merge directive format 2 (Bazaar 0.90)
# revision_id: [email-masked]
# target_branch: bzr+ssh://bazaar.launchpad.net/~ffc-core/ffc/main/
# testament_sha1: b5fca4c7c005bb8d837c248f61df08c598bac4d6
# timestamp: 2010-11-22 12:41:28 -0800
# base_revision_id: [email-masked]
# 
# Begin patch
=== modified file 'ffc/codesnippets.py'
--- ffc/codesnippets.py	2010-07-08 14:24:27 +0000
+++ ffc/codesnippets.py	2010-11-22 20:39:21 +0000
@@ -165,26 +165,11 @@
 const unsigned int v2 = face_vertices[facet%(restriction)s][2];
 
 // Compute scale factor (area of face scaled by area of reference triangle)
-const double a0 = (x%(restriction)s[v0][1]*x%(restriction)s[v1][2]
-                 + x%(restriction)s[v0][2]*x%(restriction)s[v2][1]
-                 + x%(restriction)s[v1][1]*x%(restriction)s[v2][2])
-                - (x%(restriction)s[v2][1]*x%(restriction)s[v1][2]
-                 + x%(restriction)s[v2][2]*x%(restriction)s[v0][1]
-                 + x%(restriction)s[v1][1]*x%(restriction)s[v0][2]);
-
-const double a1 = (x%(restriction)s[v0][2]*x%(restriction)s[v1][0]
-                 + x%(restriction)s[v0][0]*x%(restriction)s[v2][2]
-                 + x%(restriction)s[v1][2]*x%(restriction)s[v2][0])
-                - (x%(restriction)s[v2][2]*x%(restriction)s[v1][0]
-                 + x%(restriction)s[v2][0]*x%(restriction)s[v0][2]
-                + x%(restriction)s[v1][2]*x%(restriction)s[v0][0]);
-
-const double a2 = (x%(restriction)s[v0][0]*x%(restriction)s[v1][1]
-                 + x%(restriction)s[v0][1]*x%(restriction)s[v2][0]
-                 + x%(restriction)s[v1][0]*x%(restriction)s[v2][1])
-                - (x%(restriction)s[v2][0]*x%(restriction)s[v1][1]
-                 + x%(restriction)s[v2][1]*x%(restriction)s[v0][0]
-                 + x%(restriction)s[v1][0]*x%(restriction)s[v0][1]);
+const double a0 = (x%(restriction)s[v0][1]*x%(restriction)s[v1][2] + x%(restriction)s[v0][2]*x%(restriction)s[v2][1] + x%(restriction)s[v1][1]*x%(restriction)s[v2][2]) - (x%(restriction)s[v2][1]*x%(restriction)s[v1][2] + x%(restriction)s[v2][2]*x%(restriction)s[v0][1] + x%(restriction)s[v1][1]*x%(restriction)s[v0][2]);
+
+const double a1 = (x%(restriction)s[v0][2]*x%(restriction)s[v1][0] + x%(restriction)s[v0][0]*x%(restriction)s[v2][2] + x%(restriction)s[v1][2]*x%(restriction)s[v2][0]) - (x%(restriction)s[v2][2]*x%(restriction)s[v1][0] + x%(restriction)s[v2][0]*x%(restriction)s[v0][2] + x%(restriction)s[v1][2]*x%(restriction)s[v0][0]);
+
+const double a2 = (x%(restriction)s[v0][0]*x%(restriction)s[v1][1] + x%(restriction)s[v0][1]*x%(restriction)s[v2][0] + x%(restriction)s[v1][0]*x%(restriction)s[v2][1]) - (x%(restriction)s[v2][0]*x%(restriction)s[v1][1] + x%(restriction)s[v2][1]*x%(restriction)s[v0][0] + x%(restriction)s[v1][0]*x%(restriction)s[v0][1]);
 
 const double det = std::sqrt(a0*a0 + a1*a1 + a2*a2);"""

# Begin bundle

---

From: Anders Logg <[email-masked]>
Date: Mon, 22 Nov 2010 22:34:49 +0100

Great, pushed.

--
Anders

> IyBCYXphYXIgcmV2aXNpb24gYnVuZGxlIHY0CiMKQlpoOTFBWSZTWZZF6CoAAfffgAAQUvv//1NQ
> AAq////wUAQNPOqq3LlUOjgklNU9NJsTSZink2kIzQE0GjTQNBkSaGEaCelPU0aGgA9IAAA02qTR
> TeqbUbUBtTQ0AyAGhiDQwAAAAAAAAAACSQmQEYgaMgk2p4kyaaBkGifKVLl5k9FdBViqkBmFRVU6
> uKN0G/BasquBSqndIwz0eq1VUTxPExTtJTs85wf2CJaJTU8tuvWR7NTpT47klWSeOLPyyqBkfwII
> 7jWCBhX3imBAwgckpFZKdLkwnzFPdYBJNb8x9IoszgK0rFI9ZK8McV0Ip6nvdyWDCHIXTmPF1fdu
> F7ah6iRHtVQvUF/QVI80lDjss6LawM/xkI9GWB2vOGrPEV+eU8w8VFNN2XpbC4sW76sXByDOQ5mD
> dyLhyuW8uUS1gHWAVxCZzZyUMqTfLehWCrLDQKVu+IoiminhS02OK2bY1RWE0AmAZgFl3AKpRWRy
> BwraMDHfF2y8Ug7aauoLInjwgixzPsTiFu1xW424YTXthxdGlOM8tZZGcNk+p7Qcxi+N9iixIi/F
> j5RNqDUYQoznN7cbWgskyMTRfF5Ba30R4WQhfWUXw0NdPdGFme0uthPFnmZERQDRBoiysWhgvfGB
> eiPhKpq0i42MFClK0aHAVOTQ7s0RXY8DZDU2flsc9Lio76Ybm2iVuAILgQUTTwEBAANgAIQIRAhC
> YMAYNgxgMTBgDCy64SrzVKnNDUkslJX9NV6wrZvzV2TPy9+9j2hYB9ZEnX6aeyeHSRofgWqek1xD
> mszwabLCEpNpe91Ddf8AjlUT7sqsi9WUbsaG5821gXWrsRBBWn539algTLsYQiuGi3zX2tS3HIxV
> EbxdfJg73JOLSzR7w6u23V27GgiiCTScWtofbfaG0lUtvrhibu5wFWLOb0y3UyZOG+ZWkgQOgmSc
> GpSU3lYduzzEOnSw/WXPcxMeFazbUfYDni0eTVhwMQ0c2bvd11PJ1hvD1QwIN/VNCRpA2q6AywPE
> K3fy+6EgQSDMpd4cvebJLEu3VtcBoDeK8XgocQMA8CIrAsh6JrWJl5hOZDNCmItko0ElwA8gOCo0
> BIp28RT0EpElI6ugzZpAIxfAHthoW36KXjJUE7JmTLutWSvo/z0EQBGilo2gVnRTQHQ6DqlNEKii
> sCJ1tkXcOXhiJpAGMYi6Agp4WkJ+/SCClM66EAumWxeoIHYvjpsMmqs8VUD6TBqA1ppwYEDZi3Mn
> Qmg3EmZ0qzuaM++kyBBSFCYEDVKZyzSVmy8ThZLfTm3C9koSmrYirDAl7xLMo2LnkIBAJppppppg
> gEHWq4uwWRji1TjwjHw5Yavoq5xn/xdyRThQkJZF6Co=

> _______________________________________________
> Mailing list: https://launchpad.net/~ffc
> Post to     : [email-masked]
> Unsubscribe : https://launchpad.net/~ffc
> More help   : https://help.launchpad.net/ListHelp