Subject: [FFC-dev] Add new XML output format. This format will be used for two purposes: [...]

From: [email-masked]
Date: Thu, 29 Sep 2005 21:05:33 +0200

Commit from logg (2005-09-29 21:05 CEST)
----------------

Add new XML output format. This format will be used for two purposes:

  - When compiling forms for DOLFIN with the -a blas option. Data will
    be read at runtime, rather than compiling all data into the binary.

  - To cache form building blocks (terms) to /var/cache/ffc (or similar).
    The plan is to have FFC look in /var/cache/ffc to see if previously
    computed data can be reused (same as LaTeX caching of fonts).

None of these are implemented at present.

To compile for XML, add the flag -l xml:

  ffc -l xml Poisson.form

  ffc  ChangeLog                            1.82
  ffc  TODO                                 1.43
  ffc  doc/man/man1/ffc.1.gz                1.4
  ffc  src/bin/ffc                          1.26
  ffc  src/ffc/compiler/compiler.py         1.27
  ffc  src/ffc/compiler/elementtensor.py    1.15
  ffc  src/ffc/compiler/geometrytensor.py   1.13
  ffc  src/ffc/compiler/referencetensor.py  1.13
  ffc  src/ffc/compiler/term.py             1.4
  ffc  src/ffc/format/ase.py                1.6
  ffc  src/ffc/format/dolfin.py             1.41
  ffc  src/ffc/format/latex.py              1.14
  ffc  src/ffc/format/raw.py                1.11
+ ffc  src/ffc/format/xml.py                1.1

---

From: Anders Logg <[email-masked]>
Date: Thu, 29 Sep 2005 14:15:21 -0500

> Commit from logg (2005-09-29 21:05 CEST)

Note, should be -f blas.

/Anders
 
> _______________________________________________
> FFC-dev mailing list
> [email-masked]
> http://www.fenics.org/cgi-bin/mailman/listinfo/ffc-dev
> 

-- 
Anders Logg
Research Assistant Professor
Toyota Technological Institute at Chicago
http://www.tti-c.org/logg/