Subject: [FFC-dev] Compiling elements

From: "Garth N. Wells" <[email-masked]>
Date: Sat, 07 Mar 2009 11:07:02 +0000

I've tried to compile an element with DOLFIN wrappers, but the wrapper 
code is somewhat unexpected. From

     element = VectorElement("Lagrange", "triangle", 2)

with 'ffc -l dolfin'

I get

     class Velocity : public dolfin::Form
     {
     public:

       // Create form
       Velocity() : dolfin::Form()
       {
         _ufc_form = boost::shared_ptr<const ufc::form>(new UFC_Velocity());
       }

       // Destructor
       ~Velocity() {}

     };

FFC should generate a dolfin::FunctionSpace rather than a dolfin::Form.

Garth

---

From: Kristian Oelgaard <[email-masked]>
Date: Sat, 07 Mar 2009 13:13:08 +0100

> FFC should generate a dolfin::FunctionSpace rather than a dolfin::Form.

I tried to fix this, see if it works now. Did this ever work by the way? I
couldn't find a changeset where it did.

Kristian

> Garth
> _______________________________________________
> FFC-dev mailing list
> [email-masked]
> http://www.fenics.org/mailman/listinfo/ffc-dev
>

---

From: "Garth N. Wells" <[email-masked]>
Date: Sat, 07 Mar 2009 12:39:29 +0000

Kristian Oelgaard wrote:
> I tried to fix this, see if it works now.

It's still generating a form and trying to create a UFC object that 
doesn't exists.

> Did this ever work by the way? I

I had never tried it.

Garth

---

From: Kristian Oelgaard <[email-masked]>
Date: Sat, 07 Mar 2009 14:02:52 +0100

> It's still generating a form and trying to create a UFC object that

Try again now.

> > couldn't find a changeset where it did.

OK.

Kristian

---

From: "Garth N. Wells" <[email-masked]>
Date: Sat, 07 Mar 2009 13:15:19 +0000

>> It's still generating a form and trying to create a UFC object that

Works now. Thanks.

Just an aesthetic detail - the wrapper code class shouldn't be indented.

Garth