Subject: Re: [FFC-dev] [DOLFIN-dev] buildbot failure in mac_osx

From: "Garth N. Wells" <[email-masked]>
Date: Mon, 16 Feb 2009 12:13:45 +0000

Looks like an FFC problem due to UFL is not being installed.

Garth

[email-masked] wrote:
> The Buildbot has detected a new failure of mac_osx.
> Full details are available at:
>  http://fenics.org:8010/dolfin/mac_osx/builds/1302
> 
> Buildbot URL: http://fenics.org:8010/dolfin/
> 
> Buildslave for this Build: mac-osx
> 
> Build Reason: 
> Build Source Stamp: HEAD
> Blamelist: Anders Logg,Garth N. Wells
> 
> BUILD FAILED: failed test
> 
> sincerely,
>  -The Buildbot
> 
> _______________________________________________
> DOLFIN-dev mailing list
> [email-masked]
> http://www.fenics.org/mailman/listinfo/dolfin-dev

---

From: "Johannes Ring" <[email-masked]>
Date: Mon, 16 Feb 2009 13:23:08 +0100 (CET)

Hi,

please apply the attached patch that modifies test/test.py so that it
returns an error code different from zero (success) on failure. This way
the buildbot will notify ffc-dev when some of the tests fails.

Johannes
# HG changeset patch
# User Johannes Ring <[email-masked]>
# Date 1234786232 -3600
# Node ID 98ac7c4aecf4f6c960102a3e205ff93a14801af2
# Parent  82bdc244ad7f6650e13da7e554d39fffc5ed6fc7
Return error code != 0 on failure.

diff -r 82bdc244ad7f -r 98ac7c4aecf4 test/test.py
--- a/test/test.py	Mon Feb 16 12:34:35 2009 +0100
+++ b/test/test.py	Mon Feb 16 13:10:32 2009 +0100
@@ -7,16 +7,23 @@
 
 import os
 import re
+import sys
 
 pwd = os.path.dirname(os.path.abspath(__file__))
 
 # Tests to run
 tests = ["unit", "regression"]
 
+failed = []
+
 # Run tests
 for test in tests:
     print "Running tests: %s" % test
     print "----------------------------------------------------------------------"
     os.chdir(os.path.join(pwd, test))
-    os.system("python test.py")
+    failure = os.system("python test.py")
+    if failure:
+        failed.append(test)
     print ""
+
+sys.exit(len(failed))