Subject: [FFC-dev] Error while compiling a form file

From: Reza Farrahi Moghaddam <[email-masked]>
Date: Sat, 19 Apr 2008 12:41:11 -0700 (PDT)

I got an error on compiling a FORM file using FFC. The "a" and "l" have several terms. After a long time, it stopped on the computing tensor rep of 229 term. Is it a low disk space error? or memory error?
 
The form file is attached.
 
Any advice?
 
Here is the end part of the log of "ffc -l dolfin NonlinearPoisson.form":
.
.
.
    Computing tensor representation for term 1067... factorized
    Computing tensor representation for term 1068... factorized
    Computing tensor representation for term 1069... factorized
    
  Computing exterior facet tensors
  --------------------------------
  
    No terms
    
  Computing interior facet tensors
  --------------------------------
  
    No terms

Compiler phase 3: Computing optimization
----------------------------------------
  Not implemented
  
Compiler phase 4: Generating code
---------------------------------
  Generating code for finite elements... done
  Generating code for finite dof maps... done
  Generating code for cell integrals... done
  Generating code for exterior facet integrals... done
  Generating code for interior facet integrals... done
  Generating code for form... done
  
Phase 1: Analyzing form
-----------------------
  Checking validity of form... ok
  Reassigning form indices... done
  Checking validity of form... ok
  Simplifying form... Reassigning form indices...
  done
  Reassigning form indices... done
  Reassigning form indices... done
  done
  Checking validity of form... ok
  Determining the range of the indices... done
  Checking validity of form... ok
  Extracting form data... done
  
  Rank of form: 1
  Coefficients: 4
  Arguments:    5
  Terms:        871
  
Compiler phase 2: Computing form representation
-----------------------------------------------
  Computing cell tensor
  ---------------------
  
    Number of terms to consider: 871
    Computing factorization... done
    Number of terms to compute: 101
    Computing tensor representation for term 0... done
.
.
.
    Computing tensor representation for term 225... factorized
    Computing tensor representation for term 226... factorized
    Computing tensor representation for term 227... factorized
    Computing tensor representation for term 228... factorized
    Computing tensor representation for term 229... factorized
*** 
*** To get more information about this error, rerun ffc with the option -d1.

      __________________________________________________________________
Be smarter than spam. See how smart SpamGuard is at giving junk email the boot with the All-new Yahoo! Mail.  Click on Options in Mail and switch to New Mail today or register for free at http://mail.yahoo.ca

---

From: Anders Logg <[email-masked]>
Date: Mon, 21 Apr 2008 18:14:55 +0200

You have an awful lot of terms in your form. Try removing them one by
one to isolate the simplest possible form which does not work.

-- 
Anders

On Sat, Apr 19, 2008 at 12:41:11PM -0700, Reza Farrahi Moghaddam wrote:
> I got an error on compiling a FORM file using FFC. The "a" and "l" have several
> terms. After a long time, it stopped on the computing tensor rep of 229 term.
> Is it a low disk space error? or memory error?
>  
> ━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
> Looking for the perfect gift? Give the gift of Flickr!

> _______________________________________________
> FFC-dev mailing list
> [email-masked]
> http://www.fenics.org/mailman/listinfo/ffc-dev