Subject: [Ffc] Handling 1D problem

From: Anders Logg <[email-masked]>
Date: Sun, 31 Jan 2010 13:21:18 +0100

The 1D Poisson demo in DOLFIN is failing with the following error:

  Don't know how to create UFC simplex for dimension 0

This comes from the function ufc_simplex in FIAT. How were 0D elements
handled before? Does anyone know how to fix this? Kristian?

--
Anders

---

From: "Garth N. Wells" <[email-masked]>
Date: Sun, 31 Jan 2010 13:09:26 +0000

> handled before? Does anyone know how to fix this? Kristian?

We now get:

 error: 'detJ' was not declared in this scope

Garth

> --
> Anders
> 
> 
> ------------------------------------------------------------------------
> 
> _______________________________________________
> Mailing list: https://launchpad.net/~ffc
> Post to     : [email-masked]
> Unsubscribe : https://launchpad.net/~ffc
> More help   : https://help.launchpad.net/ListHelp

---

From: Anders Logg <[email-masked]>
Date: Sun, 31 Jan 2010 14:12:19 +0100

>  error: 'detJ' was not declared in this scope

Not for me, the 1D demo works here.

--
Anders

---

From: "Garth N. Wells" <[email-masked]>
Date: Sun, 31 Jan 2010 13:13:04 +0000

> Not for me, the 1D demo works here.

When you compile the C++ code?

Garth

---

From: Anders Logg <[email-masked]>
Date: Sun, 31 Jan 2010 14:13:41 +0100

>  error: 'detJ' was not declared in this scope

Sorry, I was too quick. I didn't look at the compilation.

Looks like something wrong with the codesnippets for 1D.

--
Anders

---

From: Anders Logg <[email-masked]>
Date: Sun, 31 Jan 2010 14:19:20 +0100

>  error: 'detJ' was not declared in this scope

Works now and the solution looks correct.

--
Anders

---

From: "Garth N. Wells" <[email-masked]>
Date: Sun, 31 Jan 2010 13:25:43 +0000

> Works now and the solution looks correct.

OK. I'm compiling all the demo so I can run the tests. On the C++ side,
only a problem so far with poisson1D (which is reported to be fixed now)
and cahn-hilliard, which looks like a problem with -f split.

I expect some problem with the Python demos associated with the auto
selection of the cell.

Garth

---

From: "Garth N. Wells" <[email-masked]>
Date: Sun, 31 Jan 2010 15:11:29 +0000

> Works now and the solution looks correct.

Python version is broken.

Garth