Subject: [FFC-dev] Python version

From: Marie Rognes <[email-masked]>
Date: Thu, 19 Jun 2008 13:36:05 +0200

Does ffc now officially depend on Python 2.5?

-- 
Marie E. Rognes
Ph.D Fellow, 
Centre of Mathematics for Applications, 
University of Oslo
http://folk.uio.no/meg

---

From: Anders Logg <[email-masked]>
Date: Fri, 20 Jun 2008 23:25:01 +0200

> Does ffc now officially depend on Python 2.5?

I'm not sure. Do we use something which was not in Python 2.4?

I don't think it's a problem to depend on 2.5 anymore.

-- 
Anders

---

From: [email-masked]
Date: Sat, 21 Jun 2008 14:00:03 +0200 (CEST)

> I'm not sure. Do we use something which was not in Python 2.4?

Yes.

all(list) does not exist in Python2.4 cf. tensorgenerator.py

--
Marie

---

From: Anders Logg <[email-masked]>
Date: Sun, 22 Jun 2008 23:45:18 +0200

> all(list) does not exist in Python2.4 cf. tensorgenerator.py

ok, I wasn't aware this was introduced in 2.5.

So yes, we now officially depend on Python 2.5. :-)

-- 
Anders