Subject: [Ffc] Regression test for HyperElasticity

From: Anders Logg <[email-masked]>
Date: Wed, 3 Feb 2010 13:21:15 +0100

The regression test is failing of HyperElasticity. I guess this is
after the recent work on stripping variables?

Is this demo ok so we can update the reference?

--
Anders

---

From: Kristian Oelgaard <[email-masked]>
Date: Wed, 3 Feb 2010 13:27:51 +0100 (CET)

> Is this demo ok so we can update the reference?

I pushed a fix to ufl, and the tests are green apart from MixedMixedElement for which I get:

346_evaluate_dof_6: values differ
  old = 0.645561
  new = 0.645562
355_evaluate_dofs: values differ
  old = -0.844483 -0.984214 -1.12569 0.04968 0.063168 0.077184 0.645561 0.71467 0.752005 0.055611 0.0594 0.068229 -0.824896 -0.8811 -1.01206
  new = -0.844483 -0.984214 -1.12569 0.04968 0.063168 0.077184 0.645562 0.71467 0.752005 0.055611 0.0594 0.068229 -0.824896 -0.8811 -1.01206

a tolerance issue.

Kristian

> --
> Anders
>
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v1.4.9 (GNU/Linux)
>
> iEYEARECAAYFAktpajoACgkQTuwUCDsYZdHgOwCbBRxQ/rW8EBSMoQ5Z3EFPfDQX
> aRQAniTR0vkzJqokdKJeVxcCK/EGqF+o
> =fmDC
> -----END PGP SIGNATURE-----
>
> _______________________________________________
> Mailing list: https://launchpad.net/~ffc
> Post to     : [email-masked]
> Unsubscribe : https://launchpad.net/~ffc
> More help   : https://help.launchpad.net/ListHelp
>
>

---

From: Anders Logg <[email-masked]>
Date: Wed, 3 Feb 2010 13:46:32 +0100

>  new = -0.844483 -0.984214 -1.12569 0.04968 0.063168 0.077184 0.645562 0.71467 0.752005 0.055611 0.0594 0.068229 -0.824896 -0.8811 -1.01206

ok, nice. I'll increase it to 1e-5. Soon we'll be at 0.1...

--
Anders

---

From: Anders Logg <[email-masked]>
Date: Wed, 3 Feb 2010 20:03:18 +0100

> ok, nice. I'll increase it to 1e-5. Soon we'll be at 0.1...

Fixed, finally, with a tolerance of 1e-9.

The problem was comparison of strings rather than float values with a
tolerance. I thought initially it would be enough to just compare the
strings and make sure those string values are printed out with only a
certain number of decimals, but we kept being screwed over by values
like

  0.0625000000000000001
  0.0624999999999999999

Which are rounded to different numbers...

--
Anders

---

From: Kristian Oelgaard <[email-masked]>
Date: Wed, 3 Feb 2010 20:08:38 +0100 (CET)

> certain number of decimals, but we kept being screwed over by values

Yes, I noticed that I was still getting errors, but good that you fixed it. I'm cleaning up the parts of the code I've been working on the most including some of the code in cpp.py.

Kristian

> iEYEARECAAYFAktpyHYACgkQTuwUCDsYZdF/qwCeOB1nj37JrAggBHGgXKZLVk/m
> RyQAnRCqEgrAGudiwoCMttbEPSqiHW5c
> =wp9r

---

From: Anders Logg <[email-masked]>
Date: Wed, 3 Feb 2010 20:11:23 +0100

> Yes, I noticed that I was still getting errors, but good that you fixed it. I'm cleaning up the parts of the code I've been working on the most including some of the code in cpp.py.

Great. I think we should try to finish up a release of FFC 0.9.1
before the end of February. Ideally, we should go through all the code
again and remove all FIXMEs.

Then FFC will be in ridiculously good shape.

--
Anders

---

From: Kristian Oelgaard <[email-masked]>
Date: Wed, 3 Feb 2010 20:18:12 +0100 (CET)

> Then FFC will be in ridiculously good shape.

Agree, I think that it sounds like a good idea.

Kristian

> iEYEARECAAYFAktpylsACgkQTuwUCDsYZdEHNwCeLbfmwDBvNioPcxBwCM8YLPXX
> clQAn3obqjXfn5Jk4bU7W2OUjb/Gce7Z
> =zmxm