Subject: [FFC-dev] A bunch of optimizations: [...]

From: [email-masked]
Date: Fri, 07 Oct 2005 22:58:30 +0200

Commit from logg (2005-10-07 22:58 CEST)
----------------

A bunch of optimizations:

  - Only precompute declarations a0, aK, gK when needed as decided by
    the current format. (Formats should return None when not needed.)

  - Write BLAS XML data directly to file instead of caching in a string.
    Very little difference in speed and much cheaper in memory for large
    files.

These optimizations considerably improve compile-time and memory usage
for complicated forms. Test results for Cahn-Hilliard will be reported
in a separate post.

  ffc  TODO                               1.49
  ffc  src/bin/ffc                        1.28
  ffc  src/ffc/compiler/elementtensor.py  1.17
  ffc  src/ffc/format/ase.py              1.9
  ffc  src/ffc/format/dolfin.py           1.48
  ffc  src/ffc/format/latex.py            1.17
  ffc  src/ffc/format/raw.py              1.13
  ffc  src/ffc/format/xml.py              1.5

---

From: "Garth N. Wells" <[email-masked]>
Date: Sat, 08 Oct 2005 10:01:24 +0200

I tried using the BLAS format, but changes in src/ffc/compiler/elementtensor.py
have broken the .xml files. "size_a" is always zero, which leads to a DOLFIN
error. The problems appears to be on line 117 of src/ffc/compiler/elementtensor.py. 

Garth

Quoting [email-masked]:

> _______________________________________________
> FFC-dev mailing list
> [email-masked]
> http://www.fenics.org/cgi-bin/mailman/listinfo/ffc-dev
>

---

From: Anders Logg <[email-masked]>
Date: Sat, 8 Oct 2005 11:13:45 -0500

ok. I'll fix it. The problem is in xml.py. It now needs to get the
size of the block (size_a) from somewhere else, since the block values
are no longer generated for the XML format.

/Anders

-- 
Anders Logg
Research Assistant Professor
Toyota Technological Institute at Chicago
http://www.tti-c.org/logg/