Subject: [Ffc] Scaling on facets

From: Anders Logg <[email-masked]>
Date: Wed, 27 Jan 2010 23:39:21 +0100

Some results from tabulate_tensor seemed to be off by a factor 2 (in 2D).
I tracked this down to a scaling issue where we need to scale the
weights on a facet such that the sum of the weights is 1.

I have added this in monomialintegration.py where I multiply by 2 in
2D and by 6 in 3D.

Is a similar scaling needed for quadrature? If so, we can have a
common scaling.

It looks like it's needed for quadrature. Check the results for the
last tabulate_tensor in the output for Normals.ufl.

--
Anders

---

From: Kristian Oelgaard <[email-masked]>
Date: Thu, 28 Jan 2010 10:12:07 +0100 (CET)

> weights on a facet such that the sum of the weights is 1.

Did you pull the latest FIAT? I fixed the scaling issue on the interval.
With your new 'fix' in FFC I get wrong results.
I added some code to check the quadrature rules in FIAT_NEW.quadrature.py, please check if you think the results look reasonable.

Kristian

> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v1.4.9 (GNU/Linux)
>
> iEYEARECAAYFAktgwJkACgkQTuwUCDsYZdEjmgCePPLLKdFfLV++b2vkN0q4yMGQ
> 084An3DsBJzp8Ej+HuXsH8p7+Eo/MzgM
> =qJm1
> -----END PGP SIGNATURE-----
>
> _______________________________________________
> Mailing list: https://launchpad.net/~ffc
> Post to     : [email-masked]
> Unsubscribe : https://launchpad.net/~ffc
> More help   : https://help.launchpad.net/ListHelp
>
>

---

From: Kristian Oelgaard <[email-masked]>
Date: Thu, 28 Jan 2010 10:16:44 +0100 (CET)

> I have added this in monomialintegration.py where I multiply by 2 in

You don't need any scaling, but if we did shouldn't it be 8 in 3D? We also had a scaling factor of 0.125 in the old FFC.
This is why some results are 'still' wrong for quadrature I think.

Kristian

---

From: Anders Logg <[email-masked]>
Date: Thu, 28 Jan 2010 11:33:10 +0100

> This is why some results are 'still' wrong for quadrature I think.

You're correct. I hadn't pulled the FIAT update.

Looks much better now! :-)

I think the scaling should have been a factor 6 which is the inverse
area of the reference tetrahedron but I guess it's not important.

--
Anders

---

From: Kristian Oelgaard <[email-masked]>
Date: Thu, 28 Jan 2010 11:38:28 +0100 (CET)

> Looks much better now! :-)

Good, will you revert the changes you made in FFC?

Kristian

> iEYEARECAAYFAkthZ+YACgkQTuwUCDsYZdF8sgCeOq3LZBS5N8IFMf/FSRAMIQ6K
> tYoAn3cXmECKegM5gbZa7jcAmPdb60gq
> =HZzv

---

From: Anders Logg <[email-masked]>
Date: Thu, 28 Jan 2010 12:04:55 +0100

> Good, will you revert the changes you made in FFC?

Yes, done already.

--
Anders