Subject: [FFC-dev] [HG FFC] Cleanup in handling of command-line options. Everything is now put

From: [email-masked] (FFC)
Date: Thu, 4 Sep 2008 14:36:32 +0200 (CEST)

One or more new changesets pushed to the primary ffc repository.
A short summary of the last three changesets is included below.

changeset:   1176:a41ade906d0e0a7d57f2ca99e4ebc2c265872f6d
tag:         tip
user:        Anders Logg <[email-masked]>
date:        Thu Sep 04 14:36:27 2008 +0200
files:       src/bin/ffc src/ffc/common/constants.py src/ffc/compiler/compiler.py src/ffc/compiler/format/ufcformat.py src/ffc/jit/jit.py
description:
Cleanup in handling of command-line options. Everything is now put
in the same dictionary and the "="s are removed.

changeset:   1175:89c3fde1506263955a837431d1f100b040be076d
user:        Anders Logg <[email-masked]>
date:        Thu Sep 04 13:38:06 2008 +0200
files:       ChangeLog setup.py
description:
Apply patch from Johannes for Windows install

changeset:   1174:b7eb035ad49db8e8a4de2e4a7bde5eccc798003d
user:        Johannes Ring <[email-masked]>
date:        Thu Sep 04 11:22:32 2008 +0200
files:       setup.py
description:
Generate batch files for Windows.

----------------------------------------------------------------------
For more details, visit http://www.fenics.org/hg/ffc

---

From: "Martin Sandve Alnæs" <[email-masked]>
Date: Thu, 4 Sep 2008 14:45:35 +0200

In the next generation SFC, I've split the options into three groups:
- output: verbosity, logging, cache directories, etc for debugging of
the form compiler itself
- code: anything that affects the generated code
- compilation: anything that affects how the code is compiled by jit

This will be useful for the cache signatures, since the output options
won't change the form module signature. Potentially, I can cache
the generated code using just options.code in the signature,
and let instant cache the compiled modules using both
options.code and options.compilation in the signature.

-- 
Martin

2008/9/4 FFC <[email-masked]>:
> _______________________________________________
> FFC-dev mailing list
> [email-masked]
> http://www.fenics.org/mailman/listinfo/ffc-dev
>

---

From: Anders Logg <[email-masked]>
Date: Thu, 4 Sep 2008 15:17:46 +0200

> options.code and options.compilation in the signature.

Nice. FFC will probably keep everything in one dictionary for a while
(for convenience).

-- 
Anders

---

From: "Martin Sandve Alnæs" <[email-masked]>
Date: Thu, 4 Sep 2008 15:25:41 +0200

> Nice. FFC will probably keep everything in one dictionary for a while

I'm also using a class ParameterDict(dict) which freezes entries
at construction time and allows access to items through attributes
named after like the keys:

p = ParameterDict(foo = 3, bar = "thing")
p.foo = 9
p["foo"] = 9
p.bar = "other"
for k,v in p.items():
    ...
p.blatti = 8 # Error!

--
Martin