Subject: Re: [FFC-dev] [DOLFIN-dev] compiler flags and compile time

From: "Garth N. Wells" <[email-masked]>
Date: Wed, 13 Sep 2006 10:19:17 +0200

I've also had problems with very large .h files (some approaching 1GB which
compilers cannot handle). What if FFC did not unroll the tensor contraction but
used loops with a fixed size? Would this be easy from the FFC side? The compiler
should be able to do some pretty good optimisations on this. Would it compare to
FFC unrolling the loops?

Garth 

Quoting Anders Logg <[email-masked]>:

> I guess you mean the -O2 that you get with dolfin-config --cflags?
> 
> Perhaps we should avoid exporting optimization flags and debugging
> flags to dolfin-config so these flags may be adjusted by users.
> 
> For now, just edit your dolfin-config script and remove the -O2. That
> should take care of it.
> 
> Another option is to compile the forms with the option -f blas given
> to FFC. This should generate much smaller h-files.
> 
> A warning: the -f blas option has not been tested for a while so I'm
> not sure it works (it definitely does not work for forms that include
> boundary integrals).
> 
> /Anders
> 
> 
> On Tue, Sep 12, 2006 at 05:46:30PM +0200, Dag Lindbo wrote:
> > Hi all,
> > 
> > Version 0.6.2-1 seems to be defaulting to some other optimization flags
> > than 0.6.1 did. This is hurting compile-times to the extent that I can not
> > use quadratic elements in my solvers (some h-files are rather big,
> > ~2Mb)...
> > 
> > What's cusing the slowdown? How do I control what flags are used by
> libtool?
> > 
> > Thanks,
> > Dag Lindbo
> > 
> > _______________________________________________
> > DOLFIN-dev mailing list
> > [email-masked]
> > http://www.fenics.org/mailman/listinfo/dolfin-dev
> _______________________________________________
> DOLFIN-dev mailing list
> [email-masked]
> http://www.fenics.org/mailman/listinfo/dolfin-dev
>

---

From: Anders Logg <[email-masked]>
Date: Wed, 13 Sep 2006 10:23:28 +0200

Unrolling the loops would be identical to what is already being done
in BLAS mode with -f blas as far as I can tell.

Or do you refer to the computation of the geometry tensor which is
performed also in BLAS mode?

/Anders

On Wed, Sep 13, 2006 at 10:19:17AM +0200, Garth N. Wells wrote:
> FFC-dev mailing list
> [email-masked]
> http://www.fenics.org/mailman/listinfo/ffc-dev