Subject: Re: [FFC-dev] [DOLFIN-dev] [HG] Merge - new mesh representation replaces old. Interior assembly works

From: "Garth N. Wells" <[email-masked]>
Date: Mon, 16 Oct 2006 13:50:16 +0200

Anders Logg wrote:
> Doesn't work for me either. The FFC format is designed for the old
> mesh and the new mesh does not yet have anything that corresponds to
> cell.vertexID() etc.
> 

Should this be changed on the FFC side? Johan J. has changed (I assume
be hand) cell.vertexID() to  cell.connections()[]. Let me if this is OK
and I can change it in FFC is no one has on it started yet.

Garth

> Let's try and fix this as quickly as we possibly can.
> 
> Now that the mesh interface is dimension-independent, we can simplify
> this a bit.
> 
> /Anders
> 
> 
> On Mon, Oct 16, 2006 at 10:27:08AM +0200, Garth N. Wells wrote:
>> Should the demos still work? I can't compile any of them.
>>
>> Garth
>>
>> Johan Jansson wrote:
>>> On Mon, Oct 16, 2006 at 03:39:32AM +0200, DOLFIN wrote:
>>>> One or more new changesets pushed to the primary DOLFIN repository.
>>>> A short summary of the last three changesets is included below.
>>>>
>>>> changeset:   2305:59d1290ce4782edf8e42afcfe565d1b19bea22be
>>>> tag:         tip
>>>> parent:      2304:d3ec89c865064d3b90f2741451b99f061169878d
>>>> parent:      2292:34be9b8d76a1f61b3f1b07d06f0499231f5fb968
>>>> user:        "Johan Jansson <[email-masked]>"
>>>> date:        Mon Oct 16 03:34:56 2006 +0200
>>>> files:       src/demo/solvers/poisson/main.cpp src/kernel/io/OpenDXFile.cpp src/kernel/io/TecplotFile.cpp src/kernel/io/VTKFile.cpp src/kernel/mesh/BoundaryComputation.cpp src/kernel/mesh/MeshGeometry.cpp src/kernel/mesh/TopologyComputation.cpp src/kernel/mesh/UniformMeshRefinement.cpp src/kernel/mesh/dolfin/MeshGeometry.h src/pydolfin/dolfin_mesh.i
>>>> description:
>>>> Merge - new mesh representation replaces old. Interior assembly works
>>>> correctly, boundary assembly not yet fully implemented.
>>>>
>>> I had to force push this changeset, don't know why - a pull showed no
>>> new changes. Perhaps it's because files were removed/replaced, or I've
>>> overlooked something.
>>>
>>>   Johan
>>> _______________________________________________
>>> DOLFIN-dev mailing list
>>> [email-masked]
>>> http://www.fenics.org/mailman/listinfo/dolfin-dev
>>>
>>
>> _______________________________________________
>> DOLFIN-dev mailing list
>> [email-masked]
>> http://www.fenics.org/mailman/listinfo/dolfin-dev
> _______________________________________________
> DOLFIN-dev mailing list
> [email-masked]
> http://www.fenics.org/mailman/listinfo/dolfin-dev
>

---

From: Anders Logg <[email-masked]>
Date: Mon, 16 Oct 2006 13:54:25 +0200

> and I can change it in FFC is no one has on it started yet.

Looks good to me, please go ahead.

It might be that you just need to update the dictionaries in
nodemap.py and vertexeval.py.

/Anders

---

From: Johan Jansson <[email-masked]>
Date: Mon, 16 Oct 2006 14:03:14 +0200

> and I can change it in FFC is no one has on it started yet.

I actually changed it on the FFC side. I'm attaching the bundle (do
"ffc unbundle"). It's very small though, you might have already made
the changes.

  Johan

---

From: Anders Logg <[email-masked]>
Date: Mon, 16 Oct 2006 14:26:50 +0200

> "ffc unbundle"). It's very small though, you might have already made

Fixed, but untested.

/Anders

---

From: "Garth N. Wells" <[email-masked]>
Date: Mon, 16 Oct 2006 14:29:27 +0200

> "ffc unbundle"). It's very small though, you might have already made

Works great.

There are a couple of other terms (cell.edgeAlignment(),
cell.faceAlignment()) which will have to be sorted out in the future.

Garth