Subject: [FFC-dev] Add mixed formulation of Stokes to the set of demo forms: [...]

From: [email-masked]
Date: Tue, 20 Sep 2005 17:15:53 +0200

Commit from logg (2005-09-20 17:15 CEST)
----------------

Add mixed formulation of Stokes to the set of demo forms:

P1 = FiniteElement("Lagrange", "triangle", 1)
P2 = FiniteElement("Vector Lagrange", "triangle", 2)
TH = P2 + P1

(v, q) = BasisFunctions(TH)
(u, p) = BasisFunctions(TH)

f = Function(P2)

a = (dot(grad(u), grad(v)) - p*div(v) + div(u)*q)*dx
L = dot(f, v)*dx

  ffc  src/demo/Poisson.form        1.20
  ffc  src/demo/PoissonSystem.form  1.6
+ ffc  src/demo/Stokes.form         1.1

---

From: "Johan Hoffman" <[email-masked]>
Date: Tue, 20 Sep 2005 17:51:43 +0200 (MEST)

> _______________________________________________
> FFC-dev mailing list
> [email-masked]
> http://www.fenics.org/cgi-bin/mailman/listinfo/ffc-dev
>

-- 
Johan Hoffman, PhD
Assistant Professor
School of Computer Science and Communication
Royal Institute of Technology KTH
SE-100 44 Stockholm
Sweden

Email: [email-masked]
URL: www.nada.kth.se/~jhoffman

---

From: "Johan Hoffman" <[email-masked]>
Date: Tue, 20 Sep 2005 17:52:03 +0200 (MEST)

Looks very nice!

/Johan

---

From: Anders Logg <[email-masked]>
Date: Tue, 20 Sep 2005 11:02:40 -0500

Thanks. I'm not sure it works yet though... need to do some more
testing.

/Anders

-- 
Anders Logg
Research Assistant Professor
Toyota Technological Institute at Chicago
http://www.tti-c.org/logg/

---

From: Anders Logg <[email-masked]>
Date: Tue, 20 Sep 2005 11:06:30 -0500

I'm implementing a Stokes solver in DOLFIN (which is just assemble +
solve). Andy will help and we will add all the functionality we need
for mixed systems as we go along, including boundary conditions,
extracting the pressure and velocity for postprocessing etc.

When this is done, it should be really easy to just write down any
mixed system and just have it work.

/Anders

On Tue, Sep 20, 2005 at 10:52:51AM -0500, Robert C. Kirby wrote:
> Good news here...
> Have you considered how to (elegantly) do boundary conditions on  
> mixed elements?  You apply conditions to the velocity but not the  
> pressure.
> 
> 
> Rob
> 
> 
> On Sep 20, 2005, at 10:15 AM, [email-masked] wrote:
>