Subject: Re: [Ffc] [Branch ~ffc-core/ffc/dev] Rev 1348: Simple functionality now in place in compute_dof_ir. Missing tabulate_* and

From: Anders Logg <[email-masked]>
Date: Thu, 17 Dec 2009 20:52:18 +0100

On Thu, Dec 17, 2009 at 02:32:19PM -0000, [email-masked] wrote:
> ------------------------------------------------------------
> revno: 1348
> committer: [email-masked]
> branch nick: ffc-dev
> timestamp: Thu 2009-12-17 15:29:05 +0100
> message:
>   Simple functionality now in place in compute_dof_ir. Missing tabulate_* and
>   create_sub_dof_map.
>
>   What is init_cell and init_cell_finalize used for?

It was added to UFC to allow a form compiler to precompute the dofmap
by iterating over the mesh. If you look at DofMap.cpp in DOLFIN you
will see this:

 // Initialize UFC dof map
 const bool init_cells = dofmap.init_mesh(ufc_mesh);
 if (init_cells)
 {
   UFCCell ufc_cell(dolfin_mesh);
   for (CellIterator cell(dolfin_mesh); !cell.end(); ++cell)
   {
     ufc_cell.update(*cell);
     dofmap.init_cell(ufc_mesh, ufc_cell);
   }
   dofmap.init_cell_finalize();
 }

init_cell and init_cell_finalize are not used by FFC only SyFi so
init_mesh should return false and the other two should be empty.

We probably need something like

  format["do_nothing"] --> "// Do nothing"

in the format dictionary.

--
Anders

---

From: Marie Rognes <[email-masked]>
Date: Thu, 17 Dec 2009 21:09:07 +0100

> init_mesh should return false and the other two should be empty.

I copied the previous, so init_mesh initializes the global_dimension 
(and returns false)

> in the format dictionary.

Check (from previous)    .

--
Marie
> ------------------------------------------------------------------------
>
> _______________________________________________
> Mailing list: https://launchpad.net/~ffc
> Post to     : [email-masked]
> Unsubscribe : https://launchpad.net/~ffc
> More help   : https://help.launchpad.net/ListHelp
>

---

From: Anders Logg <[email-masked]>
Date: Thu, 17 Dec 2009 22:58:48 +0100

> I copied the previous, so init_mesh initializes the global_dimension

Yes! Exactly.

> >in the format dictionary.

ok.

--
Anders