Subject: [FFC-dev] [HG FFC] Subdomain bug fix for quadrature representation.

From: [email-masked] (FFC)
Date: Thu, 31 Jan 2008 13:35:42 +0100 (CET)

One or more new changesets pushed to the primary ffc repository.
A short summary of the last three changesets is included below.

changeset:   1063:8bc48cce4d8fed1dd8e9ac2b95785bb33141f2ae
tag:         tip
user:        "Kristian Oelgaard <[email-masked]>"
date:        Thu Jan 31 13:35:17 2008 +0100
files:       src/ffc/compiler/codegeneration/quadrature/quadraturegenerator.py
description:
Subdomain bug fix for quadrature representation.

changeset:   1062:72167c53b57d3f77dd9fd348580bd87c1772a433
user:        "Anders Logg <[email-masked]>"
date:        Thu Jan 31 12:08:18 2008 +0100
files:       doc/manual/ffc-user-manual.pdf src/ffc/compiler/codegeneration/tensor/tensorgenerator.py src/sandbox/misc/subdomains.form
description:
Bug fix in extraction of sub domain integral (bug reported by Jake Ostien)

changeset:   1061:80a631c72e952f321fd5a5cbfe9de7b4cab6e1d3
user:        "Anders Logg <[email-masked]>"
date:        Wed Jan 23 12:03:40 2008 +0100
files:       src/ffc/jit/jit.py
description:
Fix bug in JIT compiler, appears when compiling forms on a partition
which is different from the partition of the home directory.
Solution: use shutil.move instead of os.rename. Thanks to Ola
for the bug fix.

----------------------------------------------------------------------
For more details, visit http://www.fenics.org/hg/ffc

---

From: Kristian Oelgaard <[email-masked]>
Date: Thu, 31 Jan 2008 13:37:54 +0100

Would it be worthwhile to have a subdomain demo and a corresponding reference
for regression tests?

Kristian

Quoting FFC <[email-masked]>:

> files:      
> src/ffc/compiler/codegeneration/quadrature/quadraturegenerator.py
> description:
> files:       doc/manual/ffc-user-manual.pdf
> src/ffc/compiler/codegeneration/tensor/tensorgenerator.py
> src/sandbox/misc/subdomains.form
> description:
> _______________________________________________
> FFC-dev mailing list
> [email-masked]
> http://www.fenics.org/mailman/listinfo/ffc-dev
>

---

From: Anders Logg <[email-masked]>
Date: Thu, 31 Jan 2008 13:49:21 +0100

> Would it be worthwhile to have a subdomain demo and a corresponding reference

Yes, please add it if you have time. You can use subdomains.form in
src/sandbox/misc as a starting point.

-- 
Anders