Subject: [FFC-dev] [HG FFC] evaluate_basis(): Use a Piola transform, if we have e.g. BDM elements, to map values back to the physical element.

From: [email-masked] (FFC)
Date: Mon, 17 Sep 2007 16:15:28 +0200 (CEST)

One or more new changesets pushed to the primary ffc repository.
A short summary of the last three changesets is included below.

changeset:   974:6ec7acde5eb1f4c2ee2c049a02caa43973be3b91
tag:         tip
user:        "Kristian Oelgaard <[email-masked]>"
date:        Mon Sep 17 16:15:17 2007 +0200
files:       src/ffc/compiler/codegeneration/common/evaluatebasis.py src/test/regression/reference/MixedPoisson.h
description:
evaluate_basis(): Use a Piola transform, if we have e.g. BDM elements, to map values back to the physical element.

changeset:   973:bc3d8c6266801bb5460a376627186514dd942391
user:        "Kristian Oelgaard <[email-masked]>"
date:        Mon Sep 17 16:04:06 2007 +0200
files:       src/ffc/compiler/representation/quadrature/monomialtabulation.py src/ffc/compiler/representation/tensor/monomialintegration.py src/test/regression/reference/PoissonDG.h
description:
Bug fix in monomialtabulation.py and monomialintegration.py. With the new vertex numbering in FIAT it is no longer necessary to reorder quadrature points for interior facet integrals.

changeset:   972:28fbc29ead0c041bbf3475c5e1ff153f7b70a99e
parent:      971:69e52097fa4bf97bf32cdd5547c7ea1092062df4
parent:      969:8ec66be1ec22b5bc94646d12c188457fb8ab3884
user:        "Anders Logg <[email-masked]>"
date:        Thu Sep 13 17:53:07 2007 +0200
files:       src/ffc/compiler/format/codesnippets.py
description:
merge

----------------------------------------------------------------------
For more details, visit http://www.fenics.org/hg/ffc

---

From: Anders Logg <[email-masked]>
Date: Tue, 18 Sep 2007 22:24:02 +0200

The regression tests fail:

     http://www.fenics.org:8010/ffc/

Kristian, could you check that the output is correct (viewdiff.sh) and 
then update the references?

/Anders

FFC wrote:
> _______________________________________________
> FFC-dev mailing list
> [email-masked]
> http://www.fenics.org/mailman/listinfo/ffc-dev
>

---

From: Kristian Oelgaard <[email-masked]>
Date: Wed, 19 Sep 2007 10:12:39 +0200

> then update the references?

Strange, regression tests run perfect for me. Also tried a fresh clone.

Kristian
 
> > files:       src/ffc/compiler/codegeneration/common/evaluatebasis.py
> src/test/regression/reference/MixedPoisson.h
> > description:
> > files:      
> src/ffc/compiler/representation/quadrature/monomialtabulation.py
> src/ffc/compiler/representation/tensor/monomialintegration.py
> src/test/regression/reference/PoissonDG.h
> > description:
> > Bug fix in monomialtabulation.py and monomialintegration.py. With the new
> vertex numbering in FIAT it is no longer necessary to reorder quadrature
> points for interior facet integrals.
> > 
> >

---

From: Anders Logg <[email-masked]>
Date: Thu, 20 Sep 2007 00:27:04 +0200

Yes, looks good from here too but the buildbot doesn't seem to agree.
I'll take a look when I get a chance...

/Anders