Subject: [Ffc] Quadrature elements

From: "Garth N. Wells" <[email-masked]>
Date: Thu, 03 Dec 2009 11:43:20 +0000

FFC is stuck on one last thing - QuadratureElements. The demo

   QuadratureElement.ufl

is failing. See

    https://bugs.launchpad.net/ffc/+bug/491830

Is it an easy fix? Kristian?

Garth

---

From: Kristian Oelgaard <[email-masked]>
Date: Thu, 3 Dec 2009 14:30:48 +0100

> Is it an easy fix? Kristian?

It should be, but it depends on how the new degree estimation is supposed to
work. For QuadratureElement to work properly
the integrand must be integrated with the same number of points as the QE
will have.

In this example the degree of the first integrand should be equal to that of
the QE which is how it used to be
if any QEs were present.

Kristian

>
> Garth
>
> _______________________________________________
> Mailing list: https://launchpad.net/~ffc <https://launchpad.net/%7Effc>
> Post to     : [email-masked]
> Unsubscribe : https://launchpad.net/~ffc <https://launchpad.net/%7Effc>
> More help   : https://help.launchpad.net/ListHelp
>

---

From: "Garth N. Wells" <[email-masked]>
Date: Thu, 03 Dec 2009 14:06:42 +0000

Kristian Oelgaard wrote:
> 
> 
> On Thu, Dec 3, 2009 at 12:43 PM, Garth N. Wells <[email-masked]
> <mailto:[email-masked]>> wrote:
> 
> It should be, but it depends on how the new degree estimation is
> supposed to work. For QuadratureElement to work properly
> the integrand must be integrated with the same number of points as the
> QE will have.
> 
> In this example the degree of the first integrand should be equal to
> that of the QE which is how it used to be
> if any QEs were present.
>

OK, can you suggest a combination of degrees that will work?

>     Post to     : [email-masked] <mailto:[email-masked]>
> ------------------------------------------------------------------------
> 
> Mailing list: https://launchpad.net/~ffc
> Unsubscribe : https://launchpad.net/~ffc

---

From: "Garth N. Wells" <[email-masked]>
Date: Thu, 03 Dec 2009 16:34:39 +0000

> OK, can you suggest a combination of degrees that will work?

It would be good to sort this out this today so we can make a release of
 UFL/FFC/DOLFIN and get on with new developments.

Garth

---

From: Kristian Oelgaard <[email-masked]>
Date: Thu, 3 Dec 2009 18:35:08 +0100

On Thu, Dec 3, 2009 at 5:34 PM, Garth N. Wells <[email-masked]> wrote:

> It should be fixed now, I also updated the regression references. (For the
new Grad I believe.)

Kristian

> >>     Mailing list: https://launchpad.net/~ffc<https://launchpad.net/%7Effc><
> https://launchpad.net/%7Effc>
> >>     Unsubscribe : https://launchpad.net/~ffc<https://launchpad.net/%7Effc><
> https://launchpad.net/%7Effc>

---

From: "Garth N. Wells" <[email-masked]>
Date: Thu, 03 Dec 2009 17:37:12 +0000

Kristian Oelgaard wrote:
> 
> 
> On Thu, Dec 3, 2009 at 5:34 PM, Garth N. Wells <[email-masked]
>     <mailto:[email-masked]>
>     >> <mailto:[email-masked] <mailto:[email-masked]>>> wrote:
>     >>
> It should be fixed now, I also updated the regression references. (For
> the new Grad I believe.)
> 

Excellent! The Buildbots are now all green so we can make a release.

Garth

>     <https://launchpad.net/%7Effc> <https://launchpad.net/%7Effc>
>     <mailto:[email-masked]> <mailto:[email-masked]
>     <mailto:[email-masked]>>
>     <https://launchpad.net/%7Effc> <https://launchpad.net/%7Effc>
>     <https://launchpad.net/%7Effc>
>     <mailto:[email-masked]>
>     <https://launchpad.net/%7Effc>
>     <https://launchpad.net/%7Effc>
>     <https://launchpad.net/%7Effc>

---

From: Anders Logg <[email-masked]>
Date: Thu, 3 Dec 2009 23:24:53 +0100

On Thu, Dec 03, 2009 at 06:35:08PM +0100, Kristian Oelgaard wrote:
> It should be fixed now, I also updated the regression references. (For the new
> Grad I believe.)

Great. It's a good feeling to see the buildbots all green again.

--
Anders