Subject: [FFC-dev] coefficients

From: Kristian Oelgaard <[email-masked]>
Date: Thu, 24 May 2007 12:09:15 +0200

There's a problem when generating coefficients for Projection.form

Output - shell

  Removing unused variable: c0_2_0_2
  Removing unused variable: c0_2_0_1
  Removing unused variable: c0_2_0_0
  Removing unused variable: c0_1_0_2
  Removing unused variable: c0_1_0_1
  Removing unused variable: c0_1_0_0
  Removing unused variable: c0_0_0_2
  Removing unused variable: c0_0_0_1

Projection.h

    // Compute coefficients
    const double c0_0_0_0 = w[0][0];
    
    // Compute geometry tensors
    const double G0_0 = det*c0_0_0_0;
    const double G1_0 = det*c1_1_0_0;
    const double G1_1 = det*c1_1_0_1;
    const double G1_2 = det*c1_1_0_2;
    const double G2_0 = det*c2_2_0_0;
    const double G2_1 = det*c2_2_0_1;
    const double G2_2 = det*c2_2_0_2;
    const double G2_3 = det*c2_2_0_3;
    const double G2_4 = det*c2_2_0_4;
    const double G2_5 = det*c2_2_0_5;

which doesn't compile.

I thought that this bug was solved?

Kristian

---

From: Anders Logg <[email-masked]>
Date: Fri, 25 May 2007 01:07:09 +0200

On Thu, May 24, 2007 at 12:09:15PM +0200, Kristian Oelgaard wrote:
> _______________________________________________
> FFC-dev mailing list
> [email-masked]
> http://www.fenics.org/mailman/listinfo/ffc-dev

Local projections have not been (re-)implemented yet in FFC, so I
expect there to be some problems. It's on my TODO list but I'm not
sure I will have time to fix it before the next release. (Unless
everyone tells me it's really important.)

/Anders