Subject: Re: [FFC-dev] New operators

From: "Garth N. Wells" <[email-masked]>
Date: Fri, 09 Sep 2005 08:10:35 +0200

Hi Anders,

Looks great. I'll try it out and let you know. One useful non-differential
operator (for me at least) would the cross product. Perhaps the most generic way
to allow for it would be to add the permutation tensor when you're ready for
higher-order tensors.

Garth

Quoting Anders Logg <[email-masked]>:

> The new operators are now in place:
> 
>     dot  - scalar product
>     grad - gradient
>     div  - divergence
>     rot  - rotation (curl works also)
> 
> One can now write things like
> 
>     a = div(grad(dot(rot(v), u)))*dx
> 
> Please try them out and tell me if they work. Suggestions for
> modifications of the behavior of these operators as well as
> suggestions for new (standard) operators that might make life easier
> for you are also welcome. Remember, these operators are defined
> independently from and on top of the form algebra so adding a new
> operator does not add to the complexity of the form language (this
> comment is for you Rob ;-).
> 
> /Anders
> 
> _______________________________________________
> FFC-dev mailing list
> [email-masked]
> http://www.fenics.org/cgi-bin/mailman/listinfo/ffc-dev
>

---

From: Anders Logg <[email-masked]>
Date: Fri, 9 Sep 2005 02:25:01 -0500

Good suggestion, I'll add cross(), trace() and probably mult()
so you can multiply with permutation matrices/tensors.

/Anders

-- 
Anders Logg
Research Assistant Professor
Toyota Technological Institute at Chicago
http://www.tti-c.org/logg/

---

From: [email-masked]
Date: Fri, 9 Sep 2005 16:02:26 +0200 (MEST)

Great!

/Johan