Subject: [FFC-dev] [HG FFC] Added covariant mapping for Nedelec elements.

From: [email-masked] (FFC)
Date: Wed, 7 Nov 2007 19:23:37 +0100 (CET)

One or more new changesets pushed to the primary ffc repository.
A short summary of the last three changesets is included below.

changeset:   1003:be7ba517e07b4c6a1a54fd324195cd18937d48f4
tag:         tip
user:        "Marie E. Rognes <[email-masked]>"
date:        Wed Nov 07 19:23:22 2007 +0100
files:       src/demo/VectorLaplaceGradCurl.form src/ffc/compiler/codegeneration/common/evaluatebasis.py src/ffc/compiler/codegeneration/common/evaluatebasisderivatives.py src/ffc/compiler/codegeneration/common/finiteelement.py src/ffc/compiler/language/algebra.py src/ffc/fem/finiteelement.py src/ffc/fem/mapping.py src/test/regression/reference/MixedPoisson.h src/test/regression/reference/VectorLaplaceGradCurl.h
description:
Added covariant mapping for Nedelec elements.

Think Nedelec should work now, but relies on a fix in FIAT. Added test
in VectorLaplaceGradCurl to /src/demo.

evaluatebasis, evaluatebasisderivatives and interpolate_vertex_values
updated but rather poorly tested.

changeset:   1002:c2cdf837fada55aa2e9f25afaae94fe3a73eb47d
user:        "Marie E. Rognes <[email-masked]>"
date:        Thu Nov 01 11:57:15 2007 +0100
files:       src/ffc/compiler/analysis/simplify.py
description:
Another bugfix for simplify.

Relevant for vectors of piola mapped elements, for instance
VectorElement("BDM", ..., ...)

changeset:   1001:ea7d3faf8add6f6bf5813d609bd8220feb832f1e
user:        "Marie E. Rognes <[email-masked]>"
date:        Tue Oct 30 13:44:59 2007 +0100
files:       src/ffc/compiler/analysis/simplify.py src/test/regression/reference/Elasticity.h
description:
Reintroduced the factorization in simplify and fixed another bug.

----------------------------------------------------------------------
For more details, visit http://www.fenics.org/hg/ffc

---

From: Anders Logg <[email-masked]>
Date: Wed, 7 Nov 2007 22:06:17 +0100

Excellent!

/Anders

On Wed, Nov 07, 2007 at 07:23:37PM +0100, FFC wrote:
> _______________________________________________
> FFC-dev mailing list
> [email-masked]
> http://www.fenics.org/mailman/listinfo/ffc-dev

---

From: Marie Rognes <[email-masked]>
Date: Thu, 08 Nov 2007 02:35:18 +0100

>> updated but rather poorly tested.

Very poorly tested turns out to be more precise.

evaluatebasis etc needs to additionally declare the inverse of the 
Jacobian in the H(curl) (mapping == Mapping.COVARIANT_PIOLA) cases.

Not sure of the prettiest way of modifying the code here. Will look at 
it with fresh eyes tomorrow unless anyone has fixed it by then ;)

-- 
Marie E. Rognes
Ph.D Fellow, 
Centre of Mathematics for Applications, 
University of Oslo
http://folk.uio.no/meg