Subject: Re: [Ffc] [Branch ~ffc-core/ffc/main] Rev 1354: Add missing file

From: Anders Logg <[email-masked]>
Date: Sun, 31 Jan 2010 21:07:51 +0100

All buildbots should be green now. Only FFC tests are currently
failing but I suspect a small fix is needed on the buildbot side
to run the new tests (which involve compilation against UFC).

What about the evaluate_basis and evaluate_basis_derivatives
tests. Are they in good shape, and what do they do differently from
the regression tests?

--
Anders

On Sun, Jan 31, 2010 at 08:00:29PM -0000, [email-masked] wrote:
> ------------------------------------------------------------
> revno: 1354
> committer: Anders Logg <[email-masked]>
> branch nick: ffc-main
> timestamp: Sun 2010-01-31 20:57:52 +0100
> message:
>   Add missing file
> added:
>   test/unit/test.py
>
>

> === added file 'test/unit/test.py'
> --- test/unit/test.py	1970-01-01 00:00:00 +0000
> +++ test/unit/test.py	2010-01-31 19:57:52 +0000
> @@ -0,0 +1,5 @@
> +from misc.test import *
> +from symbolics.test import *
> +
> +if __name__ == "__main__":
> +    unittest.main()
>

---

From: Kristian Oelgaard <[email-masked]>
Date: Sun, 31 Jan 2010 22:38:46 +0100 (CET)

> tests. Are they in good shape, and what do they do differently from

The current content of evaluate_basis* is just a test against old values from FFC, but with many more elements. But since many of the elements has changed the order of dofs they are not of much use. Therefore, I'm working on a test suite which will compare values from fiat_element.tabulate() to ufc_element.evaluate_basis() and ufc_element.evaluate_basis_derivatives(). There is still a little work to be done, but I can hopefully push something tomorrow that will replace what is in evaluate_basis/ and then evaluate_basis_derivatives/ can be removed.

Kristian

> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v1.4.9 (GNU/Linux)
>
> iEYEARECAAYFAktl4xcACgkQTuwUCDsYZdGrJQCdH59w7EP1Li0gM2bunvIdJDMD
> O/IAnRay+qpeibp9lwqWdPXSCWB5cHP7
> =MjH5
> -----END PGP SIGNATURE-----
>
> _______________________________________________
> Mailing list: https://launchpad.net/~ffc
> Post to     : [email-masked]
> Unsubscribe : https://launchpad.net/~ffc
> More help   : https://help.launchpad.net/ListHelp
>
>

---

From: Anders Logg <[email-masked]>
Date: Mon, 1 Feb 2010 09:15:55 +0100

> The current content of evaluate_basis* is just a test against old values from FFC, but with many more elements. But since many of the elements has changed the order of dofs they are not of much use…

ok.

Is this a unit test or where should it be placed?

--
Anders

---

From: Kristian Oelgaard <[email-masked]>
Date: Mon, 1 Feb 2010 09:21:59 +0100 (CET)

> Is this a unit test or where should it be placed?

I'm not sure, but I'll put it in test/evaluate_basis, then you can have a look and see what you think. I think it is more of a unit test because it checks that the result of the FFC implementation is in agreement with the FIAT backend.

Kristian

> iEYEARECAAYFAktmjboACgkQTuwUCDsYZdFIHQCZAeQoVlzxwdXNy9ZXPgV7NN+1
> w4IAnj0MywbaodXANy1J+iv1QhbuI4J5
> =v6R5

---

From: Anders Logg <[email-masked]>
Date: Mon, 1 Feb 2010 09:38:04 +0100

> I'm not sure, but I'll put it in test/evaluate_basis, then you can have a look and see what you think. I think it is more of a unit test because it checks that the result of the FFC implementation…

Yes, it looks like some kind of unit test to me.

Could you try placing it under test/unit/something and see if you can
make it work with the top level test/unit/test.py file?

--
Anders