Subject: [FFC-dev] [HG FFC] Merge

From: [email-masked] (FFC)
Date: Thu, 14 Feb 2008 23:56:16 +0100 (CET)

One or more new changesets pushed to the primary ffc repository.
A short summary of the last three changesets is included below.

changeset:   1096:e6525c6e3d7238fb09c2f9f7af580139a58be190
tag:         tip
parent:      1095:2b24856cc0b543365cb76dcade0801159c112f47
parent:      1085:eaf5fdcf2fec9e7d9c6cce4ec27a0b16f81a9bd8
user:        "Marie E. Rognes <[email-masked]>"
date:        Thu Feb 14 23:07:01 2008 +0100
files:       src/ffc/compiler/codegeneration/common/finiteelement.py src/ffc/compiler/format/ufcformat.py
description:
Merge

changeset:   1095:2b24856cc0b543365cb76dcade0801159c112f47
user:        "Marie E. Rognes <[email-masked]>"
date:        Tue Feb 12 15:54:16 2008 +0100
files:       src/ffc/fem/quadratureelement.py
description:
Forgot a name for the DofRepresentation of QuadratureElements

changeset:   1094:c7ed09b0684848f5b91fb8b178bc23148e3eaad2
parent:      1093:93193d9d23228122678cd726b1da924169fc06a6
parent:      1077:3ff4a3fd10cd9e8f67c5ca8bdd6400d833621b9b
user:        "Marie E. Rognes <[email-masked]>"
date:        Tue Feb 12 15:42:20 2008 +0100
files:       src/ffc/compiler/format/ufcformat.py src/ffc/fem/dofmap.py src/ffc/fem/finiteelement.py
description:
Merge.

----------------------------------------------------------------------
For more details, visit http://www.fenics.org/hg/ffc

---

From: Marie Rognes <[email-masked]>
Date: Fri, 15 Feb 2008 00:24:55 +0100

> files:       src/ffc/compiler/codegeneration/common/finiteelement.py src/ffc/compiler/format/ufcformat.py

This introduced the "new evaluate_dof".

Something peculiar seemed to happen with the reference files for the 
regression tests in one of the merges. Could someone (who feels 
confident that he has the right version of UFC) update these?

QuadratureElement still needs a fix.

-- 
Marie E. Rognes
Ph.D Fellow, 
Centre of Mathematics for Applications, 
University of Oslo
http://folk.uio.no/meg