Subject: [Ffc] bug in exp()

From: Mehdi Nikbakht <[email-masked]>
Date: Thu, 25 Mar 2010 16:44:57 +0100

Hello,

It seems that something is going wrong in handling Exponential function.
If I compile ,

element = FiniteElement("Lagrange", triangle, 1)

v = TestFunction(element)
u = TrialFunction(element)
f = Coefficient(element)

L = exp(f)*v*f*dx

the code for computing element tensor is as following,

   A[j] += FE0[ip][j]*std::exp(F0)*std::exp(F0)*W4[ip]*det;

which is obviously wrong. It should be something like,

   A[j] += FE0[ip][j]*std::exp(F0)*F0*W4[ip]*det;

Mehdi

---

From: Kristian Oelgaard <[email-masked]>
Date: Thu, 25 Mar 2010 18:07:24 +0100 (CET)

>   A[j] += FE0[ip][j]*std::exp(F0)*F0*W4[ip]*det;

Obviously, I pushed a fix.

Kristian

> Mehdi
>
>
>
> _______________________________________________
> Mailing list: https://launchpad.net/~ffc
> Post to     : [email-masked]
> Unsubscribe : https://launchpad.net/~ffc
> More help   : https://help.launchpad.net/ListHelp
>