Subject: [FFC-dev] "Unable to use UFC reference element"

From: "Martin Sandve Alnæs" <[email-masked]>
Date: Thu, 18 Oct 2007 15:10:16 +0200

After updating FFC I get this message:
*** Warning: Unable to use UFC reference element. You need to patch or
update your
*** Warning: installation of FIAT. Variable reference_element is missing.
but I have the latest FIAT from hg.

--
Martin

---

From: Kristian Oelgaard <[email-masked]>
Date: Thu, 18 Oct 2007 15:29:22 +0200

> After updating FFC I get this message:

Unfortunately, the latest changes didn't make it to the mailing list. The latest
changes requires a FIAT patch that has not been made available yet. You can
revert to changeset 983, then it should work, I think.

Kristian

> _______________________________________________
> FFC-dev mailing list
> [email-masked]
> http://www.fenics.org/mailman/listinfo/ffc-dev
>

---

From: Marie Rognes <[email-masked]>
Date: Thu, 18 Oct 2007 15:14:16 +0200

> but I have the latest FIAT from hg.

If you take a look at the ffc log, you hopefully see something like:

    changeset:   989:cc2b38891d67
    tag:         tip
    user:        "Kristian Oelgaard <[email-masked]>"
    date:        Wed Oct 17 16:33:12 2007 +0200
    summary:     Warning! Don't pull this changeset yet, need changes in
    FIAT. Changed the reference element from FIAT to FFC in
    evaluate_basis() and evaluate_basis_derivatives(). Also removed
    vscaling and dscaling in monomialtabulation.py as a consequence of
    the change in reference element.

    changeset:   988:148ead11f573
    user:        "Anders Logg <[email-masked]>"
    date:        Tue Oct 16 00:45:55 2007 +0200
    summary:     Warning! Don't pull this changeset yet.

We are changing the reference element in ffc, but have only changed the 
ffc part and not the FIAT part yet.

-- 
Marie E. Rognes
Ph.D Fellow, 
Centre of Mathematics for Applications, 
University of Oslo
http://folk.uio.no/meg

---

From: Anders Logg <[email-masked]>
Date: Thu, 18 Oct 2007 17:42:13 +0200

Kristian Oelgaard wrote:
> Unfortunately, the latest changes didn't make it to the mailing list.

The problem with commitlogs not making it to the mailing list should be 
fixed now. (The problem was strings containing "'" and one of "(" or ")".

/Anders

> The latest