Subject: Re: [Ffc] [Branch ~ffc-core/ffc/main] Rev 1443: Implement two new optimisation strategies for quadrature representation.

From: "Garth N. Wells" <[email-masked]>
Date: Thu, 11 Mar 2010 22:24:00 +0000

[email-masked] wrote:
> ------------------------------------------------------------
> revno: 1443
> committer: Kristian B. Ølgaard <[email-masked]>
> branch nick: ffc
> timestamp: Thu 2010-03-11 14:59:32 +0100
> message:
>   Implement two new optimisation strategies for quadrature representation.

Nice. Can you send a short summary to the FFC list?

Garth

> modified:
>   ffc/cpp.py
>   ffc/parameters.py
>   ffc/quadrature/optimisedquadraturetransformer.py
>   ffc/quadrature/product.py
>   ffc/quadrature/quadraturegenerator.py
>   ffc/quadrature/quadratureoptimization.py
>   ffc/quadrature/quadraturerepresentation.py
>   ffc/quadrature/quadraturetransformer.py
>   ffc/quadrature/quadraturetransformerbase.py
>   ffc/quadrature/symbol.py
>   ffc/quadrature/symbolics.py
>   test/unit/symbolics/testelasticityterm.py
>   test/unit/symbolics/testelasweighted.py
>   test/unit/symbolics/testelasweighted2.py
>   test/unit/symbolics/testmixedsymbols.py
> The size of the diff (1013 lines) is larger than your specified limit of 1000 lines
> 
> --
> lp:ffc
> https://code.launchpad.net/~ffc-core/ffc/main
> 
> Your team FFC Core Team is subscribed to branch lp:ffc.
> To unsubscribe from this branch go to https://code.launchpad.net/~ffc-core/ffc/main/+edit-subscription.

---

From: Kristian Oelgaard <[email-masked]>
Date: Thu, 11 Mar 2010 23:29:54 +0100 (CET)

> Nice. Can you send a short summary to the FFC list?

The very short story can be found by:

man ffc

I plan to write this up shortly in the FFC optimisation chapter for the FEniCS book.

Kristian

> _______________________________________________
> Mailing list: https://launchpad.net/~ffc
> Post to     : [email-masked]
> Unsubscribe : https://launchpad.net/~ffc
> More help   : https://help.launchpad.net/ListHelp
>

---

From: Anders Logg <[email-masked]>
Date: Thu, 11 Mar 2010 23:50:03 +0100

> I plan to write this up shortly in the FFC optimisation chapter for the FEniCS book.

Nice!

--
Anders

PS: We just had a baby so I'm just lurking the mailing lists this and
next week.