Subject: [Ffc] [[email-masked]: [Branch ~ffc-core/ffc/main] Rev 1421: Split quadrature code generation into representation, optimisation and code generation.]

From: Anders Logg <[email-masked]>
Date: Mon, 15 Feb 2010 20:59:46 +0100

Cool! Could you add some suitable message in stage 3?

--
Anders

Subject: [Branch ~ffc-core/ffc/main] Rev 1421: Split quadrature code generation into representation, optimisation and code generation.
From: [email-masked]
To: Anders Logg <[email-masked]>
Date: Mon, 15 Feb 2010 19:34:23 -0000

------------------------------------------------------------
revno: 1421
committer: Kristian B. Ølgaard <[email-masked]>
branch nick: ffc
timestamp: Mon 2010-02-15 19:35:39 +0100
message:
  Split quadrature code generation into representation, optimisation and code generation.
modified:
  ffc/codegeneration.py
  ffc/cpp.py
  ffc/quadrature/optimisedquadraturetransformer.py
  ffc/quadrature/quadraturegenerator.py
  ffc/quadrature/quadratureoptimization.py
  ffc/quadrature/quadraturerepresentation.py
  ffc/quadrature/quadraturetransformer.py
  ffc/quadrature/quadraturetransformerbase.py
  ffc/representation.py
The size of the diff (1261 lines) is larger than your specified limit of 1000 lines

--
lp:ffc
https://code.launchpad.net/~ffc-core/ffc/main

Your team FFC Core Team is subscribed to branch lp:ffc.
To unsubscribe from this branch go to https://code.launchpad.net/~ffc-core/ffc/main/+edit-subscription.

---

From: Kristian Oelgaard <[email-masked]>
Date: Tue, 16 Feb 2010 09:28:44 +0100 (CET)

> Cool! Could you add some suitable message in stage 3?

Done, I think that FFC is finally in a stage where we can start writing things up for the FEniCS book chapters?

Kristian

> --
> Anders
>
>
> ---------- Forwarded message ----------
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v1.4.9 (GNU/Linux)
>
> iEYEARECAAYFAkt5p7EACgkQTuwUCDsYZdFHOQCeJKutzTHVrzBBbPhT/ZM3Tuph
> k68AnA2L9GoksXBH92uW0jq3UDNUxWXv
> =SUsu
> -----END PGP SIGNATURE-----
>
> _______________________________________________
> Mailing list: https://launchpad.net/~ffc
> Post to     : [email-masked]
> Unsubscribe : https://launchpad.net/~ffc
> More help   : https://help.launchpad.net/ListHelp
>
>

---

From: Anders Logg <[email-masked]>
Date: Tue, 16 Feb 2010 09:30:43 +0100

> Done, I think that FFC is finally in a stage where we can start writing things up for the FEniCS book chapters?

Great. Yes, I think so too. I'll set up a repo for that later today.

--
Anders