Subject: Re: [Ffc] [Branch ~ffc-core/ffc/dev] Rev 1516: Add some more references

From: Kristian Oelgaard <[email-masked]>
Date: Fri, 22 Jan 2010 11:42:46 +0100 (CET)

Shouldn't we have both 'tensor' and 'quadrature' references like we had in the old FFC?
Also, before these references can be trusted, we need to check that the new code will give the same result as simple_verify_tensors in the old FFC.

Kristian

2010/1/22  <[email-masked]>:
> ------------------------------------------------------------
> revno: 1516
> committer: Anders Logg <[email-masked]>
> branch nick: ffc-dev
> timestamp: Fri 2010-01-22 10:33:16 +0100
> message:
>  Add some more references
> added:
>  test/regression/references/Biharmonic.h
>  test/regression/references/Constant.h
>  test/regression/references/Elasticity.h
>  test/regression/references/FunctionOperators.h
>  test/regression/references/MetaData.h
>  test/regression/references/MixedMixedElement.h
>  test/regression/references/NavierStokes.h
>  test/regression/references/NeumannProblem.h
>  test/regression/references/Normals.h
>  test/regression/references/P5tet.h
>  test/regression/references/P5tri.h
>  test/regression/references/PoissonSystem.h
>  test/regression/references/StabilisedStokes.h
>  test/regression/references/Stokes.h
>  test/regression/references/VectorPoisson.h
> modified:
>  test/regression/references/Heat.h
>  test/regression/references/Poisson.h
> The size of the diff (42027 lines) is larger than your specified limit of 1000 lines
>
> --
> lp:~ffc-core/ffc/dev
> https://code.launchpad.net/~ffc-core/ffc/dev
>
> You are subscribed to branch lp:~ffc-core/ffc/dev.
> To unsubscribe from this branch go to https://code.launchpad.net/~ffc-core/ffc/dev/+edit-subscription.
>

---

From: Anders Logg <[email-masked]>
Date: Fri, 22 Jan 2010 12:00:48 +0100

On Fri, Jan 22, 2010 at 11:42:46AM +0100, Kristian Oelgaard wrote:
>
> Shouldn't we have both 'tensor' and 'quadrature' references like we
> had in the old FFC?  Also, before these references can be trusted,
> we need to check that the new code will give the same result as
> simple_verify_tensors in the old FFC.
>
> Kristian

I've been thinking about this and I think we can actually have just
one set of references for the demos. Then the representation will be
the one chosen by _auto_select_representation. That will simplify a
great deal.

But the new regression test will also support having a bunch of forms
to test which are not necessarily demos. We can have a file named
forms.py which contains a bunch of extra forms to test and in those we
can select both representations. This will lead to generation of two
different references, like FooTensor.h and FooQuadrature.h and all
these references can be thrown into the same directory.

This will be simpler than having to iterate over different
representations as part of the testing framework. Now we can just
iterate over a bunch of form files.

And yes, we need to check against the old simple_verify_tensors. I'll
be working on that.

--
Anders

---

From: "Garth N. Wells" <[email-masked]>
Date: Fri, 22 Jan 2010 11:23:48 +0000

> these references can be thrown into the same directory.

Why bother then with regression tests for the demos? Or just add all the
demos to the test forms.

> iterate over a bunch of form files.

Isn't iterating over different representations easy? Just a change in
the flag.

Garth

> ------------------------------------------------------------------------
> 
> _______________________________________________
> Mailing list: https://launchpad.net/~ffc
> Post to     : [email-masked]
> Unsubscribe : https://launchpad.net/~ffc
> More help   : https://help.launchpad.net/ListHelp

---

From: Anders Logg <[email-masked]>
Date: Fri, 22 Jan 2010 21:23:24 +0100

On Fri, Jan 22, 2010 at 11:23:48AM +0000, Garth N. Wells wrote:
> Why bother then with regression tests for the demos?

We need to make sure all the demos are checked so we don't ship a demo
that doesn't work.

> Or just add all the demos to the test forms.

Yes, that's exactly what we are doing. At the start of the regression
tests, all the demos are copied to a temporary directory along with
all the additional tests.

That has two advantages:

1. We make sure we don't forget about adding a demo to the tests when
a demo is added.

2. We can treat demos and additional tests in a uniform way since they
are all just .ufl files after the tests have been generated.

> Isn't iterating over different representations easy? Just a change in

A regression testing script quickly becomes very complex (we've had
several before) so any reductions in complexity we can make are
beneficial.

--
Anders