Subject: [FFC-dev] [Bug 426498] [NEW] UFL Variable not supported

From: logg <[email-masked]>
Date: Tue, 08 Sep 2009 21:04:39 -0000

Public bug reported:

To reproduce this bug, try compiling the hyperelasticity demo in UFL:

ffc HyperElasticity.ufl

Gives the following error message:

Visiting Variable: Variable(Sum(IntValue(1, (), (), {}), SpatialDerivative(Indexed(Function(VectorElement('Lagrange', Cell('tetrahedron', 1, Space(3)), 2, 3), 0), MultiIndex((FixedIndex(0),), {FixedIndex(0): 3})), MultiIndex((FixedIndex(0),), {}))), Label(0))
Variable is not supported (yet).
  
*** FFC: Variable is not supported (yet).
*** FFC: To get more information about this error, rerun FFC with --debug.

Fix suggested by Martin:

You can either just treat a variable v as if it were v.expression(),
or call "form = strip_variables(form)" to get rid of them.

** Affects: ffc
     Importance: Medium
         Status: New

** Changed in: ffc
   Importance: Undecided => Medium

-- 
UFL Variable not supported
https://bugs.launchpad.net/bugs/426498
You received this bug notification because you are subscribed to FFC.

Status in FEniCS Form Compiler: New

Bug description:
To reproduce this bug, try compiling the hyperelasticity demo in UFL:

ffc HyperElasticity.ufl

Gives the following error message:

Visiting Variable: Variable(Sum(IntValue(1, (), (), {}), SpatialDerivative(Indexed(Function(VectorElement('Lagrange', Cell('tetrahedron', 1, Space(3)), 2, 3), 0), MultiIndex((FixedIndex(0),), {FixedIndex(0): 3})), MultiIndex((FixedIndex(0),), {}))), Label(0))
Variable is not supported (yet).
  
*** FFC: Variable is not supported (yet).
*** FFC: To get more information about this error, rerun FFC with --debug.

Fix suggested by Martin:

You can either just treat a variable v as if it were v.expression(),
or call "form = strip_variables(form)" to get rid of them.

---

From: Garth Wells <[email-masked]>
Date: Wed, 09 Sep 2009 06:17:30 -0000

** Changed in: ffc
       Status: New => Confirmed

Status in FEniCS Form Compiler: Confirmed

Bug description:

ffc HyperElasticity.ufl

  

Fix suggested by Martin:

---

From: oelgaard <[email-masked]>
Date: Wed, 09 Sep 2009 15:26:10 -0000

** Changed in: ffc
       Status: Confirmed => Fix Released

** Changed in: ffc
     Assignee: (unassigned) => oelgaard (k-b-oelgaard)

Status in FEniCS Form Compiler: Fix Released

Bug description:

ffc HyperElasticity.ufl

  

Fix suggested by Martin:

---

From: logg <[email-masked]>
Date: Wed, 09 Sep 2009 15:45:05 -0000

>      Assignee: (unassigned) => oelgaard (k-b-oelgaard)

Great! This launchpad thing has really been a success. :-)

--
Anders

Bug description:

ffc HyperElasticity.ufl

  

Fix suggested by Martin:

---

From: Garth Wells <[email-masked]>
Date: Thu, 24 Sep 2009 07:37:20 -0000

** Changed in: ffc
       Status: Fix Released => Fix Committed

Status in FEniCS Form Compiler: Fix Committed

Bug description:

ffc HyperElasticity.ufl

  

Fix suggested by Martin:

---

From: logg <[email-masked]>
Date: Thu, 24 Sep 2009 19:49:18 -0000

** Changed in: ffc
       Status: Fix Committed => Fix Released

Bug description:

ffc HyperElasticity.ufl

  

Fix suggested by Martin: