Subject: [Ffc] ferari dependency

From: "Garth N. Wells" <[email-masked]>
Date: Wed, 10 Feb 2010 01:15:44 +0000

FFC now depends on ferari,

 File
"/usr/local/lib/python2.6/dist-packages/ffc/tensor/tensoroptimization.py",
line 17, in optimize_integral_ir
    from ferari import binary
ImportError: No module named ferari

I don't think that it should.

Garth

---

From: Kristian Oelgaard <[email-masked]>
Date: Wed, 10 Feb 2010 08:50:56 +0100 (CET)

> ImportError: No module named ferari

How did you find this bug? For me it only shows if I compile with -r tensor -O, I'm surprised that you're using that combination :)
Anyway, I pushed a fix for this.

Kristian

> _______________________________________________
> Mailing list: https://launchpad.net/~ffc
> Post to     : [email-masked]
> Unsubscribe : https://launchpad.net/~ffc
> More help   : https://help.launchpad.net/ListHelp
>

---

From: Anders Logg <[email-masked]>
Date: Wed, 10 Feb 2010 09:27:01 +0100

> Anyway, I pushed a fix for this.

Good that you fixed it. The import was actually inside try clause with
a suitable warning if FErari is not available, but I had some problems
which led me to adding an import before the try for debugging. I
forgot to remove it.

FErari should be an optional dependency.

--
Anders

---

From: "Garth N. Wells" <[email-masked]>
Date: Wed, 10 Feb 2010 08:55:29 +0000

Kristian Oelgaard wrote:
> How did you find this bug? For me it only shows if I compile with -r
> tensor -O, I'm surprised that you're using that combination :)

FFC is very clever these days. It  chooses quadrature for the 'real'
solve, and then the tensor representation for some projections.

Garth

---

From: Anders Logg <[email-masked]>
Date: Wed, 10 Feb 2010 10:56:28 +0100

> solve, and then the tensor representation for some projections.

:-)

--
Anders