Subject: [FFC-dev] Passing a parameter to the form file

From: Reza Farrahi Moghaddam <[email-masked]>
Date: Thu, 24 Apr 2008 10:13:30 -0700 (PDT)

Hi,

I have a parameter in my problem which its value may change frequently. Is it possible to pass some parameters from the main.cpp file to the form file? So, there will be no need to re-compile the form file.

Reza

      __________________________________________________________________
Looking for the perfect gift? Give the gift of Flickr! 

http://www.flickr.com/gift/

---

From: Anders Logg <[email-masked]>
Date: Thu, 24 Apr 2008 20:21:36 +0200

On Thu, Apr 24, 2008 at 10:13:30AM -0700, Reza Farrahi Moghaddam wrote:
> Hi,
>  
> I have a parameter in my problem which its value may change frequently. Is it
> possible to pass some parameters from the main.cpp file to the form file? So,
> there will be no need to re-compile the form file.
>  
> Reza

Yes, define it as a piecewise constant function using Constant() in
the form file.

-- 
Anders