Subject: Re: [Ffc] [Branch ~ffc-core/ffc/dev] Rev 1555: Modify format['transform'], quadrature code compiles and is correct for all forms except Quadratu...

From: Anders Logg <[email-masked]>
Date: Wed, 27 Jan 2010 02:13:00 +0100

We're getting closer. How did you check that the quadrature code is
correct? I get a lot of error messages in error.log still. Or are
those from evaluate_basis_* functions and tensor representation?

--
Anders

On Tue, Jan 26, 2010 at 10:12:16PM -0000, [email-masked] wrote:
> ------------------------------------------------------------
> revno: 1555
> committer: Kristian B. Ølgaard <[email-masked]>
> branch nick: dev
> timestamp: Tue 2010-01-26 22:42:59 +0100
> message:
>   Modify format['transform'], quadrature code compiles and is correct for all forms except QuadratureElement and ElementRestriction.
> modified:
>   ffc/cpp.py
>
>

> === modified file 'ffc/cpp.py'
> --- ffc/cpp.py	2010-01-26 15:11:26 +0000
> +++ ffc/cpp.py	2010-01-26 21:42:59 +0000
> @@ -253,6 +253,11 @@
>  def _transform(type, j, k, r):
>      # FIXME: j, k might need to be swapped for J or JINV
>      map_name = {"J": "J", "JINV": "K"}[type] + {None: "", "+": "0", "-": "1"}[r]
> +    # FIXME: KBO: In the old format["transform"] we swapped j and k, in the old
> +    # format["transform_ufl"] we didn't. format["transform_ufl"] was only used
> +    # in the tensorgenerator so it might not be needed anymore?
> +    if type == "J":
> +        return (map_name + "_%d%d") % (k, j)
>      return (map_name + "_%d%d") % (j, k)
>
>  def _generate_switch(variable, cases, default=None):
>

---

From: Kristian Oelgaard <[email-masked]>
Date: Wed, 27 Jan 2010 09:30:12 +0100 (CET)

> those from evaluate_basis_* functions and tensor representation?

I'm using the old simple_verify_tensors, I had to modify the integral names of the references though. I'll work on checking the results in evaluate_basis* today, with a bit of luck I will succeed.

Kristian

> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v1.4.9 (GNU/Linux)
>
> iEYEARECAAYFAktfkxsACgkQTuwUCDsYZdGKkwCgkmq9GI0vXJsZB5iRi/zguqAC
> hvIAniI9Y4PUfG48EfFFTqLo6ATfiVki
> =K+lj
> -----END PGP SIGNATURE-----
>
> _______________________________________________
> Mailing list: https://launchpad.net/~ffc
> Post to     : [email-masked]
> Unsubscribe : https://launchpad.net/~ffc
> More help   : https://help.launchpad.net/ListHelp
>
>