Subject: [Ffc] ffc import error

From: "Riesen Patrick" <[email-masked]>
Date: Sat, 26 Dec 2009 16:47:20 +0100

hello all,

I'm updating my code to the bazaar repositories with dolfin0.9.5. It all seemed to work fine, but i just can't run ffc, i get the following:

Traceback (most recent call last):
  File "/Users/priesen/Work/FEniCS/build/bin/ffc", line 27, in <module>
    from ffc.common.log import info, set_level, DEBUG, ERROR
  File "/Users/priesen/Work/FEniCS/build/lib/python2.5/site-packages/ffc/__init__.py", line 13, in <module>
    from ffc.compiler import compile_form, compile_element
ImportError: cannot import name compile_form

I used the most recent dorsal with the stable packages, but i get the same when pulling the dev repositories.
I'm using OSX 10.5.8

Thank you for any hints :-)

a (late) Merry Xmas to all,

patrick

---

From: Harish Narayanan <[email-masked]>
Date: Sat, 26 Dec 2009 16:02:48 +0000

> a (late) Merry Xmas to all,

Clean out your install folder and try to rebuild (the last stable) ffc
again. It should work.

Harish

---

From: "Riesen Patrick" <[email-masked]>
Date: Sat, 26 Dec 2009 17:38:16 +0100

thank you Harish, that did it!
regards,
patrick

-----Original Message-----
From: Harish Narayanan [mailto:[email-masked]]
Sent: Sat 26.12.2009 17:02
To: Riesen  Patrick
Cc: [email-masked]
Subject: Re: [Ffc] ffc import error

Harish