Subject: Re: [FFC-dev] [Bug 463105] [NEW] ImportError: No module named ufl.log

From: Johan Hake <[email-masked]>
Date: Thu, 29 Oct 2009 08:01:21 -0000

On Thursday 29 October 2009 07:13:43 cutejeff wrote:
> Public bug reported:
> 
> I am kind of new here. I just got my dolfin worked, with ffc-0.7.0
> installed.  I was trying the Poisson Enq demo, when I entered #ffc -l
> dolfin Poisson.ufl,  I got the following error:
> 
> Traceback (most recent call last):
>   File "/usr/bin/ffc", line 23, in <module>
>     from ufl.log import UFLException
> ImportError: No module named ufl.log

Have you installed the ufl package? From version 0.7 FFC now depends on
UFL.

Get the package from www.fenics.org

Johan

> I also tried ffc-0.6.2 and the latest snapshot, but I got the same
> errors. I do have the Poisson ufl file in the right directory. I don't
> know why it's not working.
> 
> Any help would be appreciated.
> 
> p.s. I always use
> #sudo python setup.py install
>  to install ffc packages.
> 
> Jeff
> 
> ** Affects: ffc
>      Importance: Undecided
>          Status: New
>

-- 
ImportError: No module named ufl.log
https://bugs.launchpad.net/bugs/463105
You received this bug notification because you are subscribed to FFC.

Status in FEniCS Form Compiler: New

Bug description:
I am kind of new here. I just got my dolfin worked, with ffc-0.7.0 installed.  I was trying the Poisson Enq demo, when I entered #ffc -l dolfin Poisson.ufl,  I got the following error:

Traceback (most recent call last):
  File "/usr/bin/ffc", line 23, in <module>
    from ufl.log import UFLException
ImportError: No module named ufl.log

I also tried ffc-0.6.2 and the latest snapshot, but I got the same errors. I do have the Poisson ufl file in the right directory. I don't know why it's not working.

Any help would be appreciated.
 
p.s. I always use
#sudo python setup.py install
 to install ffc packages.

Jeff

---

From: Garth Wells <[email-masked]>
Date: Fri, 30 Oct 2009 09:07:06 -0000

Since there hasn't been any feedback on the suggested fix, I'll
invalidate this bug.

** Changed in: ffc
       Status: New => Invalid

Status in FEniCS Form Compiler: Invalid

Bug description:

 
p.s. I always use

Jeff