Subject: [Ffc] [[email-masked]: [Branch ~ffc-core/ffc/dev] Rev 1601: Comment on domain2dim and entities_per_dim in fiatinterface.py.]

From: Anders Logg <[email-masked]>
Date: Sat, 30 Jan 2010 19:51:36 +0100

It would be good to collect all these in one place, but UFL cannot
depend on UFC and UFC cannot depend on UFL.

Are they needed in UFC? If not, it would be natural to collect them in
UFL. Then they can be used by both FFC and UFL.

--
Anders

Subject: [Branch ~ffc-core/ffc/dev] Rev 1601: Comment on domain2dim and entities_per_dim in fiatinterface.py.
From: [email-masked]
To: Anders Logg <[email-masked]>
Date: Sat, 30 Jan 2010 18:01:15 -0000

------------------------------------------------------------
revno: 1601
committer: Kristian B. Ølgaard <[email-masked]>
branch nick: dev
timestamp: Sat 2010-01-30 18:59:11 +0100
message:
  Comment on domain2dim and entities_per_dim in fiatinterface.py.
modified:
  ffc/fiatinterface.py

--
lp:~ffc-core/ffc/dev
https://code.launchpad.net/~ffc-core/ffc/dev

You are subscribed to branch lp:~ffc-core/ffc/dev.
To unsubscribe from this branch go to https://code.launchpad.net/~ffc-core/ffc/dev/+edit-subscription.
=== modified file 'ffc/fiatinterface.py'
--- ffc/fiatinterface.py	2010-01-30 14:02:31 +0000
+++ ffc/fiatinterface.py	2010-01-30 17:59:11 +0000
@@ -24,6 +24,9 @@
 # Cache for computed elements
 _cache = {}
 
+# FIXME: KBO: Should stuff like, domain2dim and entities_per_dim be in UFC
+# instead? The same goes for similar dictionaries in UFL (geometry.py). After
+# all both FFC and UFL complies with UFC or not?
 # Mapping from domain to dimension
 domain2dim = {"vertex": 0,
               "interval": 1,

---

From: Kristian Oelgaard <[email-masked]>
Date: Sat, 30 Jan 2010 20:08:26 +0100 (CET)

> UFL. Then they can be used by both FFC and UFL.

I don't think that we use it in UFC, but we do work with UFCInterval, UFCTriangle etc. in FFC and DOLFIN.
Let's put it in UFL, it doesn't matter to UFC how the internal representation is as long as the output of "interval" is a cell defined by the vertices [0, 1].

Kristian

> --
> Anders
>
>
> ---------- Forwarded message ----------
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v1.4.9 (GNU/Linux)
>
> iEYEARECAAYFAktkf7gACgkQTuwUCDsYZdG1RQCdEuIFoFEqoko5dp6sBf9WNlPU
> dYQAoIa12l0MaD7EcuYgd6I6wqkOXTKP
> =tXgZ
> -----END PGP SIGNATURE-----
>
> _______________________________________________
> Mailing list: https://launchpad.net/~ffc
> Post to     : [email-masked]
> Unsubscribe : https://launchpad.net/~ffc
> More help   : https://help.launchpad.net/ListHelp
>
>

---

From: Anders Logg <[email-masked]>
Date: Sat, 30 Jan 2010 20:10:45 +0100

> Let's put it in UFL, it doesn't matter to UFC how the internal representation is as long as the output of "interval" is a cell defined by the vertices [0, 1].

Sounds good. I have added a FIXME about it in the code. We can do
another round of cleanups for 0.9.1 and fix it then.

--
Anders