Subject: [Ffc] Failing form files

From: Anders Logg <[email-masked]>
Date: Thu, 21 Jan 2010 18:46:42 +0100

The following form files are currently failing, some because of
missing features in the tensor representation, but here are a couple
that I don't know how they should be handled:

ElementRestriction.ufl
*** FFC: Sorry, finite element of type "ElementRestriction" are not supported by FIAT.

QuadratureElement.ufl
*** FFC: Sorry, finite element of type "Quadrature" are not supported by FIAT.

--
Anders

---

From: Kristian Oelgaard <[email-masked]>
Date: Thu, 21 Jan 2010 18:57:49 +0100 (CET)

> *** FFC: Sorry, finite element of type "ElementRestriction" are not supported by FIAT.

This was handled by the FFC FiniteElement class by manipulating (among other things) the entity_dofs dict.
I'll have a look once finished with quadrature and the new format.

> *** FFC: Sorry, finite element of type "Quadrature" are not supported by FIAT.

I don't know if we can move this element to FIAT or if it is better to keep it in FFC. I think we just need to return a QuadratureElement object. I'll take a look at this one too.

Kristian

> --
> Anders
>
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v1.4.9 (GNU/Linux)
>
> iEYEARECAAYFAktYkwIACgkQTuwUCDsYZdGnzwCfWcJwv/E6epS7p94xCYvhLRfT
> nqMAn3XNMirZmGfiZOiqGFBA9R5heX0z
> =6XuI
> -----END PGP SIGNATURE-----
>
> _______________________________________________
> Mailing list: https://launchpad.net/~ffc
> Post to     : [email-masked]
> Unsubscribe : https://launchpad.net/~ffc
> More help   : https://help.launchpad.net/ListHelp
>
>

---

From: Anders Logg <[email-masked]>
Date: Thu, 21 Jan 2010 19:01:48 +0100

> I don't know if we can move this element to FIAT or if it is better to keep it in FFC. I think we just need to return a QuadratureElement object. I'll take a look at this one too.

ok, good.

I'm about to look more closely at supporting both quadrature and
tensor representation side by side and for the same form, metadata
etc.

--
Anders

---

From: Kristian Oelgaard <[email-masked]>
Date: Thu, 21 Jan 2010 19:09:20 +0100 (CET)

> tensor representation side by side and for the same form, metadata

OK, I just need to sort out the component business for mixed elements, then the code generation for quadrature should be more or less in place.

Kristian

> iEYEARECAAYFAktYlowACgkQTuwUCDsYZdFDEwCeJ4T+duojDgM4sFbi73ojJYIM
> +RYAnRkJVhyI4D1OHXH24ieFgrJ/0MEy
> =+u0A

---

From: Anders Logg <[email-masked]>
Date: Thu, 21 Jan 2010 19:50:27 +0100

> OK, I just need to sort out the component business for mixed elements, then the code generation for quadrature should be more or less in place.

That was quick! It took me much longer to sort out the tensor
generation.

Note that ufl_element.extract_component works differently from what we
used before which was part of FFC (extract_component_element?). The
new function returns the component relative to the nested simple sub
element whereas the old returned an offset. If you need the offset,
subtract what you get out of extract_component from what you send
in...

--
Anders

---

From: Kristian Oelgaard <[email-masked]>
Date: Fri, 22 Jan 2010 09:45:28 +0100 (CET)

> That was quick! It took me much longer to sort out the tensor

Everything is not in place yet, I just made the simplest changes possible to make things compile again.

> subtract what you get out of extract_component from what you send

I just use extract_component in one place, to get the sub_element corresponding to a  given component. I need this because I have to create the fiat_element to figure out what mapping is needed for that particular component, I don't use the offset for anything so I hope it just works out of the box.

Kristian

> iEYEARECAAYFAktYofIACgkQTuwUCDsYZdGxBgCgjnzJ8oDestrRH3yZC3wcZ8yg
> QNQAnjygLtbB51WQT8hO7ttRXQPyQRlc
> =eGio

---

From: Anders Logg <[email-masked]>
Date: Fri, 22 Jan 2010 10:26:40 +0100

ok, good.

--
Anders