Subject: [FFC-dev] FFC/jit options

From: Kristian Oelgaard <[email-masked]>
Date: Wed, 16 Jul 2008 18:01:24 +0200

Hi,

Why does the jit compiler use pop() when extracting options? e.g.,

  representation = options.pop("representation", FFC_REPRESENTATION)

this means that if I do:

def compile_form(form, options):
    (compiled_form, module, form_data) = jit(form, options)

options = {"representation":"quadrature"}

for form in forms:
  compile_form(form, options)

the second time I call jit options = {} which is clearly not what I want.

Kristian

---

From: Anders Logg <[email-masked]>
Date: Wed, 16 Jul 2008 22:52:21 +0200

> the second time I call jit options = {} which is clearly not what I want.

Ooops. Not my fault, I just merged it. :-)

See if it looks better now.

-- 
Anders

---

From: Johan Hake <[email-masked]>
Date: Thu, 17 Jul 2008 00:19:14 +0200

> Ooops. Not my fault, I just merged it. :-)

Yupp, my fault! Sorry for that one. I must have thought I was dealing with a 
copied dictionary!

Johan

---

From: Kristian Oelgaard <[email-masked]>
Date: Thu, 17 Jul 2008 09:12:28 +0200

> Yupp, my fault! Sorry for that one. I must have thought I was dealing with a

That's what happens, it appears to be working now. If working is defined as
doing what I want it to. :)

Kristian
 
> _______________________________________________
> FFC-dev mailing list
> [email-masked]
> http://www.fenics.org/mailman/listinfo/ffc-dev
>