Subject: [FFC-dev] The submission process

From: "Evan Lezar" <[email-masked]>
Date: Tue, 19 Aug 2008 17:03:23 +0200

Hi there

I have recently added some functionality to FFC for my own personal use (a
transverse curl operator) and was searching on the project website for
instructions on how to submit the changes using mecurial.  I did not find
any, so If someone could point me in the right direction it would be much
appreciated.

Thanks
Evan

---

From: Johan Hake <[email-masked]>
Date: Tue, 19 Aug 2008 17:59:44 +0200

> any, so If someone could point me in the right direction it would be much

in the ffc directory:

  # update your working directory and repository to latest version
  hg pull
  hg up
  # Commit your changes to your local repository
  hg commit -m"<Message>" 
  # Make a patch or bundle of your changes for a patch 
  hg export -o ffc-<your_name>-<the_date>.patch tip 
  # or for a bundle (a binary)
  # hg bundle ffc-<your_name>-<the_date>.hg

Send the patch/bundle to the email list and hope it get included :)

Johan

---

From: Anders Logg <[email-masked]>
Date: Tue, 19 Aug 2008 18:21:07 +0200

> Send the patch/bundle to the email list and hope it get included :)

Yes, and there are instructions for doing this in the manual.

Also note that if for some reason your patch does not appear, just ask
us why or send it again. I don't drop patches silently. If it has not
appeared, it's because I haven't had time, or it got lost, or I
think someone else (Garth) is handling it.

-- 
Anders

---

From: "Evan Lezar" <[email-masked]>
Date: Tue, 19 Aug 2008 20:11:29 +0200

Thanks.

I am nearly at a point where I can submit a demo of using fenics to solve a
waveguide cutoff problem, as soon as I have that working well enough I will
send through a patch with some of my basic changes.

Evan

On Tue, Aug 19, 2008 at 6:21 PM, Anders Logg <[email-masked]> wrote:

> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v1.4.6 (GNU/Linux)
>
> iD8DBQFIqvLzTuwUCDsYZdERAhBTAJ9/cO14iRX1iArQzC0itMKOERj4wQCghOwV
> JIIxuyr/oPRrILngCSoaHu4=
> =9SN8
> -----END PGP SIGNATURE-----
>
> _______________________________________________
> FFC-dev mailing list
> [email-masked]
> http://www.fenics.org/mailman/listinfo/ffc-dev
>
>