Subject: [FFC-dev] Protect the ASE import

From: [email-masked]
Date: Tue, 07 Jun 2005 00:02:09 +0200

Commit from knepley (2005-06-07 00:02 CEST)
-------------------

Protect the ASE import

  ffc  src/ffc/format/ase.py  1.2

---

From: Anders Logg <[email-masked]>
Date: Mon, 6 Jun 2005 17:18:52 -0500

There are still problems if I import the ase module:

  File "../ffc/compiler/compiler.py", line 23, in ?
    from ffc.format import ase
  File "../ffc/format/ase.py", line 43, in ?
    format = { "sum": sum,
AttributeError: 'NoneType' object has no attribute 'getVar'

I'll keep the import under the if-case in compiler.py until we know
how to do this.

What things from ASE are you using in ase.py? It should be possible to
compile without having access to the system you are compiling for (you
don't need to have DOLFIN or LaTeX installed to use -dolfin or -latex).

(As a side note, I should change -c++ to -dolfin.)

/Anders

On Tue, Jun 07, 2005 at 12:02:09AM +0200, [email-masked] wrote:
> _______________________________________________
> FFC-dev mailing list
> [email-masked]
> http://www.fenics.org/cgi-bin/mailman/listinfo/ffc-dev
> 

-- 
Anders Logg
Research Assistant Professor
Toyota Technological Institute at Chicago
http://www.tti-c.org/logg/