Subject: [Ffc] Tests for Projection.ufl fails

From: Marie Rognes <[email-masked]>
Date: Mon, 22 Mar 2010 13:49:45 +0100

The regression testing of Projection.ufl is failing for me (and has been 
so for a while).
Could it be that the references have not been updated for this form?

The first part of the diff is as follows:

    -// This code conforms with the UFC specification version 1.2
    -// and was automatically generated by FFC version 0.9.0-beta.
    +// This code conforms with the UFC specification version 1.4
    +// and was automatically generated by FFC version 0.9.2+.
    +//
    +// This code was generated with the following parameters:
    +//
    +//   cache_dir:                      ''
    +//   convert_exceptions_to_warnings: True
    +//   cpp_optimize:                   False
    +//   epsilon:                        1e-14
    +//   form_postfix:                   True
    +//   format:                         'ufc'
    +//   log_level:                      10
    +//   log_prefix:                     ''
    +//   optimize:                       False
    +//   output_dir:                     '.'
    +//   precision:                      '8'
    +//   quadrature_degree:              'auto'
    +//   quadrature_rule:                'auto'
    +//   representation:                 'auto'
    +//   split:                          False

--
Marie

---

From: Kristian Oelgaard <[email-masked]>
Date: Mon, 22 Mar 2010 15:19:54 +0100 (CET)

Works fine here, but I get:

Missing reference for Mini.out

Kristian

On 22 March 2010 13:49, Marie Rognes <[email-masked]> wrote:
>
> The regression testing of Projection.ufl is failing for me (and has been so
> for a while).
> _______________________________________________
> Mailing list: https://launchpad.net/~ffc
> Post to     : [email-masked]
> Unsubscribe : https://launchpad.net/~ffc
> More help   : https://help.launchpad.net/ListHelp
>

---

From: Marie Rognes <[email-masked]>
Date: Mon, 22 Mar 2010 15:31:53 +0100

Kristian Oelgaard wrote:
> Works fine here, 

Ah, pulled fresh branch -- and now I see.
Projection.ufl has been removed
from the demos directory, but the reference is still
hovering around.

> but I get:

Yes, will add once I've checked that the generated
code gives meaningful results.

--
Marie

---

From: Kristian Oelgaard <[email-masked]>
Date: Mon, 22 Mar 2010 16:04:04 +0100 (CET)

> from the demos directory, but the reference is still

Aha, that explains a lot.

> code gives meaningful results.

OK.

Kristian

>>> so