Subject: [FFC-dev] problem with instant

From: Shawn Walker <[email-masked]>
Date: Wed, 3 Sep 2008 11:33:37 -0400 (EDT)

I can't seem to run the instant example on the web page:

Python 2.5.2 (r252:60911, Aug  7 2008, 15:50:01)
[GCC 4.1.2 20071124 (Red Hat 4.1.2-42)] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> from instant import inline
>>>
>>> add_func = inline("double add(double a, double b){ return a+b; }")
Traceback (most recent call last):
   File "<stdin>", line 1, in <module>
   File "/home/walker/build/lib/python2.5/site-packages/instant/inline.py", 
line 33, in inline
     module = build_module(**kwargs)
   File 
"/home/walker/build/lib/python2.5/site-packages/instant/build_module.py", 
line 356, in build_module
     os.remove(compilation_checksum_filename)
OSError: [Errno 2] No such file or directory: 
'instant_module_5FDA6577711F1F317138812C0A45BD7C675B07F7.checksum'

Does anyone know what this error is?  I still only have SWIG 1.3.29 (the 
admin people have not installed the newer version yet...).

- Shawn

---

From: Ilmar Wilbers <[email-masked]>
Date: Wed, 03 Sep 2008 18:20:12 +0200

The OSError was due to a small bug in Instant. This is fixed now.

However, this does not say anything about why the compilation failed, 
but the error should still be flushed to a log file, have a look at that 
one.

ilmar

Shawn Walker wrote:
> _______________________________________________
> FFC-dev mailing list
> [email-masked]
> http://www.fenics.org/mailman/listinfo/ffc-dev
>