Subject: [FFC-dev] [HG] Change name of trial function u --> U in demos.

From: FFC <[email-masked]>
Date: Fri, 24 Feb 2006 20:58:49 +0100

One or more new changesets pushed to the primary FFC repository.
A short summary of the last three changesets is included below.

changeset:   345:243b821c64dc616183777e3ca1be558cc240c065
tag:         tip
user:        "Anders Logg <[email-masked]>"
date:        Fri Feb 24 20:54:52 2006 -0500
files:       src/demo/Elasticity.form src/demo/EnergyNorm.form src/demo/Heat.form src/demo/Mass.form src/demo/NavierStokes.form src/demo/Poisson.form src/demo/PoissonSystem.form src/demo/Projection.form src/demo/Stabilization.form src/demo/Stokes.form src/demo/TensorWeightedPoisson.form
description:
Change name of trial function u --> U in demos.
I really like a(v, u) better than a(v, U) but I thought long
and hard about this and finally convinced myself to change.
The change was necessary to avoid confusion in some lecture
notes I'm working on where both u and U appear.

Any name can be used of course, so this just affects the demos.

changeset:   344:b2936b4d11af4e5e152457f0cffb2a9786cc1201
user:        "Anders Logg <[email-masked]>"
date:        Tue Feb 21 06:12:19 2006 -0500
files:       src/demo/Poisson.form
description:
Remove leftovers from testing in Poisson.form

changeset:   343:118b846b009bd6d7f7a322bce1c7a42b7907d764
user:        "Anders Logg <[email-masked]>"
date:        Tue Feb 21 06:02:47 2006 -0500
files:       ChangeLog src/bin/ffc src/demo/P5tet.form src/demo/P5tri.form src/demo/Poisson.form src/ffc/compiler/compiler.py src/ffc/format/dolfin.py src/ffc/format/dolfinswig.py src/ffc/parser/simple.py src/reference/P5tet.h src/reference/P5tri.h
description:
Implement compilation of finite elements (without needing to specify a form).
Use this to compile new elements that are not precompiled for DOLFIN.
SWIG format may need a fix, so please take a look and see if it's ok.

----------------------------------------------------
For more details, visit http://www.fenics.org/hg/ffc

---

From: "Garth N. Wells" <[email-masked]>
Date: Fri, 24 Feb 2006 21:44:52 +0100

I'm not really bothered by u or U, but what I would really like is

v = TestFunction(element)
u = TrialFunction(element)

rather than BasisFunction(element).

Garth

On Fri, 2006-02-24 at 20:58 +0100, FFC wrote:
> _______________________________________________
> FFC-dev mailing list
> [email-masked]
> http://www.fenics.org/cgi-bin/mailman/listinfo/ffc-dev
-- 
Dr. Garth N. Wells
Faculty of Civil Engineering and Geosciences
Delft University of Technology
Stevinweg 1
2628 CN Delft
The Netherlands

tel.     +31 15 278 7922
fax.     +31 15 278 6383
e-mail   [email-masked]
url      http://www.mechanics.citg.tudelft.nl/~garth

---

From: Anders Logg <[email-masked]>
Date: Fri, 24 Feb 2006 14:46:32 -0600

Yes, that's probably better. I will fix this after the upcoming
release (0.3.0) of FFC.

It's a quick fix to implement but doing it would require too much work
just now since it would propagate throughout the demos, manuals and
lectures notes that I'm working on finishing up.

/Anders

-- 
Anders Logg
Research Assistant Professor
Toyota Technological Institute at Chicago
http://www.tti-c.org/logg/