Subject: [FFC-dev] [HG FFC] Remove analysis module, not used anymore

From: [email-masked] (FFC)
Date: Tue, 21 Apr 2009 12:12:26 +0200 (CEST)

One or more new changesets pushed to the primary ffc repository.
A short summary of the last three changesets is included below.

changeset:   1510:e0f95c05dc524421dec94c61b24216de0e29636f
tag:         tip
user:        Anders Logg <[email-masked]>
date:        Tue Apr 21 12:12:21 2009 +0200
files:       ffc/compiler/analysis/__init__.py ffc/compiler/analysis/analyze.py ffc/compiler/analysis/checks.py ffc/compiler/analysis/elementdata.py ffc/compiler/analysis/formdata.py ffc/compiler/analysis/ranges.py ffc/compiler/analysis/simplify.py
description:
Remove analysis module, not used anymore

changeset:   1509:2ffb1ccdc11baaadd9b646a01785b71cc9a5c787
user:        Anders Logg <[email-masked]>
date:        Tue Apr 21 12:07:39 2009 +0200
files:       ffc/__init__.py ffc/common/constants.py ffc/common/debug.py ffc/common/utils.py ffc/compiler/format/removeunused.py ffc/compiler/format/ufcformat.py ffc/compiler/uflcompiler.py ffc/fem/mixedelement.py ffc/fem/projection.py ffc/jit/jit.py ffc/jit/jitobject.py scripts/ffc
description:
Cleanup some more

changeset:   1508:9c2cc8b3bde558e9bf3ea8372269f2ddbdf9d6d7
user:        "Kristian Oelgaard <[email-masked]>"
date:        Tue Apr 21 11:10:12 2009 +0200
files:       ffc/compiler/codegeneration/quadrature/uflquadraturegenerator_utils.py ffc/fem/quadratureelement.py
description:
Fix bug for quadrature generation, passing all tests again.

----------------------------------------------------------------------
For more details, visit http://www.fenics.org/hg/ffc

---

From: Kristian Oelgaard <[email-masked]>
Date: Tue, 21 Apr 2009 12:37:32 +0200

The last two changesets broke a lot of things, particularly debug, will you fix
this or should I do it?

Kristian

Quoting FFC <[email-masked]>:

> files:       ffc/compiler/analysis/__init__.py
> ffc/compiler/analysis/analyze.py ffc/compiler/analysis/checks.py
> ffc/compiler/analysis/elementdata.py ffc/compiler/analysis/formdata.py
> ffc/compiler/analysis/ranges.py ffc/compiler/analysis/simplify.py
> description:
> files:       ffc/__init__.py ffc/common/constants.py ffc/common/debug.py
> ffc/common/utils.py ffc/compiler/format/removeunused.py
> ffc/compiler/format/ufcformat.py ffc/compiler/uflcompiler.py
> ffc/fem/mixedelement.py ffc/fem/projection.py ffc/jit/jit.py
> ffc/jit/jitobject.py scripts/ffc
> description:
> Cleanup some more
>
>
> files:
> ffc/compiler/codegeneration/quadrature/uflquadraturegenerator_utils.py
> ffc/fem/quadratureelement.py
> description:
> _______________________________________________
> FFC-dev mailing list
> [email-masked]
> http://www.fenics.org/mailman/listinfo/ffc-dev
>

---

From: Anders Logg <[email-masked]>
Date: Tue, 21 Apr 2009 13:10:22 +0200

Does it work now?

-- 
Anders

---

From: Kristian Oelgaard <[email-masked]>
Date: Tue, 21 Apr 2009 13:14:20 +0200

> Does it work now?

No, on a fresh clone:

Traceback (most recent call last):
  File "/home/oelgaard/fenics/clone/ffc/scripts/ffc", line 23, in <module>
    from ffc.common.log import info, debug, set_level, DEBUG, ERROR
  File "/home/oelgaard/fenics/clone/ffc/ffc/__init__.py", line 13, in <module>
    from ffc.compiler.uflcompiler import compile as compile_ufl
  File "/home/oelgaard/fenics/clone/ffc/ffc/compiler/uflcompiler.py", line 40,
in <module>
    from ffc.fem import create_element
  File "/home/oelgaard/fenics/clone/ffc/ffc/fem/__init__.py", line 1, in
<module>
    from createelement import create_element
  File "/home/oelgaard/fenics/clone/ffc/ffc/fem/createelement.py", line 14, in
<module>
    from finiteelement import FiniteElement as FFCFiniteElement
  File "/home/oelgaard/fenics/clone/ffc/ffc/fem/finiteelement.py", line 27, in
<module>
    from ffc.common.debug import *
ImportError: No module named debug

which is a problem in many places.

Kristian

---

From: Anders Logg <[email-masked]>
Date: Tue, 21 Apr 2009 13:16:50 +0200

ok, I'll take a look. It works here but I probably have some old .pyc
files lying around.

-- 
Anders

---

From: Anders Logg <[email-masked]>
Date: Tue, 21 Apr 2009 13:45:09 +0200

I made an attempt to fix it. It works for tensor representation but I
got lost somewhere in between all the [ufl]quadraturegenerator[_utils[2]]
files.

-- 
Anders

---

From: Kristian Oelgaard <[email-masked]>
Date: Tue, 21 Apr 2009 14:05:47 +0200

Where should we get the Restriction from?

Before we had Restriction.PLUS and Restriction.MINUS (and Restriction.CONSTANT
which we no longer need)

Kristian

Quoting Anders Logg <[email-masked]>:

> > > > The last two changesets broke a lot of things, particularly debug, will
> you
> > > fix
> > > > this or should I do it?
> > > >
> > > > Kristian
> > > >

---

From: Anders Logg <[email-masked]>
Date: Tue, 21 Apr 2009 14:08:08 +0200

I just use strings now: "+", "-", None

-- 
Anders

---

From: Kristian Oelgaard <[email-masked]>
Date: Tue, 21 Apr 2009 14:11:54 +0200

> I just use strings now: "+", "-", None

OK, so we just do this explicitly everywhere we need them. I'll fix this in
ufcformat.py then.

Kristian

> > > >   File "/home/oelgaard/fenics/clone/ffc/ffc/compiler/uflcompiler.py",
> line
> > > 40,
> > > > in <module>
> > > >   File "/home/oelgaard/fenics/clone/ffc/ffc/fem/createelement.py", line
> 14,
> > > in
> > > > <module>
> > > >   File "/home/oelgaard/fenics/clone/ffc/ffc/fem/finiteelement.py", line
> 27,
> > > in
> > > > <module>

---

From: Anders Logg <[email-masked]>
Date: Tue, 21 Apr 2009 14:27:42 +0200

> OK, so we just do this explicitly everywhere we need them. I'll fix this in

Yes. It's a bit messy with a mix of new and old code but we'll clean
it up as we go. This is already added to choose_map in ufcformay.py
but the old stuff is still there:

choose_map = {"PLUS": "0", "MINUS": "1", "CONSTANT": "0", None: "", "+": "0", "-": 1}

-- 
Anders