Subject: [Ffc] evaluate_basis

From: Anders Logg <[email-masked]>
Date: Thu, 14 Jan 2010 18:07:52 +0100

Some indentation and newlines seem to need fixing in evaluate_basis.

--
Anders

---

From: Kristian Oelgaard <[email-masked]>
Date: Thu, 14 Jan 2010 18:16:00 +0100 (CET)

> Some indentation and newlines seem to need fixing in evaluate_basis.

Sure, evaluate_basis is using the old format, once _derivatives is working I'll move to the new format and fix the code that looks ugly.

Kristian

> --
> Anders
>
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v1.4.9 (GNU/Linux)
>
> iEYEARECAAYFAktPT2cACgkQTuwUCDsYZdFE2gCghMa1SxpJ4bkheU9cvqO1tvG8
> YiMAnicCT5tghfnfoHWcFhPJ8bSvnClg
> =DB1N
> -----END PGP SIGNATURE-----
>
> _______________________________________________
> Mailing list: https://launchpad.net/~ffc
> Post to     : [email-masked]
> Unsubscribe : https://launchpad.net/~ffc
> More help   : https://help.launchpad.net/ListHelp
>
>

---

From: Anders Logg <[email-masked]>
Date: Thu, 14 Jan 2010 18:27:29 +0100

> Sure, evaluate_basis is using the old format, once _derivatives is working I'll move to the new format and fix the code that looks ugly.

ok.

I think we're getting pretty close to having something that sort of works.

Have you started thinking about getting the quadrature representation
working again? Will you have time to fix it so we can make a new
release before the end of January?

--
Anders

---

From: Kristian Oelgaard <[email-masked]>
Date: Thu, 14 Jan 2010 18:45:59 +0100 (CET)

> release before the end of January?

I was hoping that I could finish the evaluate stuff this week or Monday at the latest, then I'll start looking at the quadrature code.
I don't expect too many changes but I might be wrong. One problem with the January deadline is that it doesn't leave much time for testing. There is currently no unit test available for evaluate_basis and evaluate_basis_derivatives which I think is a big problem since it is quite impossible (for me) to check by simply looking at the code if the correct thing is computed.

What I would like to have is something simple like the simple_verify_tensor, which will evaluate all the dofs on an element at some arbitrary coordinate on some random cell (NOT the reference cell).
The derivatives should be evaluated up to the element degree.
We don't have to use the forms in the demo directory, instead we should just compile single elements of different type (including mixed) and degree.

It might also be a good idea to have similar tests for other functions of e.g., dof_map which have changed a lot?

The tests should be implemented in the 'old' FFC and verified by ffc/dev before we can release a new FFC.

We should also add references for simple_verify_tensors for the new forms you added and update the reference for the one you changed. (in the old FFC).

Kristian

> iEYEARECAAYFAktPVAEACgkQTuwUCDsYZdFQBQCfWDrYUR+GoegD/bK8zmp6eOIM
> 6ogAni7HNO4J2l7XGfmf9L8r9NqJK0Rn
> =GusQ

---

From: Marie Rognes <[email-masked]>
Date: Mon, 18 Jan 2010 14:14:48 +0100

Kristian Oelgaard wrote:
>>> Sure, evaluate_basis is using the old format, once _derivatives is 
>>> working I'll move to the new format and fix the code that looks ugly.
>>>
>>> Kristian
>>
>> ok.
>>
> I was hoping that I could finish the evaluate stuff this week or 
> Monday at the latest, then I'll start looking at the quadrature code.
> I don't expect too many changes but I might be wrong. One problem with 
> the January deadline is that it doesn't leave much time for testing. 
> There is currently no unit test available for evaluate_basis and 
> evaluate_basis_derivatives which I think is a big problem since it is 
> quite impossible (for me) to check by simply looking at the code if 
> the correct thing is computed.
>
> What I would like to have is something simple like the 
> simple_verify_tensor, which will evaluate all the dofs on an element 
> at some arbitrary coordinate on some random cell (NOT the reference 
> cell).
> We don't have to use the forms in the demo directory, instead we 
> should just compile single elements of different type (including 
> mixed) and degree.
>
> It might also be a good idea to have similar tests for other functions 
> of e.g., dof_map which have changed a lot?
>

FYI: I'm working on something like this.

--
Marie

> We should also add references for simple_verify_tensors for the new 
> forms you added and update the reference for the one you changed. (in 
> the old FFC).
>
> Kristian
>
>
>> -- 
>> Anders
>>
> ------------------------------------------------------------------------
>

---

From: Kristian Oelgaard <[email-masked]>
Date: Mon, 18 Jan 2010 14:23:28 +0100 (CET)

2010/1/18 Marie Rognes <[email-masked]>:
>> I was hoping that I could finish the evaluate stuff this week or Monday at
>> the latest, then I'll start looking at the quadrature code.
>> I don't expect too many changes but I might be wrong. One problem with the
>> January deadline is that it doesn't leave much time for testing. There is
>> currently no unit test available for evaluate_basis and
>> evaluate_basis_derivatives which I think is a big problem since it is quite
>> impossible (for me) to check by simply looking at the code if the correct
>> thing is computed.
>>
>> simple_verify_tensor, which will evaluate all the dofs on an element at some
>> arbitrary coordinate on some random cell (NOT the reference cell).
>> We don't have to use the forms in the demo directory, instead we should
>> just compile single elements of different type (including mixed) and degree.
>>

Yes I noticed, I'm working on some code for evaluate_basis.

Kristian

> --
> Marie
>
>
>> We should also add references for simple_verify_tensors for the new forms
>> you added and update the reference for the one you changed. (in the old
>> FFC).
>>
>> Kristian
>>
>>
>>> --
>>> Anders
>>>