Subject: Re: [Ffc] [Branch ~ffc-core/ffc/main] Rev 1332: Add new operators for the symbolics classes and rearrange unit tests for maintainability.

From: Anders Logg <[email-masked]>
Date: Thu, 7 Jan 2010 18:55:06 +0100

I haven't looked very closely at the symbolic stuff before, but it
seems a bit strange to have so much symbolic classes in FFC when we
have UFL as a symbolic backend.

Could this functionality be added to UFL instead?

--
Anders

On Thu, Jan 07, 2010 at 05:48:17PM -0000, [email-masked] wrote:
> ------------------------------------------------------------
> revno: 1332
> committer: Kristian B. Ølgaard <[email-masked]>
> branch nick: ffc
> timestamp: Thu 2010-01-07 18:45:09 +0100
> message:
>   Add new operators for the symbolics classes and rearrange unit tests for maintainability.
> removed:
>   test/unit/test_symbolics.py
> added:
>   test/unit/symbolics/
>   test/unit/symbolics/testdgelastodyn.py
>   test/unit/symbolics/testelasticity2d.py
>   test/unit/symbolics/testelasticityterm.py
>   test/unit/symbolics/testelasweighted.py
>   test/unit/symbolics/testelasweighted2.py
>   test/unit/symbolics/testexpandoperations.py
>   test/unit/symbolics/testfloat.py
>   test/unit/symbolics/testfloatoperators.py
>   test/unit/symbolics/testfraction.py
>   test/unit/symbolics/testfractionoperators.py
>   test/unit/symbolics/testmixedsymbols.py
>   test/unit/symbolics/testnotfinished.py
>   test/unit/symbolics/testpoisson.py
>   test/unit/symbolics/testproduct.py
>   test/unit/symbolics/testproductoperators.py
>   test/unit/symbolics/testrealexamples.py
>   test/unit/symbolics/testreducegip.py
>   test/unit/symbolics/testreduceoperations.py
>   test/unit/symbolics/testreducevartype.py
>   test/unit/symbolics/testsum.py
>   test/unit/symbolics/testsumoperators.py
>   test/unit/symbolics/testsymbol.py
>   test/unit/symbolics/testsymbolics.py
>   test/unit/symbolics/testsymboloperators.py
> modified:
>   AUTHORS
>   ffc/log.py
>   ffc/quadrature/floatvalue.py
>   ffc/quadrature/fraction.py
>   ffc/quadrature/product.py
>   ffc/quadrature/sumobj.py
>   ffc/quadrature/symbol.py
>   test/unit/test.py
> The size of the diff (6018 lines) is larger than your specified limit of 1000 lines
>

---

From: Kristian Oelgaard <[email-masked]>
Date: Fri, 8 Jan 2010 10:07:37 +0100 (CET)

> have UFL as a symbolic backend.

It is not really related to what UFL does. It is a lightweight SymPy which uses whatever format FFC uses for creating code. For these reasons it doesn't really fit within the scope of UFL which is input language only.

Kristian

> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v1.4.9 (GNU/Linux)
>
> iEYEARECAAYFAktGH/oACgkQTuwUCDsYZdFY8QCgiFEVeOg+P+F2cv2XHDfE8lZY
> GisAniBvf4rO8yTTYEJ9RyTTBfmXNKKM
> =od4O
> -----END PGP SIGNATURE-----
>
> _______________________________________________
> Mailing list: https://launchpad.net/~ffc
> Post to     : [email-masked]
> Unsubscribe : https://launchpad.net/~ffc
> More help   : https://help.launchpad.net/ListHelp
>
>

---

From: Anders Logg <[email-masked]>
Date: Fri, 8 Jan 2010 10:08:46 +0100

> It is not really related to what UFL does. It is a lightweight SymPy which uses whatever format FFC uses for creating code. For these reasons it doesn't really fit within the scope of UFL which is…

ok. I might have some more comments on it once I get into how the
quadrature code generation works.

--
Anders