Subject: [Ffc] Regression in quadrature code generator

From: Anders Logg <[email-masked]>
Date: Fri, 22 Jan 2010 22:05:13 +0100

Quite a few more forms are now failing, for example MetaData.ufl that
worked before:

 File
 "/home/logg/scratch/lib/fenics-dev/lib/python2.6/site-packages/ffc/quadrature/reduce_operations.py",
 line 19, in split_expression
    access = format["component"]("", [""])
KeyError: 'component'

--
Anders

---

From: Kristian Oelgaard <[email-masked]>
Date: Fri, 22 Jan 2010 22:09:03 +0100 (CET)

>    access = format["component"]("", [""])

Sorry for pushing that. I'm still working on moving to the new format.
A fix should be ready sometime this weekend.

Kristian

> --
> Anders
>
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v1.4.9 (GNU/Linux)
>
> iEYEARECAAYFAktaEwkACgkQTuwUCDsYZdFMbQCdHwztEkoQ5QkK7TR8hpDhlKxx
> 7MUAniiytxa/DBTwlW85dFzDyujMAm54
> =cru8
> -----END PGP SIGNATURE-----
>
> _______________________________________________
> Mailing list: https://launchpad.net/~ffc
> Post to     : [email-masked]
> Unsubscribe : https://launchpad.net/~ffc
> More help   : https://help.launchpad.net/ListHelp
>
>

---

From: Anders Logg <[email-masked]>
Date: Fri, 22 Jan 2010 22:26:14 +0100

> A fix should be ready sometime this weekend.

ok.

--
Anders