Subject: [Ffc] Jacobi code in codesnippets

From: Marie Rognes <[email-masked]>
Date: Mon, 25 Jan 2010 12:47:36 +0100

Would anyone object if I removed jacobian_nD in codesnippets and moved 
only_jacobian_nD to jacobian_nD?

Also can we remove all the _FIAT_ stuff from codesnippets?

--
Marie

---

From: Anders Logg <[email-masked]>
Date: Mon, 25 Jan 2010 12:55:54 +0100

On Mon, Jan 25, 2010 at 12:47:36PM +0100, Marie Rognes wrote:
>
> Would anyone object if I removed jacobian_nD in codesnippets and
> moved only_jacobian_nD to jacobian_nD?

Could you make sure to make the corresponding changes in
tensorgenerator.py, lines 66, 82, 99?

> Also can we remove all the _FIAT_ stuff from codesnippets?

Yes.

--
Anders

---

From: Marie Rognes <[email-masked]>
Date: Mon, 25 Jan 2010 12:59:52 +0100

> tensorgenerator.py, lines 66, 82, 99?

I'll do my best ;)

>> Also can we remove all the _FIAT_ stuff from codesnippets?

Ok. There seems to be one occurance of 'fiat_coordinate_map' in 
evaluatebasis.py.... Kristian?

--
Marie

---

From: Kristian Oelgaard <[email-masked]>
Date: Mon, 25 Jan 2010 13:38:48 +0100 (CET)

>> Also can we remove all the _FIAT_ stuff from codesnippets?

No, I use that in evaluate_basis*

Kristian

> --
> Anders
>
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v1.4.9 (GNU/Linux)
>
> iEYEARECAAYFAktdhsoACgkQTuwUCDsYZdH0HQCdEXO5aE4L/oYxeuxNfa/MwaLR
> mWsAnitr9OPn2iHTYKYxUAqMoO39/8DT
> =HebG
> -----END PGP SIGNATURE-----
>
> _______________________________________________
> Mailing list: https://launchpad.net/~ffc
> Post to     : [email-masked]
> Unsubscribe : https://launchpad.net/~ffc
> More help   : https://help.launchpad.net/ListHelp
>
>

---

From: Marie Rognes <[email-masked]>
Date: Mon, 25 Jan 2010 13:39:43 +0100

> No, I use that in evaluate_basis*

Isn't everything in FIAT now parameterized over the given
reference element?

--
Marie

---

From: Kristian Oelgaard <[email-masked]>
Date: Mon, 25 Jan 2010 14:09:06 +0100 (CET)

> Isn't everything in FIAT now parameterized over the given

In expansions.py, the points are mapped to the reference element (where the expansion functions are defined i.e., FIAT),
and since I'm generating a cpp version of FIAT code it is the easiest thing to do. Maybe it is possible to use points defined on the UFC elements, but I wouldn't know what to change and where.

Kristian

---

From: Marie Rognes <[email-masked]>
Date: Mon, 25 Jan 2010 14:19:08 +0100

Kristian Oelgaard wrote:
> In expansions.py, the points are mapped to the reference element 
> (where the expansion functions are defined i.e., FIAT),
> and since I'm generating a cpp version of FIAT code it is the easiest 
> thing to do. Maybe it is possible to use points defined on the UFC 
> elements, but I wouldn't know what to change and where.
>

Ok. I'll leave the snippet used then.

--
Marie