Subject: [FFC-dev] [HG FFC] Fixed interesting bug with regard to index range generation

From: [email-masked] (FFC)
Date: Mon, 6 Jul 2009 15:11:58 +0200 (CEST)

One or more new changesets pushed to the primary ffc repository.
A short summary of the last three changesets is included below.

changeset:   1574:db32bc7cb8e3cbac0775ec190026e65a4d87692e
tag:         tip
user:        "Marie E. Rognes ([email-masked])"
date:        Tue Jul 07 00:09:51 2009 +0200
files:       ffc/compiler/representation/tensor/monomialtransformation.py
description:
Fixed interesting bug with regard to index range generation
for tensor representation.

changeset:   1573:d5bfd79d24ead7d448c4b1a4f237c70991df51c1
user:        "Marie E. Rognes ([email-masked])"
date:        Mon Jul 06 23:54:08 2009 +0200
files:       ffc/compiler/representation/tensor/monomialtransformation.py
description:
Allowed transformations of monomials where all components
have the same mapping (but not necessarily AFFINE)

changeset:   1572:2a2284cce7ea1d6f2daeaf618c0be1f91bb4f9ae
user:        "Marie E. Rognes ([email-masked])"
date:        Mon Jul 06 23:29:04 2009 +0200
files:       test/regression/test.py
description:
Fix return value from regression test

----------------------------------------------------------------------
For more details, visit http://www.fenics.org/hg/ffc

---

From: Kristian Oelgaard <[email-masked]>
Date: Mon, 06 Jul 2009 15:28:45 +0200

> for tensor representation.

Would this perhaps fix the result for the mass matrix of Nedelec elements?

Kristian

> _______________________________________________
> FFC-dev mailing list
> [email-masked]
> http://www.fenics.org/mailman/listinfo/ffc-dev
>

---

From: Marie Rognes <[email-masked]>
Date: Tue, 07 Jul 2009 00:27:52 +0200

> Would this perhaps fix the result for the mass matrix of Nedelec elements?

Testing in progress, but that was the idea, yes ;)

--
Marie