Subject: [Ffc] EnrichedElement

From: Mehdi Nikbakht <[email-masked]>
Date: Tue, 06 Apr 2010 18:25:58 +0200

Hello,

I am trying to use new syntax for the enriched elements.  I don't see
the reason why we can not enrich an scaler element. Assume this form
file,

P1 = FiniteElement("Lagrange", triangle, 1)

Mini =  P1 + P1

v = TestFunction(Mini)
u = TrialFunction(Mini)

a = inner(v, u)*dx

this file can't be compiled. But if we use VectorElement instead of
FiniteElement, it works fine. Is it a bug?

In addition, is it possible to have access to the dof maps of underling
elements, independently?

Yours,
Mehdi

---

From: Marie Rognes <[email-masked]>
Date: Tue, 06 Apr 2010 19:50:06 +0200

> FiniteElement, it works fine. Is it a bug?

Most definitely. I'll fix tomorrow unless anyone beats me to it. (It is 
just a matter of fixing some indicing in EnrichedElement.tabulate, I think.)

> In addition, is it possible to have access to the dof maps of underling

I don't quite understand what you mean here. Do you mean that you want 
code generated for each of the underlying elements as well?

--
Marie
> Yours,
> Mehdi
>
> _______________________________________________
> Mailing list: https://launchpad.net/~ffc
> Post to     : [email-masked]
> Unsubscribe : https://launchpad.net/~ffc
> More help   : https://help.launchpad.net/ListHelp
>

---

From: Marie Rognes <[email-masked]>
Date: Wed, 07 Apr 2010 13:59:33 +0200

Marie Rognes wrote:
> Most definitely. I'll fix tomorrow unless anyone beats me to it. (It 
> is just a matter of fixing some indicing in EnrichedElement.tabulate, 
> I think.)

This should be fixed now.

--
Marie