Subject: [FFC-dev] [HG FFC] Fixes for JIT compiler, caching in Instant seems to work now!

From: [email-masked] (FFC)
Date: Thu, 13 Dec 2007 11:21:22 +0100 (CET)

One or more new changesets pushed to the primary ffc repository.
A short summary of the last three changesets is included below.

changeset:   1027:9dfac24a56568464ab8f7a051c1f9c1d90866e7d
tag:         tip
user:        "Anders Logg <[email-masked]>"
date:        Thu Dec 13 11:21:15 2007 +0100
files:       src/ffc/jit/jit.py
description:
Fixes for JIT compiler, caching in Instant seems to work now!
Thanks Kent! :-)

changeset:   1026:282c54a8e905345227f952276e3c654b66ae4177
user:        "Anders Logg <[email-masked]>"
date:        Mon Dec 10 21:24:33 2007 +0100
files:       src/ffc/jit/jit.py
description:
Don't generate code for evaluate_basis and evaluate_basis_derivatives in JIT compiler

changeset:   1025:81007f2a4b8e5e483b242af3b5ac851336ded085
user:        "Kristian Oelgaard <[email-masked]>"
date:        Mon Dec 10 15:28:42 2007 +0100
files:       src/ffc/compiler/analysis/checks.py src/ffc/compiler/codegeneration/common/finiteelement.py src/ffc/compiler/language/operators.py src/ffc/compiler/representation/tensor/monomialintegration.py src/ffc/fem/quadratureelement.py
description:
Added quadratureelement.py (experimental) to src/ffc/fem/.

----------------------------------------------------------------------
For more details, visit http://www.fenics.org/hg/ffc

---

From: "Garth N. Wells" <[email-masked]>
Date: Thu, 13 Dec 2007 12:27:02 +0000

> Fixes for JIT compiler, caching in Instant seems to work now!

Looks like this might have broken somethimg.

Garth

Solving linear PDE.
Traceback (most recent call last):
   File "demo.py", line 66, in <module>
     u = pde.solve()
   File 
"/home/garth/code/fenics/dolfin/dolfin-ublas/local/lib/python2.5/site-packages/dolfin/assemble.py", 
line 142, in solve
     (A, self.dof_maps) = assemble(self.a, self.mesh)
   File 
"/home/garth/code/fenics/dolfin/dolfin-ublas/local/lib/python2.5/site-packages/dolfin/assemble.py", 
line 24, in assemble
     (compiled_form, module, form_data) = jit(form)
   File "/usr/lib/python2.5/site-packages/ffc/jit/jit.py", line 55, in jit
     instant.create_extension(wrap_headers=[filename], 
module=module_name, additional_declarations=ufc_include, include_dirs=path)
   File "/usr/lib/python2.5/site-packages/instant.py", line 675, in 
create_extension
     ext.create_extension(**args)
   File "/usr/lib/python2.5/site-packages/instant.py", line 228, in 
create_extension
     shutil.copyfile(file, os.path.join(tmp_dir, self.module,  file))
   File "/usr/lib/python2.5/shutil.py", line 46, in copyfile
     fsrc = open(src, 'rb')
IOError: [Errno 2] No such file or directory: '../ffc_form_0.h'

> _______________________________________________
> FFC-dev mailing list
> [email-masked]
> http://www.fenics.org/mailman/listinfo/ffc-dev

---

From: Anders Logg <[email-masked]>
Date: Thu, 13 Dec 2007 13:57:43 +0100

> Looks like this might have broken somethimg.

Did you update both FFC and Instant?

-- 
Anders

---

From: "Garth N. Wells" <[email-masked]>
Date: Thu, 13 Dec 2007 14:19:55 +0000

> Did you update both FFC and Instant?

Forgot to  do 'hg update' for FFC.  Works now.

Garth