Subject: [Ffc] Dependency on DOLFIN

From: Johannes Ring <[email-masked]>
Date: Tue, 18 May 2010 09:46:35 +0200

Hi,

See this bug report: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=581897

Does FFC require DOLFIN? Is it only dolfin_utils that is required? If
so, maybe there should be a separate package python-dolfin-utils in
Debian and let python-ffc depend on this package?

Johannes

---

From: "Garth N. Wells" <[email-masked]>
Date: 18 May 2010 09:05:24 +0100

On May 18 2010, Johannes Ring wrote:

>Hi,
>
> See this bug report: 
> http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=581897
>
>Does FFC require DOLFIN? 

Only when using the '-l dolfin' flag.

We should add a more informative error message.

Garth

> Is it only dolfin_utils that is required? If
>_______________________________________________
>Mailing list: https://launchpad.net/~ffc
>Post to     : [email-masked]
>Unsubscribe : https://launchpad.net/~ffc
>More help   : https://help.launchpad.net/ListHelp
>

---

From: Johannes Ring <[email-masked]>
Date: Tue, 18 May 2010 10:32:52 +0200

> We should add a more informative error message.

When DOLFIN is not available and I run

  ffc -l dolfin -r quadrature SteadyStokes.ufl

like in the bug report above, I get

  Unable to generate DOLFIN wrappers, missing module dolfin_utils.wrappers.

  *** FFC: Unable to generate DOLFIN wrappers, missing module
dolfin_utils.wrappers.
  *** FFC: To get more information about this error, rerun FFC with --debug.

which I think is a okay error message. If I rerun FFC with the --debug
flag, I get the same error message as in the bug report.

Maybe the best and simplest solution is to add python-dolfin as a
recommendation or a suggestion in the python-ffc package.

Johannes

---

From: "Garth N. Wells" <[email-masked]>
Date: Tue, 18 May 2010 10:02:19 +0100

On 18/05/10 09:32, Johannes Ring wrote:
> On Tue, May 18, 2010 at 10:05 AM, Garth N. Wells<[email-masked]>  wrote:
> which I think is a okay error message.

We can add a bit more to the message, e.g. suggest installing DOLFIN.

> If I rerun FFC with the --debug

Sounds good.

Garth

---

From: Johan Hake <[email-masked]>
Date: Tue, 18 May 2010 08:59:29 -0700

> > recommendation or a suggestion in the python-ffc package.

Not sure how this adds up to a debian package, but the dolfin_utils can be 
installed without the PyDOLFIN option in SCons. What I mean is that optimally 
should dolfin_utils be installed together with the ordinary dolfin packages. A 
person should be able to install dolfin without python-dolfin.

Johan