Subject: [FFC-dev] evaluate_dof bug

From: "Garth N. Wells" <[email-masked]>
Date: Thu, 26 Apr 2007 02:08:32 +0200

Inside the function evaluate_dof, FFC is generating the code

   // Compute affine mapping x = F(X)
   coordinates[0] = w0*x[0][0] + w1*x[1][0] + w2*x[2][0] + w3*x[3][0];
   coordinates[0] = w0*x[0][1] + w1*x[1][1] + w2*x[2][1] + w3*x[3][1];
   coordinates[0] = w0*x[0][2] + w1*x[1][2] + w2*x[2][2] + w3*x[3][2];

which should be

   // Compute affine mapping x = F(X)
   coordinates[0] = w0*x[0][0] + w1*x[1][0] + w2*x[2][0] + w3*x[3][0];
   coordinates[1] = w0*x[0][1] + w1*x[1][1] + w2*x[2][1] + w3*x[3][1];
   coordinates[2] = w0*x[0][2] + w1*x[1][2] + w2*x[2][2] + w3*x[3][2];

(the index for the array coordinates should be 0, 1 ,2).

Garth

---

From: Anders Logg <[email-masked]>
Date: Thu, 26 Apr 2007 09:35:44 +0200

ok, fixed.

/Anders

On Thu, Apr 26, 2007 at 02:08:32AM +0200, Garth N. Wells wrote:
> _______________________________________________
> FFC-dev mailing list
> [email-masked]
> http://www.fenics.org/mailman/listinfo/ffc-dev