Subject: [FIAT-dev] More on Raviart-Thomas

From: Marie Rognes <[email-masked]>
Date: Thu, 15 Mar 2007 15:41:34 -0500

Thanks for fixing the last problem!

Now, I have some new related to the degrees of freedom of the 
Raviart-Thomas elements.

First, the following FIAT code:

    from FIAT.RaviartThomas import *
    from FIAT.shapes import *
    RT0 = RaviartThomas(TRIANGLE, 0) 
    print RT0.dual_basis().entity_ids

gives:

    {0: {0: [], 1: [], 2: []}, 1: {0: 0, 1: 1, 2: 2}, 2: []}

Shouldn't this be

    {0: {0: [], 1: [], 2: []}, 1: {0: [0], 1: [1], 2: [2]}, 2: []} ?

Further,

    RT1 = RaviartThomas(TRIANGLE, 1) 
    print RT1.dual_basis().entity_ids

gives

{0: {0: [], 1: [], 2: []}, 1: {0: 1, 1: 3, 2: 5}, 2: [6, 7]}

What happened to degrees of freedom number 0, 2 and 4?

--
Marie

---

From: Marie Rognes <[email-masked]>
Date: Thu, 15 Mar 2007 15:48:57 -0500

>     print RT0.dual_basis().entity_ids
I guess a more sensible suggestion would be

{0: {0: [], 1: [], 2: []}, 1: {0: [0], 1: [1], 2: [2]}, 2: {0: []}} 

--
Marie