Subject: Re: [Fiat] [Ffc] [Branch ~ffc-core/ffc/dev] Rev 1426: Use new FIAT interface for quadrature rules and remove ffcquadraturerules.py.

From: Anders Logg <[email-masked]>
Date: Fri, 8 Jan 2010 16:52:22 +0100

On Fri, Jan 08, 2010 at 04:48:54PM +0100, Kristian Oelgaard wrote:
>
>
> 2010/1/8  <[email-masked]>:
> >------------------------------------------------------------
> >revno: 1426
> >committer: Anders Logg <[email-masked]>
> >branch nick: ffc-dev
> >timestamp: Fri 2010-01-08 14:06:48 +0100
> >message:
> > Use new FIAT interface for quadrature rules and remove ffcquadraturerules.py.
> > Old make_quadrature replaced by create_quadrature now in fiatinterface.py.
>
> If we want to support other quadrature rules should we then
> implement those in FIAT instead of FFC? The design of
> ffcfquadraturerules.py was intended to support easy addition of
> other rules.

I didn't think about that, but it would make sense to implement them
as part of FIAT. I think Rob has indicated that he would be willing
include other rules in FIAT.

--
Anders

---

From: Kristian Oelgaard <[email-masked]>
Date: Fri, 8 Jan 2010 16:56:13 +0100 (CET)

> include other rules in FIAT.

OK, I don't really care as long as it's possible to put them somewhere once we start looking at it.

Kristian

> --
> Anders
>
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v1.4.9 (GNU/Linux)
>
> iEYEARECAAYFAktHVLYACgkQTuwUCDsYZdHZ1QCgiALTKsFURzBh3GjADWfuF3Ea
> EpoAoICvhkAQWcX8CgyKqNsTHLodnqb8
> =FnH7
> -----END PGP SIGNATURE-----
>
>