Subject: [FIAT-dev] Fixes for numbering of entities

From: Anders Logg <[email-masked]>
Date: Thu, 14 Jun 2007 10:30:22 +0200

Rob, here's a bundle that fixes the numbering issue for FIAT/FFC.

It adds a new variable numbering_scheme which by the default is set to
"default" (and does not change the way FIAT numbers the entities). One
may also set this variable to "UFC" which makes FIAT use the UFC
numbering scheme.

FFC now does the following at startup:

    from FIAT import numbering
    numbering.numbering_scheme = "UFC"

To apply the bundle, just do

    hg unbundle bundle.hg

You can also check what's in the bundle before applying it:

    hg incoming -v -p bundle.hg

/Anders

---

From: "Robert Kirby" <[email-masked]>
Date: Fri, 15 Jun 2007 06:58:23 -0600

Thanks.  I'll take a look at this next week.  I am back in TX, but at my
parents' house now.

Rob

On 6/14/07, Anders Logg <[email-masked]> wrote:
> _______________________________________________
> FIAT-dev mailing list
> [email-masked]
> http://www.fenics.org/mailman/listinfo/fiat-dev
>
>
>

---

From: "Robert Kirby" <[email-masked]>
Date: Tue, 19 Jun 2007 13:04:12 -0500

I think I succeeded in applying this.  This was the first time I've tried a
bundle in hg.

Rob

---

From: Anders Logg <[email-masked]>
Date: Wed, 20 Jun 2007 00:54:43 +0200

Thanks!

Any chance of getting a new release of FIAT? I'm about to make a new
release of FFC (and coordinated release of DOLFIN) and it will depend
on the development version which is suboptimal.

/Anders

On Tue, Jun 19, 2007 at 01:04:12PM -0500, Robert Kirby wrote:
> On 6/14/07, Anders Logg < [email-masked]> wrote:
>

---

From: "Robert Kirby" <[email-masked]>
Date: Tue, 19 Jun 2007 20:27:30 -0500

Anders, I don't mind making a new release.  I will do this tomorrow.

Rob

---

From: Anders Logg <[email-masked]>
Date: Wed, 20 Jun 2007 13:41:03 +0200

Excellent!

/Anders

On Tue, Jun 19, 2007 at 08:27:30PM -0500, Robert Kirby wrote:
> On 6/19/07, Anders Logg <[email-masked] > wrote:
> 
>     Thanks!
>

---

From: "Robert Kirby" <[email-masked]>
Date: Wed, 20 Jun 2007 17:09:50 -0500

I seem to have deleted the information on the steps to take.  Do you have
this someplace?

Rob

On 6/20/07, Anders Logg <[email-masked]> wrote:
> >     > I think I succeeded in applying this.  This was the first time
> I've tried
> >     a
> >     > bundle in hg.
> >     >
> >     > Rob
> >     >
> >     >     It adds a new variable numbering_scheme which by the default
> is set
> >     to
> >     >     "default" (and does not change the way FIAT numbers the
> entities).
> >     One

---

From: Anders Logg <[email-masked]>
Date: Thu, 21 Jun 2007 00:42:56 +0200

You mean for making the release?

We should probably add this to the wiki, but here's a short list:

0. Make any preparations in FIAT (like updating ChangeLog, version
numbers if any).

1. Make the tarball fiat-x.y.z.tar.gz (but I think you use uppercase).
Make sure you don't include the .hg directory when you make it. (Just
delete it before making the tarball.)

2. Upload it to www.fenics.org/pub/software/fiat to fenics.org. This
must be done as user fenics.

3. Run the 'news' command on fenics.org as user fenics to update the
news on the front page.

4. Update the link to the latest version in the Download section on
fenics.org (must be done through the wiki).

5. Announce the release to fiat-dev.

That's it I think.

/Anders

On Wed, Jun 20, 2007 at 05:09:50PM -0500, Robert Kirby wrote:
> I seem to have deleted the information on the steps to take.  Do you have this
> someplace?
> 
> Rob
> 
> On 6/20/07, Anders Logg < [email-masked]> wrote:
> 
>     Excellent!
> 
>     /Anders
> 
>     >     > I think I succeeded in applying this.  This was the first time I've
>     tried
>     >     a
>     >     > bundle in hg.
>     >     >
>     >     > Rob
>     >     >
>     >     >     It adds a new variable numbering_scheme which by the default is
>     set
>     >     to

---

From: "Robert Kirby" <[email-masked]>
Date: Wed, 20 Jun 2007 20:37:29 -0500

Thanks, done.  So it's after "tomorrow" there, but still "tomorrow" here :)

Rob

On 6/20/07, Anders Logg <[email-masked]> wrote:
> >     >     >     Rob, here's a bundle that fixes the numbering issue for
> FIAT/
> >     FFC.
> >     >     >
> >     >     >     may also set this variable to "UFC" which makes FIAT use
> the
> >     UFC
> >     >     >     numbering scheme.
> >     >     >