Subject: Re: [Fiat] [Ffc] ffc module scientific python

From: "Garth N. Wells" <[email-masked]>
Date: Tue, 02 Feb 2010 11:13:00 +0000

Patrick Riesen wrote:
> hi, i'm following up with you to keep close to the next release of fenics,
> 
> i just built everything (no errors) but for ffc i get
> 
> 
> Exception: Unable to import the Python Scientific module required by FIAT.
> Consider installing the package python-scientific.
> 
> 
> can you tell me which package this is? obviously it's not scipy?
> 

It's:

    http://dirac.cnrs-orleans.fr/plone/software/scientificpython/

If you use Debian/Ubuntu, the package is called 'python-scientific'.

We should see if we can find a mainstream alternative, for example from
SciPy.

Garth

> best regards,
> 
> patrick
> 
> _______________________________________________
> Mailing list: https://launchpad.net/~ffc
> Post to     : [email-masked]
> Unsubscribe : https://launchpad.net/~ffc
> More help   : https://help.launchpad.net/ListHelp

---

From: Patrick Riesen <[email-masked]>
Date: Tue, 2 Feb 2010 12:23:28 +0100

>     http://dirac.cnrs-orleans.fr/plone/software/scientificpython/

Garth, thank you,

I fetched 2.9 from

http://sourcesup.cru.fr/frs/download.php/2372/ScientificPython-2.9.0.tar.gz

and it was no problem for installing from source.

I just compiled all FEniCS development modules and all went fine.

Looking forward to the new releases,

best regards,

patrick