Subject: [Fiat] Release of FIAT

From: Anders Logg <[email-masked]>
Date: Thu, 28 Jan 2010 19:21:28 +0100

Rob, we're getting closer to finishing the rewrite of FFC.

If possible, we want to finish before the Ubuntu import freeze so we
can make it into the next Ubuntu release. This means we have to finish
up pretty soon (like yesterday).

Would it be ok for me to make a new release of FIAT when the time
comes and rename FIAT_NEW --> FIAT?

Btw, Crouzex-Raviart seem to be missing, but I guess they will be
added back?

--
Anders

---

From: "Garth N. Wells" <[email-masked]>
Date: Thu, 28 Jan 2010 18:26:32 +0000

> comes and rename FIAT_NEW --> FIAT?

The import of various modules should be checked. There was a hack to import

  Derivatives, FirstDerivatives

which I changed, but it should be cleaned up, checked and tested.

FIAT now has more dependencies than before which should be taken care of
in the packaging.

Garth

> ------------------------------------------------------------------------
> 
> _______________________________________________
> Mailing list: https://launchpad.net/~fiat
> Post to     : [email-masked]
> Unsubscribe : https://launchpad.net/~fiat
> More help   : https://help.launchpad.net/ListHelp

---

From: Robert Kirby <[email-masked]>
Date: Thu, 28 Jan 2010 14:49:33 -0600

Anders, Garth,
Doing a release is fine. We should probably bump up the minor version to 0.4
or something since this is a substantial rewrite.  Or does that mean 1.0?

Crouzeix-Raviart is not hard to put back in, but I haven't done it.

The Derivative modules should be addressed.  We either need to add the
scientific python dependency, or else redistribute the appropriate
differentiation files with it.

Rob

---

From: Anders Logg <[email-masked]>
Date: Thu, 28 Jan 2010 21:56:31 +0100

On Thu, Jan 28, 2010 at 02:49:33PM -0600, Robert Kirby wrote:
> Anders, Garth,
> Doing a release is fine. We should probably bump up the minor version to 0.4 or
> something since this is a substantial rewrite.  Or does that mean
> 1.0?

You could bump it to 0.9.0, same as for FFC (which was last 0.7.1).

> differentiation files with it.

The scientific python dependency is not a problem for me. Anyone else?

--
Anders

---

From: "Garth N. Wells" <[email-masked]>
Date: Thu, 28 Jan 2010 21:09:08 +0000

> The scientific python dependency is not a problem for me. Anyone else?

There are more, sympy I think.

Garth

---

From: Marie Rognes <[email-masked]>
Date: Thu, 28 Jan 2010 22:50:34 +0100

Robert Kirby wrote:
> Anders, Garth,
> Doing a release is fine. We should probably bump up the minor version 
> to 0.4 or something since this is a substantial rewrite.  Or does that 
> mean 1.0?
>

Fixed.

--
Marie

> On Thu, Jan 28, 2010 at 12:26 PM, Garth N. Wells <[email-masked] 
> <mailto:[email-masked]>> wrote:
>
>
>
>     Anders Logg wrote:
>     <https://launchpad.net/%7Efiat>
>     <mailto:[email-masked]>
>     <https://launchpad.net/%7Efiat>

---

From: Robert Kirby <[email-masked]>
Date: Thu, 28 Jan 2010 17:30:12 -0600

The sympy dependency is only for the symbolic module FIAT_S, which I don't
think I've put into this repository.  That should be a future addition to
the project if we want.  There's nothing in ffc to use it (yet).

Rob

---

From: Robert Kirby <[email-masked]>
Date: Thu, 28 Jan 2010 17:31:14 -0600

On Thu, Jan 28, 2010 at 2:56 PM, Anders Logg <[email-masked]> wrote:

> 0.9.0 is fine with me.

Rob

---

From: Anders Logg <[email-masked]>
Date: Fri, 29 Jan 2010 01:04:44 +0100

>     You could bump it to 0.9.0, same as for FFC (which was last 0.7.1).

ok!

--
Anders