Subject: Re: [Fiat] [Dolfin] Problems with DOLFIN and SWIG 2.0.5 on Debian ia64 platform

From: Anders Logg <[email-masked]>
Date: Thu, 17 May 2012 09:50:23 +0200

On Wed, May 16, 2012 at 12:37:08PM +0200, Johan Hake wrote:
> On 05/16/2012 11:12 AM, Garth N. Wells wrote:
> >On 16 May 2012 10:05, Johan Hake<[email-masked]>  wrote:
> >>I get a taste of the path we have tried to avoid...
> >>
> >>A python3 port of all our packages :(
> >>
> >
> >I had a look a while ago, and the hang-up was python-scientific, on
> >which FIAT depends. python-scientific doesn't look to be actively
> >maintained.
>
> Looks like FIAT only uses automatic differentiation from Scientific.
> Could that be accomplished with sympy? The next release of sympy
> should support python3.

I don't know. It's something Rob would need to look at.

Rob, can this be done with SymPy? We're thinking about the
possibilities of running FEniCS with Python3 and the python-scientific
module used in FIAT seems to be the major hangup.

--
Anders

> Johan
>
> >Garth
> >
> >>Johan
> >>
> >>
> >>On 05/16/2012 10:27 AM, Johannes Ring wrote:
> >>>
> >>>On Wed, May 16, 2012 at 10:16 AM, Johan Hake<[email-masked]>
> >>>wrote:
> >>>>
> >>>>On 05/16/2012 10:02 AM, Johannes Ring wrote:
> >>>>>
> >>>>>You mean to replace PyInt_AS_LONG with PyInt_As_Long in both
> >>>>>UFC and DOLFIN?
> >>>>
> >>>>
> >>>>Well, yes, but is really silly. It looks like there are some
> >>>>other things that does not work. Is Python.h really found?
> >>>
> >>>
> >>>Yes, but I just found this in the log [1]:
> >>>
> >>>-- Found PythonInterp: /usr/bin/python (found version "2.7.3") --
> >>>Found PythonLibs: /usr/lib/python3.2/config/libpython3.2.so
> >>>(found version "3.2.3rc2")
> >>>
> >>>It seems that Python 3.2 is also installed on the build machine
> >>>and I guess DOLFIN picks up Python.h from this version. I will
> >>>fix this in the Debian package. Thanks for the help.
> >>>
> >>>[1]
> >>>https://buildd.debian.org/status/fetch.php?pkg=dolfin&arch=ia64&ver=1.0.0-5&stamp=1337006055
> >>>
> >>>
> >>>
> Johannes
> >>
> >>
> >>
> >>_______________________________________________ Mailing list:
> >>https://launchpad.net/~dolfin Post to     :
> >>[email-masked] Unsubscribe :
> >>https://launchpad.net/~dolfin More help   :
> >>https://help.launchpad.net/ListHelp
>
>
> _______________________________________________
> Mailing list: https://launchpad.net/~dolfin
> Post to     : [email-masked]
> Unsubscribe : https://launchpad.net/~dolfin
> More help   : https://help.launchpad.net/ListHelp

---

From: Johan Hake <[email-masked]>
Date: Fri, 18 May 2012 09:26:20 +0200

Ok. sympy does not support AD, so that was a bad idea.

Scientific Python is licensed under the CeCILL-C license. It looks lke 
it is a French law adapted version of LGPL. I guess that license would 
be sufficient to bundle the part of Scientific Python we need in FIAT, 
and then try to port that portion of it.

Johan

On 05/17/2012 12:53 PM, Kirby, Robert C wrote:
> I had thought the scientific license allowed me to drop in the ad
> file from it, which I had done at one point.  Doing this is far
> preferable to the dependency.  I have company in town&  baby due any
> day, so if one of you or a delegate could investigate, this would be
> great.
>
> Sympy would be quite difficult, as it doesn't support AD (I think).
> It would be a significant change, and also have a performance
> penalty, I think.
>
> Rob ________________________________________ From: Anders Logg
> [[email-masked]] Sent: Thursday, May 17, 2012 2:50 AM To: Johan Hake
> Cc: Garth N. Wells; DOLFIN Mailing List; FIAT Mailing List; Kirby,
> Robert C Subject: Re: [Dolfin] Problems with DOLFIN and SWIG 2.0.5 on
> Debian ia64 platform
>
>>> I had a look a while ago, and the hang-up was python-scientific,
>>> on which FIAT depends. python-scientific doesn't look to be
>>> actively maintained.
>>
>> Looks like FIAT only uses automatic differentiation from
>> Scientific. Could that be accomplished with sympy? The next release
>> of sympy should support python3.
>
> possibilities of running FEniCS with Python3 and the
> python-scientific module used in FIAT seems to be the major hangup.
>
> -- Anders
>
>
>
>> Johan
>>
>>> Garth
>>>
>>>> Johan
>>>>
>>>>
>>>>> On Wed, May 16, 2012 at 10:16 AM, Johan
>>>>> Hake<[email-masked]> wrote:
>>>>>>
>>>>>>> You mean to replace PyInt_AS_LONG with PyInt_As_Long in
>>>>>>> both UFC and DOLFIN?
>>>>>>
>>>>>>
>>>>>> Well, yes, but is really silly. It looks like there are
>>>>>> some other things that does not work. Is Python.h really
>>>>>> found?
>>>>>
>>>>>
>>>>> -- Found PythonInterp: /usr/bin/python (found version
>>>>> "2.7.3") -- Found PythonLibs:
>>>>> /usr/lib/python3.2/config/libpython3.2.so (found version
>>>>> "3.2.3rc2")
>>>>>
>>>>> It seems that Python 3.2 is also installed on the build
>>>>> machine and I guess DOLFIN picks up Python.h from this
>>>>> version. I will fix this in the Debian package. Thanks for
>>>>> the help.
>>>>>
>>>>> [1]
Johannes

---

From: Johan Hake <[email-masked]>
Date: Fri, 18 May 2012 20:53:23 +0200

Sounds good.

When I we feel that the "port to Python 3" itch need to be scratched we 
can look more into this.

Btw good luck with the baby!

Johan

On 05/18/2012 06:31 PM, Kirby, Robert C wrote:
> This would be by far the easiest thing to do if it's legal.  I think
> I'm just using one or two files, and I don't think they have many
> deeper dependencies inside Scientific Python.
>
> Rob ________________________________________ From: Johan Hake
> [[email-masked]] Sent: Friday, May 18, 2012 2:26 AM To: Kirby,
> Robert C Cc: Anders Logg; Garth N. Wells; DOLFIN Mailing List; FIAT
> Mailing List Subject: Re: [Dolfin] Problems with DOLFIN and SWIG
> 2.0.5 on Debian ia64 platform
>
> Scientific Python is licensed under the CeCILL-C license. It looks
> lke it is a French law adapted version of LGPL. I guess that license
> would be sufficient to bundle the part of Scientific Python we need
> in FIAT, and then try to port that portion of it.
>
> Johan
>
>> preferable to the dependency.  I have company in town&   baby due
>> any day, so if one of you or a delegate could investigate, this
>> would be great.
>>
>> Sympy would be quite difficult, as it doesn't support AD (I
>> think). It would be a significant change, and also have a
>> performance penalty, I think.
>>
>> [[email-masked]] Sent: Thursday, May 17, 2012 2:50 AM To: Johan
>> Hake Cc: Garth N. Wells; DOLFIN Mailing List; FIAT Mailing List;
>> Kirby, Robert C Subject: Re: [Dolfin] Problems with DOLFIN and SWIG
>> 2.0.5 on Debian ia64 platform
>>
>>>> I had a look a while ago, and the hang-up was
>>>> python-scientific, on which FIAT depends. python-scientific
>>>> doesn't look to be actively maintained.
>>>
>>> Scientific. Could that be accomplished with sympy? The next
>>> release of sympy should support python3.
>>
>>>>>>>> You mean to replace PyInt_AS_LONG with PyInt_As_Long
>>>>>>>> in both UFC and DOLFIN?
>>>>>>>
>>>>>>>
Johannes
>>>>>
>>>>>
>>>>>
>>>>> _______________________________________________ Mailing
>>>>> list: https://launchpad.net/~dolfin Post to     :