Subject: [FIAT-dev] trace_tabulate_jet

From: Anders Logg <[email-masked]>
Date: Mon, 4 Dec 2006 16:31:16 +0100

A couple of quick questions about trace_tabulate_jet:

  trace_tabulate_jet(facet_shape, facet, order, points)

1. Does this tabulate the basis functions on the facet with the given
number?

2. If the points are given as a subset of the reference cell of one
dimension lower (unit interval for facet on a triangle), then are the
points mapped to a subset of the facet in question?

3. Does FIAT have the same numbering of facets as FFC/DOLFIN?
(The one in Appendix in the manuals.)

/Anders

---

From: Anders Logg <[email-masked]>
Date: Mon, 4 Dec 2006 17:00:30 +0100

On Mon, Dec 04, 2006 at 09:35:48AM -0600, Kirby, Robert C wrote:
> 1.) yes, and their derivatives up to and including order.  
> It does not compute normal or tangential
> components; this is up to the caller to do appropriate dot products.

Good.

> 2.) Yes, points should be specified on the reference element of
> the dimension of the facet being evaluated on.  So, if 
> facet_shape == 1, then the points should be one-dimensional.

Good.

> 3.) It should be; if the orderings were different, the local-to-global
> mapping FFC generates wouldn't work and the error would be immediately
> noticeable.

ok.

/Anders

> 
> Robert C. Kirby
> Associate Professor
> Department of Mathematics and Statistics
> Texas Tech University
> 
> "Mathematical software should be mathematical"
> 
> 
> 
> -----Original Message-----
> From: [email-masked] on behalf of Anders Logg
> Sent: Mon 12/4/2006 9:31 AM
> To: Discussion of FIAT development
> Subject: [FIAT-dev] trace_tabulate_jet
>  
> _______________________________________________
> FIAT-dev mailing list
> [email-masked]
> http://www.fenics.org/mailman/listinfo/fiat-dev
>