Subject: [Instant] Where to find failing Instant code?

From: Anders Logg <[email-masked]>
Date: Mon, 28 Nov 2011 14:04:44 +0100

Something has happened to Instant error reporting.

I can find the log file (as reported by Instant) somewhere under
~/.instant/error, but where can I find the code that failed? It's
important to be able to inspect it.

--
Anders

---

From: Kent-Andre Mardal <[email-masked]>
Date: Mon, 28 Nov 2011 14:57:50 +0100

It have moved to
 ~/.instant/error/module_name/compile.log

On 28 November 2011 14:04, Anders Logg <[email-masked]> wrote:

> _______________________________________________
> Mailing list: https://launchpad.net/~instant
> Post to     : [email-masked]
> Unsubscribe : https://launchpad.net/~instant
> More help   : https://help.launchpad.net/ListHelp
>

---

From: Anders Logg <[email-masked]>
Date: Mon, 28 Nov 2011 15:07:17 +0100

Yes, I can find the log file, but not the code that generated the
error. It also needs to be stored.

--
Anders

---

From: Kent-Andre Mardal <[email-masked]>
Date: Mon, 28 Nov 2011 20:31:30 +0100

Agree!

Kent

---

From: Anders Logg <[email-masked]>
Date: Mon, 28 Nov 2011 21:25:06 +0100

So where is it then...? :-)

--
Anders

---

From: Kent-Andre Mardal <[email-masked]>
Date: Mon, 28 Nov 2011 23:18:19 +0100

Hake just arrived at Simula today, and he is the one that has changed the
behaviour so I´ll have
a word with him tomorrow :)

Kent

---

From: Anders Logg <[email-masked]>
Date: Mon, 28 Nov 2011 23:24:08 +0100

Great to have him back! :-)

--
Anders

On Mon, Nov 28, 2011 at 11:18:19PM +0100, Kent-Andre Mardal wrote:
>      >      > It have moved to
>      >      >  ~/.instant/error/module_name/compile.log
>      >      >
>      >      >
>      >      > On 28 November 2011 14:04, Anders Logg <[email-masked]>
>      wrote:
>      >      >      Something has happened to Instant error reporting.
>      >      >
>      >      >      I can find the log file (as reported by Instant)
>      somewhere
>      >      under
>      >      >      ~/.instant/error, but where can I find the code that
>      failed?
>      >      It's
>      >      >      important to be able to inspect it.
>      >      >
>      >      >
>      >      >      _______________________________________________
>      >      >      Mailing list: https://launchpad.net/~instant
>      >      >      Post to     : [email-masked]
>      >      >      Unsubscribe : https://launchpad.net/~instant
>      >      >      More help   : https://help.launchpad.net/ListHelp
>      >      >
>      >
>

---

From: Johan Hake <[email-masked]>
Date: Mon, 28 Nov 2011 15:59:18 -0800

> a word with him tomorrow :)

That is not going to happen, as he will not be officially at work untill the 
1st of January ;) 

[snip]

> > >      error. It also needs to be stored.

That has never been the case, but I see the use of it. I have added a branch 
which does this, but because of lack of proper instant tests, there are 
basically only regression tests not proper unittesting (Kent?), and because I 
have no uptodate dolfin installation, I have just pushed it to a branch:

  lp:~johan-hake/instant/copy_module_to_error

You can check it out and see if it does what you need. 
      
> > >      >  ~/.instant/error/module_name/compile.log

It has always been this directory. What as changed is we no longer save the 
latest compile.log in:

  ~/.instant/error/

as this was introduced as a convinience for the buildbot. But for one reason 
or the other it never worked. So now the compile.log is printed to screen if 
INSTANT_DISPLAY_COMPILE_LOG is set.

> > >      >      I can find the log file (as reported by Instant) somewhere
> > >      
> > >      under
> > >      
> > >      >      ~/.instant/error, but where can I find the code that
> > >      >      failed?
> > >      
> > >      It's
> > >

---

From: Anders Logg <[email-masked]>
Date: Tue, 29 Nov 2011 11:12:49 +0100

> That is not going to happen, as he will not be officially at work untill the

Looks like it did happen... at least the fix. Thanks!

--
Anders

---

From: Johan Hake <[email-masked]>
Date: Tue, 29 Nov 2011 11:24:09 +0100

On Tuesday November 29 2011 11:12:49 Anders Logg wrote:
> > > Hake just arrived at Simula today, and he is the one that has changed
> > > the behaviour so I´ll have
> > That is not going to happen, as he will not be officially at work untill
> > the 1st of January ;)
> 
> Looks like it did happen... 

At least the word did not happen ;)

> at least the fix. Thanks!

:)

Johan

> 
> --
> Anders
> 
> > [snip]
> > 
> > > > >      Yes, I can find the log file, but not the code that generated
> > > > >      the error. It also needs to be stored.
> > 
> > That has never been the case, but I see the use of it. I have added a
> > branch which does this, but because of lack of proper instant tests,
> > there are basically only regression tests not proper unittesting
> > (Kent?), and because I
> > 
> > as this was introduced as a convinience for the buildbot. But for one
> > reason or the other it never worked. So now the compile.log is printed
> > to screen if INSTANT_DISPLAY_COMPILE_LOG is set.
> >