Subject: [Instant-dev] [HG instant] Moved use_cache from global option to create_extension, removed global COPY_LOCAL_FILES (why was this different from USE_CACHE?).

From: [email-masked] (Instant)
Date: Mon, 11 Aug 2008 14:54:58 +0200 (CEST)

One or more new changesets pushed to the primary instant repository.
A short summary of the last three changesets is included below.

changeset:   180:b910c8011edd28095fb13098d9e281df04c75494
tag:         tip
user:        Ilmar Wilbers <[email-masked]>
date:        Mon Aug 11 14:54:56 2008 +0200
files:       src/instant.py
description:
Moved use_cache from global option to create_extension, removed global COPY_LOCAL_FILES (why was this different from USE_CACHE?).

changeset:   179:8f0f226c934be3608f8ee01d694eb5fb53eb97f2
user:        Ilmar Wilbers <[email-masked]>
date:        Mon Aug 11 13:21:29 2008 +0200
files:       etc/instant-cache-clean.sh etc/instant-clean setup.py src/instant.py
description:
Changed clean script to using Python, making it platform-independent. Also, get cache dir and tmp dir from instant module.

changeset:   178:58c9e8bc36c566b1bb8f2e77298b602b820595a7
user:        Ilmar Wilbers <[email-masked]>
date:        Fri Aug 08 15:09:35 2008 +0200
files:       doc/html_reference/api-objects.txt doc/html_reference/class-tree.html doc/html_reference/crarr.png doc/html_reference/epydoc.js doc/html_reference/frames.html doc/html_reference/help.html doc/html_reference/identifier-index.html doc/html_reference/index.html doc/html_reference/instant-module.html doc/html_reference/instant-pysrc.html doc/html_reference/instant.instant-class.html doc/html_reference/module-tree.html doc/html_reference/redirect.html doc/html_reference/toc-everything.html doc/html_reference/toc-instant-module.html doc/html_reference/toc.html
description:
Added new documentation.

----------------------------------------------------------------------
For more details, visit http://www.fenics.org/hg/instant

---

From: "Martin Sandve Alnæs" <[email-masked]>
Date: Mon, 11 Aug 2008 15:05:12 +0200

> Moved use_cache from global option to create_extension, removed global COPY_LOCAL_FILES (why was this different from USE_CACHE?).

Because Anders wanted different instant-behaviour for FFC than SFC
relied on. I'm expecting that something broke now, will test...

--
Martin

---

From: Ilmar Wilbers <[email-masked]>
Date: Mon, 11 Aug 2008 15:06:54 +0200

Hold on for a moment, will need to fix something else first.

ilmar

Martin Sandve Alnæs wrote:
> _______________________________________________
> Instant-dev mailing list
> [email-masked]
> http://fenics.org/mailman/listinfo/instant-dev
>