Subject: [Instant-dev] [HG instant] some more cleanup

From: [email-masked] (Instant)
Date: Mon, 1 Sep 2008 23:43:54 +0200 (CEST)

One or more new changesets pushed to the primary instant repository.
A short summary of the last three changesets is included below.

changeset:   194:f98e9758501ad2ab50a5836200f92dc034a11e83
tag:         tip
user:        Kent-Andre Mardal <[email-masked]>
date:        Mon Sep 01 23:43:50 2008 +0200
files:       src/instant.py
description:
some more cleanup

changeset:   193:7eacc136f0610d5e5292b8b2a89ff2dfee14af37
user:        Kent-Andre Mardal <[email-masked]>
date:        Mon Sep 01 23:41:50 2008 +0200
files:       src/instant.py
description:
some clean-up, did not remove Martin's problem

changeset:   192:25bd4d79605fa588f164dcd03ad8cae2470565b1
user:        Ilmar Wilbers <[email-masked]>
date:        Mon Sep 01 13:40:35 2008 +0200
files:       etc/instant-clean src/instant.py
description:
Changed temp_dir to be generated randomly.

----------------------------------------------------------------------
For more details, visit http://www.fenics.org/hg/instant

---

From: "Martin Sandve Alnæs" <[email-masked]>
Date: Tue, 2 Sep 2008 00:13:55 +0200

I hope you didn't spend much time on this...

I told you I had already done quite a bit  of cleaning up but didn't
dare checking in yet, I only wanted you to check the tests...

I've rewritten almost everything now, the code is much
easier to follow and manage now, but it's not quite working
yet so I'm keeping it in my own repository until tomorrow.

--
Martin

2008/9/1 Instant <[email-masked]>:
> _______________________________________________
> Instant-dev mailing list
> [email-masked]
> http://fenics.org/mailman/listinfo/instant-dev
>

---

From: [email-masked]
Date: Tue, 2 Sep 2008 07:46:00 +0200 (CEST)

> yet so I'm keeping it in my own repository until tomorrow.

:) I started but didn't get it to work and decided on small steps instead..
I look forward to your rewrite !

Kent

---

From: "Johannes Ring" <[email-masked]>
Date: Tue, 2 Sep 2008 14:25:53 +0200 (CEST)

> I look forward to your rewrite !

Martin: Now that you are rewriting the code, could you switch from using
commands.getstatus*() to subprocess since commands.getstatus*() isn't
working in Windows and it will be deprecated in Python 2.6 (see [1] and
[2])? If you don't have time, I can submit a patch later.

Johannes

[1] http://ivory.idyll.org/blog/mar-07/replacing-commands-with-subprocess
[2] http://mail.python.org/pipermail/python-dev/2007-March/072278.html

---

From: "Martin Sandve Alnæs" <[email-masked]>
Date: Tue, 2 Sep 2008 14:32:02 +0200

> [2] http://mail.python.org/pipermail/python-dev/2007-March/072278.html

Ok. I'm almost done, in the process of finally making the tests work
now, will fix afterwards.

I've changed some names, I'll try to summarize.

--
Martin

---

From: "Johannes Ring" <[email-masked]>
Date: Thu, 4 Sep 2008 11:38:17 +0200 (CEST)

On Tue, September 2, 2008 14:32, Martin Sandve Alnæs wrote:
>> [1]
>> http://ivory.idyll.org/blog/mar-07/replacing-commands-with-subprocess

I see that you have switched to subprocess in most places now, only
src/instant/config.py remains. It would be great if you could fix that
too.

Johannes