Subject: [Instant-dev] [HG instant] Setting COPY=0 by default.

From: [email-masked] (Instant)
Date: Fri, 30 Nov 2007 20:18:19 +0100 (CET)

One or more new changesets pushed to the primary instant repository.
A short summary of the last three changesets is included below.

changeset:   108:f91c4ecf36bcaada1d6227526fb55e8b2f6b7b33
tag:         tip
user:        "Martin Sandve Alnæs <[email-masked]>"
date:        Fri Nov 30 20:19:01 2007 +0100
files:       src/instant.py
description:
Setting COPY=0 by default.

changeset:   107:88051b49b8fe9e27d7bd5a510458725559e648dd
user:        kent-and@localhost
date:        Wed Nov 21 16:14:27 2007 +0100
files:       src/instant.py tests/clean.sh
description:
added the feature Anders Logg requested

changeset:   106:fc5d281ec470b308987db3b94a1709e876fb6800
user:        kent-and@localhost
date:        Tue Nov 20 15:19:11 2007 +0100
files:       ChangeLog
description:
updated ChangeLog

----------------------------------------------------------------------
For more details, visit http://www.fenics.org/hg/instant

---

From: Anders Logg <[email-masked]>
Date: Sat, 1 Dec 2007 00:54:41 +0100

How should the new feature be used (what arguments to use if I want
to cache things in ~/.instant)?

-- 
Anders

> _______________________________________________
> Instant-dev mailing list
> [email-masked]
> http://fenics.org/mailman/listinfo/instant-dev

---

From: [email-masked]
Date: Sat, 1 Dec 2007 23:21:24 +0100 (CET)

COPY is a "global" variable in the module instant.

import instant
instant.COPY=1

will do the trick.

Martin wanted it turned off by default. He also suggested to use
$HOME/.instant
instead of /tmp/instant to cache, which seems resonable.
 I don't know whether $HOME/.instant  is portable, but neither was
/tmp/instant.

Kent