Subject: [Instant-dev] [HG instant] Set PKG_CONFIG_ALLOW_SYSTEM_CFLAGS=1 by default.

From: [email-masked] (Instant)
Date: Mon, 12 Jan 2009 17:20:49 +0100 (CET)

One or more new changesets pushed to the primary instant repository.
A short summary of the last three changesets is included below.

changeset:   271:f3ea57a62fdf62923d7bb185aa858b123a5d7c1b
tag:         tip
user:        Johannes Ring <[email-masked]>
date:        Mon Jan 12 17:13:49 2009 +0100
files:       src/instant/config.py
description:
Set PKG_CONFIG_ALLOW_SYSTEM_CFLAGS=1 by default.

changeset:   270:31d94e8cc9eeb9dc9b5fdb39c4cf0c6c9908557a
user:        Kent-Andre Mardal <[email-masked]>
date:        Mon Dec 29 15:23:16 2008 +0100
files:       doc/makedoc.sh src/instant/__init__.py
description:
bugfix in example doc

changeset:   269:82140b9de5013141b02f34feef4e1058553f1452
user:        Johannes Ring <[email-masked]>
date:        Mon Dec 29 12:25:39 2008 +0100
files:       tests/rerun_tests.py tests/run_tests.py
description:
Minor fix in test script.

----------------------------------------------------------------------
For more details, visit http://www.fenics.org/hg/instant

---

From: Johan Hake <[email-masked]>
Date: Tue, 13 Jan 2009 20:00:36 +0100

> Set PKG_CONFIG_ALLOW_SYSTEM_CFLAGS=1 by default.

I thinkt there is a bug at line 19 in config.py

  assert env("PKG_CONFIG_ALLOW_SYSTEM_CFLAGS") == "0"

should be:

  assert env["PKG_CONFIG_ALLOW_SYSTEM_CFLAGS"] == "0"

As far as I know is not a dict callable ;)

Johan

> _______________________________________________
> Instant-dev mailing list
> [email-masked]
> http://fenics.org/mailman/listinfo/instant-dev

---

From: "Johannes Ring" <[email-masked]>
Date: Tue, 13 Jan 2009 20:27:40 +0100 (CET)

> As far as I know is not a dict callable ;)

oops... yes, you are right :-)

Johannes