Subject: [Syfi-dev] [HG syfi] Implemented fiber function (identity) to test Fung. Seems correct!

From: [email-masked] (SyFi)
Date: Wed, 6 May 2009 17:54:32 +0200 (CEST)

One or more new changesets pushed to the primary SyFi repository.
A short summary of the last three changesets is included below.

changeset:   515:bfc53fca84e60245a5f3996e80a61ab66eb36921
tag:         tip
user:        "Martin Sandve Alnæs <[email-masked]>"
date:        Wed May 06 17:54:30 2009 +0200
files:       demo/HyperElasticityModels/cpp/HyperElasticity.ufl demo/HyperElasticityModels/cpp/Law.ufl demo/HyperElasticityModels/cpp/Makefile demo/HyperElasticityModels/cpp/main.cpp
description:
Implemented fiber function (identity) to test Fung. Seems correct!
Note that compiling all these Fung form variants from one form file
used almost all of my 2 Gb of memory. I guess some memory profiling
would be in order.

changeset:   514:39e05b8f4204e23f621f95eb5af180da68e2c9af
user:        "Martin Sandve Alnæs <[email-masked]>"
date:        Wed May 06 16:46:01 2009 +0200
files:       demo/HyperElasticityModels/cpp/Cell.ufl demo/HyperElasticityModels/cpp/HyperElasticity.ufl demo/HyperElasticityModels/cpp/Law.ufl demo/HyperElasticityModels/cpp/Makefile demo/HyperElasticityModels/cpp/main.cpp
description:
Added norm function for easy matrix comparison.

changeset:   513:a124e862dfb91d666cfc7e6fc70b91f00cf401b7
user:        "Martin Sandve Alnæs <[email-masked]>"
date:        Tue May 05 21:36:49 2009 +0200
files:       demo/HyperElasticityModels/cpp/Makefile
description:
Updated demo makefile.

----------------------------------------------------------------------
For more details, visit http://www.fenics.org/hg/syfi

---

From: Harish Narayanan <[email-masked]>
Date: Fri, 08 May 2009 13:24:04 +0200

SyFi wrote:
> user:        "Martin Sandve AlnÃ¦s <[email-masked]>"

With these recent AD changes in UFL, my toy (SVK) hyperelasticity
attempts seem to be working too. I am using FFC and they also work in
direct notation[1].

Very cool Martin!

[1] i.e., they do not require the use of index notation, but I think you
are using index notation in your examples here for debugging.

---

From: Martin Sandve Alnæs <[email-masked]>
Date: Fri, 8 May 2009 13:46:14 +0200

> attempts seem to be working too. I am using FFC and they also work in

Great! I haven't got around to test the elasticity applications yet.

> Very cool Martin!

Thanks :)

> are using index notation in your examples here for debugging.

Yes, in the above I compute the same forms in three different ways,
without "derivative", with "derivative" used once, and with "derivative"
used twice, and get the same results for several material laws.

Martin

---

From: Anders Logg <[email-masked]>
Date: Fri, 8 May 2009 13:49:01 +0200

> >> used almost all of my 2 Gb of memory. I guess some memory profiling

Imagine compiling that form using the old FFC form language... :-)

-- 
Anders