Subject: [Syfi-dev] [HG syfi] changes from Johannes

From: [email-masked] (SyFi)
Date: Wed, 17 Sep 2008 11:12:43 +0200 (CEST)

One or more new changesets pushed to the primary SyFi repository.
A short summary of the last three changesets is included below.

changeset:   164:e26a4310dc6b2fac6925c268cc3f6fff8bd4888e
tag:         tip
user:        Kent-Andre Mardal <[email-masked]>
date:        Wed Sep 17 11:11:53 2008 +0200
files:       Makefile.am Makefile.in NEWS SConstruct SyFi.spec.in acinclude.m4 aclocal.m4 autom4te.cache/output.0 autom4te.cache/output.1 autom4te.cache/requests autom4te.cache/traces.0 autom4te.cache/traces.1 bootstrap config.guess config.h.in config.sub configure configure.ac configure.local depcomp doc/Makefile.am doc/Makefile.in doc/SConscript doc/manual/Makefile.am doc/manual/Makefile.in doc/manual/syfi-user-manual.pdf install-sh ltmain.sh missing python/Makefile.am python/Makefile.in python/README python/SyFi.i.in python/TODO python/cpp2py_exceptions.i python/ex.1.3.i python/ex.1.4.i python/newsfc/__init__.py python/newsfc/codegeneration/OldIntegralCG.py python/newsfc/codegeneration/__init__.py python/newsfc/codegeneration/codeformatting.py python/newsfc/codegeneration/codegeneration.py python/newsfc/codegeneration/dofmapcg.py python/newsfc/codegeneration/finiteelementcg.py python/newsfc/codegeneration/formcg.py python/newsfc/codegeneration/gen_tabulate_tensor.py python/newsfc/codegeneration/integralcg.py python/newsfc/codegeneration/names.py python/newsfc/common/ParameterDict.py python/newsfc/common/__init__.py python/newsfc/common/names.py python/newsfc/common/options.py python/newsfc/common/output.py python/newsfc/common/paths.py python/newsfc/common/utilities.py python/newsfc/common/version.py python/newsfc/dofcode/DofT.py python/newsfc/dofcode/Dof_Ptv.py python/newsfc/dofcode/Ptv.py python/newsfc/dofcode/__init__.py python/newsfc/geometry/UFCCell.py python/newsfc/geometry/__init__.py python/newsfc/geometry/affine_map.py python/newsfc/jit.py python/newsfc/quadrature/QuadRule.py python/newsfc/quadrature/__init__.py python/newsfc/quadrature/quad_tables.py python/newsfc/quadrature/quadrature.py python/newsfc/quadrature/quadrature_code.py python/newsfc/representation/OldIntegralRep.py python/newsfc/representation/__init__.py python/newsfc/representation/elementrepresentation.py python/newsfc/representation/formrepresentation.py python/newsfc/representation/integralrepresentation.py python/newsfc/symbolic_utils/__init__.py python/newsfc/symbolic_utils/ssa.py python/newsfc/symbolic_utils/symbol_factory.py python/newsfc/symbolic_utils/symbolic_utils.py python/newtests/_run_pychecker.py python/newtests/cell_assembly.py python/newtests/clean.sh python/newtests/codeformatter.py python/newtests/element_indexing.py python/newtests/element_representations.py python/newtests/jit.py python/newtests/sfc_commandline.py python/newtests/template.py python/newtests/test.py python/newtests/ufl_forms/H1norm.ufl python/newtests/ufl_forms/L2norm.ufl python/newtests/ufl_forms/convection_jacobi.ufl python/newtests/ufl_forms/convection_jacobi2.ufl python/newtests/ufl_forms/convection_vector.ufl python/newtests/ufl_forms/explicit_convection.ufl python/newtests/ufl_forms/mass.ufl python/newtests/ufl_forms/source.ufl python/newtests/ufl_forms/stiffness.ufl python/newtests/volumes.py python/scripts/sfc python/setup.py.in python/sfc/CodeFormatter.py python/sfc/QuadFunction.py python/sfc/TODO.TXT python/sfc/UFCCell.py python/sfc/__init__.py python/sfc/affine_map.py python/sfc/codegenerators/CodeGenerator.py python/sfc/codegenerators/CompositeDofMapCG.py python/sfc/codegenerators/DofMapCG.py python/sfc/codegenerators/DofMapDiscontinuousCG.py python/sfc/codegenerators/DofMapQuadratureCG.py python/sfc/codegenerators/DofMapSignedCG.py python/sfc/codegenerators/FiniteElementCG.py python/sfc/codegenerators/FiniteElementQuadratureCG.py python/sfc/codegenerators/FiniteElementSignedCG.py python/sfc/codegenerators/FormCG.py python/sfc/codegenerators/FunctionCG.py python/sfc/codegenerators/IntegralCG.py python/sfc/codegenerators/__init__.py python/sfc/codegenerators/codegenerators.py python/sfc/codegenerators/gen_tabulate_tensor.py python/sfc/common/__init__.py python/sfc/common/logger.py python/sfc/common/options.py python/sfc/common/strings.py python/sfc/common/timer.py python/sfc/common/utilities.py python/sfc/compiler.py python/sfc/dofcode/DofT.py python/sfc/dofcode/Dof_Ptv.py python/sfc/dofcode/Ptv.py python/sfc/dofcode/__init__.py python/sfc/fem/FiniteElement.py python/sfc/fem/Function.py python/sfc/fem/__init__.py python/sfc/integral_tools.py python/sfc/optimize/__init__.py python/sfc/optimize/cse.py python/sfc/optimize/deps.py python/sfc/optimize/horner.py python/sfc/optimize/optimize.py python/sfc/optimize/ssa.py python/sfc/quadrature/QuadRule.py python/sfc/quadrature/__init__.py python/sfc/quadrature/find_order.py python/sfc/quadrature/quad_tables.py python/sfc/quadrature/quadrature.py python/sfc/quadrature/quadrature_code.py python/sfc/representations/FERep.py python/sfc/representations/FormRep.py python/sfc/representations/IntegralRep.py python/sfc/representations/__init__.py python/sfc/representations/representations.py python/sfc/sign_on_basis.py python/sfc/symbol_factory.py python/sfc/symbolic_utils.py python/tests/README python/tests/SyFi_polygons/__init__.py python/tests/SyFi_polygons/spacetimedomain.py python/tests/SyFi_polygons/test.py python/tests/codeformatting/__init__.py python/tests/codeformatting/codeformatter.py python/tests/demos/__init__.py python/tests/demos/crouzeixraviart.py python/tests/demos/geom_test.py python/tests/demos/poisson1.py python/tests/demos/simple.py python/tests/demos/simple2.py python/tests/demos/test_integration.py python/tests/demos/time_element_test.py python/tests/run.py python/tests/run_pychecker.py python/tests/runall.py python/tests/runall.sh python/tests/sfc_callbacks/__init__.py python/tests/sfc_callbacks/callback_forms.py python/tests/sfc_callbacks/clean.sh python/tests/sfc_callbacks/scratch.py python/tests/sfc_commandline/__init__.py python/tests/sfc_commandline/forms/H1norm.form python/tests/sfc_commandline/forms/L2norm.form python/tests/sfc_commandline/forms/convection_jacobi.form python/tests/sfc_commandline/forms/convection_jacobi2.form python/tests/sfc_commandline/forms/convection_vector.form python/tests/sfc_commandline/forms/explicit_convection.form python/tests/sfc_commandline/forms/mass.form python/tests/sfc_commandline/forms/source.form python/tests/sfc_commandline/forms/stiffness.form python/tests/sfc_commandline/test.py python/tests/sfc_jit/__init__.py python/tests/sfc_jit/test.py python/tests/sympy_test/fem_sympy.py python/tests/sympy_test/fem_sympy_core.py python/tests/sympy_test/run.sh python/tests/sympy_test/run.v python/tests/sympy_test/syfi_test.py python/tests/sympy_test/sympy_core_test.py python/tests/sympy_test/sympy_test.py python/tests/templatetestdir/__init__.py python/tests/templatetestdir/test.py python/typemaps.1.3.i python/typemaps.1.4.i scripts/sfc site-packages/TODO site-packages/newsfc/__init__.py site-packages/newsfc/codegeneration/OldIntegralCG.py site-packages/newsfc/codegeneration/__init__.py site-packages/newsfc/codegeneration/codeformatting.py site-packages/newsfc/codegeneration/codegeneration.py site-packages/newsfc/codegeneration/dofmapcg.py site-packages/newsfc/codegeneration/finiteelementcg.py site-packages/newsfc/codegeneration/formcg.py site-packages/newsfc/codegeneration/gen_tabulate_tensor.py site-packages/newsfc/codegeneration/integralcg.py site-packages/newsfc/codegeneration/names.py site-packages/newsfc/common/ParameterDict.py site-packages/newsfc/common/__init__.py site-packages/newsfc/common/names.py site-packages/newsfc/common/options.py site-packages/newsfc/common/output.py site-packages/newsfc/common/paths.py site-packages/newsfc/common/utilities.py site-packages/newsfc/common/version.py site-packages/newsfc/dofcode/DofT.py site-packages/newsfc/dofcode/Dof_Ptv.py site-packages/newsfc/dofcode/Ptv.py site-packages/newsfc/dofcode/__init__.py site-packages/newsfc/geometry/UFCCell.py site-packages/newsfc/geometry/__init__.py site-packages/newsfc/geometry/affine_map.py site-packages/newsfc/jit.py site-packages/newsfc/quadrature/QuadRule.py site-packages/newsfc/quadrature/__init__.py site-packages/newsfc/quadrature/quad_tables.py site-packages/newsfc/quadrature/quadrature.py site-packages/newsfc/quadrature/quadrature_code.py site-packages/newsfc/representation/OldIntegralRep.py site-packages/newsfc/representation/__init__.py site-packages/newsfc/representation/elementrepresentation.py site-packages/newsfc/representation/formrepresentation.py site-packages/newsfc/representation/integralrepresentation.py site-packages/newsfc/symbolic_utils/__init__.py site-packages/newsfc/symbolic_utils/ssa.py site-packages/newsfc/symbolic_utils/symbol_factory.py site-packages/newsfc/symbolic_utils/symbolic_utils.py site-packages/sfc/CodeFormatter.py site-packages/sfc/QuadFunction.py site-packages/sfc/TODO.TXT site-packages/sfc/UFCCell.py site-packages/sfc/__init__.py site-packages/sfc/affine_map.py site-packages/sfc/codegenerators/CodeGenerator.py site-packages/sfc/codegenerators/CompositeDofMapCG.py site-packages/sfc/codegenerators/DofMapCG.py site-packages/sfc/codegenerators/DofMapDiscontinuousCG.py site-packages/sfc/codegenerators/DofMapQuadratureCG.py site-packages/sfc/codegenerators/DofMapSignedCG.py site-packages/sfc/codegenerators/FiniteElementCG.py site-packages/sfc/codegenerators/FiniteElementQuadratureCG.py site-packages/sfc/codegenerators/FiniteElementSignedCG.py site-packages/sfc/codegenerators/FormCG.py site-packages/sfc/codegenerators/FunctionCG.py site-packages/sfc/codegenerators/IntegralCG.py site-packages/sfc/codegenerators/__init__.py site-packages/sfc/codegenerators/codegenerators.py site-packages/sfc/codegenerators/gen_tabulate_tensor.py site-packages/sfc/common/__init__.py site-packages/sfc/common/logger.py site-packages/sfc/common/options.py site-packages/sfc/common/strings.py site-packages/sfc/common/timer.py site-packages/sfc/common/utilities.py site-packages/sfc/compiler.py site-packages/sfc/dofcode/DofT.py site-packages/sfc/dofcode/Dof_Ptv.py site-packages/sfc/dofcode/Ptv.py site-packages/sfc/dofcode/__init__.py site-packages/sfc/fem/FiniteElement.py site-packages/sfc/fem/Function.py site-packages/sfc/fem/__init__.py site-packages/sfc/integral_tools.py site-packages/sfc/optimize/__init__.py site-packages/sfc/optimize/cse.py site-packages/sfc/optimize/deps.py site-packages/sfc/optimize/horner.py site-packages/sfc/optimize/optimize.py site-packages/sfc/optimize/ssa.py site-packages/sfc/quadrature/QuadRule.py site-packages/sfc/quadrature/__init__.py site-packages/sfc/quadrature/find_order.py site-packages/sfc/quadrature/quad_tables.py site-packages/sfc/quadrature/quadrature.py site-packages/sfc/quadrature/quadrature_code.py site-packages/sfc/representations/FERep.py site-packages/sfc/representations/FormRep.py site-packages/sfc/representations/IntegralRep.py site-packages/sfc/representations/__init__.py site-packages/sfc/representations/representations.py site-packages/sfc/sign_on_basis.py site-packages/sfc/symbol_factory.py site-packages/sfc/symbolic_utils.py stamp-h.in syfi-config.in syfi.pc.in syfi/Makefile.am syfi/Makefile.in syfi/SConscript syfi/scons.cfg.in syfi/swig/README syfi/swig/SyFi.i.in syfi/swig/cpp2py_exceptions.i syfi/swig/ex.1.3.i syfi/swig/ex.1.4.i syfi/swig/typemaps.1.3.i syfi/swig/typemaps.1.4.i syfi/syfi.pc.in tests/Makefile.am tests/Makefile.in tests/SConscript tests/python/newtests/_run_pychecker.py tests/python/newtests/cell_assembly.py tests/python/newtests/clean.sh tests/python/newtests/codeformatter.py tests/python/newtests/element_indexing.py tests/python/newtests/element_representations.py tests/python/newtests/jit.py tests/python/newtests/sfc_commandline.py tests/python/newtests/template.py tests/python/newtests/test.py tests/python/newtests/ufl_forms/H1norm.ufl tests/python/newtests/ufl_forms/L2norm.ufl tests/python/newtests/ufl_forms/convection_jacobi.ufl tests/python/newtests/ufl_forms/convection_jacobi2.ufl tests/python/newtests/ufl_forms/convection_vector.ufl tests/python/newtests/ufl_forms/explicit_convection.ufl tests/python/newtests/ufl_forms/mass.ufl tests/python/newtests/ufl_forms/source.ufl tests/python/newtests/ufl_forms/stiffness.ufl tests/python/newtests/volumes.py tests/python/tests/README tests/python/tests/SyFi_polygons/__init__.py tests/python/tests/SyFi_polygons/spacetimedomain.py tests/python/tests/SyFi_polygons/test.py tests/python/tests/codeformatting/__init__.py tests/python/tests/codeformatting/codeformatter.py tests/python/tests/demos/__init__.py tests/python/tests/demos/crouzeixraviart.py tests/python/tests/demos/geom_test.py tests/python/tests/demos/poisson1.py tests/python/tests/demos/simple.py tests/python/tests/demos/simple2.py tests/python/tests/demos/test_integration.py tests/python/tests/demos/time_element_test.py tests/python/tests/run.py tests/python/tests/run_pychecker.py tests/python/tests/runall.py tests/python/tests/runall.sh tests/python/tests/sfc_callbacks/__init__.py tests/python/tests/sfc_callbacks/callback_forms.py tests/python/tests/sfc_callbacks/clean.sh tests/python/tests/sfc_callbacks/scratch.py tests/python/tests/sfc_commandline/__init__.py tests/python/tests/sfc_commandline/forms/H1norm.form tests/python/tests/sfc_commandline/forms/L2norm.form tests/python/tests/sfc_commandline/forms/convection_jacobi.form tests/python/tests/sfc_commandline/forms/convection_jacobi2.form tests/python/tests/sfc_commandline/forms/convection_vector.form tests/python/tests/sfc_commandline/forms/explicit_convection.form tests/python/tests/sfc_commandline/forms/mass.form tests/python/tests/sfc_commandline/forms/source.form tests/python/tests/sfc_commandline/forms/stiffness.form tests/python/tests/sfc_commandline/test.py tests/python/tests/sfc_jit/__init__.py tests/python/tests/sfc_jit/test.py tests/python/tests/sympy_test/fem_sympy.py tests/python/tests/sympy_test/fem_sympy_core.py tests/python/tests/sympy_test/run.sh tests/python/tests/sympy_test/run.v tests/python/tests/sympy_test/syfi_test.py tests/python/tests/sympy_test/sympy_core_test.py tests/python/tests/sympy_test/sympy_test.py tests/python/tests/templatetestdir/__init__.py tests/python/tests/templatetestdir/test.py
description:
changes from Johannes

changeset:   163:82163fbea321a85ed4cfc24e90e3fd6fd1de6fb3
user:        "Martin Sandve Alnæs <[email-masked]>"
date:        Wed Sep 10 23:55:47 2008 +0200
files:       python/newsfc/codegeneration/dofmapcg.py
description:
Added subelement signatures as comments to generated tabulate_dofs code.

changeset:   162:48e9f35fe97650faa64fc1e0b7f03245d53cf7ad
user:        "Martin Sandve Alnæs <[email-masked]>"
date:        Wed Sep 10 23:49:17 2008 +0200
files:       python/newsfc/codegeneration/codegeneration.py python/newsfc/codegeneration/dofmapcg.py python/newsfc/codegeneration/finiteelementcg.py python/newsfc/common/options.py python/newsfc/representation/elementrepresentation.py python/newtests/element_indexing.py python/newtests/jit.py python/newtests/volumes.py
description:
Work on element code generation. Most importantly, reimplemented tabulate_dofs for general element hierarchies.

----------------------------------------------------------------------
For more details, visit http://www.fenics.org/hg/syfi

---

From: Ola Skavhaug <[email-masked]>
Date: Wed, 17 Sep 2008 11:21:42 +0200

> files:       Makefile.am Makefile.in NEWS SConstruct SyFi.spec.in acinclude.m4 aclocal.m4 autom4te.cache/output.0 autom4te.cache/output.1 autom4te.cache/requests autom4te.cache/traces.0 autom4te.ca…
 
The directory scons does not exist in the file structure, causing scons to
fail.

Ola

> _______________________________________________
> SyFi-dev mailing list
> [email-masked]
> http://fenics.org/mailman/listinfo/syfi-dev