Subject: [Syfi-dev] [HG syfi] "Fixed" segmentation fault by indirect initialization of the Vector passed to DirichletBC.apply through constructing a cpp_Function over the Vector.

From: [email-masked] (SyFi)
Date: Mon, 24 Mar 2008 20:28:01 +0100 (CET)

One or more new changesets pushed to the primary SyFi repository.
A short summary of the last three changesets is included below.

changeset:   30:4d0c4271ef9b8a1a6d84df8ddbdf84fbeb6a9cc4
tag:         tip
user:        martinal@localhost
date:        Mon Mar 24 21:28:04 2008 +0100
files:       examples/solvers/linear_elasticity/crash.py
description:
"Fixed" segmentation fault by indirect initialization of the Vector passed to DirichletBC.apply through constructing a cpp_Function over the Vector.

changeset:   29:7a5a513f91e1183c020e73ad25d8eeaee0eac2ea
user:        martinal@localhost
date:        Mon Mar 24 20:22:48 2008 +0100
files:       examples/solvers/linear_elasticity/crash.py examples/solvers/linear_elasticity/demo.py
description:
Attempt at linear elasticity demo with sfc and pydolfin, get a segmentation fault in BC apply.

changeset:   28:523fe944754efab6dc9b60d284caec346065d3d7
user:        martinal@localhost
date:        Mon Mar 24 20:20:47 2008 +0100
files:       autom4te.cache/requests python/sfc/representations/FormRep.py python/sfc/representations/IntegralRep.py
description:
Name change from v_basis to basisfunctions and from v_basisfunction to basisfunction in IntegralRep

----------------------------------------------------------------------
For more details, visit http://www.fenics.org/hg/syfi

---

From: Anders Logg <[email-masked]>
Date: Mon, 24 Mar 2008 20:35:19 +0100

> files:       examples/solvers/linear_elasticity/crash.py

Nice example... :-)

-- 
Anders

> _______________________________________________
> SyFi-dev mailing list
> [email-masked]
> http://fenics.org/mailman/listinfo/syfi-dev