Subject: [Syfi-dev] [HG syfi] Bugfixes in form compilation.

From: [email-masked] (SyFi)
Date: Thu, 16 Oct 2008 11:34:36 +0200 (CEST)

One or more new changesets pushed to the primary SyFi repository.
A short summary of the last three changesets is included below.

changeset:   203:4e6f50a4d80055232ff79385c86b0473270ea68b
tag:         tip
user:        "Martin Sandve Alnæs <[email-masked]>"
date:        Thu Oct 16 11:34:40 2008 +0200
files:       examples/newsolvers/projection/demo.py site-packages/newsfc/representation/integralrepresentation.py site-packages/newsfc/representation/swiginac_eval.py
description:
Bugfixes in form compilation.
Updated projection demo to work with new dolfin Function.
Almost works fine, but there are strange oscillations in the solution.

changeset:   202:5a397f691324dd24b845c36cabeaf9e1e22ed9ca
user:        "Martin Sandve Alnæs <[email-masked]>"
date:        Thu Oct 16 10:37:23 2008 +0200
files:       examples/newsolvers/README examples/newsolvers/TODO.files examples/newsolvers/heat/demo.py examples/newsolvers/hyperelasticity/demo.py examples/newsolvers/linear_elasticity/demo.py examples/newsolvers/nonlinearpoisson/demo.py examples/newsolvers/poisson/demo.py examples/newsolvers/poisson1d/demo.py examples/newsolvers/projection/demo.py examples/newsolvers/reaction_diffusion/demo.py examples/newsolvers/u_cubed/demo.py examples/newsolvers/wave/demo.py
description:
More demo updates.

changeset:   201:34f5b77eaaf7609fb3f3e016ae5e3cf76b6e9d4c
user:        "Martin Sandve Alnæs <[email-masked]>"
date:        Thu Oct 16 10:31:51 2008 +0200
files:       examples/newsolvers/heat/demo.py examples/newsolvers/hyperelasticity/demo.py examples/newsolvers/linear_elasticity/demo.py examples/newsolvers/nonlinearpoisson/demo.py examples/newsolvers/poisson/demo.py examples/newsolvers/poisson1d/demo.py examples/newsolvers/projection/demo.py examples/newsolvers/reaction_diffusion/demo.py examples/newsolvers/u_cubed/demo.py examples/newsolvers/wave/demo.py
description:
Rewrote equations as UFL in hyperelasticity demo.

----------------------------------------------------------------------
For more details, visit http://www.fenics.org/hg/syfi

---

From: Kent Andre <[email-masked]>
Date: Thu, 16 Oct 2008 11:42:32 +0200

Cool! 

I can have a look at it. 

Kent

On to., 2008-10-16 at 11:34 +0200, SyFi wrote:
> _______________________________________________
> SyFi-dev mailing list
> [email-masked]
> http://fenics.org/mailman/listinfo/syfi-dev

---

From: "Martin Sandve Alnæs" <[email-masked]>
Date: Thu, 16 Oct 2008 11:46:13 +0200

Ok!

There are lots of places the error might be...
Including the dofmaps, or interaction with the newest dolfin.

-- 
Martin

---

From: "Martin Sandve Alnæs" <[email-masked]>
Date: Thu, 16 Oct 2008 12:03:37 +0200

Don't bother, tabulate_tensor computes dense matrices with all equal
entries. Should be easy to fix.

-- 
Martin

---

From: Kent Andre <[email-masked]>
Date: Thu, 16 Oct 2008 12:05:48 +0200

> entries. Should be easy to fix.

Yes, I noticed that the condition number was huge. 

Kent