Subject: Re: [UFL-dev] [FFC-dev] [HG FFC] Switch off debugging output.

From: Kristian Oelgaard <[email-masked]>
Date: Fri, 06 Mar 2009 16:45:09 +0100

Quoting FFC <[email-masked]>:

> One or more new changesets pushed to the primary ffc repository.
> A short summary of the last three changesets is included below.
>
> changeset:   1386:46d6bdabf0ece8ce11bd03b272fa4f0ada7a1b3e
> tag:         tip
> user:        "Kristian Oelgaard <[email-masked]>"
> date:        Fri Mar 06 16:33:48 2009 +0100
> files:       ffc/compiler/analysis/formdata.py
> ffc/compiler/codegeneration/quadrature/uflquadraturegenerator_utils.py
> ffc/compiler/representation/quadrature/uflquadraturerepresentation.py
> ffc/compiler/uflcompiler.py
> description:
> Switch off debugging output.

The following should now be possible:

cd to dolfin/demo/pde/poisson/cpp
form2ufl Poisson.form
ffc -r quadrature -l dolfin Poisson.ufl
scons
./demo

But not if 'os.environ["USER"] == "logg"' :)

The form2ufl script doesn't work for Elasticity.form and probably other forms
too. (transpose)

Although it appears to be working do expect bugs.

Kristian

>
> changeset:   1385:26cfa4605f69255a352d463310d685fef7c18455
> parent:      1384:342db73f2e54ba4c05ea7ddaa7cdddfaf8e61f96
> parent:      1376:89508f3c688c4d03923e66d4dd6c6767978bd52f
> user:        "Kristian Oelgaard <[email-masked]>"
> date:        Fri Mar 06 16:09:33 2009 +0100
> files:       ffc/compiler/compiler.py ffc/compiler/uflcompiler.py
> description:
> merge
>
>
> changeset:   1384:342db73f2e54ba4c05ea7ddaa7cdddfaf8e61f96
> user:        "Kristian Oelgaard <[email-masked]>"
> date:        Fri Mar 06 16:09:21 2009 +0100
> files:       ffc/compiler/analysis/formdata.py ffc/compiler/compiler.py
> ffc/compiler/format/uflufcformat.py ffc/compiler/uflcompiler.py scripts/ffc
> description:
> Try to generate code for DOLFIN.

> ----------------------------------------------------------------------
> For more details, visit http://www.fenics.org/hg/ffc
> _______________________________________________
> FFC-dev mailing list
> [email-masked]
> http://www.fenics.org/mailman/listinfo/ffc-dev
>

---

From: "Garth N. Wells" <[email-masked]>
Date: Fri, 06 Mar 2009 15:49:34 +0000

> But not if 'os.environ["USER"] == "logg"' :)

Nice. We can remove this when we find Anders worthy of the quadrature 
representation ;).

Garth