Subject: [UFL-dev] [HG UFL] Added GPLv3 licence file.

From: [email-masked] (UFL)
Date: Tue, 18 Nov 2008 10:26:53 +0100 (CET)

One or more new changesets pushed to the primary ufl repository.
A short summary of the last three changesets is included below.

changeset:   417:df85f19803b64128322c3085a9847b500bfa0b97
tag:         tip
user:        "Martin Sandve Alnæs <[email-masked]>"
date:        Tue Nov 18 10:26:56 2008 +0100
files:       LICENCE ROADMAP
description:
Added GPLv3 licence file.

Are there any reasons we have to use LGPL in the future?
I guess UFL being GPL infects many other fenics projects.
Until UFL is required by other FEniCS projects, it doesn't
matter.

changeset:   416:4496102b798fd77241f57815c7c74ec7ce1c024b
user:        "Martin Sandve Alnæs <[email-masked]>"
date:        Tue Nov 18 09:57:22 2008 +0100
files:       ufl/algorithms/dependencies.py ufl/algorithms/transformations.py
description:
Added variable traversal and cache to replace algorithm.

changeset:   415:fa9239baa61ad94f31cadcb2e7f5f841c8047119
user:        "Martin Sandve Alnæs <[email-masked]>"
date:        Mon Nov 17 23:05:10 2008 +0100
files:       sandbox/latextest.py sandbox/tensortest.py sandbox/test_hyperelasticity.py sandbox/u2l.py sandbox/ufl-script-params.py ufl/algorithms/dependencies.py
description:
Fixed variables being duplicated on stacks in split_by_dependencies.

Added ufl-script-params.py using optparse, to be used to
merge scripts like ufl-analyse, ufl2latex etc. into one,
with more flexible usage options.

Added some local sandbox test files (nothing to see).

----------------------------------------------------------------------
For more details, visit http://www.fenics.org/hg/ufl

---

From: Anders Logg <[email-masked]>
Date: Tue, 18 Nov 2008 16:56:06 +0100

GPL will require GPL for any form compiler using UFL (which is fine
for FFC which is already GPL).

On the other hand, one could argue that the GPL license of the form
compiler does not affect DOLFIN (or any other applications using
DOLFIN) as long as it is just used as a compiler: input UFL, output
UFC, same as GCC does not dictate the license on code it generates.

So the question is, does GPL on UFL mean that DOLFIN (and thus
applications using it) need to be GPL?

I love the GPL (surpise) but there has been interest (of course) to
let DOLFIN be LGPL.

-- 
Anders

> _______________________________________________
> UFL-dev mailing list
> [email-masked]
> http://fenics.org/mailman/listinfo/ufl-dev