Subject: [UFL-dev] Walk with operand stack?

From: Anders Logg <[email-masked]>
Date: Mon, 29 Sep 2008 14:57:26 +0200

Is there a simple way to traverse an UFL expression and have access to
the operand stack?

For any terminal object, I want to know which operators that sit at
the nodes of the path leading back to the root of the tree.

If not, I can try to implement it.

-- 
Anders

---

From: "Martin Sandve Alnæs" <[email-masked]>
Date: Mon, 29 Sep 2008 15:08:08 +0200

No. Shouldn't be too hard though.

We should discuss what algorithms we need and
how to reuse as much as possible. I can't imagine
that I've chosen the best approach to everything,
and my thoughts may be tainted by previous bad
choices in SFC...

--
Martin

2008/9/29 Anders Logg <[email-masked]>:
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v1.4.6 (GNU/Linux)
>
> iD8DBQFI4NC2TuwUCDsYZdERAr87AJ9G/f1ZAabhI2gXivLhqGDmEJj45QCgjFjj
> YhF7T+Y+k37GOMs87GNFwzs=
> =zoqE
> -----END PGP SIGNATURE-----
>
> _______________________________________________
> UFL-dev mailing list
> [email-masked]
> http://fenics.org/mailman/listinfo/ufl-dev
>
>

---

From: Anders Logg <[email-masked]>
Date: Mon, 29 Sep 2008 15:09:48 +0200

> and my thoughts may be tainted by previous bad

ok, I'll add it.

-- 
Anders