Subject: [UFL-dev] Release

From: Anders Logg <[email-masked]>
Date: Tue, 22 Sep 2009 18:47:26 +0200

New releases are needed for UFC and UFL. Which version numbers?

We have added some new functions for UFC, so I'd suggest UFC 1.2:

 - Add new function ufc::dof_map::max_local_dimension()
 - Change ufc::dof_map::local_dimension() to ufc::dof_map::local_dimension(const ufc::cell c)

In UFL, there have been bug fixes to lhs/rhs and some changes in the
log system. Should this be version 0.4.1? Martin?

--
Anders

---

From: "Garth N. Wells" <[email-masked]>
Date: Tue, 22 Sep 2009 17:48:58 +0100

> We have added some new functions for UFC, so I'd suggest UFC 1.2:

Agree.

> log system. Should this be version 0.4.1? Martin?

There has also been some work on restrictions.

Garth

> --
> Anders
> 
> 
> ------------------------------------------------------------------------
> 
> _______________________________________________
> UFC-dev mailing list
> [email-masked]
> http://fenics.org/mailman/listinfo/ufc-dev

---

From: Kristian Oelgaard <[email-masked]>
Date: Tue, 22 Sep 2009 18:08:37 +0200

Quoting "Garth N. Wells" <[email-masked]>:

> >  - Change ufc::dof_map::local_dimension() to
> ufc::dof_map::local_dimension(const ufc::cell c)
> >

I added this to the ChangeLog. I think the UFL is ready.

Kristian

> UFL-dev mailing list
> [email-masked]
> http://fenics.org/mailman/listinfo/ufl-dev
>

---

From: Anders Logg <[email-masked]>
Date: Tue, 22 Sep 2009 19:12:57 +0200

> I added this to the ChangeLog. I think the UFL is ready.

ok, let's just wait for Martin to comment.

--
Anders

---

From: Martin Sandve Alnæs <[email-masked]>
Date: Tue, 22 Sep 2009 20:02:52 +0200

The "bugfix" of adding expand_indices in lhs/rhs is _not_
the right way to do it. All you did was cover up the real bug...
I'm trying to fix it properly now.

(Ideally, the other dependencies from ufl to ufl.algorithms
in formoperators.py shouldn't have been there either.)

This release will be the 0.4 release, the last was 0.3.

Martin

On Tue, Sep 22, 2009 at 7:12 PM, Anders Logg <[email-masked]> wrote:
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v1.4.9 (GNU/Linux)
>
> iEYEARECAAYFAkq5BZcACgkQTuwUCDsYZdFdUQCePkFuvvnyEfJt7lpHArl5zeRV
> EpAAnReTiackBWjaYUdFph4il2f/1wlK
> =Pa/0
> -----END PGP SIGNATURE-----
>

---

From: Martin Sandve Alnæs <[email-masked]>
Date: Tue, 22 Sep 2009 20:15:05 +0200

Done.

Martin

---

From: "Garth N. Wells" <[email-masked]>
Date: Tue, 22 Sep 2009 19:16:41 +0100

> I'm trying to fix it properly now.

Good to know that you're still with us :).

Garth

---

From: Anders Logg <[email-masked]>
Date: Tue, 22 Sep 2009 20:26:36 +0200

> I'm trying to fix it properly now.

Great.

> This release will be the 0.4 release, the last was 0.3.

ok.

--
Anders

---

From: Anders Logg <[email-masked]>
Date: Wed, 23 Sep 2009 21:53:51 +0200

> log system. Should this be version 0.4.1? Martin?

What I meant here was 0.3.1 (I misinterpreted an entry in ChangeLog),
but 0.4.0 is also good. :-)

-- 
Anders