Subject: [UFL-dev] Fwd: UFL 0.3.0

From: Ola Skavhaug <[email-masked]>
Date: Sat, 8 Aug 2009 13:37:19 +0200

---------- Forwarded message ----------
From: Megan Lewis <[email-masked]>
Date: Fri, Aug 7, 2009 at 6:05 PM
Subject: UFL 0.3.0
To: Ola Skavhaug <[email-masked]>
Cc: Raymond Spiteri <[email-masked]>

Hi Ola,

I believe I have found a problem with UFL version 0.3.0, and I thought
I would pass along the error.  When installing dolfin with UFL 0.3.0
on Ubuntu, scons and scons install work fine, but scons
enableDemos=yes runs into an error, and none of the scripts will run.
They have this error message:

   from ufl.algorithms.transformations import purge_list_tensors
ImportError: cannot import name purge_list_tensors

This happens also when I install PyCC/Py4C.  If I remove UFL 0.3.0 and
install UFL 0.2.0, everything works fine.

Can you pass this along to the person working on UFL?

Thanks,
Megan Lewis

-- 
Ola Skavhaug

---

From: Kristian Oelgaard <[email-masked]>
Date: Sat, 08 Aug 2009 23:22:44 +0200

> ImportError: cannot import name purge_list_tensors

Which file is throwing this error? Which version of DOLFIN are you trying to
install with UFL 0.3.0? I couldn't reproduce the error.

For the dev versions, it should be"
from ufl.algorithms import purge_list_tensors
or
from ufl.algorithms.expand_indices import purge_list_tensors

Kristian

> _______________________________________________
> UFL-dev mailing list
> [email-masked]
> http://fenics.org/mailman/listinfo/ufl-dev
>