Subject: [UFL-dev] [HG UFL] Further fixes for errors found by pylint in algorithms/.

From: [email-masked] (UFL)
Date: Thu, 5 Mar 2009 10:45:22 +0100 (CET)

One or more new changesets pushed to the primary ufl repository.
A short summary of the last three changesets is included below.

changeset:   689:1ee24cc53f4654eacc50d19b6ce1b38f8a33a3b3
tag:         tip
user:        "Martin Sandve Alnæs <[email-masked]>"
date:        Thu Mar 05 10:46:32 2009 +0100
files:       sandbox/pylintlog/run_pychecker.py sandbox/pylintlog/runpylint.sh test/run_pychecker.py ufl/algorithms/ad.py ufl/algorithms/checks.py ufl/algorithms/formfiles.py ufl/algorithms/reverse_ad.py ufl/algorithms/transformations.py ufl/expr.py
description:
Further fixes for errors found by pylint in algorithms/.
Added sandbox folder pylintlog/ with script runpylint.sh
to make it easy to rerun.

changeset:   688:75333f646da2cf3dcae085b0e1fb3b089612e67f
user:        "Martin Sandve Alnæs <[email-masked]>"
date:        Thu Mar 05 10:32:07 2009 +0100
files:       sandbox/scripts/printimports.py ufl/constantvalue.py ufl/function.py ufl/integral.py ufl/operators.py ufl/sorting.py ufl/terminal.py
description:
A bunch of small fixes of errors reported by pylint.
(pylint gets confused by some of the things we do,
so there are some incorrectly reported errors)

changeset:   687:39a9f25e0c0c91a1ddaacb4050057315df35aaae
user:        "Martin Sandve Alnæs <[email-masked]>"
date:        Thu Mar 05 10:04:36 2009 +0100
files:       ROADMAP sandbox/oldsandbox/profiling.py sandbox/oldsandbox/stiffness_ad_debug.py sandbox/oldsandbox/tensor_element.ufl sandbox/oldsandbox/tensortest.py sandbox/oldsandbox/test.py sandbox/oldsandbox/test_hyperelasticity.py sandbox/oldsandbox/test_transformations.py sandbox/oldsandbox/testclasses.py sandbox/oldsandbox/testproduct.py sandbox/oldsandbox/u2l.py sandbox/operatortests/test_as_tensor.py sandbox/operatortests/test_product.py sandbox/scripts/rename.py sandbox/scripts/renderclasstree.py sandbox/scripts/showclasses.py sandbox/scripts/summarizetodos.py sandbox/scripts/tensoralgebrastrings.py sandbox/scripts/testclasses.py sandbox/suggestions/element_tensor_product_suggestion.ufl ufl/algorithms/renumbering.py
description:
Cleanup in sandbox.

----------------------------------------------------------------------
For more details, visit http://www.fenics.org/hg/ufl

---

From: Anders Logg <[email-masked]>
Date: Thu, 5 Mar 2009 10:50:33 +0100

> to make it easy to rerun.

From which directory should the runpylint.sh be run? It contains some
scary rm -rf stuff.

-- 
Anders

> _______________________________________________
> UFL-dev mailing list
> [email-masked]
> http://fenics.org/mailman/listinfo/ufl-dev

---

From: Martin Sandve Alnæs <[email-masked]>
Date: Thu, 5 Mar 2009 12:22:12 +0100

Just in its own directory.

Martin

On Thu, Mar 5, 2009 at 10:50 AM, Anders Logg <[email-masked]> wrote:
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v1.4.9 (GNU/Linux)
>
> iEYEARECAAYFAkmvoGkACgkQTuwUCDsYZdGtLACgkl0VR8Y8f77BKTJGaFuzVPV/
> Ue4An0BssMNZw5EO4u41LzKF0NDIShJ/
> =e2KS
> -----END PGP SIGNATURE-----
>