Subject: [UFL-dev] singular function and Quadrature element

From: [email-masked]
Date: Sun, 19 Apr 2009 23:17:36 +0200 (CEST)

I have a function which has a singularity on the boundary on the domain.
Hence
it is vital that this function is not evaluated at the boundary.

Can I use the quadrature element together with a quadrature rule to make
sure that this function and the form it is used in is not evaluated at the
boundary ?

Kent

---

From: Martin Sandve Alnæs <[email-masked]>
Date: Sun, 19 Apr 2009 23:47:42 +0200

In principle, but:

Quadrature elements currently don't work in SFC,
don't know what FFC can do at this point.

UFL does not (yet) standardize how to specify quadrature
rules manually if you need a particular rule. But I don't think
the Gauss rules used by SFC have points on the boundary.

Martin

On Sun, Apr 19, 2009 at 11:17 PM,  <[email-masked]> wrote:
> _______________________________________________
> UFL-dev mailing list
> [email-masked]
> http://fenics.org/mailman/listinfo/ufl-dev
>

---

From: Anders Logg <[email-masked]>
Date: Sun, 19 Apr 2009 23:56:08 +0200

> the Gauss rules used by SFC have points on the boundary.

FFC uses the quadrature points given by FIAT and none of them are on
the boundary as far as I can tell.

So this should work, but note that you can't differentiate functions
defined on a quadrature element.

-- 
Anders