Subject: [UFL-dev] Length of names

From: "Martin Sandve Alnæs" <[email-masked]>
Date: Tue, 1 Apr 2008 17:55:17 +0200

Does anyone have strong opinions on the choice of names for these?
I think we should pick one, multiple names for the same thing is just confusing.

tr(A) or trace(A)
det(A) or determinant(A)
inv(A) or inverse(A)

An there are probably some more.

-- 
Martin

---

From: Anders Logg <[email-masked]>
Date: Tue, 1 Apr 2008 18:23:26 +0200

> An there are probably some more.

determinant and inverse feel a little long, so I would prefer det()
and inv(). One typically writes det() also in mathematical notation.
Same for the trace. Even if it's short enough, I often see it written
as just tr().

-- 
Anders

---

From: [email-masked]
Date: Tue, 1 Apr 2008 20:08:17 +0200 (CEST)

> Same for the trace. Even if it's short enough, I often see it written

I also like short names as long as the meaning is clear.

Kent