Subject: [UFL-dev] [HG UFL] Made UFLObject a new-style class (object),

From: [email-masked] (UFL)
Date: Sat, 15 Mar 2008 20:37:37 +0100 (CET)

One or more new changesets pushed to the primary ufl repository.
A short summary of the last three changesets is included below.

changeset:   64:7c403ffda75eb8533f3b6e67dad342f456ea051b
tag:         tip
user:        martinal@localhost
date:        Sat Mar 15 21:37:43 2008 +0100
files:       src/ufl/base.py src/ufl/basisfunctions.py src/ufl/diffoperators.py src/ufl/tensoroperators.py
description:
Made UFLObject a new-style class (object),
and added __slots__ property to most of the classes.
This is partly an optimization that removes the
__dict__ instance from all objects, saving memory,
but most importantly at this point it will ensure
that no additional variables are added to these
objects, giving errors if 'foo.newvar=1' is attempted.
It also documents which member variables a class
has without having to read through constructor
logic.

Added __str__ implementations most places for
pretty printing, these could be improved.

changeset:   63:ed0ae01443570c813d87bb3d3a468b3b0c36f245
user:        martinal@localhost
date:        Fri Mar 14 20:57:27 2008 +0100
files:       src/ufl/utilities.py
description:
Added a couple of utility signatures for future implementation.

changeset:   62:57fe9d55a16be033ac6a57a34001c3990a5fa1c9
user:        martinal@localhost
date:        Fri Mar 14 20:24:58 2008 +0100
files:       src/ufl/__init__.py src/ufl/all.py src/ufl/base.py src/ufl/basisfunctions.py src/ufl/checks.py src/ufl/diffoperators.py src/ufl/form.py src/ufl/formoperators.py src/ufl/geometry.py src/ufl/integral.py src/ufl/mathfunctions.py src/ufl/objects.py src/ufl/output.py src/ufl/predicates.py src/ufl/tensoroperators.py src/ufl/transformers.py src/ufl/traversal.py src/ufl/utilities.py src/ufl/visitor.py
description:
Changed date format to 2008-03-14 etc.

----------------------------------------------------------------------
For more details, visit http://www.fenics.org/hg/ufl

---

From: Anders Logg <[email-masked]>
Date: Sat, 15 Mar 2008 20:47:32 +0100

Nice!

-- 
Anders

On Sat, Mar 15, 2008 at 08:37:37PM +0100, UFL wrote:
> _______________________________________________
> UFL-dev mailing list
> [email-masked]
> http://fenics.org/mailman/listinfo/ufl-dev