Subject: [UFL-dev] [HG UFL] Implement tuple notation, now in algorithms/tuplenotation.py.

From: [email-masked] (UFL)
Date: Mon, 6 Apr 2009 09:11:07 +0200 (CEST)

One or more new changesets pushed to the primary ufl repository.
A short summary of the last three changesets is included below.

changeset:   798:3362f4b3815288bfaf774d4f7c367f064c194d0e
tag:         tip
user:        Anders Logg <[email-masked]>
date:        Mon Apr 06 09:10:58 2009 +0200
files:       demo/HyperElasticity.ufl demo/TupleNotation.ufl ufl/__init__.py ufl/algorithms/__init__.py ufl/algorithms/tuplenotation.py ufl/classes.py ufl/form.py ufl/formoperators.py ufl/integral.py
description:
Implement tuple notation, now in algorithms/tuplenotation.py.
Form compilers should use ufl.algorithms.as_form to convert from
tuple (or Form) to Form. I tried placing as_form in form.py but
this did not work due to some recursive imports. It's now in
tuplenotation.py. Here's how it's done in FFC:

    forms = []
    elements = []
    for object in objects:
        if isinstance(object, FiniteElementBase):
            elements.append(object)
        elif not object is None:
            forms.append(as_form(object))

changeset:   797:63dff9824c9bc4af9b6016a0c145fb8552a04b48
user:        "Martin Sandve Alnæs <[email-masked]>"
date:        Sat Apr 04 16:22:38 2009 +0200
files:       ufl/algorithms/transformations.py
description:
Bugfix.

changeset:   796:21c9232e4ce5385ce7524a919de07d160532e890
user:        "Martin Sandve Alnæs <[email-masked]>"
date:        Fri Apr 03 17:48:29 2009 +0200
files:       ufl/algorithms/formfiles.py
description:
basis function name fix

----------------------------------------------------------------------
For more details, visit http://www.fenics.org/hg/ufl

---

From: Martin Sandve Alnæs <[email-masked]>
Date: Mon, 6 Apr 2009 09:19:32 +0200

The tests break now.

Martin

On Mon, Apr 6, 2009 at 9:11 AM, UFL <[email-masked]> wrote:
> _______________________________________________
> UFL-dev mailing list
> [email-masked]
> http://fenics.org/mailman/listinfo/ufl-dev
>
>

---

From: Martin Sandve Alnæs <[email-masked]>
Date: Mon, 6 Apr 2009 09:30:38 +0200

Sorry, wrong configuration. Tests are ok.

Martin

---

From: Anders Logg <[email-masked]>
Date: Mon, 6 Apr 2009 12:40:05 +0200

> Sorry, wrong configuration. Tests are ok.

I made sure to run the tests before committing.

You just assumed I would break something. ;-)

-- 
Anders