Subject: Re: [Ufl] [Bug 960000] [NEW] missing error message facet normal is used in cell integrals

From: Kristian Ølgaard <[email-masked]>
Date: Tue, 20 Mar 2012 15:43:16 +0100

Could this be one of the things UFL should check for (an algorithm to
check if a form is valid)?

On 20 March 2012 09:10, Johan Hake <[email-masked]> wrote:
> Public bug reported:
>
> The following three lines give comprehensible compilation error:
>
> from dolfin import *
> mesh = UnitSquare(2,2)
> assemble(dot(mesh.ufl_cell().n,mesh.ufl_cell().n)*dx)
>
> ** Affects: ffc
>     Importance: Undecided
>         Status: New
>
> --
> You received this bug notification because you are a member of FFC Core
> Team, which is subscribed to FFC.
> https://bugs.launchpad.net/bugs/960000
>
> Title:
>  missing error message facet normal is used in cell integrals
>
> Status in FEniCS Form Compiler:
>  New
>
> Bug description:
>  The following three lines give comprehensible compilation error:
>
>  from dolfin import *
>  mesh = UnitSquare(2,2)
>  assemble(dot(mesh.ufl_cell().n,mesh.ufl_cell().n)*dx)
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ffc/+bug/960000/+subscriptions

---

From: Anders Logg <[email-masked]>
Date: Tue, 20 Mar 2012 18:26:05 +0100

Since it can be checked in UFL, I think that's the right place to
check it.

PS: Notice that this is bug 960000. Who will submit lucky bug nr
1000000? :-)

--
Anders

On Tue, Mar 20, 2012 at 03:43:16PM +0100, Kristian Ølgaard wrote:
> _______________________________________________
> Mailing list: https://launchpad.net/~ufl
> Post to     : [email-masked]
> Unsubscribe : https://launchpad.net/~ufl
> More help   : https://help.launchpad.net/ListHelp