Subject: Re: [UFL-dev] [DOLFIN-dev] Interesting issue with interpolate(?)

From: Kristian Oelgaard <[email-masked]>
Date: Fri, 21 Aug 2009 12:28:01 +0200

Quoting Marie Rognes <[email-masked]>:

> Kristian Oelgaard wrote:
> > Quoting Marie Rognes <[email-masked]>:
> >
> >
> >> (Tested both using tensor and quadrature representation.
> >> Tensor and quad differ somewhat for the norm(u).
> >> Is the quadrature default to integrate RTs using
> >> "too low" a quadrature rule still?)
> >>
> >
> > Could be, quadrature uses the UFL guesstimate which just looks at the
> element
> > degree. And I think it is 'tricked' by the RT element when doing this (as I
> > recall it). You can set the quadrature order through metadata of the
> Measure to
> > increase the order manually, then tensor and quadrature should at least
> agree.
> > Do note that tensor representation ignores the metadata input (which is a
> bug).
> >
>
> Maybe life would be simpler if we just changed the numbering of the RT
> and the Nedelecs?
> So that a finite element space of degree k is always in P_k?

Yes I think so, because UFL is unaware (and is designed to be) of finite
elements and their definition/implementation.

Kristian

> --
> Marie

---

From: Kristian Oelgaard <[email-masked]>
Date: Tue, 25 Aug 2009 12:21:34 +0200

> elements and their definition/implementation.

I've modified FFC such that tensor representation will use the quadrature_order
from UFL.
Now you can tell what order to use from the command line or through metadata.
This means that both quadrature and tensor will use too few integration points
for RT elements and the like the way things are now.

Kristian

> Kristian
>
> > --
> > Marie
> >
>
>
> _______________________________________________
> FFC-dev mailing list
> [email-masked]
> http://www.fenics.org/mailman/listinfo/ffc-dev
>