Subject: [UFL-dev] [HG UFL] More cleanup. Added missing file. Moved utilities performing transformations

From: [email-masked] (UFL)
Date: Tue, 20 May 2008 18:23:32 +0200 (CEST)

One or more new changesets pushed to the primary ufl repository.
A short summary of the last three changesets is included below.

changeset:   113:1757c0f738145ca3ea85c1f3f4c02bc2558920ae
tag:         tip
user:        "Martin Sandve Alnæs <[email-masked]>"
date:        Tue May 20 18:23:35 2008 +0200
files:       ufl/algebra.py ufl/all.py ufl/analysis.py ufl/base.py ufl/geometry.py ufl/new_transform.py ufl/transformations.py ufl/traversal.py ufl/utilities.py ufl/variable.py
description:
More cleanup. Added missing file. Moved utilities performing transformations
into transformations.py, utilities doing analysis and information extraction
into analysis.py, and import all utilities into utilities.py such that
'from ufl.utilitis import *' is possible.

Moved Variable to variable.py, removed the name, and removed class Symbol.
My idea now is that we should be able to do this:

f = any expression, possibly tensor valued
fv = variable(f)
g = foo(fv)
h = diff(g, fv)

changeset:   112:9e119cc0c9d1a1e9aef51dea04ff809e0ae88464
user:        "Martin Sandve Alnæs <[email-masked]>"
date:        Tue May 20 15:03:07 2008 +0200
files:       ufl/__init__.py ufl/all.py ufl/base.py ufl/differentiation.py ufl/tensoralgebra.py ufl/tensors.py
description:
Some cleanup.

changeset:   111:5551c9d6e223c33b9fdc07cc44e24e9868df7a46
user:        "Martin Sandve Alnæs <[email-masked]>"
date:        Tue May 20 14:52:55 2008 +0200
files:       ufl/all.py ufl/base.py ufl/differentiation.py ufl/indexing.py ufl/operators.py ufl/tensoralgebra.py ufl/tensors.py
description:
Moved operators from base.py to their respective context file.
The trick was to not implement the operators in the UFLObject
class itself, but instead extend UFLObject with the various
operators in their respective files like:

def _getitem(self, key):
    return Indexed(self, key)
UFLObject.__getitem__ = _getitem

----------------------------------------------------------------------
For more details, visit http://www.fenics.org/hg/ufl

---

From: Anders Logg <[email-masked]>
Date: Thu, 22 May 2008 23:47:00 +0200

> 'from ufl.utilitis import *' is possible.

I think we should avoid * in imports as far as possible.

-- 
Anders

> _______________________________________________
> UFL-dev mailing list
> [email-masked]
> http://fenics.org/mailman/listinfo/ufl-dev