Subject: [UFL-dev] [HG UFL] Improved dot rendering, added ufl-convert script which

From: [email-masked] (UFL)
Date: Tue, 18 Nov 2008 16:40:44 +0100 (CET)

One or more new changesets pushed to the primary ufl repository.
A short summary of the last three changesets is included below.

changeset:   419:525127a121f8ec653d847a411a566d61b2a9cb31
tag:         tip
user:        "Martin Sandve Alnæs <[email-masked]>"
date:        Tue Nov 18 16:40:48 2008 +0100
files:       demo/clean.sh scripts/ufl-convert setup.py ufl/algorithms/ufl2latex.py
description:
Improved dot rendering, added ufl-convert script which
will replace ufl2pdf and ufl2latex, using options to
switch between output formats.
ufl2latex isn't completely merged in there yet.

Example:
  ufl-convert -fdot -tpng -s1 stiffness_ad.ufl

This will hopefully be helpful for visual debugging.

changeset:   418:2d86357ceeacde250c142c6e541d2810b7f9bbde
user:        "Martin Sandve Alnæs <[email-masked]>"
date:        Tue Nov 18 13:59:41 2008 +0100
files:       ufl/algorithms/dependencies.py ufl/algorithms/ufl2latex.py
description:
Simplified DependencySet to only track dependencies with the variables
 - runtime
 - coordinates
 - basisfunction[i]

changeset:   417:df85f19803b64128322c3085a9847b500bfa0b97
user:        "Martin Sandve Alnæs <[email-masked]>"
date:        Tue Nov 18 10:26:56 2008 +0100
files:       LICENCE ROADMAP
description:
Added GPLv3 licence file.

Are there any reasons we have to use LGPL in the future?
I guess UFL being GPL infects many other fenics projects.
Until UFL is required by other FEniCS projects, it doesn't
matter.

----------------------------------------------------------------------
For more details, visit http://www.fenics.org/hg/ufl

---

From: Anders Logg <[email-masked]>
Date: Tue, 18 Nov 2008 16:51:49 +0100

Very cool, but ufl2dot seems to be missing.

-- 
Anders

> _______________________________________________
> UFL-dev mailing list
> [email-masked]
> http://fenics.org/mailman/listinfo/ufl-dev