Subject: [Ufl] Scalars and Measures

From: Johan Hake <[email-masked]>
Date: Wed, 5 Jan 2011 14:15:05 -0800

Hello!

Why isn't the following valid:

  5*dx

It would be handy if it was :)

UFL borks in the function:

  is_true_ufl_scalar(5)

as the function only expects instances of Expr which an int or float are not.

Johan

---

From: Martin Sandve Alnæs <[email-masked]>
Date: Wed, 5 Jan 2011 23:20:03 +0100

The domain dimension is undefined. Use a Constant.

Martin
Den 5. jan. 2011 23.15 skrev "Johan Hake" <[email-masked]> følgende:
> _______________________________________________
> Mailing list: https://launchpad.net/~ufl
> Post to : [email-masked]
> Unsubscribe : https://launchpad.net/~ufl
> More help : https://help.launchpad.net/ListHelp

---

From: Johan Hake <[email-masked]>
Date: Wed, 5 Jan 2011 15:08:05 -0800

> The domain dimension is undefined. Use a Constant.

Ok, should there be some check further check that Meassure.__rmul__ expects an 
Expr as integrand?

Johan

> > as the function only expects instances of Expr which an int or float are
> 
> not.
> 
> > Johan
> >

---

From: Martin Sandve Alnæs <[email-masked]>
Date: Thu, 6 Jan 2011 07:11:22 +0100

The check clearly succeeded, but a better message could be written of
course.

Martin

---

From: Johan Hake <[email-masked]>
Date: Thu, 6 Jan 2011 12:08:19 -0800

> The check clearly succeeded, but a better message could be written of

:)

Johan
 
> > Ok, should there be some check further check that Meassure.__rmul__
> 
> expects an
> 
> > Expr as integrand?
> > 
> > Johan
> > 
> >> Martin
> >> 
> >> Den 5. jan. 2011 23.15 skrev "Johan Hake" <[email-masked]>
> 
> følgende:
> >> > Hello!
> >> > 
> >> > as the function only expects instances of Expr which an int or float
> 
> are
> 
> >> not.
> >> 
> >> > Johan
> >> >