Subject: [UFL-dev] [HG UFL] Improvements to AD, this now works:

From: [email-masked] (UFL)
Date: Wed, 24 Sep 2008 12:17:42 +0200 (CEST)

One or more new changesets pushed to the primary ufl repository.
A short summary of the last three changesets is included below.

changeset:   258:9e178ccb7405f7b5a0d7405bbdbe838bc8836d3b
tag:         tip
user:        "Martin Sandve Alnæs <[email-masked]>"
date:        Wed Sep 24 12:17:40 2008 +0200
files:       ufl/__init__.py ufl/algebra.py ufl/algorithms/__init__.py ufl/algorithms/ad.py ufl/algorithms/checks.py ufl/algorithms/transformations.py ufl/algorithms/ufl2latex.py ufl/base.py ufl/baseoperators.py ufl/classes.py ufl/conditional.py ufl/formoperators.py ufl/function.py ufl/mathfunctions.py ufl/objects.py ufl/tensoralgebra.py
description:
Improvements to AD, this now works:
a = f*v*dx
b = derivative(a, f)
# b == u*v*dx

We may need to discuss some implementation issues though.

changeset:   257:ae63258301bdd41942a931c914c31cbb6a2b5898
user:        "Martin Sandve Alnæs <[email-masked]>"
date:        Mon Sep 22 12:02:05 2008 +0200
files:       ROADMAP doc/manual/chapters/arguments.tex doc/manual/chapters/debugging.tex doc/manual/chapters/elements.tex doc/manual/chapters/forms.tex doc/manual/chapters/introduction.tex doc/manual/chapters/operators.tex doc/manual/chapters/transformations.tex doc/manual/ufl-user-manual.tex ufl/algorithms/transformations.py
description:
Added manual framework with almost no content.

changeset:   256:c24dffe424cae67912b05b13136c53e54ad2688e
parent:      255:c0ce93a84ee42ccb131fbfe5327be1f3d92187cb
parent:      253:de2b478145d96cb7b672f589f2815f842152e21d
user:        "Martin Sandve Alnæs <[email-masked]>"
date:        Sun Sep 21 21:53:56 2008 +0200
files:       ufl/algorithms/analysis.py ufl/algorithms/checks.py ufl/algorithms/transformations.py ufl/classes.py
description:
Another merge, didn't quite understand why this happened...

----------------------------------------------------------------------
For more details, visit http://www.fenics.org/hg/ufl

---

From: Anders Logg <[email-masked]>
Date: Wed, 24 Sep 2008 12:53:50 +0200

Excellent! :-)

-- 
Anders

> _______________________________________________
> UFL-dev mailing list
> [email-masked]
> http://fenics.org/mailman/listinfo/ufl-dev