Subject: [UFL-dev] [HG UFL] Improved LaTeX compilation. Still looks ugly since it's

From: [email-masked] (UFL)
Date: Mon, 27 Oct 2008 19:48:15 +0100 (CET)

One or more new changesets pushed to the primary ufl repository.
A short summary of the last three changesets is included below.

changeset:   369:adeecc7802c9e43ef6c9cbb64558dcc7673f4038
tag:         tip
user:        "Martin Sandve Alnæs <[email-masked]>"
date:        Mon Oct 27 19:48:15 2008 +0100
files:       scripts/ufl2latex ufl/algorithms/ufl2latex.py
description:
Improved LaTeX compilation. Still looks ugly since it's
missing precedence handling, and still missing some
operators like tensors. But now the function spaces,
arguments, and variables are defined before the integrals.

Try
  cd <ufldir>/demo
  ufl2pdf stiffness.ufl
  ufl2pdf source.ufl
then open the .pdf files.

changeset:   368:6101dc2b26f7ead61a5d07897814410287e8dea0
user:        "Martin Sandve Alnæs <[email-masked]>"
date:        Mon Oct 27 18:57:48 2008 +0100
files:       ROADMAP ufl/algorithms/variables.py ufl/variable.py
description:
Rewritten mark_duplications: fixed some problems and created new ones.

changeset:   367:056e597773bf245caca82cd67012150897cb1a22
user:        "Martin Sandve Alnæs <[email-masked]>"
date:        Mon Oct 27 17:20:52 2008 +0100
files:       scripts/ufl2latex scripts/ufl2pdf setup.py
description:
Added ufl2pdf script, using pdflatex to make
pdf file with all forms in a .ufl file.

----------------------------------------------------------------------
For more details, visit http://www.fenics.org/hg/ufl

---

From: Anders Logg <[email-masked]>
Date: Mon, 27 Oct 2008 20:36:18 +0100

Looks very nice!

-- 
Anders

> _______________________________________________
> UFL-dev mailing list
> [email-masked]
> http://fenics.org/mailman/listinfo/ufl-dev