Subject: [UFL-dev] UFL form checks.

From: Kristian Oelgaard <[email-masked]>
Date: Mon, 06 Jul 2009 14:05:54 +0200

Hi,

Currently UFL will complain about:

a = v*u*dS

*** FFC: Form argument must be restricted.
*** FFC: To get more information about this error, rerun FFC with --debug.

which is OK, but not about this form:

a = v('+')*u*dx

This should result in an error (no restrictions on dx or ds).

Kristian

---

From: Anders Logg <[email-masked]>
Date: Tue, 8 Sep 2009 23:01:35 +0200

> This should result in an error (no restrictions on dx or ds).

I've added a bug report about this so I'm closing this thread. :-)

--
Anders