Subject: [UFL-dev] [HG UFL] Added AD demos computing mass and stiffness matrices from energy functionals.

From: [email-masked] (UFL)
Date: Tue, 28 Oct 2008 15:16:04 +0100 (CET)

One or more new changesets pushed to the primary ufl repository.
A short summary of the last three changesets is included below.

changeset:   375:a3719de87e5ab19f55c3d75e7db9606675a5fa99
tag:         tip
user:        "Martin Sandve Alnæs <[email-masked]>"
date:        Tue Oct 28 15:16:01 2008 +0100
files:       demo/mass_ad.ufl demo/stiffness_ad.ufl ufl/algorithms/ad.py
description:
Added AD demos computing mass and stiffness matrices from energy functionals.

changeset:   374:bdaa2cbe1f9c5c84f27c36e3a913f5f268ef77b2
user:        "Martin Sandve Alnæs <[email-masked]>"
date:        Tue Oct 28 13:22:19 2008 +0100
files:       ufl/algorithms/ufl2latex.py ufl/algorithms/variables.py ufl/base.py ufl/baseoperators.py
description:
Made algebraic operators compute float operations
on the fly instead of representing them as Sum etc.
Simplifies some expressions created by algorithms.
Still not sorting operands to discover 2+2 in "2+n+2",
since this has other side effects.

(+ Some minor improvements to latex output.)

changeset:   373:fc14624de31b0b7fc6eceafd4c028da2a6bec805
user:        "Martin Sandve Alnæs <[email-masked]>"
date:        Tue Oct 28 10:50:59 2008 +0100
files:       scripts/ufl2latex ufl/algorithms/ufl2latex.py
description:
Improved LaTeX output: using one align environment for each part (spaces, arguments, variables, form)

----------------------------------------------------------------------
For more details, visit http://www.fenics.org/hg/ufl

---

From: Kent Andre <[email-masked]>
Date: Wed, 29 Oct 2008 09:54:16 +0100

Cool! Are there some simplifications that can be done with numbers? It
seems that (1/2)' =   (2/2^2), which is true, but ...

Kent

On ti., 2008-10-28 at 15:16 +0100, UFL wrote:
> _______________________________________________
> UFL-dev mailing list
> [email-masked]
> http://fenics.org/mailman/listinfo/ufl-dev

---

From: "Martin Sandve Alnæs" <[email-masked]>
Date: Wed, 29 Oct 2008 10:10:33 +0100

I'm working on some possible simplifications, but we can't
find all without doing some stuff I don't think I want to do.

--
Martin