Subject: [Ufl] ufl patch

From: [email-masked]
Date: Fri, 18 Jun 2010 13:27:33 +0200

please accept the attached minor bug fix patch.

Kent

# Bazaar merge directive format 2 (Bazaar 0.90)
# revision_id: [email-masked]
# target_branch: bzr+ssh://bazaar.launchpad.net/~ufl-core/ufl/main/
# testament_sha1: 6055a802a96e281128e138d14f14d152620cfe42
# timestamp: 2010-06-18 13:23:25 +0200
# base_revision_id: [email-masked]
# 
# Begin patch
=== modified file 'ufl/algorithms/analysis.py'
--- ufl/algorithms/analysis.py	2010-01-26 08:35:41 +0000
+++ ufl/algorithms/analysis.py	2010-06-15 10:41:09 +0000
@@ -242,7 +242,7 @@
 def estimate_quadrature_degree(integral):
     "Estimate the necessary quadrature order for integral using the sum of basis function degrees."
     arguments = extract_arguments(integral)
-    degrees = [b.element().degree() for v in arguments]
+    degrees = [v.element().degree() for v in arguments]
     if len(arguments) == 0:
         return None
     if len(arguments) == 1:

# Begin bundle

---

From: Kristian Oelgaard <[email-masked]>
Date: Fri, 18 Jun 2010 13:46:56 +0200

I got:

$ bzr patch ufl.patch
patch unexpectedly ends in middle of line

when trying to apply it.

Did you follow the instructions on
http://www.fenics.org/newdoc/contributing.html#patches ?

Kristian

On 18 June 2010 13:27,  <[email-masked]> wrote:
> _______________________________________________
> Mailing list: https://launchpad.net/~ufl
> Post to     : [email-masked]
> Unsubscribe : https://launchpad.net/~ufl
> More help   : https://help.launchpad.net/ListHelp
>
>

---

From: [email-masked]
Date: Fri, 18 Jun 2010 14:01:46 +0200

I think so, but lets try again.

# timestamp: 2010-06-18 13:59:06 +0200

# Begin bundle

---

From: Kristian Oelgaard <[email-masked]>
Date: Fri, 18 Jun 2010 14:53:43 +0200

> I think so, but lets try again.

I still got the same message, please check if all your changes made it through.

Kristian