Subject: [Ufl] [[email-masked]: [Branch ~ufl-core/ufl/main] Rev 986: Bump version number to 0.9.1.]

From: Anders Logg <[email-masked]>
Date: Fri, 8 Apr 2011 15:04:47 +0200

Nice to have you back! :-)

When you make releases, remember to update tarballs, announcements etc
on Launchpad. This is easiest handled using the fenics-release script
which you can get from the repository lp:fenics-dev.

Simply run the fenics-release script in the UFL repository and follow
the instructions. The script is configured using the release.conf
file. What it does is just to pack up the repository, sign the
tarball + display some reminders of things that need updating.

--
Anders

Subject: [Branch ~ufl-core/ufl/main] Rev 986: Bump version number to 0.9.1.
From: [email-masked]
To: Anders Logg <[email-masked]>
Date: Fri, 08 Apr 2011 12:08:18 -0000

------------------------------------------------------------
revno: 986
committer: Martin Alnæs <[email-masked]>
branch nick: ufl
timestamp: Fri 2011-04-08 12:46:37 +0200
message:
  Bump version number to 0.9.1.
modified:
  ufl/__init__.py

--
lp:ufl
https://code.launchpad.net/~ufl-core/ufl/main

Your team UFL Core Team is subscribed to branch lp:ufl.
To unsubscribe from this branch go to https://code.launchpad.net/~ufl-core/ufl/main/+edit-subscription
=== modified file 'ufl/__init__.py'
--- ufl/__init__.py	2011-02-23 20:26:30 +0000
+++ ufl/__init__.py	2011-04-08 10:46:37 +0000
@@ -98,11 +98,11 @@
 
 """
 
-__version__ = "0.9.0"
+__version__ = "0.9.1"
 __authors__ = "Martin Sandve Alnes and Anders Logg"
-__copyright__ = "Copyright (C) 2008-2010 " + __authors__
+__copyright__ = "Copyright (C) 2008-2011 " + __authors__
 __license__  = "GNU GPL version 3 or any later version"
-__date__ = "2008-03-14"
+__date__ = "2011-04-08"
 
 # Modified by Kristian Oelgaard, 2009
 # Modified by Anders Logg, 2009.

---

From: Anders Logg <[email-masked]>
Date: Fri, 8 Apr 2011 15:07:54 +0200

Btw, all copyright forms for UFL have been signed so you can change to
LPGL now:

https://docs.google.com/document/d/1cYk_wD5L8Sla6nGvxI_wiCOS81CDRR5jpW3oWMvfrJQ/edit?hl=en&authkey=CLT1jr4D&pli=1#

--
Anders

---

From: Martin Sandve Alnæs <[email-masked]>
Date: Fri, 8 Apr 2011 15:30:41 +0200

> Nice to have you back! :-)

Nice to be back :)

> which you can get from the repository lp:fenics-dev.

Ok, I wasn't planning on making a release quite yet, this was just some
cleanup in the test code. I plan on doing more work on the unittests on the
side.

Martin

> ---------- Forwarded message ----------
> To unsubscribe from this branch go to
> https://code.launchpad.net/~ufl-core/ufl/main/+edit-subscription
>
> _______________________________________________
> Mailing list: https://launchpad.net/~ufl
> Post to     : [email-masked]
> Unsubscribe : https://launchpad.net/~ufl
> More help   : https://help.launchpad.net/ListHelp
>
>

---

From: Martin Sandve Alnæs <[email-masked]>
Date: Fri, 8 Apr 2011 16:24:41 +0200

I changed to LGPL in the .py files, but we need a COPYING file as well. Will
fix next week if you don't.

Martin

---

From: Anders Logg <[email-masked]>
Date: Fri, 8 Apr 2011 16:40:54 +0200

ok. I might do so but have plenty of other libraries to update along
the way. :-)

--
Anders

On Fri, Apr 08, 2011 at 04:24:41PM +0200, Martin Sandve Alnæs wrote:
>     https://docs.google.com/document/d/
>     1cYk_wD5L8Sla6nGvxI_wiCOS81CDRR5jpW3oWMvfrJQ/edit?hl=en&authkey=CLT1jr4D&
>     pli=1#
>
>
>
>     > committer: Martin Aln s <[email-masked]>
>     > branch nick: ufl

---

From: Anders Logg <[email-masked]>
Date: Fri, 8 Apr 2011 16:39:34 +0200

On Fri, Apr 08, 2011 at 03:30:41PM +0200, Martin Sandve Alnæs wrote:
> Ok, I wasn't planning on making a release quite yet, this was just some cleanup
> in the test code. I plan on doing more work on the unittests on the side.

ok, I thought you made a release.

--
Anders