Subject: [UFL-dev] [HG UFL] Generalized lstr to handle lists or tuples with lists

From: [email-masked] (UFL)
Date: Mon, 29 Sep 2008 16:32:21 +0200 (CEST)

One or more new changesets pushed to the primary ufl repository.
A short summary of the last three changesets is included below.

changeset:   283:6fa9c6e9e2989fcb8d2242b15a1353fb8374cfa8
tag:         tip
user:        "Martin Sandve Alnæs <[email-masked]>"
date:        Mon Sep 29 16:32:35 2008 +0200
files:       ufl/common.py
description:
Generalized lstr to handle lists or tuples with lists
or tuples as items, calling lstr recursively.
Also using () for tuples instead of [].

changeset:   282:eefbe0539581b033128e669ba1f87e3588388aa4
user:        Anders Logg <[email-masked]>
date:        Mon Sep 29 15:56:41 2008 +0200
files:       ufl/algorithms/formdata.py ufl/common.py
description:
Move lstr() to common

changeset:   281:d94515b110076da3b5dcb0a1061a9bf046b4d629
user:        Anders Logg <[email-masked]>
date:        Mon Sep 29 13:39:01 2008 +0200
files:       ufl/__init__.py ufl/algorithms/checks.py
description:
Don't include FiniteElementBase in ufl namespace

----------------------------------------------------------------------
For more details, visit http://www.fenics.org/hg/ufl

---

From: Anders Logg <[email-masked]>
Date: Mon, 29 Sep 2008 16:34:18 +0200

Isn't it strange that str() on a list calls repr() on the items?

-- 
Anders

> _______________________________________________
> UFL-dev mailing list
> [email-masked]
> http://fenics.org/mailman/listinfo/ufl-dev