Subject: [UFL-dev] Functions in analysis.py

From: Anders Logg <[email-masked]>
Date: Tue, 21 Oct 2008 14:42:27 +0200

Can we rename the functions in analysis.py to extract_foo?

Otherwise, it's not possible to write

  elements = elements(form)

I'd like to write

  elements = extract_elements(form)
  monomials = extract_monomials(form)

etc.

-- 
Anders

---

From: "Martin Sandve Alnæs" <[email-masked]>
Date: Tue, 21 Oct 2008 14:55:17 +0200

Ok! I've been in the same situation some times...

-- 
Martin

2008/10/21 Anders Logg <[email-masked]>:
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v1.4.6 (GNU/Linux)
>
> iD8DBQFI/c4zTuwUCDsYZdERAmU6AKCAFVTohglIlD3+fZDqf2SarPX7ggCgjWdu
> fEa3U/k/Rj2BOKTleK9Omr4=
> =1VUw
> -----END PGP SIGNATURE-----
>
> _______________________________________________
> UFL-dev mailing list
> [email-masked]
> http://fenics.org/mailman/listinfo/ufl-dev
>
>

---

From: Anders Logg <[email-masked]>
Date: Tue, 21 Oct 2008 15:00:22 +0200

> Ok! I've been in the same situation some times...

ok, I'll do some renaming then...

-- 
Anders