Subject: [Ufl] Rename log module and introduce log=>ln alias?

From: Johan Hake <[email-masked]>
Date: Thu, 21 Jul 2011 12:21:53 -0700

Hello!

I am running into a subtle but crucial problem. I am using SymPy to generate 
UFL code :) The problem I have at the moment is that sympy turn log/ln into 
"log". This map to the log module in UFL and not to the ln function. I have 
tried highjack sympy output but untill now that has not been succesfull. 

Would it be possible to map log to ln in UFL and change the name of the log 
module to something else? I am sure I am not the only one that have used log 
instead of ln. In numpy and sympy log map to ln. 

As a side note one could maybe also include log2, log10 like they have in 
numpy?

Johan

---

From: Johan Hake <[email-masked]>
Date: Thu, 21 Jul 2011 12:58:46 -0700

Found a minimal fix on the sympy side of it:

  class ln(log):pass
  log = ln

We still might consider changing the name of the log module and include a 
mapping from log to ln :)

Johan

On Thursday July 21 2011 12:21:53 Johan Hake wrote:
> Hello!
> 
> I am running into a subtle but crucial problem. I am using SymPy to
> generate UFL code :) The problem I have at the moment is that sympy turn
> log/ln into "log". This map to the log module in UFL and not to the ln
> function. I have tried highjack sympy output but untill now that has not
> been succesfull.
> 
> module to something else? I am sure I am not the only one that have used
> log instead of ln. In numpy and sympy log map to ln.
> 
> _______________________________________________
> Mailing list: https://launchpad.net/~ufl
> Post to     : [email-masked]
> Unsubscribe : https://launchpad.net/~ufl
> More help   : https://help.launchpad.net/ListHelp