Subject: [UFL-dev] Restrictions at facets

From: "Garth N. Wells" <[email-masked]>
Date: Thu, 14 May 2009 06:52:52 +0100

FFC used to throw an error if functions were integrated on interior 
facets but not restricted to the '+' or '-' side, but UFL doesn't. If I do

     element = FiniteElement("Discontinuous Lagrange", triangle, 1)
     v = TestFunction(element)
     u = TrialFunction(element)

     # Integrate on interior facet
     a = v*u*dS

what result should I expect? I had anticipated an error.

Garth

---

From: Martin Sandve Alnæs <[email-masked]>
Date: Thu, 14 May 2009 09:30:18 +0200

I have zero knowledge of discontinuous Galerkin methods,
so there are no checks at all. What should we check for?

Do you mean (implementation must be different):

if integral is on interior facets:
    for f in basis function and functions in integrand:
        assert that f is restricted
?

We should probably propagate ('+') and ('-') up
the tree to reach the leaves (terminals), right?

Martin

On Thu, May 14, 2009 at 7:52 AM, Garth N. Wells <[email-masked]> wrote:
> _______________________________________________
> UFL-dev mailing list
> [email-masked]
> http://fenics.org/mailman/listinfo/ufl-dev
>

---

From: Kristian Oelgaard <[email-masked]>
Date: Thu, 14 May 2009 09:36:57 +0200

>         assert that f is restricted

Yes, that's what I would expect. Constants must also be restricted but they're
defined on DG elements right? So this is not a problem.

> the tree to reach the leaves (terminals), right?

Yes, such that grad(u)('+') == grad(u('+'))

Kristian

---

From: "Garth N. Wells" <[email-masked]>
Date: Thu, 14 May 2009 08:37:09 +0100

>         assert that f is restricted

Yes.

> the tree to reach the leaves (terminals), right?

I don't know what that means ;).

Garth

-- 
Dr Garth N Wells
Department of Engineering
University of Cambridge
Trumpington Street
Cambridge CB2 1PZ
United Kingdom

tel.   +44 1223 3 32743
fax.   +44 1223 3 32662
e-mail [email-masked]

---

From: Anders Logg <[email-masked]>
Date: Thu, 14 May 2009 09:42:05 +0200

Yes.

Yes.

-- 
Anders

---

From: Martin Sandve Alnæs <[email-masked]>
Date: Thu, 14 May 2009 09:47:25 +0200

>>         assert that f is restricted

Ok. Should be easy to do.

>> the tree to reach the leaves (terminals), right?

Ok. Except that I'm already propagating Dx and [i] up
as well, so there is some confusion there.
Let me think about it and work out something
consistent in early june, I'm trying to get my PhD
over with first.

Martin

---

From: Anders Logg <[email-masked]>
Date: Thu, 14 May 2009 10:32:16 +0200

> as well, so there is some confusion there.

I don't think there's any confusion. As fas as I can see, all these
three always need to be propagated to either a basis function or a
function.

> consistent in early june, I'm trying to get my PhD

Good luck.

-- 
Anders

---

From: "Garth N. Wells" <[email-masked]>
Date: Fri, 05 Jun 2009 19:54:53 +0100

>         assert that f is restricted

I would be nice to have the above. It would have saved me a few hours 
this afternoon . . .

Garth

---

From: Martin Sandve Alnæs <[email-masked]>
Date: Mon, 8 Jun 2009 10:25:30 +0200

Facet normals should always be restricted as well, right?

Martin

On Fri, Jun 5, 2009 at 8:54 PM, Garth N. Wells<[email-masked]> wrote:
> I would be nice to have the above. It would have saved me a few hours this
> afternoon . . .
>
> Garth
>
>

---

From: Anders Logg <[email-masked]>
Date: Mon, 8 Jun 2009 10:26:50 +0200

Yes, most of all. :-)

-- 
Anders