Subject: [UFL-dev] [HG UFL] Quickly sketched a minor idea:

From: [email-masked] (UFL)
Date: Thu, 18 Dec 2008 23:25:46 +0100 (CET)

One or more new changesets pushed to the primary ufl repository.
A short summary of the last three changesets is included below.

changeset:   453:958e2a23876e02195da0c702a6329047fb4a4c3b
tag:         tip
user:        "Martin Sandve Alnæs <[email-masked]>"
date:        Thu Dec 18 23:25:55 2008 +0100
files:       ufl/finiteelement.py ufl/geometry.py
description:
Quickly sketched a minor idea:
With a Cell class we could do this:

  triangle = Cell("triangle")
  quadratic_triangle = Cell("triangle", 2)

  cell = triangle # we can predefine interval, triangle, tetrahedron, etc.
  element = FiniteElement("CG", cell, 1) # instead of domain2dim[domain], we can just do cell.dim()
  n = cell.n() # returns FacetNormal(domain), no change in other code
  x = cell.x()
  ...

The Cell class is implemented but not used.
Putting it to use instead of the domain string
will be a small task causing no problems in UFL.

changeset:   452:cbd0138213e95e43f9595d80390c2019eb119007
user:        "Martin Sandve Alnæs <[email-masked]>"
date:        Wed Dec 17 15:00:47 2008 +0100
files:       setup.py
description:
Update setup.py like Johannes did for UFC.

changeset:   451:f3188f73c96796b08331dbfae2505991bb8774c7
user:        "Martin Sandve Alnæs <[email-masked]>"
date:        Mon Dec 15 15:04:58 2008 +0100
files:       ufl/__init__.py
description:
Added import FiniteElementBase in global ufl namespace.

----------------------------------------------------------------------
For more details, visit http://www.fenics.org/hg/ufl

---

From: Anders Logg <[email-masked]>
Date: Fri, 19 Dec 2008 08:33:44 +0100

> will be a small task causing no problems in UFL.

I think this looks good.

-- 
Anders

> _______________________________________________
> UFL-dev mailing list
> [email-masked]
> http://fenics.org/mailman/listinfo/ufl-dev