Subject: [Meshbuilder-dev] [HG MeshBuilder] Updated README with new dependencies. Also updated pro file to use precompiled OpenSceneGraph by default.

From: [email-masked] (MeshBuilder)
Date: Mon, 15 Jun 2009 14:50:23 +0200 (CEST)

One or more new changesets pushed to the primary meshbuilder repository.
A short summary of the last three changesets is included below.

changeset:   27:193b711c47b5a2040860cb2b651b7cd8b4d17440
tag:         tip
user:        Yvon Halbwachs <[email-masked]>
date:        Wed Jun 10 17:34:24 2009 +0200
files:       README meshbuilder.pro
description:
Updated README with new dependencies. Also updated pro file to use precompiled OpenSceneGraph by default.

changeset:   26:65706e9675d29bfc16057abcc663f6b2665d02ac
user:        Yvon Halbwachs <[email-masked]>
date:        Wed Jun 10 17:25:09 2009 +0200
files:       gui/ApplicationWindowBase.ui scenegraph/CategoryNode.cpp scenegraph/CategoryNode.h scenegraph/DolfinObject.cpp scenegraph/DolfinObject.h scenegraph/GeometryNode.cpp scenegraph/GeometryNode.h scenegraph/TransformNode.cpp scenegraph/TransformNode.h
description:
Removed obsolete files.

changeset:   25:3cea8490ac0764e298f41361902be01bd671d947
user:        Yvon Halbwachs <[email-masked]>
date:        Wed Jun 10 17:18:26 2009 +0200
files:       scenegraph/OsgDolfinObject.cpp
description:
Computing surface normals manually, because something is still wrong. The orientation of each faces is probably not right.

----------------------------------------------------------------------
For more details, visit http://www.fenics.org/hg/meshbuilder

---

From: "Johannes Ring" <[email-masked]>
Date: Tue, 16 Jun 2009 09:14:25 +0200

Hi Yvon,

I tried to build Meshbuilder and it works very nicely with OSG 2.2. I did
get an error about a missing file (QtOpenGL/QGLWidget) but this was
resolved by installing the libqt4-opengl-dev package. This was on Ubuntu
8.04. I'm not sure if this package also is required on Ubuntu 8.10 and
9.04.

Do you consider yourself finished with your work on Meshbuilder for now?
If so, let me know and I will add Debian packages to the repository at
packages.simula.no.

Johannes

BTW, Meshbuilder looks very nice with Qt4.

On Mon, June 15, 2009 14:50, MeshBuilder wrote:
> files:       gui/ApplicationWindowBase.ui scenegraph/CategoryNode.cpp
> scenegraph/CategoryNode.h scenegraph/DolfinObject.cpp
> scenegraph/DolfinObject.h scenegraph/GeometryNode.cpp
> scenegraph/GeometryNode.h scenegraph/TransformNode.cpp
> scenegraph/TransformNode.h
> description:
> Removed obsolete files.
>
>
> Computing surface normals manually, because something is still wrong. The
> orientation of each faces is probably not right.
>
> _______________________________________________
> Meshbuilder-dev mailing list
> [email-masked]
> http://fenics.org/mailman/listinfo/meshbuilder-dev
>

---

From: "Johannes Ring" <[email-masked]>
Date: Tue, 16 Jun 2009 10:22:14 +0200

On Tue, June 16, 2009 09:56, Yvon Halbwachs wrote:
> Hi Johannes
>
> I'm not sure about the package dependencies on ubuntu, by I guess that
> libqt4-opengl-dev is also necessary on Ubuntu 8.10  and 9.04 (I only
> have 8.04 myself).

Yes, this is my guess too.

> Could you update the README file for me under
> meshbuilder (it lists all the library dependencies)? I can't commit
> directly myself.

Done.

> Otherwise I'm done with this first step on MeshBuilder. There are plenty
> of things that we could do next, it all depends on your needs. We could
> have a talk once if you like.

I guess this should be discussed with Ola.

Johannes

> Yvon
> Johannes Ring wrote:
> --
> -------------------------------------------------------
> Yvon Halbwachs Email : [email-masked]
>                Mobile: +47 95 94 14 42
>                WWW   : http://www.kalkulo.no
> -------------------------------------------------------
> Kalkulo AS - A subsidiary of Simula Research Laboratory
> -------------------------------------------------------
>
>