Subject: [Meshbuilder-dev] Old mesh

From: "Garth N. Wells" <[email-masked]>
Date: Mon, 22 Jun 2009 18:31:34 +0100

There has been a reversion to old DOLFIN mesh function names (e.g. 
numEntities(), which is now num_entities()) which breaks compilation.

Garth

---

From: Anders Logg <[email-masked]>
Date: Mon, 22 Jun 2009 20:00:20 +0200

> numEntities(), which is now num_entities()) which breaks compilation.

I tried to fix this but I can't check that it works. I added your
key so you can have a go.

I currently can't compile MeshBuilder. Somehow, qmake picks up the QT3
version of uic instead of the QT4 version:

# make all
...
uic: File generated with too recent version of Qt Designer (4.0 vs. 3.3.8b)

Any ideas?

-- 
Anders

---

From: "Garth N. Wells" <[email-masked]>
Date: Mon, 22 Jun 2009 19:01:45 +0100

> uic: File generated with too recent version of Qt Designer (4.0 vs. 3.3.8b)

I removed all the old qt3 packages and it then worked.

Garth

> 
> 
> ------------------------------------------------------------------------
> 
> _______________________________________________
> Meshbuilder-dev mailing list
> [email-masked]
> http://fenics.org/mailman/listinfo/meshbuilder-dev

---

From: Anders Logg <[email-masked]>
Date: Mon, 22 Jun 2009 20:11:19 +0200

> I removed all the old qt3 packages and it then worked.

That took care of that, but now I'm getting

In file included from /usr/include/osg/GraphicsThread:17,
                 from /usr/include/osg/GraphicsContext:18,
                 from /usr/include/osg/Texture:20,
                 from /usr/include/osg/Texture1D:19,
                 from ./util/FieldPalette.h:9,
                 from util/FieldPalette.cpp:6:
/usr/include/osg/OperationThread:23:29: error: OpenThreads/Block: No
such file or directory

-- 
Anders

---

From: Anders Logg <[email-masked]>
Date: Mon, 22 Jun 2009 21:06:09 +0200

> /usr/include/osg/OperationThread:23:29: error: OpenThreads/Block: No

Could you check 

  dpkg -S /usr/include/OpenThreads/Block

?

-- 
Anders

---

From: "Garth N. Wells" <[email-masked]>
Date: Mon, 22 Jun 2009 20:21:00 +0100

>   dpkg -S /usr/include/OpenThreads/Block

libopenthreads-dev: /usr/include/OpenThreads/Block

Do you have libopenscenegraph-dev installed?

Garth

---

From: Anders Logg <[email-masked]>
Date: Mon, 22 Jun 2009 21:25:26 +0200

On Mon, Jun 22, 2009 at 08:21:00PM +0100, Garth N. Wells wrote:
>>>>>> There has been a reversion to old DOLFIN mesh function names 
>>>>>> (e.g.  numEntities(), which is now num_entities()) which breaks 
>>>>>> compilation.

Yes, but for some reason it didn't trigger an installation of
libopenthreads-dev. Will try that. Thanks.

-- 
Anders

---

From: "Johannes Ring" <[email-masked]>
Date: Tue, 23 Jun 2009 08:51:52 +0200

> libopenthreads-dev. Will try that. Thanks.

Maybe you still have the old libopenthreads-dev package that I backported
to get Meshbuilder to compile? Try:

  dpkg --get-selections | grep hold

If some of the OpenSceneGraph packages shows up, run

  echo "<package_name> install" | sudo dpkg --set-selections

on all of the packages and then

  sudo apt-get upgrade

This should make sure that the latest versions will be installed.

BTW, the numEntities() -> num_entities() update breaks compilation with
DOLFIN 0.9.2 which is what the Debian packages are based on.

BTW2, if one has multiple installations of Qt on Ubuntu one can select
between them by setting the QTDIR variable before running qmake. For
instance QTDIR=/usr/share/qt4 will use Qt4.

Johannes