Subject: [Meshbuilder-dev] Order on sample data meshes

From: "Johannes Ring" <[email-masked]>
Date: Mon, 22 Jun 2009 12:59:32 +0200

Hi,

if I try to open one of the meshes in the sample_data folder, meshbuilder
aborts with the following error:

terminate called after throwing an instance of 'std::runtime_error'
  what():  *** Error: Mesh is not ordered according to the UFC numbering
convention, consider calling mesh.order().

Running dolfin-order on the meshes fixes this issue. Is this the proper
way to deal with this? If so, should the old meshes be moved to the
sample_data/old/ folder?

Johannes

---

From: Anders Logg <[email-masked]>
Date: Mon, 22 Jun 2009 13:46:42 +0200

> way to deal with this? If so, should the old meshes be moved to the

Does it help if you call dolfin-order on the meshes?

dolfin-order is installed by DOLFIN and could be used like

  dolfin-order *.xml

or

  dolfin-order *.xml.gz

-- 
Anders

---

From: "Johannes Ring" <[email-masked]>
Date: Mon, 22 Jun 2009 13:53:02 +0200

> dolfin-order is installed by DOLFIN and could be used like

Yes, thats what I did and then they work fine. Should I update the
repository with the new meshes? And should the old ones be added to
sample_data/old or should they be removed?

Johannes

> --
> Anders
> _______________________________________________
> Meshbuilder-dev mailing list
> [email-masked]
> http://fenics.org/mailman/listinfo/meshbuilder-dev
>

---

From: Anders Logg <[email-masked]>
Date: Mon, 22 Jun 2009 13:55:14 +0200

On Mon, Jun 22, 2009 at 01:53:02PM +0200, Johannes Ring wrote:
> Yes, thats what I did and then they work fine.

I see that now... :-/

> Should I update the

Just remove them.

-- 
Anders

---

From: "Johannes Ring" <[email-masked]>
Date: Mon, 22 Jun 2009 13:56:53 +0200

>> Yes, thats what I did and then they work fine.

:-)

>> sample_data/old or should they be removed?

OK.

Johannes