Subject: [Meshbuilder-dev] Build-system patch

From: "Johannes Ring" <[email-masked]>
Date: Mon, 22 Sep 2008 09:47:08 +0200 (CEST)

Hi,

Here is a patch that lets the Meshbuilder build-system pick up the paths
to DOLFIN using pkg-config.

Johannes

# HG changeset patch
# User Johannes Ring <[email-masked]>
# Date 1222069077 -7200
# Node ID 72f438ed9eb880bf20ddab2b3c5b2c39120b5a8e
# Parent  dbd43ba79fbf4e9288833dc8887cad5f21e2212d
Get DOLFIN paths using pkg-config.

diff -r dbd43ba79fbf -r 72f438ed9eb8 TODO
--- a/TODO	Tue Jun 03 13:21:43 2008 +0200
+++ b/TODO	Mon Sep 22 09:37:57 2008 +0200
@@ -1,3 +1,2 @@
-* Use pkg-config to get DOLFIN paths
 * Don't crash when importing new mesh
 * Fix orientation of facets on boundary mesh to get shading right
diff -r dbd43ba79fbf -r 72f438ed9eb8 meshbuilder.pro
--- a/meshbuilder.pro	Tue Jun 03 13:21:43 2008 +0200
+++ b/meshbuilder.pro	Mon Sep 22 09:37:57 2008 +0200
@@ -127,9 +127,8 @@
 #LIBS += $$system(pkg-config --libs libpng)
 
 # Dolfin
-#INCLUDEPATH += /usr/local/include/dolfin
-INCLUDEPATH += /home/kvs/dev/fenics/dolfin/local/include 
-LIBS += -L/home/kvs/dev/fenics/dolfin/local/lib -ldolfin
+QMAKE_CXXFLAGS += $$system(pkg-config --cflags dolfin)
+LIBS += $$system(pkg-config --libs dolfin)
 
 # FIXME: Find out why this is neccessary:
 QMAKE_CXXFLAGS += -Wno-deprecated

---

From: Anders Logg <[email-masked]>
Date: Mon, 22 Sep 2008 11:47:25 +0200

I've given you write permission to the repository so just go ahead and
push.

-- 
Anders

On Mon, Sep 22, 2008 at 09:47:08AM +0200, Johannes Ring wrote:
> _______________________________________________
> Meshbuilder-dev mailing list
> [email-masked]
> http://fenics.org/mailman/listinfo/meshbuilder-dev

---

From: "Johannes Ring" <[email-masked]>
Date: Mon, 22 Sep 2008 11:48:38 +0200 (CEST)

> I've given you write permission to the repository so just go ahead and

Ok, good.

Johannes