Subject: [Syfi-dev] [HG syfi] Implemented a sort of CSE in Python, not well tested yet.

From: [email-masked] (SyFi)
Date: Mon, 10 Sep 2007 11:54:24 +0200 (CEST)

One or more new changesets pushed to the primary SyFi repository.
A short summary of the last three changesets is included below.

changeset:   734:1b839c27a604ea52a27f3e4653312b8ceff1278f
tag:         tip
user:        "Martin Sandve Alnæs <[email-masked]>"
date:        Mon Sep 10 11:56:04 2007 +0200
files:       python/sfc/optimize/opt2.py
description:
Implemented a sort of CSE in Python, not well tested yet.

changeset:   733:92cda5611dfa503c8cddcb396f236e48b239b4d3
user:        "Martin Sandve Alnæs <[email-masked]>"
date:        Fri Sep 07 16:44:01 2007 +0200
files:       python/sfc/optimize/opt2.py
description:
Implemented eliminate_equal_expressions.

changeset:   732:5cc3309c444dc0fe0a29a7b73ff73dad9aee0cb0
user:        "Martin Sandve Alnæs <[email-masked]>"
date:        Fri Sep 07 16:10:17 2007 +0200
files:       python/sfc/optimize/opt2.py
description:
Finished implementation of extract_functions.

----------------------------------------------------------------------
For more details, visit http://www.fenics.org/hg/syfi

---

From: [email-masked]
Date: Mon, 10 Sep 2007 17:24:59 +0200 (CEST)

What is a CSE?

/Anders

> user:        "Martin Sandve AlnÃ¦s <[email-masked]>"
> user:        "Martin Sandve AlnÃ¦s <[email-masked]>"
> user:        "Martin Sandve AlnÃ¦s <[email-masked]>"
> _______________________________________________
> SyFi-dev mailing list
> [email-masked]
> http://fenics.org/mailman/listinfo/syfi-dev
>

---

From: "Martin Sandve Alnæs" <[email-masked]>
Date: Mon, 10 Sep 2007 19:52:41 +0200

Common Subexpression Elimination.

Basically, given:
b = x + y + z

it can find:
a = x + y
b = a + z

but it's not optimal.

-- 
Martin

---

From: Anders Logg <[email-masked]>
Date: Mon, 10 Sep 2007 22:14:13 +0200

> Common Subexpression Elimination.

ok!

/Anders

---

From: "Martin Sandve Alnæs" <[email-masked]>
Date: Tue, 11 Sep 2007 08:52:52 +0200

That was supposed to be:

a = x + y

-- 
Martin