Subject: [Syfi-dev] [HG syfi] Attempt at more complicated analytical solution u=(a*x*y*z, 0, 0),

From: [email-masked] (SyFi)
Date: Mon, 16 Mar 2009 21:39:25 +0100 (CET)

One or more new changesets pushed to the primary SyFi repository.
A short summary of the last three changesets is included below.

changeset:   394:f6dc8dade892a323f16f4d4eba32efb8d8e2a742
tag:         tip
user:        "Martin Sandve Alnæs <[email-masked]>"
date:        Mon Mar 16 21:40:44 2009 +0100
files:       examples/newsolvers/HyperElasticitySVK/cpp/HyperElasticity.ufl examples/newsolvers/HyperElasticitySVK/cpp/main.cpp examples/newsolvers/HyperElasticitySVK/cpp/manufactured_solution.py
description:
Attempt at more complicated analytical solution u=(a*x*y*z,0,0),
not working as well as u=(a*x,0,0).

changeset:   393:adc1668b317c196b07cbd890305794b9a70d88a4
user:        "Martin Sandve Alnæs <[email-masked]>"
date:        Mon Mar 16 15:49:01 2009 +0100
files:       examples/newsolvers/HyperElasticity3D/cpp/main.cpp examples/newsolvers/HyperElasticitySVK/cpp/main.cpp examples/newsolvers/Hyperelasticity1D/cpp/main.cpp examples/newsolvers/Poisson1D/cpp/main.cpp examples/newsolvers/Projection1D/cpp/main.cpp examples/newsolvers/elements/cpp/main.cpp examples/newsolvers/interpolatefail/cpp/main.cpp examples/newsolvers/poisson/cpp/main.cpp examples/newsolvers/projection/cpp/main.cpp examples/newsolvers/projection_mixed/cpp/main.cpp examples/newsolvers/projection_tensor/cpp/main.cpp examples/newsolvers/projection_vector/cpp/main.cpp
description:
Updated demos with new CoefficientSpace syntax from dolfin_utils.

changeset:   392:f8bc27220cb791e60bf6e48d8bb7d2c2ff671932
user:        "Martin Sandve Alnæs <[email-masked]>"
date:        Mon Mar 16 15:14:31 2009 +0100
files:       examples/newsolvers/HyperElasticity3D/cpp/main.cpp examples/newsolvers/HyperElasticitySVK/cpp/main.cpp examples/newsolvers/Hyperelasticity1D/cpp/main.cpp examples/newsolvers/Poisson1D/cpp/main.cpp examples/newsolvers/Projection1D/cpp/main.cpp examples/newsolvers/div_matrix/cpp/main.cpp examples/newsolvers/elasticity/cpp/main.cpp examples/newsolvers/elements/cpp/main.cpp examples/newsolvers/interpolatefail/cpp/main.cpp examples/newsolvers/poisson/cpp/main.cpp examples/newsolvers/projection/cpp/main.cpp examples/newsolvers/projection_mixed/cpp/main.cpp examples/newsolvers/projection_tensor/cpp/Makefile examples/newsolvers/projection_tensor/cpp/main.cpp examples/newsolvers/projection_vector/cpp/main.cpp
description:
Updated demos to latest dolfin_utils/wrappers/ code generation.
Updated SVK demo to use a simple u=[a*x,0,0] solution, which
works perfectly.

----------------------------------------------------------------------
For more details, visit http://www.fenics.org/hg/syfi

---

From: [email-masked]
Date: Mon, 16 Mar 2009 21:57:13 +0100 (CET)

Noe som ikke er sjekket inn ? Jeg får:

> One or more new cham -f *.pvd *.vtu
./demo
Mesh
Boundaries
Function spaces
Functions
Coefficient 0: 	dt
Coefficient 1: 	g
Coefficient 2: 	lamda
Coefficient 3: 	mu
Coefficient 4: 	rho
Coefficient 5: 	sigma_0
Coefficient 6: 	u
Coefficient 7: 	up
Coefficient 8: 	upp
Forms
Boundary conditions
Variational problem
Solving
Solving nonlinear variational problem
  Starting Newton solve.
terminate called after throwing an instance of 'std::runtime_error'
  what():  *** Error: Wrong type of function space for coefficient 5.
[kent-and-laptop:11333] *** Process received signal ***
[kent-and-laptop:11333] Signal: Aborted (6)
[kent-and-laptop:11333] Signal code:  (-6)
[kent-and-laptop:11333] [ 0] [0x4001a410]
[kent-and-laptop:11333] [ 1] /lib/tls/i686/cmov/libc.so.6(abort+0x188)
[0x41866268]
[kent-and-laptop:11333] [ 2]
/usr/lib/libstdc++.so.6(_ZN9__gnu_cxx27__verbose_terminate_handlerEv+0x158)
[0x417b8778]
[kent-and-laptop:11333] [ 3] /usr/lib/libstdc++.so.6 [0x417b6655]
[kent-and-laptop:11333] [ 4] /usr/lib/libstdc++.so.6 [0x417b6692]
[kent-and-laptop:11333] [ 5] /usr/lib/libstdc++.so.6 [0x417b67ca]
[kent-and-laptop:11333] [ 6]
/home/kent-and/local/src/dolfin-dev/local/lib/libdolfin.songesets pushed
to the primary SyFi repository.

..

Kent

> user:        "Martin Sandve Aln??s <[email-masked]>"
> files:
> examples/newsolvers/HyperElasticitySVK/cpp/HyperElasticity.ufl
> examples/newsolvers/HyperElasticitySVK/cpp/main.cpp
> examples/newsolvers/HyperElasticitySVK/cpp/manufactured_solution.py
> description:
> user:        "Martin Sandve Aln??s <[email-masked]>"
> files:       examples/newsolvers/HyperElasticity3D/cpp/main.cpp
> examples/newsolvers/HyperElasticitySVK/cpp/main.cpp
> examples/newsolvers/Hyperelasticity1D/cpp/main.cpp
> examples/newsolvers/Poisson1D/cpp/main.cpp
> examples/newsolvers/Projection1D/cpp/main.cpp
> examples/newsolvers/elements/cpp/main.cpp
> examples/newsolvers/interpolatefail/cpp/main.cpp
> examples/newsolvers/poisson/cpp/main.cpp
> examples/newsolvers/projection/cpp/main.cpp
> examples/newsolvers/projection_mixed/cpp/main.cpp
> examples/newsolvers/projection_tensor/cpp/main.cpp
> examples/newsolvers/projection_vector/cpp/main.cpp
> description:
> user:        "Martin Sandve Aln??s <[email-masked]>"
> files:       examples/newsolvers/HyperElasticity3D/cpp/main.cpp
> examples/newsolvers/HyperElasticitySVK/cpp/main.cpp
> examples/newsolvers/Hyperelasticity1D/cpp/main.cpp
> examples/newsolvers/Poisson1D/cpp/main.cpp
> examples/newsolvers/Projection1D/cpp/main.cpp
> examples/newsolvers/div_matrix/cpp/main.cpp
> examples/newsolvers/elasticity/cpp/main.cpp
> examples/newsolvers/elements/cpp/main.cpp
> examples/newsolvers/interpolatefail/cpp/main.cpp
> examples/newsolvers/poisson/cpp/main.cpp
> examples/newsolvers/projection/cpp/main.cpp
> examples/newsolvers/projection_mixed/cpp/main.cpp
> examples/newsolvers/projection_tensor/cpp/Makefile
> examples/newsolvers/projection_tensor/cpp/main.cpp
> examples/newsolvers/projection_vector/cpp/main.cpp
> description:
> _______________________________________________
> SyFi-dev mailing list
> [email-masked]
> http://fenics.org/mailman/listinfo/syfi-dev
>

---

From: Martin Sandve Alnæs <[email-masked]>
Date: Mon, 16 Mar 2009 23:30:27 +0100

Dolfin.

Martin