Subject: [Syfi-dev] [HG syfi] Update sensitivity computation. Looks cool, but I

From: [email-masked] (SyFi)
Date: Tue, 21 Apr 2009 20:16:21 +0200 (CEST)

One or more new changesets pushed to the primary SyFi repository.
A short summary of the last three changesets is included below.

changeset:   502:c395906eac920f2dfc3cf42ee4f1e188b724bfae
tag:         tip
user:        "Martin Sandve Alnæs <[email-masked]>"
date:        Tue Apr 21 20:18:20 2009 +0200
files:       demo/Advection-Diffusion/python/demo.py
description:
Update sensitivity computation. Looks cool, but I
haven't really considered if it means anything sensible :)

changeset:   501:0ca46745f8b0e59cdb794df878bf56857a674a0f
user:        [email-masked]
date:        Tue Apr 21 17:10:24 2009 +0200
files:       demo/Advection-Diffusion/python/demo.py
description:
Added computation of sensitivity to demo for testing.

changeset:   500:a03626644b5807a4bc757c8e4ed9c16b8eaff322
user:        "Martin Sandve Alnæs <[email-masked]>"
date:        Mon Apr 20 11:26:04 2009 +0200
files:       scripts/sfc site-packages/sfc/common/options.py site-packages/sfc/representation/integralrepresentation.py
description:
Added option to trigger use of new expand_indices2 instead of old.
However, it still has some siginficant bugs, so we don't use it by default.

----------------------------------------------------------------------
For more details, visit http://www.fenics.org/hg/syfi

---

From: [email-masked]
Date: Tue, 21 Apr 2009 21:45:29 +0200 (CEST)

Are you differentiating L  with respect to c and solving the
corresponding problem ?

Kent

> user:        "Martin Sandve Aln??s <[email-masked]>"
> user:        "Martin Sandve Aln??s <[email-masked]>"
> files:       scripts/sfc site-packages/sfc/common/options.py
> site-packages/sfc/representation/integralrepresentation.py
> description:
> _______________________________________________
> SyFi-dev mailing list
> [email-masked]
> http://fenics.org/mailman/listinfo/syfi-dev
>

---

From: Martin Sandve Alnæs <[email-masked]>
Date: Tue, 21 Apr 2009 22:46:04 +0200

Technically, that is what happens in this case since a is independent of c.
See the docstring of sensitivity_rhs for the details.

Martin