Subject: [Syfi-dev] [HG syfi] Added 1D projection demo, seems to be some 1D issues.

From: [email-masked] (SyFi)
Date: Tue, 10 Mar 2009 08:42:02 +0100 (CET)

One or more new changesets pushed to the primary SyFi repository.
A short summary of the last three changesets is included below.

changeset:   350:c6ea76d1118e208c841a2e2b31418a26767d524f
tag:         tip
user:        "Martin Sandve Alnæs <[email-masked]>"
date:        Tue Mar 10 08:43:12 2009 +0100
files:       examples/newsolvers/Hyperelasticity1D/cpp/Makefile examples/newsolvers/Hyperelasticity1D/cpp/main.cpp examples/newsolvers/Projection1D/cpp/Makefile examples/newsolvers/Projection1D/cpp/Projection.ufl examples/newsolvers/Projection1D/cpp/SConstruct examples/newsolvers/Projection1D/cpp/main.cpp examples/newsolvers/projection/cpp/Projection.ufl examples/newsolvers/projection/cpp/main.cpp site-packages/newsfc/codegeneration/cellintegralcg.py
description:
Added 1D projection demo, seems to be some 1D issues.

changeset:   349:b9b2793e6974ca95c7a8f07b2eb204dfbda9f31b
user:        "Martin Sandve Alnæs <[email-masked]>"
date:        Mon Mar 09 23:35:30 2009 +0100
files:       examples/newsolvers/Hyperelasticity1D/cpp/Hyperelasticity1D.ufl examples/newsolvers/Hyperelasticity1D/cpp/Makefile examples/newsolvers/Hyperelasticity1D/cpp/main.cpp examples/newsolvers/Hyperelasticity1D/cpp/manufactured_solution.py site-packages/newsfc/codegeneration/integralcg.py
description:
Updated Hyperelasticity1D demo.
Manufactured solution computed with a swiginac script.
Some parameters give a solution close to the analytical, some don't.
Need a simpler equation to validate both the compiler and the main.cpp file
(I have too many bad experiences to trust dolfin in its current version).

Some formatting fixes, using braces around some blocks
which will enable convenient folding in many editors,
as well as separate scopes (which makes this a good
precursor to extracting blocks as functions).

changeset:   348:2031cc4d0c72333bdb0c6617e023eb2bee4115cb
user:        "Martin Sandve Alnæs <[email-masked]>"
date:        Mon Mar 09 18:14:05 2009 +0100
files:       site-packages/newsfc/codegeneration/integralcg.py
description:
Formatting fixes in generated tabulate_tensor code.

----------------------------------------------------------------------
For more details, visit http://www.fenics.org/hg/syfi

---

From: Kent Andre <[email-masked]>
Date: Tue, 10 Mar 2009 09:54:15 +0100

As you refine the mesh the solution goes to the true solution. 
The condition number of the matrix seem to be correct. 
Furthermore, if f is interpolated into the same space as the
solution you get an exact match. 

-> I think this is a P2-P1 interpolation issue. Not a bug. 

Kent

On ti., 2009-03-10 at 08:42 +0100, SyFi wrote:
> _______________________________________________
> SyFi-dev mailing list
> [email-masked]
> http://fenics.org/mailman/listinfo/syfi-dev

---

From: Martin Sandve Alnæs <[email-masked]>
Date: Tue, 10 Mar 2009 10:29:06 +0100

I thought as much on the bus, now I don't have to test it myself :)
Next step is 1D Poisson to verify derivatives and mapping in 1D then.

Martin