Subject: [Syfi-dev] Building tests fails on 64-bit platform

From: Ilmar Wilbers <[email-masked]>
Date: Fri, 04 Apr 2008 15:05:17 +0200

Hi,

Building the syfi tests for a 64-bit platform fails, any idea if this is 
due to syfi or just me setting up the environment file?

For the log, see:
http://fenics.org:8010/syfi/linux_64/builds/16/step-compile_3/0

ilmar

---

From: "Martin Sandve Alnæs" <[email-masked]>
Date: Fri, 4 Apr 2008 15:39:01 +0200

Looks like it doesn't find ginac, are you sure that's properly installed?

-- 
Martin

2008/4/4, Ilmar Wilbers <[email-masked]>:
>  _______________________________________________
>  SyFi-dev mailing list
>  [email-masked]
>  http://fenics.org/mailman/listinfo/syfi-dev
>

---

From: Ilmar Wilbers <[email-masked]>
Date: Fri, 04 Apr 2008 15:51:34 +0200

I dont' know. It is on potassium, I didn't install it, and am not very 
familiar with it.

ilmar

---

From: "Martin Sandve Alnæs" <[email-masked]>
Date: Fri, 4 Apr 2008 15:53:07 +0200

Prøv pkg-config da (men ./configure i syfi burde jo plukket opp en sånn feil):

martinal@martinal-laptop:~$ pkg-config --cflags ginac
-I/opt/ginac-1.4.1/include
martinal@martinal-laptop:~$ pkg-config --libs ginac
-L/opt/ginac-1.4.1/lib -lginac -lcln -lgmp

-- 
Martin

---

From: Ilmar Wilbers <[email-masked]>
Date: Fri, 04 Apr 2008 16:24:35 +0200

configure DID pick it up:

checking for GiNaC - version >= 1.3.7... no
*** Could not run GiNaC test program, checking why...
-lginac -lcln -lgmp
-g -O2
*** The test program failed to compile or link. See the file config.log 
for the
*** exact error that occured. This usually means GiNaC was incorrectly 
installed
*** or that you have moved GiNaC since it was installed. In the latter 
case, you
*** may want to edit the ginac-config script: /usr/bin/pkg-config.

Will check the ginac stuff.

ilmar

---

From: Ilmar Wilbers <[email-masked]>
Date: Fri, 04 Apr 2008 17:36:11 +0200

Fixed... Newer GiNaC version.

ilmar