Subject: [Syfi-dev] buildbot failure in FEniCS Buildbot on syfi-hardy-amd64

From: [email-masked]
Date: Mon, 02 Mar 2009 18:33:25 +0100

The Buildbot has detected a new failure of syfi-hardy-amd64 on FEniCS Buildbot.
Full details are available at:
 http://fenics.org:8080/builders/syfi-hardy-amd64/builds/35

Buildbot URL: http://fenics.org:8080/

Buildslave for this Build: hardy-amd64

Build Reason: 
Build Source Stamp: HEAD
Blamelist: martinal

BUILD FAILED: failed syfi build

sincerely,
 -The Buildbot

---

From: "Johannes Ring" <[email-masked]>
Date: Tue, 3 Mar 2009 10:36:07 +0100 (CET)

Hi,

The below patch should get the buildbot back on track again after the cpp
tests was moved. Should I just go ahead and apply it?

Johannes

diff -r 680115de7ab7 syfi/SConscript
--- a/syfi/SConscript	Mon Mar 02 18:31:13 2009 +0100
+++ b/syfi/SConscript	Tue Mar 03 10:31:19 2009 +0100
@@ -254,7 +254,7 @@
 # read the SConscript for tests if enabled
 ret["tests"] = []
 if env["enableTests"]:
-    ret["tests"] += env.SConscript(pjoin("#tests", "SConscript"),
+    ret["tests"] += env.SConscript(pjoin("#tests", "cpp", "SConscript"),
                                    exports=["env", "modules",
"configuredPackages"])

 # generate a builder for the syfi pkg-config file.
diff -r 680115de7ab7 tests/cpp/SConscript
--- a/tests/cpp/SConscript	Mon Mar 02 18:31:13 2009 +0100
+++ b/tests/cpp/SConscript	Tue Mar 03 10:31:19 2009 +0100
@@ -10,7 +10,8 @@
   libs, libPath, linkOpts, cppPath, frameworks = [], [], [], [], []

   ## this is needed to find SyFi.h
-  cppPath = ["..", os.path.abspath(os.path.join("..", modName.lower()))]
+  cppPath = [os.path.join("..", ".."),
+             os.path.abspath(os.path.join("..", "..", modName.lower()))]
   for d in mod.dependencies:
     if d in modules:
       # Internal dependency

On Mon, March 2, 2009 18:33, [email-masked] wrote:
> _______________________________________________
> SyFi-dev mailing list
> [email-masked]
> http://fenics.org/mailman/listinfo/syfi-dev
>

---

From: Martin Sandve Alnæs <[email-masked]>
Date: Tue, 3 Mar 2009 10:51:57 +0100

Please do.

Martin