Subject: [Syfi-dev] [HG syfi] Added spatial derivative of spatial coordinates (dx_i / dx_j = delta_ij).

From: [email-masked] (SyFi)
Date: Mon, 22 Dec 2008 11:55:05 +0100 (CET)

One or more new changesets pushed to the primary SyFi repository.
A short summary of the last three changesets is included below.

changeset:   285:c6be10fde009dc506b6d1585525f97c58cea2d59
tag:         tip
user:        "Martin Sandve Alnæs <[email-masked]>"
date:        Mon Dec 22 11:55:20 2008 +0100
files:       examples/newsolvers/div_matrix/cpp/main.cpp examples/newsolvers/poisson/cpp/main.cpp site-packages/newsfc/representation/swiginac_eval.py
description:
Added spatial derivative of spatial coordinates (dx_i / dx_j = delta_ij).
Fix in div_matrix, compiles and prints matrix.

changeset:   284:faebd85449c55326cd31e32b0b5d7697d2b03d4f
user:        "Martin Sandve Alnæs <[email-masked]>"
date:        Mon Dec 22 10:33:46 2008 +0100
files:       site-packages/newsfc/representation/elementrepresentation.py
description:
Bugfix after domain to cell changes.

changeset:   283:dd28a7bdcc7af6be39d8a987b285a956e2228704
user:        "Martin Sandve Alnæs <[email-masked]>"
date:        Mon Dec 22 10:27:54 2008 +0100
files:       site-packages/newsfc/codegeneration/names.py
description:
Remove duplicate file!

----------------------------------------------------------------------
For more details, visit http://www.fenics.org/hg/syfi

---

From: Kent Andre <[email-masked]>
Date: Mon, 22 Dec 2008 12:05:39 +0100

This demo does not work for quadrature ? 

Kent

On ma., 2008-12-22 at 11:55 +0100, SyFi wrote:
> _______________________________________________
> SyFi-dev mailing list
> [email-masked]
> http://fenics.org/mailman/listinfo/syfi-dev

---

From: "Martin Sandve Alnæs" <[email-masked]>
Date: Mon, 22 Dec 2008 12:11:43 +0100

That's right. Div is converted to u[i].dx(i), which means
SpatialDerivative is applied to an Indexed, and derivatives are
currently only implemented for BasisFunction and Function. The AD code
needs some work, and then it will be used to "propagate" derivatives
to terminal nodes.

I think u.dx(i)[i] should work.

Martin