Subject: [UFC-dev] [HG ufc] Fix name of code block for create_sub_element

From: [email-masked] (UFC)
Date: Thu, 11 Jan 2007 21:20:51 +0100 (CET)

One or more new changesets pushed to the primary UFC repository.
A short summary of the last three changesets is included below.

changeset:   73:c877c4b39853354ed44f44ec5af6c8faa87b6fde
tag:         tip
user:        "Anders Logg <[email-masked]>"
date:        Thu Jan 11 18:32:50 2007 +0100
files:       src/utils/python/ufc/finite_element.py
description:
Fix name of code block for create_sub_element

changeset:   72:1b3422dbc5acc46e120608e69820988fe05158b0
user:        "Anders Logg <[email-masked]>"
date:        Thu Jan 11 18:32:02 2007 +0100
files:       src/ufc/ufc.h src/utils/python/ufc/finite_element.py
description:
Make sub_element() a factory function and change name to create_sub_element()

changeset:   71:f8d1c971667d7e01092b867e505327693d726b08
user:        "Anders Logg <[email-masked]>"
date:        Thu Jan 11 17:20:55 2007 +0100
files:       src/ufc/ufc.h src/utils/python/ufc/finite_element.py
description:
Fix bug in specification on num_sub_elements(), argument removed.

----------------------------------------------------------------------
For more details, visit http://www.fenics.org/hg/ufc

---

From: "Martin Sandve Alnæs" <[email-masked]>
Date: Fri, 12 Jan 2007 10:51:49 +0100

> Make sub_element() a factory function and change name to create_sub_element()

Is this really necessary?

martin

---

From: Anders Logg <[email-masked]>
Date: Fri, 12 Jan 2007 11:25:44 +0100

> Is this really necessary?

Yes, to make it consistent with the other factory functions.

It is also more convenient, since otherwise one needs to allocate an
array of sub elements in the constructor and add a data member for the
array.

If there is just one sub element (the element itself) and this element
is named my_finite_element, then the body can just be

    return new my_finite_element();

/Anders