Subject: [UFC-dev] [HG ufc] Results of a fika-discussion:

From: [email-masked] (UFC)
Date: Thu, 4 Jan 2007 15:33:11 +0100 (CET)

One or more new changesets pushed to the primary UFC repository.
A short summary of the last three changesets is included below.

changeset:   46:39c19b151b83f71d08cb0d4ab636fb8354a1cf8b
tag:         tip
user:        "Martin Sandve Alnæs <[email-masked]>"
date:        Thu Jan 04 15:33:08 2007 +0100
files:       src/ufc/ufc.h
description:
Results of a fika-discussion:
Changed value_rank() and value_dimension(i) to just value_dimension() in function.
Now function has only two members: evaluate and value_dimension().
Added cell_shape, topological_dimension and geometric_dimension to cell.
This makes the cell complete and increases its value in a non-generated
code context without any significant cost.

changeset:   45:9b9322e04680357874a1602308fca38b2333614d
user:        "Martin Sandve Alnæs <[email-masked]>"
date:        Thu Jan 04 14:02:03 2007 +0100
files:       src/ufc/ufc.h
description:
Removed domain_* and range_* from function and added value_rank(), value_dimension(i).

changeset:   44:333620bd93127e91dda670a629a5ffca7ac4ac99
user:        "Martin Sandve Alnæs <[email-masked]>"
date:        Thu Jan 04 13:44:11 2007 +0100
files:       src/ufc/ufc.h
description:
Fixed inconsistent order of (mesh,cell) / (cell, mesh) arguments. Now the order is "mesh, cell" in all functions.

----------------------------------------------------------------------
For more details, visit http://www.fenics.org/hg/ufc

---

From: Anders Logg <[email-masked]>
Date: Thu, 4 Jan 2007 16:13:23 +0100

Do we really need this? The ufc::function interface is just a wrapper
for a simple callback (evaluate).

The assembler will always have a corresponding ufc::finite_element to
each ufc::function so the dimension is known.

If we need it, then we need both value_rank() and value_dimension().

/Anders

> _______________________________________________
> UFC-dev mailing list
> [email-masked]
> http://fenics.org/mailman/listinfo/ufc-dev

---

From: "Martin Sandve Alnæs" <[email-masked]>
Date: Thu, 4 Jan 2007 16:51:13 +0100

I was about to write yes, because (...) but then I can't remember what
(...) should be. If we need it, it wouldn't be in the assembly (except
for error checking perhaps), and for application-specific purposes I
can make a subclass with this if it's needed. So I've removed it. The
important thing was the extra cell info.

martin

---

From: Anders Logg <[email-masked]>
Date: Thu, 4 Jan 2007 19:13:26 +0100

ok!

/Anders