Subject: [UFC-dev] SCons for installation of ufc?

From: Johan Hake <[email-masked]>
Date: Mon, 26 Jan 2009 09:49:52 +0100

Hello!

As someone may have noticed ufc is now dependent on swig. You wil get an error 
if you do not have swig installed when you install ufc. This is probably not 
what we want.

The problem now is that ufc use distutils as installation tool, and has 
limited support for option handling. So me and Ola thought it might be a good 
idea to shift from distutils to SCons. 

In a first itteration it is enough to shift to plain SCons, not simula-scons.

What you say?

Johan

---

From: Martin Sandve Alnæs <[email-masked]>
Date: Mon, 26 Jan 2009 11:00:11 +0100

I have no problem with that.

Martin

On Mon, Jan 26, 2009 at 9:49 AM, Johan Hake <[email-masked]> wrote:
> _______________________________________________
> UFC-dev mailing list
> [email-masked]
> http://fenics.org/mailman/listinfo/ufc-dev
>

---

From: Anders Logg <[email-masked]>
Date: Mon, 26 Jan 2009 11:04:09 +0100

Sounds good.

-- 
Anders