Subject: [UFC-dev] sub elements

From: "Martin Sandve Alnæs" <[email-masked]>
Date: Mon, 19 Mar 2007 19:34:41 +0100

We need sub_dofmaps the same way we have sub_elements.
F.ex.
  my_dof_map->sub_dof_map(0)->tabulate_facet_dofs(...)
to get the boundary dofs for the x-component of a vector element.

martin

---

From: Anders Logg <[email-masked]>
Date: Tue, 20 Mar 2007 15:00:14 +0100

> to get the boundary dofs for the x-component of a vector element.

Yes, but don't you mean

    ufc::dof_map* sub_dof_map = my_dof_map->create_sub_dof_map(0);
    sub_dof_map->tabulate_facet_dofs(...);

?

/Anders

---

From: "Martin Sandve Alnæs" <[email-masked]>
Date: Tue, 20 Mar 2007 16:51:49 +0100

>     sub_dof_map->tabulate_facet_dofs(...);

Of course.

martin