Subject: [UFC-dev] additional functions in finite_element etc.

From: [email-masked]
Date: Wed, 14 Feb 2007 22:00:29 +0100 (CET)

I need some extra functions in finite_element etc for computing the sign
of the global function. I do not think this necessarily should be in
ufc, it can be something the code generators add to certain elements.

Are there any hooks for adding stuff in the Python templates ? Should
there be ?

---

From: "Martin Sandve Alnæs" <[email-masked]>
Date: Wed, 14 Feb 2007 23:41:57 +0100

Just set { 'members': yourcode } like in:

"""
class %(classname)s: public ufc::finite_element
{%(members)s
public:
"""

martin

On 2/14/07, [email-masked] <[email-masked]> wrote:
> _______________________________________________
> UFC-dev mailing list
> [email-masked]
> http://fenics.org/mailman/listinfo/ufc-dev
>