Subject: [UFC-dev] Symmetric forms

From: "Garth N. Wells" <[email-masked]>
Date: Wed, 20 Aug 2008 13:55:31 +0100

Could FFC be made clever enough to determine whether or not a bilinear 
form is self-adjoint? UFC could then have a function

   bool form::symmetric()

  which says whether or not a rank 2 tensor is symmetric.

Garth

---

From: Anders Logg <[email-masked]>
Date: Wed, 20 Aug 2008 15:49:06 +0200

>   which says whether or not a rank 2 tensor is symmetric.

I don't think that's very difficult to implement, but we should put it
in UFL (not FFC). Could you add a comment about it on the UFL wiki
page so we don't forget it?

-- 
Anders