Subject: [UFC-dev] [HG UFC] Update ChangeLog

From: [email-masked] (UFC)
Date: Fri, 27 Feb 2009 22:45:55 +0100 (CET)

One or more new changesets pushed to the primary ufc repository.
A short summary of the last three changesets is included below.

changeset:   258:0801bde05f173dca662f90df8649862152c51e83
tag:         tip
user:        Anders Logg <[email-masked]>
date:        Fri Feb 27 22:46:06 2009 +0100
files:       ChangeLog
description:
Update ChangeLog

changeset:   257:5690e6b40ddd71a7b412a794fd97a23a6af79dd5
user:        "Kristian Oelgaard <[email-masked]>"
date:        Fri Feb 27 18:51:11 2009 +0100
files:       src/utils/python/ufc/integrals.py
description:
Added a private section to format strings in integrals. Needed in order to handle different representations on the same subdomain.

changeset:   256:ecebfc239275a5d110be711c4d2529bc901684d2
user:        Anders Logg <[email-masked]>
date:        Wed Feb 25 22:52:54 2009 +0100
files:       TODO
description:
Add recent suggestions for UFC extensions from Garth to TODO list

----------------------------------------------------------------------
For more details, visit http://www.fenics.org/hg/ufc

---

From: Martin Sandve Alnæs <[email-masked]>
Date: Sat, 28 Feb 2009 02:26:47 +0100

> Added a private section to format strings in integrals. Needed in order to handle different representations on the same subdomain.

Not true. %(members)s has been there forever, and has been used by sfc
(me) for about the same amount of time.

Martin

---

From: Anders Logg <[email-masked]>
Date: Sat, 28 Feb 2009 08:28:20 +0100

> (me) for about the same amount of time.

Yes, and FFC has also used it for a quite some time. Don't know why we
forgot about this.

We'll revert back to how it was before.

-- 
Anders

---

From: Kristian Oelgaard <[email-masked]>
Date: Sat, 28 Feb 2009 13:19:14 +0100

Quoting Anders Logg <[email-masked]>:

> > > Added a private section to format strings in integrals. Needed in order
> to handle different representations on the same subdomain.
> > 

Just go ahead and revert UFC, it shouldn't break anything.

Kristian

---

From: Anders Logg <[email-masked]>
Date: Sat, 28 Feb 2009 21:40:01 +0100

> Just go ahead and revert UFC, it shouldn't break anything.

Done.

-- 
Anders

---

From: Kristian Oelgaard <[email-masked]>
Date: Mon, 02 Mar 2009 10:01:12 +0100

> > Just go ahead and revert UFC, it shouldn't break anything.

OK, it did actually break something.

%(members)s is missing in the three implementation format strings.

Could someone please add it?

Kristian

---

From: Martin Sandve Alnæs <[email-masked]>
Date: Mon, 2 Mar 2009 10:08:34 +0100

Which strings? It seems to be everywhere:

martinal@martinal-znote:~/dev/fenics/ufc/src/utils/python/ufc$ egrep members *
dof_map.py:{%(members)s
dof_map.py:{%(members)s
finite_element.py:{%(members)s
finite_element.py:{%(members)s
form.py:{%(members)s
form.py:{%(members)s
function.py:{%(members)s
function.py:{%(members)s
__init__.py:'members', 'constructor', 'destructor', plus one for each interface
integrals.py:{%(members)s
integrals.py:{%(members)s
integrals.py:{%(members)s
integrals.py:{%(members)s
integrals.py:{%(members)s
integrals.py:{%(members)s

The implementation strings don't need members,
you can just add the code. But it's no problem to
add if you still want it?

Martin

On Mon, Mar 2, 2009 at 10:01 AM, Kristian Oelgaard
<[email-masked]> wrote:
> _______________________________________________
> UFC-dev mailing list
> [email-masked]
> http://fenics.org/mailman/listinfo/ufc-dev
>

---

From: Kristian Oelgaard <[email-masked]>
Date: Mon, 02 Mar 2009 10:22:39 +0100

> add if you still want it?

True, I just find it easier to handle all cases the same way.
On second thought, let's not add it. Otherwise other compilers will have to
provide the members key when formatting code.

Kristian

---

From: Martin Sandve Alnæs <[email-masked]>
Date: Mon, 2 Mar 2009 10:50:55 +0100

> provide the members key when formatting code.

Ok. Also, "members" wouldn't be the right name for this.
Adding "declarations" or something would be fine.

Martin