Subject: [UFC-dev] [HG UFC] Update SConscript to automatically pick up the right version from the ufc.h

From: [email-masked] (UFC)
Date: Mon, 28 Sep 2009 11:57:46 +0200 (CEST)

One or more new changesets pushed to the primary ufc repository.
A short summary of the last three changesets is included below.

changeset:   285:e34c7d5ad69b
tag:         tip
user:        "Johan Hake <[email-masked]>"
date:        Mon Sep 28 11:57:42 2009 +0200
files:       SConstruct src/utils/misc/makedist
description:
Update SConscript to automatically pick up the right version from the ufc.h
and write this to the pkg-config file.

changeset:   284:42acdbe6ee2a
user:        Anders Logg <[email-masked]>
date:        Wed Sep 23 20:37:04 2009 +0200
files:       src/ufc/ufc.h src/utils/python/ufc/__init__.py src/utils/python/ufc/dof_map.py src/utils/python/ufc/finite_element.py src/utils/python/ufc/form.py src/utils/python/ufc/function.py src/utils/python/ufc/integrals.py src/utils/python/ufc_benchmark/ufc_benchmark.cpp src/utils/python/ufc_benchmark/ufc_benchmark.h src/utils/python/ufc_benchmark/ufc_data.h src/utils/python/ufc_benchmark/ufc_reference_cell.h
description:
Updates for version 1.2.

changeset:   283:9f309e364e82
user:        Anders Logg <[email-masked]>
date:        Wed Sep 23 20:36:58 2009 +0200
files:       .hgtags
description:
Added tag 1.2.0 for changeset 32b09e9501e6

----------------------------------------------------------------------
For more details, visit http://www.fenics.org/hg/ufc

---

From: Johan Hake <[email-masked]>
Date: Mon, 28 Sep 2009 12:00:46 +0200

> and write this to the pkg-config file.

The change in version number was not picked up in the generated pkgconfig 
file, in the original release. 

We need to include this commit in any tar ball or package for ufc 1.2.0.

Johan
 
> files:       src/ufc/ufc.h src/utils/python/ufc/__init__.py
>  src/utils/python/ufc/dof_map.py src/utils/python/ufc/finite_element.py
>  src/utils/python/ufc/form.py src/utils/python/ufc/function.py
>  src/utils/python/ufc/integrals.py
>  src/utils/python/ufc_benchmark/ufc_benchmark.cpp
>  src/utils/python/ufc_benchmark/ufc_benchmark.h
>  src/utils/python/ufc_benchmark/ufc_data.h
>  src/utils/python/ufc_benchmark/ufc_reference_cell.h description:
> Updates for version 1.2.
> 
> 
> _______________________________________________
> UFC-dev mailing list
> [email-masked]
> http://fenics.org/mailman/listinfo/ufc-dev
>

---

From: Anders Logg <[email-masked]>
Date: Mon, 28 Sep 2009 23:43:44 +0200

> We need to include this commit in any tar ball or package for ufc 1.2.0.

Do we need a bugfix release (1.2.1)?

--
Anders

---

From: Johan Hake <[email-masked]>
Date: Tue, 29 Sep 2009 07:48:44 +0200

On Monday 28 September 2009 23:43:44 Anders Logg wrote:
> > > Update SConscript to automatically pick up the right version from the
> > > ufc.h and write this to the pkg-config file.
> >

Yes this might be the solution.

The present release works fine with the last releases including DOLFIN 0.9.3. 
However in the development version we have now started to require a certain 
version of ufc. There we need 1.2.0 but the pkgconfig file for that release 
says 1.1.2 (or something).

Johan

---

From: Anders Logg <[email-masked]>
Date: Tue, 29 Sep 2009 08:40:32 +0200

> says 1.1.2 (or something).

That sounds like we don't need to make a release of UFC now, but
we need to make a new release at the same time as DOLFIN 0.9.4 (which
should not be that far away).

--
Anders

---

From: Johan Hake <[email-masked]>
Date: Tue, 29 Sep 2009 08:48:42 +0200

On Tuesday 29 September 2009 08:40:32 Anders Logg wrote:
> > > > > Update SConscript to automatically pick up the right version from
> > > > > the ufc.h and write this to the pkg-config file.
> > > >
> > > > The change in version number was not picked up in the generated
> > > > pkgconfig file, in the original release.
> > > >
> > The present release works fine with the last releases including DOLFIN
> > 0.9.3. However in the development version we have now started to require
> > a certain version of ufc. There we need 1.2.0 but the pkgconfig file for
> > that release says 1.1.2 (or something).
> 

Sure, it is just strange that development version of DOLFIN requires ufc 
1.2.0, which is the released version of ufc. If a user has this ufc version 
installed he will get an version error. 

Johan

---

From: Anders Logg <[email-masked]>
Date: Tue, 29 Sep 2009 13:36:44 +0200

> installed he will get an version error.

But that's normal. When running the development version of DOLFIN, you
can expect to get all sorts of errors if you don't have the latest
versions of all other packages (like FFC and Instant). This just
happens to be another kind of error (in the configuration and not the
compilation).

--
Anders