Subject: [UFC-dev] Bug in build system

From: Martin Sandve Alnæs <[email-masked]>
Date: Mon, 23 Mar 2009 11:14:06 +0100

scons install doesn't reinstall ufc_utils when files are changed,
I had to remove the installed ufc_utils folder and reinstall.

Martin

---

From: "Johannes Ring" <[email-masked]>
Date: Mon, 23 Mar 2009 11:37:17 +0100 (CET)

> I had to remove the installed ufc_utils folder and reinstall.

I can't reproduce this bug. It works perfectly fine here.

Johannes

johannr@simula-x61:ufc$ scons install
scons: Reading SConscript files ...
Using options from options.cache
Checking for SWIG...(cached) yes
Checking for SWIG version > 1.3.35...(cached) yes
Checking for Boost...(cached) yes
Checking for Python...(cached) yes
scons: done reading SConscript files.
scons: Building targets ...
swig -o src/ufc/ufc_wrap.cc -python -c++ -shadow src/ufc/ufc.i
scons: `install' is up to date.
scons: done building targets.

johannr@simula-x61:ufc$ echo "import os" >> src/utils/python/ufc/__init__.py
johannr@simula-x61:ufc$ scons install
scons: Reading SConscript files ...
Using options from options.cache
Checking for SWIG...(cached) yes
Checking for SWIG version > 1.3.35...(cached) yes
Checking for Boost...(cached) yes
Checking for Python...(cached) yes
scons: done reading SConscript files.
scons: Building targets ...
swig -o src/ufc/ufc_wrap.cc -python -c++ -shadow src/ufc/ufc.i
Install file: "src/utils/python/ufc/__init__.py" as
"local/lib/python2.5/site-packages/ufc_utils/__init__.py"
scons: done building targets.

---

From: Johan Hake <[email-masked]>
Date: Mon, 23 Mar 2009 11:37:28 +0100

> I had to remove the installed ufc_utils folder and reinstall.

I have never had this problem.

Does it happens evertime you change something?

Johan

---

From: Martin Sandve Alnæs <[email-masked]>
Date: Mon, 23 Mar 2009 11:42:56 +0100

It seems to work now, strange.

Martin