Subject: [UFL-dev] Precedence of integration rules

From: Martin Sandve Alnæs <[email-masked]>
Date: Fri, 6 Mar 2009 14:16:06 +0100

Hi,
say that we have a form with some defined options and some undefined:

  a = withopt*dx(0, myoptions) + noopt*dx(0)

A natural interpretation of this is that the form compiler
uses its default options on noopt, and overrides its defaults
with myoptions for withopt.

Now what if the form compiler gets nondefault global options?

  form = jit(a, someoptions)

Naturally, someoptions will overrule default options.
But should myoptions still overrule someoptions?
I'm leaning towards this, but I want your opinion.

In other words, is the precedence order
  myoptions > someoptions > defaultoptions
or
  someoptions > myoptions > defaultoptions
?

Martin

---

From: Anders Logg <[email-masked]>
Date: Fri, 6 Mar 2009 14:29:22 +0100

> with myoptions for withopt.

What does withopt mean for the integrand? Is it possible to attach
metadata also to integrands (not only measures)?

>   someoptions > myoptions > defaultoptions

I think:

Motivation: myoptions allows more fine-grained control over
someoptions

-- 
Anders

---

From: Martin Sandve Alnæs <[email-masked]>
Date: Fri, 6 Mar 2009 14:49:23 +0100

> metadata also to integrands (not only measures)?

No. It's just "an expression".

> Motivation: myoptions allows more fine-grained control over

Agree.

Martin

---

From: Anders Logg <[email-masked]>
Date: Fri, 6 Mar 2009 18:04:25 +0100

> No. It's just "an expression".

But can an expression have metadata attached to it?

-- 
Anders

---

From: Martin Sandve Alnæs <[email-masked]>
Date: Fri, 6 Mar 2009 18:56:37 +0100

> But can an expression have metadata attached to it?

No.

Martin