Subject: [UFL-dev] [HG UFL] Implement extract_component for all element types.

From: [email-masked] (UFL)
Date: Tue, 27 May 2008 10:05:39 +0200 (CEST)

One or more new changesets pushed to the primary ufl repository.
A short summary of the last three changesets is included below.

changeset:   119:ea0a430bda92c750c8531a3c0485727496a7dbfb
tag:         tip
user:        Anders Logg <[email-masked]>
date:        Tue May 27 10:05:55 2008 +0200
files:       ufl/finiteelement.py
description:
Implement extract_component for all element types.
Still untested but it should work. ;-) See if you
agree with the current implementation of mixed, vector
and tensor elements and then we can go ahead and add
more extensive unit tests.

changeset:   118:f8724a827eddc3e64242fad3cc02826b0410d4ac
user:        Anders Logg <[email-masked]>
date:        Tue May 27 00:35:17 2008 +0200
files:       ufl/finiteelement.py
description:
Add function extract_component to element classes, still only
implemented for simple elements

changeset:   117:3611a242d8a406cc8027570f6e09000ab12d7a09
user:        Anders Logg <[email-masked]>
date:        Thu May 22 23:43:52 2008 +0200
files:       ROADMAP ufl/elements.py ufl/finiteelement.py ufl/permutation.py ufl/utilities.py
description:
Work on the finite element classes:
 - Flatten representation of tensor elements
 - Add utilities for computing permutations (from Exterior)
 - Add support for specifying general symmetries (using a dictionary)
 - Vector and TensorElements may be created from non-scalar elements
   (opposite to what we concluded in an earlier discussion). This makes
   sense, in particular for the BDM test case. The important thing is
   that all elements are equal and simple.
 - Access function for elements and indices not yet implemented

----------------------------------------------------------------------
For more details, visit http://www.fenics.org/hg/ufl

---

From: "Martin Sandve Alnæs" <[email-masked]>
Date: Tue, 3 Jun 2008 16:16:24 +0200

> more extensive unit tests.

I think it's great. I've fixed a couple of bugs (still no tests),
and added some minor features.

The issue left to resolve is value_rank() and value_dimension(i) for
MixedElement instances that are not VectorElement or TensorElement
instances. I think we should use the same convention as we use for
ufc::finite_element::value_*, which are essentially the same
functions. The MixedElement.value_rank implemented today (value_rank
== len(subelements)) doesn't make sense, e.g. Taylor-Hood is not a
second order tensor valued element.

--
Martin