Subject: [UFL-dev] [HG UFL] Bugfix in MixedElement.extract_component (if I understand it correctly!)

From: [email-masked] (UFL)
Date: Tue, 3 Jun 2008 14:27:30 +0200 (CEST)

One or more new changesets pushed to the primary ufl repository.
A short summary of the last three changesets is included below.

changeset:   121:4a382df763e2bce23fecb38d896e216a4768a9e7
tag:         tip
user:        "Martin Sandve Alnæs <[email-masked]>"
date:        Tue Jun 03 14:27:29 2008 +0200
files:       ufl/finiteelement.py
description:
Bugfix in MixedElement.extract_component (if I understand it correctly!)

changeset:   120:8626ac075bf52f843215329e4daf2ea672056438
user:        "Martin Sandve Alnæs <[email-masked]>"
date:        Tue Jun 03 14:20:12 2008 +0200
files:       ufl/elements.py ufl/finiteelement.py
description:
Minor fixes on elements.
Implemented value_dimension(i) for FiniteElement,
VectorElement and TensorElement without extra
element information. Only true MixedElement
instances give problems, but this is the same
as ufc::finite_element::value_dimension(i),
and ufc::finite_element::value_rank(), so
we should probably resolve it the same way as
in UFC.

changeset:   119:ea0a430bda92c750c8531a3c0485727496a7dbfb
user:        Anders Logg <[email-masked]>
date:        Tue May 27 10:05:55 2008 +0200
files:       ufl/finiteelement.py
description:
Implement extract_component for all element types.
Still untested but it should work. ;-) See if you
agree with the current implementation of mixed, vector
and tensor elements and then we can go ahead and add
more extensive unit tests.

----------------------------------------------------------------------
For more details, visit http://www.fenics.org/hg/ufl

---

From: Anders Logg <[email-masked]>
Date: Tue, 1 Jul 2008 00:00:34 +0200

> Bugfix in MixedElement.extract_component (if I understand it correctly!)

Yes!

-- 
Anders