Subject: [UFL-dev] [HG UFL] Bugfix.

From: [email-masked] (UFL)
Date: Thu, 19 Feb 2009 14:01:33 +0100 (CET)

One or more new changesets pushed to the primary ufl repository.
A short summary of the last three changesets is included below.

changeset:   600:4ca6e769f21bc48cc6080b8c21d8e61131f12080
tag:         tip
user:        "Martin Sandve Alnæs <[email-masked]>"
date:        Thu Feb 19 14:02:19 2009 +0100
files:       ufl/algorithms/forward_ad.py ufl/algorithms/transformations.py ufl/exproperators.py ufl/testobjects.py
description:
Bugfix.

There is some inconsistency in the handling of products
of tensors, need to work it out before continuing on AD.
Most likely I will make Product only capable of representing
products of scalars, which reduces special cases.
Different kinds of products of tensors will be represented
by conversion to scalars through indexing, application
of products on scalars, and conversion to tensors
using ComponentTensor.

changeset:   599:8e40a63c1e53c596703414d6088cc567f9d640bd
user:        "Martin Sandve Alnæs <[email-masked]>"
date:        Wed Feb 18 20:41:35 2009 +0100
files:       test/test.py ufl/algorithms/forward_ad.py
description:
Bugfix.

changeset:   598:464cd1e6e6f053abffb678fa7257f36520f7382e
user:        "Martin Sandve Alnæs <[email-masked]>"
date:        Wed Feb 18 20:35:43 2009 +0100
files:       ufl/algorithms/forward_ad.py
description:
Bugfix.

----------------------------------------------------------------------
For more details, visit http://www.fenics.org/hg/ufl

---

From: Anders Logg <[email-masked]>
Date: Thu, 19 Feb 2009 15:13:41 +0100

> of products on scalars, and conversion to tensors

Sounds like a very good idea.

-- 
Anders

> _______________________________________________
> UFL-dev mailing list
> [email-masked]
> http://fenics.org/mailman/listinfo/ufl-dev