Subject: [UFL-dev] [HG UFL] Changes in Form:

From: [email-masked] (UFL)
Date: Fri, 27 Feb 2009 16:13:09 +0100 (CET)

One or more new changesets pushed to the primary ufl repository.
A short summary of the last three changesets is included below.

changeset:   653:304b23eab1bb0e005fac11442036c7e109ca7b16
tag:         tip
user:        "Martin Sandve Alnæs <[email-masked]>"
date:        Fri Feb 27 16:13:06 2009 +0100
files:       ufl/form.py
description:
Changes in Form:
- form.integrals() takes an optional domain_type argument,
- added form.measures() with an optional domain_type argument,
- added form.domains() with an optional domain_type argument,
- added form.integral_groups() which returns a dict mapping
from domain to a list of integrals.

Consider:

g = a.integral_groups()
for d in a.domains(Measure.CELL):
    integrals_on_d = g[d]

All integrals in integrals_on_d should then correspond
to a single ufc::cell_integral.

Ok?

changeset:   652:208bee6b38cdcd56ff14814c106bd107217a10fd
user:        "Martin Sandve Alnæs <[email-masked]>"
date:        Fri Feb 27 15:34:13 2009 +0100
files:       ufl/function.py
description:
Bugfix.

changeset:   651:15a7f4adf2a9cdcd20d2b57294bf6c57bf05a193
user:        "Martin Sandve Alnæs <[email-masked]>"
date:        Thu Feb 26 13:15:26 2009 +0100
files:       ufl/algorithms/__init__.py ufl/algorithms/formdata.py ufl/algorithms/graph.py
description:
Minor fixes.

----------------------------------------------------------------------
For more details, visit http://www.fenics.org/hg/ufl

---

From: Kristian Oelgaard <[email-masked]>
Date: Fri, 27 Feb 2009 16:51:09 +0100

Quoting UFL <[email-masked]>:

> user:        "Martin Sandve AlnÃ¦s <[email-masked]>"

Nice, but even nicer if it was implemented YESTERDAY!  :)

Kristian
 
> user:        "Martin Sandve AlnÃ¦s <[email-masked]>"
> user:        "Martin Sandve AlnÃ¦s <[email-masked]>"

---

From: Anders Logg <[email-masked]>
Date: Fri, 27 Feb 2009 17:05:40 +0100

> to a single ufc::cell_integral.

Looks nice.

-- 
Anders