Subject: [UFL-dev] [HG UFL] Fixed a significant bug in AD code. Probably THE cause

From: [email-masked] (UFL)
Date: Wed, 6 May 2009 17:04:09 +0200 (CEST)

One or more new changesets pushed to the primary ufl repository.
A short summary of the last three changesets is included below.

changeset:   880:092c044874c3544d45883a85559adc54f0eb4fcd
tag:         tip
user:        "Martin Sandve Alnæs <[email-masked]>"
date:        Wed May 06 17:04:08 2009 +0200
files:       ufl/algorithms/forward_ad.py
description:
Fixed a significant bug in AD code. Probably THE cause
for all problems I've had with hyperelasticity!

changeset:   879:14e1711e4502aad4bacc687eeb1fc2aa38e5764f
user:        "Martin Sandve Alnæs <[email-masked]>"
date:        Tue May 05 20:16:32 2009 +0200
files:       ufl/differentiation.py
description:
Bugfix in error check for diff(f[i], v).

changeset:   878:154b80a552a93084a086b950b045154607bbc325
user:        "Martin Sandve Alnæs <[email-masked]>"
date:        Fri May 01 11:28:49 2009 +0200
files:       TODO
description:
added todo item

----------------------------------------------------------------------
For more details, visit http://www.fenics.org/hg/ufl

---

From: Harish Narayanan <[email-masked]>
Date: Wed, 06 May 2009 17:06:35 +0200

UFL wrote:
> user:        "Martin Sandve AlnÃ¦s <[email-masked]>"

Great!