Subject: [UFL-dev] [HG UFL] Added lifting operators. Take a look at test/testlifting.py

From: [email-masked] (UFL)
Date: Fri, 19 Jun 2009 13:29:08 +0200 (CEST)

One or more new changesets pushed to the primary ufl repository.
A short summary of the last three changesets is included below.

changeset:   914:099fd17f34f1844716b5912e3b1574351af1342a
tag:         tip
user:        "Martin Sandve Alnæs <[email-masked]>"
date:        Fri Jun 19 13:29:02 2009 +0200
files:       sandbox/scratch/lifting.py test/testlifting.py ufl/__init__.py ufl/algorithms/formdata.py ufl/algorithms/printing.py ufl/algorithms/tuplenotation.py ufl/algorithms/ufl2dot.py ufl/algorithms/ufl2latex.py ufl/classes.py ufl/lifting.py
description:
Added lifting operators. Take a look at test/testlifting.py
and see if it works as expected.

changeset:   913:f35ae8f8cf087b111a180e93bec8ef026153e69a
user:        "Martin Sandve Alnæs <[email-masked]>"
date:        Fri Jun 19 12:47:59 2009 +0200
files:       ufl/form.py ufl/integral.py ufl/objects.py
description:
Added new measure:
dE = Measure(Integral.MACRO_CELL, 0).

changeset:   912:e0d5335438126331e28df107c52930c22b466fca
user:        "Martin Sandve Alnæs <[email-masked]>"
date:        Thu Jun 18 18:10:32 2009 +0200
files:       sandbox/scratch/lifting.py
description:
Added sketch of lifting operator extension.

----------------------------------------------------------------------
For more details, visit http://www.fenics.org/hg/ufl

---

From: Martin Sandve Alnæs <[email-masked]>
Date: Fri, 19 Jun 2009 13:32:47 +0200

Note that some algorithms may still need to be updated to handle these types.

Martin

On Fri, Jun 19, 2009 at 1:29 PM, UFL<[email-masked]> wrote:
> _______________________________________________
> UFL-dev mailing list
> [email-masked]
> http://fenics.org/mailman/listinfo/ufl-dev
>
>

---

From: Kristian Oelgaard <[email-masked]>
Date: Fri, 19 Jun 2009 14:01:49 +0200

Quoting UFL <[email-masked]>:

> user:        "Martin Sandve AlnÃ¦s <[email-masked]>"
> files:       sandbox/scratch/lifting.py test/testlifting.py ufl/__init__.py
> ufl/algorithms/formdata.py ufl/algorithms/printing.py
> ufl/algorithms/tuplenotation.py ufl/algorithms/ufl2dot.py
> ufl/algorithms/ufl2latex.py ufl/classes.py ufl/lifting.py
> description:

Looks good, it should be possible to generate some code from these terminals.

Kristian

> user:        "Martin Sandve AlnÃ¦s <[email-masked]>"
> user:        "Martin Sandve AlnÃ¦s <[email-masked]>"