Subject: [UFL-dev] log to stdout or stderr?

From: Anders Logg <[email-masked]>
Date: Thu, 19 Mar 2009 07:59:40 +0100

Messages from the UFL log system seem to be directed to stderr.
I'm expecting to messages to appear on stdout. It makes grepping for
things easier.

Is there any reason the messages appear on stderr?

-- 
Anders

---

From: Johan Hake <[email-masked]>
Date: Thu, 19 Mar 2009 08:18:39 +0100

> Is there any reason the messages appear on stderr?

The default destination for the StreamHandler is stderr. 

If you deside that the screen streamer should be stdout you can do:

  self._handler = logging.StreamHandler(sys.stdout)

in the __init__ function of the Logger class.

Johan

---

From: Anders Logg <[email-masked]>
Date: Thu, 19 Mar 2009 08:29:07 +0100

> in the __init__ function of the Logger class.

ok. I want to hear what Martin thinks first. There may be some good
reason to use stderr.

-- 
Anders

---

From: Martin Sandve Alnæs <[email-masked]>
Date: Thu, 19 Mar 2009 09:38:58 +0100

stdout is good. I can add some simpler way to write the log to file as well.

-- 
Sendt fra min mobile enhet

Martin

---

From: Anders Logg <[email-masked]>
Date: Thu, 19 Mar 2009 12:55:41 +0100

> stdout is good. I can add some simpler way to write the log to file as well.

ok, nice.

-- 
Anders