Subject: [UFL-dev] output module

From: "Martin Sandve Alnæs" <[email-masked]>
Date: Fri, 14 Mar 2008 15:51:34 +0100

Question found in roadmap file:
# Misc:
 - When do we raise excepion and when do we use assert?

I've defined
 ufl_assert(condition, message)
 ufl_warning(message)
 ufl_error(message)
in output.py

Both ufl_error and ufl_assert will raise an UFLException, but also
print message to output. The redirection stuff isn't implemented, I
figured I'd look at the built in python logging module for this.

Anyway, the output.py file is shorter than this email, so just look at it.

-- 
Martin

---

From: Anders Logg <[email-masked]>
Date: Fri, 14 Mar 2008 23:11:17 +0100

> Anyway, the output.py file is shorter than this email, so just look at it.

Looks good!

-- 
Anders