Subject: [UFL-dev] mixed-mixed element

From: Mehdi Nikbakht <[email-masked]>
Date: Tue, 01 Sep 2009 17:42:29 +0200

Hello,

I am working with mixed-mixed element. Assume,

P2_c = VectorElement("Lagrange", triangle, 2)
P1 = FiniteElement("Lagrange", triangle, 1)

P2 = P2_c + P2_c
TH = P2 + P1

(v, p) = TestFunctions(TH)

Where v and p are the test functions corresponding to P2 and P1 respectively.
However, I want to be able to use a syntax like this,

(v, u, p) = TestFunction(TH)

Which allows me to have access to the test function of each sub element. How can
I do this by UFL?

Mehdi

---

From: "Garth N. Wells" <[email-masked]>
Date: Tue, 01 Sep 2009 16:48:33 +0100

> Which allows me to have access to the test function of each sub element. How can

Take at look at the documentation (Section 2.2.6).

Garth

> Mehdi
> 
> 
> _______________________________________________
> UFL-dev mailing list
> [email-masked]
> http://fenics.org/mailman/listinfo/ufl-dev