Subject: [UFL-dev] [HG UFL] Automatically converting many of the tensor algebra operations to zero tensors when one of the operands are zero.

From: [email-masked] (UFL)
Date: Thu, 30 Oct 2008 15:27:19 +0100 (CET)

One or more new changesets pushed to the primary ufl repository.
A short summary of the last three changesets is included below.

changeset:   384:a6f2d4ed562c5fdb347d809496e8e4b819849294
tag:         tip
user:        "Martin Sandve Alnæs <[email-masked]>"
date:        Thu Oct 30 15:27:17 2008 +0100
files:       ufl/differentiation.py ufl/tensoralgebra.py
description:
Automatically converting many of the tensor algebra operations to zero tensors when one of the operands are zero.

Try
  cd demo
  ufl2pdf stiffness_ad.ufl

changeset:   383:cb3496c2565717a6c44f8e41064efa94f07539f9
user:        "Martin Sandve Alnæs <[email-masked]>"
date:        Thu Oct 30 15:07:32 2008 +0100
files:       demo/stiffness_ad.ufl ufl/algorithms/ufl2latex.py ufl/differentiation.py ufl/variable.py
description:
Automatically removing some cases of trivially zero derivatives:
e.g. f.dx(0) where f is a constant terminal object or
diff(f, v) where f is a terminal other than Variable.

changeset:   382:fe9dc0a66d4ce317d9dd672bbcc93ce402457c2c
user:        "Martin Sandve Alnæs <[email-masked]>"
date:        Thu Oct 30 13:17:08 2008 +0100
files:       ROADMAP ufl/__init__.py ufl/algorithms/__init__.py ufl/algorithms/formtransformations.py ufl/formoperators.py
description:
Some renaming, can now type:
  a = bilinear form
  astar = adjoint(a)

----------------------------------------------------------------------
For more details, visit http://www.fenics.org/hg/ufl

---

From: Anders Logg <[email-masked]>
Date: Thu, 30 Oct 2008 18:46:35 +0100

> Automatically converting many of the tensor algebra operations to zero tensors when one of the operands are zero.

It's starting to look very good!

-- 
Anders

> _______________________________________________
> UFL-dev mailing list
> [email-masked]
> http://fenics.org/mailman/listinfo/ufl-dev