Subject: [UFL-dev] [HG UFL] Changed estimate_quadrature_order to

From: [email-masked] (UFL)
Date: Fri, 20 Mar 2009 14:18:45 +0100 (CET)

One or more new changesets pushed to the primary ufl repository.
A short summary of the last three changesets is included below.

changeset:   752:f7cd7676b697d8662d2aae8e9cf0cf68ce0dfee3
tag:         tip
user:        "Martin Sandve Alnæs <[email-masked]>"
date:        Fri Mar 20 14:18:43 2009 +0100
files:       ufl/algorithms/analysis.py
description:
Changed estimate_quadrature_order to
return 2*v.degree() for linear forms.

changeset:   751:1ec80c8024aed710e6240fa0252173568a3e48df
user:        "Martin Sandve Alnæs <[email-masked]>"
date:        Fri Mar 20 10:38:12 2009 +0100
files:       test/expand_indices.py
description:
Added more tests in expand_indices.py. Looks good.

changeset:   750:908f846b6bf1bdcae99b02a422a02b20f9121cc6
user:        "Martin Sandve Alnæs <[email-masked]>"
date:        Fri Mar 20 10:03:30 2009 +0100
files:       ufl/differentiation.py
description:
Fixed a FIXME.

----------------------------------------------------------------------
For more details, visit http://www.fenics.org/hg/ufl

---

From: "Garth N. Wells" <[email-masked]>
Date: Mon, 23 Mar 2009 10:53:20 +0900

UFL wrote:
> user:        "Martin Sandve AlnÃ¦s <[email-masked]>"

For nonlinear problems it's important that the quadrature order of the 
linear and bilinear forms is the same.

Garth

> user:        "Martin Sandve AlnÃ¦s <[email-masked]>"
> user:        "Martin Sandve AlnÃ¦s <[email-masked]>"
> ------------------------------------------------------------------------
> 
> _______________________________________________
> UFL-dev mailing list
> [email-masked]
> http://fenics.org/mailman/listinfo/ufl-dev

---

From: Anders Logg <[email-masked]>
Date: Mon, 23 Mar 2009 07:42:42 +0100

> linear and bilinear forms is the same.

It seems to me that estimate_quadrature_order() should be removed from
UFL since quadrature has nothing to do with the form language.

Instead, UFL can have a function called polynomial_order() that
returns the polynomial order of an integrand if possible (if it is
indeed a polynomial) and otherwise returns None (if the integrand
contains something like exp or sin).

Then the form compilers can call polynomial_order() and then decide
what to do with the result.

-- 
Anders

---

From: Martin Sandve Alnæs <[email-masked]>
Date: Mon, 23 Mar 2009 09:59:10 +0100

> UFL since quadrature has nothing to do with the form language.

It's a utility, intended to implement a standardized
way of estimating the necessary integration order.

> contains something like exp or sin).

This is the aptly named estimate_maximum_quadrature_order
(or something like that) with the FIXME in it :)
polynomial_order is better.

> what to do with the result.

That was the idea anyway, estimate_quadrature_order
should just provide one standardized way to pick an order,
while polynomial_order provides a different approach.
Then the form compiler decides what to use.
I see no need to implement different strategies for this.

Martin