Subject: [UFL-dev] [HG UFL] Minor fixes on elements.

From: [email-masked] (UFL)
Date: Tue, 3 Jun 2008 14:20:13 +0200 (CEST)

One or more new changesets pushed to the primary ufl repository.
A short summary of the last three changesets is included below.

changeset:   120:8626ac075bf52f843215329e4daf2ea672056438
tag:         tip
user:        "Martin Sandve Alnæs <[email-masked]>"
date:        Tue Jun 03 14:20:12 2008 +0200
files:       ufl/elements.py ufl/finiteelement.py
description:
Minor fixes on elements.
Implemented value_dimension(i) for FiniteElement,
VectorElement and TensorElement without extra
element information. Only true MixedElement
instances give problems, but this is the same
as ufc::finite_element::value_dimension(i),
and ufc::finite_element::value_rank(), so
we should probably resolve it the same way as
in UFC.

changeset:   119:ea0a430bda92c750c8531a3c0485727496a7dbfb
user:        Anders Logg <[email-masked]>
date:        Tue May 27 10:05:55 2008 +0200
files:       ufl/finiteelement.py
description:
Implement extract_component for all element types.
Still untested but it should work. ;-) See if you
agree with the current implementation of mixed, vector
and tensor elements and then we can go ahead and add
more extensive unit tests.

changeset:   118:f8724a827eddc3e64242fad3cc02826b0410d4ac
user:        Anders Logg <[email-masked]>
date:        Tue May 27 00:35:17 2008 +0200
files:       ufl/finiteelement.py
description:
Add function extract_component to element classes, still only
implemented for simple elements

----------------------------------------------------------------------
For more details, visit http://www.fenics.org/hg/ufl

---

From: Anders Logg <[email-masked]>
Date: Sun, 15 Jun 2008 00:37:02 +0200

Is it always true that

  dim = _domain2dim[domain]

?

This seems to be the case for all vector-valued elements we have in
elements.py.

-- 
Anders

> _______________________________________________
> UFL-dev mailing list
> [email-masked]
> http://fenics.org/mailman/listinfo/ufl-dev

---

From: "Martin Sandve Alnæs" <[email-masked]>
Date: Sun, 15 Jun 2008 13:21:45 +0200

No, that is only the default. I have some thoughts about this, I'll
get back to it tomorrow.

-- 
Martin

2008/6/15 Anders Logg <[email-masked]>:
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v1.4.6 (GNU/Linux)
>
> iD8DBQFIVEgNQp2CVMGvcgcRAl9nAJ4wgiykoKOH9EGaMwZldAhft+lkGACfQkS2
> 1P0gpTsQf3RmrDOoyi5IEOg=
> =C+tk
> -----END PGP SIGNATURE-----
>

---

From: Anders Logg <[email-masked]>
Date: Sun, 15 Jun 2008 14:52:42 +0200

> No, that is only the default. I have some thoughts about this, I'll

Some optional parameter in elements.py, like for the degree range?

-- 
Anders