Subject: [UFL-dev] [HG UFL] Import FiniteElementBase in ufl namespace, needed by FFC to check

From: [email-masked] (UFL)
Date: Sun, 28 Sep 2008 21:39:45 +0200 (CEST)

One or more new changesets pushed to the primary ufl repository.
A short summary of the last three changesets is included below.

changeset:   277:7e2457c3bef7d1eed3014dd52ee1205334e8382c
tag:         tip
user:        Anders Logg <[email-masked]>
date:        Sun Sep 28 21:39:51 2008 +0200
files:       ufl/__init__.py
description:
Import FiniteElementBase in ufl namespace, needed by FFC to check
if a given compile object is a finite element or a form.

changeset:   276:bc27a0d125bf9b29aece55062257d11250023373
user:        "Martin Sandve Alnæs <[email-masked]>"
date:        Sun Sep 28 20:22:12 2008 +0200
files:       demo/clean.sh demo/mass.ufl test/analyse-demos.py test/classcoverage.py test/mass.py ufl/algorithms/ad.py ufl/algorithms/traversal.py
description:
Added test which runs ufl-analyse on all demo files.
Some bugfixes.
Disabled tests that fail because they call unimplemented functions (too much noise).

Added comment about implementation of AD rule for Variable, this must be implemented.
Some tests fail because of missing handlers for ZeroType, this must be added.

changeset:   275:f7b27f8daff98f184cf6962bd1245e48501e722a
user:        Anders Logg <[email-masked]>
date:        Sat Sep 27 08:55:23 2008 +0200
files:       test/ffcforms.py ufl/finiteelement.py
description:
Add minor comment to FFC test

----------------------------------------------------------------------
For more details, visit http://www.fenics.org/hg/ufl

---

From: "Martin Sandve Alnæs" <[email-masked]>
Date: Mon, 29 Sep 2008 09:40:56 +0200

Default reply-to is [email-masked], does anyone get that?

-- 
Martin

---------- Forwarded message ----------
From: Martin Sandve Alnæs <[email-masked]>
Date: 2008/9/29
Subject: Re: [UFL-dev] [HG UFL] Import FiniteElementBase in ufl
namespace, needed by FFC to check
To: UFL <[email-masked]>

For form compiler use, you can also import it through ufl.classes:

 from ufl.classes import FiniteElementBase

This allows us to hide classes from the language/user-user-interface
(as opposed to the library/developer-user-interface).

--
Martin

2008/9/28 UFL <[email-masked]>:
> _______________________________________________
> UFL-dev mailing list
> [email-masked]
> http://fenics.org/mailman/listinfo/ufl-dev
>
>

---

From: Anders Logg <[email-masked]>
Date: Mon, 29 Sep 2008 09:57:28 +0200

> Default reply-to is [email-masked], does anyone get that?

Yes. Same as for all other lists.

I'll change to import FiniteElementBase from ufl.classes.

-- 
Anders