Subject: [UFL-dev] [Bug 426496] [NEW] No error message for restrictions in cell integrals

From: logg <[email-masked]>
Date: Tue, 08 Sep 2009 21:00:49 -0000

Public bug reported:

UFL does not complain about the following form:

L = v('+')*dx

This should give an error. Restrictions should not be allowed in cell
integrals and exterior facet integrals, only in interior facet
integrals.

To reproduce this, compile the following code with FFC:

element = FiniteElement("CG", triangle, 1)
v = TestFunction(element)
L = v('+')*dx

This is a summary of a bug report to the mailing list by Kristian
earlier.

** Affects: ufl
     Importance: Medium
         Status: New

** Changed in: ufl
   Importance: Undecided => Medium

-- 
No error message for restrictions in cell integrals
https://bugs.launchpad.net/bugs/426496
You received this bug notification because you are subscribed to UFL.

Status in Unified Form Language: New

Bug description:
UFL does not complain about the following form:

L = v('+')*dx

This should give an error. Restrictions should not be allowed in cell integrals and exterior facet integrals, only in interior facet integrals.

To reproduce this, compile the following code with FFC:

element = FiniteElement("CG", triangle, 1)
v = TestFunction(element)
L = v('+')*dx

This is a summary of a bug report to the mailing list by Kristian earlier.

---

From: oelgaard <[email-masked]>
Date: Wed, 09 Sep 2009 08:42:39 -0000

** Changed in: ufl
       Status: New => In Progress

** Changed in: ufl
     Assignee: (unassigned) => oelgaard (k-b-oelgaard)

Status in Unified Form Language: In Progress

Bug description:

L = v('+')*dx

---

From: oelgaard <[email-masked]>
Date: Wed, 09 Sep 2009 14:14:45 -0000

** Changed in: ufl
       Status: In Progress => Fix Released

Status in Unified Form Language: Fix Released

Bug description:

L = v('+')*dx