Subject: Re: [UFL-dev] [FFC-dev] [HG FFC] Print log messages at level INFO + 5 in JIT compiler

From: Anders Logg <[email-masked]>
Date: Mon, 17 Aug 2009 18:35:35 +0200

This change requires the latest FFC + DOLFIN + UFL.

See if it makes sense. The change on the DOLFIN side (in jit.py) is a
bit of a hack but the rest looks good.

--
Anders

On Mon, Aug 17, 2009 at 06:32:20PM +0200, FFC wrote:
> One or more new changesets pushed to the primary ffc repository.
> A short summary of the last three changesets is included below.
>
> changeset:   1602:9802a3e1842832c00bd7ec65f52d2ce1f8d9dec1
> tag:         tip
> user:        Anders Logg <[email-masked]>
> date:        Mon Aug 17 18:32:16 2009 +0200
> files:       ffc/jit/jit.py
> description:
> Print log messages at level INFO + 5 in JIT compiler
>
>
> changeset:   1601:fd429751836c19bdd9dcf766beb2d385da6ecf4d
> user:        Anders Logg <[email-masked]>
> date:        Mon Aug 17 16:10:20 2009 +0200
> files:       ffc/jit/jit.py
> description:
> Move "Creating Python extension..." from INFO to DEBUG (unrelated to current
> discussion of log levels).
>
>
> changeset:   1600:26c86b345bda9c8e05c2b65c0c687491543e29ec
> user:        Anders Logg <[email-masked]>
> date:        Mon Aug 17 13:23:41 2009 +0200
> files:       ffc/jit/jit.py
> description:
> Add back printing of "Calling FFC JIT compiler..." in JIT compiler.
>
> ----------------------------------------------------------------------
> For more details, visit http://www.fenics.org/hg/ffc
> _______________________________________________
> FFC-dev mailing list
> [email-masked]
> http://www.fenics.org/mailman/listinfo/ffc-dev

---

From: Johan Hake <[email-masked]>
Date: Mon, 17 Aug 2009 20:08:39 +0200

> bit of a hack but the rest looks good.

Looks good. 

Due to current work on a generic interface of compiling python extension 
modules for DOLFIN code, my PyDOLFIN is currently broken. So I haven't been 
able to test it.

Johan

> > Move "Creating Python extension..." from INFO to DEBUG (unrelated to
> > current discussion of log levels).
> >
> >

---

From: Kristian Oelgaard <[email-masked]>
Date: Mon, 17 Aug 2009 20:36:52 +0200

> bit of a hack but the rest looks good.

When I run the unit tests in FFC I get:

Calling FFC just-in-time (JIT) compiler, this may take some time.
Compiler stage 1: Analyzing form
--------------------------------
  Name:                               a
  Rank:                               2
  Cell:                               <triangle of degree 1>
  Geometric dimension:                2
  Topological dimension:              2

[snip]

The first line is OK, but I thought that we wanted to avoid all the junk from
FFC when compiling something using JIT?

Kristian

---

From: Kristian Oelgaard <[email-masked]>
Date: Mon, 17 Aug 2009 20:48:35 +0200

> Compiler stage 1: Analyzing form

I copy pasted some lines from dolfin/jit.py to get rid of this in the unit
tests.

Kristian

> UFL-dev mailing list
> [email-masked]
> http://fenics.org/mailman/listinfo/ufl-dev
>