Subject: [UFL-dev] [HG UFL] Renamed Number to Scalar. Number will be a Python class in Python 3.0.

From: [email-masked] (UFL)
Date: Wed, 3 Sep 2008 15:58:09 +0200 (CEST)

One or more new changesets pushed to the primary ufl repository.
A short summary of the last three changesets is included below.

changeset:   221:de885c5bdad6bcf1ce2aaeea2458b4f613dfde14
tag:         tip
user:        "Martin Sandve Alnæs <[email-masked]>"
date:        Wed Sep 03 15:58:09 2008 +0200
files:       test/swiginac_eval.py test/test.py ufl/__init__.py ufl/algebra.py ufl/algorithms/ad.py ufl/algorithms/checks.py ufl/algorithms/swiginac_eval.py ufl/algorithms/transformations.py ufl/base.py ufl/baseoperators.py ufl/classes.py ufl/conditional.py ufl/objects.py
description:
Renamed Number to Scalar. Number will be a Python class in Python 3.0.

changeset:   220:d70b3c5f9b4ea10bcc3aaab9dd217fa3c9d83511
user:        "Martin Sandve Alnæs <[email-masked]>"
date:        Wed Sep 03 15:54:19 2008 +0200
files:       ufl/algorithms/transformations.py
description:
Add missing import. Add LaTeX handlers for mathfunctions.

changeset:   219:e6e041b37c197fc7af5e52f753ae3a4487377a07
user:        "Martin Sandve Alnæs <[email-masked]>"
date:        Tue Sep 02 14:56:06 2008 +0200
files:       ROADMAP test/run_pychecker.py ufl/__init__.py ufl/algorithms/swiginac_eval.py
description:
Added external run_pychecker.py script. Doesn't seem to work with absolute_path directive though...

----------------------------------------------------------------------
For more details, visit http://www.fenics.org/hg/ufl

---

From: Anders Logg <[email-masked]>
Date: Wed, 3 Sep 2008 21:49:57 +0200

> Renamed Number to Scalar. Number will be a Python class in Python 3.0.

Doesn't this conflict with Scalar in DOLFIN?

-- 
Anders

---

From: "Martin Sandve Alnæs" <[email-masked]>
Date: Thu, 4 Sep 2008 08:10:39 +0200

> Doesn't this conflict with Scalar in DOLFIN?

Ok, any suggestions? But the end user won't use this name anyway (I'll
consider that a bug to be fixed), so we can keep it out of the
official ufl namespace.

--
Martin

---

From: Anders Logg <[email-masked]>
Date: Thu, 4 Sep 2008 12:27:43 +0200

> consider that a bug to be fixed), so we can keep it out of the

How about FloatingPointNumber?

-- 
Anders

---

From: "Martin Sandve Alnæs" <[email-masked]>
Date: Thu, 4 Sep 2008 15:06:08 +0200

> How about FloatingPointNumber?

I chose FloatValue.

-- 
Martin

---

From: Anders Logg <[email-masked]>
Date: Thu, 4 Sep 2008 15:15:47 +0200

> > How about FloatingPointNumber?

Even better.

-- 
Anders