Subject: [UFL-dev] [HG UFL] changed f*f*f*.. to pow(f, )

From: [email-masked] (UFL)
Date: Wed, 24 Sep 2008 21:00:50 +0200 (CEST)

One or more new changesets pushed to the primary ufl repository.
A short summary of the last three changesets is included below.

changeset:   262:3c14c25dbe1d8c09ec43ac6e6ea9d7b39a73bf8b
tag:         tip
user:        "Kent-Andre Mardal <[email-masked]>"
date:        Wed Sep 24 21:00:47 2008 +0200
files:       demo/ad_ex1.ufl
description:
changed f*f*f*.. to  pow(f, )

changeset:   261:47f24c5a799264152018ebb14d5c623206cb8c12
user:        "Kent-Andre Mardal <[email-masked]>"
date:        Wed Sep 24 15:37:24 2008 +0200
files:       demo/ad_ex1.ufl
description:
ad test

changeset:   260:4e87970569562901a101b2bc90b916c90e552cfd
user:        "Martin Sandve Alnæs <[email-masked]>"
date:        Wed Sep 24 15:28:22 2008 +0200
files:       test/classcoverage.py test/mass.py ufl/algorithms/ad.py ufl/algorithms/transformations.py ufl/algorithms/ufl2latex.py ufl/formoperators.py
description:
Some bugfixes and test fixes.
Some tests fail, but that's ok for now.

----------------------------------------------------------------------
For more details, visit http://www.fenics.org/hg/ufl

---

From: "Martin Sandve Alnæs" <[email-masked]>
Date: Thu, 25 Sep 2008 09:40:47 +0200

It's great that you're adding tests, but I think this code should either be
- placed in sandbox/, as experimental playground code
- modified to verify something and placed in test/
- define some actual form and stay in demo/

In particular, .ufl files are ideally seen as "data files"
even though they are python based.

-- 
Martin

2008/9/24 UFL <[email-masked]>:
> _______________________________________________
> UFL-dev mailing list
> [email-masked]
> http://fenics.org/mailman/listinfo/ufl-dev
>
>

---

From: Kent Andre <[email-masked]>
Date: Thu, 25 Sep 2008 09:46:45 +0200

Are you refering to the print statments ? 

Kent

---

From: "Martin Sandve Alnæs" <[email-masked]>
Date: Thu, 25 Sep 2008 09:49:10 +0200

I guess removing those and renaming it to something less cryptic would be fine.

-- 
Martin