Subject: [UFL-dev] [HG UFL] Moved operators from base.py to their respective context file.

From: [email-masked] (UFL)
Date: Tue, 20 May 2008 14:52:52 +0200 (CEST)

One or more new changesets pushed to the primary ufl repository.
A short summary of the last three changesets is included below.

changeset:   111:5551c9d6e223c33b9fdc07cc44e24e9868df7a46
tag:         tip
user:        "Martin Sandve Alnæs <[email-masked]>"
date:        Tue May 20 14:52:55 2008 +0200
files:       ufl/all.py ufl/base.py ufl/differentiation.py ufl/indexing.py ufl/operators.py ufl/tensoralgebra.py ufl/tensors.py
description:
Moved operators from base.py to their respective context file.
The trick was to not implement the operators in the UFLObject
class itself, but instead extend UFLObject with the various
operators in their respective files like:

def _getitem(self, key):
    return Indexed(self, key)
UFLObject.__getitem__ = _getitem

changeset:   110:f556c349e29d7ad80442727c819a3afe7cfe082e
user:        "Martin Sandve Alnæs <[email-masked]>"
date:        Mon May 19 21:16:54 2008 +0200
files:       ufl/__init__.py ufl/integral.py ufl/objects.py ufl/utilities.py
description:
Additional small fixes. Disabled PyChecker.

changeset:   109:6111a9c4bfd2e70d1692cd2b2de3fa7641120a5c
user:        "Martin Sandve Alnæs <[email-masked]>"
date:        Mon May 19 21:11:07 2008 +0200
files:       ufl/__init__.py ufl/base.py ufl/finiteelement.py ufl/indexing.py ufl/mathfunctions.py ufl/operators.py ufl/output.py ufl/tensors.py ufl/traversal.py ufl/utilities.py
description:
Fixed a bunch of minor issues and bugs found by using static analysis with PyChecker.

----------------------------------------------------------------------
For more details, visit http://www.fenics.org/hg/ufl

---

From: Anders Logg <[email-masked]>
Date: Wed, 21 May 2008 11:47:02 +0200

> UFLObject.__getitem__ = _getitem

Nice!

-- 
Anders

> _______________________________________________
> UFL-dev mailing list
> [email-masked]
> http://fenics.org/mailman/listinfo/ufl-dev