Subject: [UFL-dev] [HG UFL] Add missing import of expand_indices

From: [email-masked] (UFL)
Date: Mon, 20 Apr 2009 13:10:48 +0200 (CEST)

One or more new changesets pushed to the primary ufl repository.
A short summary of the last three changesets is included below.

changeset:   854:cb8bfad3245ca1a4cc0619b9b6e21b3e5c95634e
tag:         tip
user:        Anders Logg <[email-masked]>
date:        Mon Apr 20 13:10:44 2009 +0200
files:       ufl/algorithms/transformations.py
description:
Add missing import of expand_indices

changeset:   853:226bb2d6feaf4273e840c10b42e7aab9b55023c8
user:        "Martin Sandve Alnæs <[email-masked]>"
date:        Mon Apr 20 11:26:19 2009 +0200
files:       ufl/algorithms/expand_indices.py ufl/algorithms/renumbering.py ufl/indexing.py ufl/tensors.py
description:
Some fixes.

changeset:   852:6c8ff185d0509dfd0cf74bf691eaff92c68d2974
user:        "Martin Sandve Alnæs <[email-masked]>"
date:        Mon Apr 20 10:42:30 2009 +0200
files:       ufl/algorithms/expand_indices.py ufl/indexing.py
description:
Bugfix.

----------------------------------------------------------------------
For more details, visit http://www.fenics.org/hg/ufl

---

From: Anders Logg <[email-masked]>
Date: Mon, 20 Apr 2009 13:12:37 +0200

> Add missing import of expand_indices

I had to place the import inside purge_list_tensors to avoid a
circular import:

  transformations.py --> expand_indices --> graph.py --> transformations.py

Is there a way around this?

-- 
Anders

---

From: Martin Sandve Alnæs <[email-masked]>
Date: Mon, 20 Apr 2009 13:25:21 +0200

That's part of why I moved expand_indices to a separate file, moved
purge_list_tensors there now.

Martin

On Mon, Apr 20, 2009 at 1:12 PM, Anders Logg <[email-masked]> wrote:
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v1.4.9 (GNU/Linux)
>
> iEYEARECAAYFAknsWKUACgkQTuwUCDsYZdEyTQCeM9MNaIc/YnRuYJkqmDA2Ht8n
> QTQAoJHh7nxfraxQOoPcvHJ0CCUjk7su
> =nWY0
> -----END PGP SIGNATURE-----
>
> _______________________________________________
> UFL-dev mailing list
> [email-masked]
> http://fenics.org/mailman/listinfo/ufl-dev
>
>

---

From: Anders Logg <[email-masked]>
Date: Mon, 20 Apr 2009 13:28:04 +0200

ok, good.

-- 
Anders