Subject: [Unicorn-dev] unicorn install error

From: Waad Subber <[email-masked]>
Date: Tue, 09 Jun 2009 13:37:04 -0400

Hello:
I am trying to install Unicorn/FEniCS distribution 2009-05-25 (beta) in
Ubuntu 8.10 with gcc (Ubuntu 4.3.2-1ubuntu12) 4.3.2. I get the error
messages below. Any idea how to resolve the problem?

Thanks
Waad
--------------------------------------------------------------------------
make[4]: Leaving directory
`/home/waad/soft/UNICORN/unicorn-fenics-dist-2009-05-25_01/dolfin-0.7.1
+snapshot2008012103/src/kernel/function'
make[3]: *** [install-recursive] Error 1
make[3]: Leaving directory
`/home/waad/soft/UNICORN/unicorn-fenics-dist-2009-05-25_01/dolfin-0.7.1
+snapshot2008012103/src/kernel/function'
make[2]: *** [install-recursive] Error 1
make[2]: Leaving directory
`/home/waad/soft/UNICORN/unicorn-fenics-dist-2009-05-25_01/dolfin-0.7.1
+snapshot2008012103/src/kernel'
make[1]: *** [install-recursive] Error 1
make[1]: Leaving directory
`/home/waad/soft/UNICORN/unicorn-fenics-dist-2009-05-25_01/dolfin-0.7.1
+snapshot2008012103/src'
make: *** [install-recursive] Error 1
scons: Reading SConscript files ...
Checking for madlib >= 0.0.1... no
Madlib >= 0.0.1 not found
Package dolfin was not found in the pkg-config search path.
Perhaps you should add the directory containing `dolfin.pc'
to the PKG_CONFIG_PATH environment variable
No package 'dolfin' found
OSError: 'pkg-config --cflags --libs dolfin' exited 1:
  File
"/home/waad/soft/UNICORN/unicorn-fenics-dist-2009-05-25_01/unicorn-kth/SConstruct", line 58:
    env.ParseConfig('pkg-config --cflags --libs dolfin')
  File "/usr/lib/scons/SCons/Environment.py", line 1371:
    return function(self, self.backtick(command))
  File "/usr/lib/scons/SCons/Environment.py", line 549:
    raise OSError("'%s' exited %d" % (command, status))
-----------------------------------------------------------------------------------

---

From: Johan Jansson <[email-masked]>
Date: Tue, 09 Jun 2009 22:16:20 +0200

Hi!

It looks like there is an earlier error when compiling DOLFIN. Could you 
send the whole install log (all of the output from ". build_local.sh")?

Best,
  Johan

Waad Subber wrote:
> _______________________________________________
> Unicorn-dev mailing list
> [email-masked]
> http://fenics.org/mailman/listinfo/unicorn-dev
>