Subject: Re: [Unicorn-dev] [Fwd: hg repo integrity]

From: Johan Jansson <[email-masked]>
Date: Sat, 21 Nov 2009 13:27:36 +0200

Thanks! Could you do the same with unicorn-unstable (your changeset 320
appears to be the latest), and then give the archives to Andy?

We've had some discussion and would like to convert both repositories
(mirror the situation at fenics.org). Please let us know if you need help
Andy (and Anders).

Best,
  Johan

On Nov 21, 2009 12:45 AM, "Murtazo Nazarov" <[email-masked]> wrote:

Hi,

Yes, here is the one I have:

http://www.csc.kth.se/~murtazo/res/unicorn.tar.gz

Let me know if I can help you.

Murtazo

Johan Jansson wrote: > > Hi Murtazo, > > I think you made the latest commit,
do you still have a c...

---

From: Anders Logg <[email-masked]>
Date: Sat, 21 Nov 2009 20:24:24 +0100

There's some support in bzr for having multiple branches in the same
repository, so I'm not sure what the best solution is. But it's
definitely possible to keep many branches on the same Launchpad
project page so you can create as many branches as you like. But it's
not clear to me how to set up the two initial branches (stable and
unstable) from two separate hg repositories and have bzr and the
conversion tool realize the two repositories are connected.

--
Anders

On Sat, Nov 21, 2009 at 01:27:36PM +0200, Johan Jansson wrote:
> Thanks! Could you do the same with unicorn-unstable (your changeset 320 appears
> to be the latest), and then give the archives to Andy?
>
> We've had some discussion and would like to convert both repositories (mirror
> the situation at fenics.org). Please let us know if you need help Andy (and
> Anders).
>
> Best,
>   Johan
>
>     Johan Jansson wrote: > > Hi Murtazo, > > I think you made the latest
>     commit, do you still have a c...
>

---

From: Johan Jansson <[email-masked]>
Date: Sat, 21 Nov 2009 21:21:54 +0100

You're right, my bad. I have the latest commit (changeset 181). Here's 
the archive of the latest Unicorn (not unstable) repository:

http://www.csc.kth.se/~jjan/transfer/unicorn-2009-11-02.zip

Best,
  Johan

Murtazo Nazarov wrote:
> Hi,
>
> The link I sent was actually unicorn-unstable not the stable one. For the stable unicorn I have to check first. Did I do the last push to that one as well?
>
> Murtazo
> ________________________________________
> From: [email-masked] [[email-masked]] On Behalf Of Johan Jansson [[email-masked]]
> Sent: Saturday, November 21, 2009 12:27 PM
> To: Murtazo Nazarov
> Cc: [email-masked]; [email-masked]; Murtazo Nazarov; Johan Jansson; Andy Ray Terrel; Anders Logg
> Subject: Re: [Fwd: [Unicorn-dev] hg repo integrity]
>
> Thanks! Could you do the same with unicorn-unstable (your changeset 320 appears to be the latest), and then give the archives to Andy?
>
> We've had some discussion and would like to convert both repositories (mirror the situation at fenics.org<http://fenics.org>). Please let us know if you need help Andy (and Anders).
>
> Best,
>   Johan
>
> On Nov 21, 2009 12:45 AM, "Murtazo Nazarov" <[email-masked]<mailto:[email-masked]>> wrote:
>
> Hi,
>
> Johan Jansson wrote: > > Hi Murtazo, > > I think you made the latest commit, do you still have a c...
>
>

---

From: Andy Ray Terrel <[email-masked]>
Date: Sat, 21 Nov 2009 22:25:53 -0500

Okay thanks for the code.  Apparently there is still some problems
with the conversion process.  I am seeing if the bzr-hg plugin has
anyway around it.

AFAIK we can create two series in the Unicorn launchpad project and
have each coorespond to a different repo.  I don't know how bzr will
handle it if you want to merge the two later in the future though.

-- Andy

FWIW Here's the error on the repos that I'm getting:

aterrel@aterrel:~/scratch/bzr_fenics_apps$ bzr branch
../unicorn_zip/unicorn-unstable/
bzr: ERROR: exceptions.UnicodeDecodeError: 'ascii' codec can't decode
byte 0xc3 in position 0: ordinal not in range(128)

Traceback (most recent call last):
  File "/usr/local/lib/python2.6/site-packages/bzrlib/commands.py",
line 842, in exception_to_return_code
    return the_callable(*args, **kwargs)
  File "/usr/local/lib/python2.6/site-packages/bzrlib/commands.py",
line 1037, in run_bzr
    ret = run(*run_argv)
  File "/usr/local/lib/python2.6/site-packages/bzrlib/commands.py",
line 654, in run_argv_aliases
    return self.run(**all_cmd_args)
  File "/usr/local/lib/python2.6/site-packages/bzrlib/builtins.py",
line 1243, in run
    source_branch=br_from)
  File "/usr/local/lib/python2.6/site-packages/bzrlib/bzrdir.py", line
1185, in sprout
    result_repo.fetch(source_repository, fetch_spec=fetch_spec)
  File "/usr/local/lib/python2.6/site-packages/bzrlib/repository.py",
line 1695, in fetch
    find_ghosts=find_ghosts, fetch_spec=fetch_spec)
  File "/usr/local/lib/python2.6/site-packages/bzrlib/decorators.py",
line 192, in write_locked
    result = unbound(self, *args, **kwargs)
  File "/usr/local/lib/python2.6/site-packages/bzrlib/plugins/hg/fetch.py",
line 665, in fetch
    self.addchangegroup(cg, mapping)
  File "/usr/local/lib/python2.6/site-packages/bzrlib/plugins/hg/fetch.py",
line 508, in addchangegroup
    self._add_inventories(manifestchunks2, mapping, pb)
  File "/usr/local/lib/python2.6/site-packages/bzrlib/plugins/hg/fetch.py",
line 430, in _add_inventories
    basis_inv)
  File "/usr/local/lib/python2.6/site-packages/bzrlib/repofmt/groupcompress_repo.py",
line 872, in add_inventory_by_delta
    propagate_caches=propagate_caches)
  File "/usr/local/lib/python2.6/site-packages/bzrlib/inventory.py",
line 1814, in create_by_apply_delta
    new_value = result._entry_to_bytes(entry)
  File "/usr/local/lib/python2.6/site-packages/bzrlib/inventory.py",
line 1534, in _entry_to_bytes
    name_str = entry.name.encode("utf8")
UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position
0: ordinal not in range(128)

bzr 2.0.2 on python 2.6.1 (Darwin-10.2.0-i386-64bit)
arguments: ['/usr/local/bin/bzr', 'branch', '../unicorn_zip/unicorn-unstable/']
encoding: 'UTF-8', fsenc: 'utf-8', lang: 'en_US.UTF-8'
plugins:
  hg
/usr/local/lib/python2.6/site-packages/bzrlib/plugins/hg [0.1.0]
  launchpad
/usr/local/lib/python2.6/site-packages/bzrlib/plugins/launchpad
[2.0.2]
  netrc_credential_store
/usr/local/lib/python2.6/site-packages/bzrlib/plugins/netrc_credential_store
[2.0.2]

*** Bazaar has encountered an internal error.  This probably indicates a
    bug in Bazaar.  You can help us fix it by filing a bug report at
        https://bugs.launchpad.net/bzr/+filebug
    including this traceback and a description of the problem.

---

From: Anders Logg <[email-masked]>
Date: Sun, 22 Nov 2009 11:41:54 +0100

> handle it if you want to merge the two later in the future though.

I tried this now and I get the same error:

11:40:37 Starting import of 182 commits ...
ABORT: exception occurred processing commit :128
bzr: ERROR: exceptions.UnicodeDecodeError: 'ascii' codec can't decode
byte 0xc3 in position 0: ordinal not in range(128)

--
Anders

---

From: Andy Ray Terrel <[email-masked]>
Date: Sun, 22 Nov 2009 08:40:55 -0500

> byte 0xc3 in position 0: ordinal not in range(128)

We'll see if anyone on the dev team can help:

https://bugs.launchpad.net/bzr-hg/+bug/486541

-- Andy

> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v1.4.9 (GNU/Linux)
>
> iEYEARECAAYFAksJFXIACgkQTuwUCDsYZdFXKgCgjToRjFFSHxzlmKVCfaWlpo1M
> HeIAn3yFhQQxlFFTx1qpDGE8EQ+fcXJg
> =VCB6
> -----END PGP SIGNATURE-----
>
>