Subject: [Viper-dev] Bug in write_png?

From: Anders Logg <[email-masked]>
Date: Mon, 4 Jun 2007 22:19:10 +0200

Traceback (most recent call last):
  File "/usr/lib/python2.5/site-packages/viper/viper.py", line 556, in
  key_press_methods
    self.write_png()
  File "/usr/lib/python2.5/site-packages/viper/viper.py", line 179, in
  write_png
    self.update()
TypeError: dolfin_update() takes exactly 2 arguments (1 given)

/Anders

---

From: Ola Skavhaug <[email-masked]>
Date: Tue, 5 Jun 2007 00:21:49 +0200

Could you point me to a relevant example? I think I found (and fixed) the bug,
which is related to the difference in update() behaviour in viper_dolfin and
viper.

Ola

Anders Logg skrev den 04/06-2007 følgende:
> _______________________________________________
> Viper-dev mailing list
> [email-masked]
> http://fenics.org/mailman/listinfo/viper-dev

---

From: Anders Logg <[email-masked]>
Date: Tue, 5 Jun 2007 00:25:18 +0200

Run the demo in src/demo/pde/stokes/taylor-hood, then run the plot.py
script and press i.

/Anders

---

From: Ola Skavhaug <[email-masked]>
Date: Tue, 5 Jun 2007 00:35:57 +0200

> Run the demo in src/demo/pde/stokes/taylor-hood, then run the plot.py

The bug is fixed now.

Ola

---

From: Anders Logg <[email-masked]>
Date: Tue, 5 Jun 2007 01:28:57 +0200

Great, now I don't get the error message anymore, but the png looks
very strange. (Maybe it's my graphics card.)

/Anders

---

From: Ola Skavhaug <[email-masked]>
Date: Tue, 5 Jun 2007 07:50:26 +0200

> very strange. (Maybe it's my graphics card.)

Yes, it is. My plots are fine.

Ola