Subject: [Viper-dev] [HG viper] rename wx test and added more cases to standalone test.

From: [email-masked]
Date: Thu, 3 Jul 2008 13:01:10 +0200 (CEST)

One or more new changesets pushed to the primary Viper repository.
A short summary of the last three changesets is included below.

changeset:   91:4d9acc674966a0b536af369c43a4ca13e63fc4dc
tag:         tip
user:        "Ola Skavhaug <[email-masked]>"
date:        Thu Jul 03 13:00:58 2008 +0200
files:       doc/manual/chapters/introduction.tex doc/manual/viper-user-manual.pdf src/demo/test_standalone.py src/demo/test_wx.py src/demo/testwx.py src/viper/viper.py
description:
rename wx test and added more cases to standalone test.

changeset:   90:2066f8af18f19d348241caecaa9d2dff15aa18da
user:        "Ola Skavhaug <[email-masked]>"
date:        Thu Jul 03 11:19:52 2008 +0200
files:       doc/manual/chapters/introduction.tex doc/manual/viper-user-manual.pdf src/demo/test_standalone.py src/viper/viper.py
description:
Added some documentation, fixed vector plotting bug in standalone mode. Added better test cases.

changeset:   89:f931bbefaf83c49578538befc0355d0f211b3fc6
user:        "Ola Skavhaug <[email-masked]>"
date:        Fri Jun 27 13:21:49 2008 +0200
files:       src/viper/viper.py
description:
Bug fix, viper_dolfin now works again.

----------------------------------------------------------------------
For more details, visit http://www.fenics.org/hg/viper

---

From: Ilmar Wilbers <[email-masked]>
Date: Thu, 17 Jul 2008 11:39:14 +0200

So what tests, if any, would it make sense to add to the buildbot?

ilmar

[email-masked] wrote:
> _______________________________________________
> Viper-dev mailing list
> [email-masked]
> http://fenics.org/mailman/listinfo/viper-dev

---

From: Ola Skavhaug <[email-masked]>
Date: Fri, 1 Aug 2008 11:57:07 +0200

> So what tests, if any, would it make sense to add to the buildbot?

This is a tricky one. Is it possible to run tests that require a
windowmanager? In that case, we could run a lot of tests. If not, testing
viper with a buildbot will be hard.

Ola

---

From: Ilmar Wilbers <[email-masked]>
Date: Fri, 01 Aug 2008 13:12:42 +0200

Well, only if you set up a connection to a display somehow. In order to 
run such tests, the DISPLAY variable should be connected to a different 
machine. Some of the buildbots run on systems without X, and even those 
who do, don't know anything about a X connection. This is really 
something for the IT departement, I think.

ilmar