Subject: [Viper-dev] [HG viper] Bug fix, viper_dolfin now works again.

From: [email-masked]
Date: Fri, 27 Jun 2008 13:21:22 +0200 (CEST)

One or more new changesets pushed to the primary Viper repository.
A short summary of the last three changesets is included below.

changeset:   89:f931bbefaf83c49578538befc0355d0f211b3fc6
tag:         tip
user:        "Ola Skavhaug <[email-masked]>"
date:        Fri Jun 27 13:21:49 2008 +0200
files:       src/viper/viper.py
description:
Bug fix, viper_dolfin now works again.

changeset:   88:7d87cdaf0080605b5790033e8b28b4e325e6756a
user:        "Ola Skavhaug <[email-masked]>"
date:        Fri Jun 27 11:34:18 2008 +0200
files:       src/demo/test_standalone.py src/demo/testwx.py src/viper/viper.py
description:
Viper can now be a wxwidget if given a wx.Frame. Added warpscalar in standalone viper. Added more tests.

changeset:   87:2d160c594823571612f2122fbd1eab24f30d870e
user:        "Ola Skavhaug <[email-masked]>"
date:        Fri Jun 20 11:39:10 2008 +0200
files:       src/bin/viper src/viper/viper.py src/viper/viper_dolfin.py
description:
Added title to viper plot window through title keyword argument.

----------------------------------------------------------------------
For more details, visit http://www.fenics.org/hg/viper

---

From: Ilmar Wilbers <[email-masked]>
Date: Fri, 27 Jun 2008 13:43:02 +0200

I was going to add the tests to the buildbot, but I get the following 
errors:
 >python testwx.py
Traceback (most recent call last):
  File "testwx.py", line 49, in <module>
    frame = MyFrame(None, -1, "wxViper", size=(400,400))
  File "testwx.py", line 32, in __init__
    self.v = Viper(mesh=self.mesh, x=self.x, frame=self, warpscalar=True)
TypeError: __init__() got an unexpected keyword argument 'warpscalar'

 >python test_standalone.py
Traceback (most recent call last):
  File "test_standalone.py", line 19, in <module>
    v = viper.Viper(coordinates=coords2d, cells=triangles)
TypeError: __init__() got an unexpected keyword argument 'cells'

Am I missing something?

ilmar

[email-masked] wrote:
> _______________________________________________
> Viper-dev mailing list
> [email-masked]
> http://fenics.org/mailman/listinfo/viper-dev
>

---

From: Ilmar Wilbers <[email-masked]>
Date: Sat, 28 Jun 2008 09:24:49 +0200

Wrong list :-) Too early in the morning.

ilmar

Ilmar Wilbers skrev:
> Forgot to send to list.
>
> ilmar
>
> Ilmar Wilbers skrev:
>   
>> Conclusion: two errors:
>> 1) forgot to install (hg pull does NOT install :-) )
>> 2) must use python-wxgtk2.6, not pythonwxgtk2.8 package.
>>
>> ilmar
>>
>> Ola Skavhaug wrote:
>>     
>>> What does
>>> import viper
>>> print viper.__file__
>>> report?
>>>
>>> Ola
>>>
>>> Ilmar Wilbers skrev den 27/06-2008 følgende:
>>>  
>>>       
>>>> I was going to add the tests to the buildbot, but I get the 
>>>> following errors:
>>>>  >python testwx.py
> DOLFIN-dev mailing list
> [email-masked]
> http://www.fenics.org/mailman/listinfo/dolfin-dev
>