Subject: [Viper-dev] [HG viper] Fix viper such that it works with the last dolfin demo, i.e. update coordinates when plotting meshfunction. Also add command line support for viper for plotting dolfin mesh functions of type uint.

From: [email-masked]
Date: Mon, 22 Dec 2008 11:58:18 +0100 (CET)

One or more new changesets pushed to the primary Viper repository.
A short summary of the last three changesets is included below.

changeset:   150:dc90bb22dce7e4fd73accca6c23a88035080135a
tag:         tip
user:        "Ola Skavhaug <[email-masked]>"
date:        Mon Dec 22 12:02:39 2008 +0100
files:       src/bin/viper src/viper/viper_dolfin.py
description:
Fix viper such that it works with the last dolfin demo, i.e. update coordinates when plotting meshfunction. Also add command line support for viper for plotting dolfin mesh functions of type uint.

changeset:   149:bc9b56f9dde43a18b43fc045d4342a226648137a
user:        Ola Skavhaug <[email-masked]>
date:        Sat Dec 20 21:45:37 2008 +0100
files:       src/viper/viper.py
description:
Bug fix in bug fix :)

changeset:   148:67a355239cdea2f2aa912622740a6a4de1ba8749
user:        Ola Skavhaug <[email-masked]>
date:        Sat Dec 20 12:01:28 2008 +0100
files:       src/viper/viper.py src/viper/viper_dolfin.py
description:
Add check to not rescale scalar xy plots.

----------------------------------------------------------------------
For more details, visit http://www.fenics.org/hg/viper

---

From: Anders Logg <[email-masked]>
Date: Mon, 22 Dec 2008 12:57:39 +0100

> Fix viper such that it works with the last dolfin demo, i.e. update coordinates when plotting meshfunction. Also add command line support for viper for plotting dolfin mesh functions of type uint.

Seems to work, but the plot still looks a little strange since the
circle remains in the center when it is in fact rotating around the
center of a square.

But maybe this is the best solution. Otherwise we might run in to
trouble with setting the bounding box?

-- 
Anders

---

From: "Ola Skavhaug" <[email-masked]>
Date: Mon, 22 Dec 2008 13:00:50 +0100

The problem now is the rescale option. Rescale resets the camera to
best fit, i.e. move the scene to the center.
I've fixed the dolfin demo, though, adding a polygon box, and updated
the camera once. It then looks much nicer.

Ola

On Mon, Dec 22, 2008 at 12:57 PM, Anders Logg <[email-masked]> wrote:
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v1.4.9 (GNU/Linux)
>
> iEYEARECAAYFAklPgLIACgkQTuwUCDsYZdGnRwCeMFfel+IXFFD1E+vk65S5SGUJ
> EycAnRM2aqSQFyUK47aWr9yW30fTCN88
> =puC3
> -----END PGP SIGNATURE-----
>
> _______________________________________________
> Viper-dev mailing list
> [email-masked]
> http://fenics.org/mailman/listinfo/viper-dev
>
>

-- 
Ola Skavhaug

---

From: Anders Logg <[email-masked]>
Date: Mon, 22 Dec 2008 13:33:25 +0100

Nice!

-- 
Anders