Subject: [Viper-dev] [HG viper] Added test for cutplane with non-default normal. Not sure it is correct, though.

From: [email-masked]
Date: Thu, 21 Aug 2008 17:35:29 +0200 (CEST)

One or more new changesets pushed to the primary Viper repository.
A short summary of the last three changesets is included below.

changeset:   102:e73a954e075f1a55bf98ac3f182b45cf22b3dcb1
tag:         tip
user:        "Ola Skavhaug <[email-masked]>"
date:        Thu Aug 21 17:35:34 2008 +0200
files:       src/demo/test_standalone.py
description:
Added test for cutplane with non-default normal. Not sure it is correct, though.

changeset:   101:db7a255edb741dd71a4dc7386f2a16380745740e
user:        "Johan Hake <[email-masked]>"
date:        Fri Aug 15 08:39:32 2008 +0200
files:       src/viper/viper.py
description:
Corrected the camera view for a cutplane.

changeset:   100:9437391d560ea40127442a23e8764da6a51b2433
user:        "Ola Skavhaug <[email-masked]>"
date:        Thu Aug 21 14:38:46 2008 +0200
files:       misc/vtk/wx-2.8/README.TXT misc/vtk/wx-2.8/__init__.py misc/vtk/wx-2.8/wxVTKRenderWindow.py misc/vtk/wx-2.8/wxVTKRenderWindowInteractor.py
description:
Added vtk files for making viper work with wx-2.8.

----------------------------------------------------------------------
For more details, visit http://www.fenics.org/hg/viper

---

From: Johan Hake <[email-masked]>
Date: Fri, 22 Aug 2008 00:09:07 +0200

> Added test for cutplane with non-default normal. Not sure it is correct,

Looks quite funny!

How can you get a perfectly rectangular (at least it looks like one) cutplane 
from a tetrahedron?

Johan

> files:       misc/vtk/wx-2.8/README.TXT misc/vtk/wx-2.8/__init__.py
> misc/vtk/wx-2.8/wxVTKRenderWindow.py
> misc/vtk/wx-2.8/wxVTKRenderWindowInteractor.py description:
> _______________________________________________
> Viper-dev mailing list
> [email-masked]
> http://fenics.org/mailman/listinfo/viper-dev

---

From: Ola Skavhaug <[email-masked]>
Date: Fri, 22 Aug 2008 09:16:50 +0200

> How can you get a perfectly rectangular (at least it looks like one) cutplane 

I have absolutely no idea. Perhaps the plane is not really an infinite plane,
but a rectangular surface? That could explain it.

Ola

---

From: Johan Hake <[email-masked]>
Date: Fri, 22 Aug 2008 09:38:16 +0200

On Friday 22 August 2008 09:16:50 Ola Skavhaug wrote:
> > How can you get a perfectly rectangular (at least it looks like one)
> > cutplane from a tetrahedron?
>
> I have absolutely no idea. Perhaps the plane is not really an infinite
> plane, but a rectangular surface? That could explain it.

Changing the single tet with a dolfin UnitCube with size 10,10,10 works fine. 
It could be that the interpolation rutine in vtk cannot handle a single 
tetrahedron. At least not if the plane is not perpendicular to one of the 
axis.

Johan