Subject: Re: [Viper-dev] [DOLFIN-dev] [HG DOLFIN] Handle output of scalar P0 functions in VTK format.

From: Anders Logg <[email-masked]>
Date: Mon, 14 Jul 2008 22:26:15 +0200

On Sun, Jul 13, 2008 at 10:44:39AM +0100, Garth N. Wells wrote:
> 
> 
> Anders Logg wrote:
> > On Sun, Jul 13, 2008 at 08:51:43AM +0100, Garth N. Wells wrote:
> >>
> >> Anders Logg wrote:
> >>> On Sat, Jul 12, 2008 at 10:28:55PM +0100, Garth N. Wells wrote:
> >>>> Anders Logg wrote:
> >>>>> Does this work? I was expecting to see a DG plot for the solution u in
> >>>>> the mixed poisson demo.
> >>>>>
> >>>> Yes, it works. Open the .vtu file with Paraview and you'll see that the 
> >>>> plot is cell-wise. You won't see it in the Viper plot.
> >>>>
> >>>> Garth
> >>> I tried it now in Paraview, but it seems I can only get a 2D plot, or
> >>> are you able to do "warp scalar"?
> >>>
> >> Looks like Paraview can't warp cell data. You can do
> >>
> >>    "Filters" -> "Alphabetical" -> "Cell Data to Point Data"
> >>
> >> and then use warp.
> >>
> >> Garth
> > 
> > Yes, but that does some kind of projection/interpolation to piecewise
> > linears. I'd like to plot the discontinuous solution and see that it
> > is discontinuous.
> >
> 
> You can see jumps in the contour colours from one cell to another. It 
> looks like Paraview/VTK doesn't support warping of cell data.
> 
> Garth

ok. This would be a very nice feature to have in Viper. Ola?

-- 
Anders

---

From: "Garth N. Wells" <[email-masked]>
Date: Mon, 14 Jul 2008 21:36:37 +0100

> ok. This would be a very nice feature to have in Viper. Ola?

It would also be good if Viper could check the type of function being 
plotted. I've implemented a check for VTK output for scalar elements, 
and I'll hopefully look at rank 1 functions soon. A number of demos were 
plotting and writing unsupported finite element types which leads to 
unpredictable results.

Garth

> 
> 
> ------------------------------------------------------------------------
> 
> _______________________________________________
> DOLFIN-dev mailing list
> [email-masked]
> http://www.fenics.org/mailman/listinfo/dolfin-dev

---

From: Ola Skavhaug <[email-masked]>
Date: Tue, 15 Jul 2008 11:46:51 +0200

> ok. This would be a very nice feature to have in Viper. Ola?

I've added it to the todo list. Let's wee what happens :)

Ola