Subject: [Viper-dev] Feature request - Plot of MeshFunction of facets

From: Johan Hake <[email-masked]>
Date: Wed, 14 Jan 2009 11:24:48 +0100

Hello!

Is it trivial to plot a MeshFunction over Facets? This would be very 
convinient.

I see now that only Meshfunctions over cells and vertices are supported, is 
this a problem with respect to VTK?

Johan

---

From: "Ola Skavhaug" <[email-masked]>
Date: Wed, 14 Jan 2009 15:30:59 +0100

> this a problem with respect to VTK?

Yes and no. I could make this work, but it a major extension of Viper.
Hence, the request is not given too high priority.

Ola

>
> Johan
> _______________________________________________
> Viper-dev mailing list
> [email-masked]
> http://fenics.org/mailman/listinfo/viper-dev
>

-- 
Ola Skavhaug

---

From: Johan Hake <[email-masked]>
Date: Wed, 14 Jan 2009 15:48:21 +0100

On Wednesday 14 January 2009 15:30:59 Ola Skavhaug wrote:
> > I see now that only Meshfunctions over cells and vertices are supported,
> > is this a problem with respect to VTK?
>

Ok. 

It would be a nice extension though, as plotting of face markers would be very 
convinient.

Johan

---

From: "Ola Skavhaug" <[email-masked]>
Date: Wed, 14 Jan 2009 16:13:36 +0100

> It would be a nice extension though, as plotting of face markers would be very

I know. Patches are welcome :)

This feature might be implemented in Viper 0.5, the new branch that is
a completely rewrite.

Ola

-- 
Ola Skavhaug

---

From: Johan Hake <[email-masked]>
Date: Wed, 14 Jan 2009 16:19:45 +0100

On Wednesday 14 January 2009 16:13:36 Ola Skavhaug wrote:
> >> > I see now that only Meshfunctions over cells and vertices are
> >> > supported, is this a problem with respect to VTK?
> >>
> > It would be a nice extension though, as plotting of face markers would be
> > very convinient.
> >
> > Johan
>

Of course! 

Any hints for where I should look? Some special VTK filters to trigger?

> This feature might be implemented in Viper 0.5, the new branch that is

Nice, so when is it due? The next version I mean.

Johan

---

From: "Ola Skavhaug" <[email-masked]>
Date: Wed, 14 Jan 2009 17:12:25 +0100

> Nice, so when is it due? The next version I mean.

We have not set a fixed date on this yet. The development is carried
forward by another project. However, the new version is already in a
more advanced state than the old viper.

-- 
Ola Skavhaug