Subject: [Viper-dev] [HG viper] Fix viper application to be able to plot double valued MeshFunctions.

From: [email-masked]
Date: Fri, 27 Mar 2009 15:21:40 +0100 (CET)

One or more new changesets pushed to the primary Viper repository.
A short summary of the last three changesets is included below.

changeset:   160:de8505d8cacc89737fd2711ca8ab233a186dd23f
tag:         tip
user:        "Ola Skavhaug <[email-masked]>"
date:        Fri Mar 27 15:25:53 2009 +0100
files:       src/bin/viper src/viper/viper.py
description:
Fix viper application to be able to plot double valued MeshFunctions.

changeset:   159:376741cf5dbf94ce6d45ac22f5ed984e9800fc7a
user:        "Johan Hake <[email-masked]>"
date:        Wed Mar 25 12:22:02 2009 +0100
files:       src/viper/viper_dolfin.py
description:
Small fix for plotting of dolfin.cpp.Functions that make plotting of
  ufl based dolfin.Functions work.

changeset:   158:db1810b3a64a7cde97e1ee121b357b4d42137a51
user:        "Ola Skavhaug <[email-masked]>"
date:        Wed Mar 25 11:11:07 2009 +0100
files:       src/viper/viper.py
description:
Use better video codec, and add keyword argument size (type two tuple) to set window size.

----------------------------------------------------------------------
For more details, visit http://www.fenics.org/hg/viper

---

From: Martin Sandve Alnæs <[email-masked]>
Date: Fri, 27 Mar 2009 18:20:08 +0100

> Fix viper application to be able to plot double valued MeshFunctions.

Does this include MeshFunctions over vertices, edges, and faces?

Could viper easily be made to plot point clouds?

When defining boundary conditions using the geometric mode,
it would be useful to visualize which dofs are marked and not.
If viper can plot point clouds using a format similar to
    [(coordinate, value), (coordinate, value), ...]
we could do that.

Martin

---

From: Ola Skavhaug <[email-masked]>
Date: Sun, 29 Mar 2009 15:59:35 +0200

> Does this include MeshFunctions over vertices, edges, and faces?

Only verices and cells at the moment, I think.

> Could viper easily be made to plot point clouds?

It is possible to plot spheres, but these get the same color.
Extending this should be simple.

>    [(coordinate, value), (coordinate, value), ...]

Good point. I'll try to fit this into my coding schedule.

Ola

> Martin
> _______________________________________________
> Viper-dev mailing list
> [email-masked]
> http://fenics.org/mailman/listinfo/viper-dev
>

-- 
Ola Skavhaug